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About the Brainware Intelligent Capture Update Guide

This guide provides information about updating Intelligent Capture products from a previous version to BIC
Foundation EP2.

Read this guide before you update Runtime Server machines, Verifier and Designer workstations, and Web
Verifier servers.

We recommend completing the update procedure in a development environment before updating a production
environment.

Note: This document does not provide information about upgrades from versions 1.3.x and 2.x. If you need
to upgrade from versions 1.3.x or 2.x, contact your Support representative.

Affected Workstations and Servers

The update affects the following workstations or servers.

o Runtime Server (RTS) machines
« Verifier workstations

« Development workstations

« Web Verifier servers

About Backward Compatibility with Other Hyland Applications

This version of BIC does not support file system storage. All BIC Foundation implementations require
database storage.

If you use the Brainware Capture scanning module with PIC 5.5 SP2 or earlier and you want to upgrade to BIC
Foundation EP2, you may keep using the older version of Capture on a separate machine and use the RTS
image import workflow step.

Capture is not available in this version of BIC and you cannot install or use it on the same machine.

Service Names

The installer deletes the Runtime Service and the System Monitoring service and recreates them with new
names when upgrading from version 5.8 or earlier.

Possible previous service names New service name
« IDC-distiller Runtime Service Manager Brainware Intelligent Capture Runtime Service
« Brainware Distiller Runtime Service Manager

Management Console
« Perceptive Intelligent Capture Runtime




Possible previous service names New service name

Service Manager

« IDC-distiller System Monitoring Brainware Intelligent Capture System Monitoring
« Brainware Distiller System Monitoring

« Perceptive Intelligent Capture System
Monitoring

Back Up all Data and Settings

To retain your unique customizations and back up your settings, consult your database administrator to create
a full database backup of the ORACLE or MS SQL Server database. Then, complete the following tasks.

Note: Archive the backup data in read-only format until BIC is running in a production environment. Neither
Hyland Software, Inc. nor any of its authorized resellers are responsible for lost data caused by any update
procedure described in this document.

« Back Up Runtime Server Settings

« Note the Runtime Service Manager Settings
« Back Up Project-Related Data

« Back Up the Application Files

o Back Up the License File

« Back Up the Configuration Files

o Back Up Permissions and Security Settings

Back Up Runtime Server Settings
To back up the RTS settings, complete the following steps.

Stop all Intelligent Capture services.

Launch Intelligent Capture Runtime Service Management Console.

In the DstAdmin window, in the left pane, right-click the top machine node and click Stop All.
Repeat the previous step for each machine.
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To export the settings, complete the following substeps.
1. Inthe left pane, right-click an instance and then click Export Settings.
2. Inthe Save As dialog box, navigate to your backup directory.

3. Inthe File name box, type a name that uniquely identifies the instance, and then click
Save.

Note: Use a combination of the RTS machine name and the instance name to
simplify re-importing.



4. Repeat the previous substeps for all instances on all machines.
6. Close Intelligent Capture Runtime Service Management Console.

Note the Runtime Service Manager Settings
To note the existing Runtime Service Manager settings for future reference, complete the following steps.

1. Launch Windows Services and stop the following services.
« Intelligent Capture Runtime Service Manager
« Intelligent Capture System Monitoring
2. Complete the following substeps.
1. Right-click Intelligent Capture Runtime Service Manager and then click Properties.

2. Inthe Intelligent Capture Runtime Service Manager Properties dialog box, on the
Log On tab, note the specified settings.

3. Repeat the previous steps for the Intelligent Capture System Monitoring service.
3. Launch the Task Manager.
4. If they are running, stop the DstHost.exe or DstMgr.exe tasks.

Back Up Project-Related Data

When you save a project in Intelligent Capture 5.7 or later, you cannot open it in an earlier version. To back up
all project-related data, complete the following steps.
1. Stop all Intelligent Capture services.
2. InWindows Explorer, navigate to the Intelligent Capture project directory.
3. Copy all of the following files to your backup directory.
o SDP project files
« Learn set directories and files
o ASSA pool files
« INIfiles
o SETfiles
« DVSfiles

« Any other project-related data, such as custom DLL files, scheduled tasks, or special
configurations

Note: For more information about your projects, see the project-related documentation.

4. |If the batch folder resides on the file system, copy the batch folder to your backup directory.

Back Up the Application Files
To back up the application files, complete the following steps.

1. Stop all Intelligent Capture services.
2. InWindows Explorer, navigate to the [Installation path] directory.



3. Optional. To reduce the size of the backup, delete any log files that you no longer need.
4. Copy all files to your backup directory.

Back Up the License File
To back up the license file, complete the following steps.

1. Stop all Intelligent Capture services.
2. Navigate to the [Installation path]\Components\Cairo directory.
3. Copy the license file to your backup directory.

Back Up the Configuration Files

Use the CONFIG backup files only as reference to review custom settings used in previous versions. Do not
copy any existing CONFIG files to the installation setup directory. Do not use any backed up CONFIG files
with the new version.

To back up the configuration files, complete the following steps.

1. Stop all Intelligent Capture services.
2. From the [Installation path]\bin directory, copy the following files to your backup directory.
« DstDsr.exe.config
« DstHost.exe.config
« DstSIm.exe.config
« DstWkBrw.exe.config
« DstVer.exe.config
o DstPmt.exe.config
« DstCoreSvc.exe.config (if available)

« Ifyourinstallation includes Web Verifier, from the [Installation pathj\Brainware
Intelligent Capture Web Server directory, copy the Web.config file to your backup
directory.

Back Up Permissions and Security Settings
To back up permissions and security settings, complete the following steps.

1. Stop all Intelligent Capture services.

2. Note the permissions and security settings of any shared directories that Intelligent Capture uses,
such as project data directories.

3. Ensure that the share names remain the same for any directories you move.



Upgrade to Brainware Intelligent Capture Foundation EP2

To upgrade to BIC Foundation EP2, review or complete the following tasks as necessary.

Prepare for the Update

Upgrade Intelligent Capture
« from versions 5.2 or earlier

o from versions 5.3 or later

Update the database schema
o SQL Server

o Oracle
Modify the Database Connection Strings
Convert Existing Project Files to the Current Version
Configure the Application Modules

Prepare for the Update

To prepare for the update, complete the following steps.

1.
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In the Learn Set Manager, complete all pending accumulated documents and migrate them into
the project.

Verify that no pending batch exports exist.
Verify that all users have logged out of the following programs.
o Designer
« Verifier
o Learn Set Manager
« Web Verifier
Stop all RTS instances.
Stop all Intelligent Capture services.
Stop Internet Information Services (IIS).
Stop all scheduled tasks and additional services related to BIC.
Optional. To specify the Help file locations, modify the SetupType.ini file.

Note: See “Help files” in the Brainware Intelligent Capture Installation and Setup Guide for
detailed steps and information.



About Documentation

The installer removes any existing Intelligent Capture documentation files when upgrading from version 5.6 or

earlier.

Upgrade from Version 5.2 or Earlier
To upgrade from version 5.2 or earlier, complete the following tasks.

1. Uninstall an Existing Version
2. Upgrade from version 5.2 or earlier

Uninstall an Existing Version
To upgrade from a version prior to 5.3, you must uninstall your existing version from all servers and

workstations.
To uninstall your version, complete the following steps.

1. On each server and workstation, complete the following substeps.
1. InWindows Programs and Features, uninstall the existing version.
2. Reboot the machine.
2. Oneach RTS machine, delete the following directories.
o [drive:\Windows\Temp\Bwe
o [drive:\Windows\Temp\DIST
o [drive:\Windows\Temp\CdrDbCache

Upgrade from Version 5.2 or Earlier

This topic provides a broad overview of the tasks you complete to upgrade to the latest BIC version.

See the Brainware Intelligent Capture Installation and Setup Guide for detailed steps and information.

Complete the following steps.

Install BIC Foundation EP2 with an attended or unattended installation.
If prompted, reboot the machine.

Replace the demo license file with the back-up license file.

Verify the installation of the components.
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Configure any shared and security customizations from previous installations against the
application directories.

6. If yourimplementation uses the file system, migrate the batches from the file system to the

database.

Upgrade from Version 5.3 or Later
To upgrade from version 5.3 or later, complete the following tasks.

1. Upgrade from version 5.3 or later
2. Upgrade to Kadmos 5 and FineReader 11
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3. Set Kadmos 5 as the Default Recognition Engine

Upgrade from Version 5.3 or Later

This topic provides a broad overview of the tasks you complete to upgrade to the latest BIC version.
See the Brainware Intelligent Capture Installation and Setup Guide for detailed steps and information.

Complete the following steps.

1.
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Run setup.exe and complete the following substeps.
1. Inthe Brainware Intelligent Capture Setup page, click Next.

2. Inthe License Agreement page, read and accept the End-User License Agreement
(EULA), and then click Next.

3. Inthe Setup page, select Repair and then click Next.
4. Click Finish.
Update the database schema.
Launch Designer and convert existing project files.
Restart all RTS instances.
Restart all BIC services.
Restart Internet Information Services (11S).
Restart all scheduled tasks and additional services related to BIC.

If your implementation uses the file system, migrate the batches from the file system to the
database.

Upgrade to Kadmos 5 and FineReader 11

If your current implementation does not include Kadmos 5 or FineReader 11, and you want to upgrade them,
you must rerun the installation process. BIC can work with existing projects that use FineReader 8.1.
However, we recommend that you upgrade to FineReader 11.

To upgrade to Kadmos 5, FineReader 11, or both, complete the following steps.

1.

2.
3.
4

o o

7.

Verify that the license file contains a Kadmos 5 and a FineReader 11 entry.
Run setup.exe.
In the Brainware Intelligent Capture Setup page, click Next.

In the License Agreement page, read and accept the End-User License Agreement (EULA), and
then click Next.

In the Setup page, select Modify and then click Next.
In the Feature Selection page, select Kadmos 5, FineReader 11, or both, and then click Next.
In the Icons on Desktop page, click Finish.

About the Kadmos 5 Server Add-On

To process documents for multiple users with multiple processors, a Kadmos 5 Server add-on is available.
For more information, see the Brainware Intelligent Capture Kadmos 5 Server Installation Guide.
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Set Kadmos 5 as the Default Recognition Engine

If you open a project that uses an obsolete OCR engine, such as Kadmos 4 or FineReader 8, BIC updates the
assigned engine.

To define Kadmos 5 as the default recognition engine, complete the following steps.

In Designer, switch to Definition Mode.
2. Inthe left pane, right-click <new project> and then click Show Properties.

3. Intheright pane, click OCR settings and then, in the OCR Properties dialog box, on the
Recoghnition tab, complete the following substeps.

1. Under Recognition Type, select OCR.
2. Under Available Engines, select Kadmos 5.
3. Select Use as default engine and then click OK.

About Projects Using the Recognita Barcode Engine
The Recognita Barcode Engine is no longer part of BIC.

If you open a project that previously used the Recognita Barcode Engine, BIC updates the project to the
QualitySoft Barcode Engine and transfers the existing bar code types if the QualitySoft Barcode Engine
supports these types.

About Projects Using the Recognita OCR Engine
The Recognita OCR Engine is no longer part of BIC.

If you open a project that previously used the Recognita OCR Engine, BIC updates the project to FineReader.

Update the SQL Server Database Schema

To update the database schema, complete the following steps.
Note: After the update, you cannot revert the database schema to an older version.

1. Launch the SQL Server Management Studio.
2. Logon using an account with administrator rights.

3. From the [drive:]\[setup directory]\FirstPart\Database\UpdateScripts\SQL Server directory,
execute the BRW_Upgrade_Database.sql script against the BIC database.

4. Review the Messages pane for errors.

Note: If there are errors, you can rerun the script as often as required.

Update the Oracle Database Schema

To update the Oracle database schema, complete the following steps.

Note: After the update, you cannot revert the database schema to an older version.
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1. Ensure that the BIC user has the appropriate permissions. For more information, see "Create the
database user" in the Brainware Intelligent Capture Installation Guide.

2. Toexecute the update script using SQL Developer, complete the following substeps.
1. Configure a connection for the BIC user.

2. From the [drive:]\[setup directory]\FirstPart\Database\UpdateScripts\Oracle
directory, open the BRW_Upgrade_Database.sql script.

3. Ensure that the connection is set to the BIC user and then execute the script.
3. Toexecute the update script using SQL Plus, complete the following substeps.
1. Start SQL Plus and connect to the database as the BIC user.

2. From the [drive:]\[setup directory]\FirstPart\Database\UpdateScripts\Oracle
directory, execute the BRW_Upgrade_Database.sql script.

4. Review the Messages pane for errors.

Note: If there are errors, you can run the script as often as required.

Revoke Oracle User Rights

After creating or updating the Oracle database, you can revoke some of the permissions from the BIC user
because they are no longer needed. Complete the following step.

« Revoke the permissions according to the following example.

REVOKE
CREATE TYPE,
CREATE INDEXTYPE,
CREATE PROCEDURE,
CREATE SEQUENCE,
CREATE SYNONYM,
CREATE PUBLIC SYNONYM,
CREATE TRIGGER

FROM BIC;

Modify the Database Connection Strings

To modify the database connection strings for all BIC components, except Web Verifier, complete the
following steps.

Note: To modify the database connection strings for Web Verifier, see the “Replace Web.config and
Brainware.System.Project.exe.config ” topic.

1. From the [Installation path]\Brainware Intelligent Capture\bin directory, open DstDsr.exe.config in
a text editor.

2. Search forthe <connectionStrings> element.
3. ForaSQL Server database, modify the following values.
« Set Data Source to the data source.



» SetInitial Catalog to the SQL Server database catalog.
« Set User ID to the SQL Server user ID.
« Set Password to the SQL Server password.
4. Foran ORACLE database, modify the following values.
« Set Data Source to the data source.
« Set User ID to the service account user ID.
« Set Password to the service account password.
5. Save and close the file.
6. Repeat the previous steps for the following configuration files.
« DstHost.exe.config
« DstSIm.exe.config
» DstVer.exe.config
« DstWkBrw.exe.config
« DstCoreSvc.exe.config
« DstPmt.exe.config
« Brainware.System.Project.config

Add the ASP.NET 4.x Role to IIS
To add the ASP.NET 4.x role to IS, complete the following steps.

In Server Manager, open the Add Roles and Features Wizard.
Inthe Add Roles and Features Wizard dialog box, click Next.

Select Role-based or feature-based installation and then click Next.
Select Select a server from the server pool and then click Next.
Open Web Server (IIS) > Web Server > Application Development.
Select ASP.NET 4.x and then click Next.

Click Next and then click Install.

Change the Application Pool .NET CLR Version to v4.0.30319
To change the application pool .NET CLR version to v4.0.30319, complete the following steps.
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1. Ininternet Information Server (IIS) Manager, open Sites, and then select the Web Verifier
application.

2. Intheright pane, click Basic Settings.

3. Inthe Edit Application dialog box, from the Application Pool field, note the pool name and then
click OK.

4. Inthe left pane, select Application Pools.

5. Inthe middle pane, right-click the Web Verifier application pool name and then click Basic
Settings.

6. Inthe Edit Application Pool dialog box, from the .NET CLR version list, select .NET CLR
Version v4.0.30319 and then click OK.



Replace Web.config and Brainware. System.Project.exe.config
If your installation includes Web Verifier, complete the following steps.

1. From your BIC setup directory, make a copy of the Web.config.Template file, name it
Web.config, and open it in a text editor.

2. Searchforthe <connectionStrings> element.
3. Fora SQL Server database, modify the following values.
« Set Data Source to the data source.
» SetInitial Catalog to the SQL Server database catalog.
« Set User ID to the service account user ID.
« Set Password to the service account password.
4. Foran ORACLE database, modify the following values.
« Set Data Source to the data source.
« Set User ID to the service account user ID.
« Set Password to the service account password.
5. Search forthe pathToProjectExe attribute and verify that the value corresponds to the location
of DstDsr.exe.

6. Compare all customized settings, such as formEvents, batchColumnsVisibility, and
appSettings with your back-up Web.config file and modify the values if required.

7. Save and close the file.
8. Copy the Web.config file to the following directories.
« [Installation path]\Brainware Intelligent Capture\bin
« [Installation path]\Brainware Intelligent Capture Web Server
9. Inthe [Installation path]\Brainware Intelligent Capture\bin directory, complete the following
substeps.
1. Rename the Brainware.System.Project.exe.config file to a new name to saveit as a
backup, or delete it.
2. Rename the Web.config file to Brainware.System.Project.exe.config.

Database Connection String Example for SQL Server

<connectionStrings>

<add name="Entities"
connectionString="metadata=res://*/Entity.Entities.csdl|res://*/Entity.Entiti
es.ssdl|res://*/Entity.Entities.msl; provider=System.Data.SqlClient;provider
connection string=&quot;Data Source=<DataSource>;Initial
Catalog=<SQLServerDatabaseCatalog>;Integrated Security=false;User
ID=<UserId>;Password=<UserPassword>;MultipleActiveResultSets=True&quot;"
providerName="System.Data.EntityClient" />

</connectionStrings>



Database Connection String Example for ORACLE

<connectionStrings>

<add name="Entities"
connectionString="metadata=res://*/Entity.ORAEntities.csdl|res://*/Entity.ORA
Entities.ssdl|res://*/Entity.ORAEntities.msl; provider=EFOracleProvider;
Provider Connection String='Data Source=<OracleServerName\InstanceName>;User
ID=<UserID>; Password=<UserPassword>'" providerName="System.Data.EntityClient"
/>

</connectionStrings>

Modify the .NET Configuration for ORACLE

If you use BIC with an ORACLE database, complete the following steps.
1. From <drive>:\WINDOWS\Microsoft. NE T\Framework\v4.0.30319\CONFIG, open
machine.config in a text editor.
2. Searchforthe <system.data> element.

3. Underthe <DbProviderFactories> element, verify or add the following element.
Provider for Oracle testing"

type="EFOracleProvider.EFOracleProviderFactory, EFOracleProvider,
Version=1.0.0.0, Culture=neutral, PublicKeyToken=def642f226e0e590b" />

Note: To copy this example as a single line, open this document in Acrobat Reader and copy
and paste the string from there.

4. Save and close thefile.

Convert Existing Project Files to the Current Version
You must convert project files created in an earlier version before you can use them.
To convert existing project files, complete the following steps.

1. In Designer, click File > Load Project.
2. Inthe Brainware Intelligent Capture — Load Project dialog box, select a project and click Open.

3. Inthe Brainware Intelligent Capture — Project Logon dialog box, log on with Administrator
credentials and then click OK.

Note: The fully automated conversion process may take a few minutes, depending on the
project size.

If prompted, confirm the error message about the missing FineReader 8.1 engine.
Verify if you need to modify the scripts.
To verify the settings, click Options > Settings.
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In the Settings dialog box, complete the following substeps.

1. Onthe Input Mode tab, verify that the required job name is selected or that the Batch
Root Directory points to the required batch directory.
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10.
1.
12.
13.
14.

15.

16.

17.

18.
19.

2. Onthe Train Mode tab, verify that the Learn Set Manager base directory points to the
required directory and then click OK.

Switchto Train Mode.
On the Options menu, clear Incremental Learning.

To rebuild the learn set under the current version, on the Toolbar, click Learn documents -“@‘-
Switch to Definition Mode.

the left pane, on the Classes tab, right-click the project and then click Show Properties.

In the right pane, on the Project tab, click OCR settings.

Inthe OCR Properties dialog box, complete the following substeps.

1. Onthe Recognition tab, under Available Engines, verify that FineReader 11 is
selected.

2. Verify the settings on the different tabs.

BIC now provides the possibility to perform a combined OCR for Korean and English in one
selection. If your project uses Korean and English, in the OCR Properties dialog box, complete the
following substeps.

1. Onthe Languages tab, under Used, remove English and Korean.

2. Under Installed, select Korean+English, click "~ and then click OK.

Upgraded projects may have correlation enabled for table fields. To review and disable this setting
if not applicable for this project, complete the following substep.

« In Definition Mode, open the properties of all table fields and clear the correlation option
on the Advanced tab of the Analysis pane.

For local projects, complete the following substeps.

1. Click Options > Users, Groups and Roles.

2. Onthe Users tab, select Allow Database Authentication and then click OK.
Click File > Save Project.
Repeat the previous steps for each project.

About Custom DLLs

Custom DLLs may have to be updated to remain valid with the current BIC version.

Configure the Application Modules

After the update you configure the application modules. Complete the following tasks.

Configure RTS Settings on a Server
Verify Verifier settings

Verify Web Verifier settings on the server
Verify Web Verifier on a client
Re-Register the COM Components
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Configure RTS Settings on a Server

To configure the RTS settings on a server, complete the following steps.

1.

In Windows Services, complete the following substeps

1. Right-click Brainware Intelligent Capture Runtime Service Manager and then click
Properties

2. Inthe Brainware Intelligent Capture Runtime Service Manager Properties dialog
box, on the Log On tab, change the settings according to those used in the previous
version.

3. Repeat the previous steps for the Brainware Intelligent Capture System Monitoring
service.

4. Start the Brainware Intelligent Capture Runtime Service Manager service.

2. InBrainware Intelligent Capture Runtime Service Management Console, create the RTS
group and the RTS machines using the same names than in the previous installation.
Note: Refer to your backed up SET files to review the previously used names.

3. Verify that the licensing machine uses the correct license file.

4. Complete the following substeps.
1. Inthe left pane, right-click one of the instances and then click Import Settings.
2. Inthe Open dialog box, select the corresponding SET files and then click Open.
3. Repeat the previous steps for each instance.

5. Verify that the batch list displays for each instance.

6. Verify that no errors display in the Statistics view.

7. To verify the configuration, process a single document from import to export.

Verify Verifier Settings

To verify the Verifier settings on a server or client, complete the following steps.

1.
2.
3.

4.
5.

Copy the backed up Verifier settings file to the required location.
To launch Verifier, double-click the settings file.

In the Brainware Intelligent Capture — Project Logon dialog box, log on with Administrator
credentials and then click OK.

Verify that the batch list displays.
Verify a batch to completion to ensure that no errors occur.

Verify Web Verifier Settings on the Server

To verify the Web Verifier settings on the server, complete the following steps.

1

2
3.
4

On the BIC Web server, in IS Manager, start the Web Verifier application.
Run iisreset as an administratorina Command Prompt window.

Open aweb browser and delete all local cache information.

Log on to Web Verifier.
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5. Click Help > About Brainware Intelligent Capture Web Verifier and verify the license file.
6. Verify a batch to completion to ensure that no errors occur.

Verify Web Verifier on a Client
To verify Web Verifier on a client, complete the following steps.

1. Open aweb browser and delete all local cache information.
2. LogontoWeb Verifier.
3. Verify a batch to completion to ensure that no errors occur.

Re-Register the COM Components
To re-register the COM components, complete the following steps.

1. Inthe [Installation path]\Brainware Intelligent Capture Web Server\Bin directory, run Register Web
Server.bat as administrator.

2. Inthe [Installation path]\Brainware Intelligent Capture Web Server\Bin directory, open Register
Web Server.log in a text editor and check the file for errors.

Review Scripts
To check if your scripts require modifications, review the following topics.

1. About the Properties Filename and DocFileName
2. About the Original File Name of a Page
3. About Cutting and Appending Documents

About the Properties Filename and DocFileName

The Workdoc. Filename property now contains the workdoc’s database ID and name instead of the image
file name from which the workdoc was created.

To retrieve the image file name from which BIC created the workdoc, use the Workdoc . DocFileName
property.

Ensure to modify your projects custom script accordingly.

About the Original File Name of a Page

The stapling process retumns a single multipage-document referenced by the associated workdoc.

Using the pWworkdoc.DocFileName (x) with anindex greater than 0 results in an index-out-of-range error.

To retrieve the original file name of a page, use the pWworkdoc. Pages
(x) .OriginalDocumentFileName property.

About Cutting and Appending Documents
The process for cutting and appending documents has changed.

Always use the pWorkdoc.DocFileCount property after appending and cutting operations to determine
the number of documents.
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Migrate Batches from the File System to the Database

If the RTS instance points to file system batches, you must migrate those batches to the database.
To migrate a file system batch to the database, you need to perform the migration steps for each state within
the batch starting with the lowest batch state. BIC creates a single batch for each state. If a file system batch
contains documents at two different states, BIC splits this batch into two different batches in the database.
To migrate the batches to the database, complete the following steps.

1. Back up the file system batches.

2. Launch Brainware Intelligent Capture Runtime Service Management Console.

3. Inthe DstAdmin window, in the left pane, right-click the RTS instance that points to a file system
batch and then click Properties.

4. Inthe Brainware Intelligent Capture Runtime Service Properties dialog box, on the Workflow
tab, complete the following substeps.

1. Enable the Database Export process step.
2. Disable all other process steps and then click OK.
5. Inthe DstAdmin window, in the left pane, right-click the RTS instance and then click Properties.

6. Inthe Brainware Intelligent Capture Runtime Service Properties dialog box, on the General
tab, under Directories, create a new job or select an existing one.

7. Complete the following substeps.

1. Inthe Brainware Intelligent Capture Runtime Service Properties dialog box, on the
Workflow tab, select the lowest batch state as Input State for Database Export.

Note: Explore your batch list to determine the lowest state.

2. Define separate states different from the existing default output states as Output State
for Database Export, and then click OK.

Note: Verify that the failed state is lower than the succeeded state.

3. Right-click the instance and then click Start.
4. Repeat the previous steps for all remaining states in your batch list.

About Batches Exported from the Database

When performing a database export from the Runtime Server, BIC creates a new ID for the exported batches,
such as 00001770_00000016. The left part of this ID represents the database ID while the right part
represents the previous file system batch ID.

This affects only the batches exported from the file system and is required to keep the string ID unique. If you
import the batches directly into the database, the string ID consists of the reference to the database ID.



Find Exported Batches

If a case in the file system has two different states, BIC creates two different database batches.
To find the batches created from the original single batch, complete the following step.

« Inthe DstAdmin window, in the right pane, in the Where box, type batch.name like ‘%
[xx]’ and then click Request.

Example If you want to display all documents for batch 16, type batch.name like ‘% 16'.

Note: The RTS instance that points to a file system batch still shows the original number of
documents even if a part of the documents was already exported. The exported documents are
still part of the batch. However, after export they have a higher state according to the output
state you defined for database export.

About Transliteration Differences
Transliteration is an advanced feature not commonly used in projects.

PIC 5.5 SP1 and SP2 incorrectly transliterate text in extended languages, such as Russian or Thai, when the
project has the "Use multi-byte encoding" setting enabled. Projects using transliteration built in PIC 5.5 SP1
or SP2 may require a correction to utilize the correct transliterated texts in later versions.

Example

« InPIC 5.5 SP1 and SP2, the Russian word for “Invoice” incorrectly transliterates to "Sqet".
« InPIC 5.3, 5.4, and 5.5 SP3, the word correctly transliterates to "SChET".
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