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Introduction

Hyland DataTransfer is a data matching, review and upload solution that allows you to automatically
verify, clean up, and enter data extracted from hand-printed paper forms, downloadable web forms, and
almost any other electronic source.

You can quickly and accurately upload information into your database, such as online and paper
applications, recruit cards, SAT scores, ACT scores, GRE scores, and AP scores without the risk of
creating duplicate student records.

With Hyland DataTransfer, you can:

e Import a nearly unlimited range of data files.

e Match input data to records in your database.

e Review potentially matching records side-by-side.

¢ Upload new or modified information in real-time into your database.

You can customize Hyland DataTransfer to upload any type of data from any information source in the
Hyland DataTransfer source code.

Refer to the following topics for more information.

e Security Recommendations

e Starting and Logging in to Hyland DataTransfer

e Understanding the Desktop and Tablet Interfaces

e Changing Roles

e Changing Workspace Versions

e Specifying Preferences

e Understanding User Roles and Privileges

e Overview of Hyland DataTransfer Administrative Tasks
e Viewing Server Logs

e Configuring PDF to TIFF Properties

Security Recommendations

The following recommendations are for security.

e End user authentication
Only system administrators have access to Hyland DataTransfer application. Regular end-users
are not allowed to access the application.

¢ Restricted Access
Hyland DataTransfer Web Application is accessible only as a localhost or comparable (from the
same private network it is installed on along with the production database). This is to restrict
access only to Administrator with access to this private network. No access outside of the private
network is allowed.
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o Database user-account restrictions
Connections from Hyland DataTransfer backend to production Database must use a dedicated
Database user-account. The account must be restricted to use minimum necessary tables
required.

o Dedicated Service to use Database
Only the dedicated admin-facing service (used by Administrator) can access the SQL queries
table using its dedicated Database user account.

e Private Network Ul Restriction
The System Administrator must ensure that application’s Ul is only accessible on private network
to prevent external attackers from reaching the vulnerable screen.

Starting and Logging in to Hyland DataTransfer
To start and log in to Hyland DataTransfer, complete the following steps.
1. Start the application by doing one of the following:

e Open a web browser and type the Hyland DataTransfer location into the browser address bar.
For example, type an address such as http://servername:8080/DataTransfer.

e On desktop computers, open the Hyland DataTransfer location by selecting File > Open from the
browser menu and provide the location.
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e Ondesktop computers, double-click the Hyland DataTransfer shortcuticon, or (in Microsoft
Windows) right-click it and click Open, or (in Apple Mac and Linux) control-click itand click
Open.

By default, there is no shortcut icon. On desktop computers, you can create a desktop shortcut,
or, for tablets, phones, and desktop computers, you can bookmark the startup page to quickly
access it when you subsequently log in to the application.

The log in screen appears.

2. When you log into Hyland DataTransfer for the first time, you are prompted to accept the End User
License Agreement (EULA). Click Accept to accept the agreement. When you accept the agreement
for your username, it is also accepted for all other roles to which you belong; if you switch to another
Role, you do not have to accept the EULA again. If you click Decline, you are redirected to the log in
screen.

3. Type your username and password in the Username and Password fields. Your username and
password are usually the same as those you use to log in to your administrative system.

Note: If there are issues starting Hyland DataTransfer or entering data in the login screen, contact
your Hyland DataTransfer system administrator for assistance in establishing the necessary
connection rights and privileges.

4. Click Log in. Depending on your login state, you will see either of the following.

e If you are logging into a workspace version in Edit mode and another user is logged into that
version of the workspace, you receive a prompt that the Sportinversion is locked by another
user.

e You are logged in to Hyland DataTransfer, and the application starts.

e You are logged in to Hyland DataTransfer with your default user role and workspace version in
which you are working. Specific product functions and features are available depending on
your role and on the workspace version in which you are working.

Note: After 25 minutes of inactivity, you are prompted that you will be logged out within five minutes
of further inactivity.

Understanding the Desktop and Tablet Interfaces

Hyland DataTransfer displays the desktop view when you use the application on desktop computers; it
displays the tablet view when you use it on tablets and on phones with larger resolutions. The layout
differs slightly between the interfaces, and not all features are available for the tablet view.

The Job Dashboard displays all jobs that are configured for Hyland DataTransfer and allows users to run
jobs in batch mode.

The Hyland DataTransfer toolbar provides access to Hyland DataTransfer features. Refer to the following
table for a description of the toolbar menu options.

Element Description
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Element Description
Help button Contains the following options.
¢ Open Admin Guide: Provides access to the administrator guide.
¢ Open User's Guide: Provides access to the user guide.
¢ About DataTransfer: Provides information about Hyland DataTransfer.
e Licensing: Provides licensing information.
Jobs button Contains the following options.
¢ Add Job: Allows you to add jobs.
¢ Recurring Jobs: Allows you to add recurring jobs.
Refer to Configuring Jobs and Processing Records.
Tools Contains the following options.
¢ Lookup: Allows you to configure the lookup tool.
¢ Check Names: Allows you to configure the check names tool.
e Data Exports: Allows you to configure data exports.
e Logs: Allows you to view log messages about jobs.
e Import History: Allows you to view details about workspace imports.
Refer to Using Hyland DataTransfer Tools.
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Element Description
Configuration Contains the following options:

¢ Connections: Allows you to configure database connections. Refer to
Configuring connection groups and database connectors.

¢ File sources: Allows you to configure servers or SFTP sites that contain the input
file used for recurring jobs. Refer to Configuring File Sources.

¢ Procedures: Allows you to configure procedures. Refer to Configuring
Procedures.

¢ Headers: Allows you to configure headers. Refer to Configuring headers.

¢ Forms: Allows you to configure forms. Refer to Configuring Forms.

¢ Notifications: Allows you to configure notifications to be sent when various
activities occur. For more information, refer to Configuring Notifications.

* ImageNow: Allows you to configure ImageNow index maps. For more
information, refer to Configuring ImageNow Index Maps.

e Data Providers: Allows you to configure data providers. Refer to
Configuring data providers.

e Document Templates: Allows you to create document templates to be used in
NQL code. For more information, refer to Configuring Document Templates.

e Variable Maps: Allows you to create variable mappings to map variables to
labels and default values. For more information, refer to Configuring Variable
Maps.

« EDI formats: Allows you to create EDI formats. Refer to Configuring EDI
formats.

Reports Contain the following options.

¢ Configure: Allows you to configure reports.

e Schedule: Allows you to configure scheduled reports.

¢ View: Allows you to view reports.

For more information, refer to Configuring Reports.

19



Hyland DataTransfer Administrator Guide

Element

Description

Preferences

Allows you to configure Hyland DataTransfer preferences; it contains the following
options.

¢  Set Default Role: Sets the current user’s role as the default role.

¢ Set Default Version: Sets the workspace version of the current user as the default
version.

¢ Record Grid Dimensions: Specifies the number of rows and columns per page
to display for records returned by a job.

* Filename in Job Name: Appends the filename of the input file to the name of a
job when you add jobs.

e Verify before running job: Confirms that you want to run the job.

¢ Display All Match Results: When jobs are run in interactive mode, all possible
record matches are compiled before the application pauses to allow you to
review the possible matches.

e Skip Previous Results: Prevents possible match records from being displayed
twice.

Refer to Specifying Preferences.

Administration

Contains the following options.
¢ Workspace: Allows you to configure workspaces. Refer to Changing

Workspace Versions.

e User: Allows you to configure user and administrator privileges. Refer to
Configuring Users and Privileges.

e Share Groups: Allows you to configure share groups, which you use to share
workspaces and workspace objects. Refer to Changing Workspace Versions.

e Server Logs: Allows you to view server logs. Refer to Viewing Server Logs.

e Archive: Allows you to configure rules for archiving jobs. Refer to
Configuring Jobs and Processing Records.

e  System Properties: Contains the following options.

o  System Email: Allows you to configure the SMTP server from which email
notifications are sent. For more information, refer to Configuring
Notifications.

o  PDF to TIFF: Allows you to configure properties for PDF to TIFF file
conversion. For more information, refer to Configuring PDF to TIFF
Properties.

Role drop-down box

Allows you to change the role into which you are logged into Hyland DataTransfer.
Refer to Changing Roles.

Workspace drop-down
box

Allows you to change the workspace version that you are using. Refer to Changing
Workspace Versions.

Logout button

Logs you out of the application.
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If you are logging into Hyland DataTransfer using phones with smaller screens and resolutions, the
mobile Job Dashboard is displayed; the exact design varies among devices, but the layout and
functionality remain the same. For more information about working with jobs, refer to Configuring Jobs
and Processing Records.

Sorting Columns

For Hyland DataTransfer dialog boxes or windows that contain tables of information, you can choose the
columns of information you want to view or hide, sort information alphabetically, and resize the width of
columns.

To select the columns that display and to sort columns, complete the following steps.

In the dialog box, point your mouse to the edge of a column and click * .

Click Sort Ascending to sort information alphabetically in a high to low sequence (A to Z).
Click Sort Descending to sort information alphabetically in a low to high sequence (Z to A).

Click Columns.

o~ 0N =

Check the check box for the column you want to display.

Resizing Columns

To resize the width of a column, point your mouse over the edge of a column until the mouse pointer
changes to i ; then, drag and drop your mouse to the desired location to resize the column.

Expanding Panes

You can collapse and expand some panes. For panes on the right side of the application window, click '**
to collapse the pane click «|to expand a collapsed pane; for panes on the left side of the application
window, click [« | to collapse the pane and '**/ to expand the pane.

Refreshing Information

To refresh information in dialog boxes and application windows, click "=
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Changing Roles

Perform one of the following actions.

If you are using the desktop version of Hyland DataTransfer, from the Role drop-down box, select the
Hyland DataTransfer role you want to use.

If you are using the mobile version of Hyland DataTransfer, select Settings > Role, and then select
the role you want to use.

Changing Workspace Versions

Perform one of the following actions.

If you are using the desktop version of Hyland DataTransfer, from the Workspace drop-down box,
select the version you want to use.

When you hover your mouse over a version in the drop-down box, a tooltip appears and displays the
version description for the version.

If you are using the mobile version of Hyland DataTransfer, select Settings > Version, and then select
the version you want to use.

Specifying Preferences

Perform one of the following actions.

Click Preferences > Set Default Role to set the current user’s role as the default role. When you log
in to Hyland DataTransfer, you are logged in using this user role.

Click Preferences > Set Default Version to set the workspace version of the current user as the
default version. When you log in to Hyland DataTransfer, you are logged in using this workspace
version.

Click Preferences > Record Grid Dimensions to specify the number of rows and columns per page
to display for records when you open a job.

The Record Grid Dimensions dialog box appears. In the Columns Per Page field, type the number
of columns to display; in the Rows Per Page field, type the number of rows to display. The default
value for each field is 20. The minimum value you can use is 10, and the maximum is 700.

Click Preferences > Filename in Job Name to append the filename of the input file to the name of a
job when you add jobs. For more information about jobs, refer to Configuring Jobs and Processing
Records.

Click Display All Match Results so that when you run jobs in interactive mode, all possible record
matches are compiled before the application pauses to allow you to review the possible matches.

Typically, for jobs running in interactive mode, each match routine in the associated procedures
contains a STOP command that pauses job processing, allowing the user to examine the list of
possible matches for that match routine. When you set this preference, the STOP command is
skipped, and each match routine will run, adding matches to the list of possible matches. If a match
routine finds a possible match that is already in the match list, the routine skips the match; the final
match list does not contain any duplicates.
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In addition, the match results also have an associated rank that is displayed in the results panel, in
the # column. The rank is set by the STORE command in each match routine and indicates which
match routine found the match. The result list is ordered by ranking—the order in which the match
routine discovers the matches.

e Click Verify Before Running Job to confirm that you want to run a job. When this option is enabled,
when you click Run, the Confirm Run dialog box appears and prompts you to confirm that you want
to run the job.

o Click Skip Previous Results so that the same possible match record is not displayed twice. For
example, when you start processing a record, you receive a list of possible matches, one of which is
John Doe. If none of the matches are correct, you click the Get More Results button and receive the
next possible set of matches. However, if the next set of matches contains John Doe again, Hyland
DataTransfer does not display John Doe as a possible match.

Understanding User Roles and Privileges
Your user role and privileges determine what you can do with Hyland DataTransfer.

The workspace version in which you are working and whether workspaces are shared also determine
what you can do. For example, you cannot configure objects, such as data exports, if you are working in a
workspace version in staged or active mode.

For more information about configuring roles and privileges, refer to Configuring Users and Privileges.
Administrator privileges determine if you can perform the following actions.
e Add, configure, and delete users.
e Configure system properties.
e Add, configure, and delete share groups.
e View server logs.
e Add, modify, and delete archive rules.
o View workspace details.
¢ Modify workspace details.
e Use workspace version control.
e Create new versions in edit mode.
e Move versions to test mode
e Move versions to staged mode.
e Move versions to active mode.
o Work with objects within the workspace.
e Add shared objects.
¢ Modify shared objects.
¢ Add, modify, and delete file sources.
e Add, modify, and delete connection groups.

e Add, modify, and delete connections.
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Add, modify, and delete headers.

Add, modify, and delete verification forms.

Add, modify, and delete ImageNow index maps.
Add, modify, and delete data providers.

Add, modify, and delete document templates.
Add, modify, and delete procedures.

o Configure Match logic.

¢ Configure Review logic.

e Configure Upload logic.

e Configure Match Display logic.

e Configure Population Selection logic.

User privileges determine if you can perform the following actions.

Configure the lookup tool.

Configure the check name tool.

View data exports.

Modify data exports.

Run data exports.

Export lookups, check names, data exports, log messages, and reports.
Import workspace versions.

Run reports.

Modify reports.

Modify scheduled reports.

View report output.

Delete report output.

Work within a workspace version.

e Work within a version in edit mode.

¢ Work within a version in test mode.

e Work within a version in staged mode.
e Work within a version in active mode.
e Work within a version in inactive mode.
Configure jobs.

e Create new and recurring jobs.

e Modify recurring jobs.
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e Enable logging of job messages.

e Enable job hold status.

e View archive rules for jobs.

e Create new records.

e Create matched records.

e Suspend records.

Create notification groups.

Modify notification groups.

Work within a specific workspace and with specific workspace objects.

Configure file sources.

Overview of Hyland DataTransfer Administrative Tasks

When you configure and administer Hyland DataTransfer, you generally perform the following steps in this

order.

1. Define and create the structure of your institution and give privileges for administrators and users to
access the appropriate Hyland DataTransfer features.

2. Configure a workspace in which to work. Workspaces can be private or can be used to share objects,
such as headers and procedures, to reuse them across multiple configurations.

3. Configure the logic that Hyland DataTransfer uses to determine if there is a potential match between
a database record and the input data and to determine how information is added or uploaded.

4. Determine the type of input data that you will be loading. For example, if you are loading SAT scores
contained in a CSV file, you are importing a delimited file.

5. Create the header. The header defines the input source. For example, if you are importing a delimited
file, you configure the header to use the delimited file format for the input file.

6. Configure header variables. These variables define the fields to be loaded from the input file; you
determine the names and positions of the fields and associate them with a header variable.

7. Create the verification form, which is used to compare an existing record of information with
potentially matching information from the input file, side-by-side.

8. Configure jobs, which consist of all information required to process records.
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Viewing Server Logs

You can view a list of server log messages, view the contents of each message, and download messages
in either.zip or native format.

1.

Select Administration > Server Logs.

A dialog box appears and displays the following columns of information.

File Name: Name of the server log file.
Size: Size, in Kb, of the log file.

Last Modified: Date and time on which the file was last modified.

To view the contents of a file, select the file you want to view. To select multiple files:

Click a file and press and hold the Ctrl key as you click each file with your mouse.
Click a file and press and hold the Shift key as you click another file to select contiguous files.

Either right-click the file you want to view and select View or select the file and click = The
contents of each file opens in a separate tab.

To download the file in ZIP format, select the file you want to download. To select multiple files:

Click a file and press and hold the Ctrl key as you click each file with your mouse.
Click a file and press and hold the Shift key as you click another file to select contiguous files.
Either right-click the file and select Download as Zip or select the file and click -"l ; then, select

the location where you want to save the file. When you download multiple files, one ZIP file is
created that contains all the log files you selected.

To download the file in the application format in which it was authored, select the file you want to
download. To select multiple files:

Click a file and press and hold the Ctrl key as you click each file with your mouse.
Click a file and press and hold the Shift key as you click another file to select contiguous files.

Either right-click the file and select Download Native or select the file and click = ; then, select
the location where you want to save the file.

5. To refresh the table of log files, either right-click the table and select Refresh or click “=.

Configuring PDF to TIFF Properties

You can configure the properties to use when you use the ImageNowAddDoc or
NWAddDoc functions to convert a PDF file to a TIFF file. For more information about
these functions, refer to Understanding the ImageNowAddDoc function and
Understanding the NWAddDoc function.

To configure properties, complete the following steps.

Select Administration > PDF to TIFF.

The Configure PDF to TIFF Properties dialog box appears.

In the TIFF DPI field, type the DPI value. Values range from 72 to 720; the default value is 240.

1.

2.
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3. From the TIFF Color drop-down box, select the color properties. Options are: Full Color, Gray Scale,
and Black & White. The default value is Full Color.

4. From the Compression Type drop-down box, select the compression type. Options are: CCITT_RLE,
CCITT_T 4, CCITT_T_6, PACKBITS, JPEG, and LZW. The default value is JPEG.

You can click Reset to reset all values in the dialog box to use the default values.

6. Click OK to save your changes and close the dialog box.

Configuring Users and Privileges

When you configure Hyland DataTransfer users, you define the structure of the institution and configure
privileges for users to enable or disable the features they can use.

Configuring Institutions
Refer to the following topics for more information.
e Configuring Organizations
e Configuring Divisions
e Configuring Departments
e Configuring Roles

e Configuring Users

Configuring Organizations
Refer to these topics for more information.
e Adding Organizations

e Renaming Organizations

e Deleting Organizations

Adding Organizations
To add an organization, complete the following steps.
1. Select Administration > User.
2. Inthe User Administration dialog box, in the Navigation pane, perform one of the following actions.
¢ In desktop view, right-click Enterprise Hierarchy and select Add Organization from the popup
menu.
e In tablet view, click *=
In the Add Organization dialog box, type the name of the organization.
Click OK. The organization is created and appears in Navigation > Enterprise Hierarchy.

Add a division under the organization. Refer to Adding Divisions for more information.
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Renaming Organizations

To rename an organization, complete the following steps.

1. Select Administration > User.

2. Inthe User Administration dialog box, in the Navigation pane, perform one of the following actions.
¢ In desktop view, right-click the organization and select Rename Organization_Name from the

popup menu.

¢ In tablet view, select the organization and click =l

3. Inthe Rename Node dialog box, type the name of the organization.

4. Click OK.

The organization is renamed.

Deleting Organizations

Note: You can delete only the lowest-level node in the hierarchy tree. For example, if you want to delete a
department that has roles and users configured for it, you must first delete all users, and next all roles,
before you can delete the department.

To delete an organization, complete the following steps.
1.  Select Administration > User.

2. Inthe User Administration dialog box, in the Navigation pane, perform one of the following
actions. .

¢ In desktop view, right-click the organization and select Delete Organization_Name from the
popup menu.
¢ In tablet view, select the organization and click L
3. In the dialog box, click Yes to delete the organization.

The organization is deleted, and it is removed from the Navigation pane.

Configuring Divisions

Refer to these topics for more information:
e Adding Divisions

e Renaming Divisions

e Deleting Divisions

Adding Divisions

To add a division, complete the following steps.

1. Select Adminsitration > User.

2. In the User Administration dialog box, in the Navigation pane, perform one of the following actions.

¢ In the desktop view, right-click the organization for which you want to add a division and select
Add Division from the popup menu.
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¢ In the tablet view, select the organization for which you want to add a division click T
In the Add Division dialog box, type the name of the division (for example, Finance).
Click OK. The division is created and appears in Navigation > Enterprise Hierarchy.

Add a department under the division. Refer to Adding Departments for more information.

Renaming Divisions

To rename a division, complete the following steps.

1.
2.

3.
4.

Select Administration > User.

In the User Administration dialog box, in the Navigation pane, perform one of the following actions
to display the Rename Node dialog box.

e In desktop view, right-click the division and select Rename Division_Name from the popup
menu.

e In tablet view, select the division and click =L
Type the name of the division.
Click OK.

The division is renamed.

Deleting Divisions

Note: You can delete only the lowest-level node in the hierarchy tree. For example, if you want to delete a
department that has roles and users configured for it, you must first delete all users, and next all roles,
before you can delete the department.

To delete a division, complete the following steps.

1.
2.

3.

Select Administration > User.
In the User Administration dialog box, in the Navigation pane, perform one of the following actions.

¢ In desktop view, right-click the division and select Delete Division_Name from the popup menu.

e In tablet view, click "= .

In the dialog box, click Yes to delete the division.

The division is deleted, and it is removed from the Navigation pane.

Configuring Departments

Refer to these topics for more information:

Adding Departments
Renaming Departments

Deleting Departments
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Adding Departments

To add a department, complete the following steps.

1.
2.

6.

Select Administration > User.

In the User Administration dialog box, in the Navigation pane, perform one of the following actions.

¢ In desktop view, right-click the division for which you want to add a department and select Add
Department from the popup menu.

¢ In tablet view, select the division for which you want to add a department and click L . The
Add Department dialog box appears.

Type the name of the department (for example, Accounts Payable).

Click OK to create the department, which appears in the Navigation pane.

You can configure department privileges, which specify the tasks that the department can perform.
When you configure privileges at the department level, these privileges are also applied to the users
and roles that belong to the department. For more information, refer to Configuring Privileges.

Add a role under the department. Refer to Adding Roles for more information.

Renaming Departments

To rename a department, complete the following steps.

1.
2.

3.
4.

Select Administration > User.

In the User Administration dialog box, in the Navigation pane, perform one of the following actions.

¢ In desktop view, right-click the department and select Rename Department_Name from the
popup menu.

e In tablet view, select the department and click =I .
In the Rename Node dialog box, type the name of the department.
Click OK.

The department is renamed.

Deleting Departments

Note: You can delete only the lowest-level node in the hierarchy tree. For example, if you want to delete a
department that has roles and users configured for it, you must first delete all users, and next all roles,
before you can delete the department.

To delete a department, complete the following steps.

1.
2.

3.

Select Administration > User.

In the User Administration dialog box, in the Navigation pane, perform one of the following actions.

¢ In desktop view, right-click the department and select Delete Department_Name from the popup
menu.

o In tablet view, select the department and click I .

In the dialog box, click Yes to delete the department.
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The department is deleted, and it is removed from the Navigation pane.

Configuring Roles

Refer to these topics for more information.
e Adding Roles

e Renaming Roles.

e Deleting Roles

Adding Roles

To add a role, complete the following steps.

1. Select Administration > User.

2. In the User Administrator dialog box, in the Navigation pane, perform one of the following actions.
e In desktop view, right-click the department for which you want to add a role and select Add

Department Role from the popup menu.

¢ In tablet view, select the department for which you want to add a role and click &
Type the name of the role (for example, Clerk).

4. Click OK. The role is created and appears in Navigation > Enterprise Hierarchy.

You can configure role privileges, which specify the tasks that the role can perform. When you
configure privileges at the role level, these privileges are also applied to the users that belong to the
role. For more information, refer to Configuring Privileges.

Note: You can assign permissions for a workspace and workspace permissions at the role level only.

6. Add a user under the role. Refer to Adding Users for more information.

Renaming Roles

To rename a role, complete the following steps.

1. Select Administration > User.

2. Inthe User Administration dialog box, in the Navigation pane, perform one of the following actions.

e In desktop view, right-click the role and select Rename Role_Name from the popup menu.

e In tablet view, select the role and click =l
3. Inthe Rename Node dialog box, type the name of the role.
4. Click OK.

The role is renamed.
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Deleting Roles

Note: You can delete only the lowest-level node in the hierarchy tree. For example, if you want to delete a
department that has roles and users configured for it, you must first delete all users, and next all roles,
before you can delete the department.

To delete a role, complete the following steps.
1. Select Administration > User.
2. In the User Administration dialog box, in the Navigation pane, perform one of the following actions.

¢ In desktop view, right-click the role and select Delete Role_Name from the popup menu.

¢ In tablet view, select the role and click &
3. In the dialog box, to delete the role, click Yes.

The role is deleted and removed from Navigation > Enterprise Hierarchy.

Configuring Users

Refer to these topics for more information.
e Adding Users

e Setting Default Roles

o Deleting Users

Adding Users

To add a user, complete the following steps.
1. Select Administration > User.
2. Inthe User Administration dialog box, in the Navigation pane, perform one of the following actions.
e In desktop view, right-click the role for which you want to add a user and select Add User from
the popup menu.
¢ In tablet view, select the role for which you want to add a user and click & . The Add User
dialog box appears.
In the Add User dialog box, type the name of the user.
4. Click OK. The user is added and appears in the Navigation > Enterprise Hierarchy.

You can configure user privileges, which specify the tasks that the user can perform. For more
information, refer to Configuring Privileges.
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Setting Default Roles

You can set a user’s role as the default role, if it is not already configured as the default role. Users are
logged in to Hyland DataTransfer with their default role.

1. Select Administration > User.

2. Inthe User Administrator dialog box, in the Navigation pane, navigate to the user for which you
want to set the default role and ;perform one of the following actions.

¢ In desktop view, right-click the role and select Set Default from the popup menu

e In tablet view, select the role and click Ev‘ .

The user role is set as the default.

Deleting Users

To delete a user, complete the following steps.

1. Select Administration > User.

2. In the User Administration dialog box, in the Navigation pane, perform one of the following actions.

¢ In desktop view, right-click the user and select Delete User_Name from the popup menu.

¢ In tablet view, select the user and click & .

The user is deleted and removed from Navigation > Enterprise Hierarchy.

Configuring Privileges

You can configure privileges for a department, role, or user. When you configure privileges for a
department, those privileges apply to the department and all the roles and users in the department. When
you configure privileges for a role, those privileges apply to the role and to all users who belong to the
role.

Note: Privileges to use a workspace are configured at the role level.
1. Select Administration > User.

2. Inthe User Administration dialog box, in the Navigation pane, click the department, role, or user for
which you want to configure privileges.

3. Inthe Department Editor, Role Editor, or User Editor pane, configure the department privileges (if
you selected a user, in the User Editor pane, click the Permissions tab). The following table
provides descriptions of the privileges.

Note: Click the arrow icon next to each privilege type to expand it and view the privileges. You can check
the privilege type check box to select all privileges, or you can check the check box for each individual
privilege to select it.
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Privilege

Description

Administrative Privileges

User Administration

Administrator can modify user privileges and can configure email
addresses for users to which to send notifications; administrators
can modify users and roles within that administrator’'s department
only.

Manage Share Groups

Administrator can add, modify, and delete share groups.

Access Server Logs

Administrator can view server logs.

Configure System Properties

Administrator can configure system properties.

Archive Administration

Administrator can create archive rules for jobs.

Workspace

Contains the following options.

e View Details: Administrator can view details about workspace
versions and can configure notifications for versions.

e  Edit Details: Administrator can modify workspace details
and can configure notifications for versions.

Version Control

Contains the following options.

¢ Create/Move to Edit: Administrator can create new
workspace versions and move workspace versions to edit
mode.

¢« Move to Test: Administrator can move workspace versions to
test mode.

¢ Move to Staged: Administrator can move workspace versions to
staged mode.

¢ Move to Active: Administrator can move workspace versions to
active mode.
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Privilege

Description

Workspace Configuration

Contains the following options.

Add Shared Objects: Administrator can add shared objects to
the workspace.

Edit Shared Objects: Administrator can modify workspace
shared objects.

Edit File Sources: Administrators can modify file sources.

Edit Connection Groups: Administrator can modify connection
groups.

Edit Connections: Administrator can modify connections.
Edit Headers: Administrator can modify header files.

Edit Verification Forms: Administrator can modify verification
forms.

Edit ImageNow Index Map: Administrator can modify
ImageNow index maps.

Edit Data Providers: Administrator can configure web service
data providers.

Edit Document Templates: Administrators can configure
document templates.

Procedures

o  Edit Match: Administrator can configure match logic.
o  Edit Review: Administrator can configure review logic.
o  Edit Upload: Administrator can configure upload logic.

o  Edit Match Display: Administrator can configure match
display logic.

o  Edit Population Selection: Administrator can configure
population selection logic.
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Privilege Description
Tools Contains the following options.

¢ Lookup: User can configure the lookup tool.

¢ Check Name: User can configure the check name tool.

e Export: User can export Hyland DataTransfer data (for
example, lookup values, data provider maps, workspaces,
and so on).

e Data Exports
o  Edit Data Exports: User can modify data exports.

o  Run Data Exports: User can run data exports.

o  Edit Scheduled Data Exports: Users can add, modify, and
delete scheduled data exports.

o  View Data Export Output: Users can view the output of
past data exports.

o  Delete Data Export Output: Users can delete the
output of past data exports.

¢ Reports
o  Run Reports: User can run reports.

o  Edit Reports: User can modify reports and can
configure notifications for reports.

o  Edit Scheduled Reports: User can create, modify, and
delete scheduled report rules.

o View Report Output: User can view output files for
reports that have been run.

o  Delete Report Output: User can delete output files for
reports that have been run.

Version Contains the following options.

¢ Import: User can import workspace versions.

e  Edit: User can work in workspace versions in edit mode.

¢ Inactive: User can work in workspace versions in inactive mode.

e  Staged: User can work in workspace versions in staged mode.

e Test: User can work in workspace versions in test mode.

Job Contains the following options.

e Create Jobs: User can create jobs and can configure
notifications for jobs.

e  Edit Recurring Jobs: User can modify recurring jobs.

e Edit Job Hold Status: User can place a hold on a job to
prevent it from being run.

e Enable Auditing: User can enable auditing.

¢ View Archived Jobs: User can view archived jobs.
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Privilege

Description

Record

Contains the following options.
*« Create New Record: User can create new records.

+ Create Match Record: User can set records as matched
records.

*  Create Suspend Record: User can suspend records.

Notifications

Contains the following options.

¢ Create Notification Groups: User can create new notification
groups.

* Edit Notification Groups: User can modify notification groups.

Workspaces

Workspace privileges are configured at the role level and are applied
to all users in the role.

A user can use only one workspace at a time.

Check the workspace that the user can use, then set the following
options.

e Headers: Headers contained in the workspace that the user
can use. Check the Headers check box to select all headers
or check individual headers to select them.

¢ Connection groups: Connection groups contained in the
workspace that the user can use. Check the Connection
Groups check box to select all connection groups or check
individual connection groups to select them.

e  File Sources: File sources contained in the workspace that
the user can use. Check the File Sources check box to
select all file sources or check individual file sources to
select them.

4. Click the Settings tab to configure email addresses for users to which system notifications are sent.
For more information, refer to Configuring Notifications.

5. Click Save to save your changes.

Configuring Workspaces

To open the Workspace Administration dialog box, select Administration > Workspace. The dialog box
provides the following information:

Name. Name of the workspace.

Description. Brief description of the workspace.

Sharing. Indicates whether the workspace is private or with a share group.

Active Version. Version of the workspace that is active.

Date Created. Date on which the workspace was created.

Created By. Name of the user who created the workspace.
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Refer to the following topics for more information.

Understanding Workspaces
Understanding Workspace Sharing
Understanding Version Control
Configuring Workspaces

Using Version Control

Configuring Share Groups

Understanding Workspaces

Workspaces consist of the objects required for a particular Hyland DataTransfer configuration.

Connection groups: A workspace can contain one or more connection groups; a connection group
can consist of one or more connections.

Procedures (code libraries): A workspace contains a set of code libraries, comprising the Hyland
DataTransfer match, review, and upload logic.

Verification form: A workspace contains a single verification form to be used for all jobs that are run
within that workspace.

Headers: A workspace contains one or more headers, which are used to define input sources. When
a job is run within a workspace, one of the headers within the workspace must be selected to use for
the job.

Data exports: A workspace can contain one or more data exports, if they are configured in that
workspace. Workspaces do not have to contain data exports.

File sources: A workspace can contain one or more file sources (both SFTP and server path file
locations), which are SFTP sites from which jobs can be downloaded. Workspaces do not have to
contain file sources.

ImageNow index maps: A workspace can optionally contain one or more index maps.
Variable maps: A workspace can optionally contain one or more variable maps.
Document templates: A workspace can optionally contain one or more document templates.

EDI formats: A workspace can optionally contain one or more EDI formats.

You can load multiple configurations, represented by workspaces, into a single Hyland DataTransfer
instance; however, users can only work with one workspace at a time. When you log into Hyland
DataTransfer, you use a default workspace and workspace version but can switch to another workspace
version.

You can have multiple versions of a workspace, with each version representing a changeset of the
workspace.

Objects can be shared among workspaces. Refer to Understanding Workspace Sharing.

38



Hyland DataTransfer Administrator Guide

Understanding Workspace Sharing
The following objects can be shared.
e Procedures
e Headers
e Verification forms
e Data exports
e Connection groups
e File sources
¢ ImageNow index maps
e Document templates
e Variable maps
e EDIformats

You can share an object if multiple workspaces need to use a common object. With sharing, you can
reduce the need for duplicating common objects and code, and you can make a single edit and apply it to
one object in all workspaces in which it is shared.

For example, you can create a single procedure and share it among multiple workspaces without needing
to create duplicate procedures for each workspace.

A workspace can be shared or private.
e Private: The workspace is not shared; therefore, no workspace objects are shared.
e Shared: The workspace can share objects with other workspaces.

The sharing method can be changed at any time; however, you cannot change a shared workspace if
shared objects are used by other workspaces and would no longer be shared.

When you share workspace objects, you configure share groups and select the group with which you
want to share objects. Any workspaces using the same share group share their objects with other
workspaces in this group. Refer to Configuring Share Groups for more information.

Workspaces consist of versions, and objects can be shared depending on the status of your workspace
version. Refer to Understanding Object Version Flow for more information.

Understanding Version Control

You can have multiple versions of a workspace; each version represents a changeset of the workspace.
There is always at least one version of a workspace.

Refer to Understanding Workspace Version Flow for information on how workspace versions are created
and moved.

Understanding Workspace Version Flow

Each workspace version has one of the following statuses.

o Edit: This workspace version is a new version. Only one version of the workspace can be in edit
status at a time, and this version can be changed by only one user at a time.

39



Hyland DataTransfer Administrator Guide

Also, only one user at a time can log in to the edit version of a workspace. If a user attempts to log in
to the edit workspace version while another user is logged into it and therefore has locked the
version, the user receives an appropriate message. In addition, any part of the user interface related
to workspaces or versioning is disabled until the user changes to a different role or workspace
version.

Test: This workspace version can be tested by any number of permitted users.

Staged: This workspace version can be used to view how the workspace will behave in a production
environment.

Active: This workspace version is the current, active version of the workspace. Only one version of
the workspace can be active at a time.

Inactive: This workspace is an older version of the workspace and is no longer in use.

Workspace objects are also versioned and have their own version flow within workspace versions. Refer
to Understanding Object Version Flow for more information.

Figure 1: Workspace Version Status Version Flow

Edit — Test —|  Staged Active | —— Inactive

Same version

Version +1

Version +1

Version +1

Edit

Objects can be added and modified in edit mode.

A version in edit mode can be moved to test mode.

A version in edit mode can be created from a version in staged, active, or inactive mode.
A version can be reverted to edit mode from test mode.

A new version in edit mode can be created from a version in test mode.

Test

A version can enter test mode from edit mode.
A version in test mode can be moved to edit mode.
A version in test mode can be moved to staged mode.

A version in test mode can be deleted.
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e Aversion can be in both edit mode and test mode at the same time; however, there can be only one
version each in edit and test mode.

Staged

e A version can enter staged mode from test mode.

e Aversion in staged mode can move to active mode.

e Aversion in staged mode can be used to create a version in edit mode.

e Aversion in staged mode cannot be deleted.

Active

e Aversion can enter active mode from staged mode.

e Aversion can enter active mode as a new version created from an inactive version.

e Aversion in active mode can move to inactive mode (when another version is made active).
e Aversion in active mode can be used to create a new version in edit mode.

e Aversion in active mode cannot be deleted.

¢ Once there is an active version of a workspace, an active version always exists for the workspace.
Inactive

e Aversion can enter inactive mode from active mode (when another version is made active).
e Aversion in inactive mode can be used to create a new version in active mode.

e Aversion in inactive mode can be used to create a new version in edit mode.

e A version in inactive mode cannot be deleted.

Understanding Object Version Flow

Within a workspace version, an object can have a new, pending, current, or dated status.

New Pending » Current Dated

version + 1 or same version

Version +1

Version +1

New
e A new version can be newly created (or copied from an existing object).
e A new version can be created from a pending version.

e A new version can be created from a current version.
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e A new version can be created from a dated version.

e A new version can be deleted.

e Only one version of an object can be in new mode.

e Aversion is in new mode when it was created or modified in a workspace version in edit mode.

e A pending version changes to new version when a workspace is moved from test back to edit mode.
Pending

e A version enters pending mode from new mode when a workspace is moved from edit mode to test
mode.

e A version in pending mode is reverted to new mode when a workspace is moved from test mode
back to edit mode.

e A version in pending mode is changed to current mode when a workspace is moved from test mode
to staged mode.

e Aversion in pending mode can be removed from the workspace.
Current

e A version enters current mode from pending mode when a workspace is moved from test mode to
staged mode.

e A version in current mode can be used to create a version in new mode.
e A version in current mode can move to dated mode (when another version is moved to current).
e A version in current mode can be removed from the workspace.

e Aversion is in current mode when it was created or modified in a workspace version in staged or
active mode.

Dated
e A version can enter dated mode from current mode.
e A version in dated mode can be used to create a version in new mode.

e A version in dated mode can be removed from the workspace.

Rolling Back Versions and Obtaining the Latest Versions of Objects

You can roll back a version of an object (use a previous version of an object) or obtain the latest version of
an object if changes have been made and committed to an object.

You can also obtain the latest version of an object if the object has been modified since you added it. For
example, you added an object from a workspace in active mode. A new version of the workspace was
later added, the shared object was modified, and the version was moved to staged mode. If you obtain
the latest object version, these object changes are applied to the object in your workspace.

Configuring Workspaces
Refer to the following topics for more information.

e Importing Workspaces

e Adding Workspaces
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o Modifying Workspaces

o Deleting Workspaces

Importing Workspaces

You can import Hyland DataTransfer 7.x workspaces, and you can import Hyland DataTransfer
configurations from versions earlier than 7.0.x.

Note: You cannot import workspaces in tablet view.

Importing Hyland DataTransfer 7.x Workspaces

Note: Only superadministrators can import workspaces. To import a workspace, complete the following
steps.

1. Select Administration > Workspace.

2. In the Workspace Administration dialog box, click 3§

In the Configuration Migration dialog box, click Import Workspace and complete the following
substeps.

1. In the Workspace Name field, type a name for the workspace.
2. In the Workspace Description field, type descriptive text about the workspace.

3. In the File field, type the path of the file you want to import, or click Browse, navigate to the
location of the file, and then select it.

4. In the Sharing field, click the appropriate option.

e Private: Sets the workspace as a private one; it is not shared, and none of its objects are
shared.

e Shared: Sets the workspace as a shared workspace, which can share its objects with either a
specific group of workspaces or all workspaces.

4. If you are sharing the workspace, from the Group drop-down box, select the share group to use for
the workspace.

7. Click OK.
Importing Legacy Configurations

You can import legacy config.dll databases from versions of Hyland DataTransfer earlier than 7.0.x. A
new Hyland DataTransfer workspace is created from the migrated config.dll database. Duplicate objects
are shared with existing Hyland DataTransfer workspaces when applicable. Hyland DataTransfer
manages importing of Hyland DataTransfer functions as follows.

o Enterprise Hierarchy

Legacy hierarchies are merged in a single hierarchy. A node in the hierarchy is merged with an
existing node if the node names match and each subsequent parent in the tree matches. If no
matches are found, the node is created as new, either as the beginning of a new tree for an
organization or as the child to a matching parent in other cases.

e Database connections

For each migrated config.dll, a new connection group is created. A default connection, corresponding
to the legacy ODBC connection selected at Hyland DataTransfer log in, is created as the primary
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connection of the group. All other legacy secondary connections are added to the group. Names and
descriptions are migrated, but legacy connection details are omitted. Current connection details are
provided manually after migration.

Code libraries

Match, Review, and Upload libraries, along with their corresponding procedures and SQL blocks, are
migrated.

Libraries can be merged or not merged depending on migration parameters. If merged, the existing
repository is searched for matching libraries. A library is considered a match if its properties are
identical, including all its procedure and SQL blocks. If a match is found, and that match is shared in
the same share group, then the migrated collection will share a link to the matched library with any
workspaces that already share the library. If there is no match, or the matches are not shared, then
the library is created as new, along with all its procedures and SQL blocks.

Procedures and SQL blocks may be merged or not merged depending on migration parameters. If
merged, the existing repository is searched for matching procedures. A procedure is considered a
match if its properties and text are identical. If a match is found, and that match is shared in the same
share group, then the migrated workspace will share a link to the matched procedure with any
workspaces that already share the procedure. If there is no match, or the matches are not shared,
then the procedure is created as new. The same logic applies to SQL blocks.

Libraries, procedures, and SQL blocks are migrated as is. Legacy conditions within their properties
and text are automatically resolved after the config.dll migration, but some manual corrections may
need to be made if there are issues with legacy code.

Program variables

Program variables are migrated from the legacy database to the new Hyland DataTransfer 7.x
schema as is. Program variables contain links to verification form objects; however, links between
program variables and form objects are not maintained. Data typing issues or other legacy concerns
are resolved after the config.dll migration. All program variables are created as new and are not
shared with other workspaces.

Headers

Headers can be merged with existing headers or created as new, depending on migration
parameters. If merged, the existing repository is searched for matching headers. A header is
considered a match if all its properties, including its type and subsequent details, are identical. If a
match is found, and that match is shared with the same share group, then the migrated workspace
will share a link to the matched header with any workspaces that already share the header. If there is
no match, or the matches are not shared, then the header is created as new.

Data exports

Data exports can be merged with existing data exports or created as new, depending on migration
parameters. If merged, the existing repository is searched for matching data exports. A data export is
considered a match if all its properties are identical. If a match is found, and that match is shared with
the same share group, then the migrated workspace will share a link to the matched data export with
any workspaces that already share the data export. If there is no match, or the matches are not
shared, then the data export is created as new.

Notes

Only superadministrators can import legacy configurations.

BEGIN TRAN in SQL statements are removed from code during migration.

To import a legacy configuration, complete the following steps.
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1. Select Administration > Workspace.

In the Workspace Administration dialog box, click Y

In the Configuration Migration dialog box, click Import Legacy Configuration and complete the
following substeps.

1. In the Workspace Name field, type a name for the workspace.
2. In the Workspace Description field, type descriptive text about the workspace.

3. Inthe Config.dll Upload field, type the path of the file you want to import, or click Browse,
navigate to the location of the file, and then select it.

4. In the Sharing field, click the appropriate option.

e Private: Sets the workspace as a private one; it is not shared, and none of its objects are
shared.

e Shared: Sets the workspace as a shared workspace, which can share its objects with
workspaces in the same share group.

4. For a shared workspace, from the Group drop-down box, select the share group to use for the
workspace. If you are sharing a workspace, you must select the appropriate share group.

5. Check the Merge Headers check box to merge legacy headers with Hyland DataTransfer 7.x
headers.

6. Check the Merge Data Exports check box to merge legacy data exports with Hyland DataTransfer
7.x data exports.

Check the Merge NQL Procedures check box to merge procedures.
8. Click Migrate.

Adding Workspaces
Note: Only superadministrators can add new workspaces.
To add a new workspace, complete the following steps.

1. Select Administration > Workspace.

In the Workspace Administration dialog box, click +
In the Add Workspace dialog box, complete the following substeps.
1. In the Name field, type the name of the workspace.
2. In the Description field, type the description of the workspace.
3. Inthe Sharing field, click the appropriate option.
4. If you are sharing a workspace, from the Group drop-down box, select the share group to use.
Click OK. The workspace is added and displays in the Workspace Manager dialog box.

To use this workspace, give yourself the appropriate privileges. Refer to Configuring Users and
Privileges.
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Modifying Workspaces
To modify a workspace, complete the following steps.
1. Select Administration > Workspace.
2. In the Workspace Administration dialog box, select the workspace you want to modify, and then
either right-click it and select Edit or click
3. Inthe Workspace Details dialog box, complete the following substeps.
1. In the Name field, type the name of the workspace.
2. In the Description field, type the description of the workspace.
3. Inthe Sharing field, click the appropriate option.

e Private. Sets the workspace as a private one, if it is not shared, and none of its objects are
shared.

e Shared. Sets the workspace as a standard workspace, which can share its objects with
workspaces in the same share group.

4. If you are sharing the workspace, from the Group drop-down box, select the share group to us.
5. Click Save.

The workspace is modified, and its updated information displays in the Workspace Manager dialog box.

Deleting Workspaces

Note: Only superadministrators can delete workspaces.
To delete a workspace, complete the following steps.

1. Select Administration > Workspaces.

2. In the Workspace Manager dialog box, select the workspace you want to delete, and then either
right-click it and select Remove, or click =

The workspace is deleted and is removed from the Workspace Manager dialog box.

Using Version Control
Refer to the following topics for more information.
e Modifying Versions
e Viewing Version Details
e Moving Versions to Test Mode
e Reverting a Version to Edit Mode
e Moving Versions to Staged Mode
e Adding Versions
e Moving Versions to Active
e Obtaining the Latest Versions of Shared Objects

e Importing Versions
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e Exporting Versions
e Configuring Workspace Version Notifications

The Version Administration dialog box displays when you select a workspace in the Workspace Manger
dialog box and either right-click it and select Versions, or click . |t displays the following information.

e Version: Numerical value of the version.
e Description: Description of the version.
e Status: Status of the version.

e Date Active: Date on which the version was activated. If the version is not active, this column displays
a blank row of information.

o Created By: Name of the user who created the version.
e Create Date: Date on which the version was created.

Figure 3: Version Administration Dialog Box
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Modifying Versions

Note: You can modify only the version in which you are working if it is in edit or test mode.
To modify a version name, complete the following steps.

1. Select Administration > Workspace.

2. Inthe Workspace Manager dialog box, select the workspace you want to modify and either right-
click it and select Versions, or click =,
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3. Inthe Version Administration dialog box, select the version you want to modify and either right-click
it and select Edit Description, or click .

4. In the Edit Version Description dialog box, type descriptive text about the version and click OK.

The version description is updated and displays in the Version Administration dialog box.

Edit ¥ersion Description x
Wearsion
Description:
Ok Cancel

Viewing Version Details
To view version information, complete the following steps.
1. Select Administration > Workspace.

2. In the Workspace Administration dialog box, click the workspace for which you want to view version
details and then either right-click it and select Version, or click 4.

3. Inthe Version Administration dialog box, either right-click the version and select View, or click -
A dialog box displays for the version and displays the following information.
e Action: Action that was taken on an object (Add, Modify, or Delete).
e Type: Type of object that was added, modified or deleted.
¢ Name: Name of the object that was added, modified, or deleted.
e Date: Date on which the action occurred.
e User: Username of the user who added, modified, or deleted the object.

e Comment: Comment that was added to the version entry.

Adding Versions

You can add a new version of a workspace if you do not have any other versions with edit status. The
new version you add has a status of edit.

A workstation version in edit mode can be created from a version in staged, active, inactive, or test mode.
A version in test mode can be reverted to edit mode if no other edit mode version exist.

To revert a version in a test mode back to edit mode, follow the procedure in Reverting a Version to Edit
Mode.

Use the following procedures to create a new workspace version in edit mode from workspace versions in
staged, active, inactive, or test mode.

1. Select Administration > Workspace.

2. In the Workspace Administration dialog box, click the workspace to which you want to add a new
version and either right-click it and select Version, or click 4
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3. Inthe Version Administration dialog box, select the workspace version from which you want to
create a new version in edit mode.

When you create a new version from the selected version, a copy of the selected version is created
and is placed in edit mode.

Click =& .
In the dialog box, click Yes to create a new version.

In the Add Version dialog box, in the Description field, type descriptive text about the version and
click OK.

The version is created and displays in the Version Administration dialog box.

Moving Versions to TestMode

Note: You can move a version from only edit mode to test mode. If you move a version from edit mode to
test mode, any existing version in test mode become inactive.

To move a version to test mode, complete the following steps.
1. Select Administration > Workspace.

2. In the Workspace Administration dialog box, click the workspace whose version you want to test
and either right-click it and select Version or click “

3. Inthe Version Administration dialog box, select the version you want to advance to testing and

either right-click it and select Test or click "+ . A dialog box appears and prompts you to confirm that
you want to advance the version to testing.

4. In the dialog box, click Yes to change the status to test.

The version is advanced to test mode, and its information is updated in the Version Administration dialog
box.

Reverting a Version to Edit Mode

Note: You can revert a version from only test mode to edit mode. You can revert a version from test
mode to edit mode only if there are no versions already in edit mode.

To revert a version back to edit mode from test mode, complete the following steps.
1. Select Administration > Workspace.

2. Inthe Workspace Administration dialog box, click the workspace whose version you want to revert
to editing and either right-click it and select Version or click = |

3. Inthe Version Administration dialog box, select the version you want to revert to editing and either
right-click it and select Edit or click

4. In the dialog box, click Yes to change the status to edit.

The version is reverted to edit status, and its information is updated in the Version Administration dialog
box.
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Moving Version to Stage Mode
Note: You can move version to staged mode only from test mode.
1. Select Administration > Workspace.

2. In the Workspace Administration dialog box, click the workspace whose version you want to
advance to staging and either right-click it and select Version or click =

3. Inthe Version Administration dialog box, s appears. select the version you want to advance to
staging and either right-click it and select Stage or click "= .

4. In the dialog box, click Yes to change the status to staged.

The version is changed to staged status, and its information is updated in the Version Administration
dialog box.

Moving Versions to Active
Note: You can move a version to active with the status of staged or inactive only.
1. Select Administration > Workspace.

2. In the Workspace Administration dialog box, click the workspace whose version you want to
activate and either right-click it and select Version, or click ‘= |

3. Inthe Version Administration dialog box, select the version you want to activate and either right-click
it and select Activate, or click = .

4. In the dialog box, click Yes to activate the version.

The version is activated, and its information is updated in the Version Administration dialog box.

Obtaining the Latest Versions of Shared Objects

If changes have been made to and committed to shared objects, you can obtain the latest versions of all
shared objects.

Note: You can also obtain the latest versions of individual objects (procedures, forms, data exports,
headers, and connection groups) in the appropriate dialog boxes or application windows for the objects.

1. Select Administration > Workspace.

2. In the Workspace Administration dialog box, click the workspace whose latest version you want to
obtain and either right-click it and select Version, or click “

3. In the Version Administration dialog box, select the version and click ' .

The latest objects are obtained and are loaded into the workspace.

50



Hyland DataTransfer Administrator Guide

Importing Versions

Note: You cannot import versions in tablet view.

To import a version from an XML file, complete the following steps.
1. Select Administration > Workspace.

2. In the Workspace Administration dialog box, click the workspace for which you want to import a
version and either right-click it and select Version, or click “& .

In the Version Administration dialog box, click <~ = and select Import.

4. In the Import Version dialog box, click Browse and navigate to the version you want to import,
select it, and click OK.

The version is imported and appears in the Version Administration dialog box.

Exporting Versions

Note: You cannot export versions in tablet view.

To export a version in an XML file, complete the following steps.
1. Select Administration > Workspace.

2. In the Workspace Administration dialog box, click the workspace for which you want to export a
version and either right-click it and select Version, or click .

3. Inthe Version Administration dialog box, select the version you want to export.
Click ¢ = and select Export.

In the Workspace Export dialog box, click the Full option if you want to export all objects in the
workspace; click Changes if you want to only export changes, and click OK.

6. Save the file in the appropriate location.

Configuring Workspace Version Notifications
You can configure Hyland DataTransfer to send email notifications to specified users about when

certain workspace version activities occur. When you select Administration > Workspace and click - ,
the Version Notification Configuration dialog box appears, from which you can configure notifications. For
more information about configuring notifications, refer to Configuring Notifications.
Configuring Share Groups
Workspaces and their objects can be shared among share groups. Create a share group and configure
workspaces to use that share group so that objects can be shared.
Adding Share Groups
To add a share group, complete the following steps.
1. Select Administration > Share Groups.
2. Inthe Share Group Administration dialog box, click “
3. Inthe Add Share Group dialog box, complete the following substeps.
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9.

1. In the Share Group Name field, type the name of the share group.
2. In the Description field, type descriptive text for the share group.
Click OK.

The share group is created and displays in the Share Group Administration dialog box.

When you share a workspace, you select the share group to use. Workspaces that use this share group
can share their objects with all other workspaces using the share group.

Modifying Share Groups

To modify a share group, complete the following steps.

1.
2.

4.

Select Administration > Share Groups.

In the Share Group Administration dialog box, select the share group you want to modify and either
right-click it and select Edit, or click «

In the Edit Share Group dialog box, complete the following substeps.

1. In the Share Group Name field, type the name of the share group.
2. In the Description field, type descriptive text for the share group.

Click OK.

The share group is modified and updated in the Share Group Administration dialog box.

Deleting Share Groups

Note: You cannot delete a share group if a workspace is using it.

To delete a share group, complete the following steps.

1.
2.

3.

Select Administration > Share Groups.

In the Share Group Administration dialog box, select the share group you want to delete and either
right-click it and select Delete, or click = .

In the dialog box, click Yes to delete the share group.

The group is deleted and is removed from the Share Group Administration dialog box.
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Configuring connection groups and database connectors

Connection groups consist of a group of database connections and are associated with a workspace;
connection groups and their connections can be shared among workspaces.

You can import connection groups from and export connection groups to an XML file.
Refer to the following topics for more information.
e Configuring connection groups

e Configuring connections

Configuring connection groups
Refer to the following topics for more information.
e Adding connection groups
¢ Modifying connection groups
e Deleting connection groups
e Copying connection groups
e Removing sharing on shared connection groups
e Rolling back connection groups
e Exporting connection groups

e Importing connection groups

Adding connection groups

You can add a new connection group or add a connection group that another workspace is sharing by
completing the following steps.

1. Select Configuration > Connections.

2. In the Connection Group Administration dialog box, click =& .

3. Inthe Add Connection Group dialog box, perform one of the following options.

e To add a connection group, complete the following substeps.

1. Click the Add Connection Group tab.
2. In the Connection Group Name field, type the name of the connection group.
3. In the Description field, type descriptive text about the connection group.
4. Click OK.

e To add a connection group that is shared by another workspace, complete the following
substeps.

1. Click the Add Shared Connection Group tab.

2. From the Workspace list, select the workspace that is sharing the connection group you
want to use.
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3. Select the connection group you want to use.
4. Click OK.

The connection group is added and appears in the Connection Group Administration dialog
box.

A database connection with the name Primary is automatically added to the connection
group. A connection group must always have a primary database connection. You can add
additional database connections to the group. Refer to Adding and modifying database
connections.

Modifying connection groups
To modify a connection group, complete the following steps.
1. Select Configuration > Connections.

2. Inthe Connection Group Administration dialog box, click the connection group you want to modify
and either click & or right-click the connection group and select Edit Connection Group.

3. In the Edit Connection Group dialog box, in the Connection Group Name field, type the name of
the connection group.

4. In the Description field, type a brief description for the connection group and click OK.

The connection group is modified, and its updated information appears in the Connection Group
Administration dialog box.

Deleting connection groups
To delete a connection group, complete the following steps.
1. Select Configuration > Connections.

2. Inthe Connection Group Administration dialog box, click the connection group you want to delete
and click = .

Copying connection groups
To copy a connection, complete the following steps.
1. Select Configuration > Connections.

2. In the Connection Group Administration dialog box, click the connection group you want to copy
and either right-click it and select Copy Connection Group, or click 'L .

3. Inthe Rename Copied Connection Group dialog box, in the Name field, type the name of the
connection group and click OK.

The connection group is copied, and the new connection group you created is added to the Connection
Group Administration dialog box.
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Removing sharing on shared connections groups

To remove sharing on a connection group that is shared with another workspace, complete the following
steps.

1. Select Configuration > Connections.
2. In the Connection Group Administration dialog box, select the connection group for which you
want to remove sharing and either right-click and select Remove Sharing, or click &

Sharing is removed on the connection group.

Rolling back connection groups

If changes have been made and committed to a connection group, you can use a previous version (roll
back) of it.

1. Select Configuration > Connections.

2. Inthe Connection Group Administration dialog box, click the connection group you want to roll
back and either right-click it and select Rollback or click "= .

The Rollback Manager dialog box appears and displays the following information.
o Name: Name of the connection group.

e Status: Status of the connection group (current or dated).

e Version Date: Date and time on which the version was created.

¢ Created By: User name of the user who created the connection group.

e Comments: Comments that were added by the user.

3. Select the previous version to which you want to revert and click Rollback. The previous version is
loaded.

Obtaining the latest versions of connection groups

If changes have been made to and committed to a connection group, you can obtain the latest version of
it by completing the following steps.

1. Select Configuration > Connections.

2. In the Connection Group Administration dialog box, click the connection group for which you want
to obtain the latest version and click ' .

Exporting connection groups

You can export connection groups to an XML file by completing the following steps.
Note: You cannot export connection groups in tablet view.

1. Select Configuration > Connections.

2. Inthe Connection Group Administration dialog box, select the connection group you want to
export.
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3.
4.

Click ¢« = and select Export.

Save the file to the appropriate location.

Importing connection groups

You can import connection groups from an XML file by completing the following steps.

Note: You cannot import connection groups in tablet view.

1.

2.
3.

5.

Select Configuration > Connections.

In the Connection Group Administration dialog box, click ¢~ = and select Import.

In the Import Connection Groups dialog box, click the Browse button and navigate to the file that
you want to import or type the location of the file in the File field.

Check the Update Existing Entities check box to update an existing connection group, with the
same name as the connection group you are importing, with the connection group you are importing.

If you do not check this check box, and there is an existing connection group with the same name as
the connection group you are importing, DUPLICATE- is appended to the start of the name of the
connection group you are importing; the existing connection group is not updated. If a connection
group exists with the name DUPLICATE-<connection_group _name>, DUPLICATE(2)- is appended to
the start of the name. The number continues to be incremented so that all connection groups have
unique names.

Click OK.

Configuring connections

Refer to the following topics for more information.

Adding and modifying database connections

Adding and modifying Nolij Web connections

Adding and modifying Hobsons Connect CRM connections
Adding and modifying integration server connections
Adding and modifying web service connections

Adding and modifying SOAP web service connections
Deleting connections

Testing connections
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Adding and modifying database connections

To add or modify a database connection, complete the following steps.

1. Select Configuration > Connections.

2. Inthe Connection Group Administration dialog box, complete one of the following actions.

e To add a new database connection, complete the following substeps.

1.

2.

Select the connection group to which you want to add a new connection and either right-
click it and click "&.

In the Add Connection dialog box, from the Type drop-down box, select Standard,

¢ To modify a database connection, select the connection you want to modify and click «.

1.

® N oA wN

In Add Database Connection or Edit Database Connection dialog box, in the Name field,
type the name of the connection.

Note: A primary database connection with the name Primary is automatically created when
you create a connection group. You can have only one primary database per group. You
cannot name another database connection Primary.

In the Description field, type a brief description of the connection.

In the URL field, type the URL of the database.

In the Username field, type the user name.

In the Password field, type the password.

In the DB Driver field, type the name of the driver used to connect to the database.
In the DB Name field, type the name of the database.

Click OK.

Adding and modifying Nolij Web connections

To add or modify a Nolij Web connection, complete the following steps.

Note: You can configure only one Nolij Web connection per connection group.

1. Select Configuration > Connections.

2. Inthe Connection Group Administration dialog box, perform one of the following actions.

e To add a new Nolij Web connection, complete the following substeps.

1.
2.

Select the connection group to which you want to add a new connection and click "-&.

In the Add Connection dialog box, from the Type drop-down box, select Nolij Web.

e To modify a Nolij Web connection, select the connection you want to modify and either right-click
it and select Edit Connection or click «".

3. Inthe Add Nolij Web Connection or Edit Nolij Web Connection dialog box, in the Name field, type
the name of the connection.

In the Description field, type a brief description of the connection.
In the URL field, type the URL of the Nolij Web instance (for example, http://localhost/NolijWeb/).
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In the Username field, type the user name.

In the Password field, type the password.

In the CAS URL field, type the URL of the CAS server.

Check the Is CAS check box to indicate that this connection uses CAS authentication.
0. Click OK.

= © ® N o

Adding and modifying Hobsons Connect CRM connecting

You can update Hobsons data using Hobsons Connect CRM web services. To do so, you create a
connection group that contains a Hobsons Connect CRM connection. You can also create a Hobsons
Connect CRM header and add and run a job using the Hobsons CRM Connect connection and header.
You can also use the appropriate NQL syntax in the Hyland DataTransfer logic to execute the Hobsons
web service.

Note: You can configure only one Hobsons CRM Connect connection per connection group.

To add or modify a Hobsons Connect CRM connection, complete the following steps.

1. Select Configuration > Connections.

2. In the Connection Group Administration dialog box, complete one of the following actions.
e To add a new Hobsons Connect CRM connection, complete the following substeps.

1. Select the connection group to which you want to add a new connection and click '&.

2. Inthe Add Connection dialog box, from the Type drop-down box, select Hobsons Connect
CRM.

¢ To modify a Hobsons Connect CRM connection, select the connection you want to modify and
click «".

3. In Add Hobsons Connect CRM or Edit Hobsons Connect CRM dialog box, in the Name field, type
the name of the connection.

In the Description field, type descriptive text about the connection.

In the Client URL field, type the URL used by clients to access web services.

In the Action URL field, type the URL used for SOAP (Simple Object Access Protocol) web services.
In the Client Name field, type the client name used for the connection.

In the Pass Key field, type the pass key used for the connection.

Click OK.

The connection is added and appears in the Connection Group Administration dialog box.

© ® N o a &

You configure jobs to use connection groups; refer to Configuring Jobs and Processing Records. When
you configure a job to use a connection group with a Hobsons connection and a Hobsons Connect CRM
header, you can also configure the logic used by the job to use the appropriate NQL syntax, as follows.

HobsonsUpdate (<web service name>, <contact id>, <attribute name 1>, <attribute wvalue
1>, <attribute name 2>, <attribute value 2>, ... , <attribute name n>, <attribute value
n>)
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The required parameters are:

e <web service name>: the name of the Hobsons Connect CRM web service (for example,
e UpdateContact)

e <contact id>: the ID value of the contact record to update.

The additional parameters are any number of attribute name or value pairs. Both components of the pair
are strings; the first string identifies the name of the Hobsons Connect CRM attribute to update, and the
second string is the new value for the specified attribute.

The HobsonsUpdate function returns a string. If the update is successful, an empty string is returned. If it
is not successful, a corresponding error message is returned.

An example of the syntax is

let S$err = HobsonsUpdate ('UpdateContact', $id, 'first name', Sfname, 'last name',
$lname, 'dob', S$dob')

This syntax runs the UpdateContact web service on the contact with id $id and updates the first_name
attribute to the value in $fname, the last_name attribute to the value in $/lname, and so on.

For more information about procedures, refer to Configuring Procedures. For detailed information about
configuring logic, refer to Appendix A: Programming Concepts.

Adding and modifying integration server connections

Configure an Integration Server connection when you want to interact with ImageNow, using Hyland
DataTransfer.

You use Integration Server connections to obtain document information about the ImageNow documents
you want to upload. When you configure index maps, you use the connection to obtain the information,
which is displayed as Hyland DataTransfer program variables, and map the ImageNow document
properties to the corresponding program variables. Refer to Configuring ImageNow Index Maps.

Use the ImageNowAddDoc function in your code to specify the parameters Hyland DataTransfer uses to
upload ImageNow documents. Refer to Understanding the ImageNowAddDoc function.

Note: You can configure only one ImageNow connection per connection group.
To add or modify an Integration Server connection, complete the following actions.
1. Select Configuration > Connections.

2. Inthe Connection Group Administration dialog box, complete one of the following actions.
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To add a new Integration Server connection, complete the following steps.

© N o g bk 0w N =

Select the connection group to which you want to add a new connection and click "-&.

In the Add Connection dialog box, from the Type drop-down box, select Integration Server.
Select the connection group to which you want to add a new connection and click "&.

In the Add Connection dialog box, from the Type drop-down box, select Integration Server.
In the Description field, type descriptive text about the connection

In the URL field, type the username used for the connection.

In the Password field, type the password used for the connection.

Click OK.

Adding and modifying web service connections

Create a web service connection when you are using web services to retrieve or update data. For more
information, refer to Configuring data providers.

Refer to the following topics for more information.

Adding and modifying web service connections without authentication
Adding and modifying session header connections
Adding and modifying session cookie connections

Adding and modifying HMAC connections

Adding and modifying web service connections without authentication

To add or modify web service connection that does not use an authentication scheme, complete the
following steps.

1.
2.

Select Configuration > Connections.

In the Connection Group Administration dialog box, perform one of the following actions.

e To add a new connection, complete the following substeps.
1. Select the connection group to which you want to add a new connection and click '&.
2. Inthe Add Connection dialog box, from the Type drop-down box, select Web Service.
3. From the Authentication drop-down box, select Not Applicable and click OK.

e To modify a web service connection, select the connection you want to modify and click «".

In the Add Web Service or Edit Web Service dialog box, in the Name field, type the name of the web
service connection.

In the Description field, type descriptive text about the web service connection.

In the Client URL field, provide the beginning portion of the URL that runs the web service. If you have
multiple web services that start with the same portion of the URL, you can provide this common portion
in the URL field and share the connection among multiple web services.

Click OK.
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Adding and modifying session header connections

A session header connection extracts a session ID or token from the response sent by an initial request to
a specified URL. The authentication request is executed with the parameters you specify, and the session
ID or token is extracted from the response. For each subsequent web service call using this connection,

the extracted session ID token is then passed into the header field you specify.

To add or modify a session header connection, complete the following actions.

1.
2.

Select Configuration > Connections.

In the Connection Group Administration dialog box, perform one of the following actions.

e To add a new connection, complete the following substeps.
1. Select the connection group to which you want to add a new connection and click '&.
2. In the Add Connection dialog box, from the Type drop-down box, select Web Service.
3. From the Authentication drop-down box, select Session Header and click OK.

e To modify a web service connection, select the connecting you want to modify and click .

In Add Web Service or Edit Web Service dialog box, in the Name field, type the name of the session
header web service connection.

In the Description field, type descriptive text about the session header web service connection.

In the Client URL field, provide the beginning portion of the URL that runs the session header web
service. If you have multiple web services that start with the same portion of the URL, you can provide
this common portion in the URL field and share the connection among multiple web services.

In the Authentication pane, specify session header authentication options by completing the following
substeps.

4. Inthe URL field, type the URL from which to receive the response.

5. From the HTTP Method drop-down box, select the HTTP method used.

6. Inthe Content Type field, type the content type to send to the URL. For example:
e For JSON authentication service, the content type is application/JSON.
e For XML authentication service, the content type is application/XML.

7. Inthe Content to Send field, provide the content (for example, the request payload) to send. For
example:

e For JSON authentication service, the content to be sent is in JSON format.

e For XML authentication service, the content to be sent is in XML format or is part of a URL
string.

8. In the Header Field field, type the header field into which the session ID or token is passed.
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7. If your authentication request requires you to include certain header properties in the request, you can
optionally configure request headers information. For example, if you are making an authentication
request to the Integration Server, which requires navigating to the appropriate URL and including the
Integration Server user name and password in the request header, you can add a request header to the
authentication request. Complete one of the following actions.

e To add a new request header, In the Request Headers pane, complete the following substeps.
9. Click &,

10. In the Add Request Header dialog box, in the Name field, type the name of the request
header. For example, if you are specifying an Integration Server user name, you could type x-
IntegrationServer-Username.

11. In the Value field, type the value of the request header. For example, for an X-
IntegrationServer-Username request header with Administrator as the user name, you would
type Administrator.

12. Click OK.
e To modify a request header, complete the following substeps.
1. Select the request header you want to modify in the Request Headers pane and click .

2. Inthe Edit Request Header dialog box, in the Value field, type the value of the request
header.

3. Click OK.
e To delete a request header, complete the following substeps.
1. Select the request header you want to modify in the Request Headers pane and click «".

2. Inthe Edit Request Header dialog box, in the Value field, type the value of the request
header.

3. Click OK.
e To delete a request header, complete the following substeps.
1. Select the request header you want to delete and click = .
A dialog box appears, prompting you to confirm that you want to delete the requested header.
2. To delete the request header, click OK.
8. Click OK.
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Adding and modifying session cookie connections

A session cookie connection extracts a session ID or token from the cookie sent by an initial request to a
specified URL. The authentication request is executed with the parameters you specify, and the session
ID or token is extracted from the cookie set by the response. For each subsequent web service call using
this connection, the extracted session ID or token is then passed into the cookie you specify.

To add a session cookie web service connection, complete the following steps.

1. Select Configuration > Connections.
2. Inthe Connection Group Administration dialog box, complete one of the following actions.
e To add a new session cookie connection, complete the following substeps.
1. Select the connection group to which you want to add a new connection and click "&.
2. In the Add Connection dialog box, from the Type drop-down box, select Web Service.
3. From the Authentication drop-down box, select Session Cookie and click OK.

e To modify a session cookie web service connection, select the connection you want to modify
and click «.

3. Inthe Add Web Service Connection or Edit Web Service Connection dialog box, in the Name field,
type the name of the session cookie web service connection.

4. In the Description field, type descriptive text about the session cookie web service connection.

In the Client URL field, provide the beginning portion of the URL that runs the session cookie web
service. If you have multiple web services that start with the same portion of the URL, you can provide
this common portion in the URL field and share the connection among multiple web services.

6. Inthe Session Cookie pane, specify session cookie authentication options by completing the following
substeps

1. Inthe URL field, type the URL from which to receive the response.

2. From the HTTP Method drop-down box, select the HTTP method used.

3. Inthe Content Type field, type the content type to send to the URL. For example,
e For JSON authentication service, the content type is application/JSON.
e For XML authentication service, the content type is application/XML.

4. Inthe Content to Send field, provide the content (for example, the request payload) to
send. For example,

e For JSON authentication service, the content to be sent is in JSON format.

o For XML authentication service, the content to be sent is in XML format or is part of a URL
string.

5. In the Cookie Field, type the cookie into which the session ID or token is passed.
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8.

If your authentication request requires you to include certain header properties in the request, you can
optionally configure request headers information. For example, if you are making an authentication
request to the Integration Server, which requires navigating to the appropriate URL and including the
Integration Server user name and password in the request header, you can add a request header to the
authentication request. Complete one of the following actions.

e To add a new request header, in the Request Headers pane, complete the following substeps.
1. Click &2,

2. Inthe Add Request Header dialog box, in the Name field, type the name of the request
header. For example, if you are specifying an Integration Server user name, you could type
X- IntegrationServer-Username.

3. Inthe Value field, type the value of the request header. For example, for an X-
IntegrationServer-Username request header with Administrator as the user name, you
would type Administrator.

4. Click OK.
o To modify a request header, complete the following substeps.
1. Select the request header you want to modify in the Request Headers pane and click .

2. Inthe Edit Request Header dialog box, in the Value field, type the value of the request
header.

3. Click OK.
e To delete a request header, complete the following substeps.
1. Select the request header you want to delete and click = .
A dialog box appears, prompting you to confirm that you want to delete the request header.
2. To delete the request header, click OK.
Click OK.

Adding and modifying HMAC connections

An HMAC (hash-based method authentication code) web service connection creates a customizable
HMAC signature included in an authorization header for all web service requests using that connection.

To add or modify an HMAC web service connection, complete the following steps.

1.
2.

Select Configuration > Connections.

In the Connection Group Administration dialog box, complete one of the following actions.

e To add a new HMAC web service connection, complete the following substeps.
1. Select the connection group to which you want to add a new connection and click "&.
2. Inthe Add Connection dialog box, from the Type drop-down box, select Web Service.
3. From the Authentication drop-down box, select HMAC and click OK

e To modify an HMAC web service connection, select the connection you want to modify and either
right-click it and select Edit Connection or click «.

In the Add Web Service Connection or Edit Web Service Connection dialog box, in the Name field,
type the name of the HMAC web service connection.
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4. In the Description field, type descriptive text about the web service connection.

5. In the Client URL field, provide the beginning portion of the URL that runs the web service. If you have
multiple web services that start with the same portion of the URL, you can provide this common portion
in the URL field and share the connection among multiple web services.

6. Inthe HMAC Authentication pane, specify the HMAC authentication options by completing the
following substeps

1. In the Endpoint field, type the URL extension that is appended to the client URL; this
combination specifies the web service endpoint.

2. From the HTTP Method drop-down box, select the HTTP method used (GET, POST,
PUT, or DELETE).

3. In the Content Type field, type the content type to send to the URL.
e For JSON authentication service, the content type is application/JSON.
e For XML authentication service, the content type is application/XML.

4. Inthe Secret Key field, type the secret token shared between the client and web service
provider used to encrypt the HMAC authorization signature.

o

In the Delimiter field, optionally specify the delimiter used to separate the values in the
concatenated string that comprises the HMAC signature.

6. In the Header Field field, type the header field to add to the HMAC signature.

7. In the Prefix field, optionally type text that prefixes the HMAC signature.

8. In the Encoding field, type the text encoding of the HMAC signature.

9. In the Algorithm field, type the algorithm with which to encrypt the HMAC signature.

7. In the pane to the right of the HMAC Authorization pane, specify the parameters that comprise the
signature by completing one of the following actions.

e To add a new HMAC parameter, complete the following substeps.

1. Click =2,
2. Inthe New HMAC Parameter dialog box, in the Name field, type the name of the HMAC
parameter.

3. From the Type drop-down box, select the type of content to add (Static String, Current
Date, Content Length, or Endpoint).

e For Static String, type the value of the string you want to include in the Value field (this
field is dimmed and unavailable for all other types of content).

e For Current Date, Hyland DataTransfer includes the current date in the HMAC
signature.

o For Content Length, Hyland DataTransfer calculates the content length of the web
service payload at runtime and includes it in the HMAC signature.

e For Endpoint, Hyland DataTransfer includes the web service’s endpoint in the HMAC
signature.

4. In the Position field, type the numeric position of the parameter to specify the location of
the parameter in the HMAC signature.

5. Click OK.
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e To modify an HMAC parameter, complete the following substeps.
1. Select the parameter you want to modify and click «.

2. In the Edit HMAC Parameter dialog box, from the Type drop-down box, select the type of
content to add (Static String, Current Date, Content Length, or Endpoint).

e For Static String, type the value of the string you want to include in the Value field (this
field is dimmed and unavailable for all other types of content).

e For Current Date, the system includes the current date in the HMAC signature.

e For Content Length, Hyland DataTransfer calculates the content length of the web
service payload at runtime and includes it in the HMAC signature.

e For Endpoint, the system includes the web service’s endpoint in the HMAC signature.
3. Click OK.
e To delete an HMAC parameter, complete the following actions.
1. Select the parameter you want to delete and click =,
2. In the dialog box, to delete the parameter, click OK.

8. If your authentication request requires you to include certain header properties in the request, you can
optionally configure request headers information. For example, if you are making an authentication
request to the Integration Server, which requires navigating to the appropriate URL and including the
Integration Server user name and password in the request header, you can add a request header to the
authentication request. Complete one of the following actions.

e To add a new request header, in the Request Headers pane, complete the following substeps.
1. Click =2,

2. Inthe Add Request Header dialog box, in the Name field, type the name of the request
header. For example, if you are specifying an Integration Server user name, you could type
X- IntegrationServer-Username.

3. Inthe Value field, type the value of the request header. For example, for an X-
IntegrationServer-Username request header with Administrator as the user name, you
would type Administrator.

4. Click OK.
o To modify a request header, complete the following actions.
1. Select the request header you want to modify in the Request Headers pane and click « .

2. Inthe Edit Request Header dialog box, from the Value field, type the value of the request
header.

3. Click OK.
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o To delete a request header, complete the following actions.

1. Select the request header you want to delete and click = .

A dialog box appears, prompting you to confirm that you want to delete the request header.

2. To delete the request header, click OK.

9. Click OK.

For example, you can create an HMAC web service connection with the following parameters.

Client URL: https://api.example.com

Endpoint: /examplews/application/v1/person/post

HTTP Method: POST

Content Type: application/json

Delimiter: \n

Header Field: Authorization

«  Prefix: AW2WS C4CA4238A0B923820DCC509A6F 75849B:
Encoding: UTF-8

Algorithm: HmacSHA1

HMAC parameters

e Parameter1

Position: 1
Name: Endpoint

Type: Endpoint

Parameter 2

Position: 2
Name: Date

Type: Current Date

Parameter 3

Position: 3

Name: App ID
Type: Static String
Value: 7529D7A

Parameter 4

Position: 4
Name: Content-Length

Type: Content Length
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e Requestheader
e Header x-examplews-appid
e Value7529D7A

Hyland DataTransfer calculates the HMAC signature by appending the endpoint value (/examplews/
application/v1/person/post), the current system date, the static string 7529D7A, and the content length of
the payload included in the request. It calculates the signature in this order because the positions of the
HMAC parameters are specified as 1 for Endpoint, 2 for Date, and so on.

Hyland DataTransfer places the delimiter \n between the HMAC parameters to separate them.

It encodes the concatenated string with UTF-8 encoding and encrypts the string with the secret key and
the HmacSHA1 encryption algorithm.

Hyland DataTransfer also appends the prefix, AW2WS C4CA4238A0B923820DCC509A6F75849B, to the
beginning of the encrypted string, and the resulting string is placed in the Authorization header.

The web service request includes a request header of x-examplews-appid with the value of 7529D7A.
When the web service executes, the web service provider calculates the expected HMAC signature using
the same criteria. If the expected HMAC signature matches the HMAC signature passed through the
Authorization header, the web service provider completes the request. If they do not match, the web
service provider returns an authorization error.

Adding and modify SOAP web service connections

Create a SOAP web service connection when you are using SOAP web services to retrieve or update
data. For more information, refer to Configuring SOAP web service data providers.

Note: SOAP web services are supported in Hyland DataTransfer 6.4.5 and higher.

To add or modify a SOAP web service connection, complete the following steps.

1. Select Configuration > Connections.

2. Inthe Connection Group Administration dialog box, complete one of the following actions.

e To add a new connection, complete the following substeps.

1. Select the connection group to which you want to add a new connection and click "&.

2. Inthe Add Connection dialog box, from the Type drop-down box, select SOAP Web
Service.

e To modify a web service connection, select the connection you want to modify and click «".

3. Inthe Add Web Service Connection or Edit Web Service Connection dialog box, in the Name field,
type the name of the SOAP web service connection.

In the Description field, type descriptive text about the SOAP web service connection.
In the URL Endpoint field, provide the URL endpoint.
Click OK.
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Deleting connections

To delete a connection, complete the following steps.

1.
2.

Select Configuration > Connections.

In the Connection Group Administration dialog box, select the connection you want to delete and
click &

Testing connections

To test a connection, complete the following steps.

1.
2.

Select Configuration > Connections.

In the Connection Group Administration dialog box, select the connection you want to test and
click ==

o |f the connection works properly, a dialog box appears and states that the test was successful.

o If the connection does not work properly, a dialog box appears and indicates why the test failed.

Configuring Procedures

Refer to the following topics for more information:

Understanding Hyland DataTransfer Logic
Understanding Variables

Configuring Variables

Configuring Libraries

Configuring Procedures

Importing and Exporting Libraries and Procedures

Understanding Hyland DataTransfer Logic

Hyland DataTransfer logic is divided into the following sections, which collect procedures related to the
process.

Match Process comprises all procedures and flow control related to matching input records to
existing records in your database.

Review Process comprises all procedures and flow control related to selecting data from your
database for potential matches.

Upload Process comprises all procedures and flow control related to adding or updating information
in your database.

Match Result Display logic defines the query that retrieves the information displayed in the Results
panel of the Job window when a match occurs. This query retrieves data based on a specified 1D
value; data columns returned by the query correspond to the columns of the Results pane.

You use this logic in a procedure and associate it with a header; when a job associated with the
header is run, the query returns the information in the Results pane.
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For an overview of the steps required to configure jobs that use this query to populate the Results
pane in the Job window, refer to Specifying data displayed in Results pane.

e Database Population Selection logic contains the query for dynamically extracting input data for a
job. You use this logic in a procedure and associate the procedures with a database header; when a
job associated with this header is run, the query extracts data from the database source.

Example:

begin-procedure test-query
!

begin-select

SSN “$SSN”,

FIRST “SFIRST”,

LAST  “SLAST”,
MI “SMI”,
DOB “+DOB”,
SEX “SSEX”,

FROM table name end-select

|
end-procedure

For an overview of steps for dynamically extracting input data for a job from a database, refer to
Obtaining input data from the database.

For information about configuring logic, refer to Appendix A: Programming Concepts. Procedures and
libraries are used to organize logic within each option.

Understanding Procedures

Procedures contain the logic that defines how Hyland DataTransfer determines if there are potential
matches between the input data and existing records in the database and how information in the
database is added or updated.

Procedures can also be shared and reused through workspaces. To add a procedure shared by another
workspace, the workspace version in which you are working must be in edit mode, and the workspace
version that contains the procedure you are importing must be in staged or active mode. For more
information about workspaces, refer to Configuring Workspaces.

For more information about configuring logic, such as procedure syntax, refer to Appendix A:
Programming Concepts.

Understanding Libraries

Libraries are used to group similar types of procedures within a category. For example, for Match Process
procedures, you can have the libraries Match Control and Match Display, and you can group related
procedures within these libraries.
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Understanding Variables
Refer to the following topics for more information.
e Understanding Data Types
e Understanding Variable Categories

e Understanding Naming Conventions

Understanding Data Types

Hyland DataTransfer has with three predefined data types for variables and constants.
e Character: Stores string values.

e Date: Stores date values.

e Number: Stores numeric values.

Understanding Variable Categories
Hyland DataTransfer uses two types of variables:
¢ Input: Represents each column of an input file.
e Program: User-defined or custom variables.

You should use lowercase text to name program variables to more easily distinguish them from input
variables.

Understanding Naming Conventions

Hyland DataTransfer examines the first character in a variable name to determine the data type of the
variable. The data type designators are:

e $: Designates a character variable
e &: Designates a date variable

e #: Designates a numeric variable

Configuring Variables
For definitions of global variables, refer to Understanding global variables.

You can also add variable mappings, which map a program variable to label and to a default value. Refer
to Configuring Variable Maps.

Refer to the following topics for more information.
e Adding Variables.

e Adding Missing Variables

e Modifying Variables

e Deleting Variables

e Importing Variables

e Exporting Variables
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e Searching Variables

e Finding Unused Variables

e Watching Variables

e Clearing Variables From the Watch List
e Moving Variables to Groups

e Configuring Groups

Adding Variables

Note: All input variables, including header variables, must have unique names. To add a variable,
complete the following steps.

1. Perform one of the following actions.

¢ Inthe Job Dashboard, select the job for which you want to add a variable and either right-click it
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.

In the Program Variables pane, click the All tab.

Click & .

In the Add Variable dialog box, in the Variable name field, type the name of the variable.

Click Apply.

S e

Continue to add variables, as appropriate; when you are finished, click OK.

The variable is added and is displayed in the Program Variables pane.

Adding Missing Variables

You can search for missing program variables and add any variables that are referenced in the code but
do not exist to Hyland DataTransfer.

To add missing variables for all procedures, refer to Adding Missing Variables for All Procedures.

To add missing variables for a selected procedure, refer to Adding Missing Variables for a Single
Procedure.

Adding Missing Variables for All Procedures

To search for and add missing variables for all Hyland DataTransfer procedures, complete the following
steps.

1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to add a variable and either right-click it
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.
2. Inthe Procedures pane, click <~ = and select Add Missing Variables.

Hyland DataTransfer searches all procedures for program variables referenced within the procedure
code. Any referenced program variables that do not exist are created.
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Adding Missing Variables for a Single Procedure
To add missing variables for a single Hyland DataTransfer procedure, complete the following steps.
1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to add a variable and either right-click it
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.

2. Select the procedure for which you want to search for missing variables.

3. Inthe Procedure Editor pane, click 50 .

Hyland DataTransfer searches the selected procedure for program variables referenced within the
procedure code. Any referenced program variables that do not exist are created.

Modifying Variables
To modify a variable, complete the following steps.
1. Perform one of the following actions.

e In the Job Dashboard, select the job for which you want to edit a variable and either right-click it
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.

In the Program Variables pane, click the All tab.

Select the variable you want to modify and either right-click it and select Modify or click
In the Edit Variable dialog box, in the Variable name field, type the name of the variable.
Click Apply.

Click OK.

The name of the variable is modified, and its information appears in the Program Variables pane.

S

Deleting Variables
To delete a variable, complete the following steps.
1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to delete a variable and either right-click
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.
2. Inthe Program Variables pane, click the All tab.
3. Select the variable you want to delete and either right-click it and select Delete or click = .

The variable is deleted and is removed from the Program Variables pane.
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Importing Variables

You can import variables from an XML file by doing the following.

1.

4.

Perform one of the following actions.

¢ Inthe Job Dashboard, select the job for which you want to import a variable and either right-click
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.
Click ¢~ ~ and select Import.

In the Import Variable dialog box, click the Browse button and navigate to the file that you want to
import or type the location of the file in the File field.

Click OK.

Exporting Variables

Note: You cannot export variables in tablet view.

You can export variables to an XML file by doing the following.

1.

Perform one of the following actions.

In the Job Dashboard, select the job for which you want to export a variable and either right-click it
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

Select Configuration > Procedures.
Click ¢~ = and select Export.

Save the file to the appropriate location.

Searching Variables

You can search for whole variables or partial text of variables.

1.

2.

3.

Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to search a variable and either right-click
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.

In the Program Variables pane, perform one of the following actions.
e To search for watched variables, click the Watch tab.

e To search through all variables, click the All tab.

In the text field in the Program Variables pane, type the text for which you want to search. You can
use whole words or partial text; if you use partial text, all items starting with the beginning character
are returned in the search. Use % as the wildcard character for partial text searches.

For example, if you search for #c%, all variables that start with #c (including the whole variable #c)
are returned in the search.

Press Enter on your keyboard.

Matches that are found are displayed in the Program Variables pane. If no matching text is found in
the search, the pane does not display any entries.
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Finding Unused Variables

You can search all procedures to find references to variables that are not being used. Program variables
that appear in procedures in any part of the code or in code that is commented out are considered used
variables.

1. Perform one of the following steps.

¢ In the Job Dashboard, select the job for which you want to search a variable and either right-click
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.

2. Inthe Program Variables pane, click = and select Find Unused.

In the Unused Program Variables pane, If you have permission to edit program variables, you can
delete unused variables. Perform one of the following actions.

e To delete a single variable, select it and click = .

o To delete multiple variables, select the variables by clicking a variable and pressing and holding
the Ctrl key as you click each variable with your mouse. Next, click = .

Watching Variables

When you run a job in interactive mode and view it in the window that appears when you edit a job, the
Program Variables pane displays all program variables. If you have many program variables, to more
easily view results for specific variables, you can place such variables in the Watch tab.

To watch a variable, complete the following steps.
1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to watch a variable and either right-click
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.

2. To watch all program variables referenced within a procedure, click *' in the Procedure Editor. All
referenced variables are added to the Watch tab.

3. To watch a single variable or all variables, in the Program Variables pane, click the All tab.

e To watch a single variable, select the variable you want to watch and either right-click it and
select Watch or click *='. The variable is moved to the Watch tab.

e To watch multiple variables, select the variables by clicking a variable and pressing and holding

the Ctrl key as you click each variable with your mouse. Next, click = . The variables are moved
to the Watch tab.
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Clearing Variables From the Watch List
To clear variables from the watch list, complete the following steps.
1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to clear a watch variable and either right-
click it and select Edit or click the Edit button. In the window that appears, click the Procedures
tab.

e Select Configuration > Procedures.
2. In the Program Variables pane, click the Watch tab.
3. Perform one of the following actions.

e To clear a single variable, select it and click

e To clear multiple variables, select the variables by clicking a variable and pressing and holding
the Ctrl key as you click each variable with your mouse. Then click

e To clear all watch variables, either do not select a variable, or select a single variable. Click

"

Moving Variables to Groups
To move a variable to a group, complete the following steps.
1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to move a variable to a group and either
right-click it and select Edit or click the Edit button. In the window that appears, click the
Procedures tab.

e Select Configuration > Procedures.
2. Inthe Program Variables pane, click the All tab.
Perform one of the following actions.

e To move a single variable, select the variable that you want to move and either right-click it and
select the Move to Group or click = .

e To move multiple variables, select the variables by clicking a variable and pressing and holding
the Ctrl key as you click each variable with your mouse. Next, click ‘= . The Move Variable to
Group dialog box appears.

4. Inthe Move Variable to Group dialog box, from the Group drop-down box, select the group to which
you want to move the variable.

5. Click OK.

The variable is moved to the specified group.
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Configuring Groups

You can use groups to manage variables for similar types. For example, you can create a Form Variables
group in which to place form variables.

Refer to the following topics for more information.

e Adding Groups

e Renaming Groups

e Deleting Groups

Adding Groups
To add a group, complete the following steps.
1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to add a group and either right-click it
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.

In the Program Variables pane, click the Groups tab.

Click & .

In the Add Group dialog box, in the Name field, type the name of the field.
Click OK.

The group is added and appears in the Groups tab.

ok~ 0D

Renaming Groups
To rename a group, complete the following steps.
1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to rename a group and either right-click
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.
2. In the Program Variables pane, click the Groups tab.
Select the group you want to rename and either right-click it and select Rename or click & .
In the Rename Group dialog box, in the Name field, type the name of the group and click OK.

The name of the group is updated, and its information appears in the Program Variables pane.
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Deleting Groups

To delete a group or all groups, complete the following steps.

1.

4.

Perform one of the following actions.

e In the Job Dashboard, select the job for which you want to delete a group and either right-click it
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.
In the Program Variables pane, click the Groups tab.
Perform one of the following steps.

e Select the group you want to delete and either right-click it and select Delete or click '='.

e To delete all groups, click =",

In the Confirm Delete dialog box, click Yes to delete the group.

Configuring Libraries

Refer to the following topics for more information.

Adding Libraries

Renaming Libraries
Specifying Control Libraries
Deleting Libraries

Importing and Exporting Libraries and Procedures

Note: In the Procedures pane, you can click * to expand all buttons in the pane; to collapse them, click

)

Adding Libraries

To add a library, complete the following steps.

1.

Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to add a library and either right-click it
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.

Select the type of procedure to which you want to add a library and either right-click it and select Add
Library or click B .

In the Add Library dialog box, in the Library Name field, type the name of the library.

In the Description field, type descriptive text about the library.

Click OK.

The library is added and appears in the Procedures pane.
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Renaming Libraries

To rename a library, complete the following steps.

1.

Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to rename a library and either right-click
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.

Select the library you want to rename and either right-click it and select Rename Library or click E.
In the Rename Library dialog box, in the Library Name field, type the name of the library.

Click OK.

The library is renamed, and its information is refreshed in the Procedures pane.

Specifying Control Libraries

You set a library as the control library when you want the library to control the flow of the process. A
control library is the library from which the first code is run for each of the Match, Review, and Upload
processes.

To specify control libraries, complete the following steps.

1.

Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to specify a control library and either
right-click it and select Edit or click the Edit button. In the window that appears, click the
Procedures tab.

e Select Configuration > Procedures.

Select the library you want to set as the control library and either right-click it and select Control
Library or click =

The library is configured as the control library, and the & jcon appears next to the library.

Deleting Libraries

Note: You cannot delete a library that contains procedures. You must first delete all procedures from the
library before deleting the library.

To delete a library, complete the following steps.

1.

Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to delete a library and either right-click it
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.

2. Select the library you want to delete and either right-click it and select Delete Library or click =¥

The library is deleted and is removed from the Procedures pane.
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Configuring Procedures

You can share procedures with other workspaces, and you can import procedures from and export
procedures to an XML file.

To open the Procedure Editor, perform one of the following actions.
e Select Configuration > Procedures from the main application toolbar.

¢ In the Job Dashboard, select the job for which you want to configure procedures and then either
right-click it and select Edit or click the Edit button; then, in the window that appears, click the
Procedures tab.

Refer to the following topics for more information.
e Understanding Procedure Keyboard Shortcuts
e Adding Procedures

e Understanding Procedure Icons

e Configuring Procedure Code

e Copying Procedures

e Renaming Procedures

e Adding and Removing Comments to Lines

e Finding Unused Procedures

e Finding Referenced Procedures

e Activating Procedures

e Deactivating Procedures

e Removing Sharing on Procedures

¢ Rolling Back Procedures

e Searching Procedures

e Importing and Exporting Libraries and Procedures

Understanding Procedure Keyboard Shortcuts

Refer to the following table for descriptions of shortcut keys for the Procedure Editor.

Shortcut Key Description
SHIFT+F8 Continue

SHIFT+F6 Next line
CTRL+ALT+F Find/Replace
CTRL+ALT+W Watch all variables
CTRL+ALT+M Add missing variables
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Shortcut Key Description
CTRL+ALT+B Clear breakpoints
CTRL+1 Toggle comment
CTRL+ALT+S Save

Adding Procedures
To add a procedure, complete the following steps.
1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to add a procedure and either right-click
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.

2. Select the library to which you want to add a procedure and either right-click it and select Add
Procedure, or click ==.

3. Inthe Add Procedures dialog box, perform one of the following actions.
e To add a new procedure, complete the following steps.
3. Click the Add Procedure tab.
4. In the Procedure Name field, type the name of the procedure.
5. In the Description field, type descriptive text about the procedure.
e To add a procedure that is shared by another workgroup, complete the following steps.
1. Click the Add Shared Procedure tab.

2. From the Workspace drop-down box, select the workspace that contains the shared
procedure.

3. In the Procedure Name drop-down, select the procedure.

Note: Only procedures that belong to workspaces in staged or active mode are available for
sharing.

4. Click OK.

The procedure is added and displays in the Procedures pane.
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Understanding Procedure Icons

Refer to the following table for a description of the icons that appear next to procedures in the Procedures

pane.

Icon

Description

Procedure is deactivated, has been modified, and is not shared.

Procedure is shared, has been modified since it was added from the workspace
sharing it, and is deactivated.

Procedure is not shared and has been modified.

Procedure is not shared, contains errors, and has been modified.

=
e Procedure is shared and has been modified since it was added from the workspace
£ sharing it.
W Procedure is not shared, contains errors, and has not been modified.
Procedure has not been modified
| S—

If you are working in a workspace version in edit mode, the procedure is not shared. If
you are working in a workspace version in a mode other than edit mode, this icon
displays for all procedures. The sharing status is unknown.

Procedure is not shared, contains errors, and is deactivated.

Procedure is not shared and is deactivated.

Procedure is not shared, has been modified, and is deactivated.

Procedure is shared.

Procedure is shared and has since been updated in the workspace sharing it.

Configuring Procedure Code

You configure procedure code in the Procedure Editor, which you can open by doing one of the following.

In the Job Dashboard, select the job for which you want to add a procedure and either right-click it
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

Select Configuration > Procedures.
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For information about configuring logic for procedures, refer to Appendix A: Programming Concepts.
Hyland DataTransfer highlights code syntax as follows.

Comments, beginning with ! or from ! to the end of the line, appear in green.

I zearch for a match
!

Keywords, which are reserved words such as begin-procedure, begin-select, let, do, and so on,
appear blue.

begin-procedure
!

bhegin-=select
last A5 L
first A%
=sn as S8
substr(ta
substrito
substrito
FREOM nu n
WHERE nua n
AND nu n
AND rnua n
end-=seleact
1

end-procedure

Text strings appear in maroon.
SELECT #nu id, 'PERS'

Global variables appear in pink.

! setup globals

let fdbname = _GL_DENAME
let fusername = _GL_TSERID
let $f ban w = GL.STATUS

SKIP, STOP and the on-error=display-error (which appears in the begin-sql line) appear in red.
if $t_ssn 1= $f_s:
zkip SUSPENT,

Errors are highlighted in red. Hover your mouse over the number to display a tooltip with information
about the issue.

if izmull (s
lda =setu

end-if

!

| zearch for

|
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Copying Procedures
To create a duplicate of a procedure, complete the following steps.
1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to copy a procedure and either right-
click it and select Edit or click the Edit button. In the window that appears, click the Procedures
tab.

e Select Configuration > Procedures.

2. Select the procedure you want to copy and either right-click it and select Copy Procedure, or click
4,

The procedure is copied, and the new procedure is added under the original procedure in the
Procedures pane.

Renaming Procedures
To rename a procedure, complete the following steps.
1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to rename a procedure and either right-
click it and select Edit or click the Edit button. In the window that appears, click the Procedures
tab.

e Select Configuration > Procedures.

2. Select the procedure you want to rename and either right-click it and select Rename or click .“The
Rename Procedure dialog box appears.

In the Procedure Name field, type the name of the procedure.
Click OK.

The procedure is renamed and is updated in the Procedures pane. In addition, the first line of code
(begin-procedure <procedure name>) is updated to reflect the new procedure name.

Adding and Removing Comments to Lines

You can quickly add or remove the comment symbol (! ) from the start of selected lines by completing
the following steps.

1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to add or remove a comment and either
right-click it and select Edit or click the Edit button. In the window that appears, click the
Procedures tab.

e Select Configuration > Procedures.

2. In the Procedures pane, select procedure for which you want to add or remove comments.
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3. Select the line or lines to which you want to add or remove comments.
4. Inthe Procedure Editor pane, click = . One of the following occurs.
e If all selected lines start with !, excluding whitespace, the lines are uncommented.

e If one or more selected lines do not start with !, excluding whitespace, one ! is added to the start
of each selected line.

Finding Unused Procedures

You can search all procedures to find references to procedures that are not being used. Control, Match
Result, and Data Population procedures are not included in the unused procedures search.

1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to search a procedure and either right-
click it and select Edit or click the Edit button. In the window that appears, click the Procedures
tab.

e Select Configuration > Procedures.

In the Procedures pane, click ©~ = and select Find Unused Procedures.

In the Unused Procedures pane, if you have permission to edit procedures, you can delete unused
procedures. Perform one of the following actions.

e To delete a single procedure, select it and click =" .

o To delete multiple procedures, select the procedures by clicking a procedure and pressing and
holding the Ctrl key as you click each procedure with your mouse. Next, click = .

4. In the dialog box, click Yes to delete the procedure.

If you try to delete procedures for which you do not have edit permissions, those procedures are not
deleted.

Finding Referenced Procedures

You can search for procedures that are referenced by other procedures by completing the following
steps.

1. Perform one of the following actions.

¢ Inthe Job Dashboard, select the job for which you want to search for a referenced procedure and
either right-click it and select Edit or click the Edit button. In the window that appears, click the
Procedures tab.

e Select Configuration > Procedures.

2. In the Procedures pane, select the procedure for which you want to search other procedures for
references.

3. Click @ = and select Referenced By.

Hyland DataTransfer searches all procedures for references to the selected procedure. When the
search completes, a dialog box appears and displays the procedures that contain references to the
procedure you selected.
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Deactivating Procedures

When you deactivate a procedure, the procedure is not used when logic is run; it is skipped. You can
reactivate procedures that have been deactivated.

To deactivate a procedure, complete the following steps.
1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to deactivate a procedure and either
right-click it and select Edit or click the Edit button. In the window that appears, click the
Procedures tab.

e Select Configuration > Procedures.
2. Right-click the procedure you want to deactivate and select Deactivate.

The procedure is deactivated.

Activating Procedures
To activate a procedure that is deactivated, complete the following steps.
1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to activate a procedure and either right-
click it and select Edit or click the Edit button. In the window that appears, click the Procedures
tab.

e Select Configuration > Procedures.
2. Right-click the procedure you want to activate and select Activate.

The procedure is activated.

Removing Sharing on Procedures
To remove sharing on a procedure that is shared with another workspace, complete the following steps.
1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to remove sharing on a procedure and
either right-click it and select Edit or click the Edit button. In the window that appears, click the
Procedures tab.

e Select Configuration > Procedures.

2. Select the procedure and either right-click it and select Remove Sharing, or click & .

Sharing is removed on the procedure.
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Rolling Back Procedures

If changes have been made and committed to a procedure, you can use a previous version (roll back) of

it.

1. Perform one of the following actions

In the Job Dashboard, select the job for which you want to roll back a procedure and either right-
click it and select Edit or click the Edit button. In the window that appears, click the Procedures
tab.

Select Configuration > Procedures.

2. Select the procedure you want to roll back and either right-click it and select Rollback Procedure or
click .

The Rollback Manager dialog box appears and displays the following information about previous
versions of the procedure.

Name: Name of the procedure.

Status: Status of the procedure (pending, current, or dated).
Version Date: Date on which the version was created.
Created By: Username of the user who created the version.

Comments: Comments that were added about the version.

Select the version to which you want to revert and click Rollback.

4. In the dialog box, to use the selected version, click Yes.

The procedure is updated to use the selected previous version of the procedure.

Obtaining the Latest Version of Procedures

If changes have been made to and committed to a procedure, you can obtain the latest version of it.

1. Perform one of the following actions.

In the Job Dashboard, select the job for which you want to obtain the latest version of a
procedure and either right-click it and select Edit or click the Edit button. In the window that
appears, click the Procedures tab.

Select Configuration > Procedures.

2. Select the procedure for which you want to obtain the latest version and either right-click it and select
Get Latest or click &,

The procedure is updated to the latest version.
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Searching Procedures

You can search for information in all procedures or in a specific procedure. Searches use case-sensitive
text.

1. Perform one of the following actions.

¢ In the Job Dashboard, select the job for which you want to search a procedure and either right-
click it and select Edit or click the Edit button. In the window that appears, click the Procedures
tab.

e Select Configuration > Procedures.
2. Perform one of the following actions.

e To search for information in all procedures, click £8 in the Procedures toolbar.

e To search for text within a specific procedure, select the procedure and click &8 in the toolbar of
the Procedure Editor.

3. Inthe Find/Replace dialog box, complete the following substeps.
1. In the Find field, type the text for which you want to search.

2. In the Replace field, type the text with which you want to replace the text in the Find
field.

3. Hyland DataTransfer searches all procedures for the text that you entered. If a match is
found, the matched text is highlighted in yellow in the Procedure Editor. If no matches
are found, a dialog box appears and indicates that there are no matches.

4. To find the next occurrence of the text, click Next. When no more matches are found, the
first match results are displayed again. If no matches were found, a dialog box appears
and indicates that no matches were found.

5. To replace the found text with the text you specified in the Replace field, click Replace.

Importing and Exporting Libraries and Procedures
Note: You cannot import or export libraries or procedures in tablet view.

You can import procedures and libraries from XML documents, and you can export them to XML
documents. You can:

o Export all procedures.

e Export a single procedure.

e Export a single library, which includes all its procedures.
e Import one or more libraries, including their procedures.
e Import a single procedure into a library.

Refer to the following topics for more information.

e Importing Libraries

e Exporting Single Libraries

e Importing Single Procedures

e Exporting Single Procedures
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e Exporting All Procedures and Libraries

Importing Libraries

You can import files that contain either the entire procedure tree or a single library and its corresponding
procedures.

Note: You cannot import libraries in tablet view.

Note: XML files that contain a single exported library are named beginning with L/B (for example,
LIB55.xml). XML files that contain all libraries and procedures (the entire procedure tree) are named
beginning with PRCS (for example, PRCS987.xml.) You can import XML files of these types. If you try to
import a file type other than a library, a popup message appears that indicates import did not complete
because the file type was not appropriate.

1. Perform one of the following actions.

e Inthe Job Dashboard, select a job and either right-click it and select Edit or click the Edit button.
In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.
Click = T and select Import Libraries.

In the Import Libraries dialog box, click the Browse button and navigate to the XML file that contains
the libraries you want to import, or type the location of the file in the File field.

4. Check the Update Existing Entities check box to update an existing library, with the same name as
the library you are importing, with the library you are importing.

If you do not check this check box, and there is an existing library with the same name as the library
you are importing, DUPLICATE- is appended to the start of the name of the library you are importing;
the existing library is not updated. If there is a library with the name DUPLICATE-</ibrary_name>,
DUPLICATE(2)- is appended to the start of the name. The number continues to be incremented so
that all libraries have unique names.

5. Click OK.

The Import Report appears and displays information about the import.

Exporting Single Libraries

Note: You cannot export single libraries in tablet view. To export a single library, complete the following
steps.

1. Perform one of the following actions.

¢ Inthe Job Dashboard, select a job and either right-click it and select Edit or click the Edit button.
In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.
2. Select the appropriate library.

Click ./# = and select Export.
4. Save the file in the appropriate location.

XML files that contain libraries are named starting with L/B (for example, LIB55.xml). You can import
files of this type when you are importing libraries (when you import a single library and all its
procedures).
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Importing Single Procedures
You cannot import single procedures in tablet view.

Note: XML files that contain a single exported procedure are named beginning with PROC (for example,
PROC123.xml). You can import XML files of this type. If you try to import a file type other than a single
procedure, a popup message appears that indicates import did not complete because the file type was
not appropriate.

To import a single procedure, complete the following steps.
1. Perform one of the following actions.

¢ Inthe Job Dashboard, select a job and either right-click it and select Edit or click the Edit button.
In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.
Select the library into which you want to import the procedure.

Click #~ - and select Import.

In the Import Procedure dialog box, click the Browse button and navigate to the file that contains the

procedure you want to import, or type the location of the file in the File field.

5. Check the Update Existing Entities check box to update an existing procedure, with the same name
as the procedure you are importing, with the procedure you are importing.

If you do not check this check box, and there is an existing procedure with the same name as the
procedure you are importing, DUPLICATE- is appended to the start of the name of the procedure you
are importing; the existing procedure is not updated. If a procedure exists with the name
DUPLICATE-<procedure_name>, DUPLICATE(2)- is appended to the start of the name. The number
continues to be incremented so that all procedures have unique names.

6. Click OK.

The Import Report appears and displays information about the import.

Exporting Single Procedures

Note: You cannot export single procedures in tablet view. To export a single procedure, complete the
following steps.

1. Perform one of the following actions.

¢ Inthe Job Dashboard, select the job a job and either right-click it and select Edit or click the Edit
button. In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.
Select the procedure you want to export.
Click .~ - and select Export.

Save the file in the appropriate location.

XML files that contain a single exported procedure are named beginning with PROC (for example,
PROC123.xml). You can import files of this type when you import a single procedure.
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Exporting All Procedures and Libraries

Note: You cannot export all procedures and libraries in tablet view.

You can export all procedures and libraries (the entire procedure tree) as an XML file by completing the
following steps.

1.

Perform one of the following actions.

¢ Inthe Job Dashboard, select a job and either right-click it and select Edit or click the Edit button.
In the window that appears, click the Procedures tab.

e Select Configuration > Procedures.
Perform one of the following actions.
e Without clicking any selection in the Procedures pane, click . ~ and select Export.

e Select a procedure type node (such as Match Process), library, or procedure; then, click < ~ and
select Export All.

Save the file in the appropriate location.

XML files that contain all exported procedures are named beginning with PRCS (for example,
PRCS987.xml). You can import files of this type when you import libraries (when you import the entire
procedure tree).

Configuring Variable Maps

You can use variable maps to map program variables to a label and description. You can also use
variable maps to provide a default value for a variable.

You can also use the InitializeVars function with variable maps. Refer to Appendix A: Programming
Concepts.

Refer to the following topics for more information.

Adding and Modifying Variables Maps
Deleting Variable Maps

Copying Variable Maps

Removing Sharing on Variable Maps

Rolling Back Variable Maps

Obtaining the Latest Versions of Variable Maps
Exporting Variable Maps

Importing Variable Maps
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Adding and Modifying Variables Maps

To add a variable mapping, complete the following steps.

1. Select Configuration > Variable Maps.
2. In the Add Variable Mapping Administration dialog box, perform one of the following actions.

To add a new variable map, click ‘=¥ to display the Add Variable Mapping dialog box.

6. To add a new variable map, click the Add Variable Map tab. Then, in the Name field, type
the name of the variable map.

7. To add a variable map that another workspace is sharing, click the Add Shared Variable
Map tab. Then, from the Workspace drop-down box, select the workspace that is sharing
the variable map, and select the variable map from the Variable Map drop-down box.

8. Click OK.

To modify a variable map, select the variable map and either right-click it and select Edit or click

1. In the Edit Variable Mapping dialog box, in the Name field, you can modify the name of the
variable map by typing a name.

2. In the Description field, you can modify the description by typing descriptive text.

3. Inthe Program Variables pane, you can perform actions such as add, modify, watch,
import, and export variables. Refer to Configuring Variables for more information.

3. To add a mapping between a variable and a label or default value, complete the following substeps.

1. In the rightmost pane, click =2 .

2. Inthe New Variable Mapping dialog box, in the Name field, type the label you want to
assign to the variable.

In the Description field, optionally type descriptive text about the variable mapping.
In the Variable field, optionally type the program variable you want to map.

In the Default field, optionally type the default value to which you want to map the
program variable.

6. Click OK.

4. To modify a variable mapping, perform one of the following actions.

If you are using desktop view, in the rightmost pane, double-click the cell you want to modify and
type the appropriate value. You can also modify the variable by clicking the entry you want to
modify in the rightmost pane and dragging and dropping a variable from the Program Variables
pane to the rightmost pane.

If you are using tablet view, complete the following steps.
1. In the rightmost pane, click «.

2. Inthe New Variable Mapping dialog box, in the Name field, type the label you want to
assign to the variable.

In the Description field, optionally type descriptive text about the variable mapping.

4. In the Variable field, optionally type the program variable you want to map.
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5. In the Default field, optionally type the default value to which you want to map the
program variable.

6. Click OK.

5. To delete a variable mapping, select the mapping you want to delete in the rightmost pane and click

Deleting Variable Maps
To delete a variable map, complete the following steps.
1. Select Configuration > Variable Maps.

2. Inthe Variable Map Administration dialog box, select the variable map you want to delete and
either right-click it and select Delete or click ='.

The variable map is deleted and is removed from the Variable Map Administration dialog box.

Copying Variable Maps
To create a duplicate of a variable map, complete the following steps.
1. Select Configuration > Variable Maps.

2. In the Variable Map Administration dialog box, select the variable map you want to copy and either
right-click it and select Copy or click "1

A copy of the variable map is created and appears in the Variable Map Administration dialog box.

Removing Sharing on Variable Maps

To remove sharing on a variable map that is shared with another workspace, complete the following
steps.

1. Select Configuration > Variable Maps.
2. Inthe Variable Map Administration dialog box, select the variable for which you want to remove

sharing and either right-click it and select Remove Sharing, or click &8
Sharing is removed on the variable map.

Rolling Back Variable Maps

If changes have been made and committed to a variable map, you can use a previous version (roll back)
of it.

1. Select Configuration > Variable Maps.

2. Inthe Variable Map Administration dialog box, click the variable map you want to roll back and
either right-click it and select Rollback, or click =. The Rollback Manager dialog box appears and
displays the following information.

e Name: Name of the variable map.
e Status: Status of the variable map (current or dated).

e Version Date: Date and time on which the version was created.
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o Created By: Username of the user who created the variable map.

e Comments: Comments that were added by the user.

3. Select the previous version to which you want to revert and click Rollback.

The previous version is loaded.

Obtaining the Latest Versions of Variable Maps

If changes have been made to and committed to a variable map, you can obtain the latest version of it.

1.
2.

Select Configuration > Variable Maps.

In the Variable Map Administration dialog box, click the variable map for which you want to obtain
the latest version and either right-click it and select Get Latest or click ‘&

Exporting Variable Maps

Note: You cannot export variable maps in tablet view.

You can export a variable map to an XML file by doing the following.

1.

2
3.
4

Select Configuration > Variable Maps.
In the Variable Map Administration dialog box, select the variable map you want to export.
Click” ~ and select Export.

Save the file to the appropriate location.

Importing Variable Maps

Note: You cannot import variable maps in tablet view.

1.

2.
3.

Select Configuration > Variable Maps.
In the Variable Map Administration dialog box, click < ~ and select Import.

In the Variable Map dialog box, click the Browse button and navigate to the file that you want to
import or type the location of the file in the File field.

Check the Update Existing Entities check box to update an existing variable map, with the same
name as the variable map you are importing, with the variable map you are importing.

If you do not check this check box, and there is an existing variable map with the same name as the
variable map you are importing, DUPLICATE- is appended to the start of the name of the variable
map you are importing; the existing variable map is not updated. If a variable map exists with the
name DUPLICATE-<index_map_name>, DUPLICATE(2)- is appended to the start of the name. The
number continues to be incremented so that all variable maps have unique names.

Click OK.
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Configuring EDI formats

You can process electronic data interchange (EDI) files in Hyland DataTransfer. Hyland DataTransfer
manages EDI formats as XML files. An EDI format defines the rules by which the EDI input file is
converted to XML. You must specify an EDI format for each EDI input file you want to process. After you
define the EDI format, configure an EDI header and use it for the appropriate job that processes the EDI
input file.

Note: EDI formats are supported in Hyland DataTransfer 6.4.4 and higher. Refer to the following topics
for more information.

e Understanding EDI files

e Adding and modifying EDI formats

e Deleting EDI formats

e Copying EDI formats

e Verifying EDI formats

e Removing sharing on EDI formats

e Rolling back EDI Formats

e Obtaining the latest versions of EDI formats
e Exporting EDI formats

e Importing EDI formats

Understanding EDI files

An EDI file begins with a segment ID (a prefix of two or three letters, such as ISA). Each line of afile is a
string that contains fields, separated by a delimiter. Segments can be nested. EDI segments translate to
XML tags or nodes; the fields within a segment translate into XML leaf nodes. With an EDI format, you
define the nesting rules and leaf nodes so that Hyland DataTransfer can construct the corresponding
XML.

For example:
ISA*00! 100!  !ZZ!TXAPP 1221003560

1080906!2015!U0!00402!130906001!0!T!$\
GS!AF!TXAPP!DBU!20080906!1257!080906001!X!004020ED0020\

ST!189!062180001\
BGN*00*062180001!20080906*1257 ! CT\
N1!TM!!ZZ!TXAPP\

NL1!AT!!73!003560\

REF!48!0800000638! FRESHMAN APPLICATION ID\
DTP!196!CM!200809\

REF!SY! ! STUDENT DECLINED TO PROVIDE SSN\
REF!27!A123456789BC!I-551 NUMBER\
DTP!102!D8!19991001\
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INI!1!102\

IN2!05!TEST\

IN2!02!FIRST\

IN2!03!M\

IN2!09!JR\

In the preceding example, prefixes include ISA, GS, and ST. The EDI file includes /, \, and * as delimiters.

IN2 is the child segment of IN7; the IN1 segment begins an IN1 loop, which can contain a various
assortment of its possible segment children. The file translates logically into the following XML format.

<ISA>
<GS>... </GS>
<ST>... </ST>
<IN1>
<IN2>... </IN2>
<IN2>... </IN2>
</IN1>
</ISA>

The segments translate to XML tags and the fields within a segment translate into XML leaf nodes.
<IN2>
<fieldl>1</fieldl>
<field2>102</field2>

</IN2>

Adding and modifying EDI formats
To add or modify an EDI format, complete the following steps.
1. Select Configuration > EDI Formats.
2. In the EDI Format Administration dialog box, complete one of the following actions.
e Toadd a new EDI format, click “ and complete the following actions.
In the Add EDI Format dialog box, complete one of the following actions.

e To add a new EDI format, click the Add EDI Format tab. In the Name field, type the name of
the EDI format.
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To add an EDI format that another workspace is sharing, click the Add Shared EDI Format
tab. From the Workspace list, select the workspace that is sharing the EDI format and select
the EDI format from the EDI Format list.

Click OK.

e To modify an EDI format, select the EDI format and click «.

3. Inthe Edit EDI Format <Format_name> dialog box, in the Name box, type a name to modify the
name of the EDI format.

4. In the Description box, enter a description for the EDI format.

In the Delimiters box, type the file delimiters (for example, /). You can provide multiple delimiters,
separated by commas.

6. Add or modify child segments by completing the following substeps.

N o o A

1. Complete one of the following actions.
To add a child segment, in the Child Segments pane, click “« .
To modify a child segment, select the segment and click «

2. Inthe Position box, type the position of the segment. The position is used for display
purposes only; ordering is not relevant to the XML format.

3. In the Segment box, type the prefix that identifies the segment. It must match the
segment ID as it appears in the EDI input file.

4. Inthe Alias box, type the alternate name used for the segment.

The Fields pane displays the fields contained by the segment. To add or modify a field,
complete the following substeps.

Complete one of the following actions.

e To add a field, click & .

o To modify a field, select the field and click «.

In the Name field, type the name of the field. Field names must be unique for each node.

In the Order field, type the order or position of the field as it appears in the segment. Each
field must have a unique order.

Click Apply to apply your changes. You can continue to add or edit fields in the dialog box.
Click OK to close the dialog box.
To delete a field, select the field and click = .

You can continue to add child segments to the segment in the Child Segments pane and
then add and modify fields for the child segment, as appropriate. The dialog box caption for

the Edit EDI_Format displays the path of the segment so that you can identify your location.

7. To delete a child segment, select the segment you want to delete and either right-click it and select
Delete or click '='.

8. Create an EDI header that uses the EDI format you defined. Refer to Configuring and modifying EDI
headers and header variables Configuring and modifying EDI.
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Deleting EDI formats
To delete an EDI format, complete the following steps.

1. Select Configuration > EDI Formats.

2. In the EDI Format Administration dialog box, select the EDI format you want to delete and click = .

Copying EDI formats
To create a duplicate of an EDI format, complete the following steps.
1. Select Configuration > EDI Formats.

2. In the EDI Format Administration dialog box, select the EDI format you want to copy and click 'l

Verifying EDI formats
To verify that your EDI input file converts to XML properly, complete the following steps.

1. Select Configuration > EDI Formats.

+

In the EDI Format Administration dialog box, select the EDI format you want to test and click =i .

In the EDI to XML File dialog box, click the Browse button to navigate to the EDI input file you want
to test.

4. Click OK.

Hyland DataTransfer converts the EDI file to an XML file and streams it to your browser.

Removing sharing on EDI formats

To remove sharing on an EDI format that is shared with another workspace, complete the following steps.

1. Select Configuration > EDI Formats.
2. Inthe EDI Format Administration dialog box, select the EDI format for which you want to remove

sharing and click =}

Rolling back EDI Formats

If changes have been made and committed to an EDI format, you can roll back to a previous version.
1. Select Configuration > EDI Formats.

2. Inthe EDI Format Administration dialog box, select the EDI format you want to roll back and either
right-click it and select Rollback or click .

The Rollback Manager dialog box displays the following information.
¢ Name: Name of the EDI format.
e Status: Status of the EDI format (current or dated).

e Version Date: Date and time the version was created.
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e Created By: User name of the user who created the EDI format.

e Comments: Comments that were added by the user.

3. Select the previous version to which you want to revert and click Rollback.

Obtaining the latest versions of EDI formats

If changes have been made and committed to an EDI format, you can obtain the latest version of it.

1.
2.

Select Configuration > EDI Formats.

In the EDI Format Administration dialog box, click the EDI format for which you want to obtain the
latest version and click ‘&

Exporting EDI formats

To export an EDI format to an XML file, complete the following steps.

Note: You cannot export EDI formats in tablet view.

1.

2
3.
4

Select Configuration > EDI Formats.
In the EDI Format Administration dialog box, select the EDI format you want to export.
Click ¢ ~ and select Export.

Save the file to the appopriate location.

Importing EDI formats

To import EDI formats, complete the following steps.

Note: You cannot import EDI formats in tablet view.

1.
2.
3.

Select Configuration > EDI Formats.
In the EDI Format Administration dialog box, click «© = and select Import.

In the Import EDI Format dialog box, click the Browse button and navigate to the file that you want
to import or type the location of the file in the File field.

Check the Update Existing Entities check box to update an existing EDI format, with the same name
as the EDI format you are importing, with the EDI format you are importing.

If you do not check this check box, and there is an existing EDI format having the same name as the
EDI format you are importing, DUPLICATE- is appended to the start of the name of the EDI format
you are importing and the existing EDI format is not updated. If an EDI format exists with the name
DUPLICATE-<EDI_format_name>, DUPLICATE(2)- is appended to the start of the name. The number
continues to be incremented so that all EDI formats have unique names.

Click OK.
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Configuring headers

Refer to the following topics for more information.

Understanding headers

Understanding header icons

Adding headers

Configuring and modifying headers and header variables
Removing sharing on headers

Rolling back headers

Obtaining the latest versions

Deleting headers

Exporting headers

Importing headers

Understanding headers

Headers define the import source, which is the input file with the data you will be loading. For example,
you may want to import student SAT scores and load them into your database, either linking the test
scores to existing records or creating new records of information. If that data is contained in a
spreadsheet of information in CSV format, you are using a delimited input file.

With Hyland DataTransfer, you map a data input source to a destination, usually mapping a column from
an input file to a database table column. Header variables comprise headers, which are input variables
that identify the field element and field order within the import file.

You can share headers with other workspaces, and you can import headers from and export headers to
an XML file.

Understanding header icons

The following table contains information about the header icons that appear in the Header Administration

dialog box.
Icon Description
: Header is shared.
=
7 Header is shared and has been modified since it was added from the workspace sharing it.
B

Header is not shared and has been modified.

Header has not been modified.
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Adding headers

To add a new header, complete the following actions.

1.
2.
3.

Select Configuration > Headers.
In the Header Administration dialog box, click “ .
Complete one of the following actions.
e To add a new header, click the Add Header tab.
6. Inthe Header Name field, type the name of the header.
7. From the Type drop-down box, select the type of header.
e Delimited
e Fixed-Width
o MS Excel
e Database
e XML
e EDI
e Hobsons Connect CRM
o Web Service
Note: EDI headers are supported in Hyland DataTransfer 6.4.4 and higher.
e To add a header that is shared by another workspace, click the Add Shared Header tab.

1. From the Workspace drop-down box, select the workspace that shares the header you want
to use.

2. From the Header drop-down box, select the header to use.
Click OK.

Configure the header and add header variables. Refer to Configuring and modifying headers and
header variables.

Configuring and modifying headers and header variables

Refer to the following topics for more information.

Configuring and modifying fixed-width headers and header variables
Configuring and modifying delimited headers and header variables
Configuring and modifying database headers

Configuring and modifying Microsoft Excel headers and header variables
Configuring and modifying XML headers and header variables
Configuring and modifying EDI headers and header variables
Configuring Hobsons Connect CRM headers and header variables

Configuring and modifying web service headers
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Configuring and modifying fixed-width headers and header variables

To configure a fixed-width header, complete the following steps.

1.
2.
3.

Select Configuration > Headers.

Click the fixed-width header you want to modify and click .

In the Header Editor dialog box, in the Header Information pane, complete the following substeps.
1. Type the name of the header in the Header Name field.

2. From the Match Result Display drop-down box, select the procedure that defines the information
that displays in the Results pane in the Job window when a match occurs. Refer to Configuring
Procedures for more information about procedures.

Note: For an overview of the steps required to configure jobs that use this query to populate the
Results pane in the Job window, refer to Specifying data displayed in Results pane.

3. Inthe File Properties pane, select the appropriate check box.

e Exclude First Row: Select this option to exclude the first row in the file when processing the
file. By default, this check box is not selected.

e Trim Whitespace: Select this option to remove the whitespace of data fields when
processing the data. By default, this check box is selected.

In the Header Variables pane, configure the header variables.

To add a new variable, click 2 in the Header Variables pane.

e If you do not click a variable in the table, the new variable appears as the first entry in the table.
e If you click a variable, the new variable is added below the selected variable.

To modify a header variable, complete the following substeps.

1. In the Header Variables pane, select the variable you want to modify and either right-
click itand select Edit or «

2. Inthe Edit Input Variable pane, in the Position field, type the number of the position of
the column. You may need to adjust the column position if a data file changes.

Use this field to move the column to a new position and to adjust all other columns to the left or to
the right, accordingly.

3. In the Name field, type the name of the variable.

4. From the Data Type drop-down box, select the data type of the variable (Character,
Number, or Date).

In the Name field, the appropriate symbol used to specify the data type of the variable is
appended to the first character of the name.

The $ (dollar sign) denotes a character variable, # (number sign) denotes a numeric variable, and
& (ampersand) denotes a date variable.

5. Select the Display check box to display the column in the pane that displays records in
the window that appears when you open a job.

6. Check the Sort check box to allow this column to be sorted in the Records panes in the
Edit Job window (Find click a job in the Job Dashboard and either click Edit or right-
click it and select Edit) or in the window that appears when a job is opened in the Job
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Dashboard (which appears when you select a record and either click Open or right-click
it and select Open) You can select up to ten columns to be sorted.

Note: A column that is set as the record key is also a sortable column and counts toward the ten
elements that can be sortable.

Sorting is based on the prefix of the input variable. If the prefix is &, sorting is based on
timestamp (which in the end is a numeric sort); if the prefix is $, sorting is alphanumeric; and if the
prefix is #, sorting is numeric.

These values are all stored as strings regardless of the prefix the values are converted to when
the user opens or edits a job to prepare a job. If, for example, the prefix is # and the value does
not convert to a numeric value, the value is managed as null; for #ZIP and value SEVEN, seven is
null when sorted.

7. In the Tooltip field, type the text that you want to appear when you hover your mouse
over the column in the pane that displays records that appear when you open a job.

8. In the Start field, type the start position of the column. Note the following information.
e The end position is adjusted accordingly.
e The width is not changed.
e The size of the columns next to the column (previous or next) are adjusted accordingly.
¢ You cannot change the start position to be larger than the end position.
e You cannot change the start position of a column that has a position of 7.
¢ When you move the start position to the left:

¢ If you move the start position to or before the start of any other column, the start position
of the other columns are moved to the right accordingly.

e If you move the start position to between the start and end range of another column, the
width and end position of the other column are changed, making the column smaller in
size.

o When you move the start position to the right:
e The column width is unchanged.
e The end position is adjusted accordingly.

e The width and end positions of the previous column are changed (making the column
largerin size).

9. Inthe End field, type the end position of the column. Note the following information.
e The end position cannot be before the start position.
¢ When you move the end to the left:

e The width of the column becomes smaller in size.

e The start position of the next column is adjusted.
e When you move the end to the right:

e The width of the column becomes larger in size.

e The start position of the next column is adjusted.
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11.
12.

10. In the Width field, type the width of the column. Note the following:
e The end position is adjusted accordingly.
e The start position of the next column is adjusted.

11. Click OK.

To prevent duplicate records when this header is used to run jobs, you can set a column as the
record key. Jobs run more quickly when a column is set as a record key.

Selecting a record key allows Hyland DataTransfer to process any records with different values in the
selected column at the same time. You do not need to select a column that guarantees unique
values, but the column should capture duplicate records. For example, if you select Last Name as the
key to a header and process a file that has many records with the last name Smith, which represent
different students, you prevent any two records with the same last name from being processed at the
same time.

To mark a column as the record key, select the column and click . The icon appears next to
the column to denote that it is the record key. You can mark one column only as the record key. You
cannot configure composite keys.

Note: A column that is set as the record key is also a sortable column and counts toward the ten
elements that can be sortable.

To delete a variable, select it and click '=' .

To preview data, in the Data Preview pane, click =

. In the Upload Preview File dialog box, click Browse and navigate to the file that you want to

preview, and then select it.

Click Preview to view the data in the Data Preview pane.

To clear data from the pane, click ‘=
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Configuring and modifying delimited headers and header variables
To configure a delimited header, complete the following steps.
1. Select Configuration > Headers.

2. In the Header Administration dialog box, click the delimited header you want to modify and click «

3. In the Header Editor dialog box, in the Header Information pane, complete the following substeps.
1. Type the name of the header in the Header Name field.

2. From the Match Result Display drop-down box, select the procedure that defines the
information that displays in the Results pane in the Job window when a match occurs.
Referto  Configuring Procedures for more information about procedures.

For an overview of the steps required to configure jobs that use this query to populate the Results
pane in the Job window, refer to Specifying data displayed in Results pane.

4. Inthe File Properties pane, select the appropriate check box:

¢ First Row Column Names: Select this option to load the first row of the data file into the file
header that is used for column names.

o Delimited: Select this option to specify that the input file is opened as a delimited file. Then click
the appropriate option.

e Tab: Select this option to specify that the file is opened as a tab-delimited file.

o Specify: Select this option to set a value by which the data is delimited in the field and
provide the value in the Specify field.

o Exclude First Row: Select this option to exclude the first row in the file when processing the
file. By default, this check box is not selected.

o Trim Whitespace: Select this option to remove the whitespace of data fields when
processing the data. By default, this check box is selected.

5. To add a new variable, click =¥ in the Header Variables pane.
e If you do not click a variable in the table, the new variable appears as the first entry in the table.

e If you click a variable, the new variable is added below the selected variable.
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6. To modify a variable, complete the following substeps.
1. In the Header Variables pane, select the variable you want to modify and click «

2. Inthe Edit Input Variable dialog box, in the Position field, type the number of the
position of the column. You may need to adjust the column position if a data file
changes.

In the Name field, type the name of the variable.

From the Data Type drop-down box, select the data type of the variable (Character,
Number, or Date).

In the Name field, the appropriate symbol used to specify the data type of the variable is
appended to the first character of the name.

The $ (dollar sign) denotes a character variable, # (number sign) denotes a numeric variable, and
& (ampersand) denotes a date variable.

5. Select the Display check box to display the column in the pane that displays records in
the window that appears when you open a job.

6. Select the Sort check box to allow this column to be sorted in the Records pane in the
Edit Job window (Find a job in the Job Dashboard and either click Edit or right-click it
and select Edit) or in the window that appears when a job is opened in the Job
Dashboard (which appears when you select a record and either click Open or right-click
it and select Open) You can select up to ten columns to be sorted.

Note: A column that is set as the record key is also a sortable column and count toward the ten
columns that can be sortable.

Sorting is based on the prefix of the input variable. If the prefix is &, sorting is based on
timestamp (which in the end is a numeric sort); if the prefix is $, sorting is alphanumeric; and if the
prefix is #, sorting is numeric.

These values are all stored as strings regardless of the prefix the values are converted to when
the user opens or edits a job to prepare a job. If, for example, the prefix is # and the value does
not convert to a numeric value, the value is managed as null; for #ZIP and value SEVEN, seven is
null when sorted.

7. Inthe Tooltip field, type the text that appears when you hover your mouse over the
column in the pane that displays records that appear when you open a job.

8. Click OK.

7. To prevent duplicate records when this header is used to run jobs, you can set a column as the
record key. Jobs run more quickly when a column is set as a record key.

Selecting a record key allows Hyland DataTransfer to process any records with different values in the
selected column at the same time. You do not need to select a column that guarantees unique
values, but the column should capture duplicate records. For example, if you select Last Name as the
key to a header and process a file that has many records with the last name Smith, which represent
different students, you prevent any two records with the same last name from being processed at the
same time.
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To mark a column as the record key, select the column and click . The &~ icon appears next to
the column to denote that it is the record key. You can mark one column only as the record key. You
cannot configure composite keys.

Note: A column that is set as the record key is also a sortable column and counts toward the ten
elements on which you can sort.

8. To delete a variable, select it and click '='.
9. Click .| .in the Data Preview pane

10. In the Upload Preview File dialog box, click Browse and navigate to the file that you want to preview,
and then select it.

11. Click Preview to view data in the Data Preview pane.

12. To clear data from the pane, click =,

Configuring and modifying database headers

You can use database headers to dynamically extract input data from the database and use it when a job
is run. For an overview of steps you must perform to dynamically obtain input data from the database for
a job, refer to Obtaining input data from the database.

To configure a database header, complete the following steps.

1. Select Configuration > Headers.

2. In the Header Administration dialog box, click the database header you want to modify and click «.

3. In the Header Editor dialog box, in the Header Information pane, complete the following steps.
1. Type the name of the header in the Header Name field.

2. From the Match Result Display drop-down box, select the procedure that defines the
information that displays in the Results pane in the Job window when a match occurs.
Refer to Configuring Procedures for more information about procedures.

For an overview of the steps required to configure jobs that use this query to populate the
Results pane in the Job window, refer to Specifying data displayed in Results pane.

3. Inthe Population Selection field, select the Database Population Selection procedure
that contains the query that dynamically extracts the input data. The query that captures
the header input variables and displays them in the Header Variables pane. Refer to
Configuring Procedures for more information about procedures.

For an overview of the steps required to configure jobs into which input data is automatically
extracted, refer to Obtaining input data from the database.

4. If you selected a query in the Population Selection field, to capture header variables from the query,
click Capture. The header variables display in the Header Variables pane.

Note: Hyland DataTransfer uses the aliases in the selected Database Population Selection
procedure to create and store column headings (input variables). You cannot edit these input
variables.

5. To edit a header variable, complete the following substeps.

1. In the Header Variables pane, select the variable you want to modify and click
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2. Inthe Edit Input Variable dialog box, in the Position field, type the number of the
position of the column. You may need to adjust the column position if a data file
changes.

In the Name field, type the name of the variable.

From the Data Type drop-down box, select the data type of the variable (Character,
Number, or Date).

In the Name field, the appropriate symbol used to specify the data type of the variable is
appended to the first character of the name.

The $ (dollar sign) denotes a character variable, # (number sign) denotes a numeric variable, and
& (ampersand) denotes a date variable.

5. Select the Display check box to display the column in the pane that displays records in
the window that appears when you open a job.

6. Select the Sort check box to allow this column to be sorted in the Records pane in the
Edit Job window (Find a job in the Job Dashboard and either click Edit or right-click it
and select Edit) or in the window that appears when a job is opened in the Job
Dashboard (which appears when you select a record and either click Open or right-click
it and select Open) You can select up to ten columns to be sorted.

Note: A column that is set as the record key is also a sortable column and count toward the ten
columns that can be sortable.

Sorting is based on the prefix of the input variable. If the prefix is &, sorting is based on
timestamp (which in the end is a numeric sort); if the prefix is $, sorting is alphanumeric; and if the
prefix is #, sorting is numeric.

These values are all stored as strings regardless of the prefix the values are converted to when
the user opens or edits a job to prepare a job. If, for example, the prefix is # and the value does
not convert to a numeric value, the value is managed as null, for #ZIP and value SEVEN, seven is
null when sorted.

7. Inthe Tooltip field, type the text that appears when you hover your mouse over the
column in the pane that displays records that appear when you open a job.

8. Click OK.

To prevent duplicate records when this header is used to run jobs, you can set a column as the
record key. Jobs run more quickly when a column is set as a record key.

Selecting a record key allows Hyland DataTransfer to process any records with different values in the
selected column at the same time. You do not need to select a column that guarantees unique
values, but the column should capture duplicate records. For example, if you select Last Name as the
key to a header and process a file that has many records with the last name Smith, which represent
different students, you prevent any two records with the same last name from being processed at the
same time.

To mark a column as the record key, select the column and click . The icon appears next to
the column to denote that it is the record key. You can mark one column only as the record key. You
cannot configure composite keys.

Note: A column that is set as the record key is also a sortable column and count toward the ten
columns that can be sortable.

To delete a variable, select it and click '=!



Hyland DataTransfer Administrator Guide

Configuring and modifying Microsoft Excel headers and header variables

Note: Microsoft Excel Headers support files created in Excel versions 97 and later. To configure a
Microsoft Excel header, complete the following actions.

1. Select Configuration > Headers.

2. In the Header Administration dialog box, click the Microsoft Excel header you want to modify and
click .

3. In the Header Editor dialog box, in the Header Information pane, complete the following substeps.
1. Type the name of the header in the Header Name field.

2. From the Match Result Display drop-down box, select the procedure that defines the
information that displays in the Results pane in the Job window when a match occurs.
Refer to Configuring Procedures for more information about procedures.

For an overview of the steps required to configure jobs that use this query to populate the
Results pane in the Job window, refer to Specifying data displayed in the Results pane.

3. Inthe File Properties pane, select the appropriate check box:

e First Row Column Names: Select this option to load the first row of the data file into the file
header that is used for column names.

o Exclude First Row: Select this option to exclude the first row in the file when processing the
file. By default, this check box is not selected.

o Trim Whitespace: Select this option to remove the whitespace of data fields when processing
the data. By default, this check box is selected.
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4. To add a new variable, click =2 in the Header Variables pane.
¢ If you do not click a variable in the table, the new variable appears as the first entry in the table.
e If you click a variable, the new variable is added below the selected variable.

5. To edit a header, complete the following substeps.

1. In the Header Variables pane, select the variable you want to modify and click «

2. Inthe Edit Input Variable dialog box, in the Position field, type the number of the
position of the column. You may need to adjust the column position if a data file
changes.

In the Name field, type the name of the variable.

From the Data Type drop-down box, select the data type of the variable (Character,
Number, or Date).

In the Name field, the appropriate symbol used to specify the data type of the variable is
appended to the first character of the name.

The $ (dollar sign) denotes a character variable, # (number sign) denotes a numeric variable, and
& (ampersand) denotes a date variable.

5. Select the Display check box to display the column in the pane that displays records in
the window that appears when you open a job.

6. Select the Sort check box to allow this column to be sorted in the Records pane in the
Edit Job window (Find a job in the Job Dashboard and either click Edit or right-click it
and select Edit) or in the window that appears when a job is opened in the Job
Dashboard (which appears when you select a record and either click Open or right-click
it and select Open) You can select up to ten columns to be sorted.

Note: A column that is set as the record key is also a sortable column and count toward the ten
columns that can be sortable.

Sorting is based on the prefix of the input variable. If the prefix is &, sorting is based on
timestamp (which in the end is a numeric sort); if the prefix is $, sorting is alphanumeric; and if the
prefix is #, sorting is numeric.

These values are all stored as strings regardless of the prefix the values are converted to when
the user opens or edits a job to prepare a job. If, for example, the prefix is # and the value does
not convert to a numeric value, the value is managed as null; for #ZIP and value SEVEN, seven is
null when sorted.

7. Inthe Tooltip field, type the text that appears when you hover your mouse over the
column in the pane that displays records that appear when you open a job.

8. Click OK.

6. To prevent duplicate records when this header is used to run jobs, you can set a column as the
record key. Jobs run more quickly when a column is set as a record key.

Selecting a record key allows Hyland DataTransfer to process any records with different values in the
selected column at the same time. You do not need to select a column that guarantees unique
values, but the column should capture duplicate records. For example, if you select Last Name as the
key to a header and process a file that has many records with the last name Smith, which represent
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10.

11.

different students, you prevent any two records with the same last name form being processed at the
same time.

To mark a column as the record key, select the column and click . The icon appears next to
the column to denote that it is the record key. You can mark one column only as the record key. You
cannot configure composite keys.

Note: A column that is set as the record key is also a sortable column and counts toward the ten
elements on which you can sort.

To delete a variable, select it and either right-click it and select Delete or click ='.
To preview data, in the Data Preview pane, click E.

In the Upload Preview File dialog box, click Browse and navigate to the file that you want to
preview, and then select it.

Click Preview to view data in the Data Preview pane.

Note: You can import data from the first sheet of a workbook only, and the data must be uniform; you
cannot import data from charts that have dissimilar data.

To clear data from the pane, click ='.

Configuring and modifying XML headers and header variables

Note: You do not provide input variables for XML header jobs, because XML syntax for procedures
allows you to reference every node in the XML by the exact XML tag name. Other input files have an input
variable for each data field in the file, but for XML input files, you must use the for each and node syntax
to navigate to the desired part of the XML tree.

To configure an XML header, complete the following steps.

1.
2.
3.

Select Configuration > Headers.

In the Header Administration dialog box, select the XML header you want to modify and click «

In the Header Editor dialog box, in the Header Information pane, complete the following substeps.
1. In the Header Information pane, type the name of the header in the Header Name field.

2. From the Match Result Display drop-down box, select the procedure that defines the
information that displays in the Results pane in the Job window when a match occurs. Refer to
Configuring Procedures for more information about procedures.

For an overview of the steps required to configure jobs that use this query to populate the
Results pane in the Job window, refer to Specifying data displayed in Results pane.

Perform one of the following steps.

e If you are using an XSD document, proceed to step 5.

e If you are using an XML document, proceed to step 6.

If you are using an XSDdocument to create the header, perform the following action.

1. Place your main XSD file and any XSD schema files that are referenced within the main XSD file
into a ZIP file.

For example, for an XSD file with the name HighSchoolTranscript_v1.1.0.xsd that contains the
following:
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<?xml version="1.0" encoding="utf-8"?>

<xs:schema xmlns:xs="http://www.w3.0rg/2001/XMLSchema"
xmlns:core="core:CoreMain:v1.8.0" xmlns:AcRec="sector:AcademicRecord:v1.5.0"
xmlns:HSTrn="message:HighSchoolTranscript:vl.1.0"
targetNamespace="message:HighSchoolTranscript:v1.1.0" version="v1.1.0">

<xs:import namespace="core:CoreMain:v1.8.0"
schemaLocation="CoreMain v1.8.0.xsd"/>

<xs:import namespace="sector:AcademicRecord:v1.5.0"
schemaLocation="AcademicRecord v1.5.0.xsd"/>

<xs:element name="HighSchoolTranscript">

<xs:complexType>

<xs:sequence>

<xs:element name="TransmissionData" type="AcRec:TransmissionDataType"/>
<xs:element name="Student" type="AcRec:K1l2StudentType"/>

<xs:element name="NoteMessage" type="core:NoteMessageType"
minOccurs="0" maxOccurs="unbounded"/>

<xs:element name="UserDefinedExtensions"
type="core:UserDefinedExtensionsType" minOccurs="0"/>

</xs:element>
</xs:schema>

The file contains references to these schemas:

e <xs:import namespace="urn:org:pesc:core:CoreMain:v1.8.0"
schemalocation="CoreMain_v1.8.0.xsd"/>

e <xs:import namespace="urn:org:pesc:sector:AcademicRecord:v1.5.0"
schemalocation="AcademicRecord_v1.5.0.xsd"/>

HighSchoolTranscript_v1.1.0.xsd (the main file) and CoreMain_v_1.8.0.xsd and
AcademicRecord_v1.5.0.xsd (the referenced files) are placed in the ZIP file.

Note: If a file that is referenced from the main file has references to other files, you must
include those files in the ZIP file. For example, if AcademicRecord_v.1.5.0.xsd referenced
other files, those must also be included in the ZIP file.

2. Obtain the name of your main XSD file, including the extension.
In the preceding example, the main XSD file is HighSchoolTranscript_v1.1.0.xsd.

3. Open the XSD file and obtain the name of the root element of your document. In the
preceding example, the root element is HighSchoolTranscript.

4. Preview data by completing the following substeps. Note that (you cannot preview data in
tablet view).

1. In the XML Preview pane, click | and select Preview XSD File. The Upload XSD
Preview File dialog box appears.

2. Inthe Upload Zip File field, click Browse..., navigate to the location of the ZIP file with
the XSD file you want to preview, and select it.

3. In the Master Filename field, type the name of the main XSD file. In the preceding
example, the main XSD file is HighSchoolTranscript_v1.1.0.xsd.
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4. Inthe Root Element field, type the name of the root element. In the preceding example,
the root element is HighSchoolTranscript.

5. Click Preview. The XSD file is uploaded, and its contents display in the XML Preview
pane.

Proceed to step 7.

If you are using an XML document to create the header, preview data by completing the
following substeps. Note that you cannot preview data in tablet view.

In the XML Preview pane, click ==/ and select Preview XML File.

2. Inthe Upload XML Preview File dialog box, click Browse, navigate to the location of the
XML file you want to preview, and select it.

3. Click Preview.

The XML file is uploaded, and its contents display in the XML Preview pane.
AML Preview

BE®o v

Mode Yalue
4 = WMLTEST_MOLL

4 = Student
4 = Perzon
= PersonlD 3E1E121152
= 5ZM 999754473
4 = Birth
= BirthDate 1990-02-02
4 = plame
= FirztMame Brittany
= Lasthlame Scott
= MiddleMame Wayne

7. To expand all notes in the XML tree, click ®. To collapse them, click =.

8. Set a record identifier by selecting the appropriate XML node and clicking . The node set
as the record identifier is the node that denotes the start of each record.
ZML Preview
H®0 v ®
Mode
4 = ¥MLTEST_MOLI
F Studert
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9.

10.

The XML tree refreshes and marks the corresponding nodes as record identifiers. The
Identifier field in the Header Information pane displays the name of the identifier.

Note: If you change the record identifier after you create a job using the XML header, the job
will not run properly.

If you select an end name in the XML tree, @ appears. If you click the icon, the XML tag
displays in the Records pane (the topmost, leftmost pane in either the Edit Job or Open Job
windows). You can also right-click a node and select Set to Display.

A ¥  icon appears next to XML tags that appear in the Records pane. Nodes that are
selected to appear in the Records pane are displayed in the Element Order pane.

Mode “alue
4« MMLTEST_MOLL

4 Student
4 « Perzon
¥ PerzaniD 35161211352
= 353N 999734473
4 = Birth
= BirthCate 1990-02-02

If you select a node that is marked to appear in the Records pane, the “—* appears. If you
click this icon, the XML node will not be displayed in the Records pane. You can also right-
click a node and select Set to Hide.

A = icon appears next to XML tags that do not appear in the Records pane.



11. Configure the order of XML elements specified to be displayed in the Records pane. The
Element Order pane displays the nodes you selected for display.

To configure the element order, select the appropriate node in the Element Order pane and
complete one of the following actions.

e Click 1+ to move the node to be the first node to be displayed.
e Click ' to move the node up one position.

e Click <+ to move the node down one position.

e Click == to move the node to the last position.

12. To allow an element to be sortable in the Records panes in the Edit Job window (which
appears when you select a job in the Job Dashboard and either click Edit or right-click it and
select Edit) or in the window that appears when a job is opened in the Job Dashboard (which
appears when you select a record and either click Open or right-click it and select Open),
click the element and click ==/, You can select up to ten elements to be sortable.

To remove sorting from the element, select an element on which sorting is enabled and click

Note: Neither icon appears if you have selected the maximum of ten elements to be sortable
and you select an element that is not sortable.

Note: An element that is set as the record key is also a sortable column and counts toward
the ten columns that can be sortable.

13. To prevent duplicate records when this header is used to run jobs, you can set

14. Selecting a record key allows Hyland DataTransfer to process any records with different
values in the selected column at the same time. You do not need to select a column that
guarantees unique values, but the column should capture duplicate records. For example, if
you select Last Name as the key to a header and process a file that has many records with
the last name Smith, which represent different students, you prevent any two records with the
same last name from being processed at the same time.

To mark a column as the record key, select the column and click . The icon appears
next to the column to denote that it is the record key. You can mark one column only as the
record key. You cannot configure composite keys.

Note: A column that is set as the record key is also a sortable column and counts toward the
ten columns that can be sortable.

14. To hide a displayed node that appears in the Element Order pane, select the node and click
“— . The node is hidden and is removed from the Element Order pane.
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15. To change the name of an XML node to display in the Records pane, complete the following
substeps.

1. Click the node you want to rename in the Element Order pane and'click .

2. Inthe Edit Display Name dialog box, in the Display Name field, type the name to be
displayed in the Records pane. The heading of the column is changed to this name
when the XML node displays in the Records pane.

3. Click OK.

Note: Changing the XML node name does not change the XML tag; it
only changes the display name used in the Records pane when jobs
are opened or edited.

When you open or edit a job that uses an XML header, the columns in
the Records pane are populated and ordered based on the tags you
specified to be displayed and the order in which you displayed.

You can view the full XML record in the Records pane; refer to Modifying records.

Configuring and modifying EDI headers and header variables

To configure an EDI header, complete the following steps.

Note: EDI headers are supported in Hyland DataTransfer 6.4.4 and higher.

1. Select Configuration > Headers.

2. In the Header Administration dialog box, click the EDI header you want to modify and click =

3. In the Header Editor dialog box, in the Header Information pane, complete the following substeps.
1. Type the name of the header in the Header Name box.

2. From the Match Result Display list, select the procedure that defines the information that
displays in the Results pane in the Job window when a match occurs. Refer to Configuring
Procedures for more information about procedures.

For an overview of the steps required to configure jobs that use this query to populate the
Results pane in the Job window, refer to Specifying data displayed in Results pane.

3. From the EDI Format list, select the EDI format to use for the header. Refer to Configuring EDI
formats for more information.
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Preview data by completing the following substeps. Note that you cannot preview data in tablet view.

1. In the rightmost pane, click -2 and select Preview EDI File.
2. Click Browse, navigate to the location of the EDI file you want to preview, and select it.

3. Click Preview. The EDI file is uploaded, and its contents display in the pane in XML format.
To expand all nodes in the XML tree, click # . To collapse them, click e,

Set a record identifier by selecting the appropriate XML node and clicking . The node set as the
record identifier is the node that denotes the start of each record.

The XML tree refreshes and marks the corresponding nodes as record identifiers.
The Identifier field in the Header Information pane displays the name of the
identifier.

Note: If you change the record identifier after you create a job using the XML
header, the job will not run properly.

If you select an end node in the XML tree, the @ appears. If you click the icon, the XML tag
displays in the Records pane (the topmost, leftmost pane in either the Edit Job or Open Job
windows). You can also right-click a node and select Set to Display.

A ¥ icon appears next to XML tags that display in the Records pane.
Nodes that are selected to appear in the Records pane are displayed in the Element Order pane.

If you select a node that is marked to appear in the Records pane, the “— appears. If you click this
icon, the XML node does not display in the Records pane. You can also right-click a node and select
Set to Hide.

A = icon appears next to XML tags that do not appear in the Records pane.

Configure the order of XML elements specified to display in the Records pane. The Element Order
pane displays the nodes you selected to display. To configure the element order, select the
appropriate node in the Element Order pane and complete one of the following steps.

e Click to move the node to be the first node to be displayed.
e Click to move the node up one position.
e Click to move the node down one position.

o Click to move the node to the last position.

To allow an element to be sortable in the Records pane in the Edit Job window (which appears when
you select a job in the Job Dashboard and either click Edit or right-click it and select Edit) or in the
window that appears when a job is opened in the Job Dashboard (which appears when you select a
record and either click Open or right-click it and select Open), click the element and click the == .
You can select up to ten elements to be sortable.

To remove sorting from the element, select an element on which sorting is enabled and click . 7

Note: Neither icon appears if you have selected the maximum of ten elements to be sortable and you
select an element that is not sortable.

Note: An element that is set as the record key is also a sortable column and counts toward the ten
columns that can be sortable.



Hyland DataTransfer Administrator Guide

10. To prevent duplicate records when this header is used to run jobs, you can set a column as the

11.

record key. Jobs run more quickly when a column is set as a record key.

Selecting a record key allows Hyland DataTransfer to process any records with different values in the
selected column at the same time. You do not need to select a column that guarantees unique
values, but the column should capture duplicate records. For example, if you select Last Name as the
key to a header and process a file that has many records with the last name Smith, which represent
different students, you prevent any two records with the same last name from being processed at the
same time.

To mark a column as the record key, select the column and click . The icon appears next to
the column to denote that it is the record key. You can mark one column only as the record key. You
cannot configure composite keys.

Note: A column that is set as the record key is also a sortable column and counts toward the ten
columns that can be sortable.

To hide a displayed node that appears in the Element Order pane, select the node and click “~—
The node is hidden and is removed from the Element Order pane.

12. To change the name of an XML node to display in the Records pane, complete the following actions.

1. Click the node you want to rename in the Element Order pane and click . !

2. Inthe Edit Display Name dialog box, in the Display Name field, type the name to display in the
Records pane. The heading of the column is changed to this name when the XML node displays
in the Records pane.

3. Click OK.

Note: Changing the XML node name does not change the XML tag; it only
changes the display name used in the Records pane when jobs are opened or
edited.

When you open or edit a job that uses an XML header, the columns in the
Records pane are populated and ordered based on the tags you specified to
be displayed and the order in which you displayed.

You can view the full XML record in the Records pane; refer to Modifying records.

Configuring Hobsons Connect CRM headers and header variables

To configure Hobsons Connect CRM header, complete the following steps.

1.
2.

Select Configuration > Headers.

In the Header Administration dialog box, click the Hobsons Connect CRM header you want to
modify and click .
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In the Header Editor dialog box, in the Header Information pane, complete the following substeps.

1.
2.

In the Header Name field, type the name of the header.

From the Match Result Display drop-down box, select the procedure that defines the
information that displays in the Results pane in the Job window when a match occurs. Refer to
Configuring Procedures for more information about procedures.

For an overview of the steps required to configure jobs that use this query to populate the Results
pane in the Job window, refer to Specifying data displayed in Results pane.

From the Connection Group drop-down box, select the connection group to use for the header.
The connection group must have a Hobsons connection configured; the header uses the
Hobsons connection, from the selected connection group.

Note: The connection is not saved on the header; you must select the connection each time you
modify the header.

The Header Filters pane appears after you select a connection group.

To add a Hobsons Connect CRM filter, in the Header Filters pane, complete the following substeps.

1.
2.

3.

Click &2,

In the Select Filters dialog box, select one filter to add or select multiple filters by performing one
of the following actions. Note that the dialog box displays only those filters that you have selected
from the Hobsons connection.

e Click a filter and press and hold the CTRL key as you click each filter with your mouse.

e Click a filter and press and hold the SHIFT key as you click another filter to select contiguous
filters.

Click OK.

To delete a filter, in the Header Filters pane, select the filter you want to delete and click =

To add a new variable, perform the following substeps.

1.

3.

Click = in the Header Variables pane. The variables are retrieved from the Hobsons connection
and display in a new dialog box.

e If you do not click a variable in the table, the new variable appears as the first entry in the
table.

e If you click a variable, the new variable is added below the selected variable.
Select one variable to add or select multiple variables by performing one of the following actions.
e Click a variable and press and hold the CTRL key as you click each variable with your mouse.

e Click a variable and press and hold the SHIFT key as you click another variable to select
contiguous variables.

Click OK.

To modify a header variable, in the Header Variables pane, complete the following substeps.

1.
2.

Select the variable you want to modify and either right-click it and select Edit or «

In the Edit Input Variable dialog box, in the Position field, type the number of the position of the
column. You may need to adjust the column position if a data file changes.

In the Name field, type the name of the variable.



10.
1.

12.

4. From the Data Type drop-down box, select the data type of the variable (Character, Number, or
Date).

In the Name field, the appropriate symbol used to specify the data type of the variable is
appended to the first character of the name.

The $ (dollar sign) denotes a character variable, # (number sign) denotes a numeric variable, and
& (ampersand) denotes a date variable.

5. Select the Display check box to display the column in the pane that displays records in the
window that appears when you open a job.

6. Select the Sort check box to allow this column to be sorted in the Records pane in the Edit Job
window (Find a job in the Job Dashboard and either click Edit or right-click it and select Edit) or
in the window that appears when a job is opened in the Job Dashboard (which appears when
you select a record and either click Open or right-click it and select Open) You can select up to
ten columns to be sorted.

Note: A column that is set as the record key is also a sortable column and count toward the ten
columns that can be sortable.

Sorting is based on the prefix of the input variable. If the prefix is &, sorting is based on
timestamp (which in the end is a numeric sort); if the prefix is $, sorting is alphanumeric; and if the
prefix is #, sorting is numeric.

These values are all stored as strings regardless of the prefix the values are converted to when
the user opens or edits a job to prepare a job. If, for example, the prefix is # and the value does
not convert to a numeric value, the value is managed as null; for #ZIP and value SEVEN, seven is
null when sorted.

7. Click OK.

To prevent duplicate records when this header is used to run jobs, you can set a column as the
record key. Jobs typically run more quickly when a column is set as a record key.

Selecting a record key allows Hyland DataTransfer to process any records with different values in the
selected column at the same time. You do not need to select a column that guarantees unique
values, but the column should capture duplicate records. For example, if you select Last Name as the
key to a header and process a file that has many records with the last name Smith, which represent
different students, you prevent any two records with the same last name from being processed at the
same time.

To mark a column as the record key, select the column and click . The icon appears next to
the column to denote that it is the record key. You can mark one column only as the record key. You
cannot configure composite keys.

Note: A column that is set as the record key is also a sortable column and count toward the ten
columns that can be sortable.

To delete a variable, in the Header Variables pane, select the variable you want to delete and click
To preview data in the Data Preview pane, click -=I. You cannot preview data in tablet view.

Hyland DataTransfer runs the Hobsons Connect CRM web service for the selected filter and input
variables; the data returned from the web service displays in Data Preview pane.

To clear data from the pane, click ='.



Hyland DataTransfer Administrator Guide

Configuring and modifying web service headers

Use a web service header when you are using web services or SOAP web services to retrieve data; refer
to Configuring data providers for more information.

To configure a web service header, complete the following steps.

1.
2.

Select Configuration > Headers.

In the Header Administration dialog box, click the web service header you want to modify and either
right-click it and select Edit or click «

In the Header Editor dialog box, in the Header Information pane, complete the following substeps.
1. Type the name of the header in the Header Name field.

2. From the Match Result Display drop-down box, select the procedure that defines the
information that displays in the Results pane in the Job window when a match occurs. Refer to
Configuring Procedures for more information about procedures.

For an overview of the steps required to configure jobs that use this query to populate the
Results pane in the Job window, refer to Specifying data displayed in Results pane.

In the Web Service Properties pane, complete the following substeps.

1. From the Web Service drop-down box, select the web service data provider with which you want
to configure the header.

2. Select the connection group associated with the web service you want to use from the
Connection Group drop-down box. This drop-down box displays the connection groups that
contain web service connections that match the name of the connection selected when you
configured the web service data provider.

Click the Capture button to create the header input variables using the output parameters you
configured for the data provider.

To prevent duplicate records when this header is used to run jobs, you can set a column as the
record key. Jobs run more quickly when a column is set as a record key.

Selecting a record key allows Hyland DataTransfer to process any records with different values in the
selected column at the same time. You do not need to select a column that guarantees unique
values, but the column should capture duplicate records. For example, if you select Last Name as the
key to a header and process a file that has many records with the last name Smith, which represent
different students, you prevent any two records with the same last name from being processed at the
same time.

To mark a column as the record key, select the column and click . The icon appears next to
the column to denote that it is the record key. You can mark one column only as the record key. You
cannot configure composite keys.

Note: A column that is set as the record key is also a sortable column and counts toward the ten
elements on which you can sort.

To delete a variable in the Header Variables pane, select it and click =
To preview data, in the Data Preview pane, click =

In the Upload Preview File dialog box, click Preview to view data in the Data Preview pane.
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10. To clear data from the pane, click '='.

Removing sharing on headers
To remove sharing on a header that is shared with another workspace, complete the following steps.

1. Select Configuration > Headers.

2. Inthe Header Administration dialog box, click the header and click &5.

Sharing on the header is removed.

Rolling back headers
If changes have been made and committed to a header, you can use a previous version (roll back) of it.
1. Select Configuration > Headers.

2. Inthe Header Administration dialog box, select the header you want to roll back and either right-
click it and select Rollback Header or click "= .

The Rollback Manager dialog box appears and displays the following information about previous
versions of the procedure.

e Name: Name of the header.
e Status: Status of the header (current or dated).
e Version Date: Date on which the version was created.
e Created By: User name of the user who created the version.
e Comments: Comments that were added about the version.
3. Select the version to which you want to revert and click Rollback.

The header is updated to use the selected previous version of the header.

Obtaining the latest versions of headers
If changes have been made to and committed to a header, you can obtain the latest version of it.
1. Select Configuration > Headers.

2. Inthe Header Administration dialog box, select the header for which you want to obtain the latest
version and click &/,

The header is updated to the latest version.

Deleting headers
To delete a header, complete the following steps.
1. Select Configuration > Headers.

2. In the Header Administration dialog box, select the header that you want to delete and click '='. A
message appears, prompting you to confirm that you want to delete the header.

3. Click Yes.
The header is deleted and is removed from the Header Administration dialog box.
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Exporting headers

Note: You cannot export headers in tablet view.

To export headers to an XML file, complete the following steps.

1.

2
3.
4

Select Configuration > Headers.
In the Header Administration dialog box, select the header you want to export.
Click ¢~ = and select Export.

Save the file to the appropriate location.

Importing headers

Note: You cannot import headers in tablet view.

You can import headers from an XML file by completing the following steps.

1.
2.
3.

Select Configuration > Headers.

In the Header Administration dialog box, click ¢~ ~ and select Import.

In the Import File Source dialog box, click the Browse button and navigate to the file that you want
to import or type the location of the file in the File field.

Select the Update Existing Entities check box to update an existing header, with the same name as
the header you are importing, with the header you are importing.

If you do not select this check box, and there is an existing header with the same name as the header
you are importing, DUPLICATE- is appended to the start of the name of the header you are importing;
the existing header is not updated. If a header exists with the name DUPLICATE-<header_name>,
DUPLICATE(2)- is appended to the start of the name. The number continues to be incremented so
that all headers have unique names.

Click OK.
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Configuring Forms

You can configure forms to use to compare the current input record side-by-side with the possible
existing record. You can link fields in the form to fields in the record and compare the values to view
whether they match.

One form is contained in a workspace and is used for all jobs run within that workspace.

You can share a form with other workspaces, and you can import a form from and export a form to an
XML file.

Note: The form is displayed for users in the Job window only when a job is running in interactive mode.
Note: You cannot configure forms in tablet view.

To open the form editor, select Configuration > Forms. You can also configure forms by selecting the
appropriate job in the Job Dashboard, right-clicking it, and then selecting Edit.

When users run records, they can use the form to verify that information in these linked fields matches.
Refer to the following topics for more information.

Refer to the following topics for more information.
e Understanding Form Objects

e Adding Forms

e Adding Form Objects

e Configuring Form and Form Object Properties
e Linking Form Fields and Assigning Variables to Form Fields
e Using Form Toggles

e Moving Form Objects

e Aligning Form Objects

e Copying and Pasting Form Objects

e Configuring Form Colors

e Deleting Form Objects

e Removing Sharing on Shared Forms

e Rolling Back Forms

e Obtaining the Latest Version of Forms
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Understanding Form Objects

The following table provides a description of the form objects you can add to a form.

Object Description

Field Set Area that contains a group of related information.
Label Text that describes an area on the form.
TextField Field in which data can be displayed.

Check box Element that users can check to select an option.

Adding Forms

You can create a new form from a blank template, or you can add a form that is shared by another
workspace. You can also create a new form from a copy of an existing form.

1.

Perform one of the following actions.

Select Configuration > Forms. The Form Editor appears.

In the Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

Select Tools > Add Form.

In the Add Verification Form dialog box, perform one of the following actions.

To add a new form, click the Add Verification Form tab. Next, perform one of the following
actions.

e Click the From Blank radio button to create a new form based on a blank template.

e Click the From Copy radio button if you have a form configured; you create new form based
on a copy of this existing form.

To add a form that is shared by another workspace, click the New Shared Verification Form
tab; then, from the Workspace drop-down box, select the workspace that shares the form you
want to add.

Click OK. One of the following actions occurs.

If you added a blank form, the Form Editor is empty, and you can begin creating the form.

If you added a form as a copy from a selected form, a copy of the form appears in the Form
Editor.

If you added a shared form, the shared form appears in the Form Editor.
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Adding Form Objects

You can add labels, text fields, check boxes, and field sets to the background of the form. You can add
labels, text fields, and check boxes to field sets.

To add a new form object, complete the following steps.

1.

4.

Perform one of the following actions.
e Select Configuration > Forms. The Form Editor appears.

e In the Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

To add a field set, either right-click the background of the form and select Add > Field Set or select
Add > Field Set from the menu at the bottom of the window. The field set appears in the form.

To add an object, do the following.

e To add an object to a field set, right-click the field set, select Add, and then select the appropriate
object (Label, TextField, or Check box); or, click Add in the menu at the bottom of the window and
select the appropriate object. The object appears in the field set.

e To add an object to the background of the form, right-click the form, select Add, and then select
the appropriate object (Label, TextField, or Check box); or, click Add in the menu at the bottom of
the window and select the appropriate object. The object appears in the form.

Click Save to save your changes.

Configuring Form and Form Object Properties

Refer to the following topics for more information.

Configuring Default Form Properties
Configuring Field Set Properties
Configuring Text Field Properties
Configuring Check Box Properties

Configuring Default Form Properties

To configure default form properties, complete the following steps.

1.

o gk w DN

Perform one of the following actions.
e Select Configuration > Forms. The Form Editor appears.

¢ Inthe Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

Right-click the form background and select Properties from the popup menu.
In the Properties dialog box, complete the following steps.

In the Field Set Height field, type the height, in pixels, of the field sets.

In the Field Set Width field, type the width, in pixels, of the field sets.

In the Component Width field, type the width, in pixels, of the form components.
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9.

In the Label Width field, type the width, in pixels, of the form labels.
In the Alignment field, click the appropriate radio button to configure the alignment of form objects.
o Left: Aligns all objects to the left, aligning the left edges of all objects to the left edge of the form.

¢ Right: Aligns all objects to the right, aligning the right edges of all objects to the right edge of the
form.

o Top: Aligns all objects to the top, aligning the top edges of all objects to the top edge of the form.
Click OK.

These properties are applied, by default, to all objects you add to the form.

Configuring Field Set Properties

To configure field set properties, complete the following steps.

1.

Perform one of the following actions.
e Select Configuration > Forms to display the Form Editor.

¢ Inthe Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

Right-click the field set and select Properties from the popup menu.

In the Properties dialog, in the Base Info pane, provide the appropriate information in the following
fields.

e ID: Type the ID that uniquely identifies the field set. You can also type this value in the ID field in
the bottom of the Form Editor.

¢ Order: Type the order value of the field set, which is either zero (0), the higher value, or 1. The
order determines which object appears on top of another object if they overlap. An object with a
0 value appears above an object with a 1 value.

e Top: Type the value, in pixels, of the top margin. This value specifies boundary length between
the top of the verification form and the field set. You can also type this value in the Top field in the
bottom of the Form Editor.

e Left: Type the value, in pixels, of the left margin. This value specifies the boundary length
between the left side of the verification form and the field set. You can also type this value in the
Left field in the bottom of the Form Editor.

e Height: Type the field set height, in pixels. You can also type this value in the Height field in the
bottom of the Form Editor.

o Width: Type the field set width, in pixels. You can also type this value in the Width field in the
bottom of the Form Editor.

In the Fields Properties pane, specify the appropriate information.

e Heading: Type the name of the heading, which is the text that appears in the top of the field set to
identify it. You can also type this name in the Heading field in the bottom of the Form Editor.

e User Check box: Click the appropriate radio button to enable or disable field toggles for users.
Field set toggles are used to determine what information, if any, can be uploaded to the database
when differences in linked form fields are detected. Refer to Using Form Toggles for more
information.
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5. Click OK to apply your changes and close the dialog box.

6. Click Save to save your changes.

Configuring Text Field Properties

To configure text field properties, complete the following steps.

1.

Perform one of the following actions.
e Select Configuration > Forms to display the Form Editor.

¢ Inthe Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

Right-click the text field and select Properties from the popup menu.

In the Properties dialog box, in the Base Info pane, provide the appropriate information in the
following fields.

¢ ID: Type the unique ID that identifies the text field. You can also type this value in the ID field in
the bottom of the Form Editor.

e Order: Type the order value of the text field, which is either zero (0), the higher value, or 1. The
order determines which object appears on top of another object if they overlap. An object with a
0 value appears above an object with a 1 value.

e Top: Type the value, in pixels, of the top margin. This value specifies boundary length between
the top of the text field and the field set. You can also type this value in the Top field in the bottom
of the Form Editor.

o Left: Type the value, in pixels, of the left margin. This value specifies the boundary length
between the left side of the text field and the field set. You can also type this value in the Left field
in the bottom of the Form Editor.

e Height: Type the text field height, in pixels. You can also type this value in the Height field in the
bottom of the Form Editor.

e Width: Type the text field width, in pixels. You can also type this value in the Width field in the
bottom of the Form Editor.

The Advanced Properties displays information that appears in the form field and information linking
form fields together. Refer to Linking Form Fields and Assigning Variables to Form Fields for more
information.

In the Field Properties pane, specify the appropriate information:
e Label: Type the text that appears in the form to identify the text field.
e Label Width: Type the width, in pixels, of the text field.
e Field Width: Type the width, in pixels, of the text field.
o Alignment: Click the appropriate radio button.

o Left: Specifies that the label appears to the left of the text field.

e Top: Specifies that the label appears above the text field.

¢ Right: Specifies that the label appears to the right of the text field.
Click OK to apply your changes and close the dialog box.
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7. To make the text field read-only so that users cannot modify information in the field when they view
the verification form, check the Read Only check box at the bottom of the Form Editor.

8. Click Save to save your changes.

Configuring Check Box Properties
1. Perform one of the following actions.
e Select Configuration > Forms. The Form Editor appears.

¢ In the Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

2. Right-click the check box and select Properties from the popup menu.

In the Properties dialog box, in the Base Info pane, provide the appropriate information in the
following fields.

¢ ID: Type the ID that uniquely identifies the check box. You can also type this value in the ID field
in the bottom of the Form Editor.

e Order: Type the order value of the check box, which is either zero (0), the higher value, or 1. The
order determines which object appears on top of another object if they overlap. An object with a
0 value appears above an object with a 1 value.

o Top: Type the value, in pixels, of the top margin. This value specifies boundary length between
the top of the check box and the field set. You can also type this value in the Top field in the
bottom of the Form Editor.

o Left: Type the value, in pixels, of the left margin. This value specifies the boundary length
between the left side of the check box and the field set. You can also type this value in the Left
field in the bottom of the Form Editor.

e Height: Type the check box height, in pixels. You can also type this value in the Height field in
the bottom of the Form Editor.

e Width: Type the check box width, in pixels. You can also type this value in the Width field in the
bottom of the Form Editor.

4. In the Field Properties pane, specify the appropriate information:
e Label: Type the text that appears in the form to identify the check box.
e Label Width: Type the width, in pixels, of the label.
e Field Width: Type the width, in pixels, of the check box.
e Alignment: Click the appropriate radio button.
o Left: Specifies that the label appears to the left of the check box.
e Top: Specifies that the label appears above the check box.
e Right: Specifies that the label appears to the right of the check box.
Click OK to apply your changes and close the dialog box.

Click Save to save your changes.
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Configuring Label Properties

To configure label properties, complete the following steps.

1.

Perform one of the following actions.
e Select Configuration > Forms. The Form Editor appears.

¢ In the Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

Click the label for which you want to configure properties.
In the ID field at the bottom of the form editor, type the ID that uniquely identifies the label.

In the Top field, type the value, in pixels, of the top margin. This value specifies boundary length
between the top of the label and the field set.

In the Left field, type the value, in pixels, of the left margin. This value specifies the boundary length
between the left side of the label and the field set.

In the Width field, type the label width, in pixels.
In the Height field, type the label width, in pixels.

Click Save to save your changes.

Linking Form Fields and Assigning Variables to Form Fields

You can configure text boxes to display information from the database by assigning it a program variable,
which contains the appropriate information.

You can also link form fields to each other so that users can compare the input record to a potential
match in the database. You link each field to a program variable, which returns the appropriate
information from the database. Users can view whether the fields match in the verification form that is
shown when they run interactive jobs.

To link form fields and to assign program variables to fields, do the following.

1.

Perform one of the following actions.
e Select Configuration > Forms. The Form Editor appears.

e In the Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

To link form fields that have matching values, select the form fields by clicking on one form field and
then pressing and holding the Shift key while clicking the matching field.

When you view the Properties dialog box for a field, the Match To field in the Advanced Properties
pane displays the ID of the other form field that is linked to the field.

Specify the variable to which the text field is assigned by selecting the variable from the Program
Variables pane and dragging and dropping it onto the text field. For more information about program
variables, refer to Configuring Procedures.

When you view the Properties dialog box for the field, the Assigned To field in the Advanced
Properties pane displays the program variable assigned to the field.
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For example, in the preceding figure, the DOB fields for the input record (Input Record) and the database
record (University Record) are linked.

e The Input Record DOB field has an ID of TF Label 14.

e The University DOB field has an ID of TF Label 59.

e The Input Record DOB field is assigned to the $f dob variable.

e The University Record DOB field is assigned to the $d_dob variable.

To link the fields, you would select the Input Record DOB field and then press and hold the Shift key on
your keyboard while clicking the University Record DOB field.

To assign the $f_dob variable to the Input Record DOB field, you would click the $f_dob variable in the
Program Variables pane and then drag and drop it onto the text field to which it is assigned.

When you open the Properties dialog box for the Input Record DOB field, it displays the label (TF Label



59) to which it is linked and the variable ($f_dob) to which it is assigned.
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When you selected the Input Record DOB and University Record DOB fields, you linked them both. To
assign the $d_dob variable to the field, you would select the variable in the Program Variables pane and
then drag and drop the variable onto the University Record field. When you open the Properties dialog
box for the field, it displays the appropriate information for the field to which it is linked and the variable for

which it is assigned.
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4. Click OK.

You can also select a color to highlight linked fields when their values differ from each other. By
default, this color is a shade of blue; however, you can specify a color from a color palette. Refer to

Configuring Form Match Colors.

Using Form Toggles
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Refer to the following topics for more information.

e Understanding Form Toggles

e Configuring Form Toggles

Understanding Form Toggles

If a field set contains a field that is linked to another field, this check box is automatically enabled. If data
between two field sets are the same (linked fields return the same values); the check box is unchecked,; if

the data is different, the toggle is checked.

=1]
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Users can check or uncheck the toggle check boxes to specify which field sets of information are included
when upload logic is processed.

Use form toggles if you need to provide the value of each field set to the associated upload logic; when
the upload logic is run, this value is included when the data file is uploaded. The form can return the value
of a toggle given a specified program variable name.

For more information about configuring procedures, refer to Configuring Procedures. Syntax for the
toggle function is:

toggle (variable)

For example:
if toggle($suffix)

Syntax for the toggle off function is:
toggle off (variable)

For example:
toggle off (Slast)

Syntax for the toggle_on function is:

toggle on(variable)

For example:

toggle on($last)

Configuring Form Toggles
To configure toggles for field sets, do the following.
1. Perform one of the following actions.
e Select Configuration > Forms. The Form Editor appears.

¢ In the Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

2. Right-click the field set and select Properties from the popup menu.

In the Properties dialog box, in the Field Properties pane, select the appropriate option for the Use
Check box option. Click the Yes radio button to use a check box (toggle) for the field set; click the No
radio button if you do not want to use a check box.

4. Click OK to save your changes.
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Moving Form Objects

You can move field sets and objects by dragging and dropping them with your mouse; complete the
following steps.

1.

3.

Perform one of the following actions.
e Select Configuration > Forms. The Form Editor appears.

e In the Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

Click the object that you want to move. To select multiple objects, click an object and press and hold
the Ctrl key as you click each object with your mouse. You can deselect an object by clicking it and
pressing and holding the Ctrl key; you can deselect all objects by clicking in an empty background
area of the form.

With your mouse, drag and drop the object to the desired location.

The object is moved to the specified location. If you selected multiple objects, they are moved the same
relative distance.

Aligning Form Objects

You can align form objects in a field set with each other, or you can align field sets on the form
background with each other.

1.

Perform one of the following actions.
e Select Configuration > Forms. The Form Editor appears.

¢ In the Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

Select the objects you want to align. To select multiple objects, click an object and press and hold
the Ctrl key as you click each object with your mouse. You can deselect an object by clicking it and
pressing and holding the Ctrl key; you can deselect all objects by clicking in an empty background
area of the form.

Right-click the objects and select Align.
Select one of the following.

o Left: Aligns all objects to the left, aligning the left edges of all objects to the left edge of the first
object you selected.

¢ Right: Aligns all objects to the right, aligning the right edges of all objects to the right edge of the
first object you selected.

e Top: Aligns all objects to the top, aligning the top edges of all objects to the top edge of the first
object you selected.

o Bottom: Aligns all objects to the bottom, aligning the bottom edges of all objects to the bottom
edge of the first object you selected.
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Copying and Pasting Form Objects

You can copy and paste form objects located within a field set onto the same field set and copy and
paste field sets onto the background form.

1.

Perform one of the following actions.
e Select Configuration > Forms. The Form Editor appears.

¢ In the Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

Select the objects you want to copy. To select multiple objects, click an object and press and hold
the Ctrl key as you click each object with your mouse. You can deselect an object by clicking it and
pressing and holding the Ctrl key; you can deselect all objects by clicking in an empty background
area of the form.

Right-click the object and select Copy.
Perform one of the following actions.
e To paste field sets onto the form background, right-click the background and select Paste.

e To paste objects on a field set within the same field set, right-click the field set and click Paste.

Configuring Form Colors

Refer to the following topics for more information.

Configuring Form Background Colors

Configuring Field Set Foreground and Background Colors
Configuring Label Foreground and Background Colors
Configuring Check Box Foreground and Background Colors
Configuring Text Field Foreground and Background Colors

Configuring Form Match Colors

Configuring From Background Colors

To configure background colors for the form, do the following.

1.

Perform one of the following actions.
e Select Configuration > Forms. The Form Editor appears.

¢ In the Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

Right-click the background and select Color.

To set the form background color, select Background, and then select the color from the palette.
The background of the form is set to this color.
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Configuring Field Set Foreground and Background Colors
To configure background and foreground colors for a field set, do the following.
1. Perform one of the following actions.

e Select Configuration > Forms. The Form Editor appears.

e Inthe Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

Right-click the field set and select Color.

To set the field set background color, select Background, and then select the color from the palette.
The background of the field set is set to this color.

4. To set the field set foreground color, select Foreground, and then select the color from the palette.

If you have not configured colors for other form objects, any form objects that appear on
the field set are set to this color. For example, if you have a label on the field set, the
label is set to this color. Any additional form objects you add to the field set are also set
to this color.

If you configure colors for form objects themselves, however, those colors, not the ones
configured for the field set foreground or background, are used.

Configuring Label Foreground and Background Colors
To configure background and foreground colors for a label, do the following.
1. Perform one of the following actions.

e Select Configuration > Forms. The Form Editor appears.

¢ In the Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

2. Right-click the label and select Color.

To set the label background color, select Background, and then select the color from the palette.
The background of the label is set to this color.

4. To set the label foreground color, select Foreground, and then select the color from the palette.
The color is applied to the label text of the label.

Configuring Check Box Foreground and Background Colors
To configure background and foreground colors for a check box, do the following.
1. Perform one of the following actions.

e Select Configuration > Forms. The Form Editor appears.

¢ In the Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

2. Right-click the check box and select Color.
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3. To set the check box background color, select Background, and then select the color from the
palette. The background of the check box is set to this color.

4. To set the check box foreground color, select Foreground, and then select the color from the palette.
The color is applied to the label text of the check box.

Configuring Text Field Foreground and Background Colors
To configure background and foreground colors for a text field, do the following.
1. Perform one of the following actions.

e Select Configuration > Forms. The Form Editor appears.

¢ Inthe Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

2. Right-click the text field and select Color.

To set the text field background color, select Background, and then select the color from the palette.
The background of the text field is set to this color.

4. To set the text field foreground color, select Foreground, and then select the color from the palette.
The color is applied to the label text of the text field.

Configuring Form Match Colors

You can set the form match color, which is the color that highlights all linked form objects when they
contain different values. For example, if the input record DOB and data record DOB fields are linked, and
their values do not match, the text fields are displayed in the match color you specify. By default, the
color is a shade of blue.

1. Perform one of the following actions.
e Select Configuration > Forms. The Form Editor appears.

¢ In the Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

2. Right-click the background and select Color.

Select Match, then select a color from the color palette.

Deleting Form Objects
To delete a form object, do the following.
1. Perform one of the following actions.
e Select Configuration > Forms. The Form Editor appears.

¢ In the Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

2. Select the object you want to delete and either right-click it and select Delete or click the Delete
button.

Note: If you delete a field set, the field set and all of its objects are deleted. The object is deleted and
is removed from the Form Editor.

13. Click Save to save your changes.
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Removing Sharing on Shared Forms
To remove sharing on a form that is shared with another workspace, do the following.
1. Perform one of the following actions.
e Select Configuration > Forms. The Form Editor appears.

e Inthe Job Dashboard, select the job with the form you want to configure, then either right-click it
and select Edit or click the Edit button.

2. Click Tools and select Remove Sharing. Sharing is removed on the form.

Rolling Back Forms
If changes have been made to and committed to a form, you can use a previous version (roll back) of it.
1. Perform one of the following actions.
e Select Configuration > Forms. The Form Editor appears.

¢ In the Job Dashboard, select the job with the form you want to roll back, then either right-click it
and select Edit or click the Edit button.

2. Click Tools and select Rollback. The Rollback Manager dialog box appears and displays the
following information.

¢ Name: Name of the form.

e Status: Status of the form (pending, current, or dated).

e Version Date: Date and time on which the version of the form was created.
e Created By: Username of the user who created the form.

e Comments: Comments added by the user.

3. Select the version you want to use and click Rollback. The previous version is loaded into the Form
Editor.

Obtaining the Latest Versions of Forms
If changes have been made to and committed to a form, you can obtain the latest version of it.
1. Preform one of the following actions.
e Select Configuration > Forms. The Form Editor appears.

¢ In the Job Dashboard, select the job with the form for which you want to obtain the latest version,
and then either right-click it and select Edit or click the Edit button.

2. Click Configuration and select Get Latest. The latest version of the form is obtained and is loaded
into the Form Editor.
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Configuring Reports

You can write custom XML reports, which are based on JasperReports and are presented in PDF format.
For more information about JasperReports, refer to http://en.wikipedia.org/wiki/JasperReports.

Note: Reports only run against the Hyland DataTransfer database. Refer to the following topics for more
information.

e Configuring Reports.
e Configuring Scheduled Reports
e Viewing Reports

Configuring Reports

In Reports > Configure, you can add, modify, and delete reports; you can also import and export reports.
Refer to the following topics for more information.

e Adding and Modifying Reports
e Deleting Reports

e Importing Reports

e Exporting Reports

Adding and Modifying Reports

You can create reports in JasperReports format.

1. Select Reports > Configure.

2. Inthe Configure Reports dialog box appears perform one of the following actions.
e To add a new report, click = to display the Add Report dialog box.

o To modify a report, select the report and either right-click it and select Edit Report or click = to
display the Edit Report dialog box.

In the Report Name field, type the name of the report.

In the XML field, type the XML code that generates the report.

To add report parameters, complete the following substeps.
1. In the Report Parameters pane, click = .

2. Inthe New Report Parameter dialog box, from the Parameter drop-down box, select the
type of parameter you want to add. Options are:

e Header
e Job
e Start Date
e EndDate
e User
3. Click Apply.
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4. Continue adding parameters, as appropriate, and click OK when you are finished.
5. To delete a parameter, select the parameter in the Report Parameters pane and click =,

6. Click OK to save your changes and close the dialog box.

Deleting Reports
To delete a report, do the following.
1. Select Reports > Configure.

2. Inthe Configure Reports dialog box, select the report you want to delete and either right-click it and

select Delete Report or click = A dialog box appears, prompting you to confirm that you want to
delete the report.

3. Click Yes. The report is deleted and is removed from the Configure Reports dialog box.

Importing Reports

To import reports from an XML file, do the following.

1. Select Reports > Configure.

2. Inthe Configure Reports dialog box, click <~ = and select Import.

3. Inthe Import Report dialog box, click Browse, navigate to the location of the file, and select it.
4. Click OK.

The file is imported, and reports that are imported are displayed in the Configure Reports dialog box.

Exporting Reports

To export reports to an XML file, do the following.

1. Select Reports > Configure.

2. In the Configure Reports dialog box, select the report you want to export.
3. Click ¢~ and select Export.

Save the XML file in the appropriate location.

Configuring Scheduled Reports

In Reports > Schedule, you can add and delete reports that are scheduled to be run at specified times,

and you can modify the schedule for these reports. You can also view reports by clicking = (refer to
Configuring Scheduled Reports for more information).

Refer to the following topics for more information.
e Adding and Modifying Scheduled Reports
e Deleting Scheduled Reports
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Adding and Modifying Scheduled Reports

To add or modify a scheduled report, complete the following steps.

1.
2.

8.

Select Reports > Schedule.
In the Schedule Reports dialog box, perform one of the following actions.
e To add a new report, click =¥ to display the Add Scheduled Report dialog box.

o To modify a report, select the report and either right-click it and select Edit Report or click =
The Edit Scheduled Report dialog box appears.

Click the Details tab. The Parameters pane displays the parameters, which you can specify, that are
available for the selected report;.

In the Parameters pane, provide the appropriate parameters. Options depend on the parameters
available for the report. Possible options are:

L=

Start Date field. Click to open a calendar from which you select the start date of the report.

=]

e End Date field. Click to open a calendar from which you select the end date of the report.
e Job field. Type the name of the job for the report.

e Header drop-down box. Select the header used for the job.

e User drop-down box. Select the user running the job.

From the Start Time drop-down box, select the time on which the report is run.

In the Recurrence Pattern pane, specify when the report recurs.

¢ Click the Once radio button to run the report once. After the report is run, rules for running the job
are disabled.

¢ Click the Daily radio button to specify that the report is run daily, and then specify the recurrence
frequency.

e Click the Weekly radio button to specify that the report is run weekly, and then specify the
recurrence frequency.

o Click the Monthly radio button to specify that the report is run monthly, and then specify the
recurrence frequency.

Click the Notifications tab to configure notifications to be sent to recipients when certain reports
actions occur. Refer to Configuring Notifications.

Click OK.

Deleting Scheduled Reports

To delete a scheduled report, do the following.

1.
2.

Select Reports > Schedule.

In the Schedule Report dialog box, select the scheduled report you want to delete and click ='.

The scheduled report is deleted and is removed from the Schedule Report dialog box.
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Viewing Reports
You can view reports in the View Reports dialog box.
Note: You cannot view reports in tablet view.

If you open the dialog box from Reports > View, the search filters display the current date for all report
rules and reports. If you open it from the Schedule Reports dialog box, the filters display the selected
report rule.

These reports, in PDF format, are stored physically on the Hyland DataTransfer server. You must specify
the root directory of the location where the reports are stored. To do so, in the datatransfer.properties
file, you must supply a report_root parameter. For example:

report root=c:/reports

The PDF files are then stored in appropriate subdirectories within that root directory. To view a report,
complete the following steps.

1. Perform one of the following actions.

o Select Reports > View.

e Select Reports > Schedule and click — .
The dialog box displays a table with the following information.
o Date: Date on which the report was created.
e Name: Name of the report.
e Report Rule Name: Name of the rule that caused the scheduled report to be run.
e Created By: Username of the administrator who configured the report.

You can filter the information in the View Reports dialog box by selecting the appropriate information in
one or more of the following fields.

¢ Report Rule: Select the report rule for which to filter results.
e Reports: Select the report for which to filter results. Select All to specify all reports.

o Date Range fields: Click the & icon to open a calendar from which you can specify the start and
end dates of a date range. You can choose both start and end dates or only a start or end date.
After specifying the filter information, click the Filter button to update the table with the selected criteria.

To view a report, click ] . The report opens in a new tab or browser window in PDF format.
To permanently delete the report PDF file and the record of the report instance, click "=!. Reports are

removed from the location specified in the report_root parameter in the datatransfer.properties file.
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Configuring File Sources

You can configure file sources—servers or SFTP connections—for recurring jobs. The file source is the
location that contains the input file that the recurring job uses. Recurring jobs run at a specified interval,

using the input file from the server or SFTP site to which it can connect.

You can also configure file sources to download additional, non-input files from a specified location. For
example, you can create a recurring job that automatically downloads the input file, creates a job for the
file, downloads non-input files to be processed by the job, and places the non-input files in a location that

Hyland DataTransfer can access.

Refer to the following topics for more information.

Adding File Sources

Modifying File Sources

Deleting File Sources

Copying File Sources

Testing File Sources

Removing Sharing on Shared File Sources
Rolling Back File Sources

Obtaining the Latest Versions of File Sources
Exporting File Sources

Importing File Sources

Adding File Sources

You can add a new file source or add a file source that another workspace is sharing.

1.
2.
3.

Select Configuration > File Sources.
Click “& .
In the Add File Source dialog box, perform one of the following actions.
e To add a new file source, complete the following steps.
1.  Click the Add File Source tab.
2. Inthe Name field, type the name of the file source.
3. From the Type drop-down box, select the type of file source (Server or SFTP).
o To add a file source that another workspace is sharing, complete the following steps.
1. Click the Add Shared File Source tab.

2. From the Workspace drop-down box, select the workspace that is sharing the file source.

3. From the File Source drop-down box, select the file source you want to add.
Click OK.
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5. In the Edit File Source dialog box, perform one of the following actions.
e To modify a server path file source, do the following.
6. Inthe Name field, type the name of the file source.
7. In the Description field, type descriptive text about the file source.
8. In the Path field, type the path.
9

In the File Pattern Field, type the file pattern information used to identify the input file
located in the specified file source. Hyland DataTransfer searches the file source for the
input file based on the file pattern information specified.

Use * to search for any number of characters; use ? to search for one character. For example:
o *xmlreturns all xml files.
e *?ml returns any files with an extension that has one character followed by ml.

o Application?.txt returns all files that start with Application, that have a single character, and
that have a .fxt extension.

Note: Hyland DataTransfer does not verify if the file pattern information is correct.
e To modify an SFTP file source, complete the following steps.
In the Name field, type the name of the file source.
In the Description field, type descriptive text about the file source.
In the URL field, type the URL of the SFTP connection.
In the Port field, type the port number.
In the Path field, type the SFTP connection path.

o ok~ w b=

In the File Pattern Field, type the file pattern information used to identify the input file located in
the specified file source. Hyland DataTransfer searches the file source for the input file based
on the file pattern information specified.

Use * to search for any number of characters; use ? to search for one character. For example:
e *xmlreturns all xml files.
e *.?mlreturns any files with an extension that has one character followed by ml.

e Application?.txt returns all files that start with Application, that have a single character, and
that have a .fxt extension.

In the Username field, type the username used to connect to the SFTP connection.

In the Password field, type the password used to connect to the SFTP connection.
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6. In the File Downloads pane, do the following.

10. Check the Additional Files check box to specify that the file source has other, non-input
files to download. When you create a recurring job that uses this file source, the input file
is downloaded from the specified path or connection, and then additional files are
downloaded from the same path or connection, given the parameters you specify in the
File Downloads pane.

11. In the File Pattern field, type the file pattern information used to identify the non-input file
located in the file source.

12. In the Destination Path field, type the location where the non-input files are placed when
they are downloaded. The path must be on a Hyland DataTransfer server or reachable
from the Hyland DataTransfer server.

7. Inthe Source File Options pane, specify how to manage the additional, non-input files in the file
source location. Click one of the following options.

e Leave. Performs no action on the files.

e Archive. Archives the files and moves them to a location that you specify in the Archive Path
field.

o Delete. Permanently deletes the files from the file source.
8. Click OK.

The file source is added and appears in the File Source Administration dialog box.

Modifying File Sources
To modify a file source, do the following.
1. Select Configuration > File Sources.

2. Inthe File Source Administration dialog box, click the file source you want to modify and either
click ¢ or right-click the file source and select

3. In the Edit File Source dialog box, perform one of the following actions.
e To modify a server path file source, complete the following steps.
13. In the Name field, type the name of the file source.
14. In the Description field, type descriptive text about the file source.
15. In the Path field, type the path.

16. In the File Pattern Field, type the file pattern information used to identify the input file
located in the specified file source. Hyland DataTransfer searches the file source for the
input file based on the file pattern information specified.

Use * to search for any number of characters; use ? to search for one character. For example:
o *xmlreturns all xml files.
e *?ml returns any files with an extension that has one character followed by ml/.

o Application?.txt returns all files that start with Application, that have a single character, and
that have a .txt extension.
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Note: Hyland DataTransfer does not verify if the file pattern information is correct.

e To modify an SFTP file source, complete the following steps.
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In the Name field, type the name of the file source.

In the Description field, type descriptive text about the file source.
In the URL field, type the URL of the SFTP connection.

In the Port field, type the port number.

In the Path field, type the SFTP connection path.

In the File Pattern Field, type the file pattern information used to identify the input file located
in the specified file source. Hyland DataTransfer searches the file source for the input file
based on the file pattern information specified.

Use * to search for any number of characters; use ? to search for one character. For example:

7.
8.

*xml returns all xml files.
.?ml returns any files with an extension that has one character followed by ml.

Application?.txt returns all files that start with Application, that have a single character, and
that have a .fxt extension.

In the Username field, type the username used to connect to the SFTP connection.

In the Password field, type the password used to connect to the SFTP connection.

4. In the File Downloads pane, complete the following steps.

17. Check the Additional Files check box to specify that the file source has other, non-input
files to download. When you create a recurring job that uses this file source, the input file
is downloaded from the specified path or connection, and then additional files are
downloaded from the same path or connection, given the parameters you specify in the
File Downloads pane.

18. In the File Pattern field, type the file pattern information used to identify the non-input file
located in the file source.

19. In the Destination Path field, type the location where the non-input files are placed when
they are downloaded. The path must be on a Hyland DataTransfer server or reachable
from the Hyland DataTransfer server.

5. In the Source File Options pane, specify how to manage the additional, non-input files in the file
source location. Click one of the following radio buttons.

e Leave: Performs no action on the files.

o Archive: Archives the files and moves them to a location that you specify in the Archive Path
field.

o Delete: Permanently deletes the files from the file source.
6. Click OK.
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Deleting File Sources

To delete a file source, do the following.

1.
2.

Select Configuration > File Sources.

In the File Source Administration dialog box, select the file source you want to delete and either
right-click it and select Delete or click '='. The file source is deleted and is removed from the File
Source Administration dialog box.

Copying File Sources

To create a duplicate of a file source, complete the following steps.
Select Configuration > File Sources.

In the File Source Administration dialog box, select the file source you want to copy and either
right-click it and select Copy or click 'Ll . A copy of the file source is created and appears in the
File Source Administration dialog box.

Testing File Sources

To test a file source connection, do the following.

1.
2.

Select Configuration > File Sources.

In the File Source Administration dialog box, select the file source you want to test and either right-
click it and select Test File Source or click " ==.

o If the file source works properly, a dialog box appears and states that the test was successful.

o If the file source does not work properly, a dialog box appears and indicates the reason that the
test failed.

Removing Sharing on Shared File Sources

To remove sharing on a file source that is shared with another workspace, do the following.

1.
2.

Select Configuration > File Sources.
In the File Source Administration dialog box, select the file source for which you want to remove

sharing and either right-click it and select Remove Sharing or click &8 Sharing is removed on the file
source.
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Rolling Back File Sources
If changes have been made and committed to a file source, you can use a previous version (roll back) of
it.
1. Select Configuration > File Sources.

2. Inthe File Source Administration dialog box, click the file source you want to roll back and either
right-click it and select Rollback or click . The Rollback Manager dialog box appears and displays
the following information.

o Name: Name of the file source.

e Status: Status of the file source (current or dated).

e Version Date: Date and time on which the version was created.
e Created By: Username of the user who created the file source.
e Comments: Comments that were added by the user.

3. Select the previous version to which you want to revert and click Rollback. The previous version is
loaded.

Obtaining the Latest Versions of File Sources
If changes have been made to and committed to a file source, you can obtain the latest version of it.
1. Select Configuration > File Sources.

2. Inthe File Source Administration dialog box, click the file source for which you want to obtain the
latest version and either right-click it and select

3. Get Latest or click .

Exporting File Sources
Note: You cannot export file sources in tablet view.
You can export file sources to an XML file by doing the following.
1. Select Configuration > File Sources.
2. Inthe File Source Administration dialog box, select the file source you want to export.
3. Click ¢« = and select Export.

4. Save the file to the appropriate location.

Importing Source Sources
Note: You cannot import file sources in tablet view.
You can import file sources from an XML file by doing the following.
1. Select Configuration > File Sources.

2. Inthe File Source Administration dialog box, click <= ~ and select Import.

3. Inthe Import File Source dialog box, click the Browse button and navigate to the file that you want
to import or type the location of the file in the File field.
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4. Check the Update Existing Entities check box to update an existing file source, with the same name
as the file source you are importing, with the file source you are importing.

If you do not check this check box, and there is an existing file source with the same name as the file
source you are importing, DUPLICATE- is appended to the start of the name of the file source you are
importing; the existing file source is not updated. If a file source exists with the name DUPLICATE-

<file_source_name>, DUPLICATE(2)- is appended to the start of the name. The number continues to
be incremented so that all file sources have unique names.

5. Click OK.

Configuring data providers

You can configure Hyland DataTransfer to use web service or SOAP web service data providers for
communication.

Note: SOAP web service data providers are supported in Hyland DataTransfer 6.4.5 and higher.
e Configuring web service data providers

e Configuring SOAP web service data providers
e Testing data providers

e Configuring data provider program functions

e Deleting data providers.

e Copying data providers

e Removing sharing on data providers

e Rolling back data providers.

e Obtaining the latest versions of data providers
e Exporting data providers

e Importing data providers

Configuring web service data providers

You can configure Hyland DataTransfer to use web service data providers for communication. Perform
the following steps to configure a web service data provider.

1. Add and configure a web service connection.

2. To provide the appropriate permissions to configure the web service data provider, enable the Edit
Data Providers privilege in Administration > User.

Add a web service data provider.
Configure the web service data provider.
Test the web service data provider.
Create a web service header.

Create a job that uses the web service connection and header.

© N o o ko

Configure the code to run the web services.
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Adding web service data providers
To add a web service data provider, complete the following steps.
1. Select Configuration > Data Providers.
2. In the Data Provider Administration box, click ‘&
3. Inthe Add Data Provider, dialog box, complete one of the following actions.
e To add a new data provider, complete the following substeps.
1. Click the Add Data Provider tab.
2. In the Name field, type the name of the data provider.
3. Select Web Service from the Type drop-down box.
e To add a data provider that another workspace is sharing, complete the following substeps.
1. Click the Add Shared Data Provider tab.
2. From the Workspace drop-down box, select the workspace that is sharing the data provider.
3. Select the data provider from the Data Provider drop-down box.
4. Click OK.

Modifying web service data providers

When you save a web service data provider, only the connection name is saved; the URL associated with
the connection is not saved so that you can configure only one web service data provider and use the
appropriate connection, depending on the connection group chosen, for two different servers.

For example, you may have the following servers and groups.

e Both test and production servers that use the web service.

e Atest connection group with a web service connection using the test URL.

e A production connection group with a web service using the production URL.

If you name both connections DTSIS and use the DTSIS connection, you can use the same data provider
for both URLSs.

For example, you save a data provider with DTSIS as the connection. The next time you open the data
provider to edit it, the application checks the connection groups in alphabetical order and searches for a
connection with the name DTSIS. If a connection with that name is found, that connection and its
associated connection group automatically display in the corresponding drop-down boxes. If the
connection is not found, the Connection Group and Connection drop-down boxes do not automatically
display any data and the message A valid web service connection must be selected appearsin
the Connection URL field.

To modify a web service data provider, complete the following steps.
1. Select Configuration > Data Providers.

2. Inthe Data Provider Administration dialog box, select the web service data provider you want to
modify and click & .

3. Inthe Edit Web Service Data Provider dialog box, in the Name field, type the name of the web
service data provider.
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In the Description field, type descriptive text about the data provider.

From the Connection Group drop-down box, select the connection group that contains the
connection you want to use for the web service data provider. The connection groups that you have
permission to view and use display in the drop-down box.

From the Connection drop-down box, select the connection, which belongs to the connection group
you selected, to use for the data provider.

After you select a connection, the Connection URL field in the right-top pane displays the URL for
the connection. You cannot modify this field. If you do not provide a valid connection, the field
displays the text A valid web service connection must be selected.

From the HTTP Method field, select the HTTP method used by the web service request (GET, POST,
PUT, or DELETE).

Click the URL Suffix tab and type the URL suffix to the web service being requested. The URL suffix
is the portion of the web service request that is dynamic (the parameters). When the web service
runs, the connection URL and the URL suffix are combined to obtain the full web service URL.

Click the Payload tab to add a request body, if necessary.

e If you are using JSON, type either the URL query string to use after you connect to the web
service or a JSON-formatted object.

o If you are using XML, type either the URL query string to use after you connect to the web service
or an XML-formatted request.

In the REST Type field, click the radio button for the REST web service type used by the web service
request (XML or JSON).

To map Hyland DataTransfer program variables to web service input and output parameters, drag and
drop variables from the Program Variables pane to the Input and Output tabs.

When you add an input or output parameter, the name of the program variable is the name of the
input or output parameter and it appears in the Name column. For example, if you map the sws_id
program variable to an input parameter, the input parameter is named $ws_id, which appears in the
Name column.

To modify an input value, click the Input tab, double-click in the field, and type the appropriate
information.

o Description: Type descriptive text about the parameter.

¢ Location: Ordinal value of the field. The first field has a value of {0} (zero), the second field has a
value of {1}, and so on

o Substitution Expression: Type the values for the input fields. You must always use {0} for the
substitution value. When you run the web service, the value of the program variable is substituted
for {0}.

To modify an output value, click the Output tab, double-click the field, and type the appropriate
information.

o Description: Type descriptive text about the parameter.

¢ Query: Type the XPath (if you are using XML) or JSONPath (if you are using JSON) query used to
retrieve information from the results of the web service request.

Click OK.
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Configuring SOAP web service data providers

You can configure Hyland DataTransfer to use SOAP web service data providers for communication.
Perform the following steps to configure a SOAP web service data provider.

1. Add and configure a SOAP web service connection. Refer to Adding and modify SOAP web service
connections.

2. To provide the appropriate permissions to configure the SOAP web service data provider, enable the
Edit Data Providers privilege in Administration > User. For more information about privileges, refer
to Configuring Users and Privileges.

Add a SOAP web service data provider. Refer to Adding and modify SOAP web service connections.
Configure the SOAP web service data provider. Refer to Modifying SOAP web service data providers.
Test the SOAP web service data provider. Refer to Testing data providers.

Create a SOAP web service header. Refer to Configuring and modifying web service headers.
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Create a job that uses the SOAP web service connection and header. Refer to Configuring Jobs and
Processing Records.

8. Configure the code to run the SOAP web services. Refer to Configuring data provider program
functions.

Adding SOAP web service data providers
To add a SOAP web service data provider, complete the following steps.
1. Select Configuration > Data Providers.
2. In the Data Provider Administration dialog box, click &
3. Inthe Add Data Provider dialog box, complete one of the following actions.
e To add a new data provider, complete the following substeps.
1. Click the Add Data Provider tab.
2. In the Name field, type the name of the data provider.

3. Select SOAP Web Service from the Type drop-down box.

e To add a data provider that another workspace is sharing, complete the following substeps.
1. Click the Add Shared Data Provider tab.

2. From the Workspace drop-down box, select the workspace that is sharing the data
provider.

3. Select the data provider from the Data Provider drop-down box.
4. Click OK.

Modifying SOAP web service data providers
To modify a SOAP web service data provider, complete the following steps.

1. Select Configuration > Data Providers.
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In the Data Provider Administration dialog box, select the SOAP web service data provider you
want to modify and click .

In the Edit SOAP Web Service Data Provider dialog box, in the Name field, type the name of the
SOAP web service data provider.

In the Description field, type descriptive text about the data provider.

From the Connection Group drop-down box, select the connection group that contains the
connection you want to use for the SOAP web service data provider. The connection groups that you
have permission to view and use display in the drop-down box.

From the Connection drop-down box, select the connection, which belongs to the connection group
you selected, to use for the data provider.

After you select a connection, the URL Endpoint field in the right-top pane displays the URL
endpoint for the connection. You cannot modify this field. If you do not provide a valid connection,
the field displays the text A valid web service connection must be selected.

In the SOAP Action field, specify the SOAP web service method that this configuration requests.

From the HTTP Method drop-down box, select the HTTP method used by the SOAP web service
request(GET, POST, PUT, or DELETE).

In the SOAP Message field, enter the XML text of the SOAP message. You can optionally use the {#}
notation to denote portions of XML that should be substituted at runtime with the values of the
corresponding program variables.

Example
<m13:COMMON ID>{2}</ml13:COMMON ID>
<ml13:SEQ 3C>{3}</ml3:SEQ 3C>

The {2}, and {3} are substituted at runtime. You can map program variables to the occurrences of the
# notation, substituting the value of the program variable into the occurrence. For example, if you
map the $ps7 variable to {2}, at runtime, the value of the $ps1 variable is inserted in the XML file
between the <m13:COMMON _ID> and </m13:COMMON_ID> tags. To map program variables, refer
to the following step.

To map Hyland DataTransfer program variables to web service input and output parameters, drag
and drop variables from the Program Variables pane to the Input and Output tabs.

When you add an input or output parameter, the name of the program variable is the name of the
input or output parameter and it appears in the Name column.

To modify an input value, click the Input tab, double-click the field, and type the appropriate
information.

o Description: Type descriptive text about the parameter.

e Location: Ordinal value of the field. The first field has a value of {0} (zero), the second field has a
value of {1}, and so on

o Substitution Expression: Type the values for the input fields. You must always use {0} for the
substitution value. When you run the web service, the value of the program variable is substituted
for {0}.
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7.

To modify an output value, click the Output tab, double-click the field, and type the appropriate
information.

o Description: Type descriptive text about the parameter.

¢ Query: Type the XPath or JSONPath query you use to retrieve information from the results of the
SOAP web service request.

Click OK.

Testing data providers

To test a data provider, complete the following steps.

1.
2.

Select Configuration > Data Providers.

In the Data Provider Administration dialog box, select the data provider you want to test and click

In the Edit Web Service Data Provider or Edit SOAP Web Service Data Provider dialog box, click
Test.

In the Web Service Test dialog box, in the Input Data pane, double-click the Value column and type
a value to test.

Click Execute. The following occurs.

e The Request URL tab displays the full URL used for the web service. If you did not select a web
service connection when testing the web service, the test does not work and the Request URL
tab displays a Malformed URL message.

e The Output field displays the values of the output parameters.
e The Request Payload tab displays the full payload sent in the request.

e The Raw Response pane displays the HTTP response code and the raw XML or JSON returned
in the response.

Configuring data provider program functions

After you configure a web service or SOAP web service connection and a web service or SOAP web
service data provider, you can run these web services in the code using the following DataProviderCall,
DataProviderPrompt, and begin-dataprovider keywords.

Understanding the DataProviderCall function

This function uses two parameters.

The $webServiceName parameter is the name of the web service to run.

The optional spayload parameter replaces the existing payload value of the web service before it

runs. Using this parameter, you can dynamically create the payload and pass it to the web service at
runtime.
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Use the following syntax.

DataProviderCall ($SwebServiceName, S$Spayload)
For example:

let $ws_id = '10'

DataProviderCall ('personWS')

In this example, personWS is the name of the web service you run. When Hyland DataTransfer reaches
this line of code, it performs the following tasks to run the personWS web service.

1. Hyland DataTransfer looks up the web service by the supplied data provider name.

2. It verifies the current connection group ( the group configured for the job configured to run) for the saved
connection name.

3. Hyland DataTransfer finds the connection for the connection group. One of the following situations
occurs.

e Ifit finds the matching connection, it uses the URL to run the web service request; then, it
populates the input parameters with the values of the mapped program variables. If the web
service returns more than one result, the record suspends with a Too many results returned
reason.

o Ifit does not find a matching connection, the web service request results in an error.

In the preceding example, after you run the person\WS web service, the output values are inserted into the
mapped program variables. The value of the sws_first name parameter is John, the value of the

$ws_last name parameter is Doe, and the value of the $ws_id parameteris 10.

For detailed information about programming concepts and syntax, refer to Appendix A: Programming
Concepts.

Understanding the DataProviderPrompt function

The command runs the specified web service, as described in Understanding the DataProvider Call
function. It also displays a prompt that users can use to view results.

Use the following syntax.

DataProviderPrompt S$prompt, S$webServiceName, S$hidePromptWhenEmpty, S$SautoSelectResult,
Spayload

Example

let Sws_id = ' '

let Sws_first name = ' '

let $ws _last name = ' '

DataProviderPrompt 'Choose the matching person.', 'personWsS'

This function uses two required parameters: a prompt ($prompt) and the name of the web service
($webServiceName).
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You can also set two optional string parameters (for example, string literals, string expressions, string
variables, and so on). Use a v (or y) value to indicate that the option is enabled. You can also use the
optional $payload parameter. The optional parameters are listed below.

e The shidePromptWhenEmpty parameter is a flag to hide the prompt if no results are returned by the
data provider—if the request had no results, Hyland DataTransfer does not prompt the user to select
one.

Example

let Sws_id = ' '

let $ws first name = ' '
let Sws_last name = ' '

DataProviderPrompt 'Choose the matching person.', 'personWS',6 'Y'

e The sautoselectResult parameter is a flag to automatically select the result if exactly one result is
returned by the data provider—if the data provider returns a single record, the record is auto-selected
and no prompt displays.

Example

let Sws_ id = ' !

let Sws_first name = ' '
let Sws_last name = ' '

DataProviderPrompt 'Choose the matching person.', 'personWs', 'yY', 'Y’

e The optional spayload parameter replaces the existing payload value of the web service before it
runs. Using this parameter, you can dynamically create the payload and pass it to the web service at
runtime.

In the Result Selection dialog box, the prompt you supply appears in the field at the top of the dialog
box. All results returned by the web service appear in the table below.

After a user selects a row, the OK button is enabled. If the user clicks OK, all the values from the selected
row are placed into the mapped program variables.

This prompt appears when a job is running in interactive mode only. If this function is processed when a
job is run in batch mode, Hyland DataTransfer checks the number of return results. The web service
performs the following actions.

e |f there are no results, the output program variables are set to the empty string.
e If there is one result, the output values are placed into the mapped program variables.

o |f there is more than one result, the record is suspended with a Too may results reason.

Understanding the begin-dataprovider function

You can use a begin-dataprovider/end-dataprovider block of code to run a specified data provider and
iterate over its results. Use the following syntax.

begin-dataprovider S$webServiceName
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For example, consider the following begin-select syntax.
begin-select
nu id ~#pers nuid let
#nu_id = #pers nuid let
$status = 'M'
let Smtch code = 'MP1'
store 1, '#nu_ id' ! rank, ID - will be fed to review process
stop ! exit match process here
FROM nu_person WHERE ssn = ~$f ssn

end-select

The preceding example could use a data provider instead of a SQL query, as shown in the following
example.

begin-dataprovider 'personWS'

let S$status = 'M'

let $mtch code = 'MP1'

store 1, 'Sws_id' ! rank, ID - will be fed to review process
stop ! exit match process here

end-dataprovider

After begin-dataprovider, you must provide the name of the data provider to run. In the preceding
example, personws is the name of the data provider.

The same code can be used inside begin-select as itis inside begin-dataprovider. Also, similar to
begin-select, begin-dataprovider runs the data provider and iterates over the results, running the
lines of codes for each result.

Like an exit-select statement that exits the begin-select/end-select code block, exit-dataprovider
exits the begin-dataprovider/end-dataprovider code.

You can use the optional spayload parameter to replace the existing payload value of the web service
before it runs. Using this parameter, you can dynamically create the payload and pass it to the web
service at runtime. Use the following syntax.

begin-dataprovider $webServiceName S$payload

Deleting data providers

To delete a data provider, complete the following steps.
1. Select Configuration > Data Providers.

2. Inthe Data Provider Administration dialog box, select the data provider you want to delete and click

The data provider is deleted and is removed from the Data Provider Administration dialog box.
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Copying data providers

To create a duplicate of a data provider, complete the following steps.

1. Select Configuration > Data Providers.

2. Inthe Data Provider Administration dialog box, select the data provider you want to copy and click

U1,

A copy of the data provider is created and appears in the Data Provider Administration dialog box.

Removing sharing on data providers

To remove sharing on a data provider that is shared with another workspace, complete the following

steps.

1. Select Configuration > Data Providers.

2. In the Data Provider Administration dialog box, select the data provider for which you want to remove
sharing and click &5.

Sharing is removed on the data provider.

Rolling back data providers

If changes are made and committed to a data provider, complete the following steps to obtain a previous

version.

1. Select Configuration > Data Providers.

2. In the Data Provider Administration dialog box, select the data provider you want to roll back and
click & .

3. The Rollback Manager dialog box appears and displays the following information.

Name: Name of the data provider.

Status: Status of the data provider (current or dated).

Version Date: Date and time on which the version was created.
Created By: User name of the user who created the data provider.

Comments: Comments that were added by the user.

4. Select the previous version to which you want to revert and click Rollback.

The previous version is loaded.

Obtaining the latest versions of data providers

If changes have been made to and committed to a data provider, you can obtain the latest version of it by
completing the following steps.

1. Select Configuration > Data Providers.

2. Inthe Data Provider Administration dialog box, select the data provider for which you want to
obtain the latest version and either right-click it and select Get Latest or click &,
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Exporting data providers

To export a data provider to an XML file, complete the following steps.

Note: You cannot export data providers in tablet view.

1.

2
3.
4

Select Configuration > Data Providers.
In the Data Provider Administration dialog box, select the data provider you want to export.
Click <~ = and select Export.

Save the file to the appropriate location.

Importing data providers

To import a data provider from an XML file, complete the following steps.

Note: You cannot import data providers in tablet view.

1.
2.
3.

Select Configuration > Data Providers.
In the Data Provider Administration dialog box, click <~ ~ and select Import.

In the Import Data Provider dialog box, click the Browse button and navigate to the file that you
want to import or type the location of the file in the File field.

Select the Update Existing Entities check box to update an existing data provider with the same
name as the data provider you are importing.

If you do not select this check box and there is an existing data provider with the same name as the
data provider you are importing, DUPLICATE- is appended to the start of the name of the data
provider you are importing; the existing data provider is not updated. If a data provider exists with the
name DUPLICATE-<data_provider_name>, DUPLICATE(2)- is appended to the start of the name.
The number continues to be incremented so that all data providers have unique names.

Click OK.
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Configuring Document Templates

You can configure document templates that can be used in the NQL code to create files based on the
template definition for uploading to Nolij Web or ImageNow.

Adding and Modifying Document Templates
To add a document template, do the following.
1. Select Configuration > Document Templates.
2. In the Document Administration dialog box, perform one of the following actions.

e To add a new document template, click = to display the Add Document Template dialog box
and perform one of the following actions.

e To add a new document template, click the Add Document Template tab and type a name
for the template in the Name field.

e To add a document template that another workspace is sharing, click the Add Shared
Document Template tab. Then, from the Workspace drop-down box, select the workspace
that is sharing the document template, and select the template from the Document Template
drop-down box.

e To modify a document template, select the template you want to modify and either right-click it
and select Edit or click ¢« to display the Edit Document Template dialog box.

3. Click OK.
Note: In the name field, type the name of the document template.
In the Description field, type descriptive text about the template.
In the Type field, type the file type (the file extension) for the file created from the template.

In the Template field, click Browse and navigate to the location of the document template you want
to upload.

Note: You cannot upload document templates in tablet view.

The contents of the file appears in the text field below the Browse... button, and the Type field
displays the type of the uploaded document template. You can modify both fields.

Document template text can contain program variables. When a document is created from the
template, the variables are replaced with their values, creating a dynamic, context-sensitive
document. Use the PopulateTemplate function in the NQL to create such a document (for more
information, refer to Understanding the PopulateTemplate faction).

7. Click OK.
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Deleting Document Templates
To delete a document template, do the following.
1. Select Configuration > Document Templates.

2. In the Document Template Administration dialog box, select the document template you want to
delete and either right-click it and select Delete or click *='.

The document template is deleted and is removed from the Document Template Administration dialog
box.

Copying Document Templates
To create a duplicate of a document template, do the following.
1. Select Configuration > Document Templates.

2. In the Document Template Administration dialog box, select the document template you want to
copy and either right-click it and select Copy or click "L1.

A copy of the document template is created and appears in the Document Template Administration
dialog box.

Removing Sharing on Document Templates
To remove sharing on a document template that is shared with another workspace, do the following.
1. Select Configuration > Document Templates.

2. Inthe Document Template Administration dialog box, select the document template for which you
want to remove sharing and either right-click it and select Remove Sharing, or click &5

Sharing is removed on the document template.

Rolling Back Document Templates

If changes have been made and committed to a document template, you can use a previous version (roll
back) of it.

1. Select Configuration > Document Templates.

2. In the Document Template Administration dialog box, click the document template you want to roll
back and either right-click it and select Rollback or click “=.

3. The Rollback Manager dialog box appears and displays the following information.
e Name: Name of the document template.
e Status: Status of the document template (current or dated).
e Version Date: Date and time on which the version was created.
e Created By: Username of the user who created the document template.
e Comments: Comments that were added by the user.

4. Select the previous version to which you want to revert and click Rollback. The previous version is
loaded.
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Obtaining the Latest Versions of Document Templates

If changes have been made to and committed to a document template, you can obtain the latest version
of it.

1.
2.

Select Configuration > Document Templates.

In the Document Template Administration dialog box, click the document template for which you
want to obtain the latest version and either right-click it and select Get Latest or click &' .

Exporting Document Templates

Note: You cannot export document templates in tablet view.

You can export a document template to an XML file by doing the following.

1.
2.

Select Configuration > Document Templates.

In the Document Template Administration dialog box, select the document template you want to
export.

Click ¢~ ~ and select Export.

Save the file to the appropriate location.

Importing Document Templates

Note: You cannot import document templates in tablet view.

You can import a document template from an XML file by doing the following.

1.

2.
3.

Select Configuration > Document Templates.
In the Document Template Administration dialog box, click < = and select Import.

In the Import Document Template dialog box, click the Browse button and navigate to the file that you
want to import or type the location of the file in the File field.

Check the Update Existing Entities check box to update an existing document template, with the
same name as the document template you are importing, with the document template you are
importing.

If you do not check this check box, and there is an existing document template with the same name
as the document template you are importing, DUPLICATE- is appended to the start of the name of
the document template you are importing; the existing document template is not updated. If a
document template exists with the name DUPLICATE-<document_template_name>, DUPLICATE(2)-
is appended to the start of the name. The number continues to be incremented so that all document
templates have unique names.

Click OK.
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Configuring ImageNow Index Maps

You can define ImageNow index maps, which are used when uploading ImageNow documents to
ImageNow, using Hyland DataTransfer. Index maps obtain document information from the specified
integration server connection and link ImageNow document properties to program variables in the code.
Use the ImageNowAddDoc syntax in the code to configure parameters used by Hyland DataTransfer to
upload ImageNow documents.

For more information about integration server connections, refer to Adding and modifying integration
server connections. For more information about the ImageNowAddDoc syntax, refer to Understanding the
ImageNowAddDoc function.

Refer to the following topics for more information.

Adding and Modifying ImageNow Index Maps

Deleting ImageNow Index Maps

Copying ImageNow Index Maps

Removing Sharing on ImageNow Index Maps

Rolling Back ImageNow Index Maps

Obtaining the Latest Versions of ImageNow Index Maps
Exporting ImageNow Index Maps

Importing ImageNow Index Maps

Adding and Modifying ImageNow Index Maps

Note: You cannot add ImageNow index maps in tablet view. To add an ImageNow index map, do the
following.

1.
2.

Select Configuration > ImageNow.

In the ImageNow Index Map Administration dialog box, perform one of the following actions.

e Toadd a new index map, click ‘@ . This button does not appear in tablet view; you cannot add
ImageNow index maps in tablet view.

1. Inthe Add ImageNow dialog box, perform one of the following actions.

e To add a new index map, click the Add ImageNow tab. Then, in the Name field, type the
name of the index map.

e To add an index map that another workspace is sharing, click the Add Shared
ImageNow tab. Then, from the Workspace drop-down box, select the workspace that
is sharing the index map, and select the index map from the ImageNow Entity drop-
down box.

2. Click OK.

¢ To modify an index map, select the index map and either right-click it and select Edit or click .
The Edit ImageNow Index Map dialog box appears.
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3. From the Connection Group drop-down box, select the connection group that contains the
integration server connection to use. This connection group is not saved with an association to the
index map; it is used to obtain custom ImageNow document properties as program variables for the
index map.

For more information about adding integration server connections, refer to Adding and modifying
integration server connections.

In the Name field, type the name of the index map. The name must be unique.
In the Description field, type descriptive text about the index map.

In the Drawer field, specify the ImageNow drawer that contains the ImageNow documents by
dragging and dropping the appropriate program variable from the Program Variables pane. This field
is required.

To remove an entry, right-click the field and select Clear.

7. In the Document Type field, specify the ImageNow document type, contained in the ImageNow
drawer, to which to link to the ImageNow index map by dragging and dropping the appropriate
program variable from the Program Variables pane. This field is required.

To remove an entry, right-click the field and select Clear.

8. In the Field 1 through Field 5 fields, define the index fields for the document by dragging and
dropping the appropriate program variables from the Program Variables pane to each field. You can
also leave each field empty.

When the ImageNowAddDoc function executes, the code inserts these fields with the values
contained in the specified program variables.

9. In the Custom Properties pane, add or modify the ImageNow custom properties associated with the
index map by completing the following substeps.

1. To add a new property, click &

The Select Custom Properties dialog box appears. It displays all available ImageNow custom
properties, excluding any that you have already added to the index map.

2. Select one or more properties to add to the index map. To select multiple properties:
e Click a property and press and hold the Ctrl key as you click each property with your mouse.

e Click a property and press and hold the Shift key as you click another property to select
contiguous properties.

3. Click OK. The selected properties appear in the Custom Properties pane.

4. Link program variables to the custom properties by selecting a program variable in the
Program Variables pane and dragging and dropping it to the appropriate custom
property.
10. To delete a custom property from the ImageNow index map, select the property you want to delete in
the Custom Properties pane and click the Delete button or right-click it and select Delete.

Use the ImageNowAddDoc function in your code to configure the parameters used by Hyland
DataTransfer to upload ImageNow documents. For more information, refer to Understanding the
ImageNowAddDoc function.
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Deleting ImageNow Index Maps
To delete an index map, complete the following steps.
1. Select Configuration > ImageNow.

2. Inthe ImageNow Index Map Administration dialog box, select the index map you want to delete
and either right-click it and select Delete or click ="

The index map is deleted and is removed from the ImageNow Index Map Administration dialog box.

Copying ImageNow Index Maps
To create a duplicate of an ImageNow index map, do the following.
1. Select Configuration > ImageNow.

2. Inthe ImageNow Index Map Administration dialog box, select the index map you want to copy and
either right-click it and select Copy or click “L1.

A copy of the index map is created and appears in the ImageNow Index Map Administration dialog box.

Removing Sharing on ImageNow Index Maps
To remove sharing on an index map that is shared with another workspace, complete the following steps.
1. Select Configuration > ImageNow.
2. In the ImageNow Index Map Administration dialog box, select the index map for which you want to
remove sharing and either right-click it and select Remove Sharing, or click 88

Sharing is removed on the index map.

Rolling Back ImageNow Index Maps

If changes have been made and committed to an ImageNow index map, you can use a previous version
(roll back) of it.

1. Select Configuration > ImageNow.

2. In the ImageNow Index Map Administration dialog box, click the index map you want to roll back
and either right-click it and select Rollback or click “=. The Rollback Manager dialog box appears
and displays the following information.

¢ Name: Name of the ImageNow index map.
e Status: Status of the index map (current or dated).
e Version Date: Date and time on which the version was created.
e Created By: Username of the user who created the index map.
e Comments: Comments that were added by the user.
3. Select the previous version to which you want to revert and click Rollback.

The previous version is loaded.
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Obtaining the Latest Versions of ImageNow Index Maps

If changes have been made to and committed to an index map, you can obtain the latest version of it.

1.
2.

Select Configuration > ImageNow.

In the ImageNow Index Map Administration dialog box, click the index map for which you want to
obtain the latest version and either right-click it and select Get Latest or click &/ .

Exporting ImageNow Index Maps

Note: You cannot export ImageNow index maps in tablet view.

You can export an ImageNow index map to an XML file by doing the following.

1.

2
3.
4

Select Configuration > ImageNow.
In the ImageNow Index Map Administration dialog box, select the index map you want to export.
Click ¢ =~ and select Export.

Save the file to the appropriate location.

Importing ImageNow Index Maps

Note: You cannot import ImageNow index maps in tablet view.

1.
2.
3.

Select Configuration > ImageNow.

In the ImageNow Index Map Administration dialog box click <~ = and select Import.

In the Import ImageNow Index Map dialog box, click the Browse button and navigate to the file you
want to import or type the location of the file in the File field.

Check the Update Existing Entities check box to update an existing ImageNow index map, with the
same name as the ImageNow index map you are importing, with the ImageNow index map you are
importing.

If you do not check this check box, and there is an existing ImageNow index map with the same
name as the ImageNow index map you are importing, DUPLICATE- is appended to the start of the
name of the ImageNow index map you are importing; the existing ImageNow index map is not
updated. If an ImageNow index map exists with the name DUPLICATE-<index_map_name>,
DUPLICATE(2)- is appended to the start of the name. The number continues to be incremented so
that all ImageNow index maps have unique names.

Click OK.
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Using Hyland DataTransfer Tools

Refer to the following topics for more information.
e Configuring Lookup Values

e Configuring Names to Check

e Viewing Log Messages

e Configuring Data Exports

e Viewing the Import History

Configuring Lookup Values
Use the lookup tool to specify the data you want to map from the input file to the database.

You configure the Hyland DataTransfer logic to substitute the output value for the input value and store
the output value in your database.

For example, an input file may have a value of Humanities for a department; its corresponding database
(output) value is HUM. You can use the lookup tool to map Humanities as HUM and then configure code
to store Humanities as HUM in your database.

Example syntax for configuring the code is:
let $some var = lookup (“MAJOR”, $MAJR)

When a job is run, lookup mapping for MAJOR determines that the correct output value for Humanities is
HUM. The variable $some_var contains the value HUM. $MAJR contains Humanities.

For more information about configuring procedures, refer to Configuring Procedures. For detailed
information about configuring logic, refer to Appendix A: Programming Concepts.

You can export lookups to an XML file, and you can import lookups from either a Hyland DataTransfer
XML file or a delimited file.

To open the Lookup Administration dialog box, either select Tools > Lookup or click the Lookup button
in the window that appears when you open or edit jobs. When you click the Lookup button, the Lookup
Administration dialog box displays the lookup entries for the header that is being used for the job.

You can filter the entries in the Lookup Administration dialog box by header, by field, or by both. Select
the appropriate header from the Header drop-down box to view entries for that header. Select the
appropriate field from the Field drop-down box to view entries for that field.

Adding Lookup Entries
To add a lookup entry, do the following.
1. Select Tools > Lookup.

2. Inthe Lookup Administration dialog box, click = .

3. Inthe Add Lookup dialog box, from the Header drop-down box, optionally select the header for
which to configure the lookup entry. Select No Header if you want to use this entry for all headers.
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© N o o

From the Field drop-down box, select the header input variable to use or type the input variable in the
Field field. This variable corresponds to the field in the input file that you want to map to a database
valid code (output).

In the In field, type the value of the input variable to map to the output value in the Out field.
In the Out field, type the output value to map to the input value (specified in the In field).
Click Apply.

Click OK.

Modifying Lookup Entries
To modify a lookup entry, do the following.

1.
2.

Select Tools > Lookup.

In the Lookup Administration dialog box, select a lookup entry to modify and either right-click it and
select Edit or click «.

In the Edit Lookup dialog box, in the In field, type the input value, which is the value of the input
variable to map to the database valid code in the Out field.

In the Out field, type the database valid code to map to input value (specified in the In field).
Click OK.

Deleting Lookup Entries

To delete a lookup entry, do the following.

1.
2.

Select Tools > Lookup.

In the Lookup Administration dialog box, select a lookup entry to modify and either right-click it and
select Delete or click ='.

The entry is deleted and is removed from the Lookup Administration dialog box.

Importing Lookup Files

Note: You cannot import lookup files in tablet view.

To import lookup entries from a either a Hyland DataTransfer file or a delimited file, do the following.

1.

2.

Select Tools > Lookup.

In the Lookup Administration dialog box, click ‘::}J
In the Import Lookups dialog box, perform one of the following actions.
e To import a delimited file, do the following.

1. Click the Delimited tab.

2. From the Header drop-down box, select the header file to use.
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3. From the Field drop-down box, select the header input field or type a new field to create it.
This variable corresponds to the field in the input file that you want to map to a database valid
code (output).

4. Specify how the imported file is delimited; either click the Tab radio button or click the
Specify option and then provide a value in the Specify field.

5. In the Upload File field, click Browse and navigate to the file you want to import.
6. Click Upload.

4. To import a Hyland DataTransfer file, click the Transfer File tab. Then, in the File field, click Browse,
navigate to the file you want to import, and select it.

5. Click OK.

The file is imported, and imported lookup values are displayed in the Lookup Administration dialog box.

Exporting Lookup Files

Note: You cannot export lookup files in tablet view. To export lookups as an XML file, do the following.
1. Select Tools > Lookup.

2. In the Lookup Administration dialog box, click (ol

3. Save the file in the appropriate location.

Configuring Names to Check

You can use the Check Name tool to configure different output values that an input name may have. You
can substitute this output value for the input name within the Hyland DataTransfer logic.

For example, for an input name Alexandria, you could use Alex or Lexie as substitutions. Code syntax is:

CHECKNAME inCNamevar, inFNamevar, outCntvar, outNamevarl, outNamevar2, ... outNamevarN

e Thefirst two variables (inCNamevar and inFNamevar) are input variables for which you are
substituting values. inFNamevar is an optional parameter.

e The third variable (outCntvar) specifies the number (count) of output variables.
e Variables that appear after the third variable (outCntvar) are the output variables.

When the Hyland DataTransfer logic is run, it searches for matches between the input and output
variables. If values for output variables are found, the output variables are populated with all variations of
the input name. If no matches are found, the input name is assigned to the output variables.

For more information about configuring procedures, refer to Configuring Procedures. For detailed
information about logic, refer to Appendix A: Programming Concepts.

You can import check name values from and export values to an XML file.

To open the Check Name Administration dialog box, select Tools > Check Names.
Refer to the following topics for more information

e Adding and Modifying Names

e Deleting Names

e Importing Names
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e Exporting Names

Adding and Modifying Names
To add or modify a name, complete the following steps.
1. Select Tools > Check Names.
2. Inthe Check Name Administration dialog, perform one of the following actions.
e Toadd a new name, click = . The Add New Check Name dialog box appears.
¢ To modify a name, select the name and click . The Edit Check Name dialog box appears.
3. To add a new value to the name, complete the following substeps.
1. Click “& to display the New Check Name Value dialog box appears.
2. Inthe Value field, type the value that the name can have.

Note: You cannot add a value that is already configured for another entry. You can only use a
value once.

3. Click Apply to add the value to the check name entry.
4. Continue adding values for the name, and then click OK.
8. To modify a value, complete the following steps.
5. Select the value you want to modify and either right-click it and select Edit or click «".
6. In the Edit dialog box, type the value in the appropriate field and click OK.

9. To delete a value, select the value you want to delete and either right-click it and select Delete or
click =

The value is deleted and is removed from the dialog box.

Deleting Names
To delete a name, do the following.
1. Select Tools > Check Names.

2. Inthe Check Name Administration dialog box, select the value you want to delete and either right-
click it and select Delete or click '='.

3. Inthe dialog box, click Yes to confirm that you want to delete the name.

The name is deleted, and all its associated values are deleted; the name is removed from the Check
Name Administration dialog box.

Importing Names

Note: You cannot import names in tablet view.

To import names form an XML file, complete the following steps.
1. Select Tools > Check Names.

2. In the Check Name Administration dialog box, click <= = and select Import.

3. Inthe Import Check Names dialog box, click Browse and navigate to the file that you want to import.
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4. Click OK.

Exporting Names

Note: You cannot export names in tablet view. To export names to an XML file, do the following.

1.
2.

Select Tools > Check Names.

In the Check Name Administration dialog box, click =

~ and select Export.

3. Save the XML file in the appropriate location.

Viewing Log Messages

You can view log messages that provide information about Hyland DataTransfer jobs.

1.

o M wobN

Perform one of the following actions.

¢ Inthe Job dashboard, select a job and click the Log button.

¢ In the Job dashboard, right-click a job and select Log.

¢ Inthe Job Dashboard, select a job in the table and either right-click it and select Open or click the

e Open button; then, in the window that appears, click Log.

e Select Tools > Logs. The Log View dialog box appears and displays the following columns of
information.

Job Name: Name of the job.

Type: Type of log message (error, SQL). To log SQL messages, check the Log SQL check
box in the Add Job dialog box for the appropriate job; refer to Adding new jobs.

Message: Body of the log message.
User: Username of the user who was logged in.

Date/Time: Date and time on which the message was logged.

To filter messages by job, select the job from the Job drop-down box.

To filter messages by type, select the type of log message from the Type drop-down box.

To export messages in XML format, click L= and then save the file in the appropriate location.

To view the suspend reason for suspended records, click the log record that indicates that a record
status changed to Suspended and then click —= to open the Detailed Log View dialog box, which
displays the suspend reason.
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Configuring Data Exports

You can use data exports to create SQL queries to obtain content from any database configured for
Hyland DataTransfer. You can save the results and export them to a delimited file.

You can share data exports with other workspaces, and you can import data exports from and export
data exports to an XML file.

Refer to the following topics for more information.

Understanding Data Export Icons

Adding Data Exports

Configuring and Modifying Data Exports

Copying Data Exports

Deleting Data Exports

Running Data Exports

Extracting Data Exports

Removing Sharing on Shared Data Exports

Rolling Back Data Exports

Importing Data Exports

Exporting Data Exports

Configuring Scheduled Data Export Rules

Understanding Data Export Icons

The following table describes data export icons and their descriptions.

Icon Description
<« Data export is shared
s Data export is shared and has been modified.
oty Data export is not shared and has been modified.
9 Date export has not been modified.

If you are working in a workspace version in edit mode, the data export is not shared. If
you are working in a workspace version in a mode other than edit mode, this icon displays
for all data exports. The sharing status is unknown.
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Adding Data Exports
To add and configure a data export, do the following.
1. Select Tools > Data Exports > Configure.
2. Inthe Data Exports Administration dialog box, click = .
3. Inthe Add Data Export dialog box, perform one of the following actions.
e To add a new data export, do the following.
7. Click the Add Data Export tab.
8. Type a name in the Name field and click OK.
e To add a data export that is shared by another workspace, do the following.
1. Click the Add Shared Data Export tab.

2. From the Workspace drop-down box, select the workspace that shares the data export you
want to add.

3. From the Data Export drop-down box, select the shared data export that you want to add.
4. Click OK.

The data export is added and appears in the Data Export Administration dialog box.

Configuring and Modifying Data Exports
1. Select Tools > Data Exports > Configure.

2. Inthe Data Exports Administration dialog box, either right-click the data export you want to
configure and select Edit or click «.

In the Edit Data Export dialog box, to rename the data export, type the name in the Name field.
From the Connection Group drop-down box, select the connection group to use.
From the Connection drop-down box, select the database connection to use.

In the Data Extract SQL field, type the appropriate SQL code for data extract.

N o o s~ o

Define the format of the delimited file that contains the data returned by the query. Click the Tab radio
button to specify that the file is tab-delimited, or click the Specify tab to provide your own value and
then type the value in the corresponding field.

8. Check the Include Date and Time check box to include the date and time in the name of the data
export file.

10. Click OK.

Copy Data Exports
To create a duplicate of a data export, do the following.

1. Select Tools > Data Exports > Configure.

2. In the Data Exports Administrator dialog box, select the data export you want to copy and click (.

The data export is duplicated, and its copy appears in the Data Export Administration dialog box.
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Deleting Data Exports
To delete a data export, do the following.
1. Select Tools > Data Exports > Configure.

2. Inthe Data Exports Administrator dialog box, select the data export you want to delete and either
right-click it and select Delete or click = The data export is deleted.

Running Data Exports

To run the query and view the data returned from the database, do the following.

1. Select Tools > Data Exports > Configure.

2. Inthe Data Exports Administrator dialog box, select the data export you want to run.
3. Click =

4. Click =#.

11. One of the following occurs.

e If there are issues with the SQL code, a dialog box appears and displays information about the
problem.

e If there are no issues with the SQL code, results of the data export are displayed in the Results
pane.

Extracting Data Exports

You can run the query you created and export the data returned to a file-delimited format you specified in
the Edit Data Export dialog box (refer to Configuring and Modifying Data Exports).

Note: You cannot extract data exports in tablet view.
1. Select Tools > Data Exports > Configure.

2. Inthe Data Exports Administrator dialog box, select the data export you want to extract and either
right-click it and select Extract or click ~=# .

3. Inthe Extract Data Export dialog box, complete the following substeps.

1. From the Connection Group drop-down box, select the connection group you want to
use.

From the Connection drop-down box, select the connection you want to use.
Click OK.

Save the file with the extracted data in the appropriate location.

Removing Sharing on Shared Data Exports

To remove sharing on data exports that are shared with another workspace, do the following.

1. Select Tools > Data Exports > Configure.

2. In the Data Exports Administrator dialog box, select the date export for which you want to remove

sharing and click &
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Sharing is removed on the data export.

Rolling Back Data Exports

If changes have been made and committed to a data export, you can use a previous version (roll back) of
it.

1. Select Tools > Data Exports > Configure.

2. Inthe Data Exports Administrator dialog box select the data export you want to roll back and either

right-click it and select Rollback or click = . The Rollback Manager dialog box appears and
provides the following information.

o Name: Name of the data export.

e Status: Status of the data export (current or dated).

e Version Date: Date and time on which the version was created.

e Created By: Username of the user who created the version.

¢ Comments: Comments, if any, added by the user for the version.
3. Select the version that you want to use and click OK.

The previous version is loaded.

Importing Data Exports
Note: You cannot import data exports in tablet view. To import a data export, do the following.
1. Select Tools > Data Exports > Configure.

2. In the Data Exports Administrator dialog box, select #~ ~ and select Import.

3. Inthe Import Data Export dialog box, click Browse to navigate to the location of the file you want to
import, and then select it.

4. Check the Update Existing Entities check box to update an existing data export, with the same
name as the data export you are importing, with the data export you are importing.

If you do not check this check box, and there is an existing data export with the same
name as the data export you are importing, DUPLICATE- is appended to the start of the
name of the data export you are importing; the existing data export is not updated. If a
data export exists with the name DUPLICATE-<data_export_name>, DUPLICATE(2)-is
appended to the start of the name. The number continues to be incremented so that all
data exports have unique names.

5. Click OK.
The data export is imported and is displayed in the Data Export Administration dialog box.

Exporting Data Exports

Note: You cannot export data exports in tablet view.
To export a data export as an XML file, do the following.
1. Select Tools > Data Exports > Configure.

2. Inthe Data Exports Administrator dialog box, click = = and select Export.
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3. Save the file in the appropriate location.

Configuring Scheduled Data Export Rules

You can configure Hyland DataTransfer to run data exports at specified times. You can also view the
output of past data exports.

Refer to the following topics for more information.
e Adding and Modifying Scheduled Data Exports
e Deleting Scheduled Data Exports

e Viewing the Previous Output of Data Exports

Adding and Modifying Scheduled Data Exports

To add or modify a scheduled data export rule, complete the following steps.

1. Select Tools > Data Exports > Schedule.

2. Inthe Schedule Data Exports dialog box, perform one of the following actions.

e To add a new scheduled data export rule, click = . The Add Scheduled Data Export dialog box
appears.

e To modify a scheduled data export rule, select the data export and either right-click it and select
Edit Scheduled Data Export or click = to display the Edit Scheduled Data Export dialog box

appears.
3. In the Name field, type the name of the scheduled data export rule.
4. In the Status field, click the Enable radio button to enable the rule; click Disable to disable it.
5. From the Data Export drop-down box, select the data export to which to assign the rule.
6. From the Connection Group drop-down box, select the Connection Group used for the data
export.
7. From the Connection drop-down box, select the connection used for the connection group.

From the Start Time drop-down box, select the time on which the report is run.

In the Options pane, click the Run in Edit Version check box to run the rule against the edit version of
the workspace (the rule is run against the edit version of the data export and connection). If you do
not check this check box, the rule is run against the active version of the workspace.

10. In the Recurrence Pattern pane, specify when the report recurs.

e Click the Once radio button to run the data export once. After the data export is run, rules for
running the data export are disabled.

o Click the Daily radio button to specify that the data export is run daily, and then specify the
recurrence frequency.

o Click the Weekly radio button to specify that the data export is run weekly, and then specify the
recurrence frequency.

e Click the Monthly radio button to specify that the data export is run monthly, and then specify the
recurrence frequency.
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11. Click the Notifications tab to configure notifications to be sent to recipients when certain data export
actions occur. Refer to Configuring Notifications.

12. Click OK.

Deleting Scheduled Data Exports

To delete a scheduled data export rule, do the following.

1. Select Tools > Data Exports > Schedule.

2. Inthe Schedule Data Exports dialog box, select the rule you want to delete and either right-click it

and select Delete or click ='. In the dialog box, click Yes to confirm that you want to delete the rule.

The rule is deleted and is removed from the Schedule Data Exports dialog box.

Viewing the Previous Output of Data Exports

To view the previous output of the scheduled data export, perform one of the following actions.
Note: You cannot view data export output in tablet view.

e Select Tools > Data Exports > View.

e Select Tools > Data Exports > Schedule.

The Schedule Data Exports dialog box appears. Next, select the data export for which you want to view
previous results and click = .

The View Data Exports dialog box appears and displays a table with the following information.
e Date: Date on which the data export was created.

¢ Name: Name of the data export.

e Data Export Rule Name: Name of the rule that caused the scheduled report to be run.

¢ Created By: Username of the administrator who configured the data export.

You can filter the information in the View Data Exports dialog box by selecting the appropriate
information in one or more of the following fields.

e Data Export Rule: Select the data export rule for which to filter results.

e Data Exports: Select the data export for which to filter results. Select All to specify all data exports.

e Date Range fields: Click the 4 icon to open a calendar from which you can specify the start and
end dates of a date range. You can choose both start and end dates or only a start or end date.

After specifying the filter information, click the Filter button to update the table with the selected criteria.

To view a data export, click =/ . The data export opens in a new tab or browser window in PDF format.

To permanently delete the data export and the record of the data export instance, click =
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Viewing the Import History

To view the import history, do the following.

1.

Select Tools > Import History.

The Import History dialog box appears and displays the following columns of information.
Name: Name of the object imported into Hyland DataTransfer (for example, Workspace or
Data Export).

Type: Type of import (Full Import or Partial Import).

Date Created: Date and time on which the object was imported.

Created By: Username of the user who imported the object.

To view details about the Hyland DataTransfer objects that were imported, select the entry in the
table and either right-click it and select Import Details or click “

The Import Report dialog box appears and displays information about the objects imported into Hyland
DataTransfer.

Configuring Notifications

You can configure Hyland DataTransfer to send notifications to users when various activities occur in
Hyland DataTransfer. You can configure notifications for jobs, scheduled reports, and version
milestones.

Refer to the following topics for more information.

Configuring Email Addresses
Configuring Notification Groups
Configuring Job Notifications
Configuring Report Notifications

Configuring Workspace Version Notifications

Configuring Email Addresses

You must have the appropriate permissions to configure the SMTP server from which notifications can be
sent, and you must also have the appropriate permissions to configure email addresses for users to
which these notifications are sent.

Refer to Configuring Users and Privileges. To configure system email addresses, do the following.

1.

Select Administration > System Properties > System E-Mail. The Configure System Email dialog
box appears.

In the Configure System Email dialog box, in the Email address field, type the email address used
that sends the system notifications.

In the Host field, type the hostname of the SMTP server that sends the emails.
In the Port field, type the port number of the SMTP server.

In the Username field, type the username of the SMTP server.
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6. Inthe Password field, type the password of the SMTP server.
Click OK.

You can assign email addresses to Hyland DataTransfer users; these are the emails addresses at
which users receive emails sent from the SMTP server. To do so, do the following.

Note: The name and email address is updated for all users in the system with this username. For
example, if user GUEST has multiple roles and therefore multiple instances in the system, the name
and email address you configure for one instance of GUEST is used for all instances of that user.

1. Select Administration > User.

2. Inthe User Administration dialog box, in the Navigation pane, click the user for which
you want to configure email settings.

In the Name field, type the name of the user for the email address.
In the Email field, type the name of the email address for the user.
Click Save.

Configuring Notification Groups

After you have configured the system email address from which notifications are sent and the email
addresses to which users receive those notifications, you can configure notifications for a variety of
functions.

You can configure notification groups, which contain lists of email recipients (similar to an email
distribution list), to which to send these notifications.

You must have the appropriate permissions to add and modify notification groups. Refer to Configuring
Users and Privileges.

Refer to the following topics for more information.
e Adding and Modifying Notification Groups

e Deleting Notification Groups

Adding and Modifying Notification Groups
To add a notification group, do the following.
1. Select Configuration > Notifications.
2. In the Notification Group Configuration dialog box, perform one of the following actions.
e To add a new notification group, click = to display the Add Notification Group dialog box.

e To modify a group, select it and click = to display the Edit Notification Group dialog box
appears.

3. Inthe Name field, type the name of the notification group.
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4. Inthe To field, provide the email addresses of the recipients of the notifications. Perform one of the
following actions.

e Manually type the email addresses in the field, separating recipients by commas.

e Click the To button to open the Select Users dialog box. Select one or more recipients and click
OK.

5. Inthe CC field, provide the email addresses of the recipients to which to send copies of the
notifications. Perform one of the following actions.

o Manually type the email addresses in the field, separating recipients by commas.

¢ Click the CC button to open the Select Users dialog box. Select one or more recipients and click
OK.

Deleting Notification Groups

To delete a notification group, complete the following steps.

1. Select Configuration > Notifications.

2. Inthe Notification Group Configuration dialog box, select the group you want to delete and click
Configuring Job Notifications

You can configure notifications to be sent when a job activity occurs. Refer to the following topics for
more information.

e Adding and Modifying Job Notifications

e Deleting Job Notifications

Adding and Modifying Job Notifications
To add a job notification, complete the following steps.
1. In the Job Dashboard, perform one of the following actions.
e Select Jobs > Add Jobs to display the Add Job dialog box.

e Select Jobs > Recurring Jobs to display the Recurring Job Administration dialog box appears.

2. Click the Notifications tab.

Perform one of the following actions.
e To add a new notification, click “¥ to display the Add Job Notification dialog box.

¢ To modify a notification, select it and click " to display the Edit Job Notification dialog box
appears.

4. From the Action drop-down box, select the job action that occurs for which a notification is sent.
Options are Complete or Processed.

When a job attains Processed or Complete status, the appropriate notifications are sent to the
provided email addresses.
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7.

Select the recipients to which to send the notifications. You can either select a configured notification
group (refer to Configuring Notification Groups, or you can specify recipients notin a group.

e To select a notification group, select the appropriate group from the drop-down box. The To and
CC fields automatically display the recipients configured for the notification group, and you
cannot modify these fields.

e To specify recipients not in a group, complete the following substeps.

1. Inthe To field, provide the email addresses of the recipients of the notifications. Perform one
of the following actions.

¢ Manually type the email addresses in the field, separating recipients by commas.

e Click the To button to open the Select Users dialog box. Select one or more recipients
and click OK.

In the CC field, provide the email addresses of the recipients to which to send copies of the
notifications. Perform one of the following actions.

¢ Manually type the email addresses in the field, separating recipients by commas.

¢ Click the CC button to open the Select Users dialog box. Select one or more recipients
and click OK.

Click OK.

Deleting Job Notifications

To delete a job notification, complete the following steps.

1.
2.

3.

Select Jobs > Add Jobs.
In the Add Job dialog box, click the Notifications tab.

Select the notification you want to delete and click =' .

Configuring Report Notifications

You can configure report notifications when certain report activities occur. Refer to the following topics
for more information.

Adding and Modifying Report Notifications
Deleting Report Notifications

Adding and Modifying Report Notifications

1.
2.

Select Reports > Schedule.
In the Schedule Reports dialog box, perform one of the following actions.
e To add a new report, click “ to display the Add Scheduled Report dialog box.

To modify a report, select the report and either right-click it and select Edit Report or click « . The
Edit Scheduled Report dialog box appears.

Click the Notifications tab.
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4. Perform one of the following actions.

e To add a new notification, click ¥ to display the Add Report Notification dialog box.

¢ To modify a notification, select it and click ¢ . The Edit Report Notification dialog box appears.

5. From the Action drop-down box, select the report action that occurs for which a notification is sent.
Option is Complete.

When a report is Complete, a notification is sent to the specified recipients, and a PDF version of the
report is included as an attachment in the email.

6. Select the recipients to which to send the notifications. You can either select a configured notification
group (refer to Configuring Notification Groups), or you can specify recipients notin a group.

e To select a notification group, select the appropriate group from the drop-down box. The To and
CC fields automatically display the recipients configured for the notification group, and you
cannot modify these fields.

e To specify recipients not in a group, do the following.

1.

7. Click OK.

In the To field, provide the email addresses of the recipients of the notifications. Perform
one of the following actions.

Manually type the email addresses in the field, separating recipients by commas.

Click the To button to open the Select Users dialog box. Select one or more recipients
and click OK.

In the CC field, provide the email addresses of the recipients to which to send copies of
the natifications. Perform one of the following actions.

Manually type the email addresses in the field, separating recipients by commas.

Click the CC button to open the Select Users dialog box. Select one or more recipients
and click OK.

Deleting Report Notifications
To delete a report notification, do the following.
1. Select Reports > Schedule.

2. In the Schedule Report dialog box, click the Notifications tab.

3. Select the notification you want to delete and click '='.
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Configuring Workspace Version Notifications

You can configure notifications to be sent when certain version activities occur. Refer to the following
topics for more information.

Adding and Modifying Workspace Version Notifications

Deleting Workspace Version Notifications

Adding and Modifying Workspace Version Notifications

To add or modify a version notification, do the following.

1.
2.

6.

Select Administration > Workspace.

In the Workspace Administration dialog box, select the workspace for which you want to configure
notifications and click .-/ . The Version Notification Configuration dialog box appears.

In the Version Notification Configuration dialog box, perform one of the following actions.
e To add a new notification, click = to display the Add Version Notification dialog box.

¢ To modify a notification, select it and click ¢« . The Edit Version Notification dialog box appears.

From the Action drop-down box, select the version action that occurs for which a notification is sent.

Options are Active, Edit, Stage, and Test.
When a workspace moves into one of these statuses, a notification is sent to the specified recipient.

Select the recipients to which to send the notifications. You can either select a configured notification
group (refer to Configuring Notification Groups), or you can specify recipients not in a group.

e To select a notification group, select the appropriate group from the drop-down box. The To and
CC fields automatically display the recipients configured for the notification group, and you
cannot modify these fields.

e To specify recipients not in a group, complete the following substeps.

1. Inthe To field, provide the email addresses of the recipients of the notifications. Perform
one of the following actions.

e Manually type the email addresses in the field, separating recipients by commas.

e Click the To button to open the Select Users dialog box. Select one or more recipients
and click OK.

2. Inthe CC field, provide the email addresses of the recipients to which to send copies of
the notifications. Perform one of the following actions.

o Manually type the email addresses in the field, separating recipients by commas.

e Click the CC button to open the Select Users dialog box. Select one or more recipients
and click OK.

Click OK.
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Deleting Workspace Version Notifications

To delete a version notification, do the following.

1.
2.
3.

Select Administration > Workspace.
In the Workspace Administration dialog box, click L.

In the Version Notification Configuration dialog, select the notification you want to delete and click

=

Configuring Jobs and Processing Records

Jobs contain all functions required to load data into your database. A job consists of the following.

Header: Defines the input data source, mapping values from the input file to the source destination in
your database.

Connection group: Comprises database connections to your database.

Input Source: Source from which you are importing data (for example, a spreadsheet containing test
information for students). Input sources can be fixed-width, delimited, XML files, EDI files, database
queries, or web service calls.

Note: EDI files are supported in Hyland DataTransfer 6.4.4 and higher.

Date and time: Date and time on which the job starts (if not specified, the job is run manually).

When you run a job, Hyland DataTransfer processes all records from the input source for the job.

Refer to the following topics for more information.

Understanding the Hyland DataTransfer desktop and tablet Job Dashboard
Understanding the Hyland DataTransfer mobile Job Dashboard
Customizing columns

Obtaining input data from the database

Adding and modifying recurring jobs

Adding new jobs

Modifying job details

Modifying jobs

Specifying data displayed in the Results pane

Opening jobs

Running jobs

Deleting jobs

Canceling jobs

Archiving jobs
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Understanding the Hyland DataTransfer desktop and table Job

Dashboard

The following figure displays Hyland DataTransfer Job Dashboard for the desktop and tablet views. Not

all features are available on the tablet view.

The Job Dashboard provides the following information.

Element

Description

Status drop-down box

Filters the status of the jobs you view in the Job Dashboard table. When you
select an option, the table displays jobs with the selected status. Options are:

Active: Active jobs are jobs that have not yet started (pending), jobs
that have run but for which there are unprocessed records
(incomplete), or jobs that have run but for which there are
suspended records (processed).

Complete: Complete jobs have been run and all records have been
processed as new or match; there are no suspended or
unprocessed records.

Archive: Archive jobs are historical jobs that have been archived.

Canceled: Canceled jobs have been canceled by a user.

Name column

Name of the job.

Click + to expand the job entry and view details about the job. The following
fields are displayed.

File Name: Filename of the input file used by the job.
Created On: Date on which the job was created.

Created by: Username of the user who created the job.
Start Time: Date and time on which the job started to run.
End Time: Date and time on which the job ended.

In Use by: Username of the user who is running the job.

File Name column

Filename of the input file used by the job.

Scheduled Start Time column

Date and time on which the job was scheduled to start.
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Element

Description

Status column

Status of the job.

Complete: The job has finished running, and there are no
unprocessed or suspended records.

Incomplete: The job is not currently running and has processed and
unprocessed records.

Processed: The job has finished running, but there are suspended
records.

Pending: The job has not yet started.
Processing: The job is currently running.
Canceled: The job was canceled.

Archive: The job was archived.

Records Status column

Provides the following subcolumns.

Progress: Provides a status bar indicating job progress when it is
being run.

Total: Number of total records for the job.

Unprocessed: Number of records that the job did not process.
Suspended: Number of suspended records.

Matched: Number of matched records.

New: Number of new records.

Locked: Number of locked records.

Header column

Name of the header used for the job.

Connection Group column

Name of the connection group for the job.

Understanding the Hyland DataTransfer Mobile Job Dashboard

If you are using DataTransfer on phones with smaller screens or resolutions, the mobile Job Dashboard is
displayed; the layout and functionality are the same for mobile Dashboards, but the overall design varies

among devices.

The mobile Job Dashboard displays the Active Jobs page, which displays a list of active jobs. To filter the
status of jobs displayed in the Job Dashboard, Settings > Filter, and then select the job status you want

to display.

To view details about a job in the mobile Job Dashboard, select the appropriate job. The following details

are displayed.

e Name: Name of the job.

e Status: Status of the job.

e Active: Active jobs are jobs that have not yet started (pending), jobs that have run but for which
there are unprocessed records (incomplete), or jobs that have run but for which there are
suspended records (processed).
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o Complete: Complete jobs have been run and all records have been processed as new or match;
there are no suspended or unprocessed records.

e Archive: Archive jobs are historical jobs that have been archived.
e Canceled: Canceled jobs have been canceled by a user.
e File: Filename of the input file used by the job.
e Progress: Displays a bar that shows the percentage of the job completion.
e Total: Total number of the job.
e Unprocessed: Total number of records not processed by the job.
e Matched: Number of matched records.
¢ New: Number of new records.
e Locked: Number of locked records.

You can also run jobs in the mobile Job Dashboard; for more information, refer to Running jobs.

Customizing columns
You can customize the columns displayed in the Job Dashboard.

Columns are automatically saved the way in which you displayed them when you last logged out of the
application or when you switched roles.

To choose the columns you want to display, complete the following steps.

1. Hover your mouse over the appropriate column. A drop-down arrow appears on the right side of the
column.

2. Click the arrow to open a menu that allows you to sort columns from A-Z or Z-A and also allows you
to select the columns you want to display.

3. Select Columns and then check the columns you want to display; uncheck the columns you do not
want to display.

After you log out of the application or change roles, the columns you specified to show or hide are
displayed in the Job Dashboard the next time you log in.

Obtaining input data from the database

Hyland DataTransfer can query a database to obtain the input data for a job. To configure a job in this
way, complete the following steps.

1. Create and configure a database connection for the input data. Refer to Configuring connection
groups and database connectors.

2. Create a procedure that uses Database Population Selection logic, which contains the query for
dynamically extracting input data. You use this logic in procedures and associate them with headers
so that you can capture header input variables from the input file.

For more information about configuring procedures, refer to Configuring Procedures. For information
about syntax for database population selection logic, refer to Understanding database population
selection syntax.

3. Create a database header and select the procedure used for database population selection. Refer to
Configuring and modifying database headers.
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4.

5.

Create a new job, selecting the header and connection you created in previous steps. Refer to Adding
new jobs.

Note: If job is recurring, the data is loaded when the job starts. If this a job you are running a single
time, the data is loaded at creation time.

Run the job. Refer to Running jobs.
e |f data from the import source has not been loaded, it is loaded when the job runs.

e If procedure aliases do not match the input columns (input variables in the header) in the header,
the job is not run properly.

e Forrecurring jobs, if a previous occurrence of a job is running, you cannot create a new job.

Adding and modifying recurring jobs

Recurring jobs run at a specified interval, using a file from a specified data source or file source.

Note: For an XML or EDI header, if you change the record identifier after you create a job using the XML
or EDI header, the job will not run.

Note: EDI headers are supported in Hyland DataTransfer 6.4.4 and higher.

Use file sources to configure the location of the input file; refer to Configuring File Sources. To add or
modify a recurring job, complete the following steps.

1.
2.

N o o ko

Select Jobs > Recurring Jobs to display the Recurring Job Administration dialog box.
Perform one of the following actions.
e Toadd a new job, click =& to display the Add Recurring Job dialog box appears.

e To modify a job, select the recurring job and click <. The Edit Recurring Job dialog box
appears.

In the Job Name field, type the name of the job.

In the Status field, click the Enable option to enable the recurring job; click Disable to disable it.
From the Header drop-down box, select the header file used for the job.

From the Connection Group drop-down box, select the connection group.

From the File Source drop-down box, select the file source (server or SFTP connection) that contains
the input file.

File Sources are configured in Hyland DataTransfer in Configuration > File Sources; for more
information, refer to Configuring File Sources.

This field is unavailable if you are using a database, web service, or Hobsons Connect CRM header.

From the Start time drop-down box, select the time on which the job starts. If you do not specify a
start date and start time, the job is run only manually.

In the Options pane, specify the following information.

e Check the Log SQL check box to log SQL messages; these messages appear in the Log View
dialog box (refer to Viewing Log Messages).

e Check the Allow Duplicate Filenames check box to allow jobs to have the same name.

e Check the Use Filename check box to include the name of the input file in the job name. When
you add a new job, the name of the input file is appended to the job name.
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Check the Delete Files check box to delete input files from the server after they have been used
for the recurring job.

10. In the Job Restrictions pane, complete the following substeps.

Check the Limit other users from running check box to prevent other users from running this
job.

Check the Limit other users from opening or editing until processed or completed check box
to prevent other users from opening or editing the job until it has finished processing records or
has completed running.

11. In the Recurrence Pattern pane, specify when the job recurs.

Click the Daily option to specify that the job recurs daily, and then specify the recurrence
frequency.

Click the Weekly option to specify that the job recurs weekly, and then specify the recurrence
frequency.

Click the Monthly option to specify that the job recurs monthly, and then specify the recurrence
frequency.

Click the Auto option to specify that the job recurs automatically whenever a file is added to the
file source used for the job. The Delete Files option is automatically selected to prevent duplicate
jobs from being created using the same file. You can use only headers that use file sources to
provide data; therefore, you cannot create automatically recurring jobs that use headers of types
database, Hobsons Connect CRM, or web service.

Click the Manual option to specify that the job recurs manually. It does not have a scheduled run
date and recurs only when manually started. You can start the job anytime in the Recurring Job
Administration dialog box or by calling the StartManualJob web service from a third-party
application (refer to Hyland DataTransfer APl Guide for more information). Refer to Running
manual recurring jobs for information on running manual recurring jobs.

12. Click the Notifications tab to configure email notifications to be sent when certain job activities
occur. Refer to Configuring Notifications.

13. Click OK.

The recurring job is added and appears in the Recurring Job Administration dialog box. When an
instance of this job is scheduled, the instance is created and appears in the Job Dashboard.

Adding new jobs

Note: For an XML or EDI header, if you change the record identifier after you create a job using the XML
or EDI header, the job will not run.

Note: EDI headers are supported in Hyland DataTransfer 6.4.4 and higher. To add a new job, complete
the following steps.

1. Select Jobs > Add Job.

2. Inthe Add Job dialog box, the Job Name field displays the name of the job. The default name of the
jobis USER DATE TIME, where USER is the username of the user who created the job, DATE is the
date (month, day, and year) on which the job was created, and TIME is the time that the job was
created.

3. From the Header drop-down box, select the header file used for the job.
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10.

11.

12.

From the Connection Group drop-down box, select the connection group.

In the Input File field, click Browse and select the input file, which contains the data that you want to
import, to use for the job.

From the Dependent On drop-down box, select the job on which you want the new job to be
dependent. Jobs that you can select have one of the following statuses: Pending, Incomplete,
Connection_Error, Record_Key_Error, and On Hold.

In the Release On field, click the appropriate option for when you want the On Hold status to be
removed from the new job. If you click Complete, the new job starts when the job on which it is
dependent obtains Complete status. If you click Processed, the new job starts when the job on
which it is dependent obtains Processed status.

In the Start Date field, click the calendar icon to display a pop-up calendar; then, select the date on
which the job starts.

From the Start time drop-down box, select the time on which the job starts. If you do not specify a
start date and start time, the job is run only manually.

Check the Log SQL check box to log SQL messages; these messages appear in the Log View dialog
box (refer to Viewing Log Messages).

In the Job Restrictions pane, complete one of the following actions.

e Check the Limit other users from running check box to prevent other users from running this
job.

e Check the Limit other users from opening or editing until processed or completed check box
to prevent other users from opening or editing the job until it has finished processing records or
has completed running.

Click OK.
The job is created and is added to the table.

Note: If you enabled Preferences > Filename in Job Name, the name of the input file is appended
to the job name.

Modify job details

To modify job details, complete the following steps.

1.

Complete one of the following actions.
e Select a job in the Job Dashboard and right-click it and select Details.

e Select a job in the Job Dashboard and click the Details button. The Edit Job Details dialog box
appears.

In the Job Name field, type the name of the job.

Note: You cannot modify any other fields, except the Job Name field, if you are modifying a job with
any status other than Pending.

From the Connection Group drop-down box, select the connection group to use for the job.

In the Start Date field, click the calendar icon to open a calendar, and then select the date on which
the job starts.

From the Start Time drop-down box, select the time on which the job starts.
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6. Click OK to save your changes and close the dialog box.

Modifying jobs

To modify a job, select a job in the table and click Edit.

Note: You cannot modify jobs in tablet view; you can modify them in desktop view only. A window
appears and displays information about the job.
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Callout No. | Element Description

1 Menu bar Displays the name of the job, name of the header used for the job, name of the
input file used for the job, and the database connection for the job.

2 Records pane Displays records contained in the job.

You can filter the records displayed by right-clicking a record, selecting Filter
By, and then selecting the appropriate option. You can also filter records by
selecting the filter option from the Filter by drop-down box. Options are:

All
Unprocessed

Suspended
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Callout No.

Element

Description

Match
New
Locked

The rank column identifies the stage of matching during which the record was
set as Match or New.

If sorting is enabled on a column, when you click a column heading, the field is
sorted alphanumerically from A-Z; if you click the heading again, the field is
sorted from Z-A. You can choose to make up to ten columns sortable when you
edit the input variables corresponding to the columns in the Header Editor
dialog box.

Refer to the following topics for more information.

e Configuring and modifying fixed-width headers and header variables
e Configuring and modifying delimited headers and header variables
e Configuring and modifying database headers

e Configuring and modifying Microsoft Excel headers and header
variables

e Configuring and modifying XML headers and header variables
e Configuring and modifying EDI headers and header variables
e Configuring Hobsons Connect CRM headers and header variables

e Configuring and modifying web service headers

Sorting is based on the prefix of the input variable. If the prefix is &, sorting is
based on timestamp (which in the end is a numeric sort); if the prefix is $,
sorting is alphanumeric; and if the prefix is #, sorting is numeric.

These values are all stored as strings regardless of the prefix the values are
converted to when the user opens or edits a job to prepare a job. If, for example,
the prefix is # and the value does not convert to a numeric value, the value is
managed as null; for #ZIP and value SEVEN, seven is null when sorted.

You can suspend, lock, reset, and modify records by right-clicking a record and
selecting the appropriate option. Refer to the following topics for more
information.

Viewing logs
Locking records
Modifying records

Suspending records

Input Variables
pane

Displays the header input variables used in the header for the job. For more
information about configuring headers and header variables, refer to Configuring
headers Configuringon.

Program
Variables pane

Allows you to view and configure program variables. For more information about
configuring variables, refer to Configuring Procedures.
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Callout No. | Element Description

5 Verification form | Verification form used for the job; it is displayed when you click the Form Editor
tab.

6 Procedures tab | Allows you to view and configure procedures. When you click this tab, the

and pane Procedures pane displays the configured procedures, and it displays the
Procedure Editor pane to the right of the tab. For more information about
procedures, refer to Configuring Procedures.

7 Form Editor tab | Allows you to view and configure the verification form used for the job. When
you click this tab, the Verification Form pane appears to the right of the tab. For
more information about configuring forms, refer to Configuring Forms.

8 Results pane Displays any potential records in the database for which there is a match in the

input record.

You must configure the appropriate Match Result Display query to retrieve the
appropriate information to display it in this pane. For more information, refer to
Specifying data displayed in Results pane.

Specifying data displayed in the Results pane

When a job is run in interactive mode on all records, or when records that were suspended when a job
was run in batch mode and are then managed in interactive mode, match logic is run and finds possible
matches for the input record.

For each possible match, an entry in the Results pane in the Job window is associated with the ID for the
possible match. You configure a query for a procedure using the Match Result Display logic that uses this
ID to populate the Results pane in the Job window.

To configure a job that uses the Match Result Display logic, complete the following steps.

1.

Create and configure a database connection for the input data. Refer to Configuring connection

groups and database connectors.

Create a procedure that uses Match Result Display logic, which contains the query that returns

information to the Results pane based on the specified ID returned by the query.

For more information about configuring procedures, refer to Configuring Procedures.

Create a header and select the procedure used for match result display. Refer to Configuring and

modifying database headers.

When the Match logic executes on a header, a list of IDs of possible matches are generated. The
Match Result Display query for that header is then executed for each ID and the data returned from
the query is displayed as a row of information in the Results pane.

Create a new job, selecting the header and connection you created in previous steps. Refer to Adding
new jobs.

Run the job. Refer to Running jobs.

When the job is run in interactive mode, all possible matches are displayed in the Results pane.

Note: You cannot run jobs in interactive mode in tablet view.
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Opening jobs

To open a job, complete the following steps.
1.

Complete one of the following actions.

To filter records in the Records pane, right-click a job, select Filter By, and select the status of the
records you want to display. You can also select the filter option from the Filter by drop-down box.

Select a job in the table in the Job Dashboard and click the Open button.
Double-click a job in the Job Dashboard table.
A window appears and displays information about the job.

Note: Only the Records pane appears in tablet view

Options are:

Records text is colored according to status.

The Rank column identifies the stage of matching during which the record was set as Match or New.
The value indicates the level of match routines executed before you determined that the record was
Match or New. If the record is unprocessed or suspended, the rank value is empty.

For more information, refer to Understanding record rank.
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If sorting is enabled on a column, when you click a column heading, the field is sorted, depending on
the type of information contained in the column. The field can be sorted alphanumerically,
numerically, or by date.

In this window, you can also complete the following steps.
e Reset arecord.

e Lock a record.

e Modify a record.

e Suspend a record.

e View the reason that a record was suspended.

e View XML records (desktop view only). Refer to Modifying records.

Resetting records

To reset any Processed record to Unprocessed, complete the following steps.

1.

Select a job in the Job Dashboard and click Open. A window appears and displays information
about the job.

Complete one of the following actions.
e In desktop view, right-click the record in the Records pane and select Reset Record.
e |n tablet view, select the record and click the Reset button.

The record is reset to Unprocessed and its information is updated in the Records pane.

Locking records

When you lock a record, it is not processed when you run a job. To lock a record, complete the following
steps.

1.

Select a job in the Job Dashboard and click Open Job. A window appears and displays information
about the job.

Complete one of the following actions.
e In desktop view, right-click the record in the Records pane and select Lock Record.

e In tablet view, select the record and click the Lock button.

The record is locked. Its status is changed to Locked in the Records pane.
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Modifying records

To modify the value of a field of information, complete the following steps.

1.

Select a job in the Job Dashboard and click Open Job. A window appears and displays information
about the job.

Complete one of the following actions.

¢ In desktop view, right-click the record in the Records pane and select Edit Record. The Record
Editor dialog box appears.

¢ In tablet view, select the record and click the Edit button. The Record Editor dialog box dialog
box appears.

e To view XML records, in desktop view, right-click a record (for a job using an XML or EDI header)
and select View Full Record.

Note: EDI headers are supported in Hyland DataTransfer 6.4.4 and higher.
Complete one of the following actions.

e If you are modifying records for jobs using headers other than XML or EDI headers, the Record
Editor dialog box appears and displays the following information about the variables for the
record.

e Pos: Numerical value of the position of the field in the input file.
¢ Field Name: Name of the field.
e Value: Value of the field.
Note: EDI headers are supported in Hyland DataTransfer 6.4.4 and higher.

e If you are modifying records for jobs using XML or EDI headers, the Edit XML Record dialog box
appears. In the Node column, a¥ icon appears next to XML tags that will appear in the
Records pane;a = icon appears next to XML tags that will not appear.

To expand all nodes in the XML tree, click *  To collapse them, click (=)
Note: EDI headers are supported in Hyland DataTransfer 6.4.4 and higher.

To select the next record, click the Next button; to select the previous record, click the Previous
button.

To modify the value of a record, double-click the entry in the Value column and then type the
appropriate value. For XML records, you can assign values to only nodes that do not have child
nodes.

To apply your changes, click Apply. If you click Previous, Next, or Close without saving your
changes, a dialog box appears and prompts you to confirm that you want to save your changes
before the action is performed for the button you clicked.

The input record is updated with the changes you made, and its information is updated in the Records
pane.
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Viewing logs

Click the View Logs button to view information about the job. Refer to Viewing Log Messages for more
information.

Suspending records

If Hyland DataTransfer cannot upload a new record to the database when you run a job, the record is
automatically suspended.

You can manually suspend a record if there is an issue with the record that you need to investigate
further.

1. Select a job in the Job Dashboard and click Open Job. A window appears and displays information
about the job.

2. Complete one of the following actions.
¢ In desktop view, right-click the record in the Records pane and select Suspend Record.
e In tablet view, select the record and click the Suspend button.

3. Inthe Suspend Record dialog box, in the Enter suspend reason field, type the reason for which you
are suspending the record.

4. Click OK.

The record is suspended. Its status changes to Suspended, and the record text is
highlighted in red in the Records pane.

Viewing the suspend reason
To view the suspend reason for a single suspended record, complete the following steps.

1. Select a job in the Job Dashboard and click Open Job. A window appears and displays information
about the job.

2. Complete one of the following actions.
¢ In desktop view, right-click the record in the Records pane and select View Suspend Reason.
e |n tablet view, select the record and click the View Reason button.

The View Suspend Reason dialog box appears and displays the reason that the record was suspended.

Searching records
You can search for information within the entire job or within a specific column of the Records pane.
Note: Searches are not case sensitive.

To search for information in the entire job, in the Records pane, type the text for which you want to
search in the Find field; then, press Enter.

If one or more results are returned, the Records pane is refreshed and all matching terms are highlighted

in yellow. If more than one result is returned, the ¢ (previous)and ’ (next) buttons are enabled, which

you can use to navigate to any available previous or next results. When you hover your mouse over these
buttons, tooltips appear and indicate the result to which you will navigate if you click the button.
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To stop viewing search results, click 3* . The text in the Find field is cleared, the search controls are
disabled, and the current page of records is refreshed without the highlighted terms.

You can also search for information within a specific column. The tooltip that appears when you hover
your mouse over the Find field provides more information and an example of how to perform the search.

Type *[COLUMN] at the end of the search term to search for the term only within the specific column.

For example, for the search term M*[GENDER], Hyland DataTransfer searches for the term M within only
the $GENDER column.

If you do not provide the correct name of the column, and the incorrect column name does not exist,
Hyland DataTransfer searches the entire job for the search terms.

For example, for M*[$GENDE], if the $GENDE column does not exist, Hyland DataTransfer searches the
entire job for M*[$GENDE].

Running jobs
Refer to the following topics for more information.
e Eliminating duplicate records
e Understanding run modes
¢ Running debug modes
e Running manual recurring jobs
e Running jobs in batch mode
e Running jobs in interactive mode
e Setting On Hold jobs

e Monitoring jobs

Eliminating duplicate records

To prevent duplicate records when a header is used to run a job, you must set a column of the header as
the record key. Because batch processing processes multiple records at one time for improved
performance, the header record key is needed to ensure that possible duplicates in the input source are
not processed at the same time.

Selecting a header key allows Hyland DataTransfer to process any records with different values in the
selected column at the same time. You do not need to select a column that guarantees unique values, but
the column should capture duplicate records. For example, if you select Last Name as the key to a header
and process a file that has many records with the last name Smith, which represent different students,
you prevent any two records with the same last name from being processed at the same time.

To mark a header column as the record key, complete the following steps.
1. Select Configuration > Headers.
2. In the Header Administration dialog box, select the header you want to modify and click «

3. In the Header Editor dialog box, to mark a column as the record key, select the column and click
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4. The © icon appears next to the column to denote that it is the record key.
You can mark one column only as the record key; you cannot configure composite keys.

Note: A column that is set as the record key is also a sortable column and count toward the ten
columns that can be sortable.

5. Configure other header properties, as appropriate.

For more information about configuring headers, refer to Configuring headers.

Understanding run modes

You can run jobs in interactive or batch mode, which is determined in the associated match procedures
using the appropriate global program variables. In tablet view, you cannot run jobs in interactive mode.

Hyland DataTransfer sets the global variable GL_ RUNMODE to BATCH when the job is run from the Job
Dashboard. Note that if the associated code has interactive elements in it (for example, the STOP
command does not work in batch mode), and a job is run in batch mode, error messages are received.
You can configure the code to branch to specify the appropriate behavior when a job is run in either
mode. For example, you can use an if...else statement in this syntax:

if GL.RUNMODE = GL.INTERACTIVE
<procedures for interactive mode>
else
<procedures for batch mode>
end-if

For more information about global variables, refer to Understanding global variables in  Programming
Concepts. For more information about configuring procedures, refer to Configuring Procedures.

Understanding batch mode
In batch mode, a job is run without user intervention. For each input record, the following occurs.

1. Match logic is run until it completes. The logic searches for possible matches until a SKIP command
is reached. The SKIP command sets the status of the input record and processes it appropriately.

e If the status of the record is MATCH or NEW, upload logic is run.
e If the status is SUSPEND, match logic is run for the next input record.
Note: Review logic is not run in batch mode.

2. Upload logic is run; the global status of the input record is used to either create a new record or to
update an existing record.
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Understanding interactive mode
Note: In tablet view, you cannot run jobs in interactive mode.

In interactive mode, the job processes each input record, pausing to allow the user to intervene. For each
input record, the following occurs.

1. Match logic is run.

1. Match logic finds possible matches for the input record. For each possible match, an
entry in the Results pane is associated with the ID for the possible match. The Match
Result Display procedure uses that ID value to populate the Results pane in the Job
window.

For an overview of steps required to configure the logic to display matches in the Results pane,
refer to Specifying data displayed in Results pane.

2. Match logic organizes the results based on a ranking of how likely it is to be a match. For
the first instance of the match logic, the logic searches for rank 1 matches, for the
second instance it searches for rank 2 matches, and so on.

3. Atthe end of each rank iteration, the match logic pauses to allow user input. The rank
and logic pause are established programmatically through the STORE and STOP
commands.

4. The user can select one of the match results from the Results pane, initiating review
logic.

5. If the user does not find a match, the user can continue to run the match logic to search
for the next rank of possible matches. If the match logic does not find a possible match,
the user is prompted to create a new record for the input. If accepted, the upload logic
will begin. If rejected, the record is suspended, and the process starts again with the next
input record.

2. Review logic is run.

6. Review logic is run when a user clicks a match record in the Results pane. The user
interface stops taking input.

7. Each time the review logic updates a program variable, any fields on the verification form
linked to that program variable is updated in real-time.

3. When the review logic completes, the interface accepts user input. The user can complete the
following actions.

e Click a different match result: This restarts the review logic process.

e Update the verification form: This allows the user to override data being uploaded to the
database.

e Insert the input record as a new record: This executes the new record upload logic.

e Update an existing record: This executes the upload logic with the selected match result
specified as the record to update.

e Suspend the input record: This flags the record as suspended and starts the iteration of the
next input record.
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4. Upload logic is run.
8. The Results pane is locked to prevent user input.

9. The upload logic creates the new record or updates the existing record with the
appropriate parameters.

10. The process completes and moves to the next input record.

When running in interactive mode, you can step through any of the match, review, or upload logic to
debug the code. You can examine the program variables any time the logic is paused for user
intervention. Refer t Running debug modesfor more information about running debug modes.

You can also use the PROMPT function to display message text to a user and allow the user to update
variables when a job is run in interactive mode. For more information, refer to Understanding the prompt
function.

Running debug modes
You can run debug modes when processing records.

o Normal mode: The logic starts and executes to completion or until a STOP command is reached.
When a STOP is reached, the interface pauses for user input.

e Debug mode: The logic pauses at each breakpoint and each STOP command. After the logic is
stopped, you can continue to the next STOP command or breakpoint, or you can proceed to the next
line of code.

You can insert breakpoints anywhere to pause on that line of code. The Procedure Editor displays the
procedure being run and identifies the line on which the job has been stopped. Breakpoints are saved
after you close jobs or the Procedure Editor, and they are also saved when you log out and log back into
DataTransfer.

Note: You cannot add breakpoints to end-select statements.
1. Complete one of the following actions.

¢ In the Job Dashboard, select the job you want to run and click the Edit button. Next, in the
topmost pane, select the record you want to run, and then click the Procedures tab.

e Select Configuration > Procedures.
1. Select the procedure that contains the line of code you first want to execute.
2. Click the line number of the line to which you want to add a breakpoint.
e A ® appears next to the line number, indicating that you have added a breakpoint to the line.

2. To clear a breakpoint, complete one of the following actions.
e To clear all breakpoints in all procedures, click 3* in the Procedures toolbar.

e To clear all breakpoints within a specific procedure, select the procedure and click 3* in the
toolbar of the Procedure Editor.
e Click the breakpoint to remove it.

3. Click Run.
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4. The code runs and pauses at the breakpoint. The following buttons are enabled in the Procedure
Editor.

o " Continues running the code until it reaches the next breakpoint, the STOP command (which

pauses to allow the user to create new recrods, set matched reocrds, or suspend records), or the end
of the code.

. = Pauses at the next line of code after this line has been run.
When you debug in line mode, a dialog box appears and displays the full text of the SQL command,
web service payload, or SOAP web message appears.
Click OK to close the dialog box and continue processing. Click Cancel to stop processing at the line.

o & Stops processing the record.

Running manual recurring jobs

If a recurring job can be run manually, you can run it at any time by completing the following actions.
1. Select Jobs > Recurring Jobs.

2. In the Recurring Job Administration dialog box, click * .

You can specify that the recurring job is run manually in the Add Recurring Job and Edit Recurring Job
dialog boxes. Refer to Adding and modifying recurring jobs for more information.

Runningjobsinbatch mode
To run a job in batch mode, complete one of the following actions.

¢ In the desktop Job Dashboard, select the job you want to run and select Run from the popup menu
or click the Run button.

¢ In the mobile Job Dashboard, select the job you want to run and select

To stop a job that is running, complete one of the following actions.

¢ In the desktop Job Dashboard, either right-click the job and select Stop or click the Stop button.

¢ In the mobile Job Dashboard, select

After Hyland DataTransfer processes the job, you can open the job to view job results, including
information about any suspended or unprocessed records.
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Running jobs in interactive mode
Note: You cannot run jobs in interactive mode in tablet view.
To run a job in interactive mode, complete the following steps.

1. Select a job in the table and click Open Job. A window appears and displays information about the
job.

2. Complete one of the following actions.
e To process a single record in the job, select the record in the topmost pane and click the Run
e button.
e To process all records in the job, click the Run All button.
e To stop running the job, click Stop in the bottom toolbar.

Depending on your configuration, you may receive the Prompt dialog box for a record, which
displays message text and allows you to update values of information for the record.

For example, you may receive a message that the address information is not correct, and you can
update address information, such as street number, city, and state.

To modify a value, click the row of in the Value column and type the appropriate text. Then, complete one
of the following actions.

o Click OK to apply your changes. The information is updated and jobs processing resumes.
e Click Reset to reset the values in the Prompt dialog box to the original values.

e Click Cancel to stop processing on the record. The Error Processing dialog box appears and
provides information about why the record could not be processed.

If you enabled the Display All Match Results preference, when you run a job in interactive mode, all
possible record matches are compiled before the application pauses to allow you to review the possible
matches. For more information, refer to Specifying Preferences.

If you are running a job and are using the DataProviderPrompt function with this job, you may receive a
Result Selection dialog box, which displays a prompt in the top field and values, returned by the job,
below it. This dialog box appears if multiple records of information are obtained from the job; select the
information you want to use and click OK. For more information about web services, refer to Configuring
data providers.

When Hyland DataTransfer processes records in interactive mode, one of the following occurs.

e If a record cannot be processed, a dialog box appears and displays information about why the
record could not be processed. The dialog box contains the following information:

e Procedure Name: Name of the programming procedure that contains the problem.
e Line #: Number of the line in the procedure in which the problem occurred.
e Error Information: Description of the problem in the procedure.

e If a new record could not be uploaded, the record is suspended.

¢ If Hyland DataTransfer cannot find a matching record in the database, a dialog box appears and
prompts you to create a new record. Click Yes to create the record and add it to your database; click
No if you do not want to create a new record.
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o |Ifthere are potential matches in your database, Hyland DataTransfer pauses and prompts you to
review results, which are displayed in the Results pane. Hyland DataTransfer organizes the results
based on a ranking of how likely they are to be matches to the input data.

Click - to continue to process records to search for more possible results.

o If Hyland DataTransfer does not find a match, you are prompted to create a new record. Click
Yes to create the record; the record is updated in the topmost pane, with its status changing to
New and its label color changing to blue.

¢ If you find a matching result and want to create a matched record, select the result in the
Results panel and click the Matched button. The record’s status is updated as Match, its color
changes to green, and it is updated in the topmost pane.

After Hyland DataTransfer uploads a record, an informational dialog box appears and displays the
record number that was processed and if it was “successfully matched,” if it was “successfully
created,” or if it “failed to upload.”

You can use the verification form, if configured, to compare information from the current input record and
potential matches in your database. Refer to Viewing the verification form.

Understanding record rank

The Rank column in the Records pane in the window that appears when you edit or open jobs identifies
the stage of matching during which the record was set as Match or New.

If the record is unprocessed or suspended, the Rank column does not display any information. If the
record was set to Match or New when the job was run in interactive mode, the rank is the value used in
the NQL STORE command. (For more information about the STORE command, refer to Understanding
the store function).

For example, consider the example match routine in the following figure:

Procedure Editor 01-match-ssn

B Y R
begin-procedure Jl-match-san

begin-select
nu_id ~§persa_nuid

let gnu id = gpers nuid
let $atatus = "M’
let $mtch code = "MPL®'
store 1, "§nu id-"
stop ! exit ma
FROM nu person
WHERE 3sn = ~3%f san

end-select

end—ﬁ:ccedure

The match routine is 07-match-ssn with the corresponding command store 1, 'nu_id'. Conventionally,
match routines are numbered, and they have a corresponding store command with the same numerical
value. This value is displayed in the Match Results pane to identify the stage of matching during which
the possible match was found. Therefore, if a record is set as Match with a record with a store of 7, the
rank is also 7. If the record is set as New, the rank is the value of the last store command. In this way, you
can identify how many records the user examined before the record was set as New.
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The rank process works similarly when the record is set to Match or New when the job was run in batch
mode. In batch mode, the record status is changed by either a SKIP NEW or SKIP MATCH command; the
STORE command is not used. (For more information about the SKIP command, refer to Understanding
the skip function).

Both the SKIP NEW and SKIP MATCH commands take an additional second parameter, which is any
string that identifies the rank at which the record status changed. The string can be any value that you
want to use to indicate rank.

Consider the example match routine in the following example:

Procedure Editor AA-match-last-4-first-2-ssn

; B P e %
begin-procedure AR-match-last-4-first-Z-san

]

I 1at 4 char last, lat 2 char first & s3amn

I

let $where lname 1 = "last _idx like “q'||substri$tmp clname,1l,4)]|]|"%\qg’

if §former ent = 1
let $temp = " OR "||'last_idx like “q'|l|substr($tmp flname 1,4)||"%\g"
let $where lname 1 = "{'||$where lname 1| |Ftemp||")’

end-if

let $where fname 1 = 'firat idx like “g'| |substr{ffname 1,1,2) || "%%q"’

if g§name cnt > 3
let $temp = " OR "||'first_idx like ‘\g'||substr{$fname 4,1,2) || "%\qg’
let $where_fname 1 = $where fname 1| |5temp

end-if

if g§name cnt > 2
let $temp = " OR "||"first_idx like ‘\g'||substr{$fname 3,1,2)||"%\qg"
let $where fname 1 = $where fname 1| |5temp

end-if

if gname cnt > 1
let $temp = " OR "||'first_idx like “g'||substr({$fname 2,1,Z)||"%\qQ"
let $where fname 1 = '"{'||$where_ fname 1| |$temp||")"

end-if

I

begin-select

distinct (nu names._nu_id) ~fpers nuid

let $nu_id = §pera_nuid

let %status = "M’

let $mtch code = "MPRR'

gtore 1, "§nu_id’ I rank, UID - will be fed to review process

I atop I have match, exit & skip to upload

exit-select

FROM nu namea, nu_peraocn

WHERE { [$where_ lname 1]

END [$where fname 1] )

AND nu namesa.nu id = nu person.nu_id
AND gan = ~5f aan

end—select

I

evaluate _CL.ROWCOUNT

when = 0
I skip to next search
break

when = 1
skip MATCH, 'Za'
break

when-octher
skip SUSPEND, 'Possible duplicate 55M...°
reak

end-evaluate

I

end-procedure
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In this example, the match routine is AA-match-last-4-first-2-ssn, and its SKIP MATCH command, which
has the string parameter AA, appears on line 45 (skip MATCH, 'AA").

In this example, AA was chosen as the parameter because match procedures are numbered
alphabetically; this batch procedure begins with AA. Therefore, if a record is set as Match with a record
with a SKIP MATCH of AA, the rank is also AA, which indicates that the record was set to Match in match
routine AA.

Similarly, if a procedure had a SKIP NEW command with a string parameter of AA, the record is set as
New with a rank of AA.

When you upgrade to this release of Hyland DataTransfer, the rank is recorded for any new records for
jobs run in interactive mode. To update record ranks for jobs run in batch mode, you must update the
SKIP NEW and SKIP MATCH commands to add the new rank. This optional parameter is a string, but you
can also use numeric string literals (for example, '7").

Viewing the verification form

With the verification form, you can compare the current input record side-by-side with the possible
existing record.

Note: The form is displayed only when a job is running in interactive mode.

When you run a record, the verification form displays data associated with the input record and the
possible record in your database.

Users can check or uncheck the toggle check boxes in form field sets to specify which field sets of
information are included when upload logic is processed.

Use form toggles if you need to provide the value of each field set to the associated upload logic; when
the upload logic is run, this value is included when the data file is uploaded. The form can return the value
of a toggle given a specified program variable name.

When you configure the associated Hyland DataTransfer logic, the logic must verify the values of the
toggles and upload changed information appropriately. Refer to Using Form Toggles for more
information.

After you review the data in the verification form and compare it with the possible matched record in the
database, you can create a new record, create a matched record, or suspend the record.

Setting On Hold jobs

You can set a job status to be On Hold so that it cannot be run interactively or in batch mode until the
hold status is released. You can set a job on hold if it has one of the following statuses: Pending,
Incomplete, Connection_Error, or Record_Key_Error.

To set a job as on hold, select the job in the Job Dashboard and click Hold.

To remove the on hold status from the job, select the job in the Job Dashboard and click Release.
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Monitoring jobs
Select a job in the Job Dashboard and click Monitor.

The Job Progress dialog box appears in the foreground of your browser and remains open and in the
foreground until you click Close.

A progress bar appears at the top of the dialog box, indicating the percentage complete of the job. The
dialog box displays the following information.

e Total: Total number of records in the job.

e Unprocessed: Number of records that are not processed.
e Suspended: Number of suspended records.

e Matched: Number of matched records.

e New: Number of new records.

e Locked: Number of locked records.

When the job is running, the Stop button appears in the Job Progress dialog box; click it to stop running
the job. When the job has completed, only the Close button is displayed.

Deleting jobs
Refer to the following topics for more information.
e Deleting jobs

e Deleting recurring jobs

Deleting jobs

You can delete a job that has never been run (the job has a status of pending and all its records are
unprocessed). You cannot delete jobs that have fully completed.

To delete a job, complete the following steps.
1. Complete one of the following actions.
¢ In the desktop Job Dashboard, select the job you want to delete and click Delete.
e In the mobile Job Dashboard, select the job you want to delete and click . Hyland
DataTransfer prompts you to confirm that you want to delete the job.
1. To delete the job, click Yes.

The job is deleted and is removed from the Job Dashboard.

Deleting recurring jobs
To delete a recurring job, complete the following steps.
1. Select Jobs > Recurring Jobs.

2. Inthe Recurring Job Administration dialog box, select the recurring job you want to delete and click

3. Inthe dialog box, to delete the job, click Yes.
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The job is deleted and is removed from the Recurring Job Administration dialog box.

Canceling jobs

You can cancel all jobs except those that has never been run (the job has a status of pending, and all its
records are unprocessed).

You can cancel jobs that have at least one record that has been processed. However, you cannot cancel
jobs that have fully completed.

When you cancel jobs, they are removed from the Job Dashboard when you select Active from the
Status drop-down box.
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To cancel a job, complete the following steps.

1.

2.

Complete one of the following actions.

¢ In the desktop Job Dashboard, select the job you want to cancel and click Cancel.

¢ In the mobile Job Dashboard, select the job you want to cancel and click . Hyland
DataTransfer prompts you to confirm that you want to cancel the job.

To cancel the job, click Yes. The job is canceled, and its status is set to Canceled in the Job
Dashboard.

Archiving jobs

You can configure rules to archive jobs in the Archive Administration dialog box. Refer to the following

topics for more information.

Adding and modifying archive rules

Deleting archive rules

Adding and modifying archive rules

1.
2.

9.

If you created a new rule, it is added and appears in the Rule Administration dialog box. If you modified

Select Administration > Archive.
In the Archive Rule Administration dialog box, complete one of the following actions.
e To add a new archive rule, click =2 . The Add Archive Rule dialog box appears.

e To modify an archive rule, select the rule and click = . The Edit Archive Rule dialog box
appears.

In the Status field, click the Enable option to enable the archive rule; click Disable to disable it.

If you are modifying a rule for a particular header, the Header drop-down box displays the header;
you cannot modify this field. If you are modifying the default rule for all headers, the Header drop-
down box is not displayed.

In the Days field, type the number of days after which the job should be archived after it has
completed.

In the Data to Maintain dialog box, specify the data that you want to archive.

e Summary Data check box: Maintains summary data. This option is always enabled; it is
unavailable to be checked.

e Record Level Details check box: Check to maintain details about records.
e Logs check box: Check to maintain log files.

From the Start Time drop-down box, select the time on which you want to start the archive rule.

In the Recurrence Pattern pane, click the appropriate option to specify whether the rule recurs daily,

weekly, or monthly, and then specify the recurrence frequency.
Click OK.

a rule, its updated information is saved.
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Deleting archive rules

Note: Hyland DataTransfer includes a default, configured archive rule (which is disabled by default) that
applies to all headers; you cannot delete this archive rule.

To delete a rule, complete the following steps.
1. Select Administration > Archive.
2. Inthe Archive Rule Administration dialog box, select the rule you want to delete and click 3 .

The rule is deleted and is removed from the Archive Rule Administration dialog box.
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e Understanding procedure syntax

e Understanding operators

e Accessing the database

¢ Understanding the assignment statement
e Understanding flow control

e Understanding global variables

e Understanding string functions

e Understanding general functions

Understanding procedure syntax

The body of a procedure contains the assignments, SQL statements, and flow control that comprise the
procedure. After you add or modify a SQL block, you can add or modify your source code.

The syntax for the procedure body is:

begin-procedure procedure-name [ (argl,arg2, ..

end-procedure

For example, the following procedure returns a value from a table matching on each of two input

variables.

Appendix A: Programming Concepts

Refer to the following topics for more information.

argN) ]

begin-procedure check-table-name (St term, Suid)

let #found match = 0
let #recr_segno = 0

begin-select

table-name_segno as ~#recr_seqno

let #found match = 1

exit-select

FROM table-name

WHERE table-name term = ~$t term

AND table-name uid = ~$uid

end-select

end-procedure
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In this example, procedure-name is the name of the procedure to be created; arg1, arg2, and so on, are
the names of the procedure parameters (both input and output); and the procedure body contains the
code for the procedure.

Every SQL block must begin and end with the begin-procedure and end-procedure keywords. The begin-
procedure statement defines the procedure start point and the name by which the procedure is
referenced and run.

Understanding database population selection syntax

Database Population Selection logic contains the query for dynamically extracting input data to a header.
You use this logic in procedures and associate them with headers so that you can capture header input
variables from the input file.

Example
begin-procedure test-query
!
begin-select
SSN “$SSN”,
FIRST “S$FIRST”,

LAST “$LAST”,

MI W $MI”,
DOB “+DOB”,
SEX “SSEX”,

FROM table name
end-select
!
end-procedure

You must write database source queries in the database syntax for the target database.

Syntax for Oracle
Note the following syntax rules.
e The column alias must be enclosed by double quotation marks (“ ”)
e Use + instead of & for the column alias.
Example
begin-select

SSN “#SSN”,

FIRST “SFIRST”,

LAST  “SLAST”,

MI wEMI”,

DOB “+DOB”

FROM demo
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end-select

Syntax for Microsoft SQL Server
Note the following syntax rules.

e The column alias must use AS and [ ]

e Use special character designators ($ for Character, # for Number, and & for Date).

Example
begin-select
SSN AS [#SSN],
LAST AS [S$SLAST],
FIRST AS [SFIRST],
MI AS [$MI],
DOB AS [&DOB] FROM DEMO

end-select

Understanding operators

The following provides a list of symbol operators used in code.

Operator Symbol Description

Character string delimiter.

+ Addition operator.

/ Division operator

- Subtraction operator.

Multiplication operator.

! Indicates a comment.

) Separates items.

= Equal to operator.

1= Not equal to operator.

<= Less than or equal to operator.
>= Greater than or equal to operator.
< Less than operator.

> Greater than operator.

( Expression or list delimiter.

) Expression or list delimiter.

I Concatenation operator.
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Operator Symbol Description

\q Escape sequence for a single quote (' ). When you insert strings that themselves
contain strings or single quotes into the database, you must escape the single
quotes.

For example, to set a variable equal to the phrase "It's OK", you would use let

In queries, you can use the following operators.

- [l

Commonly, this operator is used when you are dynamically building a WHERE clause of a query. The
conditions of the query depend on the code that executes and on the input data, so the WHERE clause
is built inside another variable.

For example, consider a variable $where_clause that contains WHERE first name = 'John' and
last_name = 'Doe'. You can add that variable to a select statement as follows.

begin-select
person_id ~Spers_id
FROM person
Swhere clause

end-select

However, if you use the preceding query, all string variables in a query are replaced with
their value surrounded by single quotes:

begin-select
person_id ~Spers_id
FROM person
'WHERE first name = 'John' and last name = 'Doe''

end-select

The query does not work in this manner; instead, use the [ ] operators, which tell the NQL interpreter to
do a straight string replacement and to not include the surrounding quotes. Use the following syntax.

begin-select
person_id
~Spers_id
FROM person
[$where clause]

end-select

Example

begin-select
person_id
~Spers_id

FROM person
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WHERE first name = 'John' and last name = 'Doe'

end-select
o ~(tilde)

Use the tilde operator within the SELECT clause of a query. The value of a specified column is placed into
the specified variable.

Example

begin-select
person_id
~Spers_id
FROM person

end-select

The value of the person_id column will be placed into the $pers_id variable. If the tilde (~) was not
specified, for example:

begin-select
person_id
Spers_id
FROM person

end-select

The value of the variable is inserted into the query itself. When the above query is run, no value would
typically be in $pers_id, and the query would look as follows.

begin-select
person_id v
FROM person

end-select

However, this query syntax is incorrect. If the tilde (~) operator occurs in the FROM clause or any clause
after (such as WHERE, ORDER BY, and so on) the operator is ignored. Any variable referenced in the
FROM clause or after is replaced with the value in the variable at the time of execution. For the two
queries:

begin-select
person_id
~Spers_id
FROM person
WHERE person_ id = $id

end-select

begin-select
person_id ~Spers_id
FROM person

WHERE person id = ~$id
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end-select

If $id = 999, both queries evaluate to:

begin-select
person_id ~Spers_id
FROM person
where person id = '999'

end-select

Accessing the database

You can optionally select, insert, update, and delete data from your database by embedding the
appropriate SQL statements within the body of a SQL block.

Refer to the following topics for more information.

e Understanding Select constructs

e Understanding Insert, Update, and Delete constructs
e Understanding the execsp statement

¢ Understanding the begin-plsql statement
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Understanding Select constructs

The syntax for the Select construct is:
[ begin-select
[select SQL logic]

end-select ]

Example
begin-select

last name as ~#tmp_ last

let #found match = 1 exit-select
FROM last names
WHERE ssn = ~$t ssn

end-select

In this example, the last_name column is selected from the last_names table, where the ssn column
matches the temporary variable $t_ssn.

The ~ (tilde) character is used in the SELECT clause of a query. The value of a specified column is placed
into the specified variable.

Use exit-select to immediately exit the SQL block in which it appears. Code is run until it reaches end-
select.

Understanding Insert, Update, and Delete constructs
The syntax for the Insert construct is:
begin-sql

[insert SQL logic]

end-sqgl

The syntax for the Update construct is:
begin-sql
[update SQL logic]

end-sqgl

The syntax for the Delete construct is:
begin-sqgl
[delete SQL logic]

end-sqgl

218



Hyland DataTransfer Administrator Guide

Example
begin-procedure inst-names
begin-sqgl
INSERT INTO names
SELECT #varl, S$var2, $var3, sysdate,
FROM dual
WHERE names id NOT IN
(SELECT names_id
FROM names
WHERE names id = ~$t id)
end-sqgl
end-procedure

In this example, values are inserted into a database table.

Understanding Insert, Update, and Delete constructs

The syntax for the Insert construct is:
begin-sqgl
[insert SQL logic]

end-sqgl

The syntax for the Update construct is:
begin-sql
[update SQL logic]

end-sqgl

The syntax for the Delete construct is:
begin-sqgl
[delete SQL logic]

end-sqgl
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Example
begin-procedure inst-names
begin-sqgl
INSERT INTO names
SELECT #varl, Svar2, S$var3, sysdate,
FROM dual
WHERE names id NOT IN
(SELECT names_id
FROM names
WHERE names id = ~$t_id)
end-sqgl
end-procedure

In this example, values are inserted into a database table.

Understanding the execps statement
This statement runs an SQL Server stored procedure.

This syntax is:

EXECSP spName (Sparaml, #param2, ~Sparam3..)

The tilde ( ~) is used for output parameters.

Understanding the begin-plsql statement
This statement runs an Oracle PL/SQL package or procedure.

e The begin-plsql statement allows a procedure to be called and for variables to be passed to it. It also
allows the return of output variables.

e The => operator is used to assign values to variables.

e The tilde ( ~ ) character is used at the beginning of a program variable to indicate that it is an output
variable type in the plsql code.

The syntax is:
begin-plsqgl
package.procedure (
in variable,
out variable;

end-plsgl
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Example
begin-plsqgl
nolijpackage.proc_add name (
first => 'John',
last => 'Doe',
id => ~#t_id);

end-plsqgl

Understanding the assignment statement

The let statement is the Hyland DataTransfer assignment operator, which is primarily used to assign a
value (for example, constant, date, or other variable) to a variable.

The syntax for the let statement is:
let S$varl = $var2

let $var3 = tostring (#vard)

let $varb = &var6

Character and string variables can be assigned only character values. Use the fostring function for
conversion if you are assigning a numeric value to a character variable. Refer to Understanding the
tostring function.

Numeric variables can be assigned only numeric values. Use the fonum function for conversion if you are
assigning a character value to a numeric variable. Refer to Understanding the tonum function.

You must enclose hard-coded character values in single quotation marks ( ' ) .

Example
let #varl = 45 let $var2
= S$varl

let $var3 = 'test string'

Understanding flow control
Hyland DataTransfer supports the following flow-control statements:

o if...else: Evaluates a statement or value and branch, depending on the result. If TRUE, program
execution branches to the code following the if statement. If FALSE, program execution branches to
the code following the else statement. Refer to Understanding the if...else statement.

e loop...until: Allows multiple lines of program code to be executed continuously until a certain
condition or value exists. Refer to Understanding the loop...until statement.

e evaluate: Evaluates a variable with multiple possible values and branches to a different block of logic
for each value. Refer to Understanding the evaluate statement.

o for each: Iterates over all the specified nodes within a given subtree in an XML file. Refer to
Understanding the for each statement.
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Understanding the if...else statement

The if...else statement is used to evaluate a statement or value and then branch, depending on the result.
There are two basic forms of the if statement: if and if...else.

The if statement is most frequently used to perform an action when a certain condition is met or to skip
the action if the condition is not met. The syntax is:

if <condition>
<statement-list>
end-if
If the condition in the if statement is TRUE, all logic contained in the statement list is run, and if the

condition is FALSE, all logic contained in the statement list is skipped. The end-if statement terminates
the statement list:

if #varl > 40
let #var3 = 45
end-if
The if...else statement uses the keyword else followed by a second set of statements, as follows.
if <condition>
<statement-list>
else
<statement-list>
end-if
If the condition is FALSE, Hyland DataTransfer executes the statement list following the else clause
instead of the statement list following the if clause:
if #varl > 40

let $var3 = 'Over 40'
else

let $var3 = 'Under 40'
end-if

Additional if statements can be nested within each other.
if #varl > 40

let S$var3 = 'Over 40'
else

if #varl = 40

let $var3 = 'Equal 40'
else

let $var3 = 'Under 40'
end-if

end-if
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You can also use the elseif command as a shortcut for nesting statements so that they are more readable
and do not require an end-if command for every condition, as shown in the following example.

if <condition 1>
elseif <condition 2>

elseif <condition 3>

elseif <condition N> else

end-if

The ellipses (...) represents that you can use any number of elseif conditions. If you use the elseif
command, you must also end with an else clause.

Understanding the loop...until statement

The loop...until statement allows multiple lines of program code to be run continuously until a certain
condition or value exists. The until statement evaluates with each loop to determine if the loop should
continue.

Example

#c =0

loop
<statement-list>
let #c = #c + 1

until #c = 5

This loop executes each line in the statement list and increments the #c variable by one until it reaches
five, after which the loop is completed.

Note: The until statement must be the last statement in the loop construct.
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Understanding the evaluate statement

The evaluate statement is used to interpret a variable with multiple possible values and to branch to a

different block of logic for each value or range of values. The evaluate statement is suitable for branching
to three or more possible locations.

Example
evaluate #age
when > 40
let Sdisplay text = 'Over 40'
break
when = 40
let Sdisplay text = 'Equal 40'
break
when < 40
let Sdisplay text = 'Under 40'
break

end-evaluate

You must use the break statement to exit the evaluate statement after you have executed the appropriate
code to prevent program execution from continuing with the next when statement.

You can use consecutive when statements if you are executing the same logic block. Use when-other as
the exception handler.

Understanding the for each statement

The for each statement iterates over all the specified nodes within a given subtree in an XML file. Use this
statement when you are processing XML input files and XML headers.

Use the node function within each for each statement to return the value for the specified node.
Example
for each 'Person'

let $f ssn = node('SSN')

let $f dob = cnvdate(node ('Birth'),yyyy-MM-dd')

let $f_sex = substr (node('Gender'), 1, 1)

for each 'Name'

let $f first = node('FirstName')
let $f middle = node('MiddleName')
let $f last = node('LastName')

next
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for each 'Contacts'
for each 'Address'
let $f_street1_1 = node ('AddressLine')
let $f city 1 = node('City")
let $f_st_1 = node ('StateProvinceCode')
let $f zip 1 = node('PostalCode')
next
for each 'Phone'
let $f full phone 1 = node('Home')
next
for each 'Phone'
let $f full phone 2 = node('Home')
next
next
next

In this example, each record corresponds to the XML subtree contained within the <Student> XML tag.
The example code shows how to process each Student subtree.

Each for each loop specifies the tag, exactly as it appears in the XML, with which to iterate. In this
example, for each loops iterate over every <Person> node within the <Student> subtree.

Use the keyword next to designate the end of the loop.

By nesting for each loops, with each inner loop iterating over the child nodes of the parent, you can iterate
through the entire XML tree.

Use the node function within each loop to return the value of the specified node. For example, the
function iterates over each <Person> node, then over each <Contacts> node, and then over each
<Address> node. Within the <Address> node are the leaf nodes <AddressLine>, <City>,
<StateProvinceCode>, and <PostalCode>. To store the address line in a program variable, use the syntax

let $f streetl 1 = node('AddressLine').
Note the following syntax restrictions.

e If you use XML syntax (for each or node) with input record data that is not XML, an error message
displays when the corresponding job is run.

e If you iterate over a node that does not exist or that does not exist as a child to the current node, the
loop is skipped because no matching child nodes are found.

e If you use the node function to reference a node that does not exist, an empty string is returned.

e If you use the node function to reference a node that is not a leaf node, the function returns a
concatenated string of all the children nodes for the specified node.

For example, if you use node('Address') instead of the leaf nodes of <Address>, you may receive, for
example, 138 Conant Street Beverly MA 02915 as output. For nodes such as <Address>, such output
may be useful; however, for a node like ('Contacts'), you would receive a string of all the addresses
and phone numbers concatenated together, which would likely not be very useful.
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Because this XML syntax allows you to reference every node in the XML by the exact XML tag name,
there are no input variables for XML header jobs. Other input files have an input variable for each
data field in the file, but for XML input files, you must use the for each and node syntax to drill down to
the desired part of the XML tree.

Hyland DataTransfer keeps the current context of the XML tree. If the code is currently within a
particular for each loop, any code within that loop will only process within the current subtree of the
XML. All for each and node calls are contextual, so the same tag name can exist in different levels of
the XML.

Understanding global variables

Global variables are predefined variables that can be referenced at any point during program execution.
Hyland DataTransfer supports the following global variables:

_GL.BATCH_

Run mode variable; specifies that a job is running in batch mode.

_GL.DBNAME_

Database variable; contains the database name or database instance name of the current database.
_GL.EXCEPTION_

Variable to which an exception message is assigned in the catch block of the try...catch function.
Refer to Understanding the try...catch function for more information.

_GL.FILENAME _
Filename variable; contains the name of the current input data file.
_GL.FILEPATH_

File path variable; returns the destination path configured for input files that are downloaded from a
file source (refer to Configuring File Sources for more information about configuring file sources).

_GL.FILETYPE_
File type variable; contains the extension of the current input data file.
_GL.HEADER_

Header variable; contains the title of the current header file (for example, Recruit Card or Web
Application).

_GL.INTERACTIVE_

Run mode variable; specifies that a job is running in interactive mode.
_GL.MATCH_

Status constant; represents a matched record.

_GL.NEW_

Status constant; represents a new record.

_GL.RECORDNO _

Global variable that contains the record number of the record being processed.

_GL.ROWCOUNT_
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Row count variable; contains the number of rows returned from a begin-select or begin-dataprovider
statement.

e _GL.RUNMODE_

Run mode variable. Hyland DataTransfer sets GL_RUNMODE to BATCH when a job is run from the
Job Dashboard. You can configure the code to branch to specify the appropriate behavior when a
job is run in batch or interactive mode.

Example
if GL.RUNMODE = GL.INTERACTIVE
<procedures for interactive mode>
else
<procedures for batch mode>

end-1if

e _GL.SUSPEND_

Status constant; represents a suspended record.
e _GL.STATUS_

Status variable; contains the status (new, match, or suspend) of the row being processed.
e _GL.USERID_

User ID variable; contains the username of the logged in user.

Understanding string functions

String functions are built-in routines for manipulating string variables and values. Refer to the following
topics for more information.

e Understanding the ascii function

e Understanding the inschr function
e Understanding the instr function

e Understanding the length function
e Understanding the lower function

e Understanding the ltrim function

o Understanding the mixed function
e Understanding the mixedlt function
e Understanding the replace function
e Understanding the rtrim function

e Understanding the substr function
e Understanding the tonum function

e Understanding the tostring function
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e Understanding the trunc function
e Understanding the unstring function

e Understanding the upper function

Understanding the ascii function

This function converts a character to its ASCII equivalent.
The syntax is:

ascii (string)

Example

let #num = ascii('X")

Understanding the inschr function

This function converts a character to its ASCII equivalent. The syntax is:
inschr (variable, replace character)

Example

let $city = inschr(Scity, '&')

This statement replaces all occurrences of & in the value of $city with the ASCII equivalent of &.

Understanding the instr function

The instr function searches variable 1 for the occurrence of variable2 beginning at start position. The
syntax is:

instr (variablel, variable2, start position)
Example

#posl = instr($Sstreet2, 'Apt',1)

if instr ('W|AP|AI|AFIN',$f ethn,1) > 0

The function also takes an optional parameter that indicates which occurrence of the found variable
should be returned. If the parameter is negative, the function searches in reverse order. If the parameter is
negative and the starting position parameter is greater than one, the starting position is n characters from
the end, counting backward.

In the following examples, you search for the / character, which occur in the first, ninth, 17th, and 25th
positions.
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Example
let $fieldl = '/folderl/folder2/folder3/"
let #cnt = instr($fieldl, '/', 1, 1)

let #cnt = instr($fieldl, '/', 1, 2)
let #cnt = instr($fieldl, '/', 1, 3)
let #cnt = instr($fieldl, '/', 1, 4)
let #cnt = instr($fieldl, '/', 1, 5)

In this example, the search starts at the first character of the string and finds the nth occurrence (first,
second, third, fourth, and fifth) of the / character. The first request returns 7 because the first character is
the first occurrence of the / character. The second request returns 9 because the ninth character is the
second occurrence of the / character. The third request returns 77, the fourth request returns 25; the
request for the fifth occurrence returns -7 because there is no fifth occurrence.

Example

let $fieldl = '/folderl/folder2/folder3/'
let #cnt = instr($fieldl, '/', 10, 1)
let #cnt = instr($fieldl, '/', 10 2)

let #cnt = instr($fieldl, '/', 10, 3)
let #cnt = instr($fieldl, '/', 10, 4)
let #cnt = instr($fieldl, '/', 10, 5)

In this example, the position of the string from which the search begins is 10 ((the second letter 0); the first
nine characters of the string are ignored. Therefore, the first occurrence of the / character is at position 77
and the second occurrence is at 25. There are no third, fourth, or fifth occurrences of the / character.

Example
let $fieldl = '/folderl/folder2/folder3/"
let #cnt = instr($fieldl, '/', 1, -1)

let #cnt = instr($fieldl, '/', 1, -2)
let #cnt = instr($fieldl, '/', 1, -3)
let #cnt = instr($fieldl, '/', 1, -4)
let #cnt = instr($fieldl, '/', 1, -5)

Because the last parameter (the start position) is negative, the search is performed in reverse order. In
this example, the search begins at the final occurrence of the / character and works backward from the
last character. Therefore, the first occurrence of the / character is at position 25, the second occurrence is
at position 77, the third occurrence is at position 9, and the fourth occurrence is at 7. There is no fifth
occurrence of the / character.
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Example

let $fieldl = '/folderl/folder2/folder3/'
let #cnt = instr($field1l, '/', 12, -1)
let #cnt = instr($fieldl, '/', 12, -2)
let #cnt = instr($fieldl, '/', 12, -3)
let #cnt = instr($fieldl, '/', 12, -4)
let #cnt = instr($fieldl, '/', 12, -5)

To perform a reverse search using a start position greater than 7, the search starts at the end of the string
and moves in reverse the specified number of starting characters; then it begins searching for the nth
occurrence of the character from the remaining characters.

Because the starting position is 72, the search first counts backward twelve characters from the end. The
twelve characters from reverse are er2/folder3/, so those characters are ignored; the remaining string is
folder1/fold.

Next, the function begins its search backward from the last character of the remaining sting—in this
example, the search begins at the final character d in the folder1/fold string—and finds the nth
occurrence of the / character. In this example, the first occurrence of the / character is at position 9 and
the second occurrence is at position 7. There are no third, fourth, or fifth occurrences.

Understanding the length function
This function returns the length of a string. The syntax is:
length (string)

Example
let #num = length('Hello"')

Understanding the lower function
This function converts a string to lower case letters. The syntax is:
lower (string)

Example

let Stvar = lower ($t name)

Understanding the Itrim function

This function removes all contiguous matching characters of type char_type from the left side of a string
variable. If char_type is not specified, the Itrim function uses the space character by default. Hyland
DataTransfer begins scanning the string from the left-most character and removes all matching
characters until it encounters a character of a type other than char_type.

The syntax is:

ltrim(string, char type)

For example

let Sunpadded = ltrim('25 Main Street', ' ')

let Sunpadded = ltrim('25 Main Street')
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Understanding the mixed function

This function converts a string to mixed case with the first characters typically being set to upper case.
The syntax is:

mixed (string)
For example

let S$street = mixed('1l35 washington street')

let $street = mixed('135 WASHINGTON STREET')
Understanding the mixedlt function

Understandingthe mixedltfunction

This function converts a string to mixed case, capitalizing the first character only. The syntax is:
mixedlt (string)

Example

let $street = mixedlt('135 vanarsdel street’)

let $street = mixedlt('135 O’HENRY STREET')

Understanding the replace function

This function replaces a string and takes three parameters.
e Source string

e Search string

e Replacement string

The code finds all occurrences of the search string within the source string and replaces them with the
replacement string.

Example
let $lk-test = '12421 Main Street'
let $lk-test = replace($lk-test, 'Street', 'St')

In the preceding example, the result returned by the replace function is '12421 Main St'.

Understanding the rtrim function

This function removes all contiguous matching characters of type char_type from the right side of a string
variable. If char_type is not specified, the rtrim function uses the space character by default. Hyland
DataTransfer begins scanning the string from the right-most character and removes all matching
characters until it encounters a character of a type other than char_type.

The syntax is:
rtrim(string, char type)

Example
let Sunpadded = rtrim('25 Main Street', ' ')

let Sunpadded = rtrim('25 Main Street')
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Understanding the substr function

This function returns a portion of a string beginning at start_pos and extending char_len characters. If
start_pos plus char_len is greater than the length of string, the extra characters are ignored.

The syntax is:

substr (string, start pos, char len)

Example
let S$short var = substr('last first middle',6,12)

Understanding the tonum function
This function converts a string to a number.
The syntax is:

tonum (string)

Example
let #num = tonum('123.45")

Understanding the tostring function
This function converts a number to a string.

The syntax is:

tostring (number)

Example

let Sterm = tostring (#year)

Understanding the trunc function
This function returns a truncated version of a long date.

The syntax is:

trunc (date wvalue)

Example
let S$new date = trunc(Ssysdate)

Understanding the unstring function

This function splits a string into two smaller strings depending on the occurrence of a separator
character.

This syntax is:

unstring ($stringl, $delimiter, S$outl, S$Sout2)

Example

unstring 'John Doe' by ' ' into $fname and $lname
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Understanding the upper function
This function converts a string to upper case letters.

The syntax is:
upper (string)

Example
let $tvar = upper ($t_name)

Understanding general functions

General functions are a mixed collection of general purpose routines. Refer to the following topics for
more information.

e Understanding the begin-dataprovider function

e Understanding the CopyFile function

e Understanding the cnvdate function

e Understanding the DataProviderCall function

e Understanding the DataProviderPrompt function

e Understanding the do function

e Understanding the ExtractBinary function

¢ Understanding the HobsonsUpdate function

e Understanding the ImageNowAddDoc function

e Understanding the ImageNowAddToFolder function

e Understanding the ImageNowAddToQueue function
e Understanding the ImageNowCreateFolder function

e Understanding the ImageNowUpdateNote function

e Understanding the ImageNowUpdateCustomProperty function
¢ Understanding the ImageNowUpdateDocumentProperty function
e Understanding the ImageNowAddStickyNote function
e Understanding the ImageNowGetFolder function

e Understanding the InitializeVars function

e Understanding the InsertBinary function

e Understanding the isnull function

e Understanding the logit function

e Understanding the lookup function

e Understanding the MoveFile function

e Understanding the NWAddDoc function
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e Understanding the NWGetDoc function

¢ Understanding the NWWorkComplete function
e Understanding the PopulateTemplate function
e Understanding the prompt function

e Understanding the skip function

e Understanding the stop function

e Understanding the store function

e Understanding the toggle function

e Understanding the toggle off function

e Understanding the toggle on function

e Understanding the try...catch function

Understanding the begin-dataprovider function

You can use a begin-dataprovider/end-dataprovider block of code to run a specified data provider and
iterate over its results. Use the following syntax.

begin-dataprovider S$SwebServiceName
For example, consider the following begin-select syntax.
begin-select
nu_id ~#pers nuid let
#nu_id = #pers_nuid let
$status = 'M'
let Smtch code = 'MPL1'
store 1, '#nu_ id' ! rank, ID - will be fed to review process
stop ! exit match process here
FROM nu_person
WHERE ssn = ~$f ssn

end-select

The preceding example could use a data provider instead of a SQL query, as shown in the following
example.

begin-dataprovider 'personWS'

let $status = 'M'

let $mtch code = 'MP1'

store 1, 'Sws_id' ! rank, ID - will be fed to review process
stop ! exit match process here

end-dataprovider

After begin-dataprovider, you must provide the name of the data provider to run. In the preceding
example, personus is the name of the data provider.
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The same code can be used inside begin-select asitis inside begin-dataprovider. Also, similar to
begin-select, begin-dataprovider runs the data provider and iterates over the results, running the
lines of codes for each result.

Like an exit-select statement that exits the begin-select/end-select code block, exit-dataprovider
exits the begin-dataprovider/end-dataprovider code.

You can also use the optional $payload parameter to replace the existing payload value of the web
service before it runs. Using this parameter, you can dynamically create the payload and pass it to the
web service at runtime. Use the following syntax.

begin-dataprovider S$SwebServiceName S$payload

Use this function with SOAP web service or web service data providers. For more information, refer to
Configuring data providers.

Note: SOAP web service data providers are supported in Hyland DataTransfer 6.4.5 and higher.

Understanding the CopyFile function

This function copies a specified file from the source path to the destination path. It takes three
parameters: the filename, the source path, and the destination path.

You can use wildcard characters in the flename parameter. If you use a wildcard, all files matching the
specified criteria are moved.

Note: If you a copy a file that has the same filename as a file in the destination path, the existing file is
overwritten.

Example

CopyFile ('temp.xml', 'c:/', 'c:/backup/"')

Understanding the cnvdate function

This function converts multiple long date values into a formatted date string. This function takes two
parameters: the string to convert into a date and the format of the new date string. For the first parameter,
the string must be in one of the following formats to be recognized as a valid date.

e dd-MMM-yy

¢ MM-dd-yy

e yyyy-MM-dd

o yyyy/MM/dd

¢ MMM ddyyyy

o dd-MMM-yyyy

e MM-dd-yyyy

e  MM/ddlyyyy

The syntaxis cnvdate (date value, 'format string')

Example
let S$tmp date = cnvdate($t date, 'DD-MMM-YYYY')

235



Hyland DataTransfer Administrator Guide

Understanding the DataProvider Call function
This function uses two parameters.
e The swebServiceName parameter is the name of the web service to run.

e The optional spayload parameter replaces the existing payload value of the web service before it
runs. Using this parameter, you can dynamically create the payload and pass it to the web service at
runtime.

The syntax is:
DataProviderCall ($SwebServiceName, S$Spayload)
Example

let Sws_id = '10' DataProviderCall ('personWs')

In this example, personWS is the name of the web service you run. When Hyland DataTransfer reaches
this line of code, it performs the following tasks to run the personWS web service.

1. Hyland DataTransfer looks up the web service by the supplied data provider name.

2. It verifies the current connection group, which is the group configured for the job configured to run, for
the saved connection name.

3. Hyland DataTransfer finds the connection for the connection group. One of the following situations
occurs.

e [fit finds the matching connection, it uses the URL to run the web service request; then, it populates
the input parameters with the values of the mapped program variables. If the web service returns
more than one result, the record suspends with a Too many results returned reason.

e Ifit does not find a matching connection, the web service request results in an error.

In the preceding example, after you run the personWS web service, the output values are inserted into the
mapped program variables. The value of the sws_fist name parameter is John, the value of the
$ws_last name parameter is Doe, and the value of the $ws_id parameter is 10.

Use this function with SOAP web service or web service data providers. For more information, refer to
Configuring data providers.

Note: SOAP web service data providers are supported in Hyland DataTransfer 6.4.5 and higher.

Understanding the DataProvider Prompt function

The command runs the specified web service, as described in Understanding the DataProvider Call
function. It also displays a prompt that users can use to view results.

Use the following syntax.

DataProviderPrompt S$prompt, S$webServiceName, S$hidePromptWhenEmpty, S$autoSelectResult,
Spayload

Example

let Sws_id = ' '

let $ws_first name = ' '

let Sws_last name = ' '

DataProviderPrompt 'Choose the matching person.', 'personWs'
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This function uses two required parameters: a prompt (sprompt) and the name of the web service
($webServiceName).

You can also set two optional string parameters (for example, string literals, string expressions, string
variables, and so on). Use a v (or y) value to indicate that the option is enabled. You can also use the
optional spayload parameter. The optional parameters are listed below.

The shidePromptWhenEmpty parameter is a flag to hide the prompt if no results are returned by the
data provider—if the request had no results, Hyland DataTransfer does not prompt the user to select
one.

Example

let Sws_id = ' !

let Sws_first name = ' '
let Sws_last name = ' '

DataProviderPrompt 'Choose the matching person.', 'personWS', 'Y'

The $sautoselectResult parameter is a flag to automatically select the result if exactly one result is
returned by the data provider—if the data provider returns a single record, the record is auto-selected
and no prompt displays.

Example

let Sws_id = ' '

let Sws_first name = ' '

let $ws _last name = ' '

DataProviderPrompt 'Choose the matching person.', 'personWs', 'y', 'y'

The optional spayload parameter replaces the existing payload value of the web service before it

runs. Using this parameter, you can dynamically create the payload and pass it to the web service at
runtime.

In the Result Selection dialog box, the prompt you supply appears in the field at the top of the dialog
box. All results returned by the web service appear in the table below.

After a user selects a row, the OK button is enabled. If the user clicks OK, all the values from the selected
row are placed into the mapped program variables.

This prompt appears when a job is running in interactive mode only. If this function is processed when a
job is run in batch mode, Hyland DataTransfer checks the number of return results. The web service
performs the following actions.

If there are no results, the output program variables are set to the empty string.
If there is one result, the output values are placed into the mapped program variables.

If there is more than one result, the record is suspended with a Too may results reason.

Use this function with SOAP web service or web service data providers. For more information, refer to
Configuring data providers.

Note: SOAP web service data providers are supported in Hyland DataTransfer 6.4.5 and higher.
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Understanding the do function

This function executes a Hyland DataTransfer procedure and optionally passes in one or more
parameters.

The syntax is:

do procedure-name [argl, arg2,.. argN]
Example

do check-dob

do lookup-name (#ssn, $last, S$first)

Understanding the ExtractBinary function

This function takes two parameters: a SQL query that retrieves one database BLOB value and a file type
that stores the binary data. It then returns the file path to the file created from the binary data.

Example
let sfilepath = ExtractBinary ($query, 'pdf')

In this example, the $query parameter contains a SQL SELECT statement that returns one record with
one column of a binary data type (for example, BLOB). Hyland DataTransfer executes the query and
creates a file with the specified extension (in this example, PDF) by writing the binary data to the file. The
ExtractBinary function then returns the filepath to the file that was created.

Note: The ExtractBinary function is supported in Hyland DataTransfer 6.4.3 and higher.

Understanding the HobsonsUpdate function

You can update Hobsons Connect CRM data using Hobsons Connect CRM web services. To do so, you
create a connection group that contains a Hobsons Connect CRM connection and then you can create a
Hobsons Connect CRM header. You create a job that uses the Hobsons Connect CRM header and
connection and can use the appropriate NQL logic that updates Hobsons Connect CRM data when the
job runs.

This syntax, which is optional, is:

HobsonsUpdate (<web service name>, <contact id>, <attribute name 1>, <attribute wvalue
1>, <attribute name 2>, <attribute wvalue 2>, ... , <attribute value n>)

The required parameters are:
o <web service name>: the name of the Hobsons web service (for example, UpdateContact).
e <contact id>: the ID value of the contact record to update.

The additional parameters are any number of attribute name or value pairs. Both components of the pair
are strings; the first string identifies the name of the Hobsons Connect CRM attribute to update and the
second string is the new value for the specified attribute.

The HobsonsUpdate function returns a string. If the update is successful, an empty string is returned. If it
is not successful, a corresponding error message is returned.

An example of the syntax is:
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let Serr = HobsonsUpdate ('UpdateContact', $id, 'first name', $fname, 'last name',
$1lname, 'dob', S$Sdob')

This syntax runs the UpdateContact web service on the contact with id $id and updates the first_name

attribute to the value in $fname, the last_name attribute to the value in $/lname, and so on.

Understanding the ImageNowAddDoc function

To upload a file to ImageNow, use the following syntax:

ImageNowAddDoc ($filepath, S$document name, $index map)

e The first parameter is an absolute path to the document you want to upload. The filename of the file in
the filepath parameter can contain one or more * (asterisk characters) as wildcards. If a file matches
the pattern, it is used. If no file matches the pattern or if multiple files match the pattern, the record is
suspended. You cannot use the * as part of the directory name.

e The second parameter is the name to provide to the document when it uploads.

e If this document name already exists in ImageNow, the function appends a number to the end
until it finds a document name that does not exist. For example, if you try to name the document
document, but document already exists, the function uses the name document(1). If document(1)
also exists, the function uses the name document(2), and so on.

e You can supply an empty document name. The function uses other criteria to determine if there is
a matching document with no name. If it finds a match, the function appends the file to the
existing document as a new page to that document. If a matching document is not found, the
function creates a new document whose document name is the document ID.

e The third parameter is the name of an ImageNow index map (refer to Configuring ImageNow Index
Maps for more information). This object links all the necessary ImageNow document properties to
program variables that can be used in the code. Hyland DataTransfer then performs a lookup on the
index map name to obtain all the mapping information necessary to upload the document. All
ImageNow properties are replaced with the value in the corresponding program variable.

Any time the ImageNowAddDoc syntax is reached in the code, Hyland DataTransfer obtains the
Integration Server connection in the current connection group and uploads the document using
ImageNow web service APIs. For more information about Integration Server connections, refer to Adding
and modifying integration server connections.

It also updates the document properties, including the custom properties, specified in the selected
ImageNow index map. For more information about configuring ImageNow index maps, refer to
Configuring ImageNow Index Maps.

This function also returns the document ID created for the uploaded document.

You can also set two optional parameters to convert files to TIFF and to delete the original file. The

following example requests show how to set optional parameters:
ImageNowAddDoc ('c:\temppdf\test2.pdf', $docname, $index map, 'Y')

and
ImageNowAddDoc ('c:\temppdf\test2.pdf', S$docname, $index map, 'Y', 'Y')

The first request contains the optional parameter to convert the file to a TIFF file before uploading. Use Y
to convert the file to TIFF. Any other value, including an empty string, does not convert the file to a TIFF.
In the first request, test2.pdf will be converted into a temp file called test2.tif. The temporary TIFF file will
be uploaded into ImageNow and will be deleted when the upload is complete. The original test2.pdf file
remains.
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You can configure properties for converting TIFF to PDF in Administration > System Properties > PDF to
TIFF; for more information, refer to Configuring PDF to TIFF Properties.

The second request contains the optional parameter to delete the original file. Use Y to delete the original
file. Hyland DataTransfer deletes files every minute. In the second request, because both optional
parameters are set, test3.pdf will be converted into a TIFF, the TIFF will be uploaded to ImageNow, and
then both the temporary TIFF file and the original test3.pdf file will be deleted. If the first optional flag is a
value other than Y, the original test3.pdf will be uploaded to ImageNow and then deleted.

The TIFF file, if one is created, is temporary and is always deleted; however, whether the original file is
deleted depends on the second optional parameter.

Note: Instead of using Y, you can also pass in string expressions, including program variables; however,
those values must be equivalent to Y to set the flag.

Note: You can convert only PDF files to TIFF files. If the file you want to convert is in any other format, the
file is not uploaded and an error message appears.

Understanding the ImageNowAddToFolder function

This function moves an existing ImageNow document into a specified ImageNow folder. It takes the
ImageNow document ID and ImageNow folder name. This function requires a properly configured
ImageNow integration server connection in the connection group you are using. The syntax is:

ImageNowAddToFolder ($imagenow docid, S$imagenow foldername)
Parameters are:
e $imageNow_docid: Document ID of the ImageNow document you are moving.

e $imagenow_foldername: Name of the ImageNow folder into which you are moving the document.

Understanding the ImageNowAddToQueue function

This function adds an ImageNow document to an ImageNow workflow queue. The syntax is:

ImageNowAddToQueue ($docid, S$workflowprocessName, S$queueName)
Parameters are:
e $docid: Document ID of the ImageNow document you are moving.

e SworkflowprocessName: Name of the ImageNow workflow process into which you are moving the
document.

Note: The workflow history remains unchanged when documents are added to the workflow queue.

e  $queueName: Optional parameter representing name of the ImageNow queue into which you are
moving the document.

When the code reaches this function, the Integration Server connection in the current connection group is
used to execute an ImageNow web service to move the document into the queue.

Understanding the ImageNowCreateFolder function

This function creates a new folder in ImageNow. It takes a folder name, drawer name, and folder type.
This function requires a properly configured ImageNow integration server connection for the connection
group you are using. The syntax is:

ImageNowCreateFolder ($foldername, S$drawername, S$foldertype)
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Parameters are:
e $foldername: Name of the ImageNow folder you are creating
e $drawername: Name of the ImageNow drawer into which the folder is added

o $foldertype: Type of folder

Understanding the ImageNowUpdateNote function
This function appends a note to an existing document.

The syntax is:

ImageNowUpdateNote ($docid, S$note)
It uses the following parameters:
e $docid: Valid document ID of an existing document in Perceptive Content

¢ S$note: The note that is appended to the document

Understanding the ImageNowUpdateCustomProperty function
This function updates the custom properties of an existing document.

Note: The date type custom property accepts values in Epoch timestamp in milliseconds.
The syntax is:

ImageNowUpdateCustomProperty ($docid, $name, $value, S$iscomposite,
ScompositePropertyName)

The ImageNowUpdateCustomProperty function uses the following parameters:
e $docid: Valid document ID of an existing document in Perceptive Content
e $name: Valid name of the custom property of the document

e $value: Valid value of the custom property of the document. If the value is Boolean, use ‘0’ for
FALSE and ‘1’ for TRUE.

e S$iscomposite: Optional Parameter. This parameter signifies whether the data type of the custom
property is composite.

e $compositePropertyName: This parameter signifies the name of the composite property.

Note: You must set the $iscomposite flag to Y/N. If Y, ensure that you enter a valid value for the
$compositePropertyName.

Understanding the ImageNowUpdateDocumentProperty function
This function updates the document properties of an existing document.

The syntax is:

ImageNowUpdateDocumentProperty (Sdocid, S$name, S$Svalue)
It uses the following parameters.
e $docid: Valid document ID of an existing document in Perceptive Content

e $name: Valid name of the document property of the document
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e $value: Valid value of the document property of the document

Understanding the ImageNowAddStickyNote function
This function adds sticky note annotation to an existing document.

The syntax is:

ImageNowAddStickyNote ($docid, $pageid, $filepageno, S$templateid, $x, Sy, S$Scontent,
Squeueid)

It uses the following parameters:
e $docid: Valid document ID of an existing document in Perceptive Content
e $pageid: Valid Page ID of an existing document in Perceptive Content
o S$filepageno: The file page number of the annotation
o S$templateid: The ID of the annotation template used to create this annotation
e $x: X co-ordinate of the position of the sticky note annotation on the document
e 3y: Y co-ordinate of the position of the sticky note annotation on the document
e S$content: The note that is added to the sticky note

e $queueid: Optional Parameter. Verifies the user's process privilege of the workflow queue that
the document is in. Overrides the user's open content privilege for the drawer that the document
is in.

Note: Sticky notes are rendered for TIFF files only.

Understanding the ImageNowGetFolder function

This function returns the ImageNow ID for a specified folder. It takes the folder name and searches
ImageNow for the folder. If a match is found, the function returns the ID of the folder. If a match is not
found, an empty string is returned. This function requires a properly configured ImageNow integration
server connection for the connection group you are using.

The syntax is:
let $folderid = ImageNowGetFolder ($foldername)

The $foldername parameter is the name of the ImageNow folder.

Understanding the InitializeVars function

The InitializeVars function updates all program variables in a variable map to use the specified default
value.

The syntax is:
InitializeVars 'Variable Map Name'
where Variable_Map_Name is the single string parameter that represents the name of the variable map.

For example, you can create a variable map for a header, with the variable map containing all the program
variables and their default values for the header, and use the InitializeVars function to set all the default
values.
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Understanding the InsertBinary function

Use the InsertBinary function to insert a binary file directly into the database. The syntax is:
InsertBinary ($Sfilepath, S$Squery)

Parameters are:

o Filepath: Absolute path to the file to insert into the database.

e Query: SQL query to execute that inserts or updates the record with the binary file. The query must
contain a question mark ( ? ) for which the binary file is substituted

Example
InsertBinary('c:/temp/file.pdf', 'INSERT INTO file table (id, binary file) VALUES (1,
?2)")

The absolute path to the file is c:/temp/file.pdf, the query also contains a ? symbol. Hyland DataTransfer
will execute the query and replace the ? with the binary contents of the file, which inserts the file directly
into the database. You can also use an SQL UPDATE statement, instead of an INSERT statement, to add
the file to an existing database record.

Understanding the isnull function

This function returns TRUE if the variable contains no valid data (NULL); otherwise, it returns FALSE. It
also returns TRUE if the string variable being queried is either null or is the empty string.

The syntax is:

isnull (variable)

Example

if isnull (Scity)

let $valid = isnull (Sdob)

Understanding the logit function

This function defines a custom logging type that will produce the logit type entries in the Log View dialog
box.

When Hyland DataTransfer is set up, custom logging or text may be written to the log file; this text does
not cause a record to suspend but writes a comment to the log file.

The syntax is:

logit 'Custom log message'

Example
logit 'No match on high school code'

logit 'Generated ID: '||$id

Understanding the lookup function

This function substitutes an output value for an input value and stores it in a program variable. Lookup
values are defined in the lookup tool (refer to Configuring Lookup Values for more information).
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The syntax is:

Let out variable = lookup(in variable, field)

The $out_variable is sent to the output value from the lookup tool. The field name is passed to the
lookup() function, either through a single-quoted $Field name or custom text that you define, along with
thein_variable.

For example, for the following fields defined in the lookup tool:
e Field: ActivityCustomMapping

e In: Testlnput

e Out: TestOutput

Use the following function.

let $tmp var = lookup ('TestInput', 'ActivityCustomMapping')
$tmp_var is set to 'TestOutput'.

For example, for the following fields defined in the lookup tool:
e Field: SACTIVITY

e In: Testinput

e Out: TestOutput

Use:

let $tmp var = lookup ('TestInput’','$ACTIVITY')
$tmp_var is set to 'TestOutput'.

Note: You do not need to use a variable name; you can use other parameters, such as activity codes or a
custom name.

Note: You define input and output variables only one time through the lookup tool.

Understanding the MoveFile function

This function moves a specified file from the source path to the destination path. It takes three
parameters: the filename, the source path, and the destination path.

You can use wildcard characters in the filename parameter. If you use a wildcard, all files matching the
specified criteria are moved.

Note: If you a move a file that has the same filename as a file in the destination path, the existing file is
overwritten.

Example

MoveFile ('temp.xml', 'c:/', 'c:/backup/"')

Understanding the NWAddDoc function

This function passes documents from Nolij Web into Hyland DataTransfer. After Hyland DataTransfer
creates a new or match record for the document, the document is sent to Nolij Web using this Nolij Web
API command.

It uses the following parameters.
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o #docCode: wfdt code, determined by the filename extension by Nolij Web. This value can be null.
e $srcPath: Directory on the server in which this file is located.

o S$fileName: Filename of the file. It can contain one or more * (asterisk characters) as wildcards. If a file
matches the pattern, it is used. If no file matches the pattern, or if multiple files match the pattern, the
record is suspended.

e S$folderID: Folder ID. String or numeric variables can be values.
e $subfolderID: Not yet supported by Nolij Web API. String or numeric variable is accepted.

e #Husercode: Nolij Web usercode for the authentication username stored for the Nolij Web connection.
The value can be null. If null is passed, the API uses the default usercode for the authenticated user
name.

You cannot use the Nolij Web superuser account with this function. When you configure the Nolij Web
connection, you must use an account that has one or more roles assigned. Any user code you use with
this function must be for a role owned by the account used in creating the Nolij Web connection.

The syntax is:

NWAddDoc (#docCode, S$srcPath, $fileName, $folderID, $subfolderID, #usercode)

You can also set two optional parameters to convert files to TIFF and to delete the original file.
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Example

nwadddoc (0, 'c:\temppdf\', 'test2.pdf', '325', '', 33, 'Y')

and

nwadddoc (0, 'c:\temppdf\', 'test3.pdf', '325', '', 44, 'Y', 'Y")

The first request contains the optional parameter to convert the file to a TIFF file before uploading. Use Y
to convert the file to TIFF. Any other value, including an empty string, does not convert the file to a TIFF.
In the first request, test2.pdf will be converted into a temp file called test2.tif. The temporary TIFF file will
be uploaded into Nolij Web and will be deleted when the upload is complete. The original test2.pdf file will
remain.

You can configure properties for converting TIFF to PDF in Administration > System Properties > PDF to
TIFF; for more information, refer Configuring PDF to TIFF Properties.

The second request contains the optional parameter to delete the original file. Use Y to delete the original
file. Hyland DataTransfer deletes files every minute. In the second request, because both optional
parameters are set, test3.pdf will be converted into a TIFF, the TIFF will be uploaded to Nolij Web, and
then both the temporary TIFF file and the original test3.pdf file will be deleted. If the first optional flag is a
value other than Y, the original test3.pdf will be uploaded to Nolij Web and then deleted.

The TIFF file, if one is created, is temporary and is always deleted; however, whether the original file is
deleted depends on the second optional parameter.

Note: Instead of using Y, you can also pass in string expressions, including program variables; however,
those values must be equivalent to Y to set the flag.

Note: You can convert only PDF files to TIFF files. If the file you want to convert is in any other format, the
file is not uploaded and an error message appears.

Understanding the NWGetDoc function

This function downloads a specified document from Nolij Web and stores the document in a temporary
space on the Hyland DataTransfer server. It returns the string path to the temporary file, which the user
can use to reference and use the downloaded file. This function requires a properly configured Nolij Web
connection in the connection group you are using. The syntax is:

let $filepath = NwGetDoc (#docid, $folderid, #usercode)
Parameters are:

e #docid: Numeric document ID in Nolij Web.

e S$folderid: Nolij Web folder ID for the document.

e #usercode: User code of the Nolij Web user who is attempting to download the document. The
#usercode parameter must correspond to the user configured for the Nolij Web connection in the
connection group you are using.
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Understanding the NWWorkComplete function

This function starts the Nolij Web workflow process and routes folders to the appropriate inboxes. This
function takes four parameters:

* Nolij Web workflow code: a string parameter that contains the Nolij Web wfma code.
e Folder Id: a string parameter that contains the Nolij Web folder ID.
o Folder name: a string parameter that contains the folder name as it appears in Nolij Web.

e User code: a numeric code parameter that contains the Nolij Web user code with which to run the
Work Complete action.

Example
NWWorkComplete ('289', '1464', 'Adams, Nicole', 44)

In the preceding example, 289 is the wfma code, 1464 is the folder ID for Nicole Adams, ‘Adams, Nicole'
is how the folder is named in Nolij Web, and 44 is the Nolij Web user code with which to run the Work
Complete action.

Understanding the PopulateTemplate faction

Use the PopulateTemplate function with document templates. When you create a new document
template that references program variables in its text, the PopulateTemplate function applies the values
of the variables to the template and creates a new text file.

Example
let $filepath = PopulateTemplate (Stemplate name)

In this example, the PopulateTemplate function looks up the document template by the specified
template name parameter, replaces all program variables in the template with their values, and then
creates a new text file in a temporary location. The PopulateTemplate function returns the file path of the
new text file. The format of the text file depends on the document type specified for the document
template (for example, a TXT type creates a .txt file, and XML type creates an .xml file, and so on). You
could then use the ImageNowAddDoc or NWAddDoc function to upload the created text file.

You can use two optional parameters—file source name and filename—with the PopulateTemplate
function. You can use these parameters to specify where to place the file after running the
PopulateTemplate function. If you provide a file source name and filename, the function retrieves the
configured file source for the workspace version and creates the file in the path of the file source; the file
created is named with the value supplied in the flename parameter.

If you supply a file source name, you must also supply the filename.

Example

let $filepath = PopulateTemplate ('XML for Auto Import', 'ServerPath', 'temp.xml')
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Understanding the prompt function

This function displays a string of message text to the user and allows users to update values for displayed
variables. You define the prompt text to display and you define the program variables that the user can
update. You also define the label that is displayed for the variable; this label is displayed to the user
instead of the actual variable name.

When a job is run in interactive mode and this line of code is reached, job processing is paused, and the
Prompt dialog box appears. The dialog box displays the prompt message and the labels for the variables
you defined; it also displays the corresponding values for the variables. The user can modify the value of
the variables.

The syntax is:

prompt string, variablel, labell, variable2, label2...variableN, labelN

Example

prompt 'Address is not valid. Please adjust accordingly.', S$fstreetl 1, 'Street 1',

Sfstreetl 2, 'Street 2', $f city 1, 'City', $f st 1, 'State', $f phone 1, 'Phone'

Understanding the skip function

This function skips all other processing and updates the status on the record. The first parameter is the
status to use: NEW, MATCH, SUSPEND, or LOCK.

The syntax within matching routines is:

skip [NEW/MATCH/SUSPEND], 'Reason for new/match/suspend'
Example

skip SUSPEND, 'Invalid birth date'

The syntax within procedure code is:

skip [SUSPEND/LOCK], 'Reason for suspend/lock'

The skip LOCK function locks the record, highlights it in a fuchsia color, and changes the status of the
record to Locked.

The SKIP NEW and SKIP MATCH commands, using additional second parameters, can be used in code
for jobs run in interactive mode to identify the rank value for a record; the rank indicates the stage of
matching during which the record was set as Match or New. The rank value appears in the Rank column
in the window that appears when you open or edit jobs. For more information, refer to Understanding
record rank.

Understanding the stop function

This function causes program execution to pause and the Hyland DataTransfer window to switch into
review mode for any records previously collected using the store command.

This syntax is:
stop

Example

<statement-list>
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store 1, '#uid'

stop

Understanding the store function

This function causes the matching set of unique IDs for the current record, in addition to a number
indicating the relative matching step, to be stored internally for subsequent display and review by an
operator.

The syntax is:

store step#, uid var
Example
<statement-list>
store 1, '#uid'

In addition, the STORE command in code for jobs run in interactive mode is used to identify the rank
value for a record; the rank indicates the stage of matching during which the record was set as Match or
New. The rank value appears in the Rank column in the window that appears when you open or edit jobs.
For more information, refer to Understanding record rank.

Understanding the toggle function
This function returns the state of a form field set toggle associated with the variable being passed in.

All variables linked to form objects are associated with a field set, which may have a visible form toggle. A
form toggle is an interactive check box indicating whether a group of fields will be included in the data
upload process.

Passing any variable linked to a form group into the toggle function returns the state of the toggle button
for that field set as either TRUE (data in this field set will be included in the upload) or FALSE (data in this
field set will not be included in the upload).

Toggle check boxes can be manually overridden to force certain data to be loaded or cause certain data
to be skipped.

The syntax is:

toggle (variable)

Example

if toggle ($suffix)

Understanding the toggle_off function

This function causes the form field set toggle associated with a linked form variable to be turned off (set
to FALSE).

The syntax is:

toggle off (variable)

Example
toggle off (Slast)
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Understanding the toggle on function

This function causes the form field set toggle associated with a linked form variable to be turned on (set
toTRUE).

The syntax is:

toggle on(variable)
Example

toggle on($last)

Understanding the try...catch function

This function discovers possible exceptions that could occur in a block of code and manages the
exception instead of stopping processing on and suspending the record. Hyland DataTransfer attempts
to run the commands between try and catch. If it is successful, it omits the catch block. If it is not
successful on any line of code, it moves to the next block and runs the commands in that block instead.

Example
try
begin-select
field 1 ~Sfieldl
from invalid table name
end-select
catch
logit GL.EXCEPTION

end-try

In this example, Hyland DataTransfer first attempts to run the begin-select command; the command is
unsuccessful with an SQL exception because the table and column do not exist. When Hyland
DataTransfer reaches the exception, it moves to the catch block and instead runs the /ogit command.

After it runs the commands in the catch block, Hyland DataTransfer continues to process the code that
follows end-try.

Use this function with the _GL.EXCEPTION__ global variable, to which the exception message is assigned.
It is populated only when it is inside a catch block. Refer to Understanding global variables for more
information about global variables.
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