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Introduction 
Perceptive DataTransfer is a data matching, review and upload solution that allows you to automatically 
verify, clean up, and enter data extracted from hand-printed paper forms, downloadable web forms, and 
almost any other electronic source.  

You can quickly and accurately upload information into your database, such as online and paper 
applications, recruit cards, SAT scores, ACT scores, GRE scores, and AP scores without the risk of 
creating duplicate student records.  

With Perceptive DataTransfer, you can: 

 Import a nearly unlimited range of data files. 

 Match input data to records in your database. 

 Review potentially matching records side-by-side. 

 Upload new or modified information in real-time into your database. 

You can customize Perceptive DataTransfer to upload any type of data from any information source in the 
Perceptive DataTransfer source code.  

Starting and Logging in to Perceptive DataTransfer  

To start and log in to Perceptive DataTransfer, do the following: 

1. Start the application by doing one of the following: 

 Open a web browser and type the Perceptive DataTransfer location into the browser address bar. 
For example, type an address such as http://servername:8080/DataTransfer.  

 On desktop computers, open the Perceptive DataTransfer location by selecting File > Open from 
the browser menu and provide the location.  

 On desktop computers, double-click the Perceptive DataTransfer shortcut icon, or (in Microsoft 
Windows) right-click it and click Open, or (in Apple Mac and Linux) control-click it and click Open. 

By default, there is no shortcut icon. On desktop computers, you can create a desktop shortcut, or, for 
tablets, phones, and desktop computers, you can bookmark the startup page to access it quickly 
when you subsequently log in to the application.  

2. When you log into Perceptive DataTransfer for the first time, you are prompted to accept the End 
User License Agreement (EULA). Click Accept to accept the agreement. When you accept the 

agreement for your username, it is also accepted for all other roles to which you belong; if you switch 
to another Role, you do not have to accept the EULA again. If you click Decline, you are redirected to 

the log in screen. 

3. Type your username and password in the Username and Password fields. Your username and 
password are usually the same as those you use to log in to your administrative system.  

Note:  If there are issues starting Perceptive DataTransfer or entering data in the login screen, 

contact your Perceptive DataTransfer system administrator for assistance in establishing the 
necessary connection rights and privileges. 

4. Click Log in.  

If you are logging into a workspace version in Edit mode and another user is logged into that version 
of the workspace, you receive a prompt that the Edit version is locked by another user. 
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You are logged in to Perceptive DataTransfer, and the application starts. 

You are logged in to Perceptive DataTransfer with your default user role and workspace version in 
which you are working. Specific product functions and features are available depending on the role 
you use and on the workspace version in which you are working. 

Note:  After 25 minutes of inactivity, you are prompted that you will be logged out within five minutes 

of further inactivity. 

Understanding the Desktop and Tablet Interfaces 

Perceptive DataTransfer displays the desktop view when you use the application on desktop computers; 

it displays the tablet view when you use it on tablets and on phones with larger resolutions. The layout 

differs slightly between the interfaces, and not all features are available for the tablet view.  

The Job Dashboard displays all jobs that are configured for Perceptive DataTransfer and allows users to 

run jobs in batch mode.  

The Perceptive DataTransfer toolbar provides access to Perceptive DataTransfer features. Refer to the 

following table for a description of the toolbar menu options. 

Element Description 

Perceptive button Contains the following options: 

 Open Admin Guide. Provides access to the 

administrator guide. 

 Open User name's Guide. Provides access to 
the user name guide. 

 About DataTransfer. Provides information 
about Perceptive DataTransfer. 

 Licensing. Provides licensing information 

Jobs button Contains the following options. 

 Add Job. Allows you to add jobs. 

 Recurring Jobs. Allows you to add recurring 
jobs. 

Refer to Configuring jobs and processing records. 

Tools Coin tans the following options. 

 Lookup. Allows you to configure the lookup tool 

 Check Names. Allows you to configure the 
check names tool. Data Exports. Allows you to 
configure data exports. 

 Logs. Allows you to view log messages about 
jobs. 

 Import History. Allows you to view details about 
workspace imports. 

Refer to Using Perceptive DataTransfer Tools. 
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Sorting columns 

For Perceptive DataTransfer dialog boxes or windows that contain tables of information, you can choose 
the columns of information you want to view or hide, sort information alphabetically, and resize the width 
of columns. 

To select the columns that are displayed and to sort columns, complete the following steps.  

1. In the dialog box, point your mouse to the edge of a column and click    . 

5. Click Sort Ascending to sort information alphabetically in a high to low sequence (A to Z). 

6. Click Sort Descending to sort information alphabetically in a low to high sequence (Z to A). 

7. Click Columns. 

8. Check the checkbox for the column you want to display.  

Resizing columns 

To resize the width of a column, point your mouse over the edge of a column until the mouse pointer 

changes to  ; then, drag and drop your mouse to the desired location to resize the column. 

Expanding Panes 

You can collapse and expand some panes. For panes on the right side of the application, click    to 

collapse the pane and click    to expand a collapsed pane; for panes on the left side of the application 

window, click    to collapse the pane and click    to expand the pane.  

Refreshing information 

To refresh information in dialog boxes and application windows, click    . 

Changing roles 

To change roles, perform one of the following actions.  

 If you are using the desktop version of DataTransfer, from the Role drop-down box, select the 

Perceptive DataTransfer role you want to use. 

 If you are using the mobile version of DataTransfer, select Settings > Role, and then select the role 

you want to use.  

Changing Workspace version 

To change workspace versions, perform one of the following actions. 

 If you are using the desktop version of DataTransfer, from the Workspace drop-down box, select the 

version you want to use. 

When you hover your mouse over a version in the drop-down box, a tooltip appears and displays the 
version description for the version. 
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 If you are using the mobile version of DataTransfer, select Settings > Version, and then select the 

version you want to use. 

Specifying Preferences 

To specify preferences, perform one of the following actions.  

 Click Preferences > Set Default Role to set the current user’s role as the default role. When you log 

in to Perceptive DataTransfer, you are logged in using this user role. 

 Click Preferences > Set Default Version to set the workspace version of the current user as the 

default version. When you log in to Perceptive DataTransfer, you are logged in using this workspace 
version.  

 Click Preferences > Record Grid Dimensions to specify the number of rows and columns per page 

to display for records when you open a job. 

 The Record Grid Dimensions dialog box appears. In the Columns Per Page field, type the number 
of columns to display; in the Rows Per Page field, type the number of rows to display. The default 

value for each field is 20. The minimum value you can use is 10, and the maximum is 100. 

 Click Preferences > Filename in Job Name to append the filename of the input file to the name of a 

job when you add jobs. For more information about jobs, refer to Configuring jobs and processing 
records. 

 Click Display All Match Results so that when you run jobs in interactive mode, all possible record 

matches are compiled before the application pauses to allow you to review the possible matches. 

 Typically, for jobs running in interactive mode, each match routine in the associated procedures 
contains a STOP command that pauses job processing, allowing the user to examine the list of 
possible matches for that match routine. When you set this preference, the STOP command is 
skipped, and each match routine will run, adding matches to the list of possible matches. If a match 
routine finds a possible match that is already in the match list, the routine skips the match; the final 
match list does not contain any duplicates. 

 In addition, the match results also have an associated rank that is displayed in the results panel, in 
the # column. The rank is set by the STORE command in each match routine and indicates which 
match routine found the match. The result list is ordered by ranking—the order in which the match 
routine discovers the matches. 

 Click Verify Before Running Job to confirm that you want to run a job. When this option is enabled, 

when you click Run, the Confirm Run dialog box appears and prompts you to confirm that you want to 
run the job. 

 Click Skip Previous Results so that the same possible match record is not displayed twice. For 

example, when you start processing a record, you receive a list of possible matches, one of which is 
John Doe. If none of the matches is correct, you click the Get More Results button and receive the 

next possible set of matches. However, if the next set of matches contains John Doe again, 
Perceptive DataTransfer does not display John Doe as a possible match.  

Understanding User Roles and Privileges  

Your user role and privileges determine what you can do with Perceptive DataTransfer. 

The workspace version in which you are working and whether workspaces are shared determine what 
you can do. For example, you cannot configure objects, such as data exports, if you are working in a 
workspace version in staged or active mode.  
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Your administrator configures your role and privileges. 

User privileges determine if you can perform the following actions. 

 Configure the lookup tool. 

 Configure the check name tool. 

 View data exports. 

 Modify data exports. 

 Run data exports. 

 Export lookups, check names, data exports, log messages, and reports. 

 Import workspace versions. 

 Run reports. 

 Modify reports. 

 Modify scheduled reports. 

 View report output. 

 Delete report output. 

 Work within a workspace version. 

 Work within a version in edit mode. 

 Work within a version in test mode. 

 Work within a version in staged mode. 

 Work within a version in active mode. 

 Work within a version in inactive mode. 

 Configure jobs. 

 Create new and recurring jobs. 

 Modify recurring jobs. 

 Enable logging of job messages. 

 Enable job hold status. 

 View archive rules for jobs. 

 Create new records. 

 Create matched records. 

 Suspend records. 

 Create notification groups. 

 Modify notification groups. 

 Work within a specific workspace and with specific workspace objects. 

 Configure file sources. 
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Viewing server logs 

You can view a list of server log messages, view the contents of each message, and download messages 
in either.zip or native format. 

1. Select Administration > Server Logs. 

A dialog box appears and displays the following columns of information. 

 File Name: Name of the server log file. 

 Size: Size, in Kb, of the log file. 

 Last Modified: Date and time on which the file was last modified. 

2. To view the contents of a file, select the file you want to view. To select multiple files: 

 Click a file and press and hold the Ctrl key as you click each file with your mouse. 

 Click a file and press and hold the Shift key as you click another file to select contiguous files. 

Either right-click the file you want to view and select View or select the file and click    . The 
contents of each file opens in a separate tab. 

3. To download the file in ZIP format, select the file you want to download. To select multiple files:  

 Click a file and press and hold the Ctrl key as you click each file with your mouse. 

 Click a file and press and hold the Shift key as you click another file to select contiguous files.  

Right-click the file and select Download as Zip or select the file and click    ; then, select the 

location where you want to save the file. When you download multiple files, one ZIP file is created 
that contains all the log files you selected. 

4. To download the file in the application format in which it was authored, select the file you want to 
download. To select multiple files: 

 Click a file and press and hold the Ctrl key as you click each file with your mouse. 

 Click a file and press and hold the Shift key as you click another file to select contiguous files. 

Right-click the file and select Download Native or select the file and click    , then, select the 

location where you want to save the file.  

5. To refresh the table of log files, either right-click the table and select Refresh or click    .  

Configure PDF to TIFF Properties 

You can configure the properties to use when you use the ImageNowAddDoc or NWAddDoc functions to 
convert a PDF file to a TIFF file. For more information about these functions, refer to Understanding the 
ImageNowAddDoc function and Understanding the NWAddDoc function. 

To configure properties, complete the following steps.  

1. Select Administration > PDF to TIFF. 

The Configure PDF to TIFF Properties dialog box appears. 

2. In the TIFF DPI field, type the DPI value. Values range from 72 to 720; the default value is 240. 
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3. From the TIFF Color drop-down box, select the color properties. Options are: Full Color, Gray Scale, 
and Black & White. The default value is Full Color. 

4. From the Compression Type drop-down box, select the compression type. Options are: CCITT_RLE, 
CCITT_T_4, CCITT_T_6, PACKBITS, JPEG, and LZW. The default value is JPEG. 

5. You can click Reset to reset all values in the dialog box to use the default values. 

6. Click OK to save your changes and close the dialog box. 

Using Perceptive DataTransfer Tools 
Refer to the following topics for more information. 

 Configuring Lookup Values 

 Configuring Names to Check 

 Viewing Log Messages 

 Configuring Data Exports  

 Viewing the Import History  

Configuring Lookup Values 

Use the lookup tool to specify the data you want to map from the input file to the database.  

Your Perceptive DataTransfer administrator configures Perceptive DataTransfer to substitute the input 
value for the output value and store the output value in your database. 

For example, an input file may have a value of Humanities for a department; its corresponding database 
(output) value is HUM. You can use the lookup tool to map Humanities as HUM, and then your Perceptive 
DataTransfer administrator configures the code to store Humanities as HUM in your database. 

You can export lookups to an XML file, and you can import lookups from either a Perceptive DataTransfer 
XML file or a delimited file. 

To open the Lookup Administration dialog box, either select Tools > Lookup or click the Lookup button in 
the window that appears when you open or edit jobs. When you click the Lookup button, the Lookup 
Administration dialog box displays the lookup entries for the header that is being used for the job. 

You can filter the entries in the Lookup Administration dialog box by header, by field, or by both. Select 
the appropriate header from the Header drop-down box to view entries for that header. Select the 
appropriate field from the Field drop-down box to view entries for that field. 
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Adding Lookup Entries 

To add a lookup entry, complete the following steps.  

1. Select Tools > Lookup. 

2. In the Lookup Administration dialog box, click    . 

3. In the Add Lookup dialog box, from the Header drop-down box, optionally select the header for 

which to configure the lookup entry. Select No Header if you want to use this entry for all headers.  

 

4. From the Field drop-down box, select the header input variable to use or type the input variable in the 
Field field. This variable corresponds to the field in the input file that you want to map to a database 

valid code (output). 

5. In the In field, type the value of the input variable to map to the output value in the Out field. 

6. In the Out field, type the output value to map to the input value (specified in the In field). 

7. Click Apply. 

8. Click OK. 
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Modifying Lookup Entries 

To modify a lookup entry, complete the following steps.  

1. Select Tools > Lookup. 

2. In the Lookup Administrator dialog box, select a lookup entry to modify and either right-click it and 

select Edit or click    . 

3. In the Edit Lookup dialog box, in the In field, type the input value, which is the value of the input 
variable to map to the database valid code in the Out field. 

4. In the Out field, type the database valid code to map to input value (specified in the In field). 

5. Click OK. 

Deleting Lookup Entries 

To delete a lookup entry, complete the following steps. 

1. Select Tools > Lookup. 

2. In the Lookup Administration dialog box, select a lookup entry to modify and either right-click it and 

select Delete or click    .  

Importing Lookup Files 

Note:  You cannot import lookup files in tablet view. 

To import lookup entries from a either a Perceptive DataTransfer file or a delimited file, complete the 
following steps. 

1. Select Tools > Lookup. 

2. In the Lookup Administration dialog box, click    . 

3. In the Import Lookups dialog box, to import a delimited file, complete the following substeps.  

 

1. Click the Delimited tab. 

2. From the Header drop-down box, select the header file to use. 

3. From the Field drop-down box, select the header input field or type a new field to create it. This 

variable corresponds to the field in the input file that you want to map to a database valid code 
(output). 
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4. Specify how the imported file is delimited; either click the Tab radio button or click the Specify 

radio button and then provide a value in the Specify field. 

5. In the Upload File field, click Browse and navigate to the file you want to import. 

6. Click Upload. 

4. To import a Perceptive DataTransfer file, click the Transfer File tab. Then, in the File field, click 
Browse, navigate to the file you want to import, and select it. 

5. Click OK.  

The file is imported and imported lookup values display in the Lookup Administration dialog box.  

Exporting Lookup Files 

To export lookups as an XML file, complete the following steps.  

1. Select Tools > Lookup. 

2. In the Lookup Administration dialog box, click    . 

3. Save the file in the appropriate location. 

Configuring Names to Check 

You can use the Check Name tool to configure different output values that an input name may have.  

For example, for an input name Alexandria, you could use Alex or Lexie as substitutions. 

You can import check name values from and export value to an XML file.  

 To open the Check Name Administration dialog box, select Tools > Check Names.  

Refer to the following topics for more information. 

 Adding and Modifying Names 

 Deleting Names 

 Importing Names 

 Exporting Names 

Adding and Modifying Names 

To add or modify a name, complete the following steps. 

1. Select Tools > Check Names. 

2. In the Check Name Administration dialog box, perform one of the following actions.  

 To add a new name, click    to display the Add New Check Name dialog box. 

 To modify a name, select the name and click    to display the Edit Check Name dialog box.  

3. To add a new value to the name, complete the following substeps.  

1. Click    to display the New Check Name Value dialog box. 

2. In the Value field, type the value that the name can have. 
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Note:  You cannot add a value that is already configured for another entry. You can only use a 

value once.  

3. Click Apply to add the value to the check name entry. 

4. Continue adding values for the name, and then click OK. 

4. To modify a value, complete the following substeps. 

1. Select the value you want to modify and either right-click it and select Edit or click . 

2. In the Edit dialog box, type the value in the dialog box and click OK. 

5. To delete a value, select the value you want to delete and either right-click it or select Delete or click  

  .The value is deleted and is removed from the dialog box.  

Deleting Names 

To delete a name, complete the following steps. 

1. Select Tools > Check Names. 

2. In the Check Name Administration dialog box, select the value you want to delete and either right-

click it and select Delete or click    . 

3. Click Yes to confirm that you want to delete the name. 

The name is deleted, and all its associated values are deleted; the name is removed from  the Check 
Name Administration dialog box.  

Importing Names 

Note:  You cannot import names in tablet view. 

To import names from an XML file, complete the following steps. 

1. Select Tools > Check Names. 

2. In the Check Name Administration dialog box, click    and select Import. 

3. In the Import Check Names dialog box, click Browse and navigate to the file you want to import.  

4. Click OK.  

Exporting Names 

Note:  You cannot export names in table view. 

To export names to an XML file, complete the following steps. 

1. Select Tools > Check Names. 

2. In the Check Name Administration dialog box, click    and select Export. 

3. Save the XML file in the appropriate location.  

Viewing Log Messages 

You can view log messages that provide information about Perceptive DataTransfer jobs.  

1. Perform one of the following actions. 
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 In the Job Dashboard, select a job and click the Log button. 

 In the Job Dashboard, right-click a job and select Log. 

 In the Job Dashboard, select a job in the table and either right-click it and select Open or click the 
Open button, then, in the window that displays, click Log. 

 Select Tools > Logs to display the Log View dialog box, which displays the following columns of 

information.  

  Job Name. Name of the job 

 Type. Type of  log message (error, SQL). To log SQL messages, check the Log SQL check 
box in the Add Job dialog box for the appropriate job. Refer to Adding new jobs.  

 Message. Body of the log message. 

 User. Username of the user name who was logged in. 

 Date/Time. Date and time on which the message was logged. 

2. To filter messages by job, select the job from the Job drop-down box. 

3. To filter messages by type, select the type of log message from the Type drop-down box. 

4. To export messages in XML format, click    and then save the file in the appropriate location. 

5. To view the suspend reason for suspended records, click the log record that indicates that a record 

status changed to Suspended and click    to open the Detailed Log View dialog box, which 

displays the suspend reason.  

Configuring Data Exports 

You can use data exports to create SQL queries to obtain content from any database configured for 
Perceptive DataTransfer. You can save the results and export them to a delimited file.  

You can share data exports with other workspaces, and you can import data exports from and export data 
exports to an XML file.  

Refer to the following topics for more information. 

 Understanding Data Export Icons  

 Adding Data Exports 

 Configuring and Modifying Data Exports 

 Copying Data Exports 

 Deleting Data Exports 

 Running Data Exports 

 Extracting Data Exports 

 Removing Sharing on Shared Data Exports 

 Rolling Back Data Exports 

 Importing Data Exports 

 Exporting Data Exports 

 Configuring Schedules Data Export Rules 
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Understanding Data Export Icons 

The following table describes data export icons and their descriptions.  

Icon Description 

 
Data export is shared 

 
Data export is shared and has been modified. 

 Data export is not shared and has been modified. 

 Data export has not been modified. 

If you are working in a workspace version in edit mode, the data export is not shared. If you are 
working in a workspace version in a mode other than edit mode, this icon is displayed for all data 
exports. The sharing status is unknown.  

Adding Data Exports 

To add and configure a data export, complete the following steps.  

1. Select Tools > Data Exports > Configure.  

2. In the Data Exports Administrator dialog box click    . 

3. In the Add Data Export dialog box, perform one of the following actions.  

 To add a new data export, complete the following steps.  

1. Click the Add Data Export tab. 

2. Type a name in the Name field and click OK. 

 To add a data export that is shared by anotehr workspace, complete the following steps.  

1. Click the Add Shared Data Export tab. 

2. From the Workspace drop-down box, select the workspace that share the data export you 

want to add.  

3. From the Data Export drop-down box, select the shared daata export that you want to add. 

4. Cick OK. 

The data export is added and appears in the Data Export Administration dialog box., 

Configuring and Modifying Data Exports 

1. Select Tools > Data Exports > Configure. 

2. In the Data Exports Administrator dialog box, either right-click the data export you want to configure 

and select Edit or click    . 

3. In the Edit Data Export dialog box, to rename the data export, type the name in the Name field.  

4. From the Connection Group drop-down box, select the connection group to use. 

5. From the Connection drop-down box, select the database connection to use. 
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6. In the Data Extract SQL field, type the appropriate SQL code for data extract. 

7. Define the format of the delimited file that contains the data returned by the query. Click the Tab radio 
button to specify that the file is tab-delimited, or click the Specify tab to provide your won value and 

then type the value in the corresponding field. 

8. Check the Include Date and Time check box to include the date and time in the name of the data 

export file. 

9. Click OK.  

Copying Data Exports 

To create a duplicate of a data export, complete the following steps.  

1. Select Tools > Data Exports > Configure. 

2. In the Data Exports Administrator dialog box, select the data export you want to copy and click    

. 

The data export is duplicated, and its copy appears in the Data Export Administration dialog box.  

Deleting Data Exports 

To delete a data export, complete the following steps. 

1. Select Tools > Data Exports > Configure. 

2. In the Data Exports Administrator dialog box, select the data export you want to delete and either 

right-click it and select Delete or click    . 

The data export is deleted and is removed from the Data Export Administration dialog box.  

Running Data Exports 

To run query and view the data returned from the database, complete the following steps. 

1. Select Tools > Data Exports > Configure. 

2. In the Data Exports Administrator dialog box, select the data export you want to run. 

3.  Click    . 

4. Click    .  

5. One of the following actions occurs. 

 If there are issues with the SQL code, a dialog box appears and displays information about the 
problem. 

 If there are no issues with the SQL code, results of the data export display in the Results pane.  

Extracting Data Exports 

You can run the query you created and export the data returned to a file-delimited format you specified in 
the Edit Data Export dialog box. Refer to Configuring and Modifying Data Exports. 

Note:  You cannot extract data exports in table view. 

1. Select Tools > Data Exports > Configure. 
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2. In the Data Exports Administrator dialog box, select the data export you want to extract and either 

right-click it and select Extract or click    . 

3. In the Extract Data Export dialog box, from the Connection Group drop-down box, select the 

connection group you want to use. 

4. From the Connection drop-down box, select the connection you want to use. 

5. Click OK. 

6. Save the file with the extracted data in the appropriate location.  

Removing Sharing on Shared Data Exports 

To remove sharing on data exports that are shared with another workspace, complete the following steps. 

1. Select Tools > Data Exports > Configure. 

2. In the Data Exports Administrator dialog box, select the data export for which you want to remove 

sharing and click    . 

Sharing is removed on the data export.  

Rolling Back Data Exports 

If changes have been made and committed to a data export, you can use a previous version (roll back) of 
it. 

1. Select Tools > Data Exports > Configure. 

2. In the Data Exports Administrator dialog box, select the data export you want to roll back and either 

right-click it and select Rollback or click   . 

The Rollback Manager dialog box appears and provides the following information. 

 Name. Name of the data export. 

 Status. Status of the data export (current or dated). 

 Version Date. Date and time on which the version was created.  

 Created By. Username of the user name who created the version. 

 Comments. Comments, if any, added by the user name for the version. 

3. Select the version that you want to use and click OK. 

The previous version is loaded.  

Importing Data Exports 

Note:  You cannot import data exports in tablet view. 

To import a data export, complete the following steps. 

1. Select Tools > Data Exports > Configure. 

2. In the Data Exports Administrator dialog box, select    and select Import. 
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3. In the Import Data Export dialog box, click Browse to navigate to the location of the file you want to 

import, and then select it. 

4. Check the Update Existing Entities check box to update an existing data export, with the same 

name as the data export you are importing, with the data export you are importing.  

If you do not check this check box, and there is an existing data export with the same name as the 
data export you are importing, DUPLIACTE- is appended to the start of the name of the data export 
you are importing; the existing data export is not updated. If a data export exists with the name 
DUPLICATE-<data_export_name>, DUPLICATE(2)- is appended to the start of the name. The 
number continues to be incremented so that all data exports have unique names.  

5. Click OK.  

The date export is imported and displays in the Data Export Administration dialog box.  

Exporting Data Exports 

Note:  You cannot export data exports in table view. 

To export a data export as an XML file, complete the following steps. 

1. Select Tools > Data Exports > Configure. 

2. In the Data Exports Administrator dialog box, click    and select Export. 

3. Save the file in the appropriate location.  

Configuring Scheduled Data Export Rules 

You can configure Perceptive DataTransfer to run data exports at specified times. You can also view the 
output of past data exports. 

Refer to the following topics for information. 

 Adding and Modifying Scheduled Data Exports 

 Deleting Scheduled Data Exports 

 Viewing the Previous Output of Data Exports 

Adding and Modifying Scheduled Data Exports  

To add or modify a scheduled data export rule, complete the following steps. 

1. Select Tools > Data Exports > Schedule. 

2. In the Schedule Data Exports dialog box, perform one of the following actions.  

 To add a new schedule data export rule, click    to display the Add Scheduled Data Export 

dialog box. 

 To modify a scheduled data export rule, select the data export and either right-click it and select 

Edit Scheduled Data Export or click    to display the Edit Scheduled Data Export dialog box.  

3. In the Name field, type the name of the scheduled data export rule. 

4. In the Status field, click the Enable radio button to enable the rule; click Disable to disable it. 

5. From the Data Export drop-down box, select the data export to which to assign the rule. 
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6. Form the Connection drop-down box, select the connection used for the connection group. 

7. From the Start Time drop-down box, select the connection used for the connection group. 

8. From the Start Time drop-down box, select the time on which the report is run. 

9. In the Options pane, click the Run in Edit Version check box to run the rule against the edit version 

of the workspace (the rule is run against the edit version of the data export and connection). If you do  
not select this check box, the rule is run against the active version of the workspace.   

10. In the Recurrent Pattern pane, specify when the report recurs. 

 Click the Once radio button to run the data export once. After the data export is run, rules for 

running the data export are disabled. 

 Click the Daily radio button to specify that the data export is run daily, and then specify the 

recurrence frequency.  

 Click the Weekly radio button to specify that the data export is urn weekly, and then specify the 

recurrence frequency. 

 Click the Monthly radio button to specify that the data export is run monthly, and then specify the 

recurrence frequency.  

11. Click the Notification tab to configure notifications to be sent to recipients when certain data export 

actions occur. Refer to Configuring Notifications.  

12. Click OK.  

Deleting Scheduled Data Exports 

To delete a scheduled data export rule, complete the following steps. 

1. Select Tools > Data Exports > Schedule. 

2. In the Schedule Data Exports dialog box, select the rule you want to delete and either right-click it 

and select Delete or click    . 

3. In the dialog box that displays, click Yes to confirm that you want to delete the rule. 

 Rule is deleted and is removed from the Schedule Data Exports dialog box.  

Viewing the Previous Output of Data Exports 

To view the previous output of the scheduled data export, perform one of the following actions.  

Note:  You cannot view data export output in table view.  

 Select Tools > Data Exports > View. 

 Select Tools > Data Exports > Schedule. 

The Schedule Data Exports dialog box displays. Next, select the data export for which you want to view 

previous results and click    .  

The View Data Exports dialog box appears and displays a table with the following information. 

 Date. Date on which the date export was created. 

 Name. Name of the data export. 

 Date Export Rule Name. Name of the rule that caused the scheduled report to be run. 
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 Created By. Username of the administrator who configured the date export.  

You can filter the information in the View Data Exports dialog box by selecting the appropriate 

information in one or more of the following fields. 

 Date Export Rule. Select the data export rule for which to filter results. 

 Data Exports. Select the data export for which to filter results. Select All to specify all date exports. 

 Data Range fields. Click the    icon to open a calendar from which you can specify the start and 

end dates of a date range. You can choose both start and end dates or only a start or end date. 

After specifying the filter information, click the Filter button to update the table with the selected criteria.  

To view a data export, click    . The data export opens in a new tabl or browser window in PDF format. 

To permanently delete the date export and record the data export instance, click    . 

Viewing the Import History 

To view the import history, complete the following steps.   

1. Select Tools > Import History. 

2. In the Import History dialog box, update the following information.  

 Name. Name of the object imported into Perceptive DataTransfer (for example, Workspace or 

Data Export).  

 Type. Type of import (Full Import or Partial Import). 

 Data Created. Date and time on which object was imported.  

 Created By. Username of the user name who imported the object. 

3. To view details about the Perceptive DataTransfer objects that were imported, select the entry in the 

table and either right-click it and select Import Details or click    . 

The Import Report dialog box appears and displays information about the objects imported into 
Perceptive DataTransfer.  

Configuring Reports 
You can write custom XML reports, which are based on JasperReports and are presented in PDF format. 
For more information about JasperReports, refer to http://en.wikipedia.org/wiki/JasperReports. 

Note:  Reports only run against the Perceptive DataTransfer database.  

Refer to the following topics for more information.  

 Configuring Reports 

 Configuring Scheduled Reports 

Configuring Reports 

In Reports > Configure, you can add, modify, and delete reports; you can also import and export reports. 
Refer to the following topics for more information.  

http://en.wikipedia.org/wiki/JasperReports
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 Adding and Modifying Reports 

 Deleting Reports 

 Importing Reports 

 Exporting Reports 

Adding and Modifying Reports 

You can create reports in JasperReports format. 

1. Select Reports > Configure. 

2. In the Configure Reports dialog box, perform one of the following actions.  

 To add a new report, click    to display the Add Report dialog box. 

 To modify a report, select the report and either right-click it and select Edit Report or click    
to display the Edit Report dialog box. 

3. In the Report Name field, type the name of the report.  

4. In the XML field, type the XML code that generates the report.  

5. To add report parameters, complete the following substeps.  

1. In the Report Parameters pane, click    to display the New Report Parameter dialog box. 

2. In the New Report Parameter, from the Parameter dialog box, select the type of parameter you 

want to add. The Options are;  

 Header 

 Job 

 Start Date 

 End Date 

 User name 

3. Click Apply. 

4. Continue adding parameters, as appropriate, and click OK when you are finished. 

5. To delete a parameter, select the parameter in the Report Parameters pane and click    . 

6. Click OK to save your changes and close the dialog box. 

Deleting Reports 

To delete a report, complete the following steps. 

1. Select Reports > Configure. 

2. In the Configure Reports dialog box, select the report you want to delete and either right-click it and 

select Delete Report or click    . 

3. In the dialog box that displays, click Yes to confirm that you want to delete the report.   

The report is deleted and is removed from the Configure Reports dialog box.  
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Importing Reports 

To import reports from an XML file, complete the following steps.  

1. Select Reports > Configure. 

2. In the Configure Reports dialog box, click    and select Import.  

3. In the Import Report dialog box, click Browse, navigate to the location of the file, and select it. 

4. Click OK. 

This file is imported, and the imported reports display in the Configure Reports dialog box. 

Exporting Reports 

To export reports to an XML file, complete the following steps. 

1. Select Reports > Configure. 

2. In the Configure Reports dialog box, select the report you want to export. 

3. Click    and select Export.  

Save the XML file in the appropriate location. 

Configuring Scheduled Reports 

In Report > Schedule, you can add and delete reports that are scheduled to run at specified times, and 

you can modify the schedule for these reports. You can also view reports by clicking  (refer to 
Configuring Scheduled Reports for more information.  

Refer to the following topics for more information. 

 Adding and Modifying Scheduled Reports 

 Deleting Scheduled Reports 

Adding and Modifying Scheduled Reports 

To add or modify a scheduled report, complete the following steps. 

1. Select Reports > Schedule. 

2. In the Schedule Reports dialog box, perform one of the following actions. 

 To add a new report click    to display the Add Scheduled Report dialog box. 

 To modify a report, select the report and either right-click it and select Edit Report or click    
to display the Edit Scheduled Report. 

3. Click the Details tab. 

4. In the Parameters pane, provide the appropriate parameters. Options depend on the parameters 

available for the report. Possible operations are: 

 Start Date field. Click    to open a calendar from which you select the start date of the report. 
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 End Date field. Click    to open a calendar from which you select the end date of the report. 

 Job field. Type the name of the job for the report. 

 Header drop-down box. Select the header used for the job. 

 User drop-down box. Select the user running the job.  

5. From the Start Time drop-down box, select the time on which the report is run. 

6. In the Recurrence Pattern pane, specify when the report recurs. 

 Click the Once radio button to run the report once. After the report is run, rules for running the job 

are disabled. 

 Click the Daily radio button to specify that the report is run daily, and then specify the recurrence 

frequency. 

 Click the Weekly radio button to specify that the report is run weekly, and then specify the 

recurrence frequency. 

 Click the Monthly radio button to specify that the report is run monthly, and then specify the 

recurrence frequency.  

7. Click the Notifications tab to configure notifications to be sent to recipients when certain reports 

actions occur. Refer to Configuring Notifications. 

8. Click OK. 

Deleting Scheduled Reports 

To delete a scheduled report, complete the following steps. 

1. Select Reports > Schedule. 

2. In the Schedule Report dialog box, select the scheduled report you want to delete and click    . 

The scheduled report is deleted and is removed from the Schedule Report dialog box.  

Viewing Reports 

You can view reports in the View Reports dialog box. 

Note:  You cannot view reports in tablet view. 

If you open the dialog box from Reports > View, the search filters display the current date for all report 

rules and reports. If you open it from the Schedule Reports dialog box, the filters display the selected 
report rule. 

These reports, in PDF format, are stored physically on the Perceptive DataTransfer server. You must 
specify the root directory of the location where the reports are stored. To do so, in the 
datatransfer.properties file, you must supply a report_root parameter. For example: 

report_root=c:/reports 

The PDF files are then stored in the appropriate subdirectories within that root directory. 

To view a report, complete the following steps. 

1. Perform one of the following actions. 

 Select Reports > View. 
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 Select Reports > Schedule and click    .  

The dialog box displays a table with the following information. 

 Date. Date on which the report was created. 

 Name. Name of the report. 

 Report Rule Name. Name of the rule that caused the scheduled report to be run.  

 Created By. Username of the administrator who configured the report.  

2. You can filter the information in the View Reports dialog box by selecting the appropriate information 
in one or more of the following fields. 

 Report Rule. Select the report rule for which to filter results. 

 Reports. Select the report for which to filter results. Select All to specify all reports. 

 Date Range fields. Click the    icon to open a calendar from which you can specify the start 

and end dates of a date range. You can choose both start and end dates or only a start or end 
date. 

3. After specifying the filter information, click the Filter button to update the table with the selected 

criteria.  

4. To view a report, click    . The report opens in a new tab or browser window in PDF format. 

5. To delete the report PDF file and the record of the report instance permanently, click    . Reports 
are removed from the location specified in the report_root parameter in the datatransfer.properties 

file.  

Configuring Notifications 
You can configure Perceptive DataTransfer to send notifications to users when various activities occur in 
Perceptive DataTransfer. You can configure notifications for jobs, scheduled reports, and version 
milestones.  

Refer to the following topics for more information.  

 Configuring Email Addresses 

 Configuring Notification Groups 

 Configuring Job Notifications 

 Configuring Report Notifications 

Configuring Email Addresses 

You must have the appropriate permissions to configure the SMTP server form which notifications can be 
sent, and you must also have the appropriate permissions to configure email addresses for users to 
which these notifications are sent. 

Refer to Configuring Users and Privileges. 

To configure system email addresses, complete the following steps.  

1. Select Administration > System Properties > System E-Mail.  
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2. In the Configure System Email dialog box, in the Email address field, type the email address used 

that sends the system notifications. 

3. In the Host field, type the hostname of the SMTP server that sends the emails. 

4. In the Port field, type the port number of the SMTP server. 

5. In the Username field, type the username of the SMTP server. 

6. In the Password field, type the password of the SMTP server. 

7. Click OK. 

8. You can assign email addresses to Perceptive DataTransfer users; these are the emails addresses at 
which users receive emails sent from the SMTP server. To do so, complete the following substeps. 

Note The name and email address is updated for all users in the system with this username. For 

example, if user GUEST has multiple roles and therefore multiple instances in the system, the name and 
email address you configure for one instance of GUEST is used for all instances of that user. 

1. Select Administration > User. 

2. In the User Administration dialog box, in the Navigation pane, click the user for which you 

want to configure email settings. 

3. In the Name field, type the name of the user for the email address. 

4. In the Email field, type the name of the email address for the user. 

5. Click Save. 

Configuring Notif ication Groups 

You can configure notifications for a variety of functions. You can configure notification groups, which 
contain lists of email recipients (similar to an email distribution list), to which to send these notifications. 

You must have the appropriate permissions to add and modify notification groups. Refer to the following 
topics for more information. 

 Adding and Modifying Notification Groups 

 Deleting Notification Groups 

Adding and Modifying Notification Groups 

To add a notification group, do the following. 

1. Select Configuration > Notifications. 

2. In the Notification Group Configuration dialog box, complete one of the following options. . 

 To add a new notification group, click    to display the Add Notification Group dialog box 

displays.  

 To modify a group, select it and click    . 

3. In the Name field, type the name of the notification group. 

4. In the To field, provide the email addresses of the recipients of the notifications. Perform one of the 

following options. 

 Manually type the email addresses in the field, separating recipients by commas. 
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 Click the To button to open the Select Users dialog box. Select one or more recipients and click 
OK. 

5. In the CC field, provide the email addresses of the recipients to which to send copies of the notifications. 

Perform one of the following options. 

 Manually type the email addresses in the field, separating recipients by commas. 

 Click the CC button to open the Select Users dialog box. Select one or more recipients and click 
OK. 

Deleting Notification Groups 

To delete a notification group, do the following. 

1. Select Configuration > Notifications. 

2. Select the group you want to delete and click    . 

Configuring Job Notif ications 

You can configure notifications to be sent when a job activity occurs. Refer to the following topics for 
more information. 

 Adding and Modifying Job Notifications  

 Deleting Job Notifications 

Adding and Modifying Job Notifications 

To add a job notification, do the following. 

1. In the Job Dashboard, perform one of the following options. 

 Select Jobs > Add Jobs to display the Add Job dialog box. . 

 Select Jobs > Recurring Jobs. 

2. In the Recurring Job Administration dialog box, click the Notifications tab. 

3. Perform one of the following options. 

 To add a new notification, click     to display the Add Job Notification dialog box. 

 To modify a notification, select it and click    . The Edit Job Notification dialog box displays. 

4. From the Action drop-down box, select the job action that occurs for which a notification is sent. 

Options are Complete or Processed. 

When a job attains Processed or Complete status, the appropriate notifications are sent to the 
provided email addresses. 

5. Select the recipients to which to send the notifications. You can either select a configured notification 
group (refer to Configuring Notification Groups), or you can specify recipients not in a group. 

 To select a notification group, select the appropriate group from the drop-down box. The To and 
CC fields automatically display the recipients configured for the notification group, and you 

cannot modify these fields. 

 To specify recipients not in a group, do the following. 
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1. In the To field, provide the email addresses of the recipients of the notifications. Perform one of 

the following options. 

 Manually type the email addresses in the field, separating recipients by commas. 

 Click the To button to open the Select Users dialog box. Select one or more recipients 
and click OK. 

2. In the CC field, provide the email addresses of the recipients to which to send copies of the 

notifications. Perform one of the following options. 

 Manually type the email addresses in the field, separating recipients by commas. 

 Click the CC button to open the Select Users dialog box. Select one or more recipients 
and click OK. 

6. Click OK. 

Deleting Job Notifications 

To delete a job notification, do the following. 

1. Select Jobs > Add Jobs. 

2. In the Add Job dialog box, click the Notifications tab. 

3. Select the notification you want to delete and click    . 

Configuring Report Notif ications 

You can configure report notifications when certain report activities occur. 

Refer to the following topics for more information.  

 Adding and Modifying Report Notifications 

 Deleting Report Notifications 

Adding and Modifying Report Notifications 

1. Select Reports > Schedule. 

2. In the Schedule Reports dialog box, perform one of the following options. 

 To add a new report, click    to display the Add Scheduled Report dialog box. 

 To modify a report, select the report and either right-click it and select Edit Report or click   to 
display the Edit Scheduled Report dialog box. 

3. Click the Notifications tab and perform one of the following options. 

 To add a new notification, click    to display the Add Report Notification dialog box. 

 To modify a notification, select it and click    to display the Edit Report Notification dialog 

box. 

4. From the Action drop-down box, select the report action that occurs for which a notification is sent. 
The Option is Complete. 

When a report is Complete, a notification is sent to the specified recipients, and a PDF version of the 

report is included as an attachment in the email. 
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5. Select the recipients to which to send the notifications. You can either select a configured notification 
group (refer to Configuring Notification Groups), or you can specify recipients not in a group. 

 To select a notification group, select the appropriate group from the drop-down box. The To and 
CC fields automatically display the recipients configured for the notification group, and you cannot 

modify these fields. 

 To specify recipients not in a group, perform one of the following actions.  

1. In the To field, provide the email addresses of the recipients of the notifications. Perform one 

of the following actions.  

 Manually type the email addresses in the field, separating recipients by commas. 

 Click the To button to open the Select Users dialog box. Select one or more recipients 
and click OK.  

2. In the CC field, provide the email addresses of the recipients to which to send copies of the 

notifications. Perform one of the following actions 

 Manually type the email addresses in the field, separating recipients by commas. 

 Click the CC button to open the Select Users dialog box. Select one or more recipients 
and click OK. 

9. Click OK. 

Deleting Scheduled Reports 

To delete a scheduled report, complete the following steps. 

1. Select Reports > Schedule. 

2. In the Schedule Report dialog box, select the scheduled report you want to delete and click    . 

The scheduled report is deleted and is removed from the Schedule Report dialog box.  

Configuring Users and Privileges 
When you configure Perceptive DataTransfer users, you define the structure of the institution and 
configure privileges for users to enable or disable the features they can use. 

Configuring Institutions 

Refer to the following topics for more information. 

 Configuring Organizations 

 Configuring Divisions 

 Configuring Departments 

 Configuring Roles 

 Configuring Users 

Configuring Organizations 

Refer to these topics for more information: 
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 Adding Organizations 

 Renaming Organizations 

 Deleting Organizations 

Adding Organizations 

To add an organization, complete the following steps. 

1. Select Administration > User. 

2. In the User Administration dialog box, in the Navigation pane, perform one of the following options. 

 In the desktop view, right-click Enterprise Hierarchy and select Add Organization from the 

popup menu. 

 In the tablet view, click    . 

3. In the Add Organization dialog box, type the name of the organization. 

4. Click OK. The organization is created and appears in the Navigation > Enterprise Hierarchy. 

5. Add a division under the organization. Refer to Adding Divisions for more information.  

Renaming Organizations 

To rename an organization, complete the following steps. 

1. Select Administration > User. 

2. In the User Administration dialog box, in the Navigation pane, perform one of the following options.  

 In desktop view, right-click the organization and select Rename Organization_Name from the 

popup menu.  

 In the tablet view, select the organization and click . 

3. In the Rename Node dialog box, type the name of the organization and click OK. 

Deleting Organizations 

Note You can delete only the lowest-level node in the hierarchy tree. For example, if you want to delete a 

department that has roles and users configured for it, you must first delete all users, and next all roles, 
before you can delete the department. 

To delete an organization, do the following. 

1. Select Administration > User. 

2. In the User Administration dialog box, in the Navigation pane, perform one of the following actions. 

 In desktop view, right-click the organization and select Delete Organization_Name from the 

popup menu. 

 In tablet view, select the organization and click    . 

A dialog box appears, prompting you to confirm that you want to delete the organization. 

3. Click Yes to delete the organization. 

The organization is deleted, and it is removed from the Navigation pane. 
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Configuring Divisions 

Refer to the following topic for more information. 

 Adding Divisions 

 Renaming Divisions 

 Deleting Divisions 

 

Adding Divisions 

To add a division, do the following. 

1. Select Administration > User. 

2. In the User Administration dialog box, in the Navigation pane, perform one of the following actions.  

 In desktop view, right-click the organization for which you want to add a division and select Add 
Division from the popup menu. 

 In tablet view, select the organization for which you want to add a division and click    . The 
Add Division dialog box appears. 

3. Type the name of the division (for example, Finance). 

4. Click OK. The division is created and appears in Navigation > Enterprise Hierarchy. 

5. Add a department under the division. Refer to Adding Departments for more information. 

Renaming Divisions 

To rename a division, complete the following steps. 

1. Select Administration > User. 

2. In the User Administration dialog box, in the Navigation pane, perform one of the following actions. 

 In the desktop view, right-click the division and select Rename Division_Name from the popup 

menu. 

 In tablet view, select the division and click    . The Rename Node dialog box appears. 

3. Type the name of the division. 

4. Click OK. The division is renamed. 

Deleting Divisions 

Note:  You can delete only the lowest-level node in the hierarchy tree. For example, if you want to delete 

a department that has roles and users configured for it, you must first delete all users, and next all roles, 
before you can delete the department.  

To delete a division, do the following. 

1. Select Administration > User. 

2. In the User Administration dialog box, in the Navigation pane, perform one of the following actions 

 In desktop view, right-click the division and select Delete Division_Name from the popup menu. 
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 In tablet view, click    .  

A dialog box appears, prompting you to confirm that you want to delete the division. 

3. Click Yes to delete the division. The division is deleted, and it is removed from the Navigation pane. 

Configuring Departments 

Refer to the following topics for more information.  

 Adding Departments 

 Renaming Departments 

 Deleting Departments 

Adding Departments 

To add a department, complete the following steps. 

1. Select Administration > User. 

2. In the User Administration dialog box, in the Navigation pane, perform one of the following actions. 

 In desktop view, right-click the division for which you want to add a department and select Add 
Department from the popup menu. 

 In tablet view, select the division for which you want to add a department and click    . 

3. Type the name of the department (for example, Accounts Payable). 

4. Click OK. The department is created and appears in the Navigation pane.  

5. You can configure department privileges, which specify the tasks that the department can perform. 
When you configure privileges at the department level, these privileges are also applied to the users 
and roles that belong to the department. For more information, refer to Configuring Privileges. 

6. Add a role under the department. Refer to Adding Roles for more information. 

 

Renaming Departments 

To rename  a department, complete the following steps.  

1. Select Administration > User. 

2. In the User Administration dialog box, in the Navigation pane, perform one of the following actions. 

 In desktop view, right-click the department and select Rename Department_Name from the 

popup menu. 

 In tablet view, select the department and click    .  

The Rename Node dialog box displays. 

3. Type the name of the department. 

4. Click OK. The department is renamed. 
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Deleting Departments 

Note You can delete only the lowest-level node in the hierarchy tree. For example, if you want to delete a 

department that has roles and users configured for it, you must first delete all users, and next all roles, 
before you can delete the department. 

To delete a department, complete the following steps.  

1. Select Administration > User. 

2. In the User Administration dialog box, in the Navigation pane, perform one of the following actions. 

 In desktop view, right-click the department and select Delete Department_Name from the 

popup menu. 

 In tablet view, select the department and click    . 

A dialog box appears, prompting you to confirm that you want to delete the department. 

3. Click Yes to delete the department. 

The department is deleted, and it is removed from the Navigation pane. 

Configuring Roles 

Refer to these topics for more information. 

 Adding Roles 

 Renaming Roles 

 Deleting Roles 

Adding Roles 

To add a role, complete the following steps. 

1. Select Administration > User. 

2. In the User Administration dialog box, in the Navigation pane, do one of the following. 

 In desktop view, right-click the department for which you want to add a role and select Add 
Department Role from the popup menu. 

 In tablet view, select the department for which you want to add a role and click    .  

The Add Department Roles dialog box appears. 

3. Type the name of the role (for example, Clerk). 

4. Click OK. The role is created and appears in Navigation > Enterprise Hierarchy. 

5. You can configure role privileges, which specify the tasks that the role can perform. When you 
configure privileges at the role level, these privileges are also applied to the users that belong to the 
role. For more information, refer to Configuring Privileges. 

Note You can assign permissions for a workspace and workspace permissions at the role level only. 

6. Add a user under the role. Refer to Adding Users for more information. 
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Renaming Roles 

To rename a role, complete the following steps.  

1. Select Administration > User. 

2. In the User Administration dialog box, in the Navigation pane, perform one of the following actions. 

 In the desktop view, right-click the role and select Rename Role_Name from the popup menu. 

 In tablet view, select the role and click  .  

The Rename Node dialog box appears. 

3. Type the name of the role. 

4. Click OK. 

The role is renamed. 

 

Deleting Roles 

Note:  You can delete only the lowest-level node in the hierarchy tree. For example, if you want to delete 

a department that has roles and users configured for it, you must first delete all users, and next all roles, 
before you can delete the department.  

To delete a role, complete the following steps.  

1. Select Administration > User. 

2. In the User Administration dialog box, in the Navigation pane, perform one of the following actions 

 In desktop view, right-click the role and select Delete Role_Name from the popup menu. 

 In tablet view, select the role and click    . 

A dialog box appears, prompting you to confirm that you want to delete the role. 

3. To delete the role, click Yes. 

The role is deleted and removed from Navigation > Enterprise Hierarchy. 

Configuring Users 

Refer to the following topics for more information. 

 Adding Users 

 Setting Default Roles 

 Deleting Users 

Adding Users 

To add a user, complete the following steps. 

1. Select Administration > User. 

2. In the User Administration dialog box, in the Navigation pane, perform one of the following actions. 
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 In desktop view, right-click the role for which you want to add a user and select Add User from 

the popup menu. 

 In tablet view, select the role for which you want to add a user and click   .  

The Add User dialog box appears. 

3. Type the name of the user. 

4. Click OK. The user is added and appears in Navigation > Enterprise Hierarchy. 

5. You can configure user privileges, which specify the tasks that the user can perform. For more 
information, refer to Configuring Privileges. 

Setting Default Roles 

You can set a user's role as the default role, if it is not already configured as the default role. Users are 
logging in to Perceptive DataTransfer with their default role. 

1. Select Administration > User. 

2. In the User Administration dialog box, in the Navigation pane, navigate to the user for which you 

want to set the default role and perform one of the following actions.  

 In the desktop view, right-click the role and select Set Default form the popup menu.  

 In tablet view, select the user and click . 

The user role is set as the default.  

Deleting Users 

To delete a user, complete the following steps.  

1. Select Administration > User.  

2. In the User Administration dialog box, in the Navigation pane, perform one of the following actions.  

 In desktop view, right-click the user and select Delete User_Name from the popup menu. 

 In tablet view, select the user and click . 

A dialog box appears, prompting you to confirm that you want to delete the user. 

3. To delete the user, click Yes.  

The user is deleted and removed from Navigation > Enterprise Hierarchy.  

Configuring Privileges 

You can configure privileges for a department, role, or user. When you configure privileges for a 
department, those privileges apply to the department and all the roles and users in the department. When 
you configure privileges for a role, those privileges apply to the role and to all users who belong to the 
role. 

Note  Privileges to use a workspace are configured at the role level. 

1. Select Administration > User. 

2. In the User Administration dialog box, in the Navigation pane, click the department, role, or user for 

which you want to configure privileges. 



 

 

Perceptive DataTransfer User Guide 

38 

3. In the Department Editor, Role Editor, or User Editor pane, configure the department privileges (if 

you selected a user, in the User Editor pane, click the Permissions tab). The following table provides 
descriptions of the privileges. 

Note  Click the arrow icon next to each privilege type to expand it and view the privileges. You can 

check the privilege type checkbox to select all privileges, or you can check the checkbox for each 
individual privilege to select it. 

 

Privilege Description 

Administrative  Privileges 

User Administration Administrator can modify user privileges and can configure email addresses for 
users to which to send notifications; administrators can modify users and roles 
within that administrator’s department only. 

Manage Share Groups Administrator can add, modify, and delete share groups. 

Access Server Logs Administrator can view server logs. 

Configure System Properties Administrator can configure system properties. 

Archive Administration Administrator can create archive rules for jobs. 

Workspace Contains the following options. 

• View Details: Administrator can view details about workspace versions 

and can configure notifications for versions. 

• Edit Details: Administrator can modify workspace details and can 

configure notifications for versions. 

Version Control Contains the following options. 

• Create/Move to Edit: Administrator can create new workspace 

versions and move workspace versions to edit mode. 

• Move to Test: Administrator can move workspace versions to test mode. 

• Move to Staged: Administrator can move workspace versions to staged 
mode. 

• Move to Active: Administrator can move workspace versions to active 
mode. 
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Privilege Description 

Workspace Configuration Contains the following options. 

• Add Shared Objects: Administrator can add shared objects to the 
workspace. 

• Edit Shared Objects: Administrator can modify workspace shared objects. 

• Edit File Sources: Administrators can modify file sources. 

• Edit Connection Groups: Administrator can modify connection groups. 

• Edit Connections: Administrator can modify connections. 

• Edit Headers: Administrator can modify header files. 

• Edit Verification Forms: Administrator can modify verification forms. 

• Edit ImageNow Index Map: Administrator can modify ImageNow index 
maps. 

• Edit Data Providers: Administrator can configure web service data 
providers. 

• Edit Document Templates: Administrators can configure document 
templates. 

• Procedures 

○  Edit Match: Administrator can configure match logic. 

○  Edit Review: Administrator can configure review logic. 

○  Edit Upload: Administrator can configure upload logic. 

○ Edit Match Display: Administrator can configure match display logic. 

○  Edit Population Selection: Administrator can configure population 

selection logic. 

User Privileges 
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Privilege Description 

Tools 

 

Contains the following options. 

• Lookup: User can configure the lookup tool. 

• Check Name: User can configure the check name tool. 

• Export: User can export Perceptive DataTransfer data (for example, 

lookup values, data provider maps, workspaces, and so on). 

• Data Exports 

○  Edit Data Exports: User can modify data exports. 

○  Run Data Exports: User can run data exports. 

○  Edit Scheduled Data Exports: Users can add, modify, and delete 

scheduled data exports. 

○  View Data Export Output: Users can view the output of past data 
exports. 

○  Delete Data Export Output: Users can delete the output of past 

data exports. 

• Reports 

○  Run Reports: User can run reports. 

○  Edit Reports: User can modify reports and can configure 

notifications for reports. 

○ Edit Scheduled Reports: User can create, modify, and delete 

scheduled report rules. 

○  View Report Output: User can view output files for reports that have 

been run. 

○  Delete Report Output: User can delete output files for reports that 

have been run. 
Version Contains the following options. 

• Import: User can import workspace versions. 

• Edit: User can work in workspace versions in edit mode. 

• Inactive: User can work in workspace versions in inactive mode. 

• Staged: User can work in workspace versions in staged mode. 

• Test: User can work in workspace versions in test mode. 
Job Contains the following options. 

• Create Jobs: User can create jobs and can configure notifications for jobs. 

• Edit Recurring Jobs: User can modify recurring jobs. 

• Edit Job Hold Status: User can place a hold on a job to prevent it from 

being run. 

• Enable Auditing: User can enable auditing. 

• View Archived Jobs: User can view archived jobs. 
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Privilege Description 

Record Contains the following options. 

• Create New Record: User can create new records. 

• Create Match Record: User can set records as matched records. 

• Create Suspend Record: User can suspend records. 
Notifications 

 

Contains the following options. 

• Create Notification Groups: User can create new notification groups. 

• Edit Notification Groups: User can modify notification groups. 
Workspaces Workspace privileges are configured at the role level and are applied to all 

users in the role. 

 

A user can use only one workspace at a time. 

 
Check the workspace that the user can use, then set the following options. 

• Headers: Headers contained in the workspace that the user can use. 

Check the Headers checkbox to select all headers or check individual 

headers to select them. 

• Connection groups: Connection groups contained in the workspace that 

the user can use. Check the Connection Groups checkbox to select all 

connection groups or check individual connection groups to select them. 

• File Sources: File sources contained in the workspace that the user can 

use. Check the File Sources checkbox to select all file sources or 

check individual file sources to select them. 

4. Click the Settings tab to configure email addresses for users to which system notifications are sent. For 

more information, refer to Configuring Notifications. 

5. Click Save to save your changes. 

Configuring File Sources 
You can configure file sources—servers or SFTP connections—for recurring jobs. The file source is the 
location that contains the input file that the recurring job uses. Recurring jobs run at a specified interval, 
using the input file from the server or SFTP site to which it can connect. 

You can also configure file sources to download additional, non-input files from a specified location. For 
example, you can create a recurring job that automatically downloads the input file, creates a job for the 
file, downloads non-input files to be processed by the job, and places the non-input files in a location that 
Perceptive DataTransfer can access. 

Refer to the following topics for more information.  

 Adding File Sources 

 Modifying File Sources  

 Deleting File Sources. 

 Copying File Sources 

 Testing File Sources 
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 Removing Sharing on Shared File Sources 

 Rolling Back File Sources 

 Obtaining the Latest Versions of File Sources 

 Export File Sources 

 Importing File Sources. 

Adding File Sources 

You can add a new file source or add a file source that another workspace is sharing. 

1. Select Configuration > File Sources. 

2. In the File Source Administration dialog box, click    . 

3. In the Add File Source dialog box, perform one of the following actions.  

 To add a new file source, complete the following steps. 

1. Click the Add File Source tab. 

2. In the Name field, type the name of the file source. 

3. From the Type drop-down box, select the type of file source (Server or SFTP).  

 To add a file source that another workspace is sharing, complete the following steps.  

1. Click the Add Shared File Source tab. 

2. From the Workspace drop-down box, select the workspace that is sharing the file source. 

3. From the File Source drop-down box, select the file source you want to add. 

4. Click OK. 

5. In the Edit File Source dialog box, perform one of the following actions.  

 To modify a server path file source, perform the following steps. 

1. In the Name field, type the name of the file source. 

2. In the Description field, type descriptive text about the file source. 

3. In the Path field, type the path. 

4. In the File Pattern Field, type the file pattern information used to identify the input file located 
in the specified file source. Perceptive DataTransfer searches the file source for the input file 
based on the file pattern information specified. 

Use * to search for any number of characters; use ? to search for one character. For example:  

 *.xml returns all XML files. 

 *.?ml returns any file with an extension that has one character followed by ml. 

 Application?.txt returns all fields that start with Application, that have a single character, and 
that have a TXT extension.  

Note  Perceptive DataTransfer does not verify if the file pattern information is correct. 

 To modify an SFTP file source, do the following. 
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1. In the Name field, type the name of the file source. 

2. In the Description field, type descriptive text about the file source. 

3. In the URL field, type the URL of the SFTP connection. 

4. In the Port field, type the port number. 

5. In the Path field, type the SFTP connection path. 

6. In the File Pattern Field, type the file pattern information used to identify the input file located in the 

specified file source. Perceptive DataTransfer searches the file source for the input file based on the 
file pattern information specified.  

Use * to search for any number of characters; use ? to search for one character. For example: 

 *.xml returns all xml files. 

 *.?ml returns any files with an extension that has one character followed by ml. 

 Application?.txt returns all files that start with Application, that have a single character, 
and that have a .txt extension. 

7. In the Username field, type the username used to connect to the SFTP connection. 

8. In the Password field, type the password used to connect to the SFTP connection.  

9. In the File Downloads pane, complete the following steps.  

1. Check the Additional Files checkbox to specify that the file source has other, non-input files to 

download. When you create a recurring job that uses this file source, the input file is downloaded 
from the specified path or connection, and then additional files are downloaded from the same 
path or connection, given the parameters you specify in the File Downloads pane. 

2. In the File Pattern field, type the file pattern information used to identify the non-input file located 

in the file source. 

3. In the Destination Path field, type the location where the non-input files are placed when they are 

downloaded. The path must be on a Perceptive DataTransfer server or reachable from the 
Perceptive DataTransfer server. 

10. In the Source File Options pane, specify how to manage the additional, non-input files in the file 

source location. Click one of the following radio buttons. 

 Leave: Performs no action on the files. 

 Archive: Archives the files and moves them to a location that you specify in the Archive Path 

field. 

 Delete: Permanently deletes the files from the file source. 

11. Click OK.  

The file source is added and appears in the File Source Administration dialog box.  

Modifying File Sources 

To modify a file source, complete the following steps.  

1. Select Configuration > File Sources. 

2. In the File Source Administration dialog box, click the file source you want to modify and either click  

  or right-click the file source and select Edit.  
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3. In the Edit File Source dialog box, perform one of the following actions.  

 To modify a server path file source, complete the following steps.  

1. In the Name field, type the name of the file source. 

2. In the Description field, type descriptive text about the file source. 

3. In the Path field, type the path. 

4. In the File Pattern Field, type the file pattern information used to identify the input file located 

in the specified field source. Perceptive DataTransfer searches the file source for the input 
file based on the file pattern information specified.  

Use * to search for any number of characters; use ? to search for one character. For 
example: 

 *.xml returns all xml files. 

 *.?ml returns any files with an extension that has one character followed by ml. 

 Application?.txt returns all files that start with Application, that have a single character, 
and that have a .txt extension. 

Note  Perceptive DataTransfer does not verify if the file pattern information is correct. 

 To modify an SFTP file source, complete the following steps. 

1. In the Name field, type the name of the file source. 

2. In the Description field, type descriptive text about the file source. 

3. In the URL field, type the URL of the SFTP connection. 

4. In the Port field, type the port number.  

5. In the Path field, type the SFTP connection path. 

6. In the File Pattern Field, type the file pattern information used to identify the input file located 

in the specified field source. Perceptive DataTransfer searches the file source for the input 
field based on the file pattern information specified.  

Use * to search for any number of characters; use ? to search for one character. For 
example: 

 *.xml returns all xml files. 

 *.?ml returns any files with an extension that has one character followed by ml. 

 Application?.txt returns all files that start with Application, that have a single character, 
and that have a .txt extension. 

7. In the Username field, type the username used to connect to the SFTP connection.  

8. In the Password field, type the password used to connect to the SFTP connection. 

4. In the File Downloads pane, complete the following steps. 

1. Check the Additional Files check box to specify that the file source has other, non-input files to 

download. When you create a recurring job that uses this field source, the input file is 
downloaded from the specified path or connection, and then additional fields are downloaded 
from the same path or connection, given the parameters you specify into eh File Downloads 
pane. 
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2. In the File Pattern field, type the file pattern information used to identify the non-input file located 

in the file source. 

3. In the Destination Path field, type the location where the non-input files are placed when they 

are downloaded. The path must be on a Perceptive DataTransfer server or reachable from the 
Perceptive DataTransfer server. 

5. In the Source File Options pane, specify how to manage the additional, non-input files in the file 

source location. Click one of the following radio buttons.  

 Leave: Performs no action on the files. 

 Archive:  Archives the fields and moves them to a location that you specify in the Archive Path 

field.  

 Delete:  Permanently deletes the files from the file source. 

6. Click OK.  

Deleting File Sources 

To delete a file source, complete the following steps. 

1. Select Configuration > File Sources. 

2. In the File Source Administration dialog box, select the file source you want to delete and either 

right-click it and select Delete or click    .  

The file source is deleted and is removed from the File Source Administration dialog box. 

Copying File Sources 

To create a duplicate of a file source, complete the following steps.  

1. Select Configuration > File Sources. 

2. In the File Source Administration dialog box, select the file source you want to copy and either 

right-click it and select Copy or click    . 

A copy of the file source is created and appears in the File Source Administration dialog box.  

Testing File Sources 

To test a field source connection, complete the following steps. 

1. Select Configuration > File Sources. 

2. In the File Source Administration dialog box, select the file source you want  to test and either right-

click it and select Test File Source or click    .  

 If the file source works properly, a dialog box appears and states that the test was successful. 

 If the file source does not work properly, a dialog box appears and indicates the reason that the 
test failed.  

Removing Sharing on Shared File Sources 

To remove sharing on a file source that is shared with another workspace, do the following. 

1. Select Configuration > File Sources. 
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2. In the File Source Administration dialog box, select the file source for which you want to remove 

sharing and either right-click it and select Remove Sharing or click .  

Sharing is removed on the file source. 

Rolling Back File Sources 

If changes have been made and committed to a file source, you can use a previous version (roll back) of 
it. 

1. Select Configuration > File Sources. 

2. In the File Source Administration dialog box, click the file source you want to roll back and either right-

click it and select Rollback or click    . The Rollback Manager dialog box displays the following 

information. 

 Name: Name of the file source. 

 Status: Status of the file source (current or dated). 

 Version Date: Date and time on which the version was created. 

 Created By: Username of the user who created the file source. 

 Comments: Comments that were added by the user. 

3. Select the previous version to which you want to revert and click Rollback.  

The previous version is loaded. 

Obtaining the Latest Versions of File Sources 

If changes have been made to and committed to a file source, you can obtain the latest version of it.  

1. Select Configuration > File Sources. 

2. In the File Source Administration dialog box, click the source file for which you want to obtain the 
latest version and either right-click it and select Get Latest or click    . 

Export File Sources 

Note  You cannot export file sources in tablet view. 

You can export files sources to an XML file by completing the following steps. 

1. Select Configuration > File Sources. 

2. In the File Source Administration dialog box, select the source file you want to export.  

3. Click    and select Export. 

4. Save the file to the appropriate location. 

Importing File Sources 

Note  You cannot import file sources in tablet view.  

You can import file sources from an XML file by doing the following. 

1. Select Configuration > File Sources. 
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2. In the File Source Administration dialog box, click    and select Import. 

3. In the Import File Source dialog box, click the Browse button and navigate to the file that you want to 
import or type the location of the file in the File field. 

4. Check the Update Existing Entities check box to update an existing file source, with the same name 

as the file source you are importing, with the file source you are importing. 

If you do not check this checkbox, and there is an existing file source with the same name as the file 
source you are importing, DUPLICATE- is appended to the start of the name of the file source you are 
importing; the existing file source is not updated. If a file source exists with the name DUPLICATE- 

<file_source_name>, DUPLICATE(2)- is appended to the start of the name. The number continues to 
be incremented so that all file sources have unique names. 

5. Click OK. 

Configuring jobs and processing records 
Jobs contain all functions required to load data into your database. A job consists of the following 
information. 

 Header: Defines the input data source, mapping values from the input file to the source destination in 

your database. 

 Connection group: Comprises database connections to your database. 

 Input Source: Source from which you are importing data (for example, a spreadsheet containing test 

information for students). Input sources can be fixed-width, delimited, XML files, EDI files, database 
queries, or web service calls. 

Note: EDI files are supported in Perceptive DataTransfer 6.4.4 and higher. 

 Date and time: Date and time on which the job starts (if not specified, the job is run manually). 

When you run a job, Perceptive DataTransfer processes all records from the input source for the job.  

Refer to the following topics for more information.  

 Understanding the Perceptive DataTransfer desktop and tablet Job Dashboard 

 Understanding the Perceptive DataTransfer mobile Job Dashboard 

 Customizing columns 

 Adding and modifying recurring jobs 

 Adding new jobs 

 Modifying job details 

 Opening jobs  

 Running jobs 

 Deleting jobs 

 Canceling jobs 
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Understanding the Perceptive DataTransfer desktop and tablet Job 
Dashboard 

The following figure displays Perceptive DataTransfer Job Dashboard for the desktop and tablet view. Not 
all features are available on the tablet view.  

The Job Dashboard provides the following information. 

Element Description 

Status drop-down box Filters the status of the jobs you view in the Job Dashboard table. When you 
select an option, the table displays jobs with the selected status. Options are: 

• Active: Active jobs are jobs that have not yet started (pending), jobs that 

have run but for which there are unprocessed records (incomplete), or 

jobs that have run but for which there are suspended records (processed). 

• Complete: Complete jobs have been run and all records have been 

processed as new or match; there are no suspended or unprocessed 

records. 

• Archive: Archive jobs are historical jobs that have been archived. 

• Canceled: Canceled jobs have been canceled by a user. 

Name column Name of the job. 

Click + to expand the job entry and view details about the job. The following fields 
display. 

 File Name: Filename of the input file used by the job. 

 Created On: Date on which the job was created. 

 Created by: Username of the user who created the job. 

 Start Time: Date and time on which the job started to run. 

 End Time: Date and time on which the job ended. 

 In Use by: Username of the user who is running the job. 

File Name column Filename of the input file used by the job. 

Scheduled Start Time column Date and time on which the job was scheduled to start. 
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Element Description 

Status column Status of the job. 

• Complete: The job has finished running, and there are no unprocessed or 

suspended records. 

• Incomplete: The job is not currently running and has processed and 

unprocessed records. 

• Processed: The job has finished running, but there are suspended 

records. 

• Pending: The job has not yet started. 

• Processing: The job is currently running. 

• Canceled: The job was canceled. 

• Archive: The job was archived. 

Records Status column: Provides the following subcolumns. 

• Progress: Provides a status bar indicating job progress when it is being run. 

• Total: Number of total records for the job. 

• Unprocessed: Number of records that the job did not process. 

• Suspended: Number of suspended records. 

• Matched: Number of matched records. 

• New: Number of new records. 

• Locked: Number of locked records. 

Header column Name of the header used for the job. 

Connection Group column Name of the connection group for the job. 

 

Understanding the Perceptive DataTransfer mobile Job Dashboard  

If you are using DataTransfer on phones with smaller screens or resolutions, the mobile Job Dashboard 
displays; the layout and functionality are the same for mobile Dashboards, but the overall design varies 
among devices.  

The mobile Job Dashboard displays the Active Jobs page, which displays a list of active jobs. To filter the 
status of jobs displayed in the Job Dashboard, Settings > Filter, and then select the job status you want 

to display. 

To view details about a job in the mobile Job Dashboard, select the appropriate job. The following details 
are displayed. 

 Name: Name of the job. 

 Status: Status of the job. 

 Active: Active jobs are jobs that have not yet started (pending), jobs that have run but for which there 
are unprocessed records (incomplete), or jobs that have run but for which there are suspended 
records (processed). 
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 Complete: Complete jobs have been run and all records have been processed as new or match; 
there are no suspended or unprocessed records. 

 Archive: Archive jobs are historical jobs that have been archived. 

 Canceled: Canceled jobs have been canceled by a user. 

 File: Filename of the input file used by the job. 

 Progress: Displays a bar that shows the percentage of the job completion. 

 Total: Total number of the job. 

 Unprocessed: Total number of records not processed by the job. 

 Matched: Number of matched records. 

 New: Number of new records. 

 Locked: Number of locked records. 

You can also run jobs in the mobile Job Dashboard; for more information, refer to Running jobs. 

Customizing columns 

You can customize the columns displayed in the Job Dashboard. 

Columns are automatically saved the way in which you displayed them when you last logged out of the 
application or when you switched roles. 

To choose the columns you want to display, complete the following steps. 

1. Hover your mouse over the appropriate column. 

2. In the drop-down list that displays on the right side of the column, click the arrow to open a menu that 
allows you to sort columns from A-Z or Z-A and also allows you to select the columns you want to 
display. 

3. Select Columns and then check the columns you want to display; uncheck the columns you do not 

want to display. 

After you log out of the application or change roles, the columns you specified to show 

or hide are displayed in the Job Dashboard the next time you log in. 

Adding and modifying recurring jobs 

Recurring jobs run at a specified interval, using a file from a specified data source or file source. To add 
or modify a recurring job, complete the following steps. 

1. Select Jobs > Recurring Jobs to display the Recurring Job Administration dialog box. 

2. Perform one of the following actions. 

 To add a new job, click    to display the Add Recurring Job dialog box. 

 To modify a job, select the recurring job and click    . The Edit Recurring Job dialog box 

appears. 

3. In the Job Name field, type the name of the job. 

4. In the Status field, click the Enable option to enable the recurring job; click Disable to disable it. 

5. From the Header drop-down box, select the header file used for the job. 
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6. From the Connection Group drop-down box, select the connection group. 

7. From the File Source drop-down box, select the file source (server or SFTP connection) that contains 

the input file. 

File Sources are configured in Perceptive DataTransfer in Configuration > File Sources; for more 

information, refer to Configuring File Sources. 

This field is unavailable if you are using a database, web service, or Hobsons Connect CRM header. 

8. From the Start time drop-down box, select the time on which the job starts. If you do not specify a start 

date and start time, the job is run only manually. 

9. In the Options pane, specify the following information. 

 Check the Log SQL check box to log SQL messages; these messages appear in the Log View 

dialog box (refer to Viewing Log Messages). 

 Check the Allow Duplicate Filenames check box to allow jobs to have the same name. 

 Check the Use Filename check box to include the name of the input file in the job name. When 

you add a new job, the name of the input file is appended to the job name. 

 Check the Delete Files check box to delete input files from the server after they have been used 

for the recurring job. 

10. In the Job Restrictions pane, complete the following substeps. 

 Check the Limit other users from running check box to prevent other users from running this 

job. 

 Check the Limit other users from opening or editing until processed or completed check box 

to prevent other users from opening or editing the job until it has finished processing records or 
has completed running. 

11. In the Recurrence Pattern pane, specify when the job recurs. 

 Click the Daily option to specify that the job recurs daily, and then specify the recurrence 

frequency. 

 Click the Weekly option to specify that the job recurs weekly, and then specify the recurrence 

frequency. 

 Click the Monthly option to specify that the job recurs monthly, and then specify the recurrence 

frequency. 

 Click the Auto option to specify that the job recurs automatically whenever a file is added to the 

file source used for the job. The Delete Files option is automatically selected to prevent duplicate 
jobs from being created using the same file. You can use only headers that use file sources to 
provide data; therefore, you cannot create automatically recurring jobs that use headers of types 
database, Hobsons Connect CRM, or web service. 

 Click the Manual option to specify that the job recurs manually. It does not have a scheduled run 
date and recurs only when manually started. You can start the job anytime in the Recurring Job 
Administration dialog box or by calling the StartManualJob web service from a third-party application 
(refer to Perceptive DataTransfer API Guide for more information). Refer to Running manual recurring 
jobs  for information on running manual recurring jobs. 

12. Click the Notifications tab to configure email notifications to be sent when certain job activities occur. 

Refer to Configuring Notifications. 

13. Click OK. 
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The recurring job is added and appears in the Recurring Job Administration dialog box. When an 
instance of this job is scheduled, the instance is created and appears in the Job Dashboard. 

Adding new jobs 

To add a new job, complete the following steps. 

1. Select Jobs > Add Job. 

2. In the Add Job dialog box, the Job Name field displays the name of the job. The default name of the 

job is USER DATE TIME, where USER is the username of the user who created the job, DATE is the 
date (month, day, and year) on which the job was created, and TIME is the time that the job was 
created. 

3. From the Header drop-down box, select the header file used for the job.  

4. From the Connection Group drop-down box, select the connection group. 

5. In the Input File field, click Browse and select the input file, which contains the data that you want to 

import, to use for the job. 

6. From the Dependent On drop-down box, select the job on which you want the new job to be 

dependent. Jobs that you can select have one of the following statuses: Pending, Incomplete, 
Connection_Error, Record_Key_Error, and On Hold.  

7. In the Release On field, click the appropriate option for when you want the On Hold status to be 
removed from the new job. If you click Complete, the new job starts when the job on which it is 
dependent obtains Complete status. If you click Processed, the new job starts when the job on 

which it is dependent obtains Processed status. 

8. In the Start Date field, click the calendar icon to display a pop-up calendar; then, select the date on 

which the job starts. 

9. From the Start time drop-down box, select the time on which the job starts. If you do not specify a 

start date and start time, the job is run only manually. 

10. Check the Log SQL check box to log SQL messages; these messages appear in the Log View 

dialog box (refer to Viewing Log Messages). 

11. In the Job Restrictions pane, complete one of the following actions. 

 Check the Limit other users from running check box to prevent other users from running this 

job. 

 Check the Limit other users from opening or editing until processed or completed check box 

to prevent other users from opening or editing the job until it has finished processing records or 
has completed running. 

12. Click OK. 

The job is created and is added to the table. 

Note  If you enabled Preferences > Filename in Job Name, the name of the input file is appended 

to the job name. 

Modifying job details 

To modify job details, complete the following steps.  

1. Complete one of the following actions. 
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 Select a job in the Job Dashboard and right-click it and select Details. 

 Select a job in the Job Dashboard and click the Details button. The Edit Job Details dialog box 

appears. 

2. In the Job Name field, type the name of the job. 

Note  You cannot modify any other fields, except the Job Name field, if you are modifying a job with 

any status other than Pending. 

3. From the Connection Group drop-down box, select the connection group to use for the job. 

4. In the Start Date field, click the calendar icon to open a calendar, and then select the date on which 

the job starts. 

5. From the Start Time drop-down box, select the time on which the job starts. 

6. Click OK to save your changes and close the dialog box. 

Opening Jobs 

To open a job, complete the following steps. 

1. Complete one of the following actions. 

 Select a job in the table in the Job Dashboard and click the Open button. 

 Double-click a job in the Job Dashboard table. 

A window displays information about the job. 

Note  Only the Records pane appears in tablet view 

2. To filter records in the Records pane, right-click a job, select Filter By, and select the status of the 
records you want to display. You can also select the filter option from the Filter by drop-down box. 

Options are: 

 All 

 Unprocessed 

 Suspended 

 Match 

 New 

 Locked 

Records text is colored according to status. 

 Locked: Purple 

 Match: Green. 

 New: Blue 

 Suspend: Red 

 Unprocessed: Black 

The Rank column identifies the stage of matching during which the record was set as Match or New. 
The value indicates the level of match routines executed before you determined that the record was 
Match or New. If the record is unprocessed or suspended, the rank value is empty. 
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Rank information is configured by your Perceptive DataTransfer administrator. 

 

3. If sorting is enabled on a column, when you click a column heading, the field is sorted, depending on 
the type of information contained in the column. The field can be sorted alphanumerically, 
numerically, or by date. 

4. In this window, you can also complete the following steps. 

 Reset a record. Refer to Resetting records. 

 Lock a record. Refer to Locking records. 

 Modify a record. Refer to Modifying records. 

 Suspend a record. Refer to Suspending records. 

 View the reason that a record was suspended. Refer to Viewing the suspend reason. 

 View XML records (desktop view only). Refer to Modifying records. 

Resetting records 

To reset any Processed record to Unprocessed, complete the following steps. 

1. Select a job in the Job Dashboard and click Open. 

A window displays information about the job. 

2. Complete one of the following actions. 

 In desktop view, right-click the record in the Records pane and select Reset Record. 

 In tablet view, select the record and click the Reset button. 

The record is reset to Unprocessed and its information is updated in the Records pane. 

Locking records 

When you lock a record, it is not processed when you run a job. To lock a record, complete the following 
steps. 

1. Select a job in the Job Dashboard and click Open Job. 

A window displays information about the job. 

2. Complete one of the following actions. 

 In desktop view, right-click the record in the Records pane and select Lock Record. 

 In tablet view, select the record and click the Lock button. 

The record is locked. Its status is changed to Locked in the Records pane. 
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. 

 

Modifying records 

1. Select a job in the Job Dashboard and click Open Job. 

A window displays information about the job. 

2. Complete one of the following actions. 

 In desktop view, right-click the record in the Records pane and select Edit Record. The Record 
Editor dialog box appears. 

 In tablet view, select the record and click the Edit button. The Record Editor dialog box 

displays. 

 To view XML records, in desktop view, right-click a record (for a job using an XML or EDI header) 
and select View Full Record. 

Note: EDI headers are supported in Perceptive DataTransfer 6.4.4 and higher. 

3. Complete one of the following actions. 

 If you are modifying records for jobs using headers other than XML or EDI headers, the Record 
Editor dialog box appears and displays the following information about the variables for the 

record. 

 Pos: Numerical value of the position of the field in the input file. 

 Field Name: Name of the field. 

 Value: Value of the field. 

Note: EDI headers are supported in Perceptive DataTransfer 6.4.4 and higher. 

 If you are modifying records for jobs using XML or EDI headers, the Edit XML Record dialog box 
appears. In the Node column, a  icon appears next to XML tags that will appear in the Records 

pane; a   icon appears next to XML tags that will not appear. 

To expand all nodes in the XML tree, click . To collapse them, click   

Note: EDI headers are supported in Perceptive DataTransfer 6.4.4 and higher. 

4. To select the next record, click the Next button; to select the previous record, click the Previous 

button. 

5. To modify the value of a record, double-click the entry in the Value column and then type the 

appropriate value. For XML records, you can assign values to only nodes that do not have child 
nodes. 

6. To apply your changes, click Apply. If you click Previous, Next, or Close without saving your 

changes, a dialog box appears and prompts you to confirm that you want to save your changes 
before the action is performed for the button you clicked. 

The input record is updated with the changes you made, and its information is updated in the Records 

pane. 

Viewing logs 

Click the View Logs button to view information about the job. Refer to Viewing Log Messages for more 

information. 
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Suspending records 

If Perceptive DataTransfer cannot upload a new record to the database when you run a job, the record is 
automatically suspended. 

You can manually suspend a record if there is an issue with the record that you need to investigate 
further. 

1. Select a job in the Job Dashboard and click Open Job. 

A window displays information about the job. 

2. Complete one of the following actions. 

 In desktop view, right-click the record in the Records pane and select Suspend Record. 

 In tablet view, select the record and click the Suspend button. 

3. In the Suspend Record dialog box, in the Enter suspend reason field, type the reason for which 

you are suspending the record. 

4. Click OK. 

The record is suspended. Its status changes to Suspended, and the record text is 

highlighted in red in the Records pane. 

Viewing the suspend reason 

To view the suspend reason for a single suspended record, complete the following steps. 

1. Select a job in the Job Dashboard and click Open Job. 

2. In the window that displays job information, perform one of the following actions.  

 In the desktop view, right-click the record in the Records pane and select View Suspend 
Reason. 

 In tablet view, select the record and click the View Reason button. 

The View Suspend Reason dialog box appears and displays the reason that the record was suspended.  

Searching records 

You can search for information within the entire job or within a specific column of the Records pane. 

Note  Searches are not case-sensitive. 

To search for information in the entire job, in the Records pane, type the text for which you want to 
search in the Find field; then press Enter.  

If one or more results are returned, the Records pane is refreshed and all matching terms are highlighted 

in yellow. If more than one result is returned, the   (previous) and  (next) buttons are enabled, which 

you can use to navigate to any available previous or next results. When you hover your mouse over these 
buttons, tooltips appear and indicate the result to which you will navigate if you click the button. 

To stop viewing search results, click  . The text in the Find field is cleared, the search controls are 

disabled, and the current page of records is refreshed without the highlighted terms. 

You can also search for information within a specific column. The tooltip that appears when you hover 
your mouse over the Find field provides more information and an example of how to perform the search. 
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Type *[COLUMN] at the end of the search term to search for the term only within the specific column. 

For example, for the search term M*[GENDER], Perceptive DataTransfer searches for the term M within 
only the $GENDER column. 

If you do not provide the correct name of the column, and the incorrect column name does not exist, 
Perceptive DataTransfer searches the entire job for the search terms. 

For example, for M*[$GENDE], if the $GENDE column does not exist, Perceptive DataTransfer searches 
the entire job for M*[$GENDE]. 

Running jobs 

Refer to the following topics for more information. 

 Understanding run modes 

 Running manual recurring jobs 

 Running jobs in batch mode 

 Running jobs in interactive mode 

 Setting On Hold jobs 

 Monitoring jobs 

Understanding run modes 

You can run jobs and records in interactive or batch mode; the mode is determined by your Perceptive 
DataTransfer administrator. 

In interactive mode, you load your data one record at a time. You open the job to view the Job window 
and run the job from there. As Perceptive DataTransfer runs through each record in the match process, it 
prompts you to add the record as either a new record or a match record. 

In tablet view, you cannot run jobs in interactive mode. 

In batch mode, you can load all records without Perceptive DataTransfer pausing between records to 
prompt you for input. You can run the job from the Job Dashboard. 

Running manual recurring jobs 

If a recurring job can be run manually, you can run it at any time by completing the following actions. 

1. Select Jobs > Recurring Jobs. 

2. In the Recurring Job Administration dialog box, click    . 

You can specify that the recurring job is run manually in the Add Recurring Job and Edit Recurring Job 

dialog boxes. Refer to Adding and modifying recurring jobs for more information. 

Running jobs in batch mode 

To run a job in batch mode, complete one of the following actions. 

 In the desktop Job Dashboard, select the job you want to run and select Run from the popup menu 
or click the Run button. 
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 In the mobile Job Dashboard, select the job you want to run and select   .  

To stop a job that is running, complete one of the following actions. 

 In the desktop Job Dashboard, right-click the job and select Stop or click the Stop button. 

 In the mobile Job Dashboard, select    . 

After Perceptive DataTransfer processes the job, you can open the job to view job results, including 
information about any suspended or unprocessed records. 

Running jobs in interactive mode 

Note  You cannot run jobs in interactive mode in tablet view. 

To run a job in interactive mode, complete the following steps. 

1. Select a job in the table and click Open Job. 

A window displays information about the job. 

2. Complete one of the following actions. 

 To process a single record in the job, select the record in the topmost pane and click the Run 

button. 

 To process all records in the job, click the Run All button. 

 To stop running the job, click Stop in the bottom toolbar. 

Depending on your configuration, you may receive the Prompt dialog box for a record, which displays 

message text and allows you to update values of information for the record. 

For example, you may receive a message that the address information is not correct, and you can 
update address information, such as street number, city, and state. 

To modify a value, click the row of in the Value column and type the appropriate text. 

Then, complete one of the following actions. 

 Click OK to apply your changes. The information is updated and jobs processing resumes. 

 Click Reset to reset the values in the Prompt dialog box to the original values. 

 Click Cancel to stop processing on the record. The Error Processing dialog box appears and 

provides information about why the record could not be processed. 

If you enabled the Display All Match Results preference, when you run a job in interactive mode, all 

possible record matches are compiled before the application pauses to allow you to review the possible 
matches. For more information, refer to Specifying Preferences. 

Depending on your configuration, you may receive a Result Selection dialog box, which displays a 

prompt in the top field and values, returned by the job, below it. This dialog box appears if multiple 
records of information are obtained from the job; select the information you want to use and click OK. 

When Perceptive DataTransfer processes records in interactive mode, one of the following occurs. 

 If a record cannot be processed, a dialog box appears and displays information about why the 
record could not be processed. The dialog box contains the following information: 

 Procedure Name: Name of the programming procedure that contains the problem. 
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 Line #: Number of the line in the procedure in which the problem occurred. 

 Error Information: Description of the problem in the procedure. 

 If a new record could not be uploaded, the record is suspended. 

 If Perceptive DataTransfer cannot find a matching record in the database, a dialog box appears and 
prompts you to create a new record. Click Yes to create the record and add it to your database; 
click No if you do not want to create a new record. 

 If there are potential matches in your database, Perceptive DataTransfer pauses and prompts you to 
review results, which are displayed in the Results pane. Perceptive DataTransfer organizes the 

results based on a ranking of how likely they are to be matches to the input data. 

Click    to continue to process records to search for results that are more possible. 

 If Perceptive DataTransfer does not find a match, you are prompted to create a new record. 
Click Yes to create the record; the record is updated in the topmost pane, with its status 

changing to New and its label color changing to blue. 

 If you find a matching result and want to create a matched record, select the result in the 
Results panel and click the Matched button. The record’s status is updated as Match, its color 

changes to green, and it is updated in the topmost pane. 

After Perceptive DataTransfer uploads a record, an informational dialog box appears and 
displays the record number that was processed and if it was “successfully matched,” if it was 
“successfully created,” or if it “failed to upload.” 

You can use the verification form, if configured, to compare information from the current input 
record and potential matches in your database. Refer to Viewing the verification form. 

Viewing the verification form 

With the verification form, you can compare the current input record side-by-side with the possible 
existing record. 

Forms are configured by your Perceptive DataTransfer administrator. 

Note  The form is displayed only when a job is running in interactive mode. 

When you run a record, the verification form displays data associated with the input record and the 
possible record in your database. 

Depending on your Perceptive DataTransfer configuration, you can select information, if changed, that 
could be included to be uploaded to your database. 

If an area that contains a group of information (for example, in the preceding figure, Name or Permanent 
Address) has a checkbox, you can check the checkbox if you want Perceptive DataTransfer to verify that 
the information has changed and can be uploaded. Your Perceptive DataTransfer administrator 
configures Perceptive DataTransfer to verify if the information has changed and can be uploaded. 

After you review the data in the verification form and compare it with the possible matched record in the 
database, you can create a new record, create a matched record, or suspend the record. 

Setting On Hold jobs 

You can set a job status to be On Hold so that it cannot be run interactively or in batch mode until the 
hold status is released. You can set a job on hold if it has one of the following statuses: Pending, 
Incomplete, Connection_Error, or Record_Key_Error. 
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To set a job as on hold, select the job in the Job Dashboard and click Hold. 

To remove the on hold status from the job, select the job in the Job Dashboard and click Release. 

Monitoring jobs 

 Select a job in the Job Dashboard and click Monitor. 

 The Job Progress dialog box appears in the foreground of your browser and remains open and in 
the foreground until you click Close. 

 A progress bar appears at the top of the dialog box, indicating the percentage complete of the job. 
The dialog box displays the following information. 

 Total: Total number of records in the job. 

 Unprocessed: Number of records that are not processed. 

 Suspended: Number of suspended records. 

 Matched: Number of matched records. 

 New: Number of new records. 

 Locked: Number of locked records. 

When the job is running, the Stop button appears in the Job Progress dialog box; click it to stop running 
the job. When the job has completed, only the Close button is displayed. 

Deleting jobs 

Refer to the following topics for more information. 

 Deleting jobs 

 Deleting recurring jobs 

Deleting jobs 

You can delete a job that has never been run (the job has a status of pending and all its records are 
unprocessed). You cannot delete jobs that have fully completed. 

To delete a job, complete the following steps. 

1. Complete one of the following actions. 

 In the desktop Job Dashboard, select the job you want to delete and click Delete. 

 In the mobile Job Dashboard, select the job you want to delete and click    . Perceptive 

DataTransfer prompts you to confirm that you want to delete the job. 

2. To delete the job, click Yes. 

The job is deleted and is removed from the Job Dashboard. 

 

Deleting recurring jobs 

To delete a recurring job, complete the following steps. 
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1. Select Jobs > Recurring Jobs. 

2. In the Recurring Job Administration dialog box, select the recurring job you want to delete and click  

  . 

A dialog box appears and prompts you to confirm that you want to delete the job. 

3. To delete the job, click Yes. 

The job is deleted and is removed from the Recurring Job Administration dialog box. 

Canceling jobs 

You can cancel all jobs except those that has never been run (the job has a status of pending, and all its 
records are unprocessed). 

You can cancel jobs that have at least one record that has been processed. However, you cannot cancel 
jobs that have fully completed. 

When you cancel jobs, they are removed from the Job Dashboard when you select Active from the 

Status drop-down box. 

To cancel a job, complete the following steps. 

1. Complete one of the following actions. 

 In the desktop Job Dashboard, select the job you want to cancel and click Cancel. 

 In the mobile Job Dashboard, select the job you want to cancel and click    . Perceptive 

DataTransfer prompts you to confirm that you want to cancel the job. 

2. To cancel the job, click Yes. 

The job is canceled, and its status is set to Canceled in the Job Dashboard. 

 

 


