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Perceptive Document Composition Setup
Overview
This document contains information on how to install Perceptive Document Composition (PDC) and PDC
language packs on your system. You can also choose to install the program features that include PDC
Server, PDC Studio, and PDC Client on your system.
•

PDC Server. The server component of Document Composition.

•

PDC Studio. The design environment of Document Composition used to create text components,
documents, scripts, and processes.

•

PDC Client. The client component of Document Composition.

Prerequisites
Technical specifications
For more information on the technical specifications for this application, see the Perceptive Document
Composition Technical Specifications Guide.

Compatibility
Review the following information for compatibility issues that may impact the installation of this application
on your computer.
•

Objects in PDC 6.2 are not compatible with previous versions. It is not possible to transfer objects
from a 6.2 repository to systems based on repository versions prior to 6.2.

•

PDC WebClient 6.2 is not compatible with previous versions of PDC and can only connect to a MWS
service version 6.2.
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Update PDC from Version 6.1.x to Version 6.2.0
This section provides information on the update of PDC version 6.1.x to version 6.2.0.
•

Update PDC server installation from Version 6.1.x to Version 6.2.0.

•

Update PDC Studio installation from Version 6.1.x to Version 6.2.0.

•

Update PDC Client installation from Version 6.1.x to Version 6.2.0.

Update PDC server installation from Version 6.1.x to Version 6.2.0
To update your PDC server installation, complete the following steps.
1. Download the update and installation packages of PDC version 6.2.0 and save these files locally so
that you can access them during the update procedures.
2. Close all running PDC applications.
3. To update your system, you must stop the PDC Core service. In the PDC server, complete the
following substep.
•

Open the Windows Services.

•

Right-click the Modus_Core service, and click Stop.

4. To retain your unique customizations and take a back up of your settings, complete the following
substeps.
1. Unzip the contents of the PDCUpdater.zip file into a directory other than the PDC installation
directory.
2. Open a command prompt window and navigate to the directory that contains the content of the
PDCUpdater.zip file.
3. Enter the following command.
backupConfiguration.cmd <back-up directory>

5. Update PDC.
•

To update a 32-bit PDC installation, double-click the PDC Setup 6.2.0 for Windows (32bit).exe
file.

•

To update a 64-bit PDC installation, double-click the PDC Setup 6.2.0 for Windows (64bit).exe
file.
Notes
•

Specify the same installation path that you used for the previous installation of this
application.

•

If a different bit variant of PDC is installed than the one that is already installed, the existing
PDC installation must first be uninstalled.
Example If the 32-bit PDC variant is installed and you want to install the 64-bit variant, then
you must first uninstall the old 32-bit variant.

6. To restore the configuration, complete the following substeps.
1. Open a command prompt window as an administrator.
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2. Navigate to the directory that contains the content of the PDCUpdater.zip file and enter the
following command.
restoreConfiguration.cmd <back up directory>

Note Use the same backup directory that you used previously to take a back up of your settings.
7. Update the database schemas.
To update the database schemas, complete the following substeps.
1. Unzip the content of Update620.zip file into the PDC installation directory. A folder named
Update620 is created below the Admin directory.
2. Based on your database, complete one of the following options.
SQL Server databases
•

Run the following SQL script on all Repository databases to update the schema.
.\Admin\Update620\MSSql_Rep_DB_Schema_Update_610_To_620.sql

•

Run the following SQL script on all ODIN databases to update the schema.
.\Admin\Update620\MSSql_Odin_DB_Schema_Update_610_To_620.sql

Oracle databases
•

Run the following SQL script on all ODIN databases to update the schema.
.\Admin\Update620\Ora_Odin_Create_Schema_Update_610_To_620.sql

Note It is recommended that you take a back up of all databases before updating their schemas. The
update scripts require a schema version 6.1.x or higher. You can run the SQL scripts on the same
schema multiple times.
8. To update the ODIN configuration file “odinparameter.config”, complete the following substeps.
1. Navigate to the PDC installation directory and open the odinparameter.config file with an UTF-8
capable editor.
2. Add the line marked in bold italics into the <process> section and save your changes.
<process>
…
<parameter name="ODP_DIRECT_PRINT_STACK_PARAM" type="string" direction="i"
size="2147483647" alias="directprintstack" defaultvalue=""/>
…
</process>

9. To replace the copied and renamed PDC executable file with the executable file of the current
version, a command file is provided. Complete the following substeps.
1. Unzip the content of the Update620.zip file into the PDC installation directory. A folder named
Update620 is created below the Admin directory.
2. Open a command prompt window as an administrator and navigate to the PDC installation
directory.
3. Navigate to Admin\Update620 and enter the following command.
PDCSystemsAndConfigurationUpdate.cmd

10. Update the language resources.
•

If you run PDC Studio and Client in a language other than German or English, you must update
the corresponding language resources.
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•

To update the language resources, complete the steps described in the Install the language pack
resources section.

11. Start the PDC windows services. In the Windows Services, stop and restart the following services.
•

Modus_Core

•

Modus_Mws

•

Modus_Ows

Update PDC Studio installation from Version 6.1.x to Version 6.2.0
To update your PDC Studio installation, complete the following steps.
1. Download the update and installation packages of PDC version 6.2.0 and save these files locally so
you can access them during the update procedures.
2. Close all running PDC applications.
3. To retain your unique customizations and take a back up of your settings, complete the following
substeps.
1. Unzip the content of the PDCUpdater.zip file into a directory other than the PDC installation
directory.
2. Open a command prompt window and navigate to the directory that contains the contents of the
PDCUpdater.zip file.
3. Enter the following command.
: backupConfiguration.cmd <back-up directory>
Note As a backup directory, use a directory other than the PDC installation directory.
4. Update PDC.
•

To update a 32-bit PDC installation, double-click the PDC Setup 6.2.0 for Windows (32bit).exe
file.

•

To update a 64-bit PDC installation, double-click the PDC Setup 6.2.0 for Windows (64bit).exe
file.
Notes
•

Specify the same installation path you used for the previous installation of this application.

•

If a bit variant of PDC, other than the one that is already installed, is installed, the existing
PDC installation must first be uninstalled.
Example If the 32-bit PDC variant is installed and you want to install the 64-bit variant, then
you must uninstall the old 32-bit variant.

5. To restore the configuration, complete the following substeps.
1. Open a command prompt window as an administrator.
2. Navigate to the directory that contains the contents of the PDCUpdater.zip file.
3. Type the following command: restoreConfiguration.cmd <back up directory>
Note Use the backup directory that you previously specified to take a backup your settings.
6.

To replace copied and renamed PDC executable with the executable of the newer version, a
command file is provided. Complete the following substeps.
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1. Unzip the content of the Update620.zip file into the PDC installation directory. A folder named
Update620 is created below the Admin directory.
2. Open a command prompt window as an administrator and navigate to the PDC installation
directory.
3. Navigate to Admin\Update620 and enter the following command.
PDCSystemsAndConfigurationUpdate.cmd

7. Update the language resources. If you run PDC Studio and Client in a language other than German
or English, you must update the corresponding language resources. To update the language
resources, complete the steps described in the Install the language pack resources section.
8. To update the ODIN configuration file “odinparameter.config”, complete the following substeps.
1. Navigate to the PDC installation directory and open the odinparameter.config file with an UTF-8
capable editor.
2. Add the line marked in bold italics to the <process> section and save your changes.
<process>
…

<parameter name="ODP_DIRECT_PRINT_STACK_PARAM" type="string" direction="i"
size="2147483647" alias="directprintstack" defaultvalue=""/>
…
</process>

Update PDC Client installation from Version 6.1.x to Version 6.2.0
To update your PDC Client installation, complete the following procedure.
To download the update and installation packages, complete the following steps.
1. Download the update and installation packages of PDC version 6.2.0 and save these files locally so
you can access them during the update procedures.
2. Close all running PDC applications.
1. To retain your unique customizations and take a backup of your settings, complete the following
substeps. Unzip the contents of the PDCUpdater.zip file into a directory other than the PDC
installation directory.
2. Open a command prompt window and navigate to the directory that contains the content of the
PDCUpdater.zip file and type the following command.
backupConfiguration.cmd <backup directory>

Note For your backup directory, use a directory other than the PDC installation directory.
3. Update PDC.
•

To update a 32-bit PDC installation, double-click the PDC Setup 6.2.0 for Windows
(32bit).exe file.

•

To update a 64-bit PDC installation, double-click the PDC Setup 6.2.0 for Windows
(64bit).exe file.
Notes
•

Specify the same installation path you used for the previous installation of this
application.
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•

If a bit variant of PDC is different than the one that is already installed, the existing PDC
installation must first be uninstalled.
Example: If the 32-bit PDC variant is installed and you want to install the 64-bit variant,
then you must first uninstall the previous 32-bit variant.

4. To restore the configuration, complete the following substeps.
1. Open a command prompt window as an administrator and navigate to the directory that
contains the contents of the PDCUpdater.zip file.
2. Type the following command. restoreConfiguration.cmd <back up directory>
Note Use the backup directory that you previously specified to take a backup of your settings.
5. To replace copied and renamed PDC executable with the executable of the newer version, a
command file is provided. Complete the following substeps.
1. Unzip the content of Update620.zip file into the PDC installation directory. A folder named
Update620 is created below the Admin directory.
2. Open a command prompt window as an administrator and navigate to the PDC installation
directory.
3. Navigate to Admin\Update620.
4. Type the following command.
PDCSystemsAndConfigurationUpdate.cmd

6. Update the language resources.
If you run PDC Studio and Client in a language other than German or English, you must update the
corresponding language resources.
To update the language resources, complete the steps described in Install the language pack
resources.
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Update PDC WebClient installation from Version 6.1.x to Version 6.2.0
Update a virtual directory on the web server
To update to version 6.2.0, complete the following steps on the web server.
1. Unzip PDC 6.2.0 WebClient from the Windows.zip file to a local directory.
2. From the PDC.WebClient directory, copy the following files to the physical directory corresponding to
the virtual IIS directory.
•

PDC.WebClient.xap

•

PDC.WebClient.html

3. Optional. If Firefox web browser is used, complete the following substeps.
1. In the virtual directory IIS, open the PDC.WebClient.xml file with an UTF-8 compatible editor.
2. Find the following line.
<add key="supportedFirefoxProductVersion" value="x.x.x" />.
3. Change value to the current supported Firefox version “39.0”.
<add key="supportedFirefoxProductVersion" value="39.0" />.

Update WebClient
To update WebClient, complete the following steps.
1. Uninstall the program Perceptive Document Composition Silverlight 5.
2. Install the PDC.WebClientEnableFullTrust MSI delivered with PDC release 6.2.
3. Ensure that the used web browser does not retain files of old versions in the browser cache. To test if
the latest PDC WebClient is running in the browser, complete the following substeps.
1. Start PDC WebClient and under the main menu, select Options.
2. In the Options dialog box, select Loaded Assemblies.
3. Ensure that all assemblies starting with ” ModusSuite.Silverlight” name have the version number
6.2.0.

Install PDC
This section of the guide provides information on the installation of PDC.

Installation package
The installation package contains the following files.
•

PDC Setup 6.2.0 for Windows (32bit).exe. This executable file installs PDC on a Windows system
as a 32-bit application. You must use this file if you want to run PDC in 32-bit compatibility mode
(WOW64) on a 64-bit Windows OS. The drivers used by PDC to access other systems must be
installed in the 32-bit version.
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•

PDC Setup 6.2.0 for Windows (64bit).exe. This executable file installs PDC on a 64-bit Windows
OS as a native 64-bit application. The drivers used by PDC to access other systems must be installed
in the 64-bit version.

Prerequisites
This section provides license information to install PDC on Microsoft SQL server or Oracle database.
PDC License
If you do not have a valid PDC license, send an email to Hyland Support and request for a license for
your environment.
Copy the license file to the PDC installation directory and ensure that the file name is PDC.lic.
MS SQL Server
•

An empty database for the Odin/MWS DB schemas.

•

An empty database for the repository DB schema.

•

The SQL Servers authentication mode must be active.

•

To run the setup, the password of the used account (SA administrator or an account, which is
member of the SQL server role db_creator) is required.

Oracle
•

Run the Ora_Odin_CreateUser.sql script to create an Oracle user for the database in which the
DB schema is to be installed.
You can find the script in the subdirectory Admin\Oracle.

•

Run the Ora_Rep_CreateUser.sql script to create an Oracle user for the database in which the
DB schema is to be installed.
You can find the script in the subdirectory Admin\Oracle.

•

You must have SYSDBA permissions to run the script.

PDC setup
•

To execute an unattended installation, see the Unattended Installation section.

•

To install the PDC Studio component only, skip this section and continue to the Install PDC
Studio only section.

•

To install the PDC Client component only, skip this section and continue to the Install PDC Client
only section.

•

To install PDC on your system, complete the following steps. You can run the 32-bit setup on a
64-bit operating system in 32-bit mode.

1. Perform one of the following actions.
•

For Windows 32-bit systems, double-click the PDC Setup 6.2.0 for Windows (32bit).exe file.

•

For Windows 64-bit systems, double-click the PDC Setup 6.2.0 for Windows (64bit).exe file.

2.

If you run 32-bit setup on 64-bit operating system, in the Perceptive Document Composition
Setup dialog box, click Yes.

3.

Optional. In the dialog box, click Install if Microsoft Visual Studio Tools for Office Runtime tool is not
installed on your system,
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4.

In the Welcome to the Perceptive Document Composition Setup Wizard page, click Next.

5.

In the License Agreement page, review the terms in the License Agreement, scroll to the end of the
agreement, click I accept the terms in the license agreement, and click Next.

6.

In the Destination Folder page, accept the default directory, and click Next or click Change to
select an alternate directory.

7.

In the Setup Type page, click Complete to install all PDC features or click Custom to choose the
PDC features you want to install. If you want to choose the PDC features to install, complete the
following substep.

8.

In the Custom Setup page, you can select the following PDC features. Note that you can select
more than one feature.

9.

•

PDC Server. Installs the server component of Document Composition.

•

PDC Studio. Installs the complete design environment of Document Composition.

•

PDC Client. Installs the client component of Document Composition.

In the Ready to Install the Program page, click Install.

10. In the Perceptive Document Composition Installation Completed page, click Finish.

PDC setup assistant (PDC Server)
To configure your PDC server and install the required databases, complete the following steps.
1. In the installation directory, double-click PDC.SetupAssistant.exe file and in the PDC Setup tab,
click Next.
2. In the Perceptive Document Composition License page, select the PDC license file.
3. In the Perceptive Document Composition Database page, click Next. The PDC Database Setup
page launches to install the repository.
4. In the PDC Database Setup page, verify the PDC Repository installation prerequisites. Each step in
the list must show OK before you can proceed to the next page. In case of errors, resolve all
indicated errors and click Test.
5. In the Select procedure page, click Next and in the Database connection page, select one of the
following database products and click Modify Connection.
•

MS SQL Server. For details on MS SQL server connection, see the MS-SQL server connection
section.

•

Oracle. For details on Oracle connection, see the Oracle connection section.

6. Click Next and in the Creating the system page, complete the following substeps.
1. In the System Name box, type the name of the Document Composition system you want to
create and in the SystemObjectID box, type the ID of the Document Composition system you
want to create.
2. Optional. In the Database Alias box, change the predefined value.
7. Click Next and in the Installation page, click the Start installation.
8. When the PDC Database setup is complete, click OK.
9. In the PDC Odin or MWS Database page, click Next. The PDC Database Setup page launches to
install the Odin and MWS database.
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10. In the Repository Setup page, verify the installation prequisites. Each step in the list must show OK
before you can proceed to the next page. In case of errors, resolve all indicated errors and click Test.
11. Click Next and in the Select procedure page, click Next.
12. In the Database connection page, select one of the following database products and In the
Installation page, click the Start installation.
•

MS SQL Server. In the SQL Server Connection page, complete the following substeps.
1. In the Server box, type the name of the SQL Server instance and complete the following
substeps.
1. In the User box, type the name of the database user you want to use to create the
database schema and in the Password box, type the password of the database user.
2. Select the Use Windows authenticaton check box.
2. In the Database box, type the name of the SQL Serever database to which you want to
install the repository database schema and click the Test Database Connection and click
OK.

•

Oracle. In the Oracle Connection page, complete the following substeps.
1. In the Server box, type the name of the Oracle server instance.
2. In the User box, type the name of the database user you want to use to create the database
schema and in the Password box, type the password of the database user.
Note Use the “user” that was created by the Ora_Rep_CreateUser.sql script because
the user must have specific permissions.
3. In the SqlPlus Path box, select the path to the SqlPlus.exe Oracle program.The SqlPlus.exe
file is required to execute the Oracle SQL scripts.
4. Click Test Database Connection and click OK.

13. When the Odin/MWS database is complete, click OK.
14. In the PDC System Selection page, select the base system and click Next.
15. In the PDC Software Configuration page, to select the location of the PDC services, perform one of
the following actions.
•

Select Local.

•

Select Specific workstation, and in the Computer name box, type the computer name.

16. In the PDC Microsoft Word Template page, select the required Normal.dotm file and click Next.
17. In the PDC Database Alias Configuration page, to the right of the MWS connection string box,
click the Edit.
18. In the Data Link Properties dialog box, complete the following substeps.
1. Under Data Provider, select one of the following data providers.
• Native SQL for MS SQL Server
• Microsoft Oracle for an Oracle database
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2. Click the Ellipsis
button to the right of the Connection String box and in the Connection
Properties dialog box, enter the connection information, click the Test connection, and click
OK.
19. In the PDC Database Alias Configuration page, to the right of the Odin connection string box,
click Edit and repeat the previous steps and click Next.
20. In the PDC Odin Language Selection page, select the preferred language and click Next.
21. In the PDC Service Administration page, select one of the following options and click Next.
•

Start or restart the services

•

Stop the services

22. In the PDC Assistant Completion page, select one of the following optoins and click OK.
•

Restart the assistant

•

Close

MS-SQL server connection
To complete the MS-SQL server connection, in the SQL Server Connection page, complete the
following steps.
1. In the Server box, type the name of the SQL server instance.
2. Complete one of the following substeps.
•

In the User box, type the name of the database user you want to use to create the database
schema and in the Password box, type the password of the database user.

•

Select the Use Windows authentication check box.

3. In the Database box, type the name of the SQL server database in which you want to install the
repository database schema
4. Click the Test Connection and click OK.
5. In the User Information for Database Alias page, perform either of the following actions and click
Next.
•

To use the credentials specified in the previous step to access the repository, select the Apply
user from previous step check box.

•

To use the logged on Windows user to access the repository, select the Use Windows
authentication check box.

•

To specify another user to access the repository, select the Use SQL Server authentication
check box and complete the following substeps.
1. In the User box, type the user name.
2. In the Password box, type the password.

Oracle connection
To complete the Oracle connection, in the Oracle Connection page, complete the following steps.
1.

In the Server box, type the name of the Oracle server instance.
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2. In the User box, type the name of the database user you want to use to create the database
schema.
Note Use the name of a user that was created by the Ora_Rep_CreateUser.sql script because
the user must have specific permissions.
3. In the Password box, type the password of the database user.
4. Click the Test Connection and click OK.

Permission configuration (PDC Server)
In the PDC server, ensure that the following security settings for the PDC installation directory are set.
•

The Users user group must be assigned Full control.

Confirm PDC.WordAddIn installation (PDC Studio)
The PDC Setup delivers the PDC.WordAddIn. This add-in for Microsoft Word provides the PDC tab that
enables the user to insert text block variables directly into a Word document.
Most combinations of Microsoft Windows and Microsoft Word installations require confirmation of the addin installation. To confirm the installation of PDC.WordAddIn, complete the following steps.
1. Start Microsoft Word.
2. If the Microsoft Office Customization Installer dialog box appears, click Install.
3. On the toolbar, click File > Options.
4. In the left pane, click Add-ins. If PDC.WordAddIn is already installed on your system, PDC Word
AddIn exists under Active Application Add-ins.
If there are issues in installing the PDC Word-AddIn, complete the steps described in the Troubleshooting
PDC Word Add-In section.

Modify the registry
To execute PDC processes that uses print functionality in a Windows service , you must modify a registry
setting if PDC runs in 32-bit mode on one of the following systems.
•

Windows 8.x (64-bit)

•

Windows 2012 Server

•

Windows 2012 Server R2

To modify the registry, see the knowledge base article 2954953 on the Microsoft knowledge base
website.

Install PDC Studio only
To install and customize PDC Studio only, without Client or Server components, complete the steps in the
following sections.
Prerequisite To install PDC Studio, a PDC Server installation is required.
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Install PDC Studio
To install the PDC Studio application, complete the following steps.
1. Perform one of the following actions.
•

For Windows 32-bit systems, double-click the PDC Setup 6.2.0 for Windows (32bit).exe file.

•

For Windows 64-bit systems, double-click the PDC Setup 6.2.0 for Windows (64bit).exe file.

2. Optional. In the dialog box, click Install if Microsoft Visual Studio Tools for Office Runtime tool is not
installed on your system,
3. In the Welcome to the Perceptive Document Composition Setup Wizard page, click Next.
4. In the License Agreement page, review the terms in the License Agreement, scroll to the end of the
agreement, click I accept the terms in the license agreement, and click Next.
5. In the Destination Folder page, accept the default directory, and click Next or click Change to select
an alternate directory.
6. In the Setup Type page, click Custom.
7. In the Custom Setup page, select the PDC Studio feature.
8. In the Ready to Install the Program page, click Install.
9. In the Perceptive Document Composition Installation Completed page, click Finish.

Configure PDC setup assistant (PDC Studio)
To configure your PDC installation, complete the following steps.
1. In the installation directory, double-click the PDC.SetupAssistant.exe file.
2. On the PDC Setup tab, click Next.
3. In the PDC Software Configuration page, to select the location of the PDC services, in the
Computer name box, type the computer name.
4. In the PDC System Selection page, select the base system and click Next.
5. In the PDC Microsoft Word Template page, select the required Normal.dotm file and click Next.
6. In the PDC Assistant Completion page, select one of the following options and click OK.
•

Restart the assistant

•

Close

Confirm PDC.WordAddIn installation
The PDC Setup delivers the PDC.WordAddIn. This add-in for Microsoft Word provides the PDC tab that
enables the user to insert text block variables directly into a Word document.
Most combinations of Microsoft Windows and Microsoft Word installations require confirmation of the
PDC Word AddIn installation. To confirm the installation of PDC.WordAddIn, complete the following steps.
1. Start Microsoft Word.
2. If the Microsoft Office Customization Installer dialog box appears, click Install.
3. On the toolbar, click File > Options.
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4. In the left pane, click Add-ins. If PDC.WordAddIn is already installed on your system, PDC Word
AddIn exists under Active Application Add-ins.
If there are issues in installing the PDC Word Add-In, complete the steps described in the
Troubleshooting PDC Word Add-In section.

Start the Core service
The configuration is changed such that the Core service can start. To start the Core service, complete the
following step.
•

Open Windows Services and start the Modus_Core service.

Start PDC Studio
When the service starts, click Start > All Programs > Perceptive Document Composition >
Perceptive Composition Studio to start the Studio.
If you start the PDC Studio for the first time, important controls, such as the Navigator, are not visible. To
display these controls, complete the following steps.
button.

1. On the Studio tab, click the Navigator

2. On the Studio tab, click the Object Inspector
3. On the Studio tab, click the Output
4. On the Studio tab, click the Toolbox

button.

button.
button.

You have now installed and customized PDC Studio with German and English as user languages. To
install additional language packs, see the User Language section. Follow the instructions with all sections
that denote PDC Studio and Client in the heading.

Install PDC Client only
To install and customize PDC Client only, without Studio or Server components, complete the steps in the
following sections.
Prerequisite A PDC Server installation is required.
•

Install PDC Client

•

Configure PDC setup assistant (PDC Client)

Install PDC Client
To install the PDC Client only, complete the following steps.
1. Complete one of the following options.
•

For Windows 32-bit systems, double-click PDC Setup 6.2.0 for Windows (32bit).exe file.

•

For Windows 64-bit systems, double-click PDC Setup 6.2.0 for Windows (64bit).exe file.
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2. Optional. In the dialog box, click Install if Microsoft Visual Studio Tools for Office Runtime tool is not
installed on your system,
3. In the Welcome to the Perceptive Document Composition Setup Wizard page, click Next.
4. In the License Agreement page, review the terms in the License Agreement, scroll to the end of the
agreement, click I accept the terms in the license agreement, and click Next.
5. In the Destination Folder page, accept the default directory, and click Next or click Change to select
an alternate directory.
6. In the Setup Type page, click Custom.
7. In the Custom Setup page, select the PDC Client feature.
8. In the Ready to Install the Program page, click Install.
9. In the Perceptive Document Composition Installation Completed page, click Finish.

Configure PDC setup assistant (PDC Client)
To configure your PDC Client installation, complete the following steps.
1. In the installation directory, double-click the PDC.SetupAssistant.exe file.
2. In the PDC Setup tab, click Next.
3. In the PDC Software Configuration page, to select the location of the PDC services, in the
Computer name box, type the computer name.
4. In the PDC System Selection page, select the base system and click Next.
5. In the PDC Assistant Completion page, select one of the following options and click OK.
•

Restart the assistant

•

Close

Install ODP.NET installation
This section provides information on how to install the ODP.NET driver, based on your operating system.

Advantages of the ODP.Net driver (PDC Server)
PDC supports both Microsoft Oracle driver and ODP.NET driver. The Microsoft Oracle driver is included
in the .Net Framework and is used by default.
The ODP.Net driver offers the following advantages.
•

Better performance

•

Better stability

•

Less memory usage

•

Better scalability

Install the ODP.NET driver (PDC Server)
To install the ODP.Net driver, complete the following steps.
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•

Go to http://www.oracle.com and download the the Oracle Data Provider for .NET Version
ODAC 11.2 Release 3 (11.2.0.2.1) or higher.
o

Use the 32-bit version of the Oracle Provider in case of a 32-bit PDC Installation.

o

Use the 64-bit version of the Oracle Provider in case of a 64-bit PDC Installation.

•

Stop all running PDC services and applications.

•

Install the driver.

•

Go to the PDC installation directory and open the modus_core.exe.config file.

•

Locate the following lines and remove the comment characters and <!-- and -->.

<!-<add
<add
<add
<add
-->

key="rws_UseODP" value="1"/>
key="rws_odp_FetchSize" value="4000000"/>
key="rws_odp_InitialLOBFetchSize" value="131072"/>
key="rws_odp_InitialLONGFetchSize" value="131072"/>

6. Optional. Change the key values.
In a test environment, the predefined values for the parameters rws_odp_FetchSize,
rws_odp_InitialLOBFetchSize, and rws_odp_InitialLONGFetchSize proved ideal. Depending on the
customer installation, it may be necessary to modify these settings.
For more information, see the Oracle website.

Key
rws_UseODP

Description
value="1"

The ODP.NET driver is used.

value="0"

The Microsoft Oracle driver is used.
The following parameters are not taken into
account.

•

rws_odp_FetchSize

•

rws_odp_InitialLOBFetchSize

•

rws_odp_InitialLONGFetchSize

rws_odp_FetchSize

Corresponds to the Oracle FetchSize.parameter

rws_odp_InitialLOBFetchSize

Corresponds to the Oracle InitialLOBFetchSize parameter.

rws_odp_InitialLONGFetchSize

Corresponds to the Oracle InitialLONGFetchSize parameter.

7. Save your changes.
8. Optional. If you use the WCF Console, complete the following substep.
• Navigate to the Document Composition installation directory and open the
PDC.WCF.Console.exe.config file.
9. Locate the following lines and remove the comment characters and <!-- and -->
<!-<add key="rws_UseODP" value="1"/>
<add key="rws_odp_FetchSize" value="4000000"/>
<add key="rws_odp_InitialLOBFetchSize" value="131072"/>
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<add key="rws_odp_InitialLONGFetchSize" value="131072"/>
-->

10. Optional. Change the key values.
In a test environment, the predefined values for the parameters rws_odp_FetchSize,
rws_odp_InitialLOBFetchSize, and rws_odp_InitialLONGFetchSize proved ideal.
Depending on the customer installation, it may be necessary to modify these settings.
For more information, see the Oracle website.

Key

Description

rws_UseODP

value="1"

The ODP.NET driver is used.

value="0"

The Microsoft Oracle driver is used.
The following parameters are not taken into
account.

• rws_odp_FetchSize
• rws_odp_InitialLOBFetchSize
• rws_odp_InitialLONGFetchSize
rws_odp_FetchSize

Corresponds to the Oracle FetchSize parameter.

rws_odp_InitialLOBFetchSize

Corresponds to the Oracle InitialLOBFetchSize.parameter

rws_odp_InitialLONGFetchSize

Corresponds to the Oracle InitialLONGFetchSize.parameter

11. Save your changes.
12. Open the Windows registry.
13. Navigate to the HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\KEY_OraClient11g_home1 path.
14. To determine the HOME directory of the ODP.Net driver, click the ORACLE_HOME key.
15. Access the directory [ORACLE_HOME]\Network\Admin and check if it contains the correct
tnsnames.ora.
16. Restart the PDC services or applications.

User language
This section defines the installation processes you need to follow to install languages, excute the
installation process, and more. See the following sections for additional information.
•

Installation package for language pack resources (PDC Studio and Client)

•

Install the language pack resources (PDC Studio and Client)

•

Set the language for the Odin views (PDC Server)

•

Use PDC in a different language (PDC Studio and Client)

Installation package for language pack resources (PDC Studio and Client)
PDC offers installation packages that allow you to install different language packs on your system.The
language packs for German and English (US) languages are delivered and installed with the product
setup. The following language packs are available.
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•

Dutch

•

French

•

Portuguese (BR)

•

Spanish

Each language pack is available in a 32-bit and 64-bit version.
•

Use the 32-bit specific language pack if the 32-bit PDC setup is installed.

•

Use the 64-bit specific language pack if the 64-bit PDC setup is installed.

Install the language pack resources (PDC Studio and Client)
The user interface of the PDC Studio and Client is available in German and English (US) languages by
default. Before installing PDC language pack resources, you must first install PDC on your system. To
access the user interface of PDC Studio and Client in the following languages, you must install the
corresponding language pack on your system.
To download the required PDC language pack installation package, complete the following steps.
1. Download the language pack from the Customer Portal and save the file locally so that you can
access it during the installation procedure.
2. Locate the required PDC language pack installation package.
3. Save the file locally.
Example
To install a 64-bit Dutch language pack resources for PDC on your system, complete the following steps.
1. Double-click the PDC Dutch Language Pack 64 bit.exe file.
2. In the Welcome to the PDC Dutch Language Pack Wizard page, click Next.
3. In the License Agreement page, review the terms in the License Agreement, scroll to the end of the
agreement, click I accept the terms in the license agreement, and click Next.
4. In the Destination Folder page, click Next.
5. In the Ready to Install the Program page, click Install.
6. In the Perceptive Document Composition Installation Completed page, click Finish.

Set the language for the Odin views (PDC Server)
To set the language for the Odin views, complete the following steps.
1. Open your database management system.
2. Open the ODIN_SETTING table.
3. Change the OD_ISO_LANG_CODE field to one of the following language codes. The language
codes are case-sensitive.
Language Code

Language

en-US

English (US)
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Language Code

Language

fr

French

nl

Dutch

es

Spanish

pt-BR

Portuguese (BR)

Use PDC in a different language (PDC Studio and Client)
You can access PDC Studio or PDC Client in a language other than the one defined in the Windows
system settings.
•

English
To use PDC Studio in English, complete the following step.
•

In the installation directory, in the subdirectory en, double-click the EN_PDC.Studio.cmd file.

To use PDC Client in English, complete the following step.
•
•

In the installation directory, in the subdirectory en, double-click the EN_PDC.Client.cmd file.

German
To use PDC Studio in German, complete the following step.
•

In the installation directory, in the subdirectory de, double-click the DE_PDC.Studio.cmd file.

To use PDC Client in German, complete the following step.
•
•

In the installation directory, in the subdirectory de, double-click the DE_PDC.Client.cmd file.

Dutch
To use PDC Studio in Dutch, complete the following step.
•

In the installation directory, in the subdirectory nl, double-click the NL_PDC.Studio.cmd file.

To use PDC Client in Dutch, complete the following step.
•
•

In the installation directory, in the subdirectory nl, double-click the NL_PDC.Client.cmd file.

French
To use PDC Studio in French, complete the following step.
• In the installation directory, in the subdirectory fr, double-click the FR_PDC.Studio.cmd file.
To use PDC Client in French, complete the following step.
• In the installation directory, in the subdirectory fr, double-click the FR_PDC.Client.cmd file.

•

Spanish
To use PDC Studio in Spanish, complete the following step.
• In the installation directory, in the subdirectory es, double-click the ES_PDC.Studio.cmd file.
To use PDC Client in Spanish, complete the following step.
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• In the installation directory, in the subdirectory es, double-click the ES_PDC.Client.cmd file.
•

Portuguese (BR)
To use PDC Studio in Portuguese (BR), complete the following step.
• In the installation directory, in the subdirectory pt-br, double-click the PT-BR_PDC.Studio.cmd
file.
To use PDC Client in Portuguese (BR), complete the following step.
• In the installation directory, in the subdirectory pt-br, double-click the PT-BR_PDC.Client.cmd
file.

Execute an unattended installation of a language pack
Command-line options that require a parameter must be specified with no space between the option and
its parameter.
For example, Setup.exe /v"/qn" is valid, while Setup.exe /v "/qn" is not.
Quotation marks around an option’s parameter are required only if the parameter contains spaces. If a
path within a parameter contains spaces, you may need to use quotation marks within quotation marks.
For example, Setup.exe /v"INSTALLDIR=\"c:\My Files\"".
•

Use the 32-bit specific language pack if the 32-bit PDC setup is installed.

•

Use the 64-bit specific language pack if the 64-bit PDC setup is installed.

•

Specify with the parameter INSTALLDIR the PDC installation directory. The language pack is
installed into a subdirectory of this directory.

To perform silent installation of PDC language pack setup, complete the following steps.
1. Start a command prompt as an administrator
2. Navigate to the folder that contains the language pack setup file.
3. Execute the following command to install the 64-bit Dutch language pack.
Change the EXE filename for other language packs.
"PDC Dutch Language Pack 64 Bit.exe" /s /v"/qn" /v"/l*v \"c:\PDCSetupLog.txt\""
/v"INSTALLDIR=\"C:\Program Files\PDC\""

Execute an unattended uninstallation of a language pack
Command-line options that require a parameter must be specified with no space between the option and
its parameter.
For example, Setup.exe /v"/qn" is valid, while Setup.exe /v "/qn" is not.
Quotation marks around an option’s parameter are required only if the parameter contains spaces. If a
path within a parameter contains spaces, you may need to use quotation marks within quotation marks.
For example, Setup.exe /v"INSTALLDIR=\"c:\My Files\"".
•

Use the 32-bit specific language pack if the 32-bit PDC setup is installed.

•

Use the 64-bit specific language pack if the 64-bit PDC setup is installed.

To perform silent uninstallation of the PDC language pack setup, complete the following steps.
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1.

Start a command prompt as an administrator

2. Navigate to the folder that contains the language pack setup file.
3.

Execute the following command to uninstall the 64-bit Dutch language pack.
Change the EXE filename for other language packs.
"PDC Dutch Language Pack 64 Bit.exe" /x /s /v"/qn" /v"/l*v \"c:\PDCSetupLog.txt\""

Perform an unattended installation
This section provides information on performing an unattended installation and uninstallation of PDC and
PDC features.
•

Execute an unattended installation of PDC setup

•

Execute an unattended uninstallation of PDC setup

Execute an unattended installation of PDC setup
You can perform a silent installation of PDC setup.
The following table provides a description of the parameters that are used for the silent installation of
PDC setup.
Parameter

Description

/s

Runs the installation in silent mode.

/v”Parameter”

Passes the Windows installer (MSI) parameters to the Windows installer.

You can pass the following parameters to MSI.
/qn

Instructs the installer to perform a silent install without user interaction.

/l*v logfilepath

Sets the path and filename of install log file.

ADDLOCAL=
Component

Specifies the PDC components to install:
•
Install PDC Client. PDCClient
•
Install PDC Studio. Studio32 or Studio64
•
Install PDC Server. Server32 or Server64
Use a comma to separate multiple instructions

Command-line options that require a parameter must be specified with no space between the option and
its parameter.
Examples
Valid. Setup.exe /v"/qn"
Invalid. Setup.exe /v "/qn"

Quotation marks around an option’s parameter are required only if the parameter contains spaces. If a
path within a parameter contains spaces, you may need to use quotation marks within quotation marks.
Example Setup.exe /v"INSTALLDIR=\"C:\Program Files\PDC\""
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To perform silent installation of PDC setup, complete the following steps.
Note For Windows 32-bit systems, replace [xx] with 32, for Windows (64-bit) systems, replace [xx] with
64.
1.

Start a command prompt as an administrator.

2.

Navigate to the folder that contains the file PDC Setup 6.2.0 for Windows ([xx]bit).exe.

3.

Execute one of the following commands.
•

Use the following command to install all PDC components into the directory C:\Program
Files\PDC and create the protocol file:C\PDC Log File.txt
"PDC Setup 6.2.0 for Windows([xx]bit).exe" /s /v"/qn"
/v"INSTALLDIR=\"C:\Program Files\PDC"" /v"/l*v \"c:\PDC Log File.txt\""

•

Use the following command to install only 64-bit PDC Studio
"PDC Setup 6.2.0 for Windows (64bit).exe" /s /v"/l*v \"c:\PDC Log File.txt\""
/v"/qn" /v"INSTALLDIR=\"D:\PDC\"" /v"ADDLOCAL=Studio64"

•

Use the following command to install only 64-bit PDC Studio and PDC Client
"PDC Setup 6.2.0 for Windows (64bit).exe" /s /v"/l*v \"c:\PDC Log File.txt\""
/v"/qn" /v"INSTALLDIR=\"D:\PDC\"" /v"ADDLOCAL=Studio64,PDCClient"

Execute an unattended uninstallation of PDC setup
You can perform silent uninstallation of PDC setup.
The following table provides a description of the parameters that are used for the silent uninstallation of
PDC setup.
Parameters

Description

/x

Uninstalls a product.

/s

Runs the installation in silent mode.

/v”Parameter”

Passes the Windows installer (MSI) parameters to the Windows installer.

You can pass the following parameters to MSI.
/qn

Instructs the installer to perform a silent uninstall.

/l*v logfilepath

Sets the path and filename of install log file.

Command-line options that require a parameter must be specified with no space between the option and
its parameter.
Examples
Valid. Setup.exe /v"/qn"
Invalid. Setup.exe /v "/qn"

Quotation marks around an option’s parameter are required only if the parameter contains spaces. If a
path within a parameter contains spaces, you may need to use quotation marks within quotation marks.
Example Setup.exe v"/l*v \"c:\PDC Log File.txt\""
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To perform silent uninstallation of PDC, complete the following steps.
1. Open a command prompt with elevated trusts and navigate to the folder that contains the file PDC
Setup 6.2.0 for Windows ([xx]bit).exe
2. Execute the following command to completely uninstall PDC.
"PDC Setup 6.2.0 for Windows([xx]bit).exe" /x /s /v"/qn" /v"/l*v c:\Uninstall.txt"

If the PDC Setup.exe file is not available, complete the following steps to uninstall the complete product.
1.

Open a command prompt with elevated trusts.

2.

Execute the following command to completely uninstall PDC.
msiexec /x {4D848AEF-9061-41B5-95D3-93B008626956}

Perform an advanced setup
This section contains information on the setup process that you can execute instead of using the PDC
Setup Assistant. These instructions are intended for experienced users.

Odin or MWS Database Setup
About the setup (PDC Server)
The Odin or MWS setup installs Odin and MWS on a database.
Oracle and MS SQL Server are currently supported.
Notes
•

You must run this application on the computer on which the Document Composition server services
are run.

•

Run the Odin/MWS setup from a user account that has write permission for the Document
Composition installation directory.

Prerequisites
License
If you do not have a valid license, send an email to Hyland Support and request a license file for your
environment. Copy the license file to the Document Composition installation directory and ensure that the
file name is PDC.lic.in your database.
Verify the following information based on your operating system.
MS SQL Server
•

An empty database for the Odin/MWS DB schemas.

•

The SQL Servers authentication mode must be active.

•

To run the setup, the password of the used account (SA administrator or an account, which is
member of the SQL server role db_creator) is required.

Oracle
•

Run the Ora_Odin_CreateUser.sql script to create an Oracle user for the database in which the DB
schema is to be installed. You can find the script in the subdirectory Admin\Oracle.
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•

You must have SYSDBA permissions to run the script.

To install Odin and MWS on a database, you can either use the Database Setup wizard or you can
manually execute the required SQL scripts.

Install Odin/MWS automatically (PDC Server)
To install Odin and MWS on a database using the Database Setup wizard, complete the following steps.
1. In the Document Composition installation directory, start the PDC.Database.Setup.exe.
2. In the Repository Setup page, verify the installation prequisites. Each step of the list must show OK
before you can proceed to the next page.
3. Optional. Resolve all indicated errors and click Test.
4. Click Next.
5. In the Select procedure page, select Create Odin/MWS Schema and click Next.
6. In the Database connection page, select one of the following database products and complete the
appropriate procedure.
•

MS SQL Server
•

In the SQL Server Connection page, complete the following substeps.
1. In the Server box, type the name of the SQL Server instance.
2. In the Database box, type the name of the SQL server database in which you want to
install the repository database schema.
3. Click the Test Database Connection and click Next.

•

Oracle
•

In the Oracle Connection page, complete the following substeps.
1. In the Server box, type the name of the Oracle server instance.
2. In the User box, type the name of the database user you want to use to create the
database schema.
Note Select a user that was created by the Ora_Odin_CreateUser.sql script because
the user must have specific permissions.
3. In the Password box, type the password of the database user.
4. In the SqlPlus Path box, check the path to the SqlPlus.exe Oracle program.
SqlPlus.exe is required to execute the Oracle SQL scripts.
5. Click Test Database Connection and click Next.

7.

In the Select Odin or MWS option page, select one of the following options.
•

Create Odin Schema

•

Create MWS Schema

•

Create Odin and MWS Schema

8. Click Next.
1. In the Installation page, click the Start installation.
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2. When the installation is completed, click OK.

Install Odin/MWS manually on an Oracle database (PDC Server)
Database user
The Oracle user must have the following roles and permissions.
Roles

System permissions

Connect

Create table

Resource

Create view
Create procedure
Create sequence

You can create a corresponding Oracle user by running the Ora_Odin_CreateUser.sql script.
The script can generate the following error messages.
•

ORA-00942. Table or View does not exist

•

ORA-02289. Sequence does not exist

You can ignore these messages. They occur because the SQL scripts contain DROP instructions for
objects that do not exist in the database.

Database schema
The subdirectory Admin\Oracle contains the following files. They are used to create the Odin and MWS
schemes.
•

Ora_Odin5.sql

•

Ora_Mws.sql

Install Odin/MWS manually on an MS SQL Server database (PDC Server)
Database schema
The subdirectory Admin\MS-SQL contains the following files. They are used to create the Odin and MWS
schemas.
•

MSSql_Odin5.sql and

•

MSSql_Mws.sql

Notes
•

Run both scripts from the SA administrator account or use an account that is a member of the SQL
server db_creator role.

•

You may have to create SQL Server databases to run the scripts.

•

You can give the databases any name you want. You need the names of these databases at a later
step in the configuration process. .
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Database user
You must create a database user with the following rights for each database used. This user enables
subsequent access to the schemas mentioned above.
Object

Rights

Tables

INSERT, SELECT, UPDATE, DELETE

Views

SELECT

Stored
Procedures

EXECUTE

The subdirectory Admin\MS-SQL contains an SQL script template MSSql_CreateUser.sql.
You can tailor this script to create a user and SQL Server login for a database on an SQL Server. For
ease of use, simply run the script in SQL Server Management Studio (SSMS).
All the information needed how to perform this action is contained in the script header. The script is used
to create a login for every database catalog used. Only one login is required if both schemas are created
in the same database catalog.

Repository Setup (PDC Server)
The repository setup installs the first Document Composition system on a database.
Oracle and MS SQL Server are currently supported.
Notes
•

You must run this application on the computer on which the Document Composition server services
will be run.

•

Run the repository setup from a user account that has write permission for the Document
Composition installation directory.

Before running the repository setup, ensure that you have a license and one of the following databases.
License
If you do not have a valid license, send an email to Hyland Support and request the license for your
environment.
Copy the license file to the PDC installation directory and ensure that the file name is PDC.lic.
MS SQL Server
•

An empty database for the repository DB schema.

•

The SQL Servers authentication mode must be active.

•

To run the setup, the password of the used account (SA administrator or an account, which is a
member of the SQL server db_creator role) is required.

Oracle
•

Run the Ora_Rep_CreateUser.sql script to create an Oracle user for the database in which the
Document Composition DB schema is to be installed. The script is locared in the subdirectory
Admin\Oracle.
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•

You must have SYSDBA permissions to run the script.

Install the repository (PDC Server)
To install the PDC repository, complete the following steps.
1. In the Document Composition installation directory, start PDC.Database.Setup.exe.
2. In the PDC Database Setup page, verify the PDC Repository installation prequisites. Each step of
the list must show OK before you can proceed to the next page.
3. In case of errors, resolve all indicated errors and click Test.
4. Click Next.
5. In the Select procedure page, select Create Repository Schema.
6. Click Next.
7. In the Database connection page, select one of the following database products and complete the
appropriate procedure.
•

MS SQL Server. In the SQL Server Connection page, complete the following substeps.
1. In the Server box, type the name of the SQL Server instance.
2. In the Database box, type the name of the SQL Server database in which you want to install
the repository database schema.
3. Complete one of the following substeps.
•

In the User box, type the name of the database user you want to use to create the
database schema and in the Password box, type the password of the database user.

•

Select the Use Windows authentication check box.

4. Click the Test Database Connection and click Next.
5. In the User information for Database Alias page, select one of the following options.
•

To use the credentials specified in the previous step to access the repository, select the
Apply user from previous step check box.

•

To use the logged on Windows user to access the repository, select the Use Windows
authentication check box.

•

To specify another user to access the repository, select the Use SQL Server
authentication check box and complete the following substeps.
1. In the User box, type the user name.
2. In the Password box, type the password.

6. Click Next.
•

Oracle. In the Oracle Connection page, complete the following substeps.
1. In the Server box, type the name of the Oracle server instance.
2. In the User box, type the name of the database user you want to use to create the
database schema.
Note Use a user that was created by the script Ora_Rep_CreateUser.sql because the
user must have specific permissions.
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3. In the Password box, type the password of the database user.
4. In the SqlPlus Path box, check the path to the SqlPlus.exe Oracle program.
Note SqlPlus.exe is needed to execute the Oracle SQL scripts.
5. Click Test Database Connection.
6. Click Next.
8. In the Creating the system page, complete the following substeps.
1. In the System Name box, type the name of the Document Composition system you want to
create.
2. In the SystemObjectID box, type the ID of the Document Composition system you want to
create.
Note Enter a unique ID for the new system and write it down. You will need it later during the
configuration.
3. Optional. In the Database Alias box, change the predefined value.
9. Click Next and In the Installation page, click the Start installation.
10. When the installation is complete, click OK.

Modify the Server Configuration
After the repository setup completes, you must enter the System Object ID you entered during the
repository setup in a number of configuration files.

Special settings for Windows Server 2008 or 2012 and Windows 7 or 8 (PDC
Server)
The program PDC.ConfigurationEditor must be run with administrator permissions to save any changes.
To update the PDC.ConfigurationEditor.exe file, complete the following steps.
1. Open the Explorer and navigate to the Document Composition installation folder.
2. Right-click the PDC.ConfigurationEditor.exe file and click Run as administrator.
The application now has explicit administrator permissions and therefore is able to execute write access
on the installation folder.

User Account Control in Windows 7 or Windows 8
If the User Account Control (UAC) is activated under Windows 7 and Windows 8, respectively, programs
are always run using the permissions of a standard user, even if the user is an administrator. This is why
a user does not have the rights assigned to the Administrator role when Studio is started.
To grant the rights of an Administrator role to the user, you must start PDC Studio with “Run as
Administrator” or deactivate the UAC.

Modify UserRepository.config (PDC Server)
To modify the UserRepository.config file, complete the following steps.
1. Under the installation directory, start PDC.ConfigurationEditor.
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2. On the File menu, click Open Configuration.
3. In the Open Configuration File dialog box, select the UserRepository.config file and click Open.
4. In the upper pane, in the Value column, double-click the System Object ID value and enter the
system object ID you entered during setup.
5. To save your changes, under the File menu, click Save Configuration.

Modify Modus_MWS.exe.config (PDC Server)
To modify the Modus_MWS.exe.config file, complete the following steps.
1. Under the installation directory, start PDC.ConfigurationEditor.
2. On the File menu, click Open Configuration.
3. In the Open Configuration File dialog box, select the modus_MWS.exe.config file and click Open.
4. In the upper pane, in the Value column, double-click the System Object ID value and enter the
system object ID you entered during setup.
5. To save your changes, under the File menu, click Save Configuration.

Specify Normal.dotm (PDC Server)
You must copy Normal.dotm to the installation directory that you specified in the Destination Folder page
during the PDC Setup procedure.

Modify PDC.Client.exe.config (PDC Client)
To modify the PDC.Client.exe.config file, complete the following steps.
1. Under the installation directory, start PDC.ConfigurationEditor.
2. On the File menu, click Open Configuration.
3. In the Open Configuration File dialog box, select the PDC.Client.exe.config file and click Open.
4. In the upper pane, in the Value column, double-click the Odin View System Object ID value and
enter the system object ID you entered during setup.
5. Optional. You must change the corresponding URL based on whether a service is running on a
different computer. Replace the local IP address (or localhost) with the IP address (or name) of the
server on which the service is run. Specifically, you need to change the URLs localhost entry to the
specific server host name or IP address for the following entries.
•

Data Provider Service

•

License Service

•

Login Service

•

Modus User Service

•

Modus Web Service

•

Modus Web Service Repository

•

Odin Web Service

•

Security Token Service
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Example
If the Document Composition Server service is on the PDCServer host, you must change the Security
Token Services URL from http://localhost:8000/sts to http://PDCServer:8000/sts.
To change the URL, perform one of the following actions.
•

To change the URLs for all services, complete the following steps.
1. Under Tools, click Adapt all Service URLs.
2. In the Adapt Service URLs dialog box, type the URL and click OK.

•

To change a specific URLs of a service, complete the following steps.
1. In the Value column, double-click the value you want to change.
2. Type the URL.

6. To save your changes, on the File menu, click Save Configuration.

Modify PDC.Studio.exe.config (PDC Studio)
To modify the PDC.Studio.exe.config file, complete the following steps.
1. Under the installation directory, start PDC.ConfigurationEditor.
2. On the File menu, click Open Configuration.
3. In the Open Configuration File dialog box, select the PDC.Studio.exe.config file and click Open.
4. Optional. You must change the corresponding URL based on whether a service is running on a
different computer.Replace the local IP address (or localhost) with the IP address (or name) of the
server on which the service is run. Specifically, you must change the localhost entry of the URL to the
specific server host name or IP address for the following entries.
•

Data Provider Service

•

License Service

•

Login Service

•

Modus Web Service Repository

•

Odin Web Service

•

Repository Service

•

Security Token Service

Example
If the Document Composition Server service is on the PDCServer host, you need to change the
Security Token Services URL from http://localhost:8000/sts to http://PDCServer:8000/sts.
To change the URL, perform one of the following actions.
•

To change the URLs for all services, complete the following steps.
1. On the Tools menu, click Adapt all Service URLs.
2. In the Adapt Service URLs dialog box, type the URL and click OK.

•

To change a specific URLs of a service, complete the following steps.
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1. In the Value column, double-click the value you want to change.
2. Type the URL.
5.

To save your changes, on the File menu, click Save Configuration.

Start the Core service (PDC Studio)
To start the PDC Core service, complete the following steps.
1. Open Windows Services.
2. Start the Modus_Core service.

Start Studio (PDC Studio)
If the service starts, you can now start PDC Studio by completing the following step.
•

Navigate to Start > All Programs > Perceptive Document Composition > Perceptive
Composition Studio.

Note If you start PDC Studio for the first time, important controls, such as the Navigator, are not visible.
To display these controls, complete the following steps.
button.

1. On the Studio tab, click the Navigator

2. On the Studio tab, click the Object Inspector
3. On the Studio tab, click the Output
4. On the Studio tab, click the Toolbox

button.

button.
button.

Submit connection data for the Odin or MWS database in the configuration (PDC
Server)
In PDC Studio, complete the following steps.
1. In the top left, click the Select System

button.

2. In the Select System dialog box, select the system and click OK.
3. In the Administration tab, click the DB Alias Administration
Odin database connection, complete the following substeps.

button. To configure the MWS or

1. In the DB Alias Administration pane, double-click MWS or Odin.
2. In the Data Link Properties dialog box, complete the following substeps.
1. Under Data Provider, select on of the following data providers.
•

Native SQL for MS SQL Server

•

Microsoft Oracle for an Oracle database

2. In the SQL Template field, click the Standard Value. The default value is inserted.
3. In the SQL Field Template field, click the Standard Value. The default value inserted.
4. Click the Ellipsis

button to the right of the Connection String box.
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5. In the Connection Properties dialog box, enter the connection information for the DB user
previously created for the respective schema using the Ora_Odin_CreateUser.sql script or
the MSSql_CreateUser.sql script.
6. Ensure that you select the Allow saving password option.
7. Click OK.
3. Repeat the previous steps for Odin or MWS DB alias and save your changes.

Start the services
To start the PDC services, complete the following steps.
1. Open Windows Services.
2. Start the Modus_Core service.
3. Start the Modus_Mws service.
4. Start the Modus_Ows service.

Modify PDC.Studio.exe.config
To modify the PDC.Studio.exe.config file, complete the following steps.
1. Under the installation directory, start PDC.ConfigurationEditor.
2. On the File menu, click Open Configuration.
3. In the Open Configuration File dialog box, select the PDC.Studio.exe.config file and click Open.
4. Optional. You must change the corresponding URL based on whether a service is running on a
different computer. Replace the local IP address (or localhost) with the IP address (or name) of the
server on which the service is running. Specifically, you must change the localhost entry of the URL
to the specific server host name or IP address for the following entries.
•

Data Provider Service

•

License Service

•

Login Service

•

Modus Web Service Repository

•

Odin Web Service

•

Repository Service

•

Security Token Service

Example
If the Document Composition Server service is on the PDCServer host, you must change the Security
Token Services URL from http://localhost:8000/sts to http://PDCServer:8000/sts.
5. To change the URL, perform one of the following actions.
• To change the URLs for all services, complete the following steps.
1. On the Tools menu, click Adapt all Service URLs.
2.

In the Adapt Service URLs dialog box, type the URL and click OK.
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• To change a specific URLs of a service, complete the following steps.

•

1.

In the Value column, double-click the value you want to change.

2.

Type the URL.

To save your changes, on the File menu, click Save Configuration.

Modify PDC.Client.exe.config
To modify the PDC.Client.exe configuration file, compete the following steps.
1. Under the installation directory, start PDC.ConfigurationEditor.
2. On the File menu, click Open Configuration.
3. In the Open Configuration File dialog box, select the PDC.Client.exe.config file and click Open.
4. In the upper pane, in the Value column, double-click the Odin View System Object ID value and
enter the system object ID you entered during setup.
5. Optional. You must change the corresponding URL based on whether a service is running on a
different computer. Replace the local IP address (or localhost) with the IP address (or name) of the
server on which the service is running. Specifically, you must change the localhost entry of the URL
to the specific server host name or IP address for the following entries.
•

Data Provider Service

•

License Service

•

Login Service

•

Modus User Service

•

Modus Web Service

•

Modus Web Service Repository

•

Odin Web Service

•

Security Token Service
Example
If the Document Composition Server service is on the PDCServer host, you must change the
Security Token Services URL from http://localhost:8000/sts to http://PDCServer:8000/sts.

6. To change the URL, perform one of the following actions.
•

To change the URLs for all services, complete the following substeps.
1. On the Tools menu, click Adapt all Service URLs.
2. In the Adapt Service URLs dialog box, type the URL and click OK.
3. To save your changes, on the File menu, click Save Configuration.

•

To change a specific URL of a service, complete the following substeps.
1. In the Value column, double-click the value you want to change.
2. Type the URL.
3. To save your changes, on the File menu, click Save Configuration.
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PDC Client with German as the user language is now installed on your system. To install additional
language packs, see the User Language section.

Troubleshooting
If an issue occurs during installation, use the following information to aid with troubleshooting.

Troubleshooting PDC Word Add-In
If the PDC Word Add-In is not successfully installed using the setup, execute the following steps.
1. Close all running instances of MS Word and PDC Studio.
2. Navigate to Windows > Control Panel > Programs and features.
3. In the list of installed programs, search for the entry “PDC.WordAddIn”, and uninstall the program.
4. Open Windows Explorer and navigate to your PDC Studio installation directory.
5. Double-click the PDC.WordAddIn.vsto file. This installs the PDC Word Add-In.
6. Start MS Word. To check if PDC Add-In is activated, perform the following substeps.
1. Under the File menu, select Word options.
2. In the left pane, select Add-Ins.
3. Under Active Application Add-ins, search for “PDC Add-In”. If it is available, PDC Word Add-In
is active in your system.
7. If PDC Add-In is listed under Inactive Application Add-ins, then execute the following substeps.
1. Select PDC Add-In.
2. Click Go. In the dialog box, select the PDC Add-In box and click OK. The PDC Word Add-In is
now active on your system.
3. If an error message is displayed, click Details, take a screenshot of the error message, and send
it to the Support services.
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