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Overview
ImageNow, version 6.6, contains new products, features, and product enhancements. This guide
provides an overview of each of these areas. This guide contains the following sections:
•

“New Products and Features” introduces the new functionality available in your ImageNow 6.6
system. This section is for ImageNow users and administrators.

•

“Product Enhancements” provides an overview of the enhancements made to existing features. This
section is for ImageNow users and administrators.

ImageNow Product Help is updated with every release. When you open ImageNow, WebNow, or any of
our other products and press F1, help topics appear for the product you have. If you have additional
privileges, such as management privileges, you can display the Administrator Help topics in ImageNow
Client as well as the User Help topics.
In addition, you can go to the Customer Portal on our website to view Product Documentation for a
particular version. This Product Documentation includes Help, Installation Guides, Getting Started
Guides, Technical Papers, Technical Specifications, Best Practice Papers, and Readmes.

New Products and Features
This section highlights, in alphabetical order, new products and features available in ImageNow, version
6.6.

64-bit support
To provide improved performance and additional memory capacity, ImageNow Server is now available as
a native 64-bit application on the Microsoft Windows Server platform.
Note When you install ImageNow Server on a 64-bit platform, you must install all external agents on a
supported 32-bit environment. 64-bit support is limited to ImageNow Server for the 6.6 release. Add-on
agents such as Message Agent and Fax Agent are 32-bit applications and should be remotely connected
to a 64-bit server.
For product technical specifications and system requirements, refer to the Product Technical
Specifications for your product version. This document is available on the Product Documentation tab of
the Customer Portal on www.perceptivesoftware.com.

Interact for Lexmark
Interact for Lexmark is now available for ImageNow version 6.5 and 6.6. Interact for Lexmark is a
software application that allows you to use a wide range of Lexmark multifunction products (MFPs) to
convert paper documents to electronic images, index them, and store them in an ImageNow system—all
with a few button clicks on the printer's control panel. Once captured, the document is immediately
available for subsequent retrieval and optional workflow processing using ImageNow Client or WebNow.
For more information on using Interact for Lexmark, refer to the Interact for Lexmark Getting Started
Guide. For more information on installing and configuring Interact for Lexmark, refer to the Interact for
Lexmark Installation and Setup Guide.
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Product Enhancements
This section provides an alphabetically listed overview of enhancements made to existing functionality.

Accounts Payable
The following accounts payable enhancements are available in ImageNow 6.6.

Lawson Advanced Connector
This release of ImageNow introduces the Lawson Advanced Connector, which is an extension to
ImageNow that provides functionality to upload staged data from Lawson to virtual tables in the
ImageNow database for use with Accounts Payable Invoice eForms.
For information on installing and configuring the Lawson Advanced Connector, refer to the Lawson
Advanced Connector Installation Guide.

Super queues in role configurations
Accounts Payable Invoice eForms now supports super queues in role configurations. Each workflow
queue where a form is used must be listed in the <roles> section of the AP_Skin.xml file in the
\inserver6\worksheets\[build folder] directory. This file determines what role the form plays in the workflow
queue and how you view the form.
For more information on using super queues in role configuration, refer to the Accounts Payable Invoice
eForm Configuration Guide.

Administration
In addition to the 64-bit enhancements listed previously in the 64-bit support section of this document,
ImageNow 6.6 contains the following administration enhancements.

64-bit Windows
To support 64-bit Windows servers, ImageNow Server now uses the Microsoft LDAP library instead of the
Netscape LDAP library.
•

The ldap.anonymous.login.enabled setting in the inserverUR.ini and inow.ini files has been removed.
The User Replication Server and the ImageNow Server now attempts an anonymous login if you do
not provide the ldap.login or ldap.password setting. For more information, refer to the User
Replication Agent Installation and Setup Guide and the ImageNow Server and Client Installation and
Setup Guide for your environment.

•

If you are using a Windows Server to connect to LDAP using SSL, there is a new process for
managing the required certificates. For more information, refer to Set up LDAP authentication with
SSL in the Managing ImageNow>Authentication section of Administrator Help.

•

Authentication on Solaris version 10 with SSL is now supported.

Note UNIX and Linux Servers continue to use the Netscape LDAP library.

INUpgradeUtil Command
The new INUpgradeUtil command upgrades overdraft license usage to 6.5 or higher compatibility.
For more information, refer to INUpgradeUtil commands in the Managing ImageNow>Administer using
Command Line Tools section of Administrator Help.
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OSM Agent
ImageNow 6.6 introduces OSM Agent, which provides Object Storage Manager (OSM) functionality to
local agents that do not have direct access to the OSM. The OSM is a key component of the ImageNow
repository architecture, which consists of two primary components: the OSM that stores the content and a
relational database that stores the metadata related to the content.
For more information on using OSM Agent, refer to the ImageNow Content Server Installation Guide.

Silent installers
You can now install the following components unattended, which enables you to perform a custom
installation or use a combination of default and customized settings during installation.
•

Content Server. For more information on installing Content Server unattended, refer to the
ImageNow Content Server Installation Guide.

•

ERM Server. For more information on installing ERM Server unattended, refer to the ImageNow ERM
Installation and Setup Guide.

•

Message Agent. For more information on installing Message Agent unattended, refer to the Message
Agent Installation and Setup Guide,

•

Output Agent. For more information on installing Output Agent unattended, refer to the Output Agent
Installation and Setup Guide for your environment.

Application Plans
The following Application Plan enhancements appear in ImageNow 6.6.

Project mapping
When creating an application plan, you use project mapping to automatically create new projects during
the linking process. Two new options, Document Custom Property and Document Key, are available as
source options for Project Name and Project Type mapping.
Note When you clear the Enable Document Mapping check box on the Document Map tab, the
Document Custom Property and the Document Key options do not appear in the Source list for project
mapping. Also note that the Document Custom Property option only appears in the Source list if a custom
property is linked to the selected document type.
For more information on project mapping, refer to Map a project in the Mapping>Projects section of
Application Plan Designer Help. Also refer to the Application Plan Designer Getting Started Guide.

Split at Delimiter macro
Split at Delimiter is a new macro option available when creating an application plan in Application Plan
Designer. This macro allows you to determine which information in a data string ImageNow should
capture based on a delimiter character. The user specifies the delimiter character, such as a space, carat,
dash, underscore, or slash, and then specifies a number that indicates the location of the delimiter to the
right of the value the user wants to find in the data string. For example, a string might contain the
following data, separated by carats: Default^Folder^^^^^Doc Type^^filename.tif. The Split at Delimiter
macro performs the opposite function as the Concatenation macro.
For information on adding a macro, refer to Add a macro in the Processing>Macros section of Application
Plan Designer Help. For example macros, refer to Macro definitions in the Processing>Macros section of
Application Plan Designer Help.
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Visual Basic scripts for Internet Explorer
When developing an application plan for Internet Explorer using Application Plan Designer, you can use
eight new Visual Basic scripts.
•

IECapture. This function captures the data from Internet Explorer in the form of name and value pairs
and stores them for subsequent searches. It returns the number of pairs found.

•

IEGetNameByIndex. This function returns the name at the specified index.

•

IEGetValueByIndex. This function returns the value at the specified index.

•

IEFindName. This function allows you to search for a name and it returns the location where
ImageNow found the name. It returns -1 if it does not find the name.

•

IEFindNameReverse. This function allows you to search for a name in reverse and it returns the
location where ImageNow found the name. It returns -1 if it does not find the name.

•

IEFindValue. This function allows you to search for a value and it returns the location where
ImageNow found the value. It returns -1 if it does not find the value.

•

IEFindValueReverse. This function allows you to search for a value in reverse and it returns the
location where ImageNow found the value. It returns -1 if it does not find the value.

•

IEGetValuebyName. This function allows you to search for a name and it returns the corresponding
value. It returns an empty string if it does not find the value.

For more information on these scripts, refer to Visual Basic scripts for Internet Explorer in the
Processing>Visual Basic Scripts>Visual Basic Script Examples section of Application Plan Designer Help.

Business Insight
The following Business Insight enhancements are available in ImageNow 6.6.

Create reports from views
Report authors now have the ability to create a new report using the column data defined in an
ImageNow document or project view. This feature is useful for report authors who want to report on
multiple custom properties in a single report or want to define their own SQL statements for report data
not exposed in the ImageNow data source.
Note You can only complete this procedure if you have the Manage Report Authoring privilege and a valid Business
Insight Author license. If you need a Business Insight Author license, contact your Perceptive Software
representative.
For more information, refer to Create a report from a view in the Management Console>Reports section of
Administrator Help.

Import an XML report specification file
You can import an XML report specification file to create a new report.
Note You can only complete this procedure if you have the Manage Report Authoring privilege and a
valid Business Insight Author license. If you need a Business Insight Author license, contact your
Perceptive Software representative.
For more information, refer to Import a report in the Management Console>Reports section of
Administrator Help.

Installation
You can now install Business Insight on Windows Server 2008 Service Pack 2 as a 32-bit application.
You can also now install Business Insight on a 64-bit version of Windows Server 2008 Service Pack 1 or
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Service Pack 2. The application runs as a 32-bit application. For these installations, you must open an
additional port from those specified for Business Insight 6.5 setup and add a new firewall rule. For more
information on system requirements, refer to the Product Technical Specifications for version 6.6.
In this version of Business Insight, the installer automatically creates the ImageNow data source based
on installer values. The installer also automatically deploys the report library. For more information on
Business Insight installation, refer to the ImageNow Business Insight Installation and Setup Guide.

Reports
This version of Business Insight contains the following report enhancements.
•

ImageNow 6.6 gives you the ability to exclude system queues and complete queues in reports. If you
define complete or system queues, you can exclude them from the report. Also, if you define
Automatic System Queues (ASQs), you can exclude them as well. For more information on excluding
queues, refer to the Report Library Catalog.

•

When selecting a range of dates in many reports, you can now select a revolving relative time period,
such as the last seven days. For more information on selecting date ranges for reports, refer to the
Report Library Catalog. For a list of reports where relative time period date selection is available, refer
to the ImageNow 6.5.1 Patch Readme.

•

New reporting data is available for the ImageNow data source view package that allows report
authors to build reports with retention data. For more information on building reports with retention
data, refer to Retention schema definition in the Creating Reports>ImageNow Data Source section of
Business Insight Query Studio Help or Reports Studio Help.

•

When a new package is deployed, the specifications of the existing reports are validated against the
new framework. Previously, when you imported a new package, you had to manually validate report
specifications.

•

This release of Business Insight provides the new reports listed in the following table. For more
information on Business Insight reports, refer to the Report Library Catalog.

Category

Report

Description

Documents under retention hold

This report shows the documents and
document types with an active retention
hold applied.

Retention policy setup

This report shows the configuration of all
selected retention policies.

Document types without retention
policies

This report shows the document types
that are not assigned to a retention policy.

Document disposition report

This report shows the documents that are
scheduled for disposition.

Administration

Document types in projects

This report shows the documents of
required and optional document types
currently present in a project.

Dashboard

AP dashboard

This report shows the documents of
required and optional document types
currently present in a project.

RIM
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Report

Description

Document tasks due in specified
days

This report shows the document tasks
that are due with a certain number of
days, and overdue tasks.

Project tasks due in specified
days

This report shows the project tasks that
are due with a certain number of days,
and overdue tasks.

Task aging report by task
template

This report shows the tasks that due and
overdue within six time boxed periods.

Task snapshot by assigned users
and groups

This report shows the tasks that a specific
group or user is assigned.

Chart deficiencies by physician

This report shows the charts that have
incomplete deficiencies. This report
requires three string custom properties:
Patient name, Account number, and Unit
number.

Document Imaging
ImageNow 6.6 contains the following document imaging enhancements.

Application plans for Fax Agent and SAP ArchiveLink
ImageNow alerts users when they must create an application plan before they can proceed with creating
a capture profile. An application plan must exist before a user can create a capture profile for Fax Agent
or SAP ArchiveLink. If an application plan does not exist for the capture method the user selects in the
Capture Profile Definition wizard, ImageNow redirects the user to create an application plan.
For more information, refer to Create a Fax Agent or SAP ArchiveLink capture profile in the Management
Console>Capture>Capture Capture Profiles section of Administrator Help.

Capture profiles and source profiles for Import Agent
In ImageNow 6.6, users can set up capture profiles and source profiles to import and assign document
keys to documents captured through Import Agent.
For more information on configuring a capture profile, refer to Create an Import Agent capture profile in
the Management Console>Capture>Capture Profiles section of Administrator Help. For more information
on configuring a source profile, refer to Create an Import Agent source profile in the Management
Console>Capture>Capture Profiles section of Administrator Help. For information on configuring Import
Agent and ImageNow Server to handle capture profiles, refer to the "inserverImp.ini" section of the
ImageNow Server and Client Installation and Setup Guide for your environment.

DataCapture profiles
DataCapture indexing is now available through capture profiles. Users now have the ability to set up a
capture profile for ImageNow to automatically assign document keys to documents read by DataCapture.
To assign document keys in a capture profile, the user must set the applicable document key in
inserverDC.ini as <<index provided>>. Then the user creates a capture profile and chooses settings on
the Index Keys tab.
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For more information on DataCapture, refer to the DataCapture Getting Started Guide. For more
information on installing and configuring DataCapture, refer to the DataCapture Installation and Setup
Guide. For more information on creating DataCapture profile, refer to Create a DataCapture profile in the
Other Components>DataCapture section of Administrator Help.

Package Mode
Package Mode now provides the ability to assign document keys (for example, drawer, folder, tab, Field
3, Field 4, Field 5, and Document Type) to documents via capture profile scripts running at the capture
profile level.
Package Mode now enables the ability to select doc type from a list filtered at the basket level
whenever the doc type barcode fails.

Development Tool Expansions
ImageNow 6.6 provides the following enhancements to ImageNow development tools.

iScript
In ImageNow 6.6, iScript contains the following new objects:
•

INRetentionHold. This object enables you to add or remove a document hold or to determine if a
document is on hold. For more information about this object, refer to INRetentionHold in the
Document Imaging Objects section of iScript Help.

•

INProjManager. This object enables you to return an array of all project types. For more information
about this object, refer to INProjManager in the Document Imaging Objects section of iScript Help.

In addition, version 6.6 contains new methods and functions for the following objects: INDocument,
INProjectType, INDocManager, INProject, INTask, and INGroup. For more information about changes
between iScript versions, refer to iScript updates by version in the Document Imaging Objects section of
iScript Help.

INTool explain-VSL command
The new explain-vsl INTool command shows the plain language syntax for VSL text that you can use in
iScript. You can also use command arguments to display a list of search constraints, a list of the VSL
data types, and the first ImageNow product release that supported the data type.
For more information on VSL, refer to What is VSL? in the Administer Using Command Line section of
Administrator Help. For explain-vsl command syntax, refer to INTool commands in the Administer Using
Command Line section of Administrator Help.

Message Agent operations
In ImageNow 6.6, Message Agent contains the following new operations:
•

GET_UNIQUE_ID. Use the input parameters in this operation to return a unique ImageNow ID. If the
request fails, an exception is returned. For more information, refer to GET_UNIQUE_ID in the
Document Service Operations>General Document Operations section of Message Agent Help.

•

INOW_USER_GET_GROUPS. Use the input parameters in this operation get a list of groups from
ImageNow. The output parameters return a list of groups for which the user is a member. Otherwise,
Message Agent returns an exception stating that the user belongs to no groups. For more
information, refer to INOW_USER_GET_GROUPS in the Document Service Operations>General
Document Operations section of Message Agent Help.
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•

INOW_USER_GET_INFO. Use the input parameters in this operation to get user profile information
from ImageNow. The output parameters return information about the user. If the request fails,
Message Agent returns an exception. For more information, refer to INOW_USER_GET_INFO in the
Document Service Operations>General Document Operations section of Message Agent Help.

•

SEND_EXTERNAL_MESSAGE. Use the input parameters in this operation to send an external
message to ImageNow. The output parameters return the external message ID, or possibly an
exception. For more information, refer to SEND_EXTERNAL_MESSAGE in the Document Service
Operations>General Document Operations section of Message Agent Help.

ImageNow API
ImageNow 6.6 provides the following new ImageNow API COM calls:
•

INArchiveCurrentDoc. This API call creates an archive record for the document or workflow item
displayed in the topmost window in ImageNow Viewer according to the given arguments. For more
information, refer to INArchiveCurrentDoc in the Automate ImageNow section of Administrator Help.

•

INOpenAppPlanView. This API call initiates a named application plan and displays the document
results in the ImageNow Explorer grid. For more information, refer to INOpenAppPlanView in the
Automate ImageNow section of Administrator Help.

ImageNow Connector for SAP ArchiveLink
The following ImageNow Connector for SAP ArchiveLink enhancement is available in ImageNow 6.6.
Also refer to Application plans for Fax Agent and SAP ArchiveLink in the Document Imaging section of
this document.

ArchiveLink documents displayed in the ImageNow Viewer
You can configure the SAP Archive from Frontend functionality to ArchiveLink the document or workflow
item displayed in the active ImageNow Viewer window. If you use the front end archiving functionality,
you must use ImageNow Client to perform the archiving and then you may use either the ImageNow
Client or the WebNow Viewer for subsequent viewings.
For more information on SAP ArchiveLink integration, refer to the ImageNow Connector for SAP
ArchiveLink Installation and Setup Guide.

Capture profile support for multiple SAP ArchiveLink repositories
There is now support for individual capture profiles mapped to each ArchiveLink repository defined in
SAP, allowing for unique indexing schemes to be applied to documents archived in different repositories.
You make this functionality available by configuring the insapalink.ini file to establish mappings to
individual Interact for ArchiveLink capture profiles for each ArchiveLink repository defined in SAP.
For more information on SAP ArchiveLink integration, refer to the ImageNow Connector for SAP
ArchiveLink Installation and Setup Guide.

Organize, Search, and View
ImageNow 6.6 contains the following organize, search, and view enhancements.

Active retention hold column in ImageNow Explorer
There is a new column in ImageNow Explorer that displays documents that have an active retention hold
(direct or inherited) applied.
For more information on adding retention columns in ImageNow Explorer, refer to Add retention columns
in the Retention section of User Help.
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Viewer file formats
You can view the file formats listed in the following table in version 6.6.
For more information on supported file types, refer to Supported file formats in the Getting Started>File
Formats section of Administrator Help.
Category

Format

Version

Extension

7-Zip

4.57

7Z

GZIP

2

GZ

Microsoft Compressed Folder

n/a

LZH, LHA

RAR Archive

2.0 through 3.5

RAR

Database

Microsoft Access

95, 97, 2000,
2002, 2003

MDB

Graphic

Digital Imaging and
Communications in Medicine

n/a

DCM

JPEG

n/a

JPG

Macintosh Raster

2

PCT

Truevision Targa

2

TGA

Microsoft Outlook

97, 2000, 2002,
2003

MSG

Microsoft PowerPoint Macintosh

98, 2001, 2004

PPS, POT

Microsoft PowerPoint PC

4

PPS, POT, PPTX,
PPTM, POTX, POTM,
PPSX, PPSM

Microsoft Excel Charts

2, 3, 4, 5, 6, 7

XLS

Microsoft Excel Mac

98, 2001, v.X,
2004

XLS

Microsoft Excel Windows

2.2 through 2007

XLW, XLT, XLA,
XLTX, XLTM, XLAM

OASIS Open Document Format

1, 2³

ODS, SXC, STC

OpenOffice Calc

1, 1.1

SXC, ODS, OTS

StarOffice Calc

6, 7

SXC, ODS

Microsoft Excel Windows XML

2003

XML

Archive

Mail

Presentation

Spreadsheet

Text and
Markup
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Format

Version

Extension

Microsoft Word Windows XML

2003

XML

XHTML

1

XHTML

XML

1

XML

Corel WordPerfect Windows

5, 5.1

WPS

1.0, 2.0, 6, 7, 8,
95, 97,

Microsoft Word Windows

2000, 2002, 2003,
2007

DOT, DOTX, DOTM

Microsoft Word Macintosh

4, 5, 6, 98, 2001,
v.X, 2004

DOT

OASIS Open Document Format

1, 2³

ODT, SXW, STW

Records and Information Management
This release of ImageNow provides the following Records and Information Management (RIM) features.
To view toolbar or menu items related to document holds, you must have an ImageNow Retention license
installed on your system.

Retention holds security
With ImageNow 6.6, the names of the retention hold security privileges changed.
•

The Apply Document Hold privilege was formerly "Assign from Grid." With this privilege, users with
the Apply Document Hold privilege can apply a direct hold to documents.

•

The Remove Document Hold privilege was formerly "Remove from Grid." With this privilege, users
with the Remove Document Hold privilege can remove a direct hold from documents.

•

The Search for Documents on Hold privilege was formerly "Search from Grid." With this privilege,
users with the Search for Documents on Hold can search for documents under a direct or inherited
hold.

For more information on retention hold security privileges, refer to Hold privilege definitions in the
Management Console>Retention Policy Manager>Holds section of Administrator Help.

Apply document holds
This release provides the ability to apply a retention hold to a document from the ImageNow Viewer or
WebNow Viewer and the Project Viewer. You can apply a document hold from several new locations
within ImageNow:
•

ImageNow Explorer grid. From the File menu, from the ImageNow Explorer toolbar, and from the
context menu when you right-click on a document.
Note This enhancement moves the Hold option from the Edit menu to the File menu within the
ImageNow Explorer grid.
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•

ImageNow Viewer or WebNow Viewer. From the File menu, the File toolbar, and the Actions pane.

•

ImageNow Project Viewer. From the Document menu, the Actions pane, the Document toolbar, and
the context menu when you right-click on a document.

For more information on document holds, refer to About document holds in the Retention>Holds section
of User Help. For more information on applying a retention hold to a document, refer to Apply a document
hold in the Retention>Holds section of User Help. For more information on removing a retention hold from
a document, refer to Remove a document hold in the Retention>Holds section of User Help.

Disposition approvals
For each approval level you create within a policy, you can assign approvers to advance the approval
request to the next level. You can now choose to either require approval from all of the listed users or you
can select a number of approvers from those who are listed to advance the approval request.
For more information about approvals and approval levels, refer to About approvers in the Path
Details>Approvers section of Retention Policy Designer Help.

Hold indicator
When you view a document on hold in the Document Viewer, an icon now appears on the status bar. The
icon only appears if the document is on hold.
For more information on document holds, refer to About document holds in the Retention>Holds section
of User Help.

Retention holds toolbar buttons and menu option behavior
You must select a document to enable the Apply Document Hold toolbars and menu options. The options
appear dimmed or hidden when selecting a project.
For more information on the retention hold button, refer to Toolbars within ImageNow or Toolbars within
WebNow in the Getting Started>Shortcuts and Toolbars section of User Help.

WebNow
The following WebNow enhancement is available in this version of WebNow.

Logging
You can now generate logs on a user-by-user basis in WebNow. In a non-cluster environment, you can
set up logging for users connected to WebNow in Log File Manager. In a cluster or non-cluster
environment, you can set up logging for any user in the Webnow.settings file.
For more information on per-user logging, refer to What is per-user logging? in the Logging section of
WebNow Help.

Workflow Designer
The following Workflow Designer enhancements are available in ImageNow, version 6.6.

Convert Form ASQ
A Convert Form ASQ (automated system queue) is a queue that converts standalone and supplemental
form types from HTML to TIF. Converting a form to TIF gives you the ability to annotate or email that
form. For example, suppose you are the director of HR and your department uses a form to capture
employee 401K benefit information. When an employee requests a copy of this information, you can
email the employee the TIF version of the form.
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To convert forms using a Convert Form ASQ, you must have a Forms or Worksheet license. If this license
is not present, the Convert Form queue appears but does not allow you to define a form set. Additionally,
you must install the File Processing Agent on your ImageNow Server. For more information about this
agent, refer to the File Processing Agent Installation and Setup Guide.
For more information on Convert Form ASQs, refer to About Convert Form ASQs, Form types and
Convert Form ASQs, and Create a Convert Form ASQ in the Queues section of Workflow Designer Help.

File Processing Agent
ImageNow File Processing Agent manages the background file processing operation for flattening
ImageNow forms. Using the ImageNow File Processing Agent, you can create automated system queues
in your workflow that convert a form from an HTML to TIF output without requiring customization or
scripting. You can define an unlimited number of form sets within a conversion ASQ. The system
appends the created TIF form as a new page on the document. The TIF page that ImageNow adds to the
document allows annotations, digital signatures, emailing, and exporting. The File Processing Agent is
necessary to create a conversion queue in workflow.
For more information on the File Processing Agent, refer to the File Processing Agent Installation and
Setup Guide.
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