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Introduction

Perceptive DataTransfer is a data matching, review and upload solution that allows you to automatically 
verify, clean up, and enter data extracted from hand-printed paper forms, downloadable web forms, and 
almost any other electronic source. 

You can quickly and accurately upload information into your database, such as online and paper 
applications, recruit cards, SAT scores, ACT scores, GRE scores, and AP scores without the risk of 
creating duplicate student records. 

With Perceptive DataTransfer, you can:

• Import a nearly unlimited range of data files.

• Match input data to records in your database.

• Review potentially matching records side-by-side.

• Upload new or modified information in real-time into your database.

You can customize Perceptive DataTransfer to upload any type of data from any information source in the 
Perceptive DataTransfer source code. 

Refer to the following topics for more information.

• Starting and Logging in to Perceptive DataTransfer on page 17.

• Understanding the Interface on page 18.

• Changing Roles on page 24.

• Changing Workspace Versions on page 24.

• Specifying Preferences on page 24.

• Understanding User Roles and Privileges on page 25.

• Overview of Perceptive DataTransfer Administrative Tasks on page 27.

• Viewing Server Logs on page 28.

• Configuring PDF to TIFF Properties on page 29.

Starting and Logging in to Perceptive DataTransfer
To start and log in to Perceptive DataTransfer, do the following:

1. Start the application by doing one of the following:

• Open a web browser and type the Perceptive DataTransfer location. You can type the location in 
your browser address bar, or you can open it from the browser by selecting File > Open from the 
browser menu. For example, type an address such as http://servername:8080/DataTransfer.

• Double-click the Perceptive DataTransfer shortcut icon, or (in Microsoft Windows) right-click it 
and click Open, or (in Apple Macintosh and Linux) control-click it and click Open.
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By default, there is no shortcut icon. You can create a desktop shortcut, or you can bookmark the 
startup page, to quickly access it when you subsequently log in to the application. 

To add a shortcut on your desktop, do one of the following:

○ In the browser toolbar, click the browser icon that appears to the left of the Perceptive 
DataTransfer URL; then, drag and drop it to the desktop.

○ In Microsoft Internet Explorer, select, from the menu bar, File > Send > Link to Desktop.

○ In Google Chrome, click  and select Create application shortcuts....

○ To bookmark the page, do one of the following:

○ In Microsoft Internet Explorer, select Favorites > Add to Favorites... from the menu bar. 
Then, set the bookmark name and location.

○ In Mozilla Firefox, either select Bookmarks > Bookmark This Page from the menu bar or 

click  in the address bar. Then, set the bookmark name and location.

○ In Apple Safari, click + in the address bar. Then, set the bookmark name and location.

○ In Google Chrome, click  in the address bar. Then, set the bookmark name and location.

The log in screen appears.

2. Type your username and password in the Username and Password fields. Your username and 
password are usually the same as those you use to log in to your administrative system. 

Note  If there are issues starting Perceptive DataTransfer or entering data in the login screen, contact 
your Perceptive DataTransfer system administrator for assistance in establishing the necessary 
connection rights and privileges.

3. Click Log in. 

You are logged in to Perceptive DataTransfer, and the application starts.

You are logged in to Perceptive DataTransfer with your default user role and workspace version in 
which you are working. Specific product functions and features are available depending on the role 
you use and on the workspace version in which you are working.

Note  After 25 minutes of inactivity, you are prompted that you will be logged out within five minutes 
of further inactivity.

Understanding the Interface
When you log into Perceptive DataTransfer, the main application window displays the Job Dashboard. 
The Job Dashboard displays all jobs that are configured for Perceptive DataTransfer and allows users to 
run jobs in batch mode. 
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Figure 1: Perceptive DataTransfer Interface

The Perceptive DataTransfer toolbar provides access to Perceptive DataTransfer features. Refer to the 
following table for a description of the toolbar menu options.
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Table 1: Perceptive DataTransfer Toolbar Elements and Descriptions

Element Description

Perceptive button Contains the following options.

• Open Admin Guide: Provides access to the online PDF version of the 
administrator guide.

• Open User’s Guide: Provides access to the online PDF version of the 
user guide.

• About Perceptive DataTransfer: Provides information about 
Perceptive DataTransfer.

Jobs button Contains the following options.

• Add Job: Allows you to add jobs.

• Recurring Jobs: Allows you to add recurring jobs.

Refer to Configuring Jobs and Processing Records on page 227.

Tools Contains the following options.

• Lookup: Allows you to configure the lookup tool. 

• Check Names: Allows you to configure the check names tool.

• Data Exports: Allows you to configure data exports.

• Logs: Allows you to view log messages about jobs.

• Import History: Allows you to view details about workspace imports.

Refer to Using Perceptive DataTransfer Tools on page 30.
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Configuration Contains the following options:

• Connections: Allows you to configure database connections. Refer to 
Configuring Connection Groups and Database Connections on 
page 74.

• File sources: Allows you to configure servers or SFTP sites that 
contain the input file used for recurring jobs. Refer to Configuring File 
Sources on page 92.

• Procedures: Allows you to configure procedures. Refer to Configuring 
Procedures on page 127.

• Headers: Allows you to configure headers. Refer to Configuring 
Headers on page 100.

• Forms: Allows you to configure forms. Refer to Configuring Forms on 
page 174.

• Notifications: Allows you to configure notifications to be sent when 
various activities occur. For more information, refer to Configuring 
Notifications on page 55.

• ImageNow: Allows you to configure ImageNow index maps. 
For more information, refer to Configuring ImageNow Index Maps 
on page 199.

• Data Providers: Allows you to configure data providers. Refer to 
Configuring Web Service Data Providers on page 157.

• Document Templates: Allows you to create document templates to be 
used in NQL code. For more information, see Configuring Document 
Templates on page 169.

Reports Contains the following options.

• Configure: Allows you to configure reports.

• Schedule: Allows you to configure scheduled reports.

• View: Allows you to view reports.

• For more information, refer to Configuring Reports on page 49.

Table 1: Perceptive DataTransfer Toolbar Elements and Descriptions (Continued)

Element Description
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Preferences Allows you to configure Perceptive DataTransfer preferences; it contains 
the following options.

• Set Default Role: Sets the current user’s role as the default role. 

• Set Default Version: Sets the workspace version of the current user as 
the default version. 

• Record Grid Dimensions: Specifies the number of rows and columns 
per page to display for records returned by a job.

• Filename in Job Name: Appends the filename of the input file to the 
name of a job when you add jobs.

• Verify before running job: Confirms that you want to run the job.

• Display All Match Results: When jobs are run in interactive mode, all 
possible record matches are compiled before the application pauses 
to allow you to review the possible matches.

• Skip Previous Results: Prevents possible match records from being 
displayed twice.

Refer to Specifying Preferences on page 24.

Administration Contains the following options.

• Workspace: Allows you to configure workspaces. Refer to 
Configuring Workspaces on page 205.

• User: Allows you to configure user and administrator privileges. Refer 
to Configuring Users And Privileges on page 63.

• Share Groups: Allows you to configure share groups, which you use 
to share workspaces and workspace objects. Refer to Configuring 
Workspaces on page 205.

• Server Logs: Allows you to view server logs. Refer to Viewing Server 
Logs on page 28.

• Archive: Allows you to configure rules for archiving jobs. Refer to 
Configuring Jobs and Processing Records on page 227.

• System Properties: Contains the following options.

○ System Email: Allows you to configure the SMTP server from 
which email notifications are sent. For more information, refer to 
Configuring Notifications on page 55.

○ PDF to TIFF: Allows you to configure properties for PDF to TIFF 
file conversion. For more information, refer to Configuring PDF to 
TIFF Properties on page 29.

Table 1: Perceptive DataTransfer Toolbar Elements and Descriptions (Continued)

Element Description
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Sorting Columns
For Perceptive DataTransfer dialog boxes or windows that contain tables of information, you can choose 
the columns of information you want to view or hide, sort information alphabetically, and resize the width 
of columns.

To select the columns that are displayed and to sort columns:

1. In the dialog box, point your mouse to the edge of a column and click .

2. Click Sort Ascending to sort information alphabetically in a high to low sequence (A to Z).

3. Click Sort Descending to sort information alphabetically in a low to high sequence (Z to A).

4. Click Columns.

5. Check the checkbox for the column you want to display. 

Resizing Columns
To resize the width of a column, point your mouse over the edge of a column until the mouse pointer 

changes to  ; then, drag and drop your mouse to the desired location to resize the column.

Expanding Panes
You can collapse and expand some panes. For panes on the right side of the application window, click 

 to collapse the pane and click  to expand a collapsed pane; for panes on the left side of the 

application window, click  to collapse the pane and click  to expand the pane.

Refreshing Information

To refresh information in dialog boxes and application windows, click .

Role drop-down box Allows you to change the role into which you are logged into Perceptive 
DataTransfer. Refer to Changing Roles on page 24.

Workspace drop-down box Allows you to change the workspace version that you are using. Refer to 
Changing Workspace Versions on page 24.

Logout button Logs you out of the application.

Table 1: Perceptive DataTransfer Toolbar Elements and Descriptions (Continued)

Element Description
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Changing Roles
From the role drop-down box, select the Perceptive DataTransfer role you want to use.

Changing Workspace Versions
From the workspace drop-down box, select the version you want to use.

When you hover your mouse over a version in the drop-down box, a tooltip appears and displays the 
version description for the version.

Specifying Preferences
Do the following.

• Click Preferences > Set Default Role to set the current user’s role as the default role. When you log 
in to Perceptive DataTransfer, you are logged in using this user role.

• Click Preferences > Set Default Version to set the workspace version of the current user as the 
default version. When you log in to Perceptive DataTransfer, you are logged in using this workspace 
version. 

• Click Preferences > Record Grid Dimensions to specify the number of rows and columns per page 
to display for records when you open a job.

The Record Grid Dimensions dialog box appears. In the Columns Per Page field, type the number of 
columns to display; in the Rows Per Page field, type the number of rows to display. The default value 
for each field is 20. The minimum value you can use is 10, and the maximum is 100.

• Click Preferences > Filename in Job Name to append the filename of the input file to the name of a 
job when you add jobs. For more information about jobs, refer to Configuring Jobs and Processing 
Records on page 227.

• Click Display All Match Results so that when you run jobs in interactive mode, all possible record 
matches are compiled before the application pauses to allow you to review the possible matches.

Typically, for jobs running in interactive mode, each match routine in the associated procedures 
contains a STOP command that pauses job processing, allowing the user to examine the list of 
possible matches for that match routine. When you set this preference, the STOP command is 
skipped, and each match routine will run, adding matches to the list of possible matches. If a match 
routine finds a possible match that is already in the match list, the routine skips the match; the final 
match list does not contain any duplicates.

In addition, the match results also have an associated rank that is displayed in the results panel, in 
the # column.The rank is set by the STORE command in each match routine and indicates which 
match routine found the match. The result list is ordered by ranking—the order in which the match 
routine discovers the matches.

• Click Verify Before Running Job to confirm that you want to run a job. When this option is enabled, 
when you click Run, the Confirm Run dialog box appears and prompts you to confirm that you want 
to run the job.
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• Click Skip Previous Results so that the same possible match record is not displayed twice. For 
example, when you start processing a record, you receive a list of possible matches, one of which is 
John Smith. If none of the matches are correct, you click the Get More Results button and receive the 
next possible set of matches. However, if the next set of matches contains John Smith again, 
Perceptive DataTransfer does not display John Smith as a possible match. 

Understanding User Roles and Privileges
Your user role and privileges determine what you can do with Perceptive DataTransfer.

The workspace version in which you are working and whether workspaces are shared also determine 
what you can do. For example, you cannot configure objects, such as data exports, if you are working in 
a workspace version in staged or active mode. 

For more information about configuring roles and privileges, refer to Configuring Users And Privileges on 
page 63.

Administrator privileges determine if you can do the following.

• Add, configure, and delete users.

• Configure system properties.

• Add, configure, and delete share groups.

• View server logs.

• Add, modify, and delete archive rules.

• View workspace details.

• Modify workspace details.

• Use workspace version control.

○ Create new versions in edit mode.

○ Move versions to test mode.

○ Move versions to staged mode.

○ Move versions to active mode.

• Work with objects within the workspace.

• Add shared objects.

• Modify shared objects.

• Add, modify, and delete file sources.

• Add, modify, and delete connection groups.

• Add, modify, and delete connections.

• Add, modify, and delete headers.

• Add, modify, and delete verification forms.
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• Add, modify, and delete ImageNow index maps.

• Add, modify, and delete data providers.

• Add, modify, and delete document templates.

• Add, modify, and delete procedures.

○ Configure Match logic.

○ Configure Review logic.

○ Configure Upload logic.

○ Configure Match Display logic.

○ Configure Population Selection logic.

User privileges determine if you can do the following.

• Configure the lookup tool.

• Configure the check name tool.

• View data exports.

• Modify data exports.

• Run data exports.

• Export lookups, check names, data exports, log messages, and reports.

• Import workspace versions.

• Run reports.

• Modify reports.

• Modify scheduled reports.

• View report output.

• Delete report output.

• Work within a workspace version.

○ Work within a version in edit mode.

○ Work within a version in test mode.

○ Work within a version in staged mode.

○ Work within a version in active mode.

○ Work within a version in inactive mode.

• Configure jobs.

○ Create new and recurring jobs.

○ Modify recurring jobs.

○ Enable logging of job messages.
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○ Enable job hold status.

○ View archive rules for jobs.

○ Create new records.

○ Create matched records.

○ Suspend records.

• Create notification groups.

• Modify notification groups.

• Work within a specific workspace and with specific workspace objects.

Overview of Perceptive DataTransfer Administrative Tasks
When you configure and administer Perceptive DataTransfer, you generally perform the following steps in 
this order.

1. Define and create the structure of your institution and give privileges for administrators and users to 
access the appropriate Perceptive DataTransfer features.

2. Configure a workspace in which to work. Workspaces can be private or can be used to share objects, 
such as headers and procedures, to reuse them across multiple configurations.

3. Configure the logic that Perceptive DataTransfer uses to determine if there is a potential match 
between a database record and the input data and to determine how information is added or 
uploaded.

4. Determine the type of input data that you will be loading. For example, if you are loading SAT scores 
contained in a CSV file, you are importing a delimited file.

5. Create the header. The header defines the input source. For example, if you are importing a delimited 
file, you configure the header to use the delimited file format for the input file.

6. Configure header variables. These variables define the fields to be loaded from the input file; you 
determine the names and positions of the fields and associate them with a header variable. 

7. Create the verification form, which is used to compare an existing record of information with 
potentially matching information from the input file, side-by-side.

8. Configure jobs, which consist of all information required to process records.
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Viewing Server Logs
You can view a list of server log messages, view the contents of each message, and download messages 
in either.zip or native format.

1. Select Administration > Server Logs.

A dialog box appears and displays the following columns of information.

• File Name: Name of the server log file.

• Size: Size, in Kb, of the log file.

• Last Modified: Date and time on which the file was last modified.

2. To view the contents of a file, select the file you want to view. To select multiple files:

• Click a file and press and hold the Ctrl key as you click each file with your mouse.

• Click a file and press and hold the Shift key as you click another file to select contiguous files.

Right-click the file you want to view and select View. The contents of each file opens in a separate 
tab.

3. To download the file in .zip format, select the file you want to download. To select multiple files:

• Click a file and press and hold the Ctrl key as you click each file with your mouse.

• Click a file and press and hold the Shift key as you click another file to select contiguous files.

Right-click the file and select Download as Zip; then, select the location where you want to save the 
file. When you download multiple files, one .zip file is created that contains all the log files you 
selected.

4. To download the file in the application format in which it was authored, select the file you want to 
download. To select multiple files:

• Click a file and press and hold the Ctrl key as you click each file with your mouse.

• Click a file and press and hold the Shift key as you click another file to select contiguous files.

Right-click the file and select Download Native; then, select the location where you want to save the 
file. 
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Configuring PDF to TIFF Properties
You can configure the properties to use when you use the ImageNowAddDoc or NWAddDoc functions to 
convert a PDF file to a TIFF file. For more information about these functions, refer to Understanding the 
ImageNowAddDoc Function on page 286 and Understanding the NWAddDoc Function on page 291.

To configure properties, do the following.

1. Select Administration > PDF to TIFF.

The Configure PDF to TIFF Properties dialog box appears.

Figure 2: Configure PDF to TIFF Properties Dialog Box

2. In the TIFF DPI field, type the DPI value. Values range from 72 to 720; the default value is 240.

3. From the TIFF Color drop-down box, select the color properties. Options are: Full Color, Gray Scale, 
and Black & White. The default value is Full Color.

4. From the Compression Type drop-down box, select the compression type. Options are: CCITT_RLE, 
CCITT_T_4, CCITT_T_6, PACKBITS, JPEG, and LZW. The default value is JPEG.

5. You can click Reset to reset all values in the dialog box to use the default values.

6. Click OK to save your changes and close the dialog box.
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Using Perceptive DataTransfer Tools

Refer to the following topics for more information.

• Configuring Lookup Values on page 30.

• Configuring Names to Check on page 34.

• Viewing Log Messages on page 39.

• Configuring Data Exports on page 39.

• Viewing the Import History on page 47.

Configuring Lookup Values
Use the lookup tool to specify the data you want to map from the input file to the database. 

You configure the Perceptive DataTransfer logic to substitute the output value for the input value and 
store the output value in your database.

For example, an input file may have a value of Humanities for a department; its corresponding database 
(output) value is HUM. You can use the lookup tool to map Humanities as HUM and then configure code 
to store Humanities as HUM in your database.

Example syntax for configuring the code is:

let $some_var = lookup(“MAJOR”, $MAJR)

When a job is run, lookup mapping for MAJOR determines that the correct output value for Humanities is 
HUM. The variable $some_var contains the value HUM. $MAJR contains Humanities.

For more information about configuring procedures, refer to Configuring Procedures on page 127 For 
detailed information about configuring logic, refer to Programming Concepts on page 261.

You can export lookups to an XML file, and you can import lookups from either a Perceptive DataTransfer 
XML file or a delimited file.

To open the Lookup Administration dialog box, either select Tools > Lookup or click the Lookup button 
in the window that appears when you open or edit jobs. When you click the Lookup button, the Lookup 
Administration dialog box displays the lookup entries for the header that is being used for the job.

You can filter the entries in the Lookup Administration dialog box by header, by field, or by both. Select 
the appropriate header from the Header drop-down box to view entries for that header. Select the 
appropriate field from the Field drop-down box to view entries for that field. 
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Figure 3: Lookup Administration Dialog Box

Adding Lookup Entries
To add a lookup entry, do the following.

1. Select Tools > Lookup.

The Lookup Administration dialog box appears.

2. Click .

The Add Lookup dialog box appears.
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Figure 4: Add Lookup Dialog Box

3. From the Header drop-down box, optionally select the header for which to configure the lookup entry. 
Select No Header if you want to use this entry for all headers.

4. From the Field drop-down box, select the header input variable to use or type the input variable in the 
Field field. This variable corresponds to the field in the input file that you want to map to a database 
valid code (output).

5. In the In field, type the value of the input variable to map to the output value in the Out field.

6. In the Out field, type the output value to map to the input value (specified in the In field).

7. Click Apply.

8. Click OK.

Modifying Lookup Entries
To modify a lookup entry, do the following.

1. Select Tools > Lookup.

The Lookup Administration dialog box appears.

2. Select a lookup entry to modify and either right-click it and select Edit or click .

The Edit Lookup dialog box appears.

3. In the In field, type the input value, which is the value of the input variable to map to the database 
valid code in the Out field.

4. In the Out field, type the database valid code to map to input value (specified in the In field).

5. Click OK.
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Deleting Lookup Entries
To delete a lookup entry, do the following.

1. Select Tools > Lookup.

The Lookup Administration dialog box appears.

2. Select a lookup entry to modify and either right-click it and select Delete or click .

The entry is deleted and is removed from the Lookup Administration dialog box.

Importing Lookup Files
To import lookup entries from a either a Perceptive DataTransfer file or a delimited file, do the following.

1. Select Tools > Lookup.

The Lookup Administration dialog box appears.

2. Click  .

The Import Lookups dialog box appears.

Figure 5: Import Lookups Dialog Box
Perceptive DataTransfer Administrator Guide Page 33 of 301



3. Do one of the following.

• To import a delimited file, do the following.

1. click the Delimited tab.

2. From the Header drop-down box, select the header file to use.

3. From the Field drop-down box, select the header input field or type a new field to create it. 
This variable corresponds to the field in the input file that you want to map to a database valid 
code (output).

4. Specify how the imported file is delimited; either click the Tab radio button or click the 
Specify radio button and then provide a value in the Specify field.

5. In the Upload File field, click Browse... and navigate to the file you want to import.

6. Click Upload.

• To import a Perceptive DataTransfer file, click the Transfer File tab. Then, in the File field, click 
Browse..., navigate to the file you want to import, and select it.

4. Click OK.

The file is imported, and imported lookup values are displayed in the Lookup Administration dialog 
box.

Exporting Lookup Files
To export lookups as an XML file, do the following.

1. Select Tools > Lookup.

The Lookup Administration dialog box appears.

2. Click  .

3. Save the file in the appropriate location.

Configuring Names to Check
You can use the Check Name tool to configure different output values that an input name may have.

You can substitute this output value for the input name within the Perceptive DataTransfer logic.

For example, for an input name Alexandria, you could use Alex or Lexie as substitutions.
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Code syntax is:

CHECKNAME inCNamevar, inFNamevar, outCntvar, outNamevar1, outNamevar2,... outNamevarN

• The first two variables (inCNamevar and inFNamevar) are input variables for which you are 
substituting values. inFNamevar is an optional parameter.

• The third variable (outCntvar) specifies the number (count) of output variables.

• Variables that appear after the third variable (outCntvar) are the output variables.

When the Perceptive DataTransfer logic is run, it searches for matches between the input and output 
variables. If values for output variables are found, the output variables are populated with all variations of 
the input name. If no matches are found, the input name is assigned to the output variables.

For more information about configuring procedures, refer to Configuring Procedures on page 127 For 
detailed information about logic, refer to Programming Concepts on page 261

You can import check name values from and export values to an XML file.

To open the Check Name Administration dialog box, select Tools > Check Names.
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Figure 6: Check Name Administration Dialog Box

Refer to the following topics for more information.

• Adding and Modifying Names on page 37.

• Deleting Names on page 38.

• Importing Names on page 38.

• Exporting Names on page 39.
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Adding and Modifying Names
To add or modify a name, do the following.

1. Select Tools > Check Names.

The Check Name Administration dialog box appears.

2. Do one of the following: 

• To add a new name, click .

The Add New Check Name dialog box appears.

• To modify a name, select the name and click .

The Edit Check Name dialog box appears.

3. To add a new value to the name, do the following:

1. Click .

The New Check Name Value dialog box appears.

2. In the Value field, type the value that the name can have.

Note  You cannot add a value that is already configured for another entry. You can only use a 
value once.

3. Click Apply to add the value to the check name entry.

4. Continue adding values for the name, and then click OK.

4. To modify a value, do the following:

1. Select the value you want to modify and either right-click it and select Edit or click .

The Edit dialog box appears.

2. Type the value in the dialog box and click OK.

5. To delete a value, select the value you want to delete and either right-click it and select Delete or 

click .

The value is deleted and is removed from the dialog box.
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Deleting Names 
To delete a name, do the following.

1. Select Tools > Check Names.

The Check Name Administration dialog box appears.

2. Select the value you want to delete and either right-click it and select Delete or click .

A dialog box appears and prompts you to confirm that you want to delete the name.

3. Click Yes to confirm that you want to delete the name.

The name is deleted, and all its associated values are deleted; the name is removed from the Check 
Name Administration dialog box.

Importing Names
To import names from an XML file, do the following.

1. Select Tools > Check Names.

The Check Name Administration dialog box appears.

2. Click  and select Import.

The Import Check Names dialog box appears.

Figure 7: Import Check Names Dialog Box

3. Click Browse... and navigate to the file that you want to import.

4. Click OK.
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Exporting Names
To export names to an XML file, do the following.

1. Select Tools > Check Names.

The Check Name Administration dialog box appears.

2. Click  and select Export.

3. Save the XML file in the appropriate location.

Viewing Log Messages
You can view log messages that provide information about Perceptive DataTransfer jobs. 

1. Do one of the following:

• In the Job dashboard, select a job and click the Log button.

• In the Job dashboard, right-click a job and select Log.

• In the Job Dashboard, select a job in the table and either right-click it and select Open or click the 
Open button; then, in the window that appears, click Log.

• Select Tools > Logs.

The Log View dialog box appears and displays the following columns of information.

• Job Name: Name of the job.

• Type: Type of log message (error, SQL). To log SQL messages, check the Log SQL checkbox 
in the Add Job dialog box for the appropriate job; refer to Adding New Jobs on page 233.

• Message: Body of the log message.

• User: Username of the user who was logged in.

• Date/Time: Date and time on which the message was logged.

2. To filter messages by job, select the job from the Job drop-down box.

3. To filter messages by type, select the type of log message from the Type drop-down box.

4. To export messages in XML format, click  and then save the file in the appropriate location.

Configuring Data Exports
You can use data exports to create SQL queries to obtain content from any database configured for 
Perceptive DataTransfer. You can save the results and export them to a delimited file.

You can share data exports with other workspaces, and you can import data exports from and export 
data exports to an XML file.
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Figure 8: Data Exports Administrator Dialog Box

Refer to the following topics for more information.

• Adding Data Exports on page 41.

• Configuring and Modifying Data Exports on page 42.

• Copying Data Exports on page 44.

• Deleting Data Exports on page 44.

• Running Data Exports on page 44.

• Extracting Data Exports on page 45.

• Removing Sharing on Shared Data Exports on page 45.

• Rolling Back Data Exports on page 46.

• Importing Data Exports on page 46.

• Exporting Data Exports on page 47.
Perceptive DataTransfer Administrator Guide Page 40 of 301



Understanding Data Export Icons
The following table describes data export icons and their descriptions.

Adding Data Exports
To add and configure a data export, do the following.

1. Select Tools > Data Exports.

The Data Exports Administrator dialog box appears.

2. Click . 

The Add Data Export dialog box appears.

Figure 9: Add Data Export Dialog Box

Table 2: Data Export Icons and Descriptions

Icon Description

Data export is shared.

Data export is shared and has been modified.

Data export is not shared and has been modified.

Data export has not been modified.

If you are working in a workspace version in edit mode, the data export is not shared.
If you are working in a workspace version in a mode other than edit mode, this icon is 
displayed for all data exports. The sharing status is unknown.
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3. Do one of the following.

• To add a new data export, do the following.

1. Click the Add Data Export tab.

2. Type a name in the Name field and click OK.

• To add a data export that is shared by another workspace, do the following.

1. Click the Add Shared Data Export tab.

2. From the Workspace drop-down box, select the workspace that shares the data export you 
want to add.

3. From the Data Export drop-down box, select the shared data export that you want to add.

4. Click OK.

The data export is added and appears in the Data Export Administration dialog box.

Configuring and Modifying Data Exports
1. Select Tools > Data Exports.

The Data Exports Administrator dialog box appears.

2. Either right-click the data export you want to configure and select Edit or click . 

The Edit Data Export dialog box appears.
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Figure 10: Edit Data Export Dialog Box

3. To rename the data export, type the name in the Name field.

4. From the Connection Group drop-down box, select the connection group to use.

5. From the Connection drop-down box, select the database connection to use.

6. In the Data Extract SQL field, type the appropriate SQL code for data extract.
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7. Define the format of the delimited file that contains the data returned by the query. Click the Tab radio 
button to specify that the file is tab-delimited, or click the Specify tab to provide your own value and 
then type the value in the corresponding field.

8. Check the Include Date and Time checkbox to include the date and time in the name of the data 
export file.

9. Click OK.

Copying Data Exports
To create a duplicate of a data export, do the following.

1. Select Tools > Data Exports.

The Data Exports Administrator dialog box appears.

2. Select the data export you want to copy and click .

The data export is duplicated, and its copy appears in the Data Export Administration dialog box.

Deleting Data Exports
To delete a data export, do the following.

1. Select Tools > Data Exports.

The Data Exports Administrator dialog box appears.

2. Select the data export you want to delete and either right-click it and select Delete or click .

The data export is deleted and is removed from the Data Export Administration dialog box.

Running Data Exports
To run the query and view the data returned from the database, do the following.

1. Select Tools > Data Exports.

The Data Exports Administrator dialog box appears.

2. Select the data export you want to run.

3. Click .
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4. Click .

5. One of the following occurs.

• If there are issues with the SQL code, a dialog box appears and displays information about the 
problem.

• If there are no issues with the SQL code, results of the data export are displayed in the Results 
pane.

Extracting Data Exports
You can run the query you created and export the data returned to a file-delimited format you specified in 
the Edit Data Export dialog box (refer to Configuring and Modifying Data Exports on page 42).

1. Select Tools > Data Exports.

The Data Exports Administrator dialog box appears.

2. Select the data export you want to extract and either right-click it and select Extract or click .

The Extract Data Export dialog box appears.

3. From the Connection Group drop-down box, select the connection group you want to use.

4. From the Connection drop-down box, select the connection you want to use.

5. Click OK.

6. Save the file with the extracted data in the appropriate location.

Removing Sharing on Shared Data Exports
To remove sharing on data exports that are shared with another workspace, do the following.

1. Select Tools > Data Exports.

The Data Exports Administrator dialog box appears.

2. Select the data export for which you want to remove sharing and click .

Sharing is removed on the data export.
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Rolling Back Data Exports
If changes have been made and committed to a data export, you can use a previous version (roll back) of 
it.

1. Select Tools > Data Exports.

The Data Exports Administrator dialog box appears.

2. Select the data export you want to roll back and either right-click it and select Rollback or click .

The Rollback Manager dialog box appears and provides the following information.

• Name: Name of the data export.

• Status: Status of the data export (current or dated).

• Version Date: Date and time on which the version was created.

• Created By: Username of the user who created the version.

• Comments: Comments, if any, added by the user for the version.

3. Select the version that you want to use and click OK.

The previous version is loaded.

Importing Data Exports
To import a data export, do the following.

1. Select Tools > Data Exports.

The Data Exports Administrator dialog box appears.

2. Select  and select Import.

The Import Data Export dialog box appears.

3. Click Browse... to navigate to the location of the file you want to import, and then select it.

4. Check the Update Existing Entities checkbox to update an existing data export, with the same 
name as the data export you are importing, with the data export you are importing. 

If you do not check this checkbox, and there is an existing data export with the same name as the 
data export you are importing, DUPLICATE- is appended to the start of the name of the data export 
you are importing; the existing data export is not updated. If a data export exists with the name 
DUPLICATE-<data_export_name>, DUPLICATE(2)- is appended to the start of the name. The number 
continues to be incremented so that all data exports have unique names.

5. Click OK.

The data export is imported and is displayed in the Data Export Administration dialog box.
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Exporting Data Exports
To export a data export as an XML file, do the following.

1. Select Tools > Data Exports.

The Data Exports Administrator dialog box appears.

2. Click  and select Export.

3. Save the file in the appropriate location.

Viewing the Import History
To view the import history, do the following.

1. Select Tools > Import History.

The Import History dialog box appears and displays the following columns of information.

• Name: Name of the object imported into Perceptive DataTransfer (for example, Workspace or 
Data Export).

• Type: Type of import (Full Import or Partial Import). 

• Date Created: Date and time on which the object was imported.

• Created By: Username of the user who imported the object.
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Figure 11: Import History Dialog Box

2. To view details about the Perceptive DataTransfer objects that were imported, select the entry in the 

table and either right-click it and select Import Details or click .

The Import Report dialog box appears and displays information about the objects imported into 
Perceptive DataTransfer.
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Configuring Reports

You can write custom XML reports, which are based on JasperReports and are presented in PDF format. 
For more information about JasperReports, refer to http://en.wikipedia.org/wiki/JasperReports.

Note  Reports only run against the Perceptive DataTransfer database.

Refer to the following topics for more information.

• Configuring Reports on page 49.

• Configuring Scheduled Reports on page 51.

• Viewing Reports on page 53.

Configuring Reports
In Reports > Configure, you can add, modify, and delete reports; you can also import and export reports. 
Refer to the following topics for more information.

• Adding and Modifying Reports on page 49.

• Deleting Reports on page 50.

• Importing Reports on page 51.

• Exporting Reports on page 51.

Adding and Modifying Reports
You can create reports in JasperReports format.

1. Select Reports > Configure.

The Configure Reports dialog box appears.

2. Do one of the following.

• To add a new report, click .

The Add Report dialog box appears.

• To modify a report, select the report and either right-click it and select Edit Report or click .

The Edit Report dialog box appears.

3. In the Report Name field, type the name of the report.

4. In the XML field, type the XML code that generates the report.
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5. To add report parameters, do the following.

1. In the Report Parameters pane, click .

The New Report Parameter dialog box appears.

2. From the Parameter drop-down box, select the type of parameter you want to add. Options are:

• Header

• Job

• Start Date

• End Date

• User

3. Click Apply.

4. Continue adding parameters, as appropriate, and click OK when you are finished.

5. To delete a parameter, select the parameter in the Report Parameters pane and click .

6. Click OK to save your changes and close the dialog box.

Deleting Reports
To delete a report, do the following.

1. Select Reports > Configure.

The Configure Reports dialog box appears.

2. Select the report you want to delete and either right-click it and select Delete Report or click .

A dialog box appears, prompting you to confirm that you want to delete the report.

3. Click Yes.

The report is deleted and is removed from the Configure Reports dialog box.
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Importing Reports
To import reports from an XML file, do the following.

1. Select Reports > Configure.

The Configure Reports dialog box appears.

2. Click  and select Import.

The Import Report dialog box appears.

Figure 12: Import Report Dialog Box

3. Click Browse...., navigate to the location of the file, and select it.

4. Click OK.

The file is imported, and reports that are imported are displayed in the Configure Reports dialog box.

Exporting Reports
To export reports to an XML file, do the following.

1. Select Reports > Configure.

The Configure Reports dialog box appears.

2. Select the report you want to export.

3. Click  and select Export.

Save the XML file in the appropriate location.

Configuring Scheduled Reports
In Reports > Schedule, you can add and delete reports that are scheduled to be run at specified times, 

and you can modify the schedule for these reports. You can also view reports by clicking  (refer to 
Configuring Scheduled Reports on page 51 for more information).
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Refer to the following topics for more information.

• Adding and Modifying Scheduled Reports on page 52.

• Deleting Scheduled Reports on page 53.

Adding and Modifying Scheduled Reports
To add or modify a scheduled report, do the following.

1. Select Reports > Schedule.

The Schedule Reports dialog box appears.

2. Do one of the following.

• To add a new report, click .

The Add Scheduled Report dialog box appears.

• To modify a report, select the report and either right-click it and select Edit Report or click .

The Edit Scheduled Report dialog box appears.

3. Click the Details tab.

The Parameters pane displays the parameters, which you can specify, that are available for the 
selected report;.

4. In the Parameters pane, provide the appropriate parameters. Options depend on the parameters 
available for the report. Possible options are:

• Start Date field: Click  to open a calender from which you select the start date of the report. 

• End Date field: Click  to open a calender from which you select the end date of the report.

• Job field: Type the name of the job for the report.

• Header drop-down box: Select the header used for the job.

• User drop-down box: Select the user running the job.

5. From the Start Time drop-down box, select the time on which the report is run.

6. In the Recurrence Pattern pane, specify when the report recurs.

• Click the Once radio button to run the report once. After the report is run, rules for running the job 
are disabled.

• Click the Daily radio button to specify that the report is run daily, and then specify the recurrence 
frequency.
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• Click the Weekly radio button to specify that the report is run weekly, and then specify the 
recurrence frequency.

• Click the Monthly radio button to specify that the report is run monthly, and then specify the 
recurrence frequency.

7. Click the Notifications tab to configure notifications to be sent to recipients when certain reports 
actions occur. Refer to Configuring Notifications on page 55

8. Click OK.

Deleting Scheduled Reports
To delete a scheduled report, do the following.

1. Select Reports > Schedule.

The Schedule Report dialog box appears.

2. Select the scheduled report you want to delete and click .

The scheduled report is deleted and is removed from the Schedule Report dialog box.

Viewing Reports
You can view reports in the View Reports dialog box.

If you open the dialog box from Reports > View, the search filters display the current date for all report 
rules and reports. If you open it from the Schedule Reports dialog box, the filters display the selected 
report rule. 

These reports, in PDF format, are stored physically on the Perceptive DataTransfer server. You must 
specify the root directory of the location where the reports are stored. To do so, in the 
datatransfer.properties file, you must supply a report_root parameter. For example:

report_root=c:/reports

The PDF files are then stored in appropriate subdirectories within that root directory. 

To view a report, do the following.

1. Do one of the following. 

• Select Reports > View.

• Select Reports > Schedule and click .

The dialog box displays a table with the following information.

• Date: Date on which the report was created.

• Name: Name of the report.
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• Report Rule Name: Name of the rule that caused the scheduled report to be run.

• Created By: Username of the administrator who configured the report.

You can filter the information in the View Reports dialog box by selecting the appropriate information in 
one or more of the following fields.

• Report Rule: Select the report rule for which to filter results.

• Reports: Select the report for which to filter results. Select All to specify all reports.

• Date Range fields: Click the  icon to open a calender from which you can specify the start and 
end dates of a date range. You can choose both start and end dates or only a start or end date.

After specifying the filter information, click the Filter button to update the table with the selected criteria.

To view a report, click . The report opens in a new tab or browser window in PDF format.

To permanently delete the report PDF file and the record of the report instance, click . Reports are 
removed from the location specified in the report_root parameter in the datatransfer.properties file.
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Configuring Notifications

You can configure Perceptive DataTransfer to send notifications to users when various activities occur in 
Perceptive DataTransfer. You can configure notifications for jobs, scheduled reports, and version 
milestones.

Refer to the following topics for more information.

• Configuring Email Addresses on page 55.

• Configuring Notification Groups on page 56.

• Configuring Job Notifications on page 57.

• Configuring Report Notifications on page 59.

• Configuring Workspace Version Notifications on page 61.

Configuring Email Addresses
You must have the appropriate permissions to configure the SMTP server from which notifications can be 
sent, and you must also have the appropriate permissions to configure email addresses for users to 
which these notifications are sent.

Refer to Configuring Users And Privileges on page 63.

To configure system email addresses, do the following.

1. Select Administration > System Properties > System E-Mail.

The Configure System Email dialog box appears.

2. In the Email address field, type the email address used that sends the system notifications. 

3. In the Host field, type the hostname of the SMTP server that sends the emails.

4. In the Port field, type the port number of the SMTP server.

5. In the Username field, type the username of the SMTP server.

6. In the Password field, type the password of the SMTP server.

7. Click OK.

8. You can assign email addresses to Perceptive DataTransfer users; these are the emails addresses at 
which users receive emails sent from the SMTP server. To do so, do the following.

Note  The name and email address is updated for all users in the system with this username. For 
example, if user GUEST has multiple roles and therefore multiple instances in the system, the name and 
email address you configure for one instance of GUEST is used for all instances of that user.

1. Select Administration > User.

The User Administration dialog box appears.

2. In the Navigation pane, click the user for which you want to configure email settings.
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3. In the Name field, type the name of the user for the email address.

4. In the Email field, type the name of the email address for the user.

5. Click Save.

Configuring Notification Groups
After you have configured the system email address from which notifications are sent and the email 
addresses to which users receive those notifications, you can configure notifications for a variety of 
functions.

You can configure notification groups, which contain lists of email recipients (similar to an email 
distribution list), to which to send these notifications.

You must have the appropriate permissions to add and modify notification groups.

Refer to Configuring Users And Privileges on page 63.

Refer to the following topics for more information.

• Adding and Modifying Notification Groups on page 56.

• Deleting Notification Groups on page 57.

Adding and Modifying Notification Groups
To add a notification group, do the following.

1. Select Configuration > Notifications.

The Notification Group Configuration dialog box appears.

2. Do one of the following.

• To add a new notification group, click .

The Add Notification Group dialog box appears.

• To modify a group, select it and click .

The Edit Notification Group dialog box appears.

3. In the Name field, type the name of the notification group.
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4. In the To field, provide the email addresses of the recipients of the notifications. Do one of the 
following.

• Manually type the email addresses in the field, separating recipients by commas.

• Click the To button to open the Select Users dialog box. Select one or more recipients and click 
OK.

5. In the CC field, provide the email addresses of the recipients to which to send copies of the 
notifications. Do one of the following.

• Manually type the email addresses in the field, separating recipients by commas.

• Click the CC button to open the Select Users dialog box. Select one or more recipients and click 
OK.

Deleting Notification Groups
To delete a notification group, do the following.

1. Select Configuration > Notifications.

The Notification Group Configuration dialog box appears.

2. Select the group you want to delete and click .

Configuring Job Notifications
You can configure notifications to be sent when a job activity occurs.

Refer to the following topics for more information.

• Adding and Modifying Job Notifications on page 57.

• Deleting Job Notifications on page 59.

Adding and Modifying Job Notifications
To add a job notification, do the following.

1. In the Job Dashboard, do one of the following.

• Select Jobs > Add Jobs.

The Add Job dialog box appears.

• Select Jobs > Recurring Jobs.

The Recurring Job Administration dialog box appears.

2. Click the Notifications tab.
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3. Do one of the following.

• To add a new notification, click .

The Add Job Notification dialog box appears.

• To modify a notification, select it and click .

The Edit Job Notification dialog box appears.

4. From the Action drop-down box, select the job action that occurs for which a notification is sent. 
Options are Complete or Processed.

When a job attains Processed or Complete status, the appropriate notifications are sent to the 
provided email addresses.

5. Select the recipients to which to send the notifications. You can either select a configured notification 
group (refer to Configuring Notification Groups on page 56), or you can specify recipients not in a 
group.

• To select a notification group, select the appropriate group from the drop-down box. The To and 
CC fields automatically display the recipients configured for the notification group, and you 
cannot modify these fields.

• To specify recipients not in a group, do the following.

1. In the To field, provide the email addresses of the recipients of the notifications. Do one of the 
following.

• Manually type the email addresses in the field, separating recipients by commas.

• Click the To button to open the Select Users dialog box. Select one or more recipients 
and click OK.

2. In the CC field, provide the email addresses of the recipients to which to send copies of the 
notifications. Do one of the following.

• Manually type the email addresses in the field, separating recipients by commas.

• Click the CC button to open the Select Users dialog box. Select one or more recipients 
and click OK.

6. Click OK.
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Deleting Job Notifications
To delete a job notification, do the following.

1. Select Jobs > Add Jobs.

The Add Job dialog box appears.

2. Click the Notifications tab.

3. Select the notification you want to delete and click .

Configuring Report Notifications
You can configure report notifications when certain report activities occur.

Refer to the following topics for more information.

• Adding and Modifying Report Notifications on page 59.

• Deleting Report Notifications on page 60.

Adding and Modifying Report Notifications
1. Select Reports > Schedule.

The Schedule Reports dialog box appears.

2. Do one of the following.

• To add a new report, click .

The Add Scheduled Report dialog box appears.

• To modify a report, select the report and either right-click it and select Edit Report or click .

The Edit Scheduled Report dialog box appears.

3. Click the Notifications tab.

4. Do one of the following.

• To add a new notification, click .

The Add Report Notification dialog box appears.

• To modify a notification, select it and click .

The Edit Report Notification dialog box appears.
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5. From the Action drop-down box, select the report action that occurs for which a notification is sent. 
Option is Complete.

When a report is Complete, a notification is sent to the specified recipients, and a PDF version of the 
report is included as an attachment in the email.

6. Select the recipients to which to send the notifications. You can either select a configured notification 
group (refer to Configuring Notification Groups on page 56), or you can specify recipients not in a 
group.

• To select a notification group, select the appropriate group from the drop-down box. The To and 
CC fields automatically display the recipients configured for the notification group, and you 
cannot modify these fields.

• To specify recipients not in a group, do the following.

1. In the To field, provide the email addresses of the recipients of the notifications. Do one of the 
following.

• Manually type the email addresses in the field, separating recipients by commas.

• Click the To button to open the Select Users dialog box. Select one or more recipients 
and click OK.

2. In the CC field, provide the email addresses of the recipients to which to send copies of the 
notifications. Do one of the following.

• Manually type the email addresses in the field, separating recipients by commas.

• Click the CC button to open the Select Users dialog box. Select one or more recipients 
and click OK.

7. Click OK.

Deleting Report Notifications
To delete a report notification, do the following.

1. Select Reports > Schedule.

The Schedule Report dialog box appears.

2. Click the Notifications tab.

3. Select the notification you want to delete and click .
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Configuring Workspace Version Notifications
You can configure notifications to be sent when certain version activities occur.

Refer to the following topics for more information.

• Adding and Modifying Workspace Version Notifications on page 61.

• Deleting Workspace Version Notifications on page 62.

Adding and Modifying Workspace Version Notifications

To add or modify a version notification, do the following.

1. Select Administration > Workspace.

The Workspace Administration dialog box appears.

2. Select the workspace for which you want to configure notifications and click .

The Version Notification Configuration dialog box appears.

3. Do one of the following.

• To add a new notification, click .

The Add Version Notification dialog box appears.

• To modify a notification, select it and click .

The Edit Version Notification dialog box appears.

4. From the Action drop-down box, select the version action that occurs for which a notification is sent. 
Options are Active, Edit, Stage, and Test.

When a workspace moves into one of these statuses, a notification is sent to the specified recipient.

5. Select the recipients to which to send the notifications.You can either select a configured notification 
group (refer to Configuring Notification Groups on page 56), or you can specify recipients not in a 
group.

• To select a notification group, select the appropriate group from the drop-down box. The To and 
CC fields automatically display the recipients configured for the notification group, and you 
cannot modify these fields.

• To specify recipients not in a group, do the following.

1. In the To field, provide the email addresses of the recipients of the notifications. Do one of the 
following.

• Manually type the email addresses in the field, separating recipients by commas.

• Click the To button to open the Select Users dialog box. Select one or more recipients 
and click OK.
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2. In the CC field, provide the email addresses of the recipients to which to send copies of the 
notifications. Do one of the following.

• Manually type the email addresses in the field, separating recipients by commas.

• Click the CC button to open the Select Users dialog box. Select one or more recipients 
and click OK.

6. Click OK.

Deleting Workspace Version Notifications
To delete a version notification, do the following.

1. Select Administration > Workspace.

The Workspace Administration dialog box appears.

2. Click .

The Version Notification Configuration dialog box appears.

3. Select the notification you want to delete and click .
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Configuring Users And Privileges

When you configure Perceptive DataTransfer users, you define the structure of the institution and 
configure privileges for users to enable or disable the features they can use.

Configuring Institutions
Refer to the following topics for more information:

• Configuring Organizations on page 63.

• Configuring Divisions on page 64.

• Configuring Departments on page 66.

• Configuring Roles on page 67.

• Configuring Users on page 69.

Configuring Organizations
Refer to these topics for more information:

• Adding Organizations on page 63.

• Renaming Organizations on page 64.

• Deleting Organizations on page 64.

Adding Organizations

To add an organization, do the following.

1. Select Administration > User.

The User Administration dialog box appears.

2. In the Navigation pane, right-click Enterprise Hierarchy.

3. From the popup menu, select Add Organization.

The Add Organization dialog box appears.

4. Type the name of the organization.

5. Click OK.

The organization is created and appears in Navigation > Enterprise Hierarchy.

6. Add a division under the organization. Refer to Adding Divisions on page 65 for more information.
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Renaming Organizations

To rename an organization, do the following.

1. Select Administration > User.

The User Administration dialog box appears.

2. In the Navigation pane, right-click the organization you want to rename.

3. From the popup menu, click Rename Organization_Name.

The Rename Node dialog box appears.

4. Type the name of the organization.

5. Click OK.

The organization is renamed.

Deleting Organizations

Note  You can delete only the lowest-level node in the hierarchy tree. For example, if you want to delete a 
department that has roles and users configured for it, you must first delete all users, and next all roles, 
before you can delete the department.

To delete an organization, do the following.

1. Select Administration > User.

The User Administration dialog box appears.

2. In the Navigation pane, right-click the organization you want to delete.

3. From the popup menu, click Delete Organization_Name.

A dialog box appears, prompting you to confirm that you want to delete the organization.

4. Click Yes to delete the organization.

The organization is deleted, and it is removed from the Navigation pane.

Configuring Divisions
Refer to these topics for more information:

• Adding Divisions on page 65.

• Configuring Divisions on page 64.

• Renaming Divisions on page 65.

• Deleting Divisions on page 65.
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Adding Divisions

To add a division, do the following.

1. Select Administration > User.

The User Administration dialog box appears.

2. In the Navigation pane, right-click the organization under which you want to add a division.

3. From the popup menu, click Add Division.

The Add Division dialog box appears.

4. Type the name of the division (for example, Finance).

5. Click OK.

The division is created and appears in Navigation > Enterprise Hierarchy.

6. Add a department under the division. Refer to Adding Departments on page 66 for more information.

Renaming Divisions

To rename a division, do the following.

1. Select Administration > User.

The User Administration dialog box appears.

2. In the Navigation pane, right-click the division you want to rename.

3. From the popup menu, click Rename Division_Name.

The Rename Node dialog box appears.

4. Type the name of the division.

5. Click OK.

The division is renamed.

Deleting Divisions

Note  You can delete only the lowest-level node in the hierarchy tree. For example, if you want to delete a 
department that has roles and users configured for it, you must first delete all users, and next all roles, 
before you can delete the department.

To delete a division, do the following.

1. Select Administration > User.

The User Administration dialog box appears.

2. In the Navigation pane, right-click the division you want to delete.
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3. From the popup menu, click Delete Division_Name.

A dialog box appears, prompting you to confirm that you want to delete the division.

4. Click Yes to delete the division.

The division is deleted, and it is removed from the Navigation pane.

Configuring Departments
Refer to these topics for more information:

• Adding Departments on page 66.

• Renaming Departments on page 66.

• Deleting Departments on page 67.

Adding Departments

To add a department, do the following.

1. Select Administration > User.

The User Administration dialog box appears.

2. In the Navigation pane, right-click the division under which you want to add a department.

3. From the popup menu, click Add Department.

The Add Department dialog box appears.

4. Type the name of the department (for example, Accounts Payable).

5. Click OK.

The department is created and appears in the Navigation pane.

6. You can configure department privileges, which specify the tasks that the department can perform. 
When you configure privileges at the department level, these privileges are also applied to the users 
and roles that belong to the department. For more information, refer to Configuring Privileges on 
page 69.

7. Add a role under the department. Refer to Adding Roles on page 67 for more information.

Renaming Departments

To rename a department, do the following.

1. Select Administration > User.

The User Administration dialog box appears.

2. In the Navigation pane, right-click the department you want to rename.
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3. From the popup menu, click Rename Department_Name.

The Rename Node dialog box appears.

4. Type the name of the department.

5. Click OK.

The department is renamed.

Deleting Departments

Note  You can delete only the lowest-level node in the hierarchy tree. For example, if you want to delete a 
department that has roles and users configured for it, you must first delete all users, and next all roles, 
before you can delete the department.

To delete a department, do the following.

1. Select Administration > User.

The User Administration dialog box appears.

2. In the Navigation pane, right-click the department you want to delete.

3. From the popup menu, click Delete Department_Name

A dialog box appears, prompting you to confirm that you want to delete the department.

4. Click Yes to delete the department.

The department is deleted, and it is removed from the Navigation pane.

Configuring Roles
Refer to these topics for more information:

• Adding Roles on page 67.

• Renaming Roles on page 68.

• Deleting Roles on page 68.

Adding Roles

To add a role, do the following.

1. Select Administration > User.

The User Administration dialog box appears.

2. In the Navigation pane, right-click the department to which you want to add a role.

3. From the popup menu, click Add Department Role.

The Add Department Roles dialog box appears.

4. Type the name of the role (for example, Clerk).
Perceptive DataTransfer Administrator Guide Page 67 of 301



5. Click OK.

The role is created and appears in Navigation > Enterprise Hierarchy.

6. You can configure role privileges, which specify the tasks that the role can perform. When you 
configure privileges at the role level, these privileges are also applied to the users that belong to the 
role. For more information, refer to Configuring Privileges on page 69.

Note  You can assign permissions for a workspace and workspace permissions at the role level only. 

7. Add a user under the role. Refer to Adding Users on page 69 for more information.

Renaming Roles

To rename a role, do the following.

1. Select Administration > User.

The User Administration dialog box appears.

2. In the Navigation pane, right-click the role you want to rename.

3. From the popup menu, click Rename Role_Name.

The Rename Node dialog box appears.

4. Type the name of the role.

5. Click OK.

The role is renamed.

Deleting Roles

Note  You can delete only the lowest-level node in the hierarchy tree. For example, if you want to delete a 
department that has roles and users configured for it, you must first delete all users, and next all roles, 
before you can delete the department.

To delete a role, do the following.

1. Select Administration > User.

The User Administration dialog box appears.

2. In Navigation > Enterprise Hierarchy, right-click the role you want to delete.

3. From the popup menu, click Delete Role_Name.

A dialog box appears, prompting you to confirm that you want to delete the role.

4. To delete the role, click Yes.

The role is deleted and removed from Navigation > Enterprise Hierarchy.
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Configuring Users
Refer to these topics for more information:

• Adding Users on page 69.

• Deleting Users on page 69.

Adding Users

To add a user, do the following.

1. Select Administration > User.

The User Administration dialog box appears.

2. In Navigation > Enterprise Hierarchy, right-click the role under which you want to add a user.

3. From the popup menu, click Add User.

The Add User dialog box appears.

4. Type the name of the user.

5. Click OK.

The user is added and appears in Navigation > Enterprise Hierarchy.

6. You can configure user privileges, which specify the tasks that the user can perform. For more 
information, refer to Configuring Privileges on page 69.

Deleting Users

To delete a user, do the following.

1. Select Administration > User.

The User Administration dialog box appears.

2. In Navigation > Enterprise Hierarchy, right-click the user you want to delete.

3. From the popup menu, click Delete User_Name.

A dialog box appears, prompting you to confirm that you want to delete the user.

4. To delete the user, click Yes.

The user is deleted and removed from Navigation > Enterprise Hierarchy.

Configuring Privileges
You can configure privileges for a department, role, or user. When you configure privileges for a 
department, those privileges apply to the department and all the roles and users in the department. When 
you configure privileges for a role, those privileges apply to the role and to all users who belong to the 
role.
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Note  Privileges to use a workspace are configured at the role level.

1. Select Administration > User.

The User Administration dialog box appears.

2. In the Navigation pane, click the department, role, or user for which you want to configure privileges.

3. In the Department Editor, Role Editor, or User Editor pane, configure the department privileges (if you 
selected a user, in the User Editor pane, click the Permissions tab). The following table provides 
descriptions of the privileges.

Note  Click the arrow icon next to each privilege type to expand it and view the privileges. You can 
check the privilege type checkbox to select all privileges, or you can check the checkbox for each 
individual privilege to select it.

Table 3: Department Privilege Types and Privilege

Privilege Description

Administrative Privileges

User Administration Administrator can modify user privileges and can configure email addresses for 
users to which to send notifications; administrators can modify users and roles 
within that administrator’s department only.

Manage Share Groups Administrator can add, modify, and delete share groups.

Access Server Logs Administrator can view server logs.

Configure System Properties Administrator can configure system properties.

Archive Administration Administrator can create archive rules for jobs.

Workspace Contains the following options.

• View Details: Administrator can view details about workspace versions and can 
configure notifications for versions.

• Edit Details: Administrator can modify workspace details and can configure 
notifications for versions.

Version Control Contains the following options.

• Create/Move to Edit: Administrator can create new workspace versions and 
move workspace versions to edit mode.

• Move to Test: Administrator can move workspace versions to test mode.

• Move to Staged: Administrator can move workspace versions to staged mode.

• Move to Active: Administrator can move workspace versions to active mode.
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Workspace Configuration Contains the following options.

• Add Shared Objects: Administrator can add shared objects to the workspace.

• Edit Shared Objects: Administrator can modify workspace shared objects.

• Edit File Sources: Administrators can modify file sources.

• Edit Connection Groups: Administrator can modify connection groups.

• Edit Connections: Administrator can modify connections.

• Edit Headers: Administrator can modify header files.

• Edit Verification Forms: Administrator can modify verification forms.

• Edit ImageNow Index Map: Administrator can modify ImageNow index maps.

• Edit Data Providers: Administrator can configure web service data providers.

• Edit Document Templates: Administrators can configure document templates.

• Procedures

○ Edit Match: Administrator can configure match logic.

○ Edit Review: Administrator can configure review logic.

○ Edit Upload: Administrator can configure upload logic.

○ Edit Match Display: Administrator can configure match display logic.

○ Edit Population Selection: Administrator can configure population selection 
logic.

Table 3: Department Privilege Types and Privilege (Continued)

Privilege Description
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User Privileges

Tools Contains the following options.

• Lookup: User can configure the lookup tool.

• Check Name: User can configure the check name tool.

• Export: User can export Perceptive DataTransfer data (for example, lookup 
values, data provider maps, workspaces, and so on).

• Data Exports

○ Edit Export: User can modify data exports.

○ Run Export: User can run data exports.

• Reports

○ Run Reports: User can run reports.

○ Edit Reports: User can modify reports and can configure notifications for 
reports.

○ Edit Scheduled Reports: User can create, modify, and delete scheduled 
report rules.

○ View Report Output: User can view output files for reports that have been 
run.

○ Delete Report Output: User can delete output files for reports that have 
been run.

Version Contains the following options.

• Import: User can import workspace versions.

• Edit: User can work in workspace versions in edit mode.

• Inactive: User can work in workspace versions in inactive mode.

• Staged: User can work in workspace versions in staged mode.

• Test: User can work in workspace versions in test mode.

Job Contains the following options.

• Create Jobs: User can create jobs and can configure notifications for jobs.

• Edit Recurring Jobs: User can modify recurring jobs.

• Edit Job Hold Status: User can place a hold on a job to prevent it from being 
run.

• Enable Auditing: User can enable auditing.

• View Archived Jobs: User can view archived jobs.

Table 3: Department Privilege Types and Privilege (Continued)

Privilege Description
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4. Click the Settings tab to configure email addresses for users to which system notifications are sent. 
For more information, refer to Configuring Notifications on page 55.

5. Click Save to save your changes.

Record Contains the following options.

• Create New Record: User can create new records.

• Create Match Record: User can set records as matched records.

• Create Suspend Record: User can suspend records.

Notifications Contains the following options.

• Create Notification Groups: User can create new notification groups.

• Edit Notification Groups: User can modify notification groups.

Workspaces Workspace privileges are configured at the role level and are applied to all users in 
the role.

A user can use only one workspace at a time.

Check the workspace that the user can use, then set the following options.

• Headers: Headers contained in the workspace that the user can use. Check the 
Headers checkbox to select all headers or check individual headers to select 
them.

• Connection groups: Connection groups contained in the workspace that the 
user can use. Check the Connection Groups checkbox to select all connection 
groups or check individual connection groups to select them.

• File Sources: File sources contained in the workspace that the user can use. 
Check the File Sources checkbox to select all file sources or check individual 
file sources to select them.

Table 3: Department Privilege Types and Privilege (Continued)

Privilege Description
Perceptive DataTransfer Administrator Guide Page 73 of 301



Configuring Connection Groups and Database Connections

Connection groups consist of a group of database connections and are associated with a workspace; 
connection groups (and their connections) can be shared among workspaces.

You can share connection groups with other workspaces, and you can import connection groups from 
and export connection groups to an XML file.

Refer to the following topics for more information.

• Configuring Connection Groups on page 74.

• Configuring Connections on page 79.

Configuring Connection Groups
Refer to the following topics for more information.

• Adding Connection Groups on page 74.

• Modifying Connection Groups on page 76.

• Deleting Connection Groups on page 76.

• Copying Connection Groups on page 77.

• Removing Sharing on Shared Connection Groups on page 77,

• Rolling Back Connection Groups on page 78.

• Exporting Connection Groups on page 78.

• Importing Connection Groups on page 79.

Adding Connection Groups
You can add a new connection group or add a connection group that another workspace is sharing.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Click .

The Add Connection Group dialog box appears.
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Figure 13: Add Connection Group Dialog Box

3. Do one of the following.

• To add a new connection group, do the following.

1. Click the Add Connection Group tab.

2. In the Connection Group Name field, type the name of the connection group.

3. In the Description field, type descriptive text about the connection group.

• To add a connection group that is shared by another workspace, do the following.

1. Click the Add Shared Connection Group tab.

2. From the Workspace drop-down box, select the workspace that is sharing the connection 
group you want to use.

3. Click the connection group that you want to use to select it.

4. Click OK.

The connection group is added and appears in the Connection Group Administration dialog box.

A database connection with the name Primary is automatically added to the connection group. A 
connection group must always have a primary database connection. You can add additional 
database connections to the group; refer to Adding Database Connections on page 80.
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Modifying Connection Groups
To modify a connection group, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Click the connection group you want to modify and either click  or right-click the connection group 
and select Edit Connection Group.

The Edit Connection Group dialog box appears.

Figure 14: Edit Connection Group Dialog Box

3. In the Connection Group Name field, type the name of the connection group.

4. In the Description field, type a brief description for the connection group.

5. Click OK.

The connection group is modified, and its updated information appears in the Connection Group 
Manager dialog box.

Deleting Connection Groups
To delete a connection group, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Click the connection group you want to delete and either right-click it and select Remove 

Connection Group or click .
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Copying Connection Groups
To copy a connection group, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Click the connection group you want to copy and either right-click it and select Copy Connection 

Group or click .

The Rename Copied Connection Group dialog box appears.

Figure 15: Rename Copied Connection Group Dialog Box

3. In the Name field, type the name of the connection group.

4. Click OK.

The connection group is copied, and the new connection group you created is added to the 
Connection Group Administration dialog box.

Removing Sharing on Shared Connection Groups
To remove sharing on a connection group that is shared with another workspace, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Select the connection group for which you want to remove sharing and either right-click it and select 

Remove Sharing or click .

Sharing is removed on the connection group.
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Rolling Back Connection Groups
If changes have been made and committed to a connection group, you can use a previous version (roll 
back) of it.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Click the connection group you want to roll back and either right-click it and select Rollback or click 

.

The Rollback Manager dialog box appears and displays the following information.

• Name: Name of the connection group.

• Status: Status of the connection group (current or dated).

• Version Date: Date and time on which the version was created.

• Created By: Username of the user who created the connection group.

• Comments: Comments that were added by the user.

3. Select the previous version to which you want to revert and click Rollback.

The previous version is loaded.

Obtaining the Latest Versions of Connection Groups
If changes have been made to and committed to a connection group, you can obtain the latest version of 
it.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Click the connection group for which you want to obtain the latest version and either right-click it and 

select Get Latest or click .

Exporting Connection Groups
You can export connection groups to an XML file by doing the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Select the connection group you want to export.

3. Click  and select Export.

4. Save the file to the appropriate location.
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Importing Connection Groups
You can import connection groups from an XML file by doing the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Click  and select Import.

The Import Connection Groups dialog box appears.

3. Click the Browse... button and navigate to the file that you want to import or type the location of the 
file in the File field.

4. Check the Update Existing Entities checkbox to update an existing connection group, with the 
same name as the connection group you are importing, with the connection group you are importing. 

If you do not check this checkbox, and there is an existing connection group with the same name as 
the connection group you are importing, DUPLICATE- is appended to the start of the name of the 
connection group you are importing; the existing connection group is not updated. If a connection 
group exists with the name DUPLICATE-<connection_group_name>, DUPLICATE(2)- is appended to 
the start of the name. The number continues to be incremented so that all connection groups have 
unique names.

5. Click OK.

Configuring Connections
Refer to the following topics for more information.

• Adding Database Connections on page 80.

• Modifying Database Connections on page 80.

• Adding Nolij Web Connections on page 81.

• Modifying Nolij Web Connections on page 82.

• Adding Hobsons Connect CRM Connections on page 82.

• Modifying Hobsons Connect CRM Connections on page 84.

• Adding QAS Connections on page 84.

• Modifying QAS Connections on page 86.

• Adding Integration Server Connections on page 86.

• Modifying Integration Server Connections on page 87.

• Adding Web Service Connections on page 88.

• Modifying Web Service Connections on page 89.
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• Deleting Connections on page 90

• Testing Connections on page 91.

Adding Database Connections
To add a database connection, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Select the connection group to which you want to add a new connection and either right-click it and 

select Add Connection or click .

The Add Connection dialog box appears.

3. From the drop Type drop-down box, select Standard.

The Add Database Connection dialog box appears.

4. In the Name field, type the name of the connection. 

Note  A primary database connection with the name Primary is automatically created when you 
create a connection group. You can only have one primary database per group. You cannot name 
another database connection Primary. 

5. In the Description field, type a brief description of the connection.

6. In the URL field, type the URL of the database.

7. In the Username field, type the username.

8. In the Password field, type the password.

9. In the DB Driver field, type the name of the driver used to connect to the database.

10. In the DB Name field, type the name of the database.

11. Click OK.

The connection is added to the connection group and appears in the Connection Group Manager 
dialog box.

Modifying Database Connections
To modify a database connection, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Select the connection you want to modify and either right-click it and select Edit Connection or click 

.

The Edit Connection dialog box appears.
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3. In the Name field, type the name of the connection.

Note  You cannot rename a database connection with the name Primary.

4. In the Description field, type a brief description of the connection.

5. In the URL field, type the URL of the database.

6. In the Username field, type the username.

7. In the Password field, type the password.

8. In the DB Driver field, type the name of the driver used to connect to the database.

9. In the DB Name field, type the name of the database.

10. Click OK.

The connection is added to the connection group and appears in the Connection Group 
Administration dialog box.

Adding Nolij Web Connections
Note  You can configure only one Nolij Web connection per connection group.

To add a Nolij Web database connection, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Select the connection group to which you want to add a new connection and either right-click it and 

select Add Connection or click .

The Add Connection dialog box appears.

3. From the Type drop-down box, select Nolij Web.

The Add Nolij Web Connection dialog box appears.

4. In the Name field, type the name of the connection.

5. In the Description field, type a brief description of the connection.

6. In the URL field, type the URL of the Nolij Web instance (for example, http://localhost/NolijWeb/).

7. In the Username field, type the username.

8. In the Password field, type the password.

9. In the CAS URL field, type the URL of the CAS server.

10. Check the Is CAS checkbox to indicate that this connection uses CAS authentication.

11. Click OK.

The Nolij Web connection is added to the connection group and appears in the Connection Group 
Manager dialog box.
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Modifying Nolij Web Connections
To modify a Nolij Web database connection, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Select the connection you want to modify and either right-click it and select Edit Connection or click 

.

The Edit Nolij Web Connection dialog box appears.

3. In the Name field, type the name of the connection.

4. In the Description field, type a brief description of the connection.

5. In the URL field, type the URL of the Nolij Web instance (for example, http://localhost/NolijWeb/).

6. In the Username field, type the username.

7. In the Password field, type the password.

8. In the CAS URL field, type the URL of the CAS server, if you are using CAS authentication.

9. Check the Is CAS checkbox if you are using CAS authentication.

10. Click OK.

The Nolij connection is modified and its updated information appears in the Connection Group 
Manager dialog box.

Adding Hobsons Connect CRM Connections
You can update Hobsons data using Hobsons Connect CRM web services. To do so, you create a 
connection group that contains a Hobsons Connect CRM connection. You can also create a Hobsons 
Connect CRM header and add and run a job using the Hobsons CRM Connect connection and header. 
You can also use the appropriate NQL syntax in the Perceptive DataTransfer logic to execute the 
Hobsons web service. 

Note  You can configure only one Hobsons CRM connection per connection group.

To add a Hobsons Connect CRM connection, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Select the connection group to which you want to add a new connection and either right-click it and 

select Add Connection or click .

The Add Connection dialog box appears.

3. From the Type drop-down box, select Hobsons Connect CRM.

The Add Hobsons Connect CRM Connection dialog box appears.
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4. In the Name field, type the name of the connection.

5. In the Description field, type descriptive text about the connection.

6. In the Client URL field, type the URL used by clients to access web services.

7. In the Action URL field, type the URL used for SOAP (Simple Object Access Protocol) web services.

8. In the Client Name field, type the client name used for the connection.

9. In the Pass Key field, type the pass key used for the connection.

10. Click OK.

The connection is added and appears in the Connection Group Administration dialog box.

You configure jobs to use connection groups; refer to Configuring Jobs and Processing Records on 
page 227. When you configure a job to use a connection group with a Hobsons connection and a 
Hobsons Connect CRM header, and you can also configure the logic, used by the job configured to use 
the Hobsons Connect CRM header and connection, to use the appropriate NQL syntax:

HobsonsUpdate(<web service name>, <contact id>, <attribute name 1>, <attribute value 
1>, <attribute name 2>, <attribute value 2>, ... , <attribute name n>, <attribute value 
n>)

The required parameters are:

• <web service name>: the name of the Hobsons Connect CRM web service (for example, 
UpdateContact)

• <contact id>: the ID value of the contact record to update.

The additional parameters are any number of attribute name or value pairs. Both components of the pair 
are strings; the first string identifies the name of the Hobsons Connect CRM attribute to update, and the 
second string is the new value for the specified attribute.

The HobsonsUpdate function returns a string. If the update is successful, an empty string is returned. If it 
is not successful, a corresponding error message is returned.

An example of the syntax is:

let $err = HobsonsUpdate('UpdateContact', $id, 'first_name', $fname, 'last_name', 
$lname, 'dob', $dob')

This syntax runs the UpdateContact web service on the contact with id $id and updates the first_name 
attribute to the value in $fname, the last_name attribute to the value in $lname, and so on.

For more information about procedures, refer to Configuring Procedures on page 127. For detailed 
information about configuring logic, refer to Programming Concepts on page 261.
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Modifying Hobsons Connect CRM Connections
To modify a Hobsons Connect CRM connection, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Select the connection you want to modify and either right-click it and select Edit Connection or click 

.

The Edit Hobsons Connect CRM Connection dialog box appears.

3. In the Name field, type the name of the connection.

4. In the Client URL field, type the URL used by clients to access web services.

5. In the Action URL field, type the URL used for SOAP web services.

6. In the Client Name field, type the client name used for the connection.

7. In the Pass Key field, type the pass key used for the connection.

8. Click OK.

Adding QAS Connections
Note  You can configure only one QAS connection per connection group.

Note  By default, headers are configured to use QAS.

To add a QAS connection, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Select the connection group to which you want to add a new connection and either right-click it and 

select Add Connection or click .

The Add Connection dialog box appears.

3. From the Type drop-down box, select QAS.

The Add QAS Connection dialog box appears.

4. In the Name field, type the name of the connection.

5. In the Description field, type descriptive text about the connection.

6. In the Client URL field, type the URL used by clients to access QAS web services.

7. In the Action URL field, type the URL used by QAS for SOAP (Simple Object Access Protocol) web 
services.

8. In the Username field, type the username used for the connection.
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9. In the Password field, type the password used for the connection.

10. Click OK.

The connection is added and appears in the Connection Group Administration dialog box.

You configure jobs to use connection groups; refer to Configuring Jobs and Processing Records on 
page 227.

Note  By default, headers are configured to use QAS. You can disable this option. For more information 
about configuring headers, refer to Configuring and Modifying Fixed-Width Headers and Header 
Variables on page 102, Configuring and Modifying Delimited Headers and Header Variables on page 107, 
Configuring and Modifying Database Headers on page 110, and Configuring and Modifying XML Headers 
and Header Variables on page 112.

When you configure a job to use a connection group with a QAS connection and a QAS header, and you 
can also configure the logic, used by the job configured to use the QAS header and connection, to use 
the appropriate NQL syntax:

let $result = QASAddressCheck('country_code', $qas_f1, $qas_f2, $qas_f3, $qas_f4, 
$qas_f5, 'address_1', 'address_2', 'state', 'zip' 'string6', ...'stringN')

Use this syntax to verify addresses through a web service call. The function takes the following 
parameters,.

• Country code: This parameter can be passed in as either a string literal or a program variable. 
Supported codes are USA and CAN.

• Parameters two through six: These parameters are program variables that are populated with the 
refined fields of the address. These parameters are output variables; the QASAddressCheck function 
accepts any number of input variables; however, the function always returns five outputs. For 
example:

○ The corrected street address is obtained for $qas_f1.

○ The corrected second street address (for example, an apartment number) is obtained for $qas_f2.

○ The corrected city is obtained for $qas_f3.

○ The corrected state code is obtained for $qas_f4.

○ The corrected nine-digit zip code is obtained for $qas_f5.

• Parameters 7 and on: These parameters are any number of address fields represented by any string 
expression (for example, string literals, string variables, concatenated strings, and so on.) The 
QASAddressCheck function will accept as few or as many address fields as needed. The QAS web 
service will accept any number of inputs and find and refine the matching address.

The QASAddressCheck function returns a string match code generated by QAS. This match code must 
be parsed so that you can determine the success or failure of the search and the accuracy of the returned 
address. 

For example:

let $result = QASAddressCheck('USA', $qas_f1, $qas_f2, $qas_f3, $qas_f4, $qas_f5, '1600 
Pennsylvania Ave', 'Washington', 'DC', '20500')
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This example returns the following results.

• $qas_f1: 1600 Pennsylvania Ave NW

• $qas_f2

• $qas_f3: Washington

• $qas_f4: DC

• $qas_f5: 20500-0003

• $result: R53300020000f00080000

For more information about procedures, refer to Configuring Procedures on page 127. For detailed 
information about configuring logic, refer to Programming Concepts on page 261.

Modifying QAS Connections
To modify a QAS connection, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Select the connection you want to modify and either right-click it and select Edit Connection or click 

.

The Edit QAS Connection dialog box appears.

3. In the Name field, type the name of the connection.

4. In the Description field, type descriptive text about the connection.

5. In the Client URL field, type the URL used by clients to access QAS web services.

6. In the Action URL field, type the URL used by QAS for SOAP (Simple Object Access Protocol) web 
services.

7. In the Username field, type the username used for the connection.

8. In the Password field, type the password used for the connection.

9. Click OK.

Adding Integration Server Connections
Configure an integration server connection when you want to interact with ImageNow, using Perceptive 
DataTransfer. 

You use integration server connections to obtain document information about the ImageNow documents 
you want to upload. When you configure index maps, you use the connection to obtain the information, 
which is displayed as Perceptive DataTransfer program variables, and map the ImageNow document 
properties to the corresponding program variables. Refer to Configuring ImageNow Index Maps on 
page 199.
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Use the ImageNowAddDoc function in your code to specify the parameters Perceptive DataTransfer uses 
to upload ImageNow documents. Refer to Understanding the ImageNowAddDoc Function on page 286.

Note  You can configure only one ImageNow connection per connection group.

To add an integration server connection, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Select the connection group to which you want to add a new connection and either right-click it and 

select Add Connection or click .

The Add Connection dialog box appears.

3. From the Type drop-down box, select Integration Server.

The Add Integration Server Connection dialog box appears.

4. In the Name field, type the name of the connection.

5. In the Description field, type descriptive text about the connection.

6. In the URL field, type the URL used to access ImageNow.

7. In the Username field, type the username used for the connection.

8. In the Password field, type the password used for the connection.

9. Click OK.

The connection is added and appears in the Connection Group Administration dialog box.

Modifying Integration Server Connections
To modify an integration server connection, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Select the connection you want to modify and either right-click it and select Edit Connection or click 

.

The Edit Integration Server Connection dialog box appears.

3. In the Name field, type the name of the connection.

4. In the Description field, type descriptive text about the connection.

5. In the URL field, type the URL used to access ImageNow.

6. In the Username field, type the username used for the connection.

7. In the Password field, type the password used for the connection.

8. Click OK.
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Adding Web Service Connections
Create a web service connection when you are using web services to retrieve or update data. For more 
information, refer to Configuring Web Service Data Providers on page 157.

To add a web service connection, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. To add a new connection, select the connection group to which you want to add a new connection 

and either right-click it and select Add Connection or click .

The Add Connection dialog box appears.

3. From the Type drop-down box, select Web Service and click OK.

The Edit Web Service Connection dialog box appears.

4. In the Name field, type the name of the web service connection.

5. In the Description field, type descriptive text about the web service connection.

6. In the Client URL field, provide the beginning portion of the URL that runs the web service. If you have 
multiple web services that start with the same portion of the URL, you can provide this common 
portion in the URL field and share the connection among multiple web services.

7. In the Authentication pane, you can specify optional authentication options. 

1. From the Scheme drop-down box, select the authentication scheme to use. 

• Session Header: Extracts a session ID or token from the response sent by an initial request to 
a specified URL. The authentication request is executed with the parameters you specify, and 
the session ID or token is extracted from the response. For each subsequent web service call 
using this connection, the extracted session ID token is then passed into the header field you 
specify.

• Session Cookie: Extracts a session ID or token from the cookie sent by an initial request to a 
specified URL. The authentication request is executed with the parameters you specify, and 
the session ID or token is extracted from the cookie set by the response. For each 
subsequent web service call using this connection, the extracted session ID or token is then 
passed into the cookie you specify.

2. In the URL field, type the URL from which to receive the response.

3. From the HTTP Method drop-down box, select the HTTP method used.

4. In the Content Type field, type the content type to send to the URL. For example:

• For JSON authentication service, the content type is application/JSON.

• For XML authentication service, the content type is application/XML.
Perceptive DataTransfer Administrator Guide Page 88 of 301



5. In the Content to Send field, provide the content (for example, the request payload) to send. For 
example:

• For JSON authentication service, the content to be sent is in JSON format.

• For XML authentication service, the content to be sent is in XML format or is part of a URL 
string.

6. Do one of the following.

• In the Header Field, which appears for the Session Header scheme only, type the header field 
into which the session ID or token is passed.

• In the Cookie Field, which appears for the Session Cookie scheme only, type the cookie into 
which the session ID or token is passed.

8. Click OK.

Modifying Web Service Connections
To modify an integration server connection, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Select the connection you want to modify and either right-click it and select Edit Connection or click 

.

The Edit Web Service Connection dialog box appears.

3. From the Type drop-down box, select Web Service.

The Edit Web Service Connection dialog box appears.

4. In the Name field, type the name of the web service connection.

5. In the Description field, type descriptive text about the web service connection.

6. In the URL field, provide the beginning portion of the URL that runs the web service. If you have 
multiple web services that start with the same portion of the URL, you can provide this common 
portion in the URL field and share the connection among multiple web services.

7. In the Authentication pane, you can specify optional authentication options. 

1. From the Scheme drop-down box, select the authentication scheme to use. 

• Session Header: Extracts a session ID or token from the response sent by an initial request to 
a specified URL. The authentication request is executed with the parameters you specify, and 
the session ID or token is extracted from the response. For each subsequent web service call 
using this connection, the extracted session ID token is then passed into the header field you 
specify.

• Session Cookie: Extracts a session ID or token from the cookie sent by an initial request to a 
specified URL. The authentication request is executed with the parameters you specify, and 
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the session ID or token is extracted from the cookie set by the response. For each 
subsequent web service call using this connection, the extracted session ID or token is then 
passed into the cookie you specify.

2. In the URL field, type the URL from which to receive the response.

3. From the HTTP Method drop-down box, select the HTTP method used.

4. In the Content Type field, type the content type to send to the URL. For example:

• For JSON authentication service, the content type is application/JSON.

• For XML authentication service, the content type is application/XML.

5. In the Content to Send field, provide the content (for example, the request payload) to send. For 
example:

• For JSON authentication service, the content to be sent is in JSON format.

• For XML authentication service, the content to be sent is in XML format or is part of a URL 
string.

6. Do one of the following.

• In the Header Field, which appears for the Session Header scheme only, type the header field 
into which the session ID or token is passed.

• In the Cookie Field, which appears for the Session Cookie scheme only, type the cookie into 
which the session ID or token is passed.

8. Click OK.

Deleting Connections
To delete a connection, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Select the connection you want to delete and either right-click it and select Remove Connection or 

click .
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Testing Connections
To test a connection, do the following.

1. Select Configuration > Connections.

The Connection Group Administration dialog box appears.

2. Select the connection you want to test and either right-click it and select Test Connection or click 

. 

• If the connection works properly, a dialog box appears and states that the test was successful.

• If the connection does not work properly, a dialog box appears and indicates the reason that the 
test failed.
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Configuring File Sources

You can configure file sources—servers or SFTP connections—for recurring jobs. The file source is the 
location that contains the input file that the recurring job uses. Recurring jobs run at a specified interval, 
using the input file from the server or SFTP site to which it can connect.

You can also configure file sources to download additional, non-input files from a specified location. For 
example, you can create a recurring job that automatically downloads the input file, creates a job for the 
file, downloads non-input files to be processed by the job, and places the non-input files in a location that 
Perceptive DataTransfer can access. 

Refer to the following topics for more information.

• Adding File Sources on page 92.

• Modifying File Sources on page 95.

• Deleting File Sources on page 97.

• Copying File Sources on page 97.

• Testing File Sources on page 98.

• Removing Sharing on Shared File Sources on page 98.

• Rolling Back File Sources on page 98.

• Obtaining the Latest Versions of File Sources on page 99.

• Exporting File Sources on page 99.

• Importing File Sources on page 99.

Adding File Sources
You can add a new file source or add a file source that another workspace is sharing.

1. Select Configuration > File Sources.

The File Source Administration dialog box appears.

2. Click .

The Add File Source dialog box appears.
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Figure 16: Add File Source Dialog Box

3. Do one of the following.

• To add a new file source, do the following.

1. Click the Add File Source tab.

2. In the Name field, type the name of the file source.

3. From the Type drop-down box, select the type of file source (Server or SFTP).

• To add a file source that another workspace is sharing, do the following.

1. Click the Add Shared File Source tab.

2. From the Workspace drop-down box, select the workspace that is sharing the file source.

3. From the File Source drop-down box, select the file source you want to add.

4. Click OK.

The Edit File Source dialog box appears.

5. Do one of the following.

• To modify a server path file source, do the following.

1. In the Name field, type the name of the file source.

2. In the Description field, type descriptive text about the file source.

3. In the Path field, type the path.

4. In the File Pattern Field, type the file pattern information used to identify the input file located 
in the specified file source. Perceptive DataTransfer searches the file source for the input file 
based on the file pattern information specified.
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Use * to search for any number of characters; use ? to search for one character. For example:

• *.xml returns all XML files.

• *.?ml returns any files with an extension that has one character followed by ml.

• Application?.txt returns all files that start with Application, that have a single character, 
and that have a .txt extension.

Note  Perceptive DataTransfer does not verify if the file pattern information is correct.

• To modify an SFTP file source, do the following.

1. In the Name field, type the name of the file source.

2. In the Description field, type descriptive text about the file source.

3. In the URL field, type the URL of the SFTP connection.

4. In the Port field, type the port number.

5. In the Path field, type the SFTP connection path.

6. In the File Pattern Field, type the file pattern information used to identify the input file located 
in the specified file source. Perceptive DataTransfer searches the file source for the input file 
based on the file pattern information specified.

Use * to search for any number of characters; use ? to search for one character. For example:

• *.xml returns all XML files.

• *.?ml returns any files with an extension that has one character followed by ml.

• Application?.txt returns all files that start with Application, that have a single character, 
and that have a .txt extension.

7. In the Username field, type the username used to connect to the SFTP connection.

8. In the Password field, type the password used to connect to the SFTP connection.
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6. In the File Downloads pane, do the following.

1. Check the Additional Files checkbox to specify that the file source has other, non-input files to 
download. When you create a recurring job that uses this file source, the input file is downloaded 
from the specified path or connection, and then additional files are downloaded from the same 
path or connection, given the parameters you specify in the File Downloads pane.

2. In the File Pattern field, type the file pattern information used to identify the non-input file located 
in the file source.

3. In the Destination Path field, type the location where the non-input files are placed when they are 
downloaded. The path must be on a Perceptive DataTransfer server or reachable from the 
Perceptive DataTransfer server. 

7. In the Source File Options pane, specify how to manage the additional, non-input files in the file 
source location. Click one of the following radio buttons.

• Leave: Performs no action on the files.

• Archive: Archives the files and moves them to a location that you specify in the Archive Path 
field.

• Delete: Permanently deletes the files from the file source.

8. Click OK.

The file source is added and appears in the File Source Administration dialog box.

Modifying File Sources
To modify a file source, do the following.

1. Select Configuration > File Sources.

The File Source Administration dialog box appears.

2. Click the file source you want to modify and either click  or right-click the file source and select 
Edit.

The Edit File Source dialog box appears.

3. Do one of the following.

• To modify a server path file source, do the following.

1. In the Name field, type the name of the file source.

2. In the Description field, type descriptive text about the file source.

3. In the Path field, type the path.
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4. In the File Pattern Field, type the file pattern information used to identify the input file located 
in the specified file source. Perceptive DataTransfer searches the file source for the input file 
based on the file pattern information specified.

Use * to search for any number of characters; use ? to search for one character. For example:

• *.xml returns all xml files.

• *.?ml returns any files with an extension that has one character followed by ml.

• Application?.txt returns all files that start with Application, that have a single character, 
and that have a .txt extension.

Note  Perceptive DataTransfer does not verify if the file pattern information is correct.

• To modify an SFTP file source, do the following.

1. In the Name field, type the name of the file source.

2. In the Description field, type descriptive text about the file source.

3. In the URL field, type the URL of the SFTP connection.

4. In the Port field, type the port number.

5. In the Path field, type the SFTP connection path.

6. In the File Pattern Field, type the file pattern information used to identify the input file located 
in the specified file source. Perceptive DataTransfer searches the file source for the input file 
based on the file pattern information specified.

Use * to search for any number of characters; use ? to search for one character. For example:

• *.xml returns all xml files.

• .?ml returns any files with an extension that has one character followed by ml.

• Application?.txt returns all files that start with Application, that have a single character, 
and that have a .txt extension.

7. In the Username field, type the username used to connect to the SFTP connection.

8. In the Password field, type the password used to connect to the SFTP connection.
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4. In the File Downloads pane, do the following.

1. Check the Additional Files checkbox to specify that the file source has other, non-input files to 
download. When you create a recurring job that uses this file source, the input file is downloaded 
from the specified path or connection, and then additional files are downloaded from the same 
path or connection, given the parameters you specify in the File Downloads pane.

2. In the File Pattern field, type the file pattern information used to identify the non-input file located 
in the file source.

3. In the Destination Path field, type the location where the non-input files are placed when they are 
downloaded. The path must be on a Perceptive DataTransfer server or reachable from the 
Perceptive DataTransfer server. 

5. In the Source File Options pane, specify how to manage the additional, non-input files in the file 
source location. Click one of the following radio buttons.

• Leave: Performs no action on the files.

• Archive: Archives the files and moves them to a location that you specify in the Archive Path 
field.

• Delete: Permanently deletes the files from the file source.

6. Click OK.

Deleting File Sources
To delete a file source, do the following.

1. Select Configuration > File Sources.

The File Source Administration dialog box appears.

2. Select the file source you want to delete and either right-click it and select Delete or click .

The file source is deleted and is removed from the File Source Administration dialog box.

Copying File Sources
To create a duplicate of a file source, do the following.

1. Select Configuration > File Sources.

The File Source Administration dialog box appears.

2. Select the file source you want to copy and either right-click it and select Copy or click .

A copy of the file source is created and appears in the File Source Administration dialog box.
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Testing File Sources
To test a file source connection, do the following.

1. Select Configuration > File Sources.

The File Source Administration dialog box appears.

2. Select the file source you want to test and either right-click it and select Test File Source or click .

• If the file source works properly, a dialog box appears and states that the test was successful.

• If the file source does not work properly, a dialog box appears and indicates the reason that the 
test failed.

Removing Sharing on Shared File Sources
To remove sharing on a file source that is shared with another workspace, do the following.

1. Select Configuration > File Sources.

The File Source Administration dialog box appears.

2. Select the file source for which you want to remove sharing and either right-click it and select 

Remove Sharing or click .

Sharing is removed on the file source.

Rolling Back File Sources
If changes have been made and committed to a file source, you can use a previous version (roll back) of 
it.

1. Select Configuration > File Sources.

The File Source Administration dialog box appears.

2. Click the file source you want to roll back and either right-click it and select Rollback or click .

The Rollback Manager dialog box appears and displays the following information.

• Name: Name of the file source.

• Status: Status of the file source (current or dated).

• Version Date: Date and time on which the version was created.

• Created By: Username of the user who created the file source.

• Comments: Comments that were added by the user.

3. Select the previous version to which you want to revert and click Rollback.

The previous version is loaded.
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Obtaining the Latest Versions of File Sources
If changes have been made to and committed to a file source, you can obtain the latest version of it.

1. Select Configuration > File Sources.

The File Source Administration dialog box appears.

2. Click the file source for which you want to obtain the latest version and either right-click it and select 

Get Latest or click .

Exporting File Sources
You can export file sources to an XML file by doing the following.

1. Select Configuration > File Sources.

The File Source Administration dialog box appears.

2. Select the file source you want to export.

3. Click  and select Export.

4. Save the file to the appropriate location.

Importing File Sources
You can import file sources from an XML file by doing the following.

1. Select Configuration > File Sources.

The File Source Administration dialog box appears.

2. Click  and select Import.

The Import File Source dialog box appears.

3. Click the Browse... button and navigate to the file that you want to import or type the location of the 
file in the File field.

4. Check the Update Existing Entities checkbox to update an existing file source, with the same name 
as the file source you are importing, with the file source you are importing. 

If you do not check this checkbox, and there is an existing file source with the same name as the file 
source you are importing, DUPLICATE- is appended to the start of the name of the file source you are 
importing; the existing file source is not updated. If a file source exists with the name DUPLICATE-
<file_source_name>, DUPLICATE(2)- is appended to the start of the name. The number continues to 
be incremented so that all file sources have unique names.

5. Click OK.
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Configuring Headers

Refer to the following topics for more information.

• Understanding Headers on page 100.

• Understanding Header Icons on page 101.

• Adding Headers on page 101.

• Configuring and Modifying Headers and Header Variables on page 102.

• Removing Sharing on Headers on page 124.

• Rolling Back Headers on page 124.

• Obtaining the Latest Versions of Headers on page 124.

• Deleting Headers on page 125.

• Exporting Headers on page 125.

• Importing Headers on page 125.

Understanding Headers
Headers define the import source, which is the input file with the data you will be loading. For example, 
you may want to import student SAT scores and load them into your database, either linking the test 
scores to existing records or creating new records of information. If that data is contained in a 
spreadsheet of information in CSV format, you are using a delimited input file.

With Perceptive DataTransfer, you map a data input source to a destination, usually mapping a column 
from an input file to a database table column. Header variables comprise headers, which are input 
variables that identify the field element and field order within the import file.

You can share headers with other workspaces, and you can import headers from and export headers to 
an XML file.
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Understanding Header Icons
The following table describes the header icons that appear in the Header Administration dialog box.

Adding Headers
To add a new header, do the following.

1. Select Configuration > Headers. 

The Header Administration dialog box appears.

2. Click .

The Add Header dialog box appears.

3. Do one of the following.

• To add a new header, click the Add Header tab.

1. In the Header Name field, type the name of the header.

2. From the Type drop-down box, select the type of header.

• Delimited

• Database

• Fixed Width

• XML

• Hobsons Connect CRM

• Web Service

Table 4: Data Export Icons and Descriptions

Icon Description

Header is shared.

Header is shared and has been modified since it was added from the workspace 
sharing it.

Header is not shared has been modified.

Header has not been modified.
If you are working in a workspace version in edit mode, the header is not shared.
If you are working in a workspace version in a mode other than edit mode, this icon is 
displayed for all headers. The sharing status is unknown.
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• To add a header that is shared by another workspace, click the Add Shared Header tab.

1. From the Workspace drop-down box, select the workspace that shares the header you want 
to use.

2. From the Header drop-down box, select the header to use.

4. Click OK.

5. Configure the header and add header variables; refer to Configuring and Modifying Headers and 
Header Variables on page 102.

Configuring and Modifying Headers and Header Variables
Refer to the following topics for more information.

• Configuring and Modifying Fixed-Width Headers and Header Variables on page 102.

• Configuring and Modifying Delimited Headers and Header Variables on page 107.

• Configuring and Modifying Database Headers on page 110.

• Configuring and Modifying XML Headers and Header Variables on page 112.

• Configuring Hobsons Connect CRM Headers and Header Variables on page 119.

• Configuring Web Service Headers on page 122.

Configuring and Modifying Fixed-Width Headers and Header Variables
To configure a fixed-width header, do the following.

1. Select Configuration > Headers. 

The Header Administration dialog box appears.

2. Click the fixed-width header you want to modify and either right-click it and select Edit or click .

The Header Editor dialog box appears.
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Figure 17: Header Editor Dialog Box
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3. In the Header Information pane, do the following.

1. Type the name of the header in the Header Name field.

2. From the Match Result Display drop-down box, select the procedure that defines the information 
that is displayed in the Results pane in the Job window when a match occurs. Refer to 
Configuring Procedures on page 127 for more information about procedures.

For an overview of the steps required to configure jobs that use this query to populate the Results 
pane in the Job window, refer to Specifying Data Displayed in the Results Pane on page 237.

3. Check the QAS Enabled checkbox to enable QAS on the header. By default, this option is 
enabled. 

When a job is created using this header, Perceptive DataTransfer checks the associated 
connection group for a QAS connection. If there is no connection, it is assumed that you are not 
using QAS in the procedures associated with the job. If a QAS connection is found, the QAS 
connection is tested; if the test is unsuccessful, the job status is set to Connection_Error, and you 
must correct the connection before you can run the job. This verification is performed each time 
you attempt to run the job. 

For more information about adding QAS connections, refer to Adding QAS Connections on 
page 84.

4. In the File Properties pane, check the appropriate checkbox.

• Exclude First Row: Check to exclude the first row in the file when processing the file. By 
default, this checkbox is not checked.

• Trim Whitespace: Check to remove the whitespace of data fields when processing the data. 
By default, this checkbox is checked.

4. In the Header Variables pane, configure the header variables. 

5. To add a new variable, click  in the Header Variables pane.

• If you do not click a variable in the table, the new variable appears as the first entry in the table.

• If you click a variable, the new variable is added below the selected variable.

6. To modify a header variable, do the following.

1. In the Header Variables pane, select the variable you want to modify and either right-click it and 

select Edit or .

The Edit Input Variable dialog box appears.

2. In the Position field, type the number of the position of the column. You may need to adjust the 
column position if a data file changes.

Use this field to move the column to a new position and to adjust all other columns to the left or to 
the right, accordingly.
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3. In the Name field, type the name of the variable. 

4. From the Data Type drop-down box, select the data type of the variable (Character, Number, or 
Date).

In the Name field, the appropriate symbol used to specify the data type of the variable is 
appended to the first character of the name. 

$ (dollar sign) denotes a character variable, # (number sign) denotes a numeric variable, and & 
(ampersand) denotes a date variable.

5. Check the Display checkbox to display the column in the pane that displays records in the 
window that appears when you open a job.

6. Check the Sort checkbox to allow this column to be sorted in the Record panes grid in the Edit 
Job window (which appears when you click a job in the Job dashboard and either click Edit or 
right-click it and select Edit) or in the window that appears when a job is opened in the Job 
Dashboard (which appears when you select a record and either click Open or right-click it and 
select Open) You can select up to ten columns to be sorted.

Note  A column that is set as the record key is also a sortable column and counts toward the ten 
elements that can be sortable.

Sorting is based on the prefix of the input variable. If the prefix is &, sorting is based on 
timestamp (which in the end is a numeric sort); if the prefix is $, sorting is alphanumeric; and if the 
prefix is #, sorting is numeric.

These values are all stored as strings regardless of the prefix the values are converted to when 
the user opens or edits a job to prepare a job. If, for example, the prefix is # and the value does 
not convert to a numeric value, the value is managed as null; for #ZIP and value SEVEN, seven is 
null when sorted.

7. In the Tooltip field, type the text that you want to appear when you hover your mouse over the 
column in the pane that displays records that appears when you open a job.

8. In the Start field, type the start position of the column. Note the following:

• The end position is adjusted accordingly.

• The width is not changed.

• The size of the columns next to the column (previous or next) are adjusted accordingly.

• You cannot change the start position to be larger than the end position.

• You cannot change the start position of a column that has a position of 1.

• When you move the start position to the left:

○ If you move the start position to at or before the start of any other column, the start 
position of the other columns are moved to the right accordingly.
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○ If you move the start position to between the start and end range of another column, the 
width and end position of the other column are changed (making the column smaller in 
size).

• When you move the start position to the right:

○ The column width is unchanged.

○ The end position is adjusted accordingly.

○ The width and end positions of the previous column are changed (making the column 
larger in size).

9. In the End field, type the end position of the column. Note the following:

• The end position cannot be before the start position.

• When you move the end to the left:

○ The width of the column becomes smaller in size.

○ The start position of the next column is adjusted. 

• When you move the end to the right:

○ The width of the column becomes larger in size.

○ The start position of the next column is adjusted.

10. In the Width field, type the width of the column. Note the following:

• The end position is adjusted accordingly.

• The start position of the next column is adjusted.

11. Click OK.

7. To prevent duplicate records when this header is used to run jobs, you can set a column as the 
record key. Jobs run more quickly when a column is set as a record key.

Selecting a header key allows Perceptive DataTransfer to process any records with different values in 
the selected column at the same time. You do not need to select a column that guarantees unique 
values, but the column should capture duplicate records. For example, if you select Last Name as the 
key to a header and process a file that has many records with the last name Smith, which represent 
different students, you prevent any two records with the same last name from being processed at the 
same time. 

To mark a column as the record key, select the column and click .

The  icon appears next to the column to denote that it is the record key.

You can mark one column only as the record key; you cannot configure composite keys.

Note  A column that is set as the record key is also a sortable column and counts toward the ten 
elements that can be sortable.
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8. To delete a variable, select it and either right-click it and select Delete or click .

In the Data Preview pane, you can preview data by clicking the preview data button; click the clear 
preview data button to clear the information displayed in the pane.

9. Click .

The Upload Preview File dialog box appears.

10. Click Browse... and navigate to the file that you want to preview, and then select it.

11. Click Preview.

The data is displayed in the Data Preview pane. 

12. To clear data from the pane, click .

Configuring and Modifying Delimited Headers and Header Variables
To configure a delimited header, do the following.

1. Select Configuration > Headers. 

The Header Administration dialog box appears.

2. Click the delimited header you want to modify and either right-click it and select Edit or click .

The Header Editor dialog box appears.

3. In the Header Information pane, do the following.

1. Type the name of the header in the Header Name field.

2. From the Match Result Display drop-down box, select the procedure that defines the information 
that is displayed in the Results pane in the Job window when a match occurs. Refer to 
Configuring Procedures on page 127 for more information about procedures.

For an overview of the steps required to configure jobs that use this query to populate the Results 
pane in the Job window, refer to Specifying Data Displayed in the Results Pane on page 237.

3. Check the QAS Enabled checkbox to enable QAS on the header. By default, this option is 
enabled. 

When a job is created using this header, Perceptive DataTransfer checks the associated 
connection group for a QAS connection. If there is no connection, it is assumed that you are not 
using QAS in the procedures associated with the job. If a QAS connection is found, the QAS 
connection is tested; if the test is unsuccessful, the job status is set to Connection_Error, and you 
must correct the connection before you can run the job. This verification is performed each time 
you attempt to run the job. 

For more information about adding QAS connections, refer to Adding QAS Connections on 
page 84.
Perceptive DataTransfer Administrator Guide Page 107 of 301



4. In the File Properties pane, check the appropriate checkbox:

• First Row Column Names: Check to load the first row of the data file into the file header that 
is used for column names.

• Delimited: Check to specify that the input file is opened as a delimited file. Then click the 
appropriate radio button.

○ Tab: Click to specify that the file is opened as a tab-delimited file.

○ Specify: Click to set a value by which the data is delimited in the field and provide the 
value in the Specify field.

• Exclude First Row: Check to exclude the first row in the file when processing the file. By 
default, this checkbox is not checked.

• Trim Whitespace: Check to remove the whitespace of data fields when processing the data. 
By default, this checkbox is checked.

4. To add a new variable, click  in the Header Variables pane.

• If you do not click a variable in the table, the new variable appears as the first entry in the table.

• If you click a variable, the new variable is added below the selected variable.

5. To edit a header, do the following.

1. In the Header Variables pane, select the variable you want to modify and either right-click it and 

select Edit or .

The Edit Input Variable dialog box appears.

2. In the Position field, type the number of the position of the column. You may need to adjust the 
column position if a data file changes.

3. In the Name field, type the name of the variable. 

4. From the Data Type drop-down box, select the data type of the variable (Character, Number, or 
Date).

5. In the Name field, the appropriate symbol used to specify the data type of the variable is 
appended to the first character of the name. 

$ (dollar sign) denotes a character variable, # (number sign) denotes a numeric variable, and & 
(ampersand) denotes a date variable.

6. Check the Display checkbox to display the column in the pane that displays records in the 
window that appears when you open a job.

7. Check the Sort checkbox to allow this column to be sorted in the Record panes grid in the Edit 
Job window (which appears when you click a job in the Job dashboard and either click Edit or 
right-click it and select Edit) or in the window that appears when a job is opened in the Job 
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Dashboard (which appears when you select a record and either click Open or right-click it and 
select Open) You can select up to ten columns to be sorted.

Note  A column that is set as the record key is also a sortable column and count toward the ten 
columns that can be sortable.

Sorting is based on the prefix of the input variable. If the prefix is &, sorting is based on 
timestamp (which in the end is a numeric sort); if the prefix is $, sorting is alphanumeric; and if the 
prefix is #, sorting is numeric.

These values are all stored as strings regardless of the prefix the values are converted to when 
the user opens or edits a job to prepare a job. If, for example, the prefix is # and the value does 
not convert to a numeric value, the value is managed as null; for #ZIP and value SEVEN, seven is 
null when sorted.

8. In the Tooltip field, type the text that appears when you hover your mouse over the column in the 
pane that displays records that appears when you open a job.

9. Click OK.

6. To prevent duplicate records when this header is used to run jobs, you can set a column as the 
record key. Jobs run more quickly when a column is set as a record key.

Selecting a header key allows Perceptive DataTransfer to process any records with different values in 
the selected column at the same time. You do not need to select a column that guarantees unique 
values, but the column should capture duplicate records. For example, if you select Last Name as the 
key to a header and process a file that has many records with the last name Smith, which represent 
different students, you prevent any two records with the same last name from being processed at the 
same time. 

To mark a column as the record key, select the column and click .

The  icon appears next to the column to denote that it is the record key.

You can mark one column only as the record key; you cannot configure composite keys.

Note  A column that is set as the record key is also a sortable column and count toward the ten 
elements that can be sortable.

7. To delete a variable, select it and either right-click it and select Delete or click .

In the Data Preview pane, you can preview data by clicking the preview data button; click the clear 
preview data button to clear the information displayed in the pane.

8. Click .

The Upload Preview File dialog box appears.

9. Click Browse... and navigate to the file that you want to preview, and then select it.

10. Click Preview.
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The data is displayed in the Data Preview pane. 

11. To clear data from the pane, click .

Configuring and Modifying Database Headers
You can use database headers to dynamically extract input data from the database and use it when a job 
is run. For an overview of steps you must perform to dynamically obtain input data from the database for 
a job, refer to Obtaining Input Data from the Database on page 230.

To configure a database header, do the following.

1. Select Configuration > Headers. 

The Header Administration dialog box appears.

2. Click the database header you want to modify and either right-click it and select Edit or click .

The Header Editor dialog box appears.

3. In the Header Information pane, do the following.

1. Type the name of the header in the Header Name field.

2. From the Match Result Display drop-down box, select the procedure that defines the information 
that is displayed in the Results pane in the Job window when a match occurs. Refer to 
Configuring Procedures on page 127 for more information about procedures.

For an overview of the steps required to configure jobs that use this query to populate the Results 
pane in the Job window, refer to Specifying Data Displayed in the Results Pane on page 237.

3. In the Population Selection field, select the Database Population Selection procedure that 
contains the query that dynamically extracts the input data. The query that captures the header 
input variables and displays them in the Header Variables pane. Refer to Configuring Procedures 
on page 127 for more information about procedures.

For an overview of the steps required to configure jobs into which input data is automatically 
extracted, refer to Obtaining Input Data from the Database on page 230.
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4. Check the QAS Enabled checkbox to enable QAS on the header. By default, this option is 
enabled. 

When a job is created using this header, Perceptive DataTransfer checks the associated 
connection group for a QAS connection. If there is no connection, it is assumed that you are not 
using QAS in the procedures associated with the job. If a QAS connection is found, the QAS 
connection is tested; if the test is unsuccessful, the job status is set to Connection_Error, and you 
must correct the connection before you can run the job. This verification is performed each time 
you attempt to run the job. 

For more information about adding QAS connections, refer to Adding QAS Connections on 
page 84.

4. If you selected a query in the Population Selection field, to capture header variables from the query, 
click Capture. The header variables are displayed in the Header Variables pane.

Note  Perceptive DataTransfer uses the aliases in the selected Database Population Selection procedure 
to create and store column headings (input variables). You cannot edit these input variables.

5. To edit a header variable, do the following.

1. In the Header Variables pane, select the variable you want to modify and either right-click it and 

select Edit or .

The Edit Input Variable dialog box appears.

2. In the Position field, type the number of the position of the column. You may need to adjust the 
column position if a data file changes.

3. In the Name field, type the name of the variable. 

4. From the Data Type drop-down box, select the data type of the variable (Character, Number, or 
Date).

In the Name field, the appropriate symbol used to specify the data type of the variable is 
appended to the first character of the name. 

$ (dollar sign) denotes a character variable, # (number sign) denotes a numeric variable, and & 
(ampersand) denotes a date variable.

5. Check the Display checkbox to display the column in the pane that displays records in the 
window that appears when you open a job.
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6. Check the Sort checkbox to allow this column to be sorted in the Record panes grid in the Edit 
Job window (which appears when you click a job in the Job dashboard and either click Edit or 
right-click it and select Edit) or in the window that appears when a job is opened in the Job 
Dashboard (which appears when you select a record and either click Open or right-click it and 
select Open) You can select up to ten columns to be sorted.

Note  A column that is set as the record key is also a sortable column and count toward the ten 
columns that can be sortable.

Sorting is based on the prefix of the input variable. If the prefix is &, sorting is based on 
timestamp (which in the end is a numeric sort); if the prefix is $, sorting is alphanumeric; and if the 
prefix is #, sorting is numeric.

These values are all stored as strings regardless of the prefix the values are converted to when 
the user opens or edits a job to prepare a job. If, for example, the prefix is # and the value does 
not convert to a numeric value, the value is managed as null; for #ZIP and value SEVEN, seven is 
null when sorted.

7. In the Tooltip field, type the text that appears when you hover your mouse over the column in the 
pane that displays records that appears when you open a job.

8. Click OK.

6. To prevent duplicate records when this header is used to run jobs, you can set a column as the 
record key. Jobs run more quickly when a column is set as a record key.

Selecting a header key allows Perceptive DataTransfer to process any records with different values in 
the selected column at the same time. You do not need to select a column that guarantees unique 
values, but the column should capture duplicate records. For example, if you select Last Name as the 
key to a header and process a file that has many records with the last name Smith, which represent 
different students, you prevent any two records with the same last name from being processed at the 
same time. 

To mark a column as the record key, select the column and click .

The  icon appears next to the column to denote that it is the record key.

You can mark one column only as the record key; you cannot configure composite keys.

Note  A column that is set as the record key is also a sortable column and count toward the ten 
columns that can be sortable.

7. To delete a variable, select it and either right-click it and select Delete or click .

Configuring and Modifying XML Headers and Header Variables
Note  You do not provide input variables for XML header jobs, because XML syntax for procedures 
allows you to reference every node in the XML by the exact XML tag name. Other input files have an input 
variable for each data field in the file, but for XML input files, you must use the for each and node syntax 
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to navigate to the desired part of the XML tree. For information about configuring for each and node 
syntax for procedures that process XML files, refer to Understanding the for each Statement on 
page 273.

To configure an XML header, do the following.

1. Select Configuration > Headers. 

The Header Administration dialog box appears.

2. Click the XML header you want to modify and either right-click it and select Edit or click .

The Header Editor dialog box appears.

3. In the Header Information pane, do the following.

1. Type the name of the header in the Header Name field.

2. From the Match Result Display drop-down box, select the procedure that defines the information 
that is displayed in the Results pane in the Job window when a match occurs. Refer to 
Configuring Procedures on page 127 for more information about procedures.

For an overview of the steps required to configure jobs that use this query to populate the Results 
pane in the Job window, refer to Specifying Data Displayed in the Results Pane on page 237.

3. Check the QAS Enabled checkbox to enable QAS on the header. By default, this option is 
enabled. 

When a job is created using this header, Perceptive DataTransfer checks the associated 
connection group for a QAS connection. If there is no connection, it is assumed that you are not 
using QAS in the procedures associated with the job. If a QAS connection is found, the QAS 
connection is tested; if the test is unsuccessful, the job status is set to Connection_Error, and you 
must correct the connection before you can run the job. This verification is performed each time 
you attempt to run the job. 

For more information about adding QAS connections, refer to Adding QAS Connections on 
page 84.

4. Do one of the following.

• If you are using an XSD document, proceed to step 5.

• If you are using an XML document, proceed to step 6.

5. If you are using an XSD document to create the header, do the following.

1. Place your main XSD file and any XSD schema files that are referenced within the main XSD file 
into a .zip file.
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For example, for an XSD file with the name HighSchoolTranscript_v1.1.0.xsd that contains the 
following:

<?xml version="1.0" encoding="utf-8"?>

<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema" 
xmlns:core="core:CoreMain:v1.8.0" xmlns:AcRec="sector:AcademicRecord:v1.5.0" 
xmlns:HSTrn="message:HighSchoolTranscript:v1.1.0" 
targetNamespace="message:HighSchoolTranscript:v1.1.0" version="v1.1.0">

<xs:import namespace="core:CoreMain:v1.8.0" 
schemaLocation="CoreMain_v1.8.0.xsd"/>

<xs:import namespace="sector:AcademicRecord:v1.5.0" 
schemaLocation="AcademicRecord_v1.5.0.xsd"/>

<xs:element name="HighSchoolTranscript">

<xs:complexType>

<xs:sequence>

<xs:element name="TransmissionData" type="AcRec:TransmissionDataType"/>

<xs:element name="Student" type="AcRec:K12StudentType"/>

<xs:element name="NoteMessage" type="core:NoteMessageType" minOccurs="0" 
maxOccurs="unbounded"/>

<xs:element name="UserDefinedExtensions" 
type="core:UserDefinedExtensionsType" minOccurs="0"/>

</xs:sequence>

</xs:complexType>

</xs:element>

</xs:schema>

The file contains references to these schemas:

• <xs:import namespace="urn:org:pesc:core:CoreMain:v1.8.0" 
schemaLocation="CoreMain_v1.8.0.xsd"/>

• <xs:import namespace="urn:org:pesc:sector:AcademicRecord:v1.5.0" 
schemaLocation="AcademicRecord_v1.5.0.xsd"/>

HighSchoolTranscript_v1.1.0.xsd (the main file) and CoreMain_v_1.8.0.xsd and 
AcademicRecord_v1.5.0.xsd (the referenced files) are placed in the .zip file.

Note  If a file that is referenced from the main file has references to other files, you must include 
those files in the .zip file. For example, if AcademicRecord_v.1.5.0.xsd referenced other files, 
those must also be included in the .zip file.

2. Obtain the name of your main XSD file, including the extension.

In the preceding example, the main XSD file is HighSchoolTranscript_v1.1.0.xsd.

3. Open the XSD file and obtain the name of the root element of your document.
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In the preceding example, the root element is HighSchoolTranscript.

4. Preview data by doing the following.

1. In the XML Preview pane, click  and select Preview XSD File. The Upload XSD Preview 
File dialog box appears.

2. In the Upload Zip File field, click Browse..., navigate to the location of the .zip file with the 
XSD file you want to preview, and select it.

3. In the Master Filename field, type the name of the main XSD file. In the preceding example, 
the main XSD file is HighSchoolTranscript_v1.1.0.xsd.

4. In the Root Element field, type the name of the root element. In the preceding example, the 
root element is HighSchoolTranscript.

5. Click Preview. The XSD file is uploaded, and its contents are displayed in the XML Preview 
pane.

5. Proceed to step 7.

6. If you are using an XML document to create the header, preview data by doing the following.

1. In the XML Preview pane, click  and select Preview XML File.

The Upload XML Preview File dialog box appears.

2. Click Browse..., navigate to the location of the XML file you want to preview, and select it.

3. Click Preview.

The XML file is uploaded, and its contents are displayed in the XML Preview pane.
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Figure 18: XML Preview Pane Displaying XML File Data

4. Proceed to step 7.

7. To expand all nodes in the XML tree, either click  or right-click a node and select Expand All; to 

collapse them, either click  or right-click a node and select Collapse All.

8. Set a record identifier by selecting the appropriate XML node and either right-clicking it and selecting 

Set Record Identifier or clicking . The node set as the record identifier is the node that denotes 
the start of each record.

Figure 19: XML Identifier Student
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The XML tree refreshes and marks the corresponding nodes as record identifiers. The Identifier field 
in the Header Information pane displays the name of the identifier.

Note  If you change the record identifier after you create a job using the XML header, the job will not 
run properly.

9. If you select an end node in the XML tree, the  appears. If you click the icon, the XML tag will be 
displayed in the Records pane (the topmost, leftmost pane in either the Edit Job or Open Job 
windows). You can also right-click a node and select Set to Display. 

A  icon appears next to XML tags that will appear in the Records pane.

Nodes that are selected to appear in the Records pane are displayed in the Element Order pane.

Figure 20: XML Node Set to be Displayed in the Records Pane

If you select a node that is marked to appear in the Records pane, the  appears. If you click this 
icon, the XML node will not be displayed in the Records pane. You can also right-click a node and 
select Set to Hide.

A  icon appears next to XML tags that will not appear in the Records pane.

10. Configure the order of XML elements specified to be displayed in the Records pane. The Element 
Order pane displays the nodes you selected to be displayed.

To configure the element order, select the appropriate node in the Element Order pane and do one of 
the following.

• Click  to move the node to be the first node to be displayed.

• Click  to move the node up one position.
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• Click  to move the node down one position.

• Click  to move the node to the last position.

11. To allow an element to be sortable in the Record panes grid in the Edit Job window (which appears 
when you click a job in the Job dashboard and either click Edit or right-click it and select Edit) or in 
the window that appears when a job is opened in the Job Dashboard (which appears when you select 

a record and either click Open or right-click it and select Open), click the element and click the . 
You can select up to ten elements to be sortable. 

To remove sorting from the element, select an element on which sorting is enabled and click .

Note  Neither icon appears if you have selected the maximum of ten elements to be sortable and you 
select a element that is not sortable.

Note  An element that is set as the record key is also a sortable column and counts toward the ten 
columns that can be sortable.

12. To prevent duplicate records when this header is used to run jobs, you can set a column as the 
record key. Jobs run more quickly when a column is set as a record key.

Selecting a header key allows Perceptive DataTransfer to process any records with different values in 
the selected column at the same time. You do not need to select a column that guarantees unique 
values, but the column should capture duplicate records. For example, if you select Last Name as the 
key to a header and process a file that has many records with the last name Smith, which represent 
different students, you prevent any two records with the same last name from being processed at the 
same time. 

To mark a column as the record key, select the column and click .

The  icon appears next to the column to denote that it is the record key.

You can mark one column only as the record key; you cannot configure composite keys.

Note  A column that is set as the record key is also a sortable column and counts toward the ten 
columns that can be sortable.

13. To hide a displayed node that appears in the Element Order pane, select the node and click . The 
node is hidden and is removed from the Element Order pane.
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14. To change the name of an XML node to be displayed in the Records pane, do the following.

1. Click the node you want to rename in the Element Order pane and click .

The Edit Display Name dialog box appears.

2. In the Display Name field, type the name to be displayed in the Records pane. The heading of the 
column is changed to this name when the XML node is displayed in the Records pane.

3. Click OK.

Note  Changing the XML node name does not change the XML tag; it only changes the display name 
used in the Record pane when jobs are opened or edited.

When you open or edit a job that uses an XML header, the columns in the Record pane are populated 
and ordered based on the tags you specified to be displayed and the order in which you displayed.

You can view the full XML record in the Record pane; refer to Modifying Records on page 240.

Configuring Hobsons Connect CRM Headers and Header Variables
To configure Hobsons Connect CRM header, do the following.

1. Select Configuration > Headers. 

The Header Administration dialog box appears.

2. Click the Hobsons Connect CRM header you want to modify and either right-click it and select Edit 

or click .

The Header Editor dialog box appears.

3. In the Header Information pane, do the following.

1. In the Header Name field, type the name of the header. 

2. From the Match Result Display drop-down box, select the procedure that defines the information 
that is displayed in the Results pane in the Job window when a match occurs. Refer to 
Configuring Procedures on page 127 for more information about procedures.

For an overview of the steps required to configure jobs that use this query to populate the Results 
pane in the Job window, refer to Specifying Data Displayed in the Results Pane on page 237.

3. From the Connection Group drop-down box, select the connection group to use for the header. 
The connection group must have a Hobsons connection configured; the header uses the 
Hobsons connection, from the selected connection group. 

Note  The connection is not saved on the header; you must select the connection each time you 
modify the header.

The Header Filters pane appears after you select a connection group. 
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4. To add a Hobsons Connect CRM filter, in the Header Filters pane, do the following.

1. Click .

The Select Filters dialog box appears and displays filters obtained from the Hobsons connection. 
The dialog box displays only those filters you have not already selected.

2. Select one filter to add or select multiple filters by doing one of the following.

• Click a filter and press and hold the Ctrl key as you click each filter with your mouse.

• Click a filter and press and hold the Shift key as you click another filter to select contiguous 
filters.

3. Click OK.

5. To delete a filter, in the Header Filters pane, select the filter you wan to delete and click .

6. To add a new variable, do the following.

1. Click  in the Header Variables pane. The variables are retrieved from the Hobsons connection 
and are a displayed in a new dialog box.

• If you do not click a variable in the table, the new variable appears as the first entry in the 
table.

• If you click a variable, the new variable is added below the selected variable.

2. Select one variable to add or select multiple variables by doing one of the following.

• Click a variable and press and hold the Ctrl key as you click each variable with your mouse.

• Click a variable and press and hold the Shift key as you click another variable to select 
contiguous variables.

3. Click OK.

7. To modify a header variable, in the Header Variables pane, do the following.

1. Select the variable you want to modify and either right-click it and select Edit or .

The Edit Input Variable dialog box appears.

2. In the Position field, type the number of the position of the column. You may need to adjust the 
column position if a data file changes.

3. In the Name field, type the name of the variable. 
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4. From the Data Type drop-down box, select the data type of the variable (Character, Number, or 
Date).

In the Name field, the appropriate symbol used to specify the data type of the variable is 
appended to the first character of the name. 

$ (dollar sign) denotes a character variable, # (number sign) denotes a numeric variable, and & 
(ampersand) denotes a date variable.

5. Check the Display checkbox to display the column in the pane that displays records in the 
window that appears when you open a job.

6. Check the Sort checkbox to allow this column to be sorted in the Record panes grid in the Edit 
Job window (which appears when you click a job in the Job dashboard and either click Edit or 
right-click it and select Edit) or in the window that appears when a job is opened in the Job 
Dashboard (which appears when you select a record and either click Open or right-click it and 
select Open) You can select up to ten columns to be sorted.

Note  A column that is set as the record key is also a sortable column and count toward the ten 
columns that can be sortable.

Sorting is based on the prefix of the input variable. If the prefix is &, sorting is based on 
timestamp (which in the end is a numeric sort); if the prefix is $, sorting is alphanumeric; and if the 
prefix is #, sorting is numeric.

These values are all stored as strings regardless of the prefix the values are converted to when 
the user opens or edits a job to prepare a job. If, for example, the prefix is # and the value does 
not convert to a numeric value, the value is managed as null; for #ZIP and value SEVEN, seven is 
null when sorted.

7. Click OK.

8. To prevent duplicate records when this header is used to run jobs, you can set a column as the 
record key. Jobs typically run more quickly when a column is set as a record key.

Selecting a header key allows Perceptive DataTransfer to process any records with different values in 
the selected column at the same time. You do not need to select a column that guarantees unique 
values, but the column should capture duplicate records. For example, if you select Last Name as the 
key to a header and process a file that has many records with the last name Smith, which represent 
different students, you prevent any two records with the same last name from being processed at the 
same time. 

To mark a column as the record key, select the column and click .

The  icon appears next to the column to denote that it is the record key.

You can mark one column only as the record key; you cannot configure composite keys.

Note  A column that is set as the record key is also a sortable column and count toward the ten 
columns that can be sortable.
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9. To delete a variable, in the Header Variables pane, select the variable you wan to delete and click 

.

10. To preview data in the Data Preview pane, click Preview.

Perceptive DataTransfer runs the Hobsons Connect CRM web service for the selected filter and input 
variables; the data returned from the web service is displayed in Data Preview pane. 

11. To clear data from the pane, click .

Configuring Web Service Headers
Use a web service header when you are using web services to retrieve data; refer to Configuring Web 
Service Data Providers on page 157 for more information.

To configure a web service header, do the following.

1. Select Configuration > Headers. 

The Header Administration dialog box appears.

2. Click the web service header you want to modify and either right-click it and select Edit or click .

The Header Editor dialog box appears.

3. In the Header Information pane, do the following.

1. Type the name of the header in the Header Name field.

2. From the Match Result Display drop-down box, select the procedure that defines the information 
that is displayed in the Results pane in the Job window when a match occurs. Refer to 
Configuring Procedures on page 127 for more information about procedures.

For an overview of the steps required to configure jobs that use this query to populate the Results 
pane in the Job window, refer to Specifying Data Displayed in the Results Pane on page 237.

3. Check the QAS Enabled checkbox to enable QAS on the header. By default, this option is 
enabled. 

When a job is created using this header, Perceptive DataTransfer checks the associated 
connection group for a QAS connection. If there is no connection, it is assumed that you are not 
using QAS in the procedures associated with the job. If a QAS connection is found, the QAS 
connection is tested; if the test is unsuccessful, the job status is set to Connection_Error, and you 
must correct the connection before you can run the job. This verification is performed each time 
you attempt to run the job. 

For more information about adding QAS connections, refer to Adding QAS Connections on 
page 84.
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4. In the Web Service Properties pane, do the following.

1. From the Web Service drop-down box, select the web service data provider with which you want 
to configure the header.

2. Select the connection group associated with the web service you want to use from the 
Connection Group drop-down box. This drop-down box displays the connection groups that 
contain web service connections that match the name of the connection selected when you 
configured the web service data provider.

5. Click the Capture button to create the header input variables using the output parameters you 
configured for the data provider.

6. To prevent duplicate records when this header is used to run jobs, you can set a column as the 
record key. Jobs run more quickly when a column is set as a record key.

Selecting a header key allows Perceptive DataTransfer to process any records with different values in 
the selected column at the same time. You do not need to select a column that guarantees unique 
values, but the column should capture duplicate records. For example, if you select Last Name as the 
key to a header and process a file that has many records with the last name Smith, which represent 
different students, you prevent any two records with the same last name from being processed at the 
same time. 

To mark a column as the record key, select the column and click .

The  icon appears next to the column to denote that it is the record key.

You can mark one column only as the record key; you cannot configure composite keys.

Note  A column that is set as the record key is also a sortable column and count toward the ten 
elements that can be sortable.

7. To delete a variable in the Header Variables pane, select it and either right-click it and select Delete 

or click .

In the Data Preview pane, you can preview data by clicking the preview data button; click the clear 
preview data button to clear the information displayed in the pane.

8. Click .

The Upload Preview File dialog box appears.

9. Click Preview.

The data is displayed in the Data Preview pane. 

10. To clear data from the pane, click .
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Removing Sharing on Headers
To remove sharing on a header that is shared with another workspace, do the following.

1. Select Configuration > Headers. 

The Header Administration dialog box appears.

2. Select the header and either right-click it and select Remove Sharing or click .

Sharing on the header is removed.

Rolling Back Headers
If changes have been made and committed to a header, you can use a previous version (roll back) of it.

1. Select Configuration > Headers. 

The Header Administration dialog box appears.

2. Select the header you want to roll back and either right-click it and select Rollback Header or click 

.

The Rollback Manager dialog box appears and displays the following information about previous 
versions of the procedure.

• Name: Name of the header.

• Status: Status of the header (current or dated).

• Version Date: Date on which the version was created.

• Created By: Username of the user who created the version.

• Comments: Comments that were added about the version.

3. Select the version to which you want to revert and click Rollback.

The header is updated to use the selected previous version of the header.

Obtaining the Latest Versions of Headers
If changes have been made to and committed to a header, you can obtain the latest version of it.

1. Select Configuration > Headers. 

The Header Administration dialog box appears.

2. Select the header for which you want to obtain the latest version and either right-click it and select 

Get Latest or click .

The header is updated to the latest version.
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Deleting Headers
To delete a header, do the following.

1. Select Configuration > Headers. 

The Header Administration dialog box appears.

2. Select the header that you want to delete and either right-click it and select Delete or click .

A message appears, prompting you to confirm that you want to delete the header.

3. Click Yes.

The header is deleted and is removed from the Header Administration dialog box.

Exporting Headers
You can export headers to an XML file by doing the following.

1. Select Configuration > Headers.

The Header Administration dialog box appears.

2. Select the header you want to export.

3. Click  and select Export.

4. Save the file to the appropriate location.

Importing Headers
You can import headers from an XML file by doing the following.

1. Select Configuration > Headers.

The Header Administration dialog box appears.

2. Click  and select Import.

The Import File Source dialog box appears.

3. Click the Browse... button and navigate to the file that you want to import or type the location of the 
file in the File field.
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4. Check the Update Existing Entities checkbox to update an existing header, with the same name as 
the header you are importing, with the header you are importing. 

If you do not check this checkbox, and there is an existing header with the same name as the header 
you are importing, DUPLICATE- is appended to the start of the name of the header you are importing; 
the existing header is not updated. If a header exists with the name DUPLICATE-<header_name>, 
DUPLICATE(2)- is appended to the start of the name. The number continues to be incremented so 
that all headers have unique names.

5. Click OK.
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Configuring Procedures

Refer to the following topics for more information:

• Understanding Perceptive DataTransfer Logic on page 128.

• Understanding Variables on page 129.

• Configuring Variables on page 130.

• Configuring Libraries on page 139.

• Configuring Procedures on page 142.

• Importing and Exporting Libraries and Procedures on page 153.

Figure 21: Procedure Editor
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Understanding Perceptive DataTransfer Logic
Perceptive DataTransfer logic is divided into the following sections, which collect procedures related to 
the process. 

• Match Process comprises all procedures and flow control related to matching input records to 
existing records in your database. 

• Review Process comprises all procedures and flow control related to selecting data from your 
database for potential matches.

• Upload Process comprises all procedures and flow control related to adding or updating information 
in your database.

• Match Result Display logic defines the query that retrieves the information displayed in the Results 
panel of the Job window when a match occurs. This query retrieves data based on a specified ID 
value; data columns returned by the query correspond to the columns of the Results pane. 

You use this logic in a procedure and associate it with a header; when a job associated with the 
header is run, the query returns the information in the Results pane.

For an overview of the steps required to configure jobs that use this query to populate the Results 
pane in the Job window, refer to Specifying Data Displayed in the Results Pane on page 237.

• Database Population Selection logic contains the query for dynamically extracting input data for a 
job. You use this logic in a procedure and associate the procedures with a database header; when a 
job associated with this header is run, the query extracts data from the database source.

For example:

begin-procedure test-query

!

   begin-select

      SSN “$SSN”,

      FIRST “$FIRST”,

      LAST “$LAST”,

      MI “$MI”,

      DOB “+DOB”,

      SEX “$SEX”,

      FROM table_name

   end-select

!

end-procedure

For an overview of steps for dynamically extracting input data for a job from a database, refer to 
Obtaining Input Data from the Database on page 230.

For information about configuring logic, refer to Programming Concepts on page 261.
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Procedures and libraries are used to organize logic within each option.

Understanding Procedures
Procedures contain the logic that defines how Perceptive DataTransfer determines if there are potential 
matches between the input data and existing records in the database and how information in the 
database is added or updated. 

Procedures can also be shared and reused through workspaces. To add a procedure shared by another 
workspace, the workspace version in which you are working must be in edit mode, and the workspace 
version that contains the procedure you are importing must be in staged or active mode. For more 
information about workspaces, refer to Configuring Workspaces on page 205.

For more information about configuring logic, such as procedure syntax, refer to Programming Concepts 
on page 261.

Understanding Libraries
Libraries are used to group similar types of procedures within a category. For example, for Match Process 
procedures, you can have the libraries Match Control and Match Display, and you can group related 
procedures within these libraries.

Understanding Variables
Refer to the following topics for more information.

• Understanding Data Types on page 129.

• Understanding Variable Categories on page 130.

• Understanding Naming Conventions on page 130.

Understanding Data Types
Perceptive DataTransfer has with three predefined data types for variables and constants.

• Character: Stores string values.

• Date: Stores date values.

• Number: Stores numeric values.
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Understanding Variable Categories
Perceptive DataTransfer uses two types of variables:

• Input: Represents each column of an input file.

• Program: User-defined or custom variables.

You should use lowercase text to name program variables to more easily distinguish them from input 
variables. 

Understanding Naming Conventions
Perceptive DataTransfer examines the first character in a variable name to determine the data type of the 
variable. The data type designators are:

• $: Designates a character variable

• &: Designates a date variable

• #: Designates a numeric variable

Configuring Variables
For definitions of global variables, refer to Understanding Global Variables on page 275 in Programming 
Concepts on page 261.

Refer to the following topics for more information.

• Adding Variables on page 131.

• Adding Missing Variables on page 131.

• Modifying Variables on page 132.

• Deleting Variables on page 133.

• Importing Variables on page 134.

• Exporting Variables on page 134.

• Searching Variables on page 135.

• Finding Unused Variables on page 135.

• Watching Variables on page 136.

• Clearing Variables From the Watch List on page 136.

• Moving Variables to Groups on page 137.

• Moving Variables to Groups on page 137.

• Configuring Groups on page 137.
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Adding Variables
Note  All input variables, including header variables, must have unique names.

To add a variable, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to add a variable and either right-click it 
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. In the Program Variables pane, click the All tab.

3. Click . 

The Add Variable dialog box appears.

Figure 22: Add Variable Dialog Box

4. In the Variable name field, type the name of the variable.

5. Click Apply.

6. Continue to add variables, as appropriate; when you are finished, click OK.

The variable is added and is displayed in the Program Variables pane.

Adding Missing Variables
You can search for missing program variables and add any variables that are referenced in the code but 
do not exist to Perceptive DataTransfer. 

To add missing variables for all procedures, refer to Adding Missing Variables for All Procedures on 
page 132.

To add missing variables for a selected procedure, refer to Adding Missing Variables for a Single 
Procedure on page 132.
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Adding Missing Variables for All Procedures

To search for and add missing variables for all Perceptive DataTransfer procedures, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to add a variable and either right-click it 
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. In the Procedures pane, click  and select Add Missing Variables.

Perceptive DataTransfer searches all procedures for program variables referenced within the 
procedure code. Any referenced program variables that do not exist are created.

Adding Missing Variables for a Single Procedure

To add missing variables for a single Perceptive DataTransfer procedure, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to add a variable and either right-click it 
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. Select the procedure for which you want to search for missing variables.

3. In the Procedure Editor pane, click .

Perceptive DataTransfer searches the selected procedure for program variables referenced within the 
procedure code. Any referenced program variables that do not exist are created.

Modifying Variables
To modify a variable, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to edit a variable and either right-click it 
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. In the Program Variables pane, click the All tab.

3. Select the variable you want to modify and either right-click it and select Modify or click .

The Edit Variable dialog box appears.
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Figure 23: Edit Variable Dialog Box

4. In the Variable name field, type the name of the variable.

5. Click Apply.

6. Click OK.

The name of the variable is modified, and its information appears in the Program Variables pane.

Deleting Variables
To delete a variable, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to delete a variable and either right-click 
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. In the Program Variables pane, click the All tab.

3. Select the variable you want to delete and either right-click it and select Delete or click .

The variable is deleted and is removed from the Program Variables pane.
Perceptive DataTransfer Administrator Guide Page 133 of 301



Importing Variables
You can import variables from an XML file by doing the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to import a variable and either right-click 
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

• Select Tools > ImageNow; then, in the The ImageNow Index Map Administration dialog box, 

select an ImageNow index map and click  to open the Edit ImageNow Index Map dialog box.

• Select Tools > Data Providers; then, in the Data Providers Administration dialog box, select a 

data provider and click  to open the Edit Web Service Data Provider dialog box. 

2. Click  and select Import.

The Import Variable dialog box appears.

3. Click the Browse... button and navigate to the file that you want to import or type the location of the 
file in the File field.

4. Click OK.

Exporting Variables
You can export variables to an XML file by doing the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to export a variable and either right-click 
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

• Select Tools > ImageNow; then, in the The ImageNow Index Map Administration dialog box, 

select an ImageNow index map and click  to open the Edit ImageNow Index Map dialog box.

• Select Tools > Data Providers; then, in the Data Providers Administration dialog box, select a 

data provider and click  to open the Edit Web Service Data Provider dialog box. 

2. Click  and select Export.

3. Save the file to the appropriate location.
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Searching Variables
You can search for whole variables or partial text of variables.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to search a variable and either right-click 
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. In the Program Variables pane, do one of the following.

• To search for watched variables, click the Watch tab. 

• To search through all variables, click the All tab.

3. In the text field in the Program Variables pane, type the text for which you want to search. You can 
use whole words or partial text; if you use partial text, all items starting with the beginning character 
are returned in the search. Use % as the wildcard character for partial text searches.

For example, if you search for #c%, all variables that start with #c (including the whole variable #c) are 
returned in the search.

4. Press Enter on your keyboard.

Matches that are found are displayed in the Program Variables pane. If no matching text is found in 
the search, the pane does not display any entries. 

Finding Unused Variables
You can search all procedures to find references to variables that are not being used. Program variables 
that appear in procedures in any part of the code or in code that is commented out are considered used 
variables.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to search a variable and either right-click 
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. In the Program Variables pane, click  and select Find Unused.

The Unused Program Variables pane appears and displays the variables that are not used.

3. If you have permission to edit program variables, you can delete unused variables. Do one of the 
following.

• To delete a single variable, select it and click .

• To delete multiple variables, select the variables by clicking a variable and pressing and holding 

the Ctrl key as you click each variable with your mouse. Next, click .
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Watching Variables
When you run a job in interactive mode and view it in the window that appears when you edit a job, the 
Program Variables pane displays all program variables. If you have many program variables, to more 
easily view results for specific variables, you can place such variables in the Watch tab.

To watch a variable, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to watch a variable and either right-click 
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. To watch all program variables referenced within a procedure, click  in the Procedure Editor. All 
referenced variables are added to the Watch tab.

3. To watch a single variable or all variables, in the Program Variables pane, click the All tab.

• To watch a single variable, select the variable you want to watch and either right-click it and 

select Watch or click .

The variable is moved to the Watch tab.

• To watch multiple variables, select the variables by clicking a variable and pressing and holding 

the Ctrl key as you click each variable with your mouse. Next, click .

The variables are moved to the Watch tab.

Clearing Variables From the Watch List
To clear variables from the watch list, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to clear a watch variable and either right-
click it and select Edit or click the Edit button. In the window that appears, click the Procedures 
tab.

• Select Configuration > Procedures. 

2. In the Program Variables pane, click the Watch tab.

3. Do one of the following.

• To clear a single variable, select it and click .

• To clear multiple variables, select the variables by clicking a variable and pressing and holding 

the Ctrl key as you click each variable with your mouse. Next, click .

• To clear all watch variables, either do not select a variable, or select a single variable; then, click 

.
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Moving Variables to Groups
To move a variable to a group, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to move a variable to a group and either 
right-click it and select Edit or click the Edit button. In the window that appears, click the 
Procedures tab.

• Select Configuration > Procedures. 

2. In the Program Variables pane, click the All tab.

3. Do one of the following.

• To move a single variable, select the variable that you want to move and either right-click it and 

select the Move to Group or click .

• To move multiple variables, select the variables by clicking a variable and pressing and holding 

the Ctrl key as you click each variable with your mouse. Next, click .

The Move Variable to Group dialog box appears.

4. From the Group drop-down box, select the group to which you want to move the variable.

5. Click OK.

The variable is moved to the specified group.

Configuring Groups
You can use groups to manage variables for similar types. For example, you can create a Form Variables 
group in which to place form variables.

Refer to the following topics for more information.

• Adding Groups on page 137.

• Renaming Groups on page 138.

• Deleting Groups on page 139.

Adding Groups

To add a group, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to add a group and either right-click it 
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. In the Program Variables pane, click the Groups tab.
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3. Click .

The Add Group dialog box appears.

4. In the Name field, type the name of the field.

5. Click OK.

The group is added and appears in the Groups tab.

Renaming Groups

To rename a group, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to rename a group and either right-click 
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. In the Program Variables pane, click the Groups tab.

3. Select the group you want to rename and either right-click it and select Rename or click .

The Rename Group dialog box appears.

Figure 24: Rename Group Dialog Box

4. In the Name field, type the name of the group and click OK.

The name of the group is updated, and its information appears in the Program Variables pane.
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Deleting Groups

To delete a group or all groups, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to delete a group and either right-click it 
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. In the Program Variables pane, click the Groups tab.

3. Do one of the following.

• Select the group you want to delete and either right-click it and select Delete or click .

• To delete all groups, click . 

The Confirm Delete dialog box appears, prompting you to confirm that you want to delete the 
selected group or all groups.

4. Click Yes to delete the group.

Configuring Libraries
Refer to the following topics for more information.

• Adding Libraries on page 140.

• Renaming Libraries on page 140.

• Specifying Control Libraries on page 141.

• Deleting Libraries on page 142.

• Importing and Exporting Libraries and Procedures on page 153.

Note  In the Procedures pane, you can click  to expand all buttons in the pane; to collapse them, click 
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Adding Libraries
To add a library, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to add a library and either right-click it 
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. Select the type of procedure to which you want to add a library and either right-click it and select Add 

Library or click .

The New Library dialog box appears.

Figure 25: Add Library Dialog Box

3. In the Library Name field, type the name of the library.

4. In the Description field, type descriptive text about the library.

5. Click OK.

The library is added and appears in the Procedures pane.

Renaming Libraries
To rename a library, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to rename a library and either right-click 
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. Select the library you want to rename and either right-click it and select Rename Library or click .

The Rename Library dialog box appears.
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Figure 26: Rename Library Dialog Box

3. In the Library Name field, type the name of the library.

4. Click OK.

The library is renamed, and its information is refreshed in the Procedures pane.

Specifying Control Libraries
You set a library as the control library when you want the library to control the flow of the process. A 
control library is the library from which the first code is run for each of the Match, Review, and Upload 
processes. 

Do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to specify a control library and either 
right-click it and select Edit or click the Edit button. In the window that appears, click the 
Procedures tab.

• Select Configuration > Procedures. 

2. Select the library you want to set as the control library and either right-click it and select Control 

Library or click .

The library is configured as the control library, and the  icon appears next to the library.
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Deleting Libraries
Note  You cannot delete a library that contains procedures. You must first delete all procedures from the 
library before deleting the library. 

To delete a library, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to delete a library and either right-click it 
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. Select the library you want to delete and either right-click it and select Delete Library or click .

The library is deleted and is removed from the Procedures pane.

Configuring Procedures
You can share procedures with other workspaces, and you can import procedures from and export 
procedures to an XML file.

To open the Procedure Editor, do one of the following.

• Select Configuration > Procedures from the main application toolbar.

• In the Job Dashboard, select the job for which you want to configure procedures and then either 
right-click it and select Edit or click the Edit button; then, in the window that appears, click the 
Procedures tab.

Refer to the following topics for more information.

• Understanding Procedure Keyboard Shortcuts on page 143.

• Adding Procedures on page 143.

• Understanding Procedure Icons on page 145.

• Configuring Procedure Code on page 146.

• Copying Procedures on page 147.

• Renaming Procedures on page 148.

• Adding and Removing Comments to Lines on page 148.

• Finding Unused Procedures on page 149.

• Finding Referenced Procedures on page 150.

• Activating Procedures on page 150.

• Deactivating Procedures on page 150.

• Removing Sharing on Procedures on page 151.

• Rolling Back Procedures on page 151.
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• Searching Procedures on page 152.

• Importing and Exporting Libraries and Procedures on page 153.

Understanding Procedure Keyboard Shortcuts
Refer to the following table for descriptions of shortcut keys for the Procedure Editor.

Adding Procedures
To add a procedure, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to add a procedure and either right-click 
it and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. Select the library to which you want to add a procedure and either right-click it and select Add 

Procedure or click .

The Add Procedure dialog box appears.

Table 1: Procedure Editor Shortcut Keys and Descriptions

Shortcut Key Description

SHIFT+F8 Continue

SHIFT+F6 Next line

CTRL+ALT+F Find/Replace

CTRL+ALT+W Watch all variables

CTRL+ALT+M Add missing variables

CTRL+ALT+B Clear breakpoints

CTRL+1 Toggle comment

CTRL+ALT+S Save
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Figure 27: Add Procedure Dialog Box

3. Do one of the following.

• To add a new procedure, do the following.

1. Click the Add Procedure tab.

2. In the Procedure Name field, type the name of the procedure.

3. In the Description field, type descriptive text about the procedure.

• To add a procedure that is shared by another workgroup, do the following.

1. Click the Add Shared Procedure tab.

2. From the Workspace drop-down box, select the workspace that contains the shared 
procedure. 

3. In the Procedure Name drop-down, select the procedure.

Note  Only procedures that belong to workspaces in staged or active mode are available for 
sharing.

4. Click OK.

The procedure is added and is displayed in the Procedures pane.
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Understanding Procedure Icons
Refer to the following table for a description of the icons that appear next to procedures in the 
Procedures pane.

Table 5: Procedure Icons and Descriptions

Icon Description

Procedure is deactivated, has been modified, and is not shared.

Procedure is shared, has been modified since it was added from the workspace 
sharing it, and is deactivated.

Procedure is not shared and has been modified.

Procedure is not shared, contains errors, and has been modified.

Procedure is shared and has been modified since it was added from the workspace 
sharing it.

Procedure is not shared, contains errors, and has not been modified.

This procedure has not been modified.

If you are working in a workspace version in edit mode, the procedure is not shared.
If you are working in a workspace version in a mode other than edit mode, this icon is 
displayed for all procedures. The sharing status is unknown.

Procedure is not shared, contains errors, and is deactivated.

Procedure is not shared and is deactivated.

Procedure is not shared, has been modified, and is deactivated.

Procedure is shared.

Procedure is shared and has since been updated in the workspace sharing it.
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Configuring Procedure Code
You configure procedure code in the Procedure Editor, which you can open by doing one of the following.

• In the Job Dashboard, select the job for which you want to add a procedure and either right-click it 
and select Edit or click the Edit button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

For information about configuring logic for procedures, refer to Programming Concepts on page 261.

Perceptive DataTransfer highlights code syntax as follows.

• Comments, beginning with ! or from ! to the end of the line, appear in green.

Figure 28: Comment Text

• Keywords, which are reserved words such as begin-procedure, begin-select, let, do, and so on, 
appear blue.

Figure 29: Keyword Text

• Text strings appear in maroon.

Figure 30: Text String Text
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• Global variables appear in pink.

Figure 31: Global Variable Text

• SKIP, STOP and the on-error=display-error (which appears in the begin-sql line) appear in red. 

Figure 32: SKIP, STOP, on-error=display-error Text

• Errors are highlighted in red. Hover your mouse over the number to display a tooltip with information 
about the issue.

Figure 33: Highlighted Lines of Code with Errors

Copying Procedures
To create a duplicate of a procedure, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to copy a procedure and either right-
click it and select Edit or click the Edit button. In the window that appears, click the Procedures 
tab.

• Select Configuration > Procedures. 

2. Select the procedure you want to copy and either right-click it and select Copy Procedure or click 

.

The procedure is copied, and the new procedure is added under the original procedure in the 
Procedures pane.
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Renaming Procedures
To rename a procedure, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to rename a procedure and either right-
click it and select Edit or click the Edit button. In the window that appears, click the Procedures 
tab.

• Select Configuration > Procedures. 

2. Select the procedure you want to rename and either right-click it and select Rename or click .

The Rename Procedure dialog box appears.

Figure 34: Rename Procedure Dialog Box

3. In the Procedure Name field, type the name of the procedure.

4. Click OK.

The procedure is renamed and is updated in the Procedures pane.

Adding and Removing Comments to Lines
You can quickly add or remove the comment symbol ( ! ) from the start of selected lines by doing the 
following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to add or remove a comment and either 
right-click it and select Edit or click the Edit button. In the window that appears, click the 
Procedures tab.

• Select Configuration > Procedures. 

2. In the Procedures pane, select procedure for which you want to add or remove comments.
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3. Select the line or lines to which you want to add or remove comments.

4. In the Procedure Editor pane, click . One of the following occurs.

• If all selected lines start with !, excluding whitepsace, the lines are uncommented.

• If one or more selected lines do not start with !, excluding whitepsace, one ! is added to the start 
of each selected line.

Finding Unused Procedures
You can search all procedures to find references to procedures that are not being used. Control, Match 
Result, and Data Population procedures are not included in the unused procedures search.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to search a procedure and either right-
click it and select Edit or click the Edit button. In the window that appears, click the Procedures 
tab.

• Select Configuration > Procedures. 

2. In the Procedures pane, click  and select Find Unused Procedures.

The Unused Procedures pane appears and displays the procedures that are not used.

3. If you have permission to edit procedures, you can delete unused procedures. Do one of the 
following.

• To delete a single procedure, select it and click .

• To delete multiple procedures, select the procedures by clicking a procedure and pressing and 

holding the Ctrl key as you click each procedure with your mouse. Next, click .

A dialog box appears, prompting you to confirm that you want to delete the procedure.

4. Click Yes.

If you try to delete procedures for which you do not have edit permissions, those procedures are not 
deleted.
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Finding Referenced Procedures
You can search for procedures that are referenced by other procedures by doing the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to search for a referenced procedure and 
either right-click it and select Edit or click the Edit button. In the window that appears, click the 
Procedures tab.

• Select Configuration > Procedures. 

2. In the Procedures pane, select the procedure for which you want to search other procedures for 
references.

3. Click  and select Referenced By.

Perceptive DataTransfer searches all procedures for references to the selected procedure. When the 
search completes, a dialog box appears and displays the procedures that contain references to the 
procedure you selected.

Deactivating Procedures
When you deactivate a procedure, the procedure is not used when logic is run; it is skipped. You can 
reactivate procedures that have been deactivated.

To deactivate a procedure, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to deactivate a procedure and either 
right-click it and select Edit or click the Edit button. In the window that appears, click the 
Procedures tab.

• Select Configuration > Procedures. 

2. Right-click the procedure you want to deactivate and select Deactivate.

The procedure is deactivated.

Activating Procedures
To activate a procedure that is deactivated, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to activate a procedure and either right-
click it and select Edit or click the Edit button. In the window that appears, click the Procedures 
tab.

• Select Configuration > Procedures. 

2. Right-click the procedure you want to activate and select Activate.

The procedure is activated.
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Removing Sharing on Procedures
To remove sharing on a procedure that is shared with another workspace, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to remove sharing on a procedure and 
either right-click it and select Edit or click the Edit button. In the window that appears, click the 
Procedures tab.

• Select Configuration > Procedures. 

2. Select the procedure and either right-click it and select Remove Sharing or click .

Sharing is removed on the procedure.

Rolling Back Procedures
If changes have been made and committed to a procedure, you can use a previous version (roll back) of 
it.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to roll back a procedure and either right-
click it and select Edit or click the Edit button. In the window that appears, click the Procedures 
tab.

• Select Configuration > Procedures. 

2. Select the procedure you want to roll back and either right-click it and select Rollback Procedure or 

click .

The Rollback Manager dialog box appears and displays the following information about previous 
versions of the procedure.

• Name: Name of the procedure.

• Status: Status of the procedure (pending, current, or dated).

• Version Date: Date on which the version was created.

• Created By: Username of the user who created the version.

• Comments: Comments that were added about the version.

3. Select the version to which you want to revert and click Rollback.

A dialog box appears and prompts you to confirm that you want to use the selected version of the 
procedure.

4. To use the selected version, click Yes.

The procedure is updated to use the selected previous version of the procedure.
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Obtaining the Latest Version of Procedures
If changes have been made to and committed to a procedure, you can obtain the latest version of it.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to obtain the latest version of a 
procedure and either right-click it and select Edit or click the Edit button. In the window that 
appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. Select the procedure for which you want to obtain the latest version and either right-click it and select 

Get Latest or click .

The procedure is updated to the latest version.

Searching Procedures
You can search for information in all procedures or in a specific procedure. Searches use case-sensitive 
text.

1. Do one of the following.

• In the Job Dashboard, select the job for which you want to search a procedure and either right-
click it and select Edit or click the Edit button. In the window that appears, click the Procedures 
tab.

• Select Configuration > Procedures. 

2. Do one of the following:

• To search for information in all procedures, click  in the Procedures toolbar.

• To search for text within a specific procedure, select the procedure and click  in the toolbar of 
the Procedure Editor.

The Find/Replace dialog box appears.

Figure 35: Find/Replace Dialog Box
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3. In the Find field, type the text for which you want to search.

4. In the Replace field, type the text with which you want to replace the text in the Find field.

5. Perceptive DataTransfer searches all procedures for the text that you entered. If a match is found, the 
matched text is highlighted in yellow in the Procedure Editor. If no matches are found, a dialog box 
appears and indicates that there are no matches.

6. To find the next occurrence of the text, click Next. When no more matches are found, the first match 
results are displayed again. If no matches were found, a dialog box appears and indicates that no 
matches were found.

7. To replace the found text with the text you specified in the Replace field, click Replace.

Importing and Exporting Libraries and Procedures
You can import procedures and libraries from XML documents, and you can export them to XML 
documents. You can:

• Export all procedures.

• Export a single procedure.

• Export a single library, which includes all its procedures.

• Import one or more libraries, including their procedures.

• Import a single procedure into a library.

Refer to the following topics for more information.

• Importing Libraries on page 154.

• Exporting Single Libraries on page 154.

• Importing Single Procedures on page 155.

• Exporting Single Procedures on page 156.

• Exporting All Procedures and Libraries on page 156.
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Importing Libraries
You can import files that contain either the entire procedure tree or a single library and its corresponding 
procedures.

Note  XML files that contain a single exported library are named beginning with LIB (for example, 
LIB55.xml). XML files that contain all libraries and procedures (the entire procedure tree) are named 
beginning with PRCS (for example, PRCS987.xml.) You can import XML files of these types. If you try to 
import a file type other than a library, a popup message appears that indicates import did not complete 
because the file type was not appropriate.

1. Do one of the following.

• In the Job Dashboard, select a job and either right-click it and select Edit or click the Edit button. 
In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. Click  and select Import Libraries.

The Import Libraries dialog box appears.

3. Click the Browse... button and navigate to the XML file that contains the libraries you want to import, 
or type the location of the file in the File field.

4. Check the Update Existing Entities checkbox to update an existing library, with the same name as 
the library you are importing, with the library you are importing. 

If you do not check this checkbox, and there is an existing library with the same name as the library 
you are importing, DUPLICATE- is appended to the start of the name of the library you are importing; 
the existing library is not updated. If there is a library with the name DUPLICATE-<library_name>, 
DUPLICATE(2)- is appended to the start of the name. The number continues to be incremented so 
that all libraries have unique names.

5. Click OK.

The Import Report appears and displays information about the import.

Exporting Single Libraries
To export a single library, do the following.

1. Do one of the following.

• In the Job Dashboard, select a job and either right-click it and select Edit or click the Edit button. 
In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. Select the appropriate library.
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3. Click and select Export.

4. Save the file in the appropriate location.

XML files that contain libraries are named starting with LIB (for example, LIB55.xml). You can import 
files of this type when you are importing libraries (when you import a single library and all its 
procedures).

Importing Single Procedures
Note  XML files that contain a single exported procedure are named beginning with PROC (for example, 
PROC123.xml). You can import XML files of this type. If you try to import a file type other than a single 
procedure, a popup message appears that indicates import did not complete because the file type was 
not appropriate.

To import a single procedure, do the following.

1. Do one of the following.

• In the Job Dashboard, select a job and either right-click it and select Edit or click the Edit button. 
In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. Select the library into which you want to import the procedure.

3. Click  and select Import.

The Import Procedure dialog box appears.

4. Click the Browse... button and navigate to the file that contains the procedure you want to import, or 
type the location of the file in the File field.

5. Check the Update Existing Entities checkbox to update an existing procedure, with the same name 
as the procedure you are importing, with the procedure you are importing. 

If you do not check this checkbox, and there is an existing procedure with the same name as the 
procedure you are importing, DUPLICATE- is appended to the start of the name of the procedure you 
are importing; the existing procedure is not updated. If a procedure exists with the name 
DUPLICATE-<procedure_name>, DUPLICATE(2)- is appended to the start of the name. The number 
continues to be incremented so that all procedures have unique names.

6. Click OK.

The Import Report appears and displays information about the import.
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Exporting Single Procedures
To export a single procedure, do the following.

1. Do one of the following.

• In the Job Dashboard, select the job a job and either right-click it and select Edit or click the Edit 
button. In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. Select the procedure you want to export.

3. Click and select Export.

4. Save the file in the appropriate location.

XML files that contain a single exported procedure are named beginning with PROC (for example, 
PROC123.xml). You can import files of this type when you import a single procedure.

Exporting All Procedures and Libraries
You can export all procedures and libraries (the entire procedure tree) as an XML file by doing the 
following.

1. Do one of the following.

• In the Job Dashboard, select a job and either right-click it and select Edit or click the Edit button. 
In the window that appears, click the Procedures tab.

• Select Configuration > Procedures. 

2. Do one of the following.

• Without clicking any selection in the Procedures pane, click and select Export.

• Select a procedure type node (such as Match Process), library, or procedure; then, click 

and select Export All.

3. Save the file in the appropriate location.

XML files that contain a all exported procedures are named beginning with PRCS (for example, 
PRCS987.xml). You can import files of this type when you import libraries (when you import the entire 
procedure tree).
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Configuring Web Service Data Providers

You can configure Perceptive DataTransfer to use data provider web services for communication. 
Perform the following steps to configure a web service data provider.

1. Add and configure a web service connection. Refer to Adding Web Service Connections on page 88.

2. Provide the appropriate permissions to configure the data provider by enabling the Edit Data 
Providers privilege in Administration > User. For more information about privileges, refer to 
Configuring Users And Privileges on page 63.

3. Add a data provider. Refer to Adding Web Service Data Providers on page 157.

4. Configure the data provider. Refer to Modifying Web Service Data Providers on page 157.

5. Test the data provider. Refer to Testing Web Service Data Providers on page 163.

6. Create a web service header. Refer to Configuring Web Service Headers on page 122

7. Create a job that uses the web service connection and header. Refer to Configuring Jobs and 
Processing Records on page 227.

8. Configure the code to run the web services. Refer to Configuring Web Service Data Provider Program 
Functions on page 165.

Adding Web Service Data Providers
To add a web service data provider, do the following.

1. Select Configuration > Data Providers.

The Data Provider Administration dialog box appears.

2. Click .

The Add Data Provider dialog box appears. Do one of the following.

○ To add a new data provider, click the Add Data Provider tab. In the Name field, type the 
name of the data provider and select Web Service from the Type drop-down box.

○ To add a data provider that another workspace is sharing, click the Add Shared Data 
Provider tab. Then, from the Workspace drop-down box, select the workspace that is 
sharing the data provider, and select the data provider from the Data Provider drop-down 
box.

3. Click OK.

Modifying Web Service Data Providers
When you save a web service data provider, only the connection name is saved; the URL associated with 
the connection is not saved so that you can configure only one web service data provider and use the 
appropriate connection, depending on the connection group chosen, for two different servers. 
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For example, you may have the following:

• Both test and production servers that use the web service.

• A test connection group with a web service connection using the test URL.

• A production connection group with a web service using the production URL.

If you name both connections DTSIS and use the DTSIS connection, you can use the same data provider 
for both URLs.

For example, you save a data provider with DTSIS as the connection. The next time you open the data 
provider to edit it, the application checks the connection groups in alphabetical order and searches for a 
connection with the name DTSIS. If a connection with that name is found, that connection and its 
associated connection group are automatically displayed in the corresponding drop-down boxes. If the 
connection is not found, the Connection Group and Connection drop-down boxes do not automatically 
display any data, and the message A valid web service connection must be selected appears in 
the Connection URL field.

To modify a web service data provider, do the following.

1. Select Configuration > Data Providers.

The Data Provider Administration dialog box appears.

2. Select the web service data provider you want to modify and either right-click it and select Edit or 

click .

The Edit Web Service Data Provider dialog box appears.
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Figure 36: Edit Web Service Data Provider Dialog Box

3. In the Name field, type the name of the web service data provider.

4. In the Description field, type descriptive text about the data provider.
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5. From the Connection Group drop-down box, select the connection group that contains the 
connection you want to use for the web service data provider. The connection groups that you have 
permission to view and use are displayed in the drop-down box.

6. From the Connection drop-down box, select the connection, which belongs to the connection group 
you selected, to use for the data provider. 

After you select a connection, the Connection URL field in the right-top pane displays the URL for the 
connection. You cannot modify this field. If you do not provide a valid connection, the field displays 
the text A valid web service connection must be selected.

7. From the HTTP Method field, select the HTTP method used by the web service request (GET, POST, 
PUT, or DELETE). 

8. Click the URL Suffix tab and type the URL suffix to the web service being requested. The URL suffix 
is the portion of the web service request that is dynamic (the parameters). When the web service is 
run, the connection URL and the URL suffix are combined to obtain the full web service URL.

9. Click the Payload tab to add a request body, if necessary.

• If you are using JSON, type either the URL query string to use after the connection to the web 
service has been made or a JSON-formatted object.

• If you are using XML, type either the URL query string to use after the connection to the web 
service has been made or an XML-formatted request.

10. In the REST Type field, click the radio button for the REST web service type used by the web service 
request (XML or JSON).

11. Map Perceptive DataTransfer program variables to web service input and output parameters by 
dragging and dropping variables from the Program Variables pane to the Input and Output panes.

When you add an input or output parameter, the name of the program variable is the name of the 
input or output parameter, and it appears in the Name column. For example, if you map the $ws_id 
program variable to an input parameter, the input parameter is named $ws_id, which appears in the 
Name column.

12. In the Input pane, double-click in the field and type the appropriate information.

• Description: Type descriptive text about the parameter.

• Location: Ordinal value of the field. The first field has a value of {0} (zero), the second field has a 
value of {1}, and so on

• Sub Expression: Type the values to be substituted into the input fields. You must always use {0} 
for the substitution value. When the web service is run, the value of the program variable is 
substituted into {0}.

13. In the Output pane, double-click in the field and type the appropriate information.

• Description: Type descriptive text about the parameter.

• Query: Type the XPath (if you are using XML) or JSONPath (if you are using JSON) query used to 
retrieve information from the results of the web service request.

14. Click OK.
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Deleting Web Service Data Providers
To delete a web service data provider, do the following.

1. Select Configuration > Data Providers.

The Data Provider Administration dialog box appears.

2. Select the data provider you want to delete and either right-click it and select Delete or click .

The data provider is deleted and is removed from the Data Provider Administration dialog box.

Copying Data Providers 
To create a duplicate of a data provider, do the following.

1. Select Configuration > Data Providers.

The Data Provider Administration dialog box appears.

2. Select the data provider you want to copy and either right-click it and select Copy or click .

A copy of the data provider is created and appears in the Data Provider Administration dialog box.

Removing Sharing on Data Providers
To remove sharing on a data provider that is shared with another workspace, do the following.

1. Select Configuration > Data Providers.

The Data Provider Administration dialog box appears.

2. Select the data provider for which you want to remove sharing and either right-click it and select 

Remove Sharing or click .

Sharing is removed on the data provider.

Rolling Back Data Providers
If changes have been made and committed to a data provider, you can use a previous version (roll back) 
of it.

1. Select Configuration > Data Providers.

The Data Provider Administration dialog box appears.

2. Click the data provider you want to roll back and either right-click it and select Rollback or click .

The Rollback Manager dialog box appears and displays the following information.

• Name: Name of the data provider.

• Status: Status of the data provider (current or dated).
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• Version Date: Date and time on which the version was created.

• Created By: Username of the user who created the data provider.

• Comments: Comments that were added by the user.

3. Select the previous version to which you want to revert and click Rollback.

The previous version is loaded.

Obtaining the Latest Versions of Data Providers
If changes have been made to and committed to a data provider, you can obtain the latest version of it.

1. Select Configuration > Data Providers.

The Data Provider Administration dialog box appears.

2. Click the data provider for which you want to obtain the latest version and either right-click it and 

select Get Latest or click .

Exporting Data Providers
You can export a data provider to an XML file by doing the following.

1. Select Configuration > Data Providers.

The Data Provider Administration dialog box appears.

2. Select the data provider you want to export.

3. Click  and select Export.

4. Save the file to the appropriate location.

Importing Data Providers
You can import a data provider from an XML file by doing the following.

1. Select Configuration > Data Providers.

The Data Provider Administration dialog box appears.

2. Click  and select Import.

The Import Data Provider dialog box appears.

3. Click the Browse... button and navigate to the file that you want to import or type the location of the 
file in the File field.
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4. Check the Update Existing Entities checkbox to update an existing data provider, with the same 
name as the data provider you are importing, with the data provider you are importing. 

If you do not check this checkbox, and there is an existing data provider with the same name as the 
data provider you are importing, DUPLICATE- is appended to the start of the name of the data 
provider you are importing; the existing data provider is not updated. If a data provider exists with the 
name DUPLICATE-<data_provider_name>, DUPLICATE(2)- is appended to the start of the name. The 
number continues to be incremented so that all data providers have unique names.

5. Click OK.

Testing Web Service Data Providers
To test a web service data provider, do the following.

1. Select Configuration > Data Providers.

The Data Provider Administration dialog box appears.

2. Select the web service data provider you want to test and either right-click it and select Edit or click 

.

The Edit Web Service Data Provider dialog box appears.

3. Click Test.

The Web Service Test dialog box appears.
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Figure 37: Web Service Test Dialog Box

4. In the Input Data pane, double-click the Value column and type a value to test.

5. Click Execute.

The Request URL tab displays the full URL used for the web service. If you did not select a web 
service connection when testing the web service, the test does not work, and the Request URL tab 
displays a Malformed URL message.

The Output field displays the values of the output parameters.
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Configuring Web Service Data Provider Program Functions
After you configure a web service connection and a web service data provider, you can run these web 
services in the code, using the following DataProviderCall and DataProviderPrompt keywords.

Understanding the DataProviderCall Function
This function takes a single parameter, which is the name of the web service to run. For example:

let $ws_id = '10'

DataProviderCall('personWS') 

In this example, personWS is the name of the web service to run. When Perceptive DataTransfer reaches 
this line of code, it runs the personWS web service by doing the following.

1. Perceptive DataTransfer looks up the web service by the supplied data provider name.

2. It verifies the current connection group, which is the group configured for the job configured to run, 
for the saved connection name.

3. Perceptive DataTransfer finds the connection for the connection group. One of the following occurs.

• If it finds the matching connection, it uses the URL to run the web service request; then, it 
populates the input parameters with the values of the mapped program variables. If the web 
service returns more than one result, the first result in the list is used to populate the program 
variables.

• If it does not find a matching connection, the web service request results in an error.

In the preceding example, after the personWS web service is run, the output values are inserted into the 
mapped program variables. The value of the $ws_fist_name parameter is Fred, the value of the 
$ws_last_name parameter is Cook, and the value of the $ws_id parameter is 10. 

For detailed information about programming concepts and syntax, refer to Programming Concepts on 
page 261.

Understanding the DataProviderPrompt Function
This function takes two parameters: a prompt and the name of the web service. For example:

let $ws_id = ' '

let $ws_first_name = ' '

let $ws_last_name = ' '

DataProviderPrompt 'Choose the matching person.', 'personWS'

The command runs the specified web service, as described in Understanding the DataProviderCall 
Function on page 165. It also displays a prompt to users, who can select the result they want to view.
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You can also set two optional parameters; both parameters are strings (for example, string literals, string 
expressions, string variables, and so on). Use a Y (or y) value to indicate that the option is enabled. The 
parameters are:

• The first parameter is a flag to hide the prompt if no results are returned by the data provider—if the 
request had no results, Perceptive DataTransfer does not prompt the user to select one. For example:

let $ws_id = ' '

let $ws_first_name = ' '

let $ws_last_name = ' '

DataProviderPrompt 'Choose the matching person.', 'personWS', 'Y'

• The second parameter is a flag to automatically select the result if exactly one result is returned by 
the data provider—if the data provider returns a single record, the record is auto-selected without the 
prompt being displayed. For example:

let $ws_id = ' '

let $ws_first_name = ' '

let $ws_last_name = ' '

DataProviderPrompt 'Choose the matching person.', 'personWS', 'Y', 'Y'

In the Result Selection dialog box, the prompt you supplied appears in the field at the top of the dialog 
box. All results returned by the web service appear in the table below.

Figure 38: Result Selection Dialog Box
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After a user selects a row, the OK button is enabled. If the user clicks OK, all the values from the selected 
row are placed into the mapped program variables.

This prompt appears when a job is running in interactive mode only. If this function is processed when a 
job is run in batch mode, Perceptive DataTransfer checks the number of return results. The following 
occurs.

• If there are no results, the output program variables are set to the empty string. 

• If there is one result, the output values are placed into the mapped program variables.

• If there is more than one result, the record is suspended with a Too may results reason.

Understanding the begin-dataprovider Function
You can use a begin-dataprovider/end-dataprovider block of code to run a specified data provider and 
iterate over its results.

For example, consider the following begin-select syntax.

begin-select

        nu_id   ~#pers_nuid

let #nu_id = #pers_nuid

        let $status = 'M'

        let $mtch_code = 'MP1'

        store 1, '#nu_id'                ! rank, ID - will be fed to review process

        stop                             ! exit match process here

FROM nu_person

        WHERE ssn = ~$f_ssn

      end-select

The preceding example could use a data provider instead of a SQL query, as follows.

begin-dataprovider 'personWS'

        let $status = 'M'

        let $mtch_code = 'MP1'

        store 1, '$ws_id'                ! rank, ID - will be fed to review process

        stop                             ! exit match process here

      end-dataprovider

After begin-dataprovider, you must provide the name of the data provider to run. In the preceding 
example, personWS is the name of the data provider.
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The same code can be used inside begin-select as it is inside begin-dataprovider. Also, similar to begin-
select, begin-dataprovider runs the data provider and iterates over the results, running the lines of codes 
for each result.

Like an exit-select statement that exits the begin-select/end-select code block, exit-dataprovider exits 
the begin-dataprovider/end-dataprovider code.
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Configuring Document Templates

You can configure document templates that can be used in the NQL code to create files based on the 
template definition for uploading to Nolij Web or Image now.

Adding and Modifying Document Templates 
To add a document template, do the following.

1. Select Configuration > Document Templates.

The Document Administration dialog box appears.

2. Do one of the following.

• To add a new document template, click .

The Add Document Template dialog box appears. Do one of the following.

• To add a new document template, click the Add Document Template tab and type a name 
for the template in the Name field.

• To add a document template that another workspace is sharing, click the Add Shared 
Document Template tab. Then, from the Workspace drop-down box, select the workspace 
that is sharing the document template, and select the template from the Document Template 
drop-down box.

• To modify a document template, select the template you want to modify and either right-click it 

and select Edit or click .

The Edit Document Template dialog box appears.
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Figure 39: Edit Document Template Dialog Box

3. Click OK.

4. In the name field, type the name of the document template.

5. In the Description field, type descriptive text about the template.

6. In the Type field, type the file type (the file extension) for the file created from the template.

7. In the Template field, click Browse... and navigate to the location of the document template you want 
to upload.
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The contents of the file appears in the text field below the Browse... button, and the Type field 
displays the type of the uploaded document template. You can modify both fields.

Document template text can contain program variables. When a document is created from the 
template, the variables are replaced with their values, creating a dynamic, context-sensitive 
document. Use the PopulateTemplate function in the NQL to create such a document (for more 
information, refer to Understanding the PopulateTemplate Function on page 293).

8. Click OK.

Deleting Document Templates
To delete a document template, do the following.

1. Select Configuration > Document Templates.

The Document Template Administration dialog box appears.

2. Select the document template you want to delete and either right-click it and select Delete or click 

.

The document template is deleted and is removed from the Document Template Administration 
dialog box.

Copying Document Templates
To create a duplicate of a document template, do the following.

1. Select Configuration > Document Templates.

The Document Template Administration dialog box appears.

2. Select the document template you want to copy and either right-click it and select Copy or click .

A copy of the document template is created and appears in the Document Template Administration 
dialog box.

Removing Sharing on Document Templates
To remove sharing on a document template that is shared with another workspace, do the following.

1. Select Configuration > Document Templates.

The Document Template Administration dialog box appears.

2. Select the document template for which you want to remove sharing and either right-click it and 

select Remove Sharing or click .

Sharing is removed on the document template.
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Rolling Back Document Templates
If changes have been made and committed to a document template, you can use a previous version (roll 
back) of it.

1. Select Configuration > Document Templates.

The Document Template Administration dialog box appears.

2. Click the document template you want to roll back and either right-click it and select Rollback or 

click .

The Rollback Manager dialog box appears and displays the following information.

• Name: Name of the document template.

• Status: Status of the document template (current or dated).

• Version Date: Date and time on which the version was created.

• Created By: Username of the user who created the document template.

• Comments: Comments that were added by the user.

3. Select the previous version to which you want to revert and click Rollback.

The previous version is loaded.

Obtaining the Latest Versions of Document Templates
If changes have been made to and committed to a document template, you can obtain the latest version 
of it.

1. Select Configuration > Document Templates.

The Document Template Administration dialog box appears.

2. Click the document template for which you want to obtain the latest version and either right-click it 

and select Get Latest or click .

Exporting Document Templates
You can export a document template to an XML file by doing the following.

1. Select Configuration > Document Templates.

The Document Template Administration dialog box appears.

2. Select the document template you want to export.

3. Click  and select Export.

4. Save the file to the appropriate location.
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Importing Document Templates
You can import a document template from an XML file by doing the following.

1. Select Configuration > Document Templates.

The Document Template Administration dialog box appears.

2. Click  and select Import.

The Import Document Template dialog box appears.

3. Click the Browse... button and navigate to the file that you want to import or type the location of the 
file in the File field.

4. Check the Update Existing Entities checkbox to update an existing document template, with the 
same name as the document template you are importing, with the document template you are 
importing. 

If you do not check this checkbox, and there is an existing document template with the same name 
as the document template you are importing, DUPLICATE- is appended to the start of the name of 
the document template you are importing; the existing document template is not updated. If a 
document template exists with the name DUPLICATE-<document_template_name>, DUPLICATE(2)- 
is appended to the start of the name. The number continues to be incremented so that all document 
templates have unique names.

5. Click OK.
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Configuring Forms

You can configure forms to use to compare the current input record side-by-side with the possible 
existing record. You can link fields in the form to fields in the record and compare the values to view 
whether they match.

One form is contained in a workspace and is used for all jobs run within that workspace.

You can share a form with other workspaces, and you can import a form from and export a form to an 
XML file.

Note  The form is displayed for users in the Job window only when a job is running in interactive mode.

To open the form editor, select Configuration > Forms. You can also configure forms by selecting the 
appropriate job in the Job Dashboard, right-clicking it, and then selecting Edit.

Figure 40: Example Verification Form
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When users run records, they can use the form to verify that information in these linked fields matches.

Refer to the following topics for more information.

• Understanding Form Objects on page 175.

• Adding Forms on page 176.

• Adding Form Objects on page 176.

• Configuring Form and Form Object Properties on page 177.

• Linking Form Fields and Assigning Variables to Form Fields on page 186.

• Using Form Toggles on page 190.

• Moving Form Objects on page 192.

• Aligning Form Objects on page 193.

• Copying and Pasting Form Objects on page 193.

• Configuring Form Colors on page 194.

• Deleting Form Objects on page 197.

• Removing Sharing on Shared Forms on page 197.

• Rolling Back Forms on page 198.

• Obtaining the Latest Versions of Forms on page 198.

Understanding Form Objects
The following table provides a description of the form objects you can add to a form.

Table 6: Form Objects and Descriptions

Object Description

Field Set Area that contains a group of related information.

Label Text that describes an area on the form.

TextField Field in which data can be displayed.

Checkbox Element that users can check to select an option.
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Adding Forms
You can create a new form from a blank template, or you can add a form that is shared by another 
workspace. You can also create a new form from a copy of an existing form.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Select Tools > Add Form.

The Add Verification Form dialog box appears.

3. Do one of the following.

• To add a new form, click the Add Verification Form tab. Next, do one of the following:

○ Click the From Blank radio button to create a new form based on a blank template.

○ Click the From Copy radio button if you have a form configured; you create new form based 
on a copy of this existing form.

• To add a form that is shared by another workspace, click the New Shared Verification Form 
tab; then, from the Workspace drop-down box, select the workspace that shares the form you 
want to add.

4. Click OK.

The following occurs.

• If you added a blank form, the Form Editor is empty, and you can begin creating the form.

• If you added a form as a copy from a selected form, a copy of the form appears in the Form 
Editor.

• If you added a shared form, the shared form appears in the Form Editor.

Adding Form Objects
You can add labels, text fields, checkboxes, and field sets to the background of the form. You can add 
labels, text fields, and checkboxes to field sets.
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To add a new form object, do the following.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. To add a field set, either right-click the background of the form and select Add > Field Set or select 
Add > Field Set from the menu at the bottom of the window.

The field set appears in the form.

3. To add an object, do the following.

• To add an object to a field set, right-click the field set, select Add, and then select the appropriate 
object (Label, TextField, or Checkbox); or, click Add in the menu at the bottom of the window and 
select the appropriate object.

The object appears in the field set.

• To add an object to the background of the form, right-click the form, select Add, and then select 
the appropriate object (Label, TextField, or Checkbox); or, click Add in the menu at the bottom of 
the window and select the appropriate object.

The object appears in the form.

4. Click Save to save your changes.

Configuring Form and Form Object Properties
Refer to the following topics for more information.

• Configuring Default Form Properties on page 178.

• Configuring Field Set Properties on page 179.

• Configuring Text Field Properties on page 181.

• Configuring Checkbox Properties on page 184.
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Configuring Default Form Properties
To configure default form properties, do the following.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Right-click the form background and select Properties from the popup menu.

The Properties dialog box appears.

Figure 41: Properties Dialog Box

3. In the Field Set Height field, type the height, in pixels, of the field sets.

4. In the Field Set Width field, type the width, in pixels, of the field sets.

5. In the Component Width field, type the width, in pixels, of the form components.

6. In the Label Width field, type the width, in pixels, of the form labels.
Perceptive DataTransfer Administrator Guide Page 178 of 301



7. In the Alignment field, click the appropriate radio button to configure the alignment of form objects.

• Left: Aligns all objects to the left, aligning the left edges of all objects to the left edge of the form.

• Right: Aligns all objects to the right, aligning the right edges of all objects to the right edge of the 
form.

• Top: Aligns all objects to the top, aligning the top edges of all objects to the top edge of the form.

8. Click OK.

These properties are applied, by default, to all objects you add to the form.

Configuring Field Set Properties
To configure field set properties, do the following.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Right-click the field set and select Properties from the popup menu.

The Properties dialog box appears.
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Figure 42: Field Set Properties Dialog Box

3. In the Base Info pane, provide the appropriate information in the following fields.

• ID: Type the ID that uniquely identifies the field set.

You can also type this value in the ID field in the bottom of the Form Editor.

• Order: Type the order value of the field set, which is either zero (0), the higher value, or 1. 

The order determines which object appears on top of another object if they overlap. An object 
with a 0 value appears above an object with a 1 value.

Top: Type the value, in pixels, of the top margin. This value specifies boundary length between 
the top of the verification form and the field set.

You can also type this value in the Top field in the bottom of the Form Editor.
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• Left: Type the value, in pixels, of the left margin. This value specifies the boundary length 
between the left side of the verification form and the field set.

You can also type this value in the Left field in the bottom of the Form Editor.

• Height: Type the field set height, in pixels.

You can also type this value in the Height field in the bottom of the Form Editor.

• Width: Type the field set width, in pixels.

You can also type this value in the Width field in the bottom of the Form Editor.

4. In the Field Properties pane, specify the appropriate information:

• Heading: Type the name of the heading, which is the text that appears in the top of the field set to 
identify it.

You can also type this name in the Heading field in the bottom of the Form Editor.

• User Checkbox: Click the appropriate radio button to enable or disable field toggles for users. 
Field set toggles are used to determine what information, if any, can be uploaded to the database 
when differences in linked form fields are detected. Refer to Using Form Toggles on page 190 for 
more information.

5. Click OK to apply your changes and close the dialog box.

6. Click Save to save your changes.

Configuring Text Field Properties
To configure text field properties, do the following.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Right-click the text field and select Properties from the popup menu.

The Properties dialog box appears.
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Figure 43: Text Field Properties Dialog Box
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3. In the Base Info pane, provide the appropriate information in the following fields.

• ID: Type the unique ID that identifies the text field.

You can also type this value in the ID field in the bottom of the Form Editor.

• Order: Type the order value of the text field, which is either zero (0), the higher value, or 1. 

The order determines which object appears on top of another object if they overlap. An object 
with a 0 value appears above an object with a 1 value.

• Top: Type the value, in pixels, of the top margin. This value specifies boundary length between 
the top of the text field and the field set.

You can also type this value in the Top field in the bottom of the Form Editor.

• Left: Type the value, in pixels, of the left margin. This value specifies the boundary length 
between the left side of the text field and the field set.

You can also type this value in the Left field in the bottom of the Form Editor.

• Height: Type the text field height, in pixels.

You can also type this value in the Height field in the bottom of the Form Editor.

• Width: Type the text field width, in pixels.

You can also type this value in the Width field in the bottom of the Form Editor.

4. The Advanced Properties displays information that appears in the form field and information linking 
form fields together. Refer to Linking Form Fields and Assigning Variables to Form Fields on page 186 
for more information.

5. In the Field Properties pane, specify the appropriate information:

• Label: Type the text that appears in the form to identify the text field.

• Label Width: Type the width, in pixels, of the text field.

• Field Width: Type the width, in pixels, of the text field.

• Alignment: Click the appropriate radio button.

○ Left: Specifies that the label appears to the left of the text field.

○ Top: Specifies that the label appears above the text field.

○ Right: Specifies that the label appears to the right of the text field.

6. Click OK to apply your changes and close the dialog box.

7. To make the text field read-only so that users cannot modify information in the field when they view 
the verification form, check the Read Only checkbox at the bottom of the Form Editor. 

8. Click Save to save your changes.
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Configuring Checkbox Properties
To configure checkbox properties, do the following.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Right-click the checkbox and select Properties from the popup menu.

The Properties dialog box appears.

Figure 44: Checkbox Properties Dialog Box
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3. In the Base Info pane, provide the appropriate information in the following fields.

• ID: Type the ID that uniquely identifies the checkbox.

You can also type this value in the ID field in the bottom of the Form Editor.

• Order: Type the order value of the checkbox, which is either zero (0), the higher value, or 1. 

The order determines which object appears on top of another object if they overlap. An object 
with a 0 value appears above an object with a 1 value.

• Top: Type the value, in pixels, of the top margin. This value specifies boundary length between 
the top of the checkbox and the field set.

You can also type this value in the Top field in the bottom of the Form Editor.

• Left: Type the value, in pixels, of the left margin. This value specifies the boundary length 
between the left side of the checkbox and the field set.

You can also type this value in the Left field in the bottom of the Form Editor.

• Height: Type the checkbox height, in pixels.

You can also type this value in the Height field in the bottom of the Form Editor.

• Width: Type the checkbox width, in pixels.

You can also type this value in the Width field in the bottom of the Form Editor.

4. In the Field Properties pane, specify the appropriate information:

• Label: Type the text that appears in the form to identify the checkbox.

• Label Width: Type the width, in pixels, of the label.

• Field Width: Type the width, in pixels, of the checkbox.

• Alignment: Click the appropriate radio button.

○ Left: Specifies that the label appears to the left of the checkbox.

○ Top: Specifies that the label appears above the checkbox.

○ Right: Specifies that the label appears to the right of the checkbox.

5. Click OK to apply your changes and close the dialog box.

6. Click Save to save your changes.
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Configuring Label Properties
To configure label properties, do the following.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Click the label for which you want to configure properties.

3. In the ID field at the bottom of the form editor, type the ID that uniquely identifies the label.

4. In the Top field, type the value, in pixels, of the top margin. This value specifies boundary length 
between the top of the label and the field set.

5. In the Left field, type the value, in pixels, of the left margin. This value specifies the boundary length 
between the left side of the label and the field set.

6. In the Width field, type the label width, in pixels.

7. In the Height field, type the label width, in pixels.

8. Click Save to save your changes.

Linking Form Fields and Assigning Variables to Form Fields
You can configure text boxes to display information from the database by assigning it a program variable, 
which contains the appropriate information.

You can also link form fields to each other so that users can compare the input record to a potential 
match in the database. You link each field to a program variable, which returns the appropriate 
information from the database. Users can view whether the fields match in the verification form that is 
shown when they run interactive jobs.

To link form fields and to assign program variables to fields, do the following.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. To link form fields that have matching values, select the form fields by clicking on one form field and 
then pressing and holding the Shift key while clicking the matching field. 

When you view the Properties dialog box for a field, the Match To field in the Advanced Properties 
pane displays the ID of the other form field that is linked to the field.
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3. Specify the variable to which the text field is assigned by selecting the variable from the Program 
Variables pane and dragging and dropping it onto the text field. For more information about program 
variables, refer to Configuring Procedures on page 127.

When you view the Properties dialog box for the field, the Assigned To field in the Advanced 
Properties pane displays the program variable assigned to the field.

Figure 45: Example DOB Fields
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For example, in the preceding figure, the DOB fields for the input record (Input Record) and the database 
record (University Record) are linked.

• The Input Record DOB field has an ID of TF Label 14.

• The University DOB field has an ID of TF Label 59.

• The Input Record DOB field is assigned to the $f_dob variable.

• The University Record DOB field is assigned to the $d_dob variable.

To link the fields, you would select the Input Record DOB field and then press and hold the Shift key on 
your keyboard while clicking the University Record DOB field. 

To assign the $f_dob variable to the Input Record DOB field, you would click the $f_dob variable in the 
Program Variables pane and then drag and drop it onto the text field to which it is assigned.

When you open the Properties dialog box for the Input Record DOB field, it displays the label (TF Label 
59) to which it is linked and the variable ($f_dob) to which it is assigned.
Perceptive DataTransfer Administrator Guide Page 188 of 301



Figure 46: Example Input Record DOB Field Properties

When you selected the Input Record DOB and University Record DOB fields, you linked them both. To 
assign the $d_dob variable to the field , you would select the variable in the Program Variables pane and 
then drag and drop the variable onto the University Record field. When you open the Properties dialog 
box for the field, it displays the appropriate information for the field to which it is linked and the variable 
for which it is assigned.
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Figure 47: Example University Record DOB Field Properties

4. Click OK.

You can also select a color to highlight linked fields when their values differ from each other. By 
default, this color is a shade of blue; however, you can specify a color from a color palette. Refer to 
Configuring Form Match Colors on page 196.

Using Form Toggles
Refer to the following topics for more information.

• Understanding Form Toggles on page 191.

• Configuring Form Toggles on page 192.
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Understanding Form Toggles
If a field set contains a field that is linked to another field, this checkbox is automatically enabled. If data 
between two field sets are the same (linked fields return the same values); the checkbox is unchecked; if 
the data is different, the toggle is checked.

Users can check or uncheck the toggle checkboxes to specify which field sets of information are included 
when upload logic is processed.

Use form toggles if you need to provide the value of each field set to the associated upload logic; when 
the upload logic is run, this value is included when the data file is uploaded. The form can return the value 
of a toggle given a specified program variable name. 

For more information about configuring procedures, refer to Configuring Procedures on page 127.

Syntax for the toggle function is:

toggle(variable)

For example:

if toggle($suffix)

Syntax for the toggle_off function is:

toggle_off(variable)

For example:

toggle_off($last)

Syntax for the toggle_on function is:

toggle_on(variable)

For example:

toggle_on($last)
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Configuring Form Toggles
To configure toggles for field sets, do the following.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Right-click the field set and select Properties from the popup menu.

The Properties dialog box appears.

3. In the Field Properties pane, select the appropriate option for the Use Checkbox option. Click the Yes 
radio button to use a checkbox (toggle) for the field set; click the No radio button if you do not want to 
use a checkbox. 

4. Click OK to save your changes.

Moving Form Objects
You can move field sets and objects by dragging and dropping them with your mouse; do the following.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Click the object that you want to move. To select multiple objects, click an object and press and hold 
the Ctrl key as you click each object with your mouse. You can deselect an object by clicking it and 
pressing and holding the Ctrl key; you can deselect all objects by clicking in an empty background 
area of the form.

3. With your mouse, drag and drop the object to the desired location. 

The object is moved to the specified location. If you selected multiple objects, they are moved the 
same relative distance.
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Aligning Form Objects
You can align form objects in a field set with each other, or you can align field sets on the form 
background with each other.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Select the objects you want to align. To select multiple objects, click an object and press and hold 
the Ctrl key as you click each object with your mouse. You can deselect an object by clicking it and 
pressing and holding the Ctrl key; you can deselect all objects by clicking in an empty background 
area of the form.

3. Right-click the objects and select Align.

4. Select one of the following.

• Left: Aligns all objects to the left, aligning the left edges of all objects to the left edge of the first 
object you selected.

• Right: Aligns all objects to the right, aligning the right edges of all objects to the right edge of the 
first object you selected.

• Top: Aligns all objects to the top, aligning the top edges of all objects to the top edge of the first 
object you selected.

• Bottom: Aligns all objects to the bottom, aligning the bottom edges of all objects to the bottom 
edge of the first object you selected.

Copying and Pasting Form Objects
You can copy and paste form objects located within a field set onto the same field set and copy and 
paste field sets onto the background form. 

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Select the objects you want to copy. To select multiple objects, click an object and press and hold 
the Ctrl key as you click each object with your mouse. You can deselect an object by clicking it and 
pressing and holding the Ctrl key; you can deselect all objects by clicking in an empty background 
area of the form.
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3. Right-click the object and select Copy.

4. Do one of the following.

• To paste field sets onto the form background, right-click the background and select Paste.

• To paste objects on a field set within the same field set, right-click the field set and click Paste.

Configuring Form Colors
Refer to the following topics for more information.

• Configuring Form Background Colors on page 194.

• Configuring Field Set Foreground and Background Colors on page 194.

• Configuring Label Foreground and Background Colors on page 195.

• Configuring Checkbox Foreground and Background Colors on page 195.

• Configuring Text Field Foreground and Background Colors on page 196.

• Configuring Form Match Colors on page 196.

Configuring Form Background Colors
To configure background colors for the form, do the following.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Right-click the background and select Color.

3. To set the form background color, select Background, and then select the color from the palette.

The background of the form is set to this color.

Configuring Field Set Foreground and Background Colors
To configure background and foreground colors for a field set, do the following.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Right-click the field set and select Color.
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3. To set the field set background color, select Background, and then select the color from the palette.

The background of the field set is set to this color.

4. To set the field set foreground color, select Foreground, and then select the color from the palette.

If you have not configured colors for other form objects, any form objects that appear on the field set 
are set to this color. For example, if you have a label on the field set, the label is set to this color. Any 
additional form objects you add to the field set are also set to this color.

If you configure colors for form objects themselves, however, those colors, not the ones configured 
for the field set foreground or background, are used.

Configuring Label Foreground and Background Colors
To configure background and foreground colors for a label, do the following.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Right-click the label and select Color.

3. To set the label background color, select Background, and then select the color from the palette.

The background of the label is set to this color. 

4. To set the label foreground color, select Foreground, and then select the color from the palette.

The color is applied to the label text of the label.

Configuring Checkbox Foreground and Background Colors
To configure background and foreground colors for a checkbox, do the following.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Right-click the checkbox and select Color.
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3. To set the checkbox background color, select Background, and then select the color from the 
palette.

The background of the checkbox is set to this color. 

4. To set the checkbox foreground color, select Foreground, and then select the color from the palette.

The color is applied to the label text of the checkbox.

Configuring Text Field Foreground and Background Colors
To configure background and foreground colors for a text field, do the following.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Right-click the text field and select Color.

3. To set the text field background color, select Background, and then select the color from the palette.

The background of the text field is set to this color. 

4. To set the text field foreground color, select Foreground, and then select the color from the palette.

The color is applied to the label text of the text field.

Configuring Form Match Colors
You can set the form match color, which is the color that highlights all linked form objects when they 
contain different values. For example, if the input record DOB and data record DOB fields are linked, and 
their values do not match, the text fields are displayed in the match color you specify. By default, the 
color is a shade of blue. 

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.
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2. Right-click the background and select Color.

3. Select Match, then select a color from the color palette.

Deleting Form Objects
To delete a form object, do the following.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Select the object you want to delete and either right-click it and select Delete or click the Delete 
button.

Note  If you delete a field set, the field set and all of its objects are deleted.

The object is deleted and is removed from the Form Editor.

3. Click Save to save your changes.

Removing Sharing on Shared Forms
To remove sharing on a form that is shared with another workspace, do the following.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to configure, then either right-click it 
and select Edit or click the Edit button.

2. Click Tools and select Remove Sharing.

Sharing is removed on the form.
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Rolling Back Forms
If changes have been made to and committed to a form, you can use a previous version (roll back) of it.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form you want to roll back, then either right-click it 
and select Edit or click the Edit button.

2. Click Tools and select Rollback.

The Rollback Manager dialog box appears and displays the following information.

• Name: Name of the form.

• Status: Status of the form (pending, current, or dated).

• Version Date: Date and time on which the version of the form was created.

• Created By: Username of the user who created the form.

• Comments: Comments added by the user.

3. Select the version you want to use and click Rollback.

The previous version is loaded into the Form Editor.

Obtaining the Latest Versions of Forms
If changes have been made to and committed to a form, you can obtain the latest version of it.

1. Do one of the following.

• Select Configuration > Forms. 

The Form Editor appears.

• In the Job Dashboard, select the job with the form for which you want to obtain the latest version, 
and then either right-click it and select Edit or click the Edit button.

2. Click Configuration and select Get Latest.

The latest version of the form is obtained and is loaded into the Form Editor.
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Configuring ImageNow Index Maps

You can define ImageNow index maps, which are used when uploading ImageNow documents to 
ImageNow, using Perceptive DataTransfer. Index maps obtain document information from the specified 
integration server connection and link ImageNow document properties to program variables in the code. 
Use the ImageNowAddDoc syntax in the code to configure parameters used by Perceptive DataTransfer 
to upload ImageNow documents.

For more information about integration server connections, refer to Adding Integration Server 
Connections on page 86. For more information about the ImageNowAddDoc syntax, refer to 
Understanding the ImageNowAddDoc Function on page 286.

Refer to the following topics for more information.

• Adding and Modifying ImageNow Index Maps on page 199.

• Deleting ImageNow Index Maps on page 202.

• Copying ImageNow Index Maps on page 202.

• Removing Sharing on ImageNow Index Maps on page 202.

• Rolling Back ImageNow Index Maps on page 203.

• Obtaining the Latest Versions of ImageNow Index Maps on page 203.

• Exporting ImageNow Index Maps on page 203.

• Importing ImageNow Index Maps on page 204.

Adding and Modifying ImageNow Index Maps
To add an ImageNow index map, do the following.

1. Select Configuration > ImageNow.

The ImageNow Index Map Administration dialog box appears.

2. Do one of the following.

• To add a new index map, click .

The Add ImageNow dialog box appears. Do one of the following.

○ To add a new index map, click the Add ImageNow tab. Then, in the Name field, type the 
name of the index map.

○ To add an index map that another workspace is sharing, click the Add Shared ImageNow 
tab. Then, from the Workspace drop-down box, select the workspace that is sharing the 
index map, and select the index map from the ImageNow Entity drop-down box.

Click OK.
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• To modify an index map, select the index map and either right-click it and select Edit or click .

The Edit ImageNow Index Map dialog box appears.

Figure 48: Edit ImageNow Index Map dialog box
Perceptive DataTransfer Administrator Guide Page 200 of 301



3. From the Connection Group drop-down box, select the connection group that contains the 
integration server connection to use. This connection group is not saved with an association to the 
index map; it is used to obtain custom ImageNow document properties as program variables for the 
index map. 

For more information about adding integration server connections, refer to Adding Integration Server 
Connections on page 86.

4. In the Name field, type the name of the index map. The name must be unique.

5. In the Description field, type descriptive text about the index map.

6. In the Drawer field, specify the ImageNow drawer that contains the ImageNow documents by 
dragging and dropping the appropriate program variable from the Program Variables pane. This field 
is required.

To remove an entry, right-click the field and select Clear.

7. In the Document Type field, specify the ImageNow document type, contained in the ImageNow 
drawer, to which to link to the ImageNow index map by dragging and dropping the appropriate 
program variable from the Program Variables pane. This field is required.

To remove an entry, right-click the field and select Clear.

8. In the Field 1 through Field 5 fields, define the index fields for the document by dragging and 
dropping the appropriate program variables from the Program Variables pane to each field. You can 
also leave each field empty.

When the ImageNowAddDoc function executes, the code inserts these fields with the values 
contained in the specified program variables.

9. In the Custom Properties pane, add or modify the ImageNow custom properties associated with the 
index map by doing the following.

1. To add a new property, click . 

The Select Custom Properties dialog box appears. It displays all available ImageNow custom 
properties, excluding any that you have already added to the index map.

2. Select one or more properties to add to the index map. To select multiple properties:

• Click a property and press and hold the Ctrl key as you click each property with your mouse.

• Click a property and press and hold the Shift key as you click another property to select 
contiguous properties.

3. Click OK.

The selected properties appear in the Custom Properties pane.

4. Link program variables to the custom properties by selecting a program variable in the Program 
Variables pane and dragging and dropping it to the appropriate custom property.
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10. To delete a custom property from the ImageNow index map, select the property you want to delete in 
the Custom Properties pane and click the Delete button or right-click it and select Delete. 

Use the ImageNowAddDoc function in your code to configure the parameters used by Perceptive 
DataTransfer to upload ImageNow documents. For more information, refer to Understanding the 
ImageNowAddDoc Function on page 286.

Deleting ImageNow Index Maps
Do delete an index map, do the following.

1. Select Configuration > ImageNow.

The ImageNow Index Map Administration dialog box appears.

2. Select the index map you want to delete and either right-click it and select Delete or click .

The index map is deleted and is removed from the ImageNow Index Map Administration dialog box.

Copying ImageNow Index Maps
To create a duplicate of an ImageNow index map, do the following.

1. Select Configuration > ImageNow.

The ImageNow Index Map Administration dialog box appears.

2. Select the index map you want to copy and either right-click it and select Copy or click .

A copy of the index map is created and appears in the ImageNow Index Map Administration dialog 
box.

Removing Sharing on ImageNow Index Maps
To remove sharing on an index map that is shared with another workspace, do the following.

1. Select Configuration > ImageNow.

The ImageNow Index Map Administration dialog box appears.

2. Select the index map for which you want to remove sharing and either right-click it and select 

Remove Sharing or click .

Sharing is removed on the index map.
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Rolling Back ImageNow Index Maps
If changes have been made and committed to an ImageNow index map, you can use a previous version 
(roll back) of it.

1. Select Configuration > ImageNow.

The ImageNow Index Map Administration dialog box appears.

2. Click the index map you want to roll back and either right-click it and select Rollback or click .

The Rollback Manager dialog box appears and displays the following information.

• Name: Name of the ImageNow index map.

• Status: Status of the index map (current or dated).

• Version Date: Date and time on which the version was created.

• Created By: Username of the user who created the index map.

• Comments: Comments that were added by the user.

3. Select the previous version to which you want to revert and click Rollback.

The previous version is loaded.

Obtaining the Latest Versions of ImageNow Index Maps
If changes have been made to and committed to an index map, you can obtain the latest version of it.

1. Select Configuration > ImageNow.

The ImageNow Index Map Administration dialog box appears.

2. Click the index map for which you want to obtain the latest version and either right-click it and select 

Get Latest or click .

Exporting ImageNow Index Maps
You can export an ImageNow index map to an XML file by doing the following.

1. Select Configuration > ImageNow.

The ImageNow Index Map Administration dialog box appears.

2. Select the index map you want to export.

3. Click  and select Export.

4. Save the file to the appropriate location.
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Importing ImageNow Index Maps
You can import an ImageNow Index Map from an XML file by doing the following.

1. Select Configuration > ImageNow.

The ImageNow Index Map Administration dialog box appears.

2. Click  and select Import.

The Import ImageNow Index Map dialog box appears.

3. Click the Browse... button and navigate to the file that you want to import or type the location of the 
file in the File field.

4. Check the Update Existing Entities checkbox to update an existing ImageNow index map, with the 
same name as the ImageNow index map you are importing, with the ImageNow index map you are 
importing. 

If you do not check this checkbox, and there is an existing ImageNow index map with the same name 
as the ImageNow index map you are importing, DUPLICATE- is appended to the start of the name of 
the ImageNow index map you are importing; the existing ImageNow index map is not updated. If an 
ImageNow index map exists with the name DUPLICATE-<index_map_name>, DUPLICATE(2)- is 
appended to the start of the name. The number continues to be incremented so that all ImageNow 
index maps have unique names.

5. Click OK.
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Configuring Workspaces

To open the Workspace Administration dialog box, select Administration > Workspace. The dialog box 
provides the following information:

• Name: Name of the workspace.

• Description: Brief description of the workspace.

• Sharing: Indicates whether the workspace is private or with a share group.

• Active Version: Version of the workspace that is active.

• Date Created: Date on which the workspace was created.

• Created By: Name of the user who created the workspace.

Refer to the following topics for more information.

• Understanding Workspaces on page 205.

• Understanding Workspace Sharing on page 206.

• Understanding Version Control on page 207.

• Configuring Workspaces on page 211.

• Using Version Control on page 216.

• Configuring Share Groups on page 223.

Understanding Workspaces
Workspaces consist of the objects required for a particular Perceptive DataTransfer configuration.

• Connection groups: A workspace can contain one or more connection groups; a connection group 
can consist of one or more connections.

• Procedures (code libraries): A workspace contains a set of code libraries, comprising the Perceptive 
DataTransfer match, review, and upload logic.

• Verification form: A workspace contains a single verification form to be used for all jobs that are run 
within that workspace.

• Headers: A workspace contains one or more headers, which are used to define input sources. When 
a job is run within a workspace, one of the headers within the workspace must be selected to use for 
the job.

• Data exports: A workspace can contain one or more data exports, if they are configured in that 
workspace. Workspaces do not have to contain data exports.

• File sources: A workspace can contain one or more file sources (both SFTP and server path file 
locations), which are SFTP sites from which jobs can be downloaded. Workspaces do not have to 
contain file sources.
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• ImageNow index maps: A workspace can optionally contain one or more index maps. 

• Document templates: A workspace can optionally contain one or more document templates.

You can load multiple configurations, represented by workspaces, into a single Perceptive DataTransfer 
instance; however, users can only work with one workspace at a time. When you log into Perceptive 
DataTransfer, you use a default workspace and workspace version but can switch to another workspace 
version.

You can have multiple versions of a workspace, with each version representing a changeset of the 
workspace.

Objects can be shared among workspaces. Refer to Understanding Workspace Sharing on page 206.

Understanding Workspace Sharing
The following objects can be shared.

• Procedures

• Headers

• Verification forms

• Data exports

• Connection groups

• File sources

• ImageNow index maps

• Document templates

You can share an object if multiple workspaces need to use a common object. With sharing, you can 
reduce the need for duplicating common objects and code, and you can make a single edit and apply it to 
one object in all workspaces in which it is shared.

For example, you can create a single procedure and share it among multiple workspaces without needing 
to create duplicate procedures for each workspace.

A workspace can be shared or private. 

• Private: The workspace is not shared; therefore, no workspace objects are shared.

• Shared: The workspace can share objects with other workspaces.

The sharing method can be changed at any time; however, you cannot change a shared workspace if 
shared objects are used by other workspaces and would no longer be shared.

When you share workspace objects, you configure share groups and select the group with which you 
want to share objects. Any workspaces using the same share group share their objects with other 
workspaces in this group. Refer to Configuring Share Groups on page 223 for more information.

Workspaces consist of versions, and objects can be shared depending on the status of your workspace 
version. Refer to Understanding Version Control on page 207 for more information.
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Understanding Version Control
You can have multiple versions of a workspace; each version represents a changeset of the workspace. 
There is always at least one version of a workspace.

Refer to Understanding Workspace Version Flow on page 207 for information on how workspace 
versions are created and moved.

Understanding Workspace Version Flow
Each workspace version has one of the following statuses.

• Edit: This workspace version is a new version. Only one version of the workspace can be in edit 
status at a time, and this version can be changed by only one user at a time. 

Also, only one user at a time can log in to the edit version of a workspace. If a user attempts to log in 
to the edit workspace version while another user is logged into it and therefore has locked the 
version, the user receives an appropriate message. In addition, any part of the user interface related 
to workspaces or versioning is disabled until the user changes to a different role or workspace 
version.

• Test: This workspace version can be tested by any number of permitted users.

• Staged: This workspace version can be used to view how the workspace will behave in a production 
environment.

• Active: This workspace version is the current, active version of the workspace. Only one version of 
the workspace can be active at a time.

• Inactive: This workspace is an older version of the workspace and is no longer in use.

Workspace objects are also versioned and have their own version flow within workspace versions. Refer 
to Understanding Object Version Flow on page 210 for more information.
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Figure 49: Workspace Version Status Version Flow
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Edit

• Objects can be added and modified in edit mode.

• A version in edit mode can be moved to test mode.

• A version in edit mode can be created from a version in staged, active, or inactive mode.

• A version can be reverted to edit mode from test mode.

• A new version in edit mode can be created from a version in test mode.

Test

• A version can enter test mode from edit mode.

• A version in test mode can be moved to edit mode.

• A version in test mode can be moved to staged mode.

• A version in test mode can be deleted.

• A version can be in both edit mode and test mode at the same time; however, there can be only one 
version each in edit and test mode.

Staged

• A version can enter staged mode from test mode.

• A version in staged mode can move to active mode.

• A version in staged mode can be used to create a version in edit mode.

• A version in staged mode can not be deleted.

Active

• A version can enter active mode from staged mode.

• A version can enter active mode as a new version created from an inactive version.

• A version in active mode can move to inactive mode (when another version is made active).

• A version in active mode can be used to create a new version in edit mode.

• A version in active mode can not be deleted.

• Once there is an active version of a workspace, an active version always exists for the workspace. 

Inactive

• A version can enter inactive mode from active mode (when another version is made active).

• A version in inactive mode can be used to create a new version in active mode.

• A version in inactive mode can be used to create a new version in edit mode.

• A version in inactive mode can not be deleted 
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Understanding Object Version Flow 
Within a workspace version, an object can have a new, pending, current, or dated status.

Figure 50: Object Version Flow
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• Only one version of an object can be in new mode.
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• A version enters pending mode from new mode when a workspace is moved from edit mode to test 
mode.

• A version in pending mode is reverted to new mode when a workspace is moved from test mode 
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Current

• A version enters current mode from pending mode when a workspace is moved from test mode to 
staged mode.

• A version in current mode can be used to create a version in new mode.

• A version in current mode can move to dated mode (when another version is moved to current).

• A version in current mode can be removed from the workspace.

• A version is in current mode when it was created or modified in a workspace version in staged or 
active mode. 

Dated

• A version can enter dated mode from current mode.

• A version in dated mode can be used to create a version in new mode.

• A version in dated mode can be removed from the workspace.

Rolling Back Versions and Obtaining the Latest Versions of Objects
You can roll back a version of an object (use a previous version of an object) or obtain the latest version of 
an object if changes have been made and committed to an object.

You can also obtain the latest version of an object if the object has been modified since you added it. For 
example, you added an object from a workspace in active mode. A new version of the workspace was 
later added, the shared object was modified, and the version was moved to staged mode. If you obtain 
the latest object version, these object changes are applied to the object in your workspace.

Configuring Workspaces
Refer to the following topics for more information.

• Importing Workspaces on page 211.

• Adding Workspaces on page 214.

• Modifying Workspaces on page 215.

• Deleting Workspaces on page 216.

Importing Workspaces
You can import Perceptive DataTransfer 6.x workspaces, and you can import Perceptive DataTransfer 
configurations from versions earlier than 6.0.x.
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Importing Perceptive DataTransfer 6.x Workspaces

Note  Only superadministrators can import workspaces.

To import a workspace, do the following.

1. Select Administration > Workspace.

The Workspace Administration dialog box appears.

2. Click .

The Configuration Migration dialog box appears.

3. Click Import Workspace.

4. In the Workspace Name field, type a name for the workspace.

5. In the Workspace Description field, type descriptive text about the workspace.

6. In the File field, type the path of the file you want to import, or click Browse...., navigate to the 
location of the file, and then select it. 

7. In the Sharing field, click the appropriate radio button.

• Private: Sets the workspace as a private one; it is not shared, and none of its objects are shared.

• Shared: Sets the workspace as a shared workspace, which can share its objects with either a 
specific group of workspaces or all workspaces.

8. If you are sharing the workspace, from the Group drop-down box, select the share group to use for 
the workspace.

9. Click OK.

Importing Legacy Configurations

You can import legacy config.dll databases from versions of Perceptive DataTransfer earlier than 6.0.x. A 
new Perceptive DataTransfer workspace is created from the migrated config.dll database. Duplicate 
objects are shared with existing Perceptive DataTransfer workspaces when applicable. Perceptive 
DataTransfer manages importing of Perceptive DataTransfer functions as follows.

• Enterprise Hierarchy

Legacy hierarchies are merged in a single hierarchy. A node in the hierarchy is merged with an 
existing node if the node names match and each subsequent parent in the tree matches. If no 
matches are found, the node is created as new, either as the beginning of a new tree for an 
organization or as the child to a matching parent in other cases.

• Database connections

For each migrated config.dll, a new connection group is created. A default connection, corresponding 
to the legacy ODBC connection selected at Perceptive DataTransfer log in, is created as the primary 
connection of the group. All other legacy secondary connections are added to the group. Names and 
descriptions are migrated, but legacy connection details are omitted. Current connection details are 
provided manually after migration.
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• Code libraries

Match, Review, and Upload libraries, along with their corresponding procedures and SQL blocks, are 
migrated.

Libraries can be merged or not merged depending on migration parameters. If merged, the existing 
repository is searched for matching libraries. A library is considered a match if its properties are 
identical, including all its procedure and SQL blocks. If a match is found, and that match is shared in 
the same share group, then the migrated collection will share a link to the matched library with any 
workspaces that already share the library. If there is no match, or the matches are not shared, then 
the library is created as new, along with all its procedures and SQL blocks.

Procedures and SQL blocks may be merged or not merged depending on migration parameters. If 
merged, the existing repository is searched for matching procedures. A procedure is considered a 
match if its properties and text are identical. If a match is found, and that match is shared in the same 
share group, then the migrated workspace will share a link to the matched procedure with any 
workspaces that already share the procedure. If there is no match, or the matches are not shared, 
then the procedure is created as new. The same logic applies to SQL blocks.

Libraries, procedures, and SQL blocks are migrated as is. Legacy conditions within their properties 
and text are automatically resolved after the config.dll migration, but some manual corrections may 
need to be made if there are issues with legacy code.

• Program variables

Program variables are migrated from the legacy database to the new Perceptive DataTransfer 6.x 
schema as is. Program variables contain links to verification form objects; however, links between 
program variables and form objects are not maintained. Data typing issues or other legacy concerns 
are resolved after the config.dll migration. All program variables are created as new and are not 
shared with other workspaces. 

• Headers

Headers can be merged with existing headers or created as new, depending on migration 
parameters. If merged, the existing repository is searched for matching headers. A header is 
considered a match if all its properties, including its type and subsequent details, are identical. If a 
match is found, and that match is shared with the same share group, then the migrated workspace 
will share a link to the matched header with any workspaces that already share the header. If there is 
no match, or the matches are not shared, then the header is created as new.

• Data exports

Data exports can be merged with existing data exports or created as new, depending on migration 
parameters. If merged, the existing repository is searched for matching data exports. A data export is 
considered a match if all its properties are identical. If a match is found, and that match is shared with 
the same share group, then the migrated workspace will share a link to the matched data export with 
any workspaces that already share the data export. If there is no match, or the matches are not 
shared, then the data export is created as new.

Note  Only superadministrators can import legacy configurations.

Note  BEGIN TRAN in SQL statements are removed from code during migration.
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To import a legacy configuration, do the following.

1. Select Administration > Workspace.

The Workspace Administration dialog box appears.

2. Click .

The Configuration Migration dialog box appears.

3. Click Import Legacy Configuration.

4. In the Workspace Name field, type a name for the workspace.

5. In the Workspace Description field, type descriptive text about the workspace.

6. In the Config.dll Upload field, type the path of the file you want to import, or click Browse..., navigate 
to the location of the file, and then select it. 

7. In the Sharing field, click the appropriate radio button.

• Private: Sets the workspace as a private one; it is not shared, and none of its objects are shared.

• Shared: Sets the workspace as a shared workspace, which can share its objects with 
workspaces in the same share group.

8. For a shared workspace, from the Group drop-down box, select the share group to use for the 
workspace. If you are sharing a workspace, you must select the appropriate share group.

9. Check the Merge Headers checkbox to merge legacy headers with Perceptive DataTransfer 6.x 
headers.

10. Check the Merge Data Exports checkbox to merge legacy data exports with Perceptive 
DataTransfer 6.x data exports. 

11. Check the Merge NQL Procedures checkbox to merge procedures.

12. Click Migrate.

Adding Workspaces
Note  Only superadministrators can add new workspaces.

To add a new workspace, do the following.

1. Select Administration > Workspace.

The Workspace Administration dialog box appears.

2. Click .

The Add Workspace dialog box appears.

3. In the Name field, type the name of the workspace.

4. In the Description field, type the description of the workspace.
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5. In the Sharing field, click the appropriate radio button:

• Private: Sets the workspace as a private one; it is not shared, and none of its objects are shared.

• Shared: Sets the workspace as a shared workspace, which can share its objects with 
workspaces in the same share group.

6. If you are sharing a workspace, from the Group drop-down box, select the share group to use.

7. Click OK.

The workspace is added and appears in the Workspace Manager dialog box.

8. To use this workspace, give yourself the appropriate privileges. Refer to Configuring Users And 
Privileges on page 63.

Modifying Workspaces
To modify a workspace, do the following.

1. Select Administration > Workspace.

The Workspace Administration dialog box appears.

2. Select the workspace you want to modify, and then either right-click it and select Edit or click .

The Workspace Details dialog box appears.

3. In the Name field, type the name of the workspace.

4. In the Description field, type the description of the workspace.

5. In the Sharing field, click the appropriate radio button:

• Private: Sets the workspace as a private one; it is not shared, and none of its objects are shared.

• Shared: Sets the workspace as a shared workspace, which can share its objects with 
workspaces in the same share group.

6. If you are sharing the workspace, from the Group drop-down box, select the share group to use.

7. Click Save.

The workspace is modified, and its updated information appears in the Workspace Manager dialog 
box.
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Deleting Workspaces
Note  Only superadministrators can delete workspaces.

To delete a workspace, do the following.

1. Select Administration >Workspaces.

The Workspace Manager dialog box appears.

2. Select the workspace you want to delete, and then either right-click it and select Remove or click 

.

The workspace is deleted and is removed from the Workspace Manager dialog box.

Using Version Control
Refer to the following topics for more information.

• Modifying Versions on page 217.

• Viewing Version Details on page 218.

• Moving Versions to Test Mode on page 219.

• Reverting a Version to Edit Mode on page 220.

• Moving Versions to Staged Mode on page 221.

• Adding Versions on page 219.

• Moving Versions to Active on page 221.

• Obtaining the Latest Versions of Shared Objects on page 222.

• Importing Versions on page 222.

• Exporting Versions on page 223.

• Configuring Workspace Version Notifications on page 223.

The Version Administration dialog box appears when you select a workspace in the Workspace Manager 

dialog box and either right-click it and select Versions or click . It displays the following information.

• Version: Numerical value of the version.

• Description: Description of the version.

• Status: Status of the version.

• Date Active: Date on which the version was activated. If the version is not active, this column displays 
a blank row of information.

• Created By: Name of the user who created the version.

• Create Date: Date on which the version was created.
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Figure 51: Version Administration Dialog Box

Modifying Versions
Note  You can modify only the version in which you are working if it is in edit or test mode.

To modify a version name, do the following.

1. Select Administration > Workspace.

The Workspace Manager dialog box appears.

2. Select the workspace you want to modify and either right-click it and select Versions or click .

The Version Administration dialog box appears.

3. Select the version you want to modify and either right-click it and select Edit Description or click 

.

The Edit Version Description dialog box appears.
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Figure 52: Edit Version Description Dialog Box

4. In the Versions Description field, type descriptive text about the version.

5. Click OK.

The version description is updated and appears in the Version Administration dialog box.

Viewing Version Details
To view version information, do the following.

1. Select Administration > Workspace.

The Workspace Administration dialog box appears.

2. Click the workspace for which you want to view version details and then either right-click it and select 

Version or click .

The Version Administration dialog box appears.

3. Either right-click the version and select View or click .

A dialog box appears for the version and displays the following information.

• Action: Action that was taken on an object (Add, Modify, or Delete).

• Type: Type of object that was added, modified or deleted.

• Name: Name of the object that was added, modified, or deleted.

• Date: Date on which the action occurred.

• User: Username of the user who added, modified, or deleted the object.

• Comment: Comment that was added to the version entry.
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Adding Versions
You can add a new version of a workspace if you do not have any other versions with edit status. The 
new version you add has a status of edit.

A workspace version in edit mode can be created from a version in staged, active, inactive, or test mode. 
A version in test mode can be reverted to edit mode if no other edit mode versions exist. 

To revert a version in test mode back to edit mode, follow the procedure in Reverting a Version to Edit 
Mode on page 220. 

Use the following procedure to create a new workspace version in edit mode from workspace versions in 
staged, active, inactive, or test mode.

1. Select Administration > Workspace.

The Workspace Administration dialog box appears.

2. Click the workspace to which you want to add a new version and either right-click it and select 

Version or click .

The Version Administration dialog box appears.

3. Select the workspace version from which you want to create a new version in edit mode.

When you create a new version from the selected version, a copy of the selected version is created 
and is placed in edit mode. 

4. Click .

A dialog box appears and prompts you to confirm that you want to create a new version.

5. Click Yes to create a new version.

The Add Version dialog box appears.

6. In the Description field, type descriptive text about the version.

7. Click OK.

The version is created and appears in the Version Administration dialog box.

Moving Versions to Test Mode
Note  You can move a version from only edit mode to test mode.

Note  If you move a version from edit mode to test mode, any existing versions in test mode become 
inactive.
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To move a version to test mode, do the following.

1. Select Administration > Workspace.

The Workspace Administration dialog box appears.

2. Click the workspace whose version you want to test and either right-click it and select Version or 

click .

The Version Administration dialog box appears.

3. Select the version you want to advance to testing and either right-click it and select Test or click .

A dialog box appears and prompts you to confirm that you want to advance the version to testing.

4. Click Yes to change the status to test.

The version is advanced to test mode, and its information is updated in the Version Administration 
dialog box.

Reverting a Version to Edit Mode
Note  You can revert a version from only test mode to edit mode.

Note  You can revert a version from test mode to edit mode only if there are no versions already in edit 
mode.

To revert a version back to edit mode from test, do the following.

1. Select Administration > Workspace.

The Workspace Administration dialog box appears.

2. Click the workspace whose version you want to revert to editing and either right-click it and select 

Version or click .

The Version Administration dialog box appears.

3. Select the version you want to revert to editing and either right-click it and select Edit or click .

A dialog box appears and prompts you to confirm that you want to revert the version to editing.

4. Click Yes to change the status to edit.

The version is reverted to edit status, and its information is updated in the Version Administration 
dialog box.
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Moving Versions to Staged Mode
Note  You can move versions to staged mode only from test mode.

1. Select Administration > Workspace.

The Workspace Administration dialog box appears.

2. Click the workspace whose version you want to advance to staging and either right-click it and select 

Version or click .

The Version Administration dialog box appears.

3. Select the version you want to advance to staging and either right-click it and select Stage or click 

.

A dialog box appears and prompts you to confirm that you want to advance the version to staging.

4. Click Yes to change the status to staged.

The version is changed to staged status, and its information is updated in the Version Administration 
dialog box.

Moving Versions to Active
Note  You can move a version to active with the status of staged or inactive only.

To move a version to active, do the following.

1. Select Administration > Workspace.

The Workspace Administration dialog box appears.

2. Click the workspace whose version you want to activate and either right-click it and select Version or 

click .

The Version Administration dialog box appears.

3. Select the version you want to activate and either right-click it and select Activate or click .

A dialog box appears and prompts you to confirm that you want to activate the version.

4. Click Yes to activate the version.

The version is activated, and its information is updated in the Version Administration dialog box.
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Obtaining the Latest Versions of Shared Objects
If changes have been made to and committed to shared objects, you can obtain the latest versions of all 
shared objects.

Note  You can also obtain the latest versions of individual objects (procedures, forms, data exports, 
headers, and connection groups) in the appropriate dialog boxes or application windows for the objects.

1. Select Administration > Workspace.

The Workspace Administration dialog box appears.

2. Click the workspace whose latest version you want to obtain and either right-click it and select 

Version or click .

The Version Administration dialog box appears.

3. Select the version and click .

The latest objects are obtained and are loaded into the workspace.

Importing Versions
To import a version from an XML file, do the following.

1. Select Administration > Workspace.

The Workspace Administration dialog box appears.

2. Click the workspace for which you want to import a version and either right-click it and select Version 

or click .

The Version Administration dialog box appears.

3. Click  and select Import.

The Import Version dialog box appears.

4. Click Browse... and navigate to the version you want to import, and then select it.

5. Click OK.

The version is imported and appears in the Version Administration dialog box.
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Exporting Versions
To export a version in an XML file, do the following.

1. Select Administration > Workspace.

The Workspace Administration dialog box appears.

2. Click the workspace for which you want to export a version and either right-click it and select Version 

or click .

The Version Administration dialog box appears.

3. Select the version you want to export.

4. Click  and select Export.

The Workspace Export dialog box appears.

5. Click the Full radio button if you want to export all objects in the workspace; click Changes if you 
want to only export changes.

6. Click OK.

Save the file in the appropriate location.

Configuring Workspace Version Notifications
You can configure Perceptive DataTransfer to send email notifications to specified users about when 

certain workspace version activities occur. When you select Administration > Workspace and click , 
the Version Notification Configuration dialog box appears, from which you can configure notifications. For 
more information about configuring notifications, refer to Configuring Notifications on page 55.

Configuring Share Groups
Workspaces and their objects can be shared among share groups. Create a share group and configure 
workspaces to use that share group so that objects can be shared.
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Figure 53: Share Group Administration Dialog Box

Adding Share Groups
To add a share group, do the following.

1. Select Administration > Share Groups.

The Share Group Administration dialog box appears.

2. Click .

The Add Share Group dialog box appears.

Figure 54: Add Share Group Dialog Box
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3. In the Share Group Name field, type the name of the share group.

4. In the Description field, type descriptive text for the share group.

5. Click OK.

The share group is created and is displayed in the Share Group Administration dialog box.

When you share a workspace, you select the share group to use. Workspaces that use this share 
group can share their objects with all other workspaces using the share group.

Modifying Share Groups
To modify a share group, do the following. 

1. Select Administration > Share Groups.

The Share Group Administration dialog box appears.

2. Select the share group you want to modify and either right-click it and select Edit or click .

The Edit Share Group dialog box appears.

Figure 55: Edit Share Group Dialog Box

3. In the Share Group Name field, type the name of the share group.

4. In the Description field, type descriptive text for the share group.

5. Click OK.

The share group is modified and updated in the Share Group Administration dialog box.
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Deleting Share Groups
Note  You cannot delete a share group if a workspace is using it.

To delete a share group, do the following. 

1. Select Administration > Share Groups.

The Share Group Administration dialog box appears.

2. Select the share group you want to delete and either right-click it and select Delete or click .

A dialog box appears and prompts you to confirm that you want to delete the share group.

3. To delete the share group, click Yes.

The group is deleted and is removed from the Share Group Administration dialog box.
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Configuring Jobs and Processing Records

Jobs contain all functions required to load data into your database. A job consists of the following.

• Header: Defines the input data source, mapping values from the input file to the source destination in 
your database.

• Connection group: Comprises database connections to your database.

• Input Source: Source from which you are importing data (for example, a spreadsheet containing test 
information for students). Input sources can be fixed-width, delimited, or XML files, database queries, 
or web service calls.

• Date and time: Date and time on which the job starts (if not specified, the job is run manually).

When you run a job, Perceptive DataTransfer processes all records from the input source for the job.

You can view jobs in the Job Dashboard of the main application window, which contains a table that 
provides the following information.
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Table 7: Job Dashboard Elements and Descriptions

Element Description

Status drop-down box Filters the status of the jobs you view in the Job Dashboard table. When you 
select an option, the table displays jobs with the selected status. Options are:

• Active: Active jobs are jobs that have not yet started (pending), jobs that 
have run but for which there are unprocessed records (incomplete), or 
jobs that have run but for which there are suspended records 
(processed).

• Complete: Complete jobs have been run and all records have been 
processed as new or match; there are no suspended or unprocessed 
records.

• Archive: Archive jobs are historical jobs that have been archived.

• Canceled: Canceled jobs have been canceled by a user.

Name column Name of the job.

Click + to expand the job entry and view details about the job. The following 
fields are displayed.

• File Name: Filename of the input file used by the job.

• Created On: Date on which the job was created.

• Created by: Username of the user who created the job.

• Start Time: Date and time on which the job started to run.

• End Time: Date and time on which the job ended.

• In Use by: Username of the user who is running the job.

File Name column Filename of the input file used by the job.

Scheduled Start Time column Date and time on which the job was scheduled to start.

Status column Status of the job.

• Complete: The job has finished running, and there are no unprocessed or 
suspended records.

• Incomplete: The job is not currently running and has processed and 
unprocessed records.

• Processed: The job has finished running, but there are suspended 
records.

• Pending: The job has not yet started.

• Processing: The job is currently running.

• Canceled: The job was canceled.

• Archive: The job was archived.
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Refer to the following topics for more information.

• Customizing Columns on page 229.

• Obtaining Input Data from the Database on page 230.

• Adding and Modifying Recurring Jobs on page 230.

• Adding New Jobs on page 233.

• Modifying Job Details on page 234.

• Modifying Jobs on page 235.

• Specifying Data Displayed in the Results Pane on page 237.

• Opening Jobs on page 238.

• Running Jobs on page 242.

• Deleting Jobs on page 257.

• Canceling Jobs on page 258.

• Archiving Jobs on page 258.

Customizing Columns
You can customize the columns displayed in the Job Dashboard.

Columns are automatically saved the way in which you displayed them when you last logged out of the 
application or when you switched roles.

Records Status column: Provides the following subcolumns.

• Progress: Provides a status bar indicating job progress when it is being run.

• Total: Number of total records for the job.

• Unprocessed: Number of records that the job did not process.

• Suspended: Number of suspended records.

• Matched: Number of matched records.

• New: Number of new records.

• Locked: Number of locked records.

Header column Name of the header used for the job.

Connection Group column Name of the connection group for the job.

Table 7: Job Dashboard Elements and Descriptions (Continued)

Element Description
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To choose the columns you want to display, do the following.

1. Hover your mouse over the appropriate column.

A drop-down arrow appears on the right side of the column.

2. Click the arrow to open a menu that allows you to sort columns from A-Z or Z-A and also allows you 
to select the columns you want to display.

3. Select Columns, then check the columns you want to display; uncheck the columns you do not want 
to display.

After you log out of the application or change roles, the columns you specified to show or hide are 
displayed in the Job Dashboard the next time you log in.

Obtaining Input Data from the Database
Perceptive DataTransfer can query a database to obtain the input data for a job. To configure a job in this 
way, do the following.

1. Create and configure a database connection for the input data. Refer to Configuring Connection 
Groups and Database Connections on page 74.

2. Create a procedure that uses Database Population Selection logic, which contains the query for 
dynamically extracting input data. You use this logic in procedures and associate them with headers 
so that you can capture header input variables from the input file. 

For more information about configuring procedures, refer to Configuring Procedures on page 127. 
For information about syntax for database population selection logic, refer to Understanding 
Database Population Selection Syntax on page 262.

3. Create a database header and select the procedure used for database population selection. Refer to 
Configuring and Modifying Database Headers on page 110.

4. Create a new job, selecting the header and connection you created in previous steps. Refer to Adding 
New Jobs on page 233.

Note  If job is recurring, the data is loaded when the job starts. If this a a job you are running a single 
time, the data is loaded at creation time. 

5. Run the job. Refer to Running Jobs on page 242.

• If data from the import source has not been loaded, it is loaded when the job runs.

• If procedure aliases do not match the input columns (input variables in the header) in the header, 
the job is not run properly.

• For recurring jobs, if a previous occurrence of a job is running, you cannot create a new job.

Adding and Modifying Recurring Jobs
Recurring jobs run at a specified interval, using a file from a specified data source or file source. 

Note  For an XML header, if you change the record identifier after you create a job using the XML header, 
the job will not run.
Perceptive DataTransfer Administrator Guide Page 230 of 301



Use file sources to configure the location of the input file; refer to Configuring File Sources on page 92.

To add or modify a recurring job, do the following.

1. Select Jobs > Recurring Jobs.

The Recurring Job Administration dialog box appears.

2. Do one of the following.

• To add a new job, click .

The Add Recurring Job dialog box appears.

• To modify a job, select the recurring job and either right-click it and select Edit or click .

The Edit Recurring Job dialog box appears.

3. In the Job Name field, type the name of the job. 

4. In the Status field, click the Enable radio button to enable the recurring job; click Disable to disable 
it.

5. From the Header drop-down box, select the header file used for the job.

6. From the Connection Group drop-down box, select the connection group.

7. From the File Source drop-down box, select the file source (server or SFTP connection) that contains 
the input file. 

File Sources are configured in Perceptive DataTransfer in Configuration > File Sources; for more 
information, refer to Configuring File Sources on page 92.

This field is dimmed and unavailable if you are using a database, web service, or Hobsons Connect 
CRM header.

8. From the Start time drop-down box, select the time on which the job starts. If you do not specify a 
start date and start time, the job is run only manually.
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9. In the Options pane, specify the following.

• Check the Log SQL checkbox to log SQL messages; these messages appear in the Log View 
dialog box (refer to Viewing Log Messages on page 39).

• Check the Allow Duplicate Filenames to allow jobs to have the same name.

• Check the Use Filename checkbox to include the name of the input file in the job name. When 
you add a new job, the name of the input file is appended to the job name.

• Check the Delete Files checkbox to delete input files from the server after they have been used 
for the recurring job.

10. In the Job Restrictions pane, do the following.

• Check the Limit other users from running checkbox to prevent other users from running this 
job.

• Check the Limit other users from opening or editing until processed or completed checkbox 
to prevent other users from opening or editing the job until it has finished processing records or 
has completed running. 

11. In the Recurrence Pattern pane, specify when the job recurs.

• Click the Daily radio button to specify that the job recurs daily, and then specify the recurrence 
frequency.

• Click the Weekly radio button to specify that the job recurs weekly, and then specify the 
recurrence frequency.

• Click the Monthly radio button to specify that the job recurs monthly, and then specify the 
recurrence frequency.

• Click the Auto radio button to specify that the job recurs automatically whenever a file is added to 
the file source used for the job. The Delete Files option is automatically selected to prevent 
duplicate jobs from being created using the same file. You can use only headers that use file 
sources to provide data; therefore, you cannot create automatically recurring jobs that use 
headers of types database, Hobsons Connect CRM, or web service. 

• Click the Manual radio button to specify that the job recurs manually. It does not have a 
scheduled run date and recurs only when manually started. You can start the job anytime in the 
Recurring Job Administration dialog box or by calling the StartManualJob web service from a 
third-party application (refer to Perceptive DataTransfer API Guide for more information). Refer to 
Running Manual Recurring Jobs on page 248 for information on running manual recurring jobs.

12. Click the Notifications tab to configure email notifications to be sent when certain job activities 
occur. Refer to Configuring Notifications on page 55.

13. Click OK.

The recurring job is added and appears in the Recurring Job Administration dialog box. When an 
instance of this job is scheduled, the instance is created and appears in the Job Dashboard.
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Adding New Jobs
Note  For an XML header, if you change the record identifier after you create a job using the XML header, 
the job will not run.

To add a new job, do the following.

1. Select Jobs > Add Job.

The Add Job dialog box appears.

Figure 56: Add Job Dialog Box

2. The Job Name field displays the name of the job. The default name of the job is USER DATE TIME, 
where USER is the username of the user who created the job, DATE is the date (month, day, and 
year) on which the job was created, and TIME is the time that the job was created.

3. From the Header drop-down box, select the header file used for the job.
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4. From the Connection Group drop-down box, select the connection group.

5. In the Input File field, click Browse... and select the input file, which contains the data that you want 
to import, to use for the job. 

6. From the Dependent On drop-down box, select the job on which you want the new job to be 
dependent. Jobs that you can select have one of the following statuses: Pending, Incomplete, 
Connection_Error, Record_Key_Error, and On Hold.

7. In the Release On field, click the appropriate radio button for when you want the On Hold status to be 
removed from the new job. If you click Complete, the new job starts when the job on which it is 
dependent obtains Complete status. If you click Processed, the new job starts when the job on 
which it is dependent obtains Processed status. 

8. In the Start Date field, click the calendar icon to display a pop-up calendar; then, select the date on 
which the job starts.

9. From the Start time drop-down box, select the time on which the job starts. If you do not specify a 
start date and start time, the job is run only manually.

10. Check the Log SQL checkbox to log SQL messages; these messages appear in the Log View dialog 
box (refer to Viewing Log Messages on page 39).

11. In the Job Restrictions pane, do the following.

• Check the Limit other users from running checkbox to prevent other users from running this 
job.

• Check the Limit other users from opening or editing until processed or completed checkbox 
to prevent other users from opening or editing the job until it has finished processing records or 
has completed running. 

12. Click OK.

The job is created and is added to the table.

Note  If you enabled Preferences > Filename in Job Name, the name of the input file is appended 
to the job name.

Modifying Job Details
To modify job details, do the following.

1. Select a job in the Job Dashboard and right-click it and select Edit Details.

The Edit Job Details dialog box appears.

2. In the Job Name field, type the name of the job.

Note  You cannot modify any other fields, except the Job Name field, if you are modifying a job with 
any status other than Pending.

3. From the Connection Group drop-down box, select the connection group to use for the job.

4. In the Start Date field, click the calendar icon to open a calendar, and then select the date on which 
the job starts.
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5. From the Start Time drop-down box, select the time on which the job starts.

6. Click OK to save your changes and close the dialog box.

Modifying Jobs
To modify a job, select a job in the table and either right-click it and select Edit or click Edit.

A window appears and displays information about the job.

Figure 57: Edit Job Window
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Table 8: Edit Job Window Elements and Descriptions

Callout No. Element Description

1 Menu bar Displays the name of the job, name of the header used for the job, name of the 
input file used for the job, and the database connection for the job.

2 Records pane Displays records contained in the job. 

You can filter the records displayed by right-clicking a record, selecting Filter 
By, and then selecting the appropriate option. You can also filter records by 
selecting the filter option from the Filter by drop-down box. Options are: 

• All

• Unprocessed

• Suspended

• Match

• New

• Locked

The rank column identifies the stage of matching during which the record was 
set as Match or New. For more information, see Understanding Record Rank on 
page 251.

If sorting is enabled on a column, when you click a column heading, the field is 
sorted alphanumerically from A-Z; if you click the heading again, the field is 
sorted from Z-A. You can choose to make up to ten columns sortable when you 
edit the input variables corresponding to the columns in the Header Editor 
dialog box. 

Refer to the following topics for more information.

• Configuring and Modifying Fixed-Width Headers and Header Variables on 
page 102.

• Configuring and Modifying Delimited Headers and Header Variables on 
page 107.

• Configuring and Modifying Database Headers on page 110.

• Configuring and Modifying XML Headers and Header Variables on 
page 112.

• Configuring Hobsons Connect CRM Headers and Header Variables on 
page 119.

Sorting is based on the prefix of the input variable. If the prefix is &, sorting is 
based on timestamp (which in the end is a numeric sort); if the prefix is $, 
sorting is alphanumeric; and if the prefix is #, sorting is numeric.
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Specifying Data Displayed in the Results Pane
When a job is run in interactive mode on all records, or when records that were suspended when a job 
was run in batch mode and are then managed in interactive mode, match logic is run and finds possible 
matches for the input record. 

2 Records pane (cont.) These values are all stored as strings regardless of the prefix the values are 
converted to when the user opens or edits a job to prepare a job. If, for 
example, the prefix is # and the value does not convert to a numeric value, the 
value is managed as null; for #ZIP and value SEVEN, seven is null when sorted.

You can suspend, lock, reset, and modify records by right-clicking a record and 
selecting the appropriate option. Refer to the following topics for more 
information.

• Viewing Logs on page 241.

• Locking Records on page 240.

• Modifying Records on page 240.

• Suspending Records on page 241.

3 Input Variables pane Displays the header input variables used in the header for the job. For more 
information about configuring headers and header variables, refer to 
Configuring Headers on page 100.

4 Program Variables pane Allows you to view and configure program variables. For more information 
about configuring variables, refer to Configuring Procedures on page 127.

5 Verification form Verification form used for the job; it is displayed when you click the Form Editor 
tab.

6 Procedures tab and 
pane

Allows you to view and configure procedures. When you click this tab, the 
Procedures pane displays the configured procedures, and it displays the 
Procedure Editor pane to the right of the tab. For more information about 
procedures, refer to Configuring Procedures on page 127.

7 Form Editor tab Allows you to view and configure the verification form used for the job. When 
you click this tab, the Verification Form pane appears to the right of the tab. For 
more information about configuring forms, refer to Configuring Forms on 
page 174.

8 Results pane Displays any potential records in the database for which there is a match in the 
input record.

You must configure the appropriate Match Result Display query to retrieve the 
appropriate information to display it in this pane. For more information, refer to 
Specifying Data Displayed in the Results Pane on page 237.

Table 8: Edit Job Window Elements and Descriptions (Continued)

Callout No. Element Description
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For each possible match, an entry in the Results pane in the Job window is associated with the ID for the 
possible match. You configure a query for a procedure using the Match Result Display logic that uses this 
ID to populate the Results pane in the Job window.

To configure a job that uses the Match Result Display logic, do the following.

1. Create and configure a database connection for the input data. Refer to Configuring Connection 
Groups and Database Connections on page 74.

2. Create a procedure that uses Match Result Display logic, which contains the query that returns 
information to the Results pane based on the specified ID returned by the query. 

For more information about configuring procedures, refer to Configuring Procedures on page 127.

3. Create a header and select the procedure used for match result display. Refer to Configuring and 
Modifying Database Headers on page 110.

When the Match logic executes on a header, a list of IDs of possible matches are generated. The 
Match Result Display query for that header is then executed for each ID and the data returned from 
the query is displayed as a row of information in the Results pane.

4. Create a new job, selecting the header and connection you created in previous steps. Refer to Adding 
New Jobs on page 233.

5. Run the job. Refer to Running Jobs on page 242.

When the job is run in interactive mode, all possible matches are displayed in the Results pane.

Opening Jobs
To open a job, do the following.

1. Do one of the following.

• Select a job in the table in the Job Dashboard and either right-click it and select Open or click the 
Open button.

• Double-click a job in the Job Dashboard table.

A window appears and displays information about the job.

2. You can filter records in the topmost pane (Records pane) by right-clicking a job, selecting Filter By, 
and selecting the status of the records you want to display. You can also select the filter option from 
the Filter by drop-down box. Options are:

• All

• Unprocessed

• Suspended

• Match

• New

• Locked

Records text is colored according to status.
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• Locked: Purple

• Match: Green.

• New: Blue

• Suspend: Red

• Unprocessed: Black

The Rank column identifies the stage of matching during which the record was set as Match or New. 
The value indicates the level of match routines executed before you determined that the record was 
Match or New. If the record is unprocessed or suspended, the rank value is empty.

For more information, refer to Understanding Record Rank on page 251.

Figure 58: Record Color Codes

3. If sorting is enabled on a column, when you click a column heading, the field is sorted, depending on 
the type of information contained in the column. The field can be sorted alphanumerically, 
numerically, or by date. 

4. To reset a record, select the record in the topmost pane and select Reset Record. Refer to Resetting 
Records on page 240.

5. To lock a record, select the record in the topmost pane and select Lock Record. Perceptive 
DataTransfer does not process locked records when you run jobs. Refer to Locking Records on 
page 240.

6. To modify a record, right-click a record and select Edit Record. Refer to Modifying Records on 
page 240.

7. To suspend a record, right-click a record and select Suspend Record. Refer to Suspending Records 
on page 241.

8. To view XML records, right-click a record (for a job using an XML header) and select View Full 
Record. Refer to Modifying Records on page 240.
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Resetting Records
You can reset any Processed record to Unprocessed by doing the following.

1. Select a job in the Job Dashboard and click Open.

A window appears and displays information about the job.

2. In the topmost pane, right-click the record you want to reset and select Reset Record.

The record is reset to Unprocessed and its information is updated in the Records pane.\

Locking Records
When you lock a record, it is not processed when you run a job. To lock a record, do the following.

1. Select a job in the Job Dashboard and click Open Job.

A window appears and displays information about the job.

2. In the topmost pane, right-click the record you want to lock and select Lock Record.

The record is locked. Its status is changed to Locked in the Records pane.

Modifying Records
You can modify the value of a field of information by doing the following.

1. Select a job in the Job Dashboard and click Open Job.

A window appears and displays information about the job.

2. In the top-most pane, right-click the record you want to modify and select Edit Record.

One of the following occurs:

• If you are modifying records for jobs using headers other than XML headers, the Record Editor 
dialog box appears and displays the following information about the variables for the record.

○ Pos: Numerical value of the position of the field in the input file. 

○ Field Name: Name of the field.

○ Value: Value of the field.

• If you are modifying records for jobs using XML headers, the Edit XML Record dialog box 

appears. In the Node column, a  icon appears next to XML tags that will appear in the 

Records pane; a  icon appears next to XML tags that will not appear.

To expand all nodes in the XML tree, click ; to collapse them, click .

3. To select the next record, click the Next button; to select the previous record, click the Previous 
button.
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4. To modify the value of a record, double-click the entry in the Value column and then type the 
appropriate value. For XML records, you can assign values to only nodes that do not have child 
nodes.

5. To apply your changes, click Apply. If you click Previous, Next, or Close without saving your 
changes, a dialog box appears and prompts you to confirm that you want to save your changes 
before the action is performed for the button you clicked.

The input record is updated with the changes you made, and its information is updated in the 
Records pane.

Viewing Logs
Click the View Logs button to view information about the job. Refer to Viewing Log Messages on page 39 
for more information.

Suspending Records
If Perceptive DataTransfer cannot upload a new record to the database when you run a job, the record is 
automatically suspended.

You can manually suspend a record if there is an issue with the record that you need to investigate 
further.

1. Select a job in the Job Dashboard and click Open Job.

A window appears and displays information about the job.

2. Right-click the record that you want to suspend and select Suspend.

The Suspend Record dialog box appears.

3. In the Enter suspend reason field, type the reason for which you are suspending the record.

4. Click OK.

The record is suspended. Its status changes to Suspended, and the record text is highlighted in red in 
the Records pane.

Searching Records
You can search for information within the entire job or within a specific column of the Record pane. 

Note  Searches are not case sensitive.

To search for information in the entire job, in the Record pane, type the text for which you want to search 
in the Find field; then, press Enter. 

If one or more results are returned, the Record pane is refreshed, and all matching terms are highlighted 

in yellow. If more than one result is returned, the  (previous) and  (next) buttons are enabled, which 
you can use to navigate to any available previous or next results. When you hover your mouse over these 
buttons, tooltips appear and indicate the result to which you will navigate if you click the button.
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To stop viewing search results, click . The text in the Find field is cleared, the search controls are 
disabled, and the current page of records is refreshed without the highlighted terms.

You can also search for information within a specific column. The tooltip that appears when you hover 
your mouse over the Find field provides more information and an example of how to perform the search.

Type *[COLUMN] at the end of the search term to search for the term only within the specific column.

For example, for the search term M*[GENDER], Perceptive DataTransfer searches for the term M within 
only the $GENDER column. 

If you do not provide the correct name of the column, and the incorrect column name does not exist, 
Perceptive DataTransfer searches the entire job for the search terms.

For example, for M*[$GENDE], if the $GENDE column does not exist, Perceptive DataTransfer searches 
the entire job for M*[$GENDE].

Running Jobs
Refer to the following topics for more information.

• Eliminating Duplicate Records on page 242.

• Understanding Run Modes on page 243.

• Running Debug Modes on page 245.

• Running Manual Recurring Jobs on page 248.

• Running Jobs in Batch Mode on page 248.

• Running Jobs in Interactive Mode on page 249.

• Running Jobs Using QAS on page 256.

• Setting On Hold Jobs on page 256.

• Monitoring Jobs on page 256.

• Running Jobs Using QAS on page 256.

Eliminating Duplicate Records
To prevent duplicate records when a header is used to run a job, you must set a column of the header as 
the record key. Because batch processing processes multiple records at one time for improved 
performance, the header record key is needed to ensure that possible duplicates in the input source are 
not processed at the same time.

Selecting a header key allows Perceptive DataTransfer to process any records with different values in the 
selected column at the same time. You do not need to select a column that guarantees unique values, but 
the column should capture duplicate records. For example, if you select Last Name as the key to a header 
and process a file that has many records with the last name Smith, which represent different students, 
you prevent any two records with the same last name from being processed at the same time. 
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To mark a header column as the record key, do the following.

1. Select Configuration > Headers. 

The Header Administration dialog box appears.

2. Click the header you want to modify and either right-click it and select Edit or click .

The Header Editor dialog box appears.

3. To mark a column as the record key, select the column and click .

The  icon appears next to the column to denote that it is the record key.

You can mark one column only as the record key; you cannot configure composite keys.

Note  A column that is set as the record key is also a sortable column and count toward the ten 
columns that can be sortable.

4. Configure other header properties, as appropriate.

For more information about configuring headers, refer to Configuring Headers on page 100.

Understanding Run Modes
You can run jobs in interactive or batch mode, which is determined in the associated match procedures 
using the appropriate global program variables. 

Perceptive DataTransfer sets the global variable GL_RUNMODE to BATCH when the job is run from the 
Job Dashboard. Note that if the associated code has interactive elements in it (for example, the STOP 
command does not work in batch mode), and a job is run in batch mode, error messages are received. 
You can configure the code to branch to specify the appropriate behavior when a job is run in either 
mode. For example, you can use an if...else statement in this syntax:

if _GL.RUNMODE_ = _GL.INTERACTIVE_

   <procedures for interactive mode>

 else 

   <procedures for batch mode>

end-if

For more information about global variables, refer to Understanding Global Variables on page 275 in 
Programming Concepts on page 261 For more information about configuring procedures, refer to 
Configuring Procedures on page 127.
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Understanding Batch Mode

In batch mode, a job is run without user intervention. For each input record, the following occurs.

1. Match logic is run until it completes. The logic searches for possible matches until a SKIP command 
is reached. The SKIP command sets the status of the input record and processes it appropriately.

• If the status of the record is MATCH or NEW, upload logic is run. 

• If the status is SUSPEND, match logic is run for the next input record.

Note  Review logic is not run in batch mode.

2. Upload logic is run; the global status of the input record is used to either create a new record or to 
update an existing record.

Understanding Interactive Mode

In interactive mode, the job processes each input record, pausing to allow the user to intervene. For each 
input record, the following occurs.

1. Match logic is run.

1. Match logic finds possible matches for the input record. For each possible match, an entry in the 
Results pane is associated with the ID for the possible match. The Match Result Display 
procedure uses that ID value to populate the Results pane in the Job window.

For an overview of steps required to configure the logic to display matches in the Results pane, 
refer to Specifying Data Displayed in the Results Pane on page 237.

2. Match logic organizes the results based on a ranking of how likely it is to be a match. For the first 
instance of the match logic, the logic searches for rank 1 matches, for the second instance it 
searches for rank 2 matches, and so on.

3. At the end of each rank iteration, the match logic pauses to allow user input. The rank and logic 
pause are established programmatically through the STORE and STOP commands.

4. The user can select one of the match results from the Results pane, initiating review logic.

5. If the user does not find a match, the user can continue to run the match logic to search for the 
next rank of possible matches. If the match logic does not find a possible match, the user is 
prompted to create a new record for the input. If accepted, the upload logic will begin. If rejected, 
the record is suspended, and the process starts again with the next input record. 

2. Review logic is run.

1. Review logic is run when a user clicks a match record in the Results pane. The user interface 
stops taking input.

2. Each time the review logic updates a program variable, any fields on the verification form linked 
to that program variable is updated in real-time.
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3. When the review logic completes, the interface accepts user input. The user can do the following.

• Click a different match result: This restarts the review logic process.

• Update the verification form: This allows the user to override data being uploaded to the 
database.

• Insert the input record as a new record: This executes the new record upload logic.

• Update an existing record: This executes the upload logic with the selected match result 
specified as the record to update.

• Suspend the input record: This flags the record as suspended and starts the iteration of the 
next input record. 

3. Upload logic is run. 

1. The Results pane is locked to prevent user input.

2. The upload logic creates the new record or updates the existing record with the appropriate 
parameters.

3. The process completes and moves to the next input record. 

When running in interactive mode, you can step through any of the match, review, or upload logic to 
debug the code. You can examine the program variables any time the logic is paused for user 
intervention. Refer to Running Debug Modes on page 245 for more information about running debug 
modes.

You can also use the PROMPT function to display message text to a user and allow the user to update 
variables when a job is run in interactive mode. For more information, refer to Understanding the prompt 
function on page 294.

Running Debug Modes
You can run debug modes when processing records. 

• Normal mode: The logic starts and executes to completion or until a STOP command is reached. 
When a STOP is reached, the interface pauses for user input.

• Debug mode: The logic pauses at each breakpoint and each STOP command. After the logic is 
stopped, you can continue to the next STOP command or breakpoint, or you can proceed to the next 
line of code.

You can insert breakpoints anywhere to pause on that line of code. The Procedure Editor displays the 
procedure being run and identifies the line on which the job has been stopped. 

Note  You cannot add breakpoints to end-select statements.
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Do the following.

1. In the Job Dashboard, select the job you want to run and either right-click it and select Edit or click 
the Edit button. 

2. In the topmost pane, select the record you want to run.

3. Click the Procedures tab.

4. Select the procedure that contains the line of code you first want to execute.

5. Click the line number of the line to which you want to add a breakpoint.

A  appears next to the line number, indicating that you have added a breakpoint to the line.
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Figure 59: Procedure with Breakpoints
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6. To clear a breakpoint, do one of the following.

• To clear all breakpoints in all procedures, click  in the Procedures toolbar.

• To clear all breakpoints within a specific procedure, select the procedure and click  in the 
toolbar of the Procedure Editor.

• Click the breakpoint to remove it.

7. Click Run.

8. The code runs and pauses at the breakpoint. The following buttons are enabled in the Procedure 
Editor.

•  Continues running the code until it reaches the next breakpoint, the STOP command (which 
pauses to allow the user to create new records, set matched records, or suspend records), or the 
end of the code.

•  Pauses at the next line of code after this line has been run.

•  Stops processing the record.

Running Manual Recurring Jobs
If a recurring job can be run manually, you can run it at any time by doing the following.

1. Select Jobs > Recurring Jobs.

The Recurring Job Administration dialog box appears.

2. Click .

You can specify that the recurring job is run manually in the Add Recurring Job and Edit Recurring Job 
dialog boxes. Refer to Adding and Modifying Recurring Jobs on page 230 for more information.

Running Jobs in Batch Mode
To run a job in batch mode, in the Job Dashboard, select the job you want to run and either right-click it 
and select Run from the popup menu or click the Run button.

To stop a job that is running, either right-click the job and select Stop or click the Stop button.

After Perceptive DataTransfer processes the job, you can open the job to view job results, including 
information about any suspended or unprocessed records. 
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Running Jobs in Interactive Mode
To run a job in interactive mode, do the following.

1. Select a job in the table and click Open Job.

A window appears and displays information about the job.

2. Do one of the following.

• To process a single record in the job, select the record in the topmost pane and click the Run 
button.

• To process all records in the job, click the Run All button.

• To stop running the job, click Stop in the bottom toolbar.

Depending on your configuration, you may receive the Prompt dialog box for a record, which displays 
message text and allows you to update values of information for the record.

For example, you may receive a message that the address information is not correct, and you can 
update address information, such as street number, city, and state.

To modify a value, click the row of in the Value column and type the appropriate text. Then, do one of 
the following.

• Click OK to apply your changes. The information is updated, and jobs processing resumes.

• Click Reset to reset the values in the Prompt dialog box to the original values.

• Click Cancel to stop processing on the record. The Error Processing dialog box appears and 
provides information about why the record could not be processed.

If you enabled the Display All Match Results preference, when you run a job in interactive mode, all 
possible record matches are compiled before the application pauses to allow you to review the 
possible matches. For more information, refer to Specifying Preferences on page 24.

If you are running a job and are using the DataProviderPrompt function with this job, you may receive 
a Result Selection dialog box, which displays a prompt in the top field and values, returned by the 
job, below it. This dialog box appears if multiple records of information are obtained from the job; 
select the information you want to use and click OK. For more information about web services, refer 
to Configuring Web Service Data Providers on page 157.
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Figure 60: Result Selection Dialog Box

When Perceptive DataTransfer processes records in interactive mode, one of the following occurs.

• If a record cannot be processed, a dialog box appears and displays information about why the 
record could not be processed. The dialog box contains the following information:

○ Procedure Name: Name of the programming procedure that contains the problem.

○ Line #: Number of the line in the procedure in which the problem occurred.

○ Error Information: Description of the problem in the procedure.

• If a new record could not be uploaded, the record is suspended.

• If Perceptive DataTransfer cannot find a matching record in the database, a dialog box appears 
and prompts you to create a new record. Click Yes to create the record and add it to your 
database; click No if you do not want to create a new record.
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• If there are potential matches in your database, Perceptive DataTransfer pauses and prompts you 
to review results, which are displayed in the Results pane. Perceptive DataTransfer organizes the 
results based on a ranking of how likely they are to be matches to the input data. 

Click  to continue to process records to search for more possible results. 

○ If Perceptive DataTransfer does not find a match, you are prompted to create a new record. 
Click Yes to create the record; the record is updated in the topmost pane, with its status 
changing to New and its label color changing to blue.

○ If you find a matching result and want to create a matched record, select the result in the 
Results panel and click the Matched button. The record’s status is updated as Match, its 
color changes to green, and it is updated in the topmost pane.

After Perceptive DataTransfer uploads a record, an informational dialog box appears and 
displays the record number that was processed and if it was “successfully matched,” if it was 
“successfully created,” or if it “failed to upload.”

You can use the verification form, if configured, to compare information from the current input 
record and potential matches in your database. Refer to Viewing the Verification Form on 
page 254.

Understanding Record Rank
The Rank column in the Record grid in the window that appears when you edit or open jobs identifies the 
stage of matching during which the record was set as Match or New.

If the record is unprocessed or suspended, the Rank column does not display any information. If the 
record was set to Match or New when the job was run in interactive mode, the rank is the value used in 
the NQL STORE command. (For more information about the STORE command, refer to Understanding 
the store Function on page 297).

For example, consider the example match routine in the following figure:
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Figure 61: Example Match Routine in Interactive Mode

The match routine is 01-match-ssn with the corresponding command store 1, 'nu_id'. Conventionally, 
match routines are numbered, and they have a corresponding store command with the same numerical 
value. This value is displayed in the Match Results pane to identify the stage of matching during which the 
possible match was found. Therefore, if a record is set as Match with a record with a store of 1, the rank 
is also 1. If the record is set as New, the rank is the value of the last store command. In this way, you can 
identify how many records the user examined before the record was set as New. 

The rank process works similarly when the record is set to Match or New when the job was run in batch 
mode. In batch mode, the record status is changed by either a SKIP NEW or SKIP MATCH command; the 
STORE command is not used. (For more information about the SKIP command, see Understanding the 
skip Function on page 296).

Both the SKIP NEW and SKIP MATCH commands take an additional second parameter, which is any 
string that identifies the rank at which the record status changed. The string can be any value that you 
want to use to indicate rank.

Consider the example match routine in the following example:
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Figure 62: Example Match Routine in Batch Mode
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In this example, the match routine is AA-match-last-4-first-2-ssn, and its SKIP MATCH command, which 
has the string parameter AA, appears on line 45 (skip MATCH, 'AA'). 

In this example, AA was chosen as the parameter because match procedures are numbered 
alphabetically; this batch procedure begins with AA. Therefore, if a record is set as Match with a record 
with a SKIP MATCH of AA, the rank is also AA, which indicates that the record was set to Match in match 
routine AA.

Similarly, if a procedure had a SKIP NEW command with a string parameter of AA, the record is set as 
New with a rank of AA.

When you upgrade to this release of Perceptive DataTransfer, the rank is recorded for any new records 
for jobs run in interactive mode. To update record ranks for jobs run in batch mode, you must update the 
SKIP NEW and SKIP MATCH commands to add the new rank. This optional parameter is a string, but you 
can also use numeric string literals (for example, '1').

Viewing the Verification Form
With the verification form, you can compare the current input record side-by-side with the possible 
existing record. 

Note  The form is displayed only when a job is running in interactive mode.

When you run a record, the verification form displays data associated with the input record and the 
possible record in your database. 
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Figure 63: Sample Verification Form

Users can check or uncheck the toggle checkboxes in form field sets to specify which field sets of 
information are included when upload logic is processed.

Use form toggles if you need to provide the value of each field set to the associated upload logic; when 
the upload logic is run, this value is included when the data file is uploaded. The form can return the value 
of a toggle given a specified program variable name. 

When you configure the associated Perceptive DataTransfer logic, the logic must verify the values of the 
toggles and upload changed information appropriately. Refer to Using Form Toggles on page 190 for 
more information.

After you review the data in the verification form and compare it with the possible matched record in the 
database, you can create a new record, create a matched record, or suspend the record.
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Setting On Hold Jobs
You can set a job status to be On Hold so that it cannot be run interactively or in batch mode until the 
hold status is released. You can set a job on hold if it has one of the following statuses: Pending, 
Incomplete, Connection_Error, or Record_Key_Error.

To set a job as on hold, select the job in the Job Dashboard and either right-click it and select Hold or 
click Hold.

To remove the on hold status from the job, select the job in the Job Dashboard and either right-click it 
and select Release or click Release.

Monitoring Jobs
Select a job in the Job Dashboard and either right-click it and select Monitor or click Monitor.

The Job Progress dialog box appears in the foreground of your browser and remains open and in the 
foreground until you click Close. 

A progress bar appears at the top of the dialog box, indicating the percentage complete of the job. The 
dialog box displays the following information.

• Total: Total number of records in the job.

• Unprocessed: Number of records that are not processed.

• Suspended: Number of suspended records.

• Matched: Number of matched records.

• New: Number of new records.

• Locked: Number of locked records.

When the job is running, the Stop button appears in the Job Progress dialog box; click it to stop running 
the job. When the job has completed, only the Close button is displayed.

Running Jobs Using QAS
You can run jobs that use headers on which QAS is configured. By default, QAS is enabled on headers; 
you can disable this option. 

When a job is created using a header on which QAS is enabled, Perceptive DataTransfer checks the 
associated connection group for a QAS connection. If there is no connection, it is assumed that you are 
not using QAS in the procedures associated with the job. If a QAS connection is found, the QAS 
connection is tested; if the test is unsuccessful, the job status is set to Connection_Error, and you must 
correct the connection before you can run the job. This verification is performed each time you attempt to 
run the job. 
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The following steps provide an overview of the tasks you must perform to run jobs using QAS.

1. Add a QAS connection. Refer to Adding Connection Groups on page 74.

2. Enable QAS on the header. By default, headers are configured to use QAS. You can disable this 
option. For more information about configuring headers, refer to Configuring and Modifying Fixed-
Width Headers and Header Variables on page 102, Configuring and Modifying Delimited Headers and 
Header Variables on page 107, Configuring and Modifying Database Headers on page 110, and 
Configuring and Modifying XML Headers and Header Variables on page 112.

3. Provide the appropriate QAS code for the procedures associated with the job. For more information 
about procedures, refer to Configuring Procedures on page 127. For information about the 
QASCheckAddress function, refer to Understanding the QASAddressCheck Function on page 294.

4. Add a job that uses the configured header and QAS connection group. Refer to Adding New Jobs on 
page 233.

Deleting Jobs
Refer to the following topics for more information.

• Deleting Jobs on page 257.

• Deleting Recurring Jobs on page 258.

Deleting Jobs
You can delete a job that has never been run (the job has a status of pending, and all its records are 
unprocessed). You cannot delete jobs that have fully completed.

To delete a job, do the following.

1. In the Job Dashboard, select the job you want to delete and either right-click it and select Delete or 
click Delete.

A dialog box appears and prompts you to confirm that you want to delete the job.

2. To delete the job, click Yes.

The job is deleted and is removed from the Job Dashboard.
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Deleting Recurring Jobs
To delete a recurring job, do the following.

1. Select Jobs > Recurring Jobs.

The Recurring Job Administration dialog box appears.

2. Select the recurring job you want to delete and either right-click it and select Delete or click .

A dialog box appears and prompts you to confirm that you want to delete the job.

3. To delete the job, click Yes.

The job is deleted and is removed from the Recurring Job Administration dialog box.

Canceling Jobs
You can cancel all jobs except those that has never been run (the job has a status of pending, and all its 
records are unprocessed). 

You can cancel jobs that have at least one record that has been processed. However, you cannot cancel 
jobs that have fully completed.

When you cancel jobs, they are removed from the Job Dashboard when you select Active from the 
Status drop-down box.

To cancel a job, do the following.

1. In the Job Dashboard, select the job you want to cancel and either right-click it and select Cancel or 
click Cancel.

A dialog box appears and prompts you to confirm that you want to cancel the job.

2. To cancel the job, click Yes.

The job is canceled, and its status is set to Canceled in the Job Dashboard.

Archiving Jobs
You can configure rules to archive jobs in the Archive Administration dialog box.
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Figure 64: Archive Administration Dialog Box

Refer to the following topics for more information.

• Adding and Modifying Archive Rules on page 259.

• Deleting Archive Rules on page 260.

Adding and Modifying Archive Rules
1. Select Administration > Archive.

The Archive Rule Administration dialog box appears.

2. Do one of the following.

• To add a new archive rule, click .

The Add Archive Rule dialog box appears.

• To modify an archive rule, select the rule and either right-click it and select Edit or click .

The Edit Archive Rule dialog box appears.

3. In the Status field, click the Enable radio button to enable the archive rule; click Disable to disable it.

4. If you are modifying a rule for a particular header, the Header drop-down box displays the header; 
you cannot modify this field. If you are modifying the default rule for all headers, the Header drop-
down box is not displayed. 
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5. In the Days field, type the number of days after which the job should be archived after it has 
completed.

6. In the Data to Maintain dialog box, specify the data that you want to archive.

• Summary Data checkbox: Maintains summary data. This option is always enabled; it is dimmed 
and unavailable to be checked.

• Record Level Details checkbox: Check to maintain details about records.

• Logs checkbox: Check to maintain log files.

7. From the Start Time drop-down box, select the time on which you want to start the archive rule.

8. In the Recurrence Pattern pane, click the appropriate radio button to specify whether the rule recurs 
daily, weekly, or monthly, and then specify the recurrence frequency.

9. Click OK.

If you created a new rule, it is added and appears in the Rule Administration dialog box. If you 
modified a rule, its updated information is saved.

Deleting Archive Rules
Note  Perceptive DataTransfer includes a default, configured archive rule (which is disabled by default) 
that applies to all headers; you cannot delete this archive rule.

To delete a rule, do the following.

1. Select Administration > Archive.

The Archive Rule Administration dialog box appears.

2. Select the rule you want to delete and either right-click it and select Delete or click .

The rule is deleted and is removed from the Archive Rule Administration dialog box.
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Appendix A: Programming Concepts

Refer to the following topics for more information.

• Understanding Procedure Syntax on page 261.

• Understanding Operators on page 264.

• Accessing the Database on page 267.

• Understanding the Assignment Statement on page 270.

• Understanding Flow Control on page 270.

• Understanding Global Variables on page 275.

• Understanding String Functions on page 276.

• Understanding General Functions on page 282.

Understanding Procedure Syntax
The body of a procedure contains the assignments, SQL statements, and flow control that comprise the 
procedure. After you add or modify a SQL block, you can add or modify your source code. 

The syntax for the procedure body is:

begin-procedure procedure-name [(arg1,arg2, … argN)]

   …

end-procedure

For example, the following procedure returns a value from a table matching on each of two input 
variables. 

begin-procedure check-table-name ($t_term, $uid)

   let #found_match = 0

   let #recr_seqno = 0

   begin-select

      table-name_seqno as  ~#recr_seqno

         let #found_match = 1

         exit-select

      FROM table-name

      WHERE table-name_term = ~$t_term
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        AND table-name_uid = ~$uid

   end-select

end-procedure

In this example, procedure-name is the name of the procedure to be created; arg1, arg2, and so on, are 
the names of the procedure parameters (both input and output); and the procedure body contains the 
code for the procedure.

Every SQL block must begin and end with the begin-procedure and end-procedure keywords. The begin-
procedure statement defines the procedure start point and the name by which the procedure is 
referenced and run. 

Understanding Database Population Selection Syntax
Database Population Selection logic contains the query for dynamically extracting input data to a header. 
You use this logic in procedures and associate them with headers so that you can capture header input 
variables from the input file.

For example:

begin-procedure test-query

!

   begin-select

      SSN       “$SSN”,

      FIRST             “$FIRST”,

      LAST              “$LAST”,

      MI                “$MI”,

      DOB          “+DOB”,

      SEX               “$SEX”,

      FROM table_name

   end-select

!

end-procedure

You must write database source queries in the database syntax for the target database.

Syntax for Oracle

Note the following.

• The column alias must be enclosed by double quotation marks (“ ”)

• Use + instead of & for the column alias.
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For example:

begin-select

         SSN “#SSN”,

         FIRST         “$FIRST”,

         LAST          “$LAST”,

         MI             “$MI”,

         DOB           “+DOB”

      FROM demo

   end-select

Syntax for IBM Informix

The column alias name must include a two-character translator to the proper special character 
designator.

• NN_ for Number #.

• SS_ for Character $.

• DD_ for Date &.

For example:

begin-select

   trim(ssn)NN_SSN 

   trim(first)SS_FIRST,

   trim(last) SS_LAST,

   trim(mi)SS_MI,

   dob DD_DOB

      from demo

Syntax for Microsoft SQL Server

Note the following:

• The column alias must use AS and [ ]

• Use special character designators ($ for Character, # for Number, and & for Date).

For example:

begin-select

    SSN AS [#SSN],

    LAST AS [$LAST],

    FIRST AS [$FIRST],

    MI AS [$MI],
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    DOB AS [&DOB]

    FROM DEMO

end-select

Understanding Operators
The following table describes symbol operators used in code.

Table 9: Symbol Operators and Descriptions

Operator Symbol Description

' Character string delimiter.

+ Addition operator.

/ Division operator

- Subtraction operator.

* Multiplication operator.

! Indicates a comment.

, Separates items.

= Equal to operator.

!= Not equal to operator.

<= Less than or equal to operator.

>= Greater than or equal to operator.

< Less than operator.

> Greater than operator.

( Expression or list delimiter.

) Expression or list delimiter.

|| Concatenation operator.

\q Escape sequence for a single quote ( ' ). When you insert strings that themselves 
contains strings or single quotes into the database, you must escape the single 
quotes. 

For example, to set a variable equal to the phrase "It’s OK", you would use let 
$some_var = 'It\qs OK.'
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In queries, you can use the following operators.

• [ ] 

Commonly, this operator is used when you are dynamically building a WHERE clause of a query. The 
conditions of the query depend on the code that executes and on the input data, so the WHERE 
clause is built inside another variable. 

For example, consider a variable $where_clause that contains WHERE first_name = 'John' and 
last_name = 'Smith'. You can add that variable to a select statement as follows.

begin-select

   person_id     ~$pers_id

   FROM person

   $where_clause

end-select

However, if you use the preceding query, all string variables in a query are replaced with their value 
surrounded by single quotes:

begin-select

   person_id     ~$pers_id

   FROM person

   'WHERE first_name = 'John' and last_name = 'Smith''

end-select

The query does not work in this manner; instead, use the [ ] operators, which tell the NQL interpreter 
to do a straight string replacement and to not include the surrounding quotes. The syntax is:

begin-select

   person_id     ~$pers_id

  FROM person

  [$where_clause]

end-select

For example:

begin-select

  person_id     ~$pers_id

  FROM person

  WHERE first_name = 'John' and last_name = 'Smith'

end-select
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• ~ (tilde)

Use the tilde operator within the SELECT clause of a query. The value of a specified column is placed 
into the specified variable. For example:

begin-select

   person_id    ~$pers_id

   FROM person

end-select

The value of the person_id column will be placed into the $pers_id variable. 

If the tilde (~) was not specified, for example:

begin-select

   person_id     $pers_id

   FROM person

end-select

The value of the variable is inserted into the query itself. When the above query is run, no value would 
typically be in $pers_id, and the query would look as follows.

begin-select

   person_id     ''

   FROM person

end-select

However, this query syntax is incorrect. If the tilde (~) operator occurs in the FROM clause or any 
clause after (such as WHERE, ORDER BY, and so on) the operator is ignored. Any variable referenced 
in the FROM clause or after is replaced with the value in the variable at the time of execution. For the 
two queries:

begin-select

   person_id   ~$pers_id

   FROM person

   WHERE person_id = $id

end-select

begin-select

   person_id    ~$pers_id

   FROM person

   WHERE person_id = ~$id

end-select
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If $id = 999, both queries evaluate to:

begin-select

    person_id    ~$pers_id

    FROM person

    where person_id = '999'

end-select

Accessing the Database
You can optionally select, insert, update, and delete data from your database by embedding the 
appropriate SQL statements within the body of a SQL block.

Refer to the following topics for more information.

• Understanding Select Constructs on page 267.

• Understanding Insert, Update, and Delete Constructs on page 268.

• Understanding the execsp Statement on page 269.

• Understanding the begin-plsql Statement on page 269.

Understanding Select Constructs
The syntax for the Select construct is:

[ begin-select

   [select SQL logic]

end-select ]

For example:

begin-select

   last_name as  ~#tmp_last

      let #found_match = 1

      exit-select

 

   FROM last_names

   WHERE ssn = ~$t_ssn

end-select

In this example, the last_name column is selected from the last_names table, where the ssn column 
matches the temporary variable $t_ssn.
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The ~ (tilde) character is used in the SELECT clause of a query. The value of a specified column is placed 
into the specified variable.

Use exit-select to immediately exit the SQL block in which it appears. Code is run until it reaches end-
select.

Understanding Insert, Update, and Delete Constructs
The syntax for the Insert construct is:

begin-sql 

   [insert SQL logic]

end-sql

The syntax for the Update construct is:

begin-sql 

   [update SQL logic]

end-sql 

The syntax for the Delete construct is:

begin-sql 

   [delete SQL logic]

end-sql 

For example:

begin-procedure inst-names

   begin-sql

      INSERT INTO names

      SELECT #var1, $var2, $var3, sysdate,

        FROM dual

       WHERE names_id NOT IN 

            (SELECT names_id

               FROM names

              WHERE names_id = ~$t_id)

   end-sql

end-procedure 

 

In this example, values are inserted into a database table.
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Understanding the execsp Statement
This statement runs a SQL Server stored procedure.

This syntax is:

EXECSP spName($param1, #param2, ~$param3...)

The tilde ( ~) is used for output parameters.

Understanding the begin-plsql Statement
This statement runs an Oracle PL/SQL package or procedure.

• The begin-plsql statement allows a procedure to be called and for variables to be passed to it. It also 
allows the return of output variables.

• The => operator is used to assign values to variables.

• The tilde ( ~ ) character is used at the beginning of a program variable to indicate that it is an output 
variable type in the plsql code.

The syntax is:

begin-plsql

   package.procedure(

         in_variable,

         out_variable;

end-plsql

For example:

begin-plsql

   nolijpackage.proc_add_name(

      first => 'John',

      last => 'Smith',

      id => ~#t_id);

end-plsql
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Understanding the Assignment Statement
The let statement is the Perceptive DataTransfer assignment operator, which is primarily used to assign a 
value (for example, constant, date, or other variable) to a variable. 

The syntax for the let statement is:

let $var1 = $var2

let $var3 = tostring(#var4)

let $var5 = &var6

Character and string variables can be assigned only character values. Use the tostring function for 
conversion if you are assigning a numeric value to a character variable. Refer to Understanding the 
tostring Function on page 281.

Numeric variables can be assigned only numeric values. Use the tonum function for conversion if you are 
assigning a character value to a numeric variable. Refer to Understanding the tonum Function on 
page 281.

You must enclose hard-coded character values in single quotation marks ( ' ).

For example:

let #var1 = 45

let $var2 = $var1

let $var3 = 'test string'

Understanding Flow Control
Perceptive DataTransfer supports the following flow-control statements:

• if...else: Evaluates a statement or value and branch, depending on the result. If TRUE, program 
execution branches to the code following the if statement. If FALSE, program execution branches to 
the code following the else statement. Refer to Understanding the if...else Statement on page 271.

• loop...until: Allows multiple lines of program code to be executed continuously until a certain 
condition or value exists. Refer to Understanding the loop...until Statement on page 272.

• evaluate: Evaluates a variable with multiple possible values and branches to a different block of logic 
for each value. Refer to Understanding the evaluate Statement on page 273.

• for each: Iterates over all the specified nodes within a given subtree in an XML file. Refer to 
Understanding the for each Statement on page 273.
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Understanding the if...else Statement
The if…else statement is used to evaluate a statement or value and then branch, depending on the result. 
There are two basic forms of the if statement: if and if…else.

The if statement is most frequently used to perform an action when a certain condition is met or to skip 
the action if the condition is not met. The syntax is:

if <condition>

   <statement-list>

end-if

If the condition in the if statement is TRUE, all logic contained in the statement list is run, and if the 
condition is FALSE, all logic contained in the statement list is skipped. The end-if statement terminates 
the statement list:

if #var1 > 40

   let #var3 = 45

end-if

The if...else statement uses the keyword else followed by a second set of statements, as follows.

if <condition>

   <statement-list>

 else 

   <statement-list>

end-if

If the condition is FALSE, Perceptive DataTransfer executes the statement list following the else clause 
instead of the statement list following the if clause:

if #var1 > 40 

   let $var3 = 'Over 40'

 else

   let $var3 = 'Under 40'

end-if
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Additional if statements can be nested within each other:

if #var1 > 40 

   let $var3 = 'Over 40'

 else

   if #var1 = 40

      let $var3 = 'Equal 40'

    else

      let $var3 = 'Under 40'

   end-if

end-if

You can also use the elseif command as a shortcut for nesting statements so that they are more readable 
and do not require an end-if command for every condition, as follows.

if <condition 1>

elseif <condition 2>

elseif <condition 3>

....

elseif <condition N>

else

end-if

The ellipses (...) represents that you can use any number of elseif conditions.

If you use the elseif command, you must also end with an else clause. 

Understanding the loop...until Statement
The loop…until statement allows multiple lines of program code to be run continuously until a certain 
condition or value exists. The until statement evaluates with each loop to determine if the loop should 
continue.

For example:

#c = 0

loop

   <statement-list>

   let #c = #c + 1

until #c = 5
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This loop executes each line in the statement list and increments the #c variable by one until it reaches 
five, after which the loop is completed.

Note  The until statement must be the last statement in the loop construct.

Understanding the evaluate Statement
The evaluate statement is used to interpret a variable with multiple possible values and to branch to a 
different block of logic for each value or range of values. The evaluate statement is suitable for branching 
to three or more possible locations.

For example:

evaluate #age

   when > 40

      let $display_text = 'Over 40'

      break

   when = 40

      let $display_text = 'Equal 40'

      break

   when < 40 

      let $display_text = 'Under 40'

      break

end-evaluate

You must use the break statement to exit the evaluate statement after you have executed the appropriate 
code to prevent program execution from continuing with the next when statement.

You can use consecutive when statements if you are executing the same logic block.

Use when-other as the exception handler.

Understanding the for each Statement
The for each statement iterates over all the specified nodes within a given subtree in an XML file. Use this 
statement when you are processing XML input files and XML headers.

Use the node function within each for each statement to return the value for the specified node.

For example:

for each 'Person'

    let $f_ssn = node('SSN')

    let $f_dob = cnvdate(node('Birth'), 'yyyy-MM-dd')

    let $f_sex = substr(node('Gender'), 1, 1)

  

    for each 'Name'
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       let $f_first = node('FirstName')

       let $f_middle = node('MiddleName')

       let $f_last = node('LastName')

    next

  

    for each 'Contacts'

       for each 'Address'

          let $f_street1_1 = node('AddressLine')

          let $f_city_1 = node('City')

          let $f_st_1 = node('StateProvinceCode')

          let $f_zip_1 = node('PostalCode')

       next

       for each 'Phone'

          let $f_full_phone_1 = node('Home')

       next

        for each 'Phone'

           let $f_full_phone_2 = node('Home')

        next

     next

  next

In this example, each record corresponds to the XML subtree contained within the <Student> XML tag. 
The example code shows how to process each Student subtree.

Each for each loop specifies the tag, exactly as it appears in the XML, with which to iterate. In this 
example, for each loops iterate over every <Person> node within the <Student> subtree.

Use the keyword next to designate the end of the loop.

By nesting for each loops, with each inner loop iterating over the child nodes of the parent, you can 
iterate through the entire XML tree.

Use the node function within each loop to return the value of the specified node. For example, the 
function iterates over each <Person> node, then over each <Contacts> node, and then over each 
<Address> node.  Within the <Address> node are the leaf nodes <AddressLine>, <City>, 
<StateProvinceCode>, and <PostalCode>.  To store the address line in a program variable, use the 
syntax let $f_street1_1 = node('AddressLine').

Note the following.

• If you use XML syntax (for each or node) with input record data that is not XML, an error message is 
displayed when the corresponding job is run.

• If you iterate over a node that does not exist or that does not exist as a child to the current node, the 
loop is skipped because no matching child nodes could be found.
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• If you use the node function to reference a node that does not exist, an empty string is returned.

• If you use the node function to reference a node that is not a leaf node, the function returns a 
concatenated string of all the children nodes for the specified node. 

For example, if you use node('Address') instead of the leaf nodes of <Address>, you may receive, for 
example, 138 Conant Street Beverly MA 02915 as output. For nodes such as <Address>, such output 
may be useful; however, for a node like ('Contacts'), you would receive a string of all the addresses 
and phone numbers concatenated together, which would likely not be very useful.

• Because this XML syntax allows you to reference every node in the XML by the exact XML tag name, 
there are no input variables for XML header jobs.  Other input files have an input variable for each 
data field in the file, but for XML input files, you must use the for each and node syntax to drill down 
to the desired part of the XML tree.

• Perceptive DataTransfer keeps the current context of the XML tree. If the code is currently within a 
particular for each loop, any code within that loop will only process within the current subtree of the 
XML. All for each and node calls are contextual, so the same tag name can exist in different levels of 
the XML. 

Understanding Global Variables
Global variables are predefined variables that can be referenced at any point during program execution.

Perceptive DataTransfer supports the following global variables:

• _GL.BATCH_

Run mode variable; specifies that a job is running in batch mode.

• _GL.DBNAME_

Database variable; contains the database name or database instance name of the current database.

• _GL.FILENAME_

Filename variable; contains the name of the current input data file.

• _GL.FILEPATH_

File path variable; returns the destination path configured for input files that are downloaded from a 
file source (refer to Configuring File Sources on page 92 for more information about configuring file 
sources).

• _GL.FILETYPE_

File type variable; contains the extension of the current input data file.

• _GL.HEADER_

Header variable; contains the title of the current header file (for example, Recruit Card or Web 
Application).

• _GL.INTERACTIVE_

Run mode variable; specifies that a job is running in interactive mode.
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• _GL.MATCH_

Status constant; represents a matched record.

• _GL.NEW_

Status constant; represents a new record.

• _GL.QASENABLED_

Global variable that can be referenced within the code so you can determine if the current header is 
QAS-enabled. Values can be Y or N.

• _GL.RECORDNO_

Global variable that contains the record number of the record being processed.

• _GL.ROWCOUNT_

Row count variable; contains the number of rows returned from a begin-select or begin-dataprovider 
statement.

• _GL.RUNMODE_

Run mode variable. Perceptive DataTransfer sets GL_RUNMODE to BATCH when a job is run from 
the Job Dashboard. You can configure the code to branch to specify the appropriate behavior when 
a job is run in batch or interactive mode. For example:

if _GL.RUNMODE_ = GL.INTERACTIVE_

   <procedures for interactive mode>

 else 

   <procedures for batch mode>

end-if

• _GL.SUSPEND_

Status constant; represents a suspended record.

• _GL.STATUS_

Status variable; contains the status (new, match, or suspend) of the row being processed.

• _GL.USERID_

User ID variable; contains the username of the logged in user.

Understanding String Functions
String functions are built-in routines for manipulating string variables and values. Refer to the following 
topics for more information.

• Understanding the ascii function on page 277.

• Understanding the inschr function on page 277.

• Understanding the length Function on page 278.
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• Understanding the lower function on page 278.

• Understanding the ltrim Function on page 278.

• Understanding the mixed Function on page 279.

• Understanding the mixedlt Function on page 279.

• Understanding the replace Function on page 280.

• Understanding the rtrim Function on page 280.

• Understanding the substr Function on page 280.

• Understanding the tonum Function on page 281.

• Understanding the tostring Function on page 281.

• Understanding the trunc Function on page 281.

• Understanding the unstring Function on page 281.

• Understanding the upper Function on page 282.

Understanding the ascii function
This function returns the ASCII value of the leftmost character of a string.

The syntax is:

ascii(string)

For example:

let #num = ascii('X')

Understanding the inschr function
This function converts a character to its ASCII equivalent.

The syntax is:

inschr(variable, replace character)

For example:

let $city = inschr($city, '&')

This statement replaces all occurrences of & in the value of $city with the ASCII equivalent of &.
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Understanding the instr Function
The instr function searches variable1 for the occurrence of variable2 beginning at start position.

The syntax is:

instr (variable1, variable2, start position)

For example:

#pos1 = instr($street2,'Apt',1)

if instr('W|AP|AI|AF|N',$f_ethn,1) > 0

Understanding the length Function
This function returns the length of a string.

The syntax is:

length(string)

For example:

let #num = length('Hello')

Understanding the lower function
This function converts a string to lower case letters.

The syntax is:

lower(string)

For example:

let $tvar = lower($t_name)

Understanding the ltrim Function
This function removes all contiguous matching characters of type char_type from the left side of a string 
variable. If char_type is not specified, the ltrim function uses the space character by default. Perceptive 
DataTransfer begins scanning the string from the left-most character and removes all matching 
characters until it encounters a character of a type other than char_type.
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The syntax is:

ltrim(string, char_type)

For example'

let $unpadded = ltrim('25 Main Street', ' ')

let $unpadded = ltrim('25 Main Street')

Understanding the mixed Function
This function converts a string to mixed case with the first characters typically being set to upper case.

The syntax is:

mixed(string)

For example

let $street = mixed('135 washington street')

let $street = mixed('135 WASHINGTON STREET')

Understanding the mixedlt Function
This function converts a string to mixed case, capitalizing the first character only.

The syntax is:

mixedlt(string)

For example:

let $street = mixedlt('135 vanarsdel street’)

let $street = mixedlt('135 O’HENRY STREET')
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Understanding the replace Function
This function replaces a string and takes three parameters.

• Source string

• Search string

• Replacement string

The code finds all occurrences of the search string within the source string and replaces them with the 
replacement string. For example:

let $lk-test = '12421 Main Street'

  let $lk-test = replace($lk-test, 'Street', 'St')

In the preceding example, the result returned by the replace function is '12421 Main St'.

Understanding the rtrim Function
This function removes all contiguous matching characters of type char_type from the right side of a string 
variable. If char_type is not specified, the rtrim function uses the space character by default. Perceptive 
DataTransfer begins scanning the string from the right-most character and removes all matching 
characters until it encounters a character of a type other than char_type.

The syntax is:

rtrim(string, char_type)

For example:

let $unpadded = rtrim('25 Main Street', ' ')

let $unpadded = rtrim('25 Main Street')

Understanding the substr Function
This function returns a portion of a string beginning at start_pos and extending char_len characters. If 
start_pos plus char_len is greater than the length of string, the extra characters are ignored.

The syntax is:

substr(string, start_pos, char_len)

For example:

let $short_var = substr('last first middle',6,12)
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Understanding the tonum Function
This function converts a string to a number.

The syntax is:

tonum(string)

For example:

let #num = tonum('123.45')

Understanding the tostring Function
This function converts a number to a string.

The syntax is:

tostring (number)

For example:

let $term = tostring(#year)

Understanding the trunc Function
This function returns a truncated version of a long date.

The syntax is:

trunc(date value)

For example:

let $new_date = trunc($sysdate)

Understanding the unstring Function
This function splits a string into two smaller strings depending on the occurrence of a separator 
character.

This syntax is:

unstring($string1, $delimiiter, $out1, $out2)

For example:

unstring 'John Smith' by ' ' into $fname and $lname
Perceptive DataTransfer Administrator Guide Page 281 of 301



Understanding the upper Function
This function converts a string to upper case letters.

The syntax is:

upper(string)

For example:

let $tvar = upper($t_name)

Understanding General Functions
General functions are a mixed collection of general purpose routines. Refer to the following topics for 
more information.

• Understanding the CopyFile Function on page 283

• Understanding the cnvdate Function on page 283.

• Understanding the DataProviderCall Function on page 284.

• Understanding the DataProviderPrompt Function on page 284.

• Understanding the do Function on page 285.

• Understanding the HobsonsUpdate Function on page 285.

• Understanding the ImageNowAddDoc Function on page 286.

• Understanding the ImageNowAddToFolder Function on page 288.

• Understanding the ImageNowAddToQueue Function on page 288.

• Understanding the ImageNowCreateFolder Function on page 288.

• Understanding the ImageNowGetFolder Function on page 288.

• Understanding the InsertBinary Function on page 289.

• Understanding the isnull Function on page 289.

• Understanding the logit Function on page 290.

• Understanding the lookup Function on page 290.

• Understanding the MoveFile Function on page 291.

• Understanding the NWAddDoc Function on page 291.

• Understanding the NwGetDoc Function on page 293.

• Understanding the NWWorkComplete Function on page 293.

• Understanding the PopulateTemplate Function on page 293.
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• Understanding the prompt function on page 294.

• Understanding the QASAddressCheck Function on page 294.

• Understanding the skip Function on page 296.

• Understanding the stop Function on page 296.

• Understanding the store Function on page 297.

• Understanding the toggle Function on page 297.

• Understanding the toggle_off Function on page 298.

• Understanding the toggle_on Function on page 298.

Understanding the CopyFile Function
This function copies a specified file from the source path to the destination path. It takes three 
parameters: the filename, the source path, and the destination path.

You can use wildcard characters in the filename parameter. If you use a wildcard, all files matching the 
specified criteria are moved.

Note  If you a copy a file that has the same filename as a file in the destination path, the existing file is 
overwritten.

For example:

CopyFile('temp.xml', 'c:/', 'c:/backup/')

Understanding the cnvdate Function
This function converts multiple long date values into a formatted date string. This function takes two 
parameters: the string to convert into a date and the format of the new date string. For the first parameter, 
the string must be in one of the following formats to be recognized as a valid date.

• dd-MMM-yy

• MM-dd-yy

• yyyy-MM-dd

• yyyy/MM/dd

• MMM dd yyyy

• dd-MMM-yyyy

• MM-dd-yyyy

• MM/dd/yyyy

The syntax is:

cnvdate(date value, 'format string')
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For example:

let $tmp_date = cnvdate($t_date, 'DD-MMM-YYYY')

Understanding the DataProviderCall Function
This function takes a single parameter, which is the name of the web service to run. Syntax is:

let $output_variable = 'input_value'

DataProviderCall('web_service') 

For example:

let $ws_id = '10'

DataProviderCall('personWS') 

Use this function to execute web services when you are using web service data providers. For more 
information, refer to Configuring Web Service Data Providers on page 157.

Understanding the DataProviderPrompt Function
This function takes two parameters: a prompt and the name of the web service. Syntax is:

$output_variable = 'input_value'

DataProviderPrompt 'string', 'web_service'

For example:

let $ws_id = ' '

let $ws_first_name = ' '

let $ws_last_name = ' '

DataProviderPrompt 'Choose the matching person.', 'personWS'

The command runs the specified web service the same as the DataProviderCall function. It also displays 
a prompt to users, who can select the result they want to view.

Use this function to execute web services when you are using web service data providers. For more 
information, refer to Configuring Web Service Data Providers on page 157.
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You can also set two optional parameters; both parameters are strings (for example, string literals, string 
expressions, string variables, and so on). Use a Y (or y) value to indicate that the option is enabled. The 
parameters are:

• The first parameter is a flag to hide the prompt if no results are returned by the data provider—if the 
request had no results, Perceptive DataTransfer does not prompt the user to select one. For example:

let $ws_id = ' '

let $ws_first_name = ' '

let $ws_last_name = ' '

DataProviderPrompt 'Choose the matching person.', 'personWS', 'Y'

• The second parameter is a flag to automatically select the result if exactly one result is returned by 
the data provider—if the data provider returns a single record, the record is auto-selected without the 
prompt being displayed. For example:

let $ws_id = ' '

let $ws_first_name = ' '

let $ws_last_name = ' '

DataProviderPrompt 'Choose the matching person.', 'personWS', 'Y', 'Y'

Understanding the do Function
This function executes a Perceptive DataTransfer procedure and optionally passes in one or more 
parameters.

The syntax is:

do procedure-name [arg1, arg2,… argN]

For example:

do check-dob

do lookup-name (#ssn, $last, $first)

Understanding the HobsonsUpdate Function
You can update Hobsons Connect CRM data using Hobsons Connect CRM web services. To do so, you 
create a connection group that contains a Hobsons Connect CRM connection, and then you can create a 
Hobsons Connect CRM header. You create a job that uses the Hobsons Connect CRM header and 
connection and can use the appropriate NQL logic that updates Hobsons Connect CRM data when the 
job is run. 
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This syntax, which is optional, is:

HobsonsUpdate(<web service name>, <contact id>, <attribute name 1>, <attribute value 
1>, <attribute name 2>, <attribute value 2>, ... , <attribute value n>)

The required parameters are:

• <web service name>: the name of the Hobsons web service (for example, UpdateContact).

• <contact id>: the ID value of the contact record to update.

The additional parameters are any number of attribute name or value pairs. Both components of the pair 
are strings; the first string identifies the name of the Hobsons Connect CRM attribute to update, and the 
second string is the new value for the specified attribute.

The HobsonsUpdate function returns a string. If the update is successful, an empty string is returned. If it 
is not successful, a corresponding error message is returned.

An example of the syntax is:

let $err = HobsonsUpdate('UpdateContact', $id, 'first_name', $fname, 'last_name', 
$lname, 'dob', $dob')

This syntax runs the UpdateContact web service on the contact with id $id and updates the first_name 
attribute to the value in $fname, the last_name attribute to the value in $lname, and so on.

Understanding the ImageNowAddDoc Function
To upload a file to ImageNow, use the following syntax:

ImageNowAddDoc($filepath, $document_name, $index_map)

• The first parameter is an absolute path to the document you want to upload. The filename of the file in 
the filepath parameter can contain one or more * (asterisk characters) as wildcards. If a file matches 
the pattern, it is used. If no file matches the pattern, or if multiple files match the pattern, the record is 
suspended. You cannot use the * as part of the directory name. 

• The second parameter is the name to provide to the document when it uploads. 

○ If this document name already exists in ImageNow, the function appends a number to the end 
until it finds a document name that does not exist. For example, if you try to name the document 
document, but document already exists, the function uses the name document(1). If document(1) 
also exists, the function uses the name document(2), and so on. 

○ You can supply an empty document name. The function uses other criteria to determine if there is 
a matching document with no name. If it finds a match, the function appends the file to the 
existing document as a new page to that document. If a matching document is not found, the 
function creates a new document whose document name is the document ID.
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• The third parameter is the name of an ImageNow index map (refer to Configuring ImageNow Index 
Maps on page 199 for more information). This object links all the necessary ImageNow document 
properties to program variables that can be used in the code. Perceptive DataTransfer then performs 
a lookup on the index map name to obtain all the mapping information necessary to upload the 
document. All ImageNow properties are replaced with the value in the corresponding program 
variable.

Any time the ImageNowAddDoc syntax is reached in the code, Perceptive DataTransfer obtains the 
Integration Server connection in the current connection group and uploads the document using 
ImageNow web service APIs. For more information about Integration Server connections, refer to Adding 
Integration Server Connections on page 86. 

It also updates the document properties, including the custom properties, specified in the selected 
ImageNow index map. For more information about configuring ImageNow index maps, refer to 
Configuring ImageNow Index Maps on page 199.

This function also returns the document ID created for the uploaded document.

You can also set two optional parameters to convert files to TIFF and to delete the original file.

The following example requests show how to set optional parameters:

ImageNowAddDoc('c:\temppdf\test2.pdf', $docname, $index_map, 'Y')

and

ImageNowAddDoc('c:\temppdf\test2.pdf', $docname, $index_map, 'Y', 'Y')

The first request contains the optional parameter to convert the file to a TIFF file before uploading. Use Y 
to convert the file to TIFF. Any other value, including an empty string, does not convert the file to a TIFF. 
In the first request, test2.pdf will be converted into a temp file called test2.tif. The temporary TIFF file will 
be uploaded into ImageNow and will be deleted when the upload is complete. The original test2.pdf file 
remains.

You can configure properties for converting TIFF to PDF in Administration > System Properties > PDF to 
TIFF; for more information, see Configuring PDF to TIFF Properties on page 29.

The second request contains the optional parameter to delete the original file. Use Y to delete the original 
file. Perceptive DataTransfer deletes files every minute. In the second request, because both optional 
parameters are set, test3.pdf will be converted into a TIFF, the TIFF will be uploaded to ImageNow, and 
then both the temporary TIFF file and the original test3.pdf file will be deleted. If the first optional flag is a 
value other than Y, the original test3.pdf will be uploaded to ImageNow and then deleted.

The TIFF file, if one is created, is temporary and is always deleted; however, whether the original file is 
deleted depends on the second optional parameter. 

Note  Instead of using Y, you can also pass in string expressions, including program variables; however, 
those values must be equivalent to Y to set the flag. 

Note  You can convert only PDF files to TIFF files. If the file you want to convert is in any other format, the 
file is not uploaded, and an error message appears.
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Understanding the ImageNowAddToFolder Function
This function moves an existing ImageNow document into a specified ImageNow folder. It takes the 
ImageNow document ID and ImageNow folder name. This function requires a properly configured 
ImageNow integration server connection in the connection group you are using. The syntax is:

ImageNowAddToFolder($imagenow_docid, $imagenow_foldername)

Parameters are:

• $imageNow_docid: Document ID of the ImageNow document you are moving.

• $imagenow_foldername: Name of the ImageNow folder into which you are moving the document.

Understanding the ImageNowAddToQueue Function
This function adds an ImageNow document to an ImageNow workflow queue. The syntax is:

ImageNowAddToQueue($docid, $queueName)

The first parameter is the string that identifies the ImageNow document ID.

The second parameter is the string identifying the ImageNow queue name.

When the code reaches this function, the Integration Server connection in the current connection group is 
used to execute an ImageNow web service to move the document into the queue.

Understanding the ImageNowCreateFolder Function
This function creates a new folder in ImageNow. It takes a folder name, drawer name, and folder type. 
This function requires a properly configured ImageNow integration server connection for the connection 
group you are using. The syntax is:

ImageNowCreateFolder($foldername, $drawername, $foldertype)

Parameters are:

• $foldername: Name of the ImageNow folder you are creating.

• $drawername: Name of the ImageNow drawer into which the folder is added.

• $foldertype: Type of folder.

Understanding the ImageNowGetFolder Function
This function returns the ImageNow ID for a specified folder. It takes the folder name and searches 
ImageNow for the folder. If a match is found, the function returns the ID of the folder. If a match is not 
found, an empty string is returned. This function requires a properly configured ImageNow integration 
server connection for the connection group you are using. 
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The syntax is:

let $folderid = ImageNowGetFolder($foldername)

The $foldername parameter is the name of the ImageNow folder.

Understanding the InsertBinary Function
Use the InsertBinary function to insert a binary file directly into the database. The syntax is:

InsertBinary($filepath, $query)

Parameters are:

• Filepath: Absolute path to the file to insert into the database.

• Query: SQL query to execute that inserts or updates the record with the binary file. The query must 
contain a question mark ( ? ) for which the binary file is substituted

For example: 

InsertBinary('c:/temp/file.pdf', 'INSERT INTO file_table (id, binary_file) VALUES (1, 
?)')

The absolute path to the file is c:/temp/file.pdf; the query also contains a ? symbol. Perceptive 
DataTransferwill execute the query and replace the ? with the binary contents of the file, which inserts the 
file directly into the database. You can also use a SQL UPDATE statement, instead of an INSERT 
statement, to add the file to an existing database record. 

Understanding the isnull Function
This function returns TRUE if the variable contains no valid data (NULL); otherwise, it returns FALSE. It 
also returns TRUE if the string variable being queried is either null or is the empty string.

The syntax is:

isnull(variable)

For example:

if isnull($city)

let $valid = isnull($dob) 
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Understanding the logit Function
This function defines a custom logging type that will produce the logit type entries in the Log View dialog 
box.

When Perceptive DataTransfer is set up, custom logging or text may be written to the log file; this text 
does not cause a record to suspend but writes a comment to the log file.

The syntax is:

logit 'Custom log message'

For example:

logit 'No match on high school code'

logit 'Generated ID: '||$id

Understanding the lookup Function
This function substitutes an output value for an input value and stores it in a program variable. Lookup 
values are defined in the lookup tool (refer to Configuring Lookup Values on page 30 for more 
information).

The syntax is:

Let out_variable = lookup(in_variable, field)

The $out_variable gets set to the output value from the lookup tool. The field name is passed to the 
lookup() function, either through a single-quoted $Field name or custom text that you define, along with 
the in_variable. 

For example, for the following fields defined in the lookup tool.

• Field: ActivityCustomMapping

• In: TestInput

• Out: TestOutput

Use the following function.

let $tmp_var = lookup('TestInput','ActivityCustomMapping')

$tmp_var is set to 'TestOutput'.
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For example, for the following fields defined in the lookup tool.

• Field: $ACTIVITY

• In: TestInput

• Out: TestOutput

Use:

let $tmp_var = lookup('TestInput','$ACTIVITY')

$tmp_var is set to 'TestOutput'.

Note  You do not need to use a variable name; you can use other parameters, such as activity codes or a 
custom name. 

Note  You define input and output variables only one time through the lookup tool.

Understanding the MoveFile Function
This function moves a specified file from the source path to the destination path. It takes three 
parameters: the filename, the source path, and the destination path.

You can use wildcard characters in the filename parameter. If you use a wildcard, all files matching the 
specified criteria are moved.

Note  If you a move a file that has the same filename as a file in the destination path, the existing file is 
overwritten.

For example:

MoveFile('temp.xml', 'c:/', 'c:/backup/')

Understanding the NWAddDoc Function
This function passes documents from Nolij Web into Perceptive DataTransfer. After Perceptive 
DataTransfer creates a new or match record for the document, the document is sent to Nolij Web using 
this Nolij Web API command.

It uses the following parameters.

• #docCode: wfdt code, determined by the filename extension by Nolij Web. This value can be null.

• $srcPath: Directory on the server in which this file is located. 

• $fileName: Filename of the file. It can contain one or more * (asterisk characters) as wildcards. If a file 
matches the pattern, it is used. If no file matches the pattern, or if multiple files match the pattern, the 
record is suspended.

• $folderID: Folder ID. String or numeric variables can be values.
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• $subfolderID: not yet supported by Nolij Web API. String or numeric variable is accepted. 

• #usercode: Nolij Web usercode for the authentication username stored for the Nolij Web connection. 
The value can be null. If null is passed, the API uses the default usercode for the authenticated user 
name. 

You cannot use the Nolij Web superuser account with this function. When you configure the Nolij 
Web connection, you must use an account that has one or more roles assigned. Any user code you 
use with this function must be for a role owned by the account used in creating the Nolij Web 
connection. 

The syntax is:

NWAddDoc(#docCode, $srcPath, $fileName, $folderID, $subfolderID, #usercode)

You can also set two optional parameters to convert files to TIFF and to delete the original file.

For example:

nwadddoc(0, 'c:\temppdf\', 'test2.pdf', '325', '', 33, 'Y')

and

nwadddoc(0, 'c:\temppdf\', 'test3.pdf', '325', '', 44, 'Y', 'Y')

The first request contains the optional parameter to convert the file to a TIFF file before uploading. Use Y 
to convert the file to TIFF. Any other value, including an empty string, does not convert the file to a TIFF. 
In the first request, test2.pdf will be converted into a temp file called test2.tif. The temporary TIFF file will 
be uploaded into Nolij Web and will be deleted when the upload is complete. The original test2.pdf file will 
remain.

You can configure properties for converting TIFF to PDF in Administration > System Properties > PDF to 
TIFF; for more information, see Configuring PDF to TIFF Properties on page 29.

The second request contains the optional parameter to delete the original file. Use Y to delete the original 
file. Perceptive DataTransfer deletes files every minute. In the second request, because both optional 
parameters are set, test3.pdf will be converted into a TIFF, the TIFF will be uploaded to Nolij Web, and 
then both the temporary TIFF file and the original test3.pdf file will be deleted. If the first optional flag is a 
value other than Y, the original test3.pdf will be uploaded to Nolij Web and then deleted.

The TIFF file, if one is created, is temporary and is always deleted; however, whether the original file is 
deleted depends on the second optional parameter. 

Note  Instead of using Y, you can also pass in string expressions, including program variables; however, 
those values must be equivalent to Y to set the flag. 

Note  You can convert only PDF files to TIFF files. If the file you want to convert is in any other format, the 
file is not uploaded, and an error message appears.
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Understanding the NwGetDoc Function
This function downloads a specified document from Nolij Web and stores the document in a temporary 
space on the Perceptive DataTransfer server. It returns the string path to the temporary file, which the 
user can use to reference and use the downloaded file. This function requires a properly configured Nolij 
Web connection in the connection group you are using. The syntax is:

let $filepath = NwGetDoc(#docid, $folderid, #usercode)

Parameters are:

• #docid: Numeric document ID in Nolij Web.

• $folderid: Nolij Web folder ID for the document.

• #usercode: User code of the Nolij Web user who is attempting to download the document. The 
#usercode parameter must correspond to the user configured for the Nolij Web connection in the 
connection group you are using.

Understanding the NWWorkComplete Function
This function starts the Nolij Web workflow process and routes folders to the appropriate inboxes. This 
function takes four parameters:

• Nolij Web workflow code: a string parameter that contains the Nolij Web wfma code.

• Folder Id: a string parameter that contains the Nolij Web folder ID.

• Folder name: a string parameter that contains the folder name as it appears in Nolij Web.

• User code: a numeric code parameter that contains the Nolij Web user code with which to run the 
Work Complete action.

For example:

NWWorkComplete('289', '1464', 'Adams, Nicole', 44)

In the preceding example, 289 is the wfma code, 1464 is the folder ID for Nicole Adams, 'Adams, Nicole' 
is how the folder is named in Nolij Web, and 44 is the Nolij Web user code with which to run the Work 
Complete action.

Understanding the PopulateTemplate Function
Use the PopulateTemplate function with document templates. When you create a new document 
template that references program variables in its text, the PopulateTemplate function applies the values 
of the variables to the template and creates a new text file. 

For example:

let $filepath = PopulateTemplate($template_name)
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In this example, the PopulateTemplate function looks up the document template by the specified 
template name parameter, replaces all program variables in the template with their values, and then 
creates a new text file in a temporary location. The PopulateTemplate function returns the file path of the 
new text file. The format of the text file depends on the document type specified for the document 
template (for example, a TXT type creates a .txt file, and XML type creates an .xml file, and so on). You 
could then use the ImageNowAddDoc or NWAddDoc function to upload the created text file. 

You can use two optional parameters—file source name and filename—with the PopulateTemplate 
function. You can use these parameters to specify where to place the file after running the 
PopulateTemplate function. If you provide a file source name and filename, the function retrieves the 
configured file source for the workspace version and creates the file in the path of the file source; the file 
created is named with the value supplied in the filename parameter. 

If you supply a file source name, you must also supply the filename.

For example:

let $filepath = PopulateTemplate('XML for Auto Import', 'ServerPath', 'temp.xml')

Understanding the prompt function
This function displays a string of message text to the user and allows users to update values for displayed 
variables. You define the prompt text to display, and you define the program variables that the user can 
update. You also define the label that is displayed for the variable; this label is displayed to the user 
instead of the actual variable name.

When a job is run in interactive mode, and this line of code is reached, job processing is paused, and the 
Prompt dialog box appears. The dialog box displays the prompt message and the labels for the variables 
you defined; it also displays the corresponding values for the variables. The user can modify the value of 
the variables.

The syntax is:

prompt string, variable1, label1, variable2, label2...variableN, labelN 

For example:

prompt 'Address is not valid. Please adjust accordingly.', $fstreet1_1, 'Street 1', 
$fstreet1_2, 'Street 2', $f_city_1, 'City', $f_st_1, 'State', $f_phone_1, 'Phone'

Understanding the QASAddressCheck Function
When you configure a job to use a connection group with a QAS connection and a QAS header, you can 
also configure the logic, used by the job configured to use the QAS header and connection, to use the 
appropriate NQL syntax:

let $result = QASAddressCheck('country_code', $qas_f1, $qas_f2, $qas_f3, $qas_f4, 
$qas_f5, 'address_1', 'address_2', 'state', 'zip' 'string6', ...'stringN')
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Use this syntax to verify addresses through a web service call. The function takes the following 
parameters,.

• Country code: This parameter can be passed in as either a string literal or a program variable. 
Supported codes are USA and CAN.

• Parameters two through six: These parameters are program variables that are populated with the 
refined fields of the address. These parameters are output variables; the QASAddressCheck function 
accepts any number of input variables; however, the function always returns five outputs. For 
example:

○ The corrected street address is obtained for $qas_f1.

○ The corrected second street address (for example, an apartment number) is obtained for $qas_f2.

○ The corrected city is obtained for $qas_f3.

○ The corrected state code is obtained for $qas_f4.

○ The corrected nine-digit zip code is obtained for $qas_f5.

• Parameters 7 and on: These parameters are any number of address fields represented by any string 
expression (for example, string literals, string variables, concatenated strings, and so on.) The 
QASAddressCheck function will accept as few or as many address fields as needed. The QAS web 
service will accept any number of inputs and find and refine the matching address.

The QASAddressCheck function returns a string match code generated by QAS. This match code must 
be parsed so that you can determine the success or failure of the search and the accuracy of the returned 
address. 

For example:

let $result = QASAddressCheck('USA', $qas_f1, $qas_f2, $qas_f3, $qas_f4, $qas_f5, '1600 
Pennsylvania Ave', 'Washington', 'DC', '20500')

This example returns the following results.

• $qas_f1: 1600 Pennsylvania Ave NW

• $qas_f2

• $qas_f3: Washington

• $qas_f4: DC

• $qas_f5: 20500-0003

• $result: R53300020000f00080000

The QASAddressCheck function is frequently used with the PROMPT function. For example, the code 
may perform an address check, and if the results are insufficient (or nonexistent), the code might then use 
a PROMPT command to request that the user correct the address. A loop could be used to require the 
user to keep adjusting the address until a suitable match can be found. For more information about the 
PROMPT command, refer to Understanding the prompt function on page 294.
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Understanding the skip Function
This function skips all other processing and updates the status on the record. The first parameter is the 
status to use: NEW, MATCH, SUSPEND, or LOCK.

The syntax within matching routines is:

skip [NEW/MATCH/SUSPEND], 'Reason for new/match/suspend'

For example:

skip SUSPEND, 'Invalid birth date'

The syntax within procedure code is:

skip [SUSPEND/LOCK], 'Reason for suspend/lock'

The skip LOCK function locks the record, highlights it in a fuchsia color, and changes the status of the 
record to Locked.

The SKIP NEW and SKIP MATCH commands, using additional second parameters, can be used in code 
for jobs run in interactive mode to identify the rank value for a record; the rank indicates the stage of 
matching during which the record was set as Match or New. The rank value appears in the Rank column 
in the window that appears when you open or edit jobs. For more information, see Understanding Record 
Rank on page 251.

Understanding the stop Function
This function causes program execution to pause and the Perceptive DataTransfer window to switch into 
review mode for any records previously collected using the store command.

The syntax is:

stop

For example:

<statement-list>

store 1, '#uid'

stop
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Understanding the store Function
This function causes the matching set of unique IDs for the current record, in addition to a number 
indicating the relative matching step, to be stored internally for subsequent display and review by an 
operator.

The syntax is:

store step#, uid_var

For example:

<statement-list>

store 1, '#uid'

In addition, the STORE command in code for jobs run in interactive mode is used to identify the rank 
value for a record; the rank indicates the stage of matching during which the record was set as Match or 
New. The rank value appears in the Rank column in the window that appears when you open or edit jobs. 
For more information, see Understanding Record Rank on page 251.

Understanding the toggle Function
This function returns the state of a form field set toggle associated with the variable being passed in.

All variables linked to form objects are associated with a field set, which may have a visible form toggle. A 
form toggle is an interactive checkbox indicating whether a group of fields will be included in the data 
upload process. 

Passing any variable linked to a form group into the toggle function returns the state of the toggle button 
for that field set as either TRUE (data in this field set will be included in the upload) or FALSE (data in this 
field set will not be included in the upload). 

Toggle checkboxes can be manually overridden to force certain data to be loaded or cause certain data 
to be skipped.

The syntax is:

toggle(variable)

For example:

if toggle($suffix)
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Understanding the toggle_off Function
This function causes the form field set toggle associated with a linked form variable to be turned off (set 
to FALSE).

The syntax is:

toggle_off(variable)

For example:

toggle_off($last)

Understanding the toggle_on Function
This function causes the form field set toggle associated with a linked form variable to be turned on (set 
to TRUE).

The syntax is:

toggle_on(variable)

For example:

toggle_on($last)
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